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Introduction
FrameMaker 9 delivered a completely new interface according 
to the CS (Creative Suite) products. This is of course also 
present in FrameMaker vv.

While at the first view this looks nice and brings a number of 
good functions to the Frame user, it also has its drawbacks.

Gray interface is not a good
idea either

Orientation on a large screen is not that easy with all items of 
the same none-colour. This slows down work:

The new buttons are grey in normal state, dark grey/black in 
active state and somewhat coloured if hovered over. Toggled 
buttons get a button-border. 

For comparison, see here the crisp buttons from FM-8:

Productive functions missing
from the interface

Since FrameMaker 6 Shlomo Perets provided additional func-
tions both in the menus and on a special tool bar. Many peo-
ple boost their productivity with these functions.

The Enhanced Tool Bar provides equivalent features.

Online documentation Some online documents are no more delivered with 
FrameMaker, although they are still valid (albeit being in the 
state of FM-9 and below).

Workspaces Workspaces is one of the great features of the new UI. How-
ever, for limited space on a laptop screen some alternative 
arrangements for the tool bar buttons may be helpful. There 
is, for example, no need of buttons for standard functions 
like Save or Print (these functions can be invoked with well 
known short cuts).

Vertical tool bar Access to the Vertical Tool Bar has been abandoned by Adobe 
with the new UI. However, the file is still there and can be 
used. It is even more useful with a modified design. The nice 
thing of this tool bar is that it often fits onto the margin area 
of documents thus reducing mouse miles.

Equations palette Since years the equations palette has not been enhanced in its 
presentation. On large screens with high resolution the but-
ton labels are not very legible. The Enhanced Tool Bar also 
offers an enlarged and more crisp Equations Palette.

Caveat With FM-11 Adobe introduced the concept of views on the 
document (Author view, WYSIWYG view and XML view). ETB is 
active only in the WYSIWYG view. For greatest compatibility it 
uses an own set of work spaces and menus.
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Feature overview
Note: FM-11: ETB is active only in the WYSIWYG view. For greatest 

compatibility it uses an own set of work spaces and menus.

Vis a vis the original FrameMaker installation the following 
features are installed/replaced

 Many menu items now show keyboard short cuts.

 Reasonable menu items are added, especially to context 
menus.

 Standard tool bars now show colour per default. See Stand-
ard tool bars on page 16.

 For the additional/modified tool bars see ETB tool bars on 
page 16.

 The Vertical Tool Bar is back again. It is modified to use 2 
rather than 4 levels. The top elements have been changed 
to items normally not invoked by keyboard (see Vertical tool 
bar on page 18).

 Additional work spaces are defined. See Predefined work 
spaces on page 19.

 Menu Insert Special Character got a host of additional 
symbols. See Text context menu on page 14.

 Documentation and other features of the Enhanced Tool 
Bars (ETB) for FM-9 to FM-11 are available with menu Help 
> Enhanced Tool Bar.

 Some documents from older FM versions are available in 
the menu Enhanced Toolbar > FM Online Manuals. These 
documents are still useful.

 Completely new documents are FrameMaker Commands 
and Customising FrameMaker.

 Offline Help (PDF) is also provided in this menu

 In Printing View no rulers are displayed. These remain not 
displayed when switching to Edit View.

 Clip art added: Scales and grids for diagrams.

 The maker.ini files both from the user area and from $HOME 
can be handled with the standard text editor.

 Console file from the User Area can be opened in standard 
text editor.

 The small utility TextHelper allows special paste opera-
tions from any application (see TextHelper on page 22).

 Optionally you may get coloured cursors and TAB indica-
tors as well as a modified dialogue for Insert Table. See 
Optional UI modifications on page 21.

Revisions 4.0.Installation and contents harmonised with the version for 
FM-12.
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Installation
See also www.daube.ch.

Note: ETB is installed for the current user.

Administrator rights Data is stored in the FrameMaker installation folder and also 
in the user’s area. Nevertheless in a company environment – 
where only an IT-person may install programs – the installa-
tion program must run with admin rights!

Updating ETB If you have ETB already installed (and want to update it), start 
the Installation program from the Start Menu and use 
Remove ETB. Then install the new version of ETB.

Installation steps 1 Please get familiar with this documentation

2 Close FrameMaker, if necessary.

3 Download Inst-FMvv-toolbars-en.zip from www.daube.ch

4 Expand the downloaded ZIP to any location (for example to 
the desktop). This will store one file PrepInstall-etb-
en.exe and a directory InstallETB.

5 Execute the file PrepInstall-etb-en.exe:

6 The panel tells You what will happen if You use Continue 
install. The preparation is necessary to avoid bothering the 
user with very Windows-specific stuff …

7 You may get an error message (see Access restriction on 
page 7). It’s just information: read it and click OK.

8 You may also get an error message (see Copy fails on 
page 7). Just click OK and repeat step 6.

9 Continue install. starts the real installation program. The 
Preparation program will close after short time.

http://www.daube.ch/docu/fmaker55.html
http://www.daube.ch/docu/fmaker55.html#installation
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10If you want to get the coloured cursors, activate the check 
box (see Modified cursors on page 16).

11- Either use Change GUI-colour if you only want coloured 
buttons, but not the ETB functionality

-Or use Install ETB to install the ETB functionality.

12After a short time a message box indicates successful 
installation.

Note: The original tool bars and work spaces (in the FM installation 
directories) are not touched. 

Start TextHelper 
automatically

You find a short cut to the utiity TextHelper on page 22 in the 
start menu. You may wish to lcopy/move this short cut to the 
AutoStart folder.

Get the grey FM-UI To get the original FM user interface with it’s grey buttons, 
start the ETB installation program from the short cut in the 
start menu and use button Change GUI colours. Then use the 
standard work spaces.

Note: This does not de-install ETB. The special work spaces and 
menus are still there. To completely remove ETB from your sys-
tem, see Remove ETB from your system on page 6.

What’s installed?

Note: $HOME is the installation directory of FrameMaker.

 A short cut is placed in the Start Menu (All Users): 
(De)Installation FMvv-Toolbars en. This short cut can be 
moved to any convenient place.

 Before files are distributed, original files are renamed to 
xxx.ori to be able to restore them. Files are distributed to:

- Configuration files, documents and helper programs to 
$HOME\fminit\configui

- Additional clip art to $HOME\clipart
- The modified vertical tool bar to $HOME\fminit\configui
- The enlarged Equation palette to $HOME\fminit
- ETB work spaces, tool bars, menu and icon files are cop-

ied to the user area (…\vv\Workspaces)

- coloured cursors and modified dialogues are installed 
by replacing fminit\fmres.dll and …\fmdlg.dll.

 maker.ini in the user area get information in section Frame: 
ETBVersion and ETBColour. 

Help, the ETB is not visible!

After installing ETB you start FM and open a document. The 
ETB toolbars do not show up and the menus are not changed. 
For example, there is no Help > Enhanced Toolbars item. 
As a user writes: «All of the files installed where they were 
supposed to install. But for some reason the toolbars are not 
being called by the FM12 loading process …»
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Solution Select one of the ETB workspaces in the drop down list top 
right. It will take some time to establish the workspace. The 
ETB features should now appear.

Background The last used workspace is kept in maker.ini – and this is of 
course not an ETB-workspace as long as ETB is not installed.

How to add ETB toolbars to custom workspaces

If you have set up your own workspaces you may want to use 
therein ETB features, such as a special tool bar. You may wish 
to create a screen shot of your private WS to know what you 
have defined there.

To use ETB toolbars and menu addenda do this1):

 You start with one of the ETB-workspaces and save it with 
your name (prevent the original WS from changes).

 Change the workspace to your desire and save it again.

Note: FM-11: This method does not support the special menu set-ups 
for Review, AuthorView o CodeView.

Remove ETB from your system

To remove the ETB files from the FrameMaker installation:

 Start the installation program with the short cut in the 
Start Menu and then click on Remove ETB.

 Files of the Enhanced Tool Bars (ETB) for FM-9 to FM-11 are 
removed from the FM installation (configuration files, clip 
art and additional documentation, enhanced vertical tool-
bar).

Completely remove ETB Since this is not a standard Windows de-installation you may 
wish to remove the installation directory %appdata%\D+DD. and 
the short cut in the Start Menu to get rid of all things.

However, leaving short cut and installation directory intact 
allows you install the Enhanced Tool Bars (ETB) for FM-9 to 
FM-11 again.

What’s about FM updates?

The Enhanced Tool Bar was tested with the latest version of 
FM (FM 9.0.4.255, FM 10.0.3.419, FM 11.0.2.384). 

1 When updating or re-installing FM-vv, keep the preferences.

2 Uninstall ETB before you update FM (use button Remove 
ETB of the installation program) – The FM updating process 
may not work with installed ETB.

3 Update FM.

4 Install ETB again.

1 Doing it he other way round (modifying the second line in a workspace 
file to use the ETB-menus and tool bars is also possible for FM-11 only, 
but more troublesome.
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Possible error messages

Since version 4 of ETB the installation program tries to raise 
its privileges2) to avoid much of the restrictions. But this may 
fail in companies with IT installation procedure.

Access restriction MsgNoAccess1

Copy fails MsgNoAccess3:

Please follow the instructions on the message and click OK; 
then again try Continue Inst. 

FM version mismatch The following message appears, if you have checked the box 
for “Install coloured cursors” and FM is not patched up to the 
desired level.
:

8 Close FM; start the installation program and use Remove 
ETB, then install ETB again without checking the box.

File deletion fails If some files could not be copied automatically during instal-
lation (see Access to user area fails on page 8), then an analo-
gous message may be issued during de-installation:

2 The method is similar to “Run as Administrator” with the context menu.

Thee are old (depreciated) installation files for ETB in
C:\SystemMods\FM9-toolbars-en
- but they can not be deleted (probably access restric-
tions)

Please let Your adminstraor remove this directory

Prepare Installation Enhanced Toolbars

Copy from C:\Users\Klaus\Desktop to
C:\Users\Klaus\AppData\Roaming\D+DD\FM9-toolbars-de 
failed

Please delete C:\Users\Klaus\AppData\Roaming\D+DD manu-

Prepare Installation Enhanced Toolbars

The resources version number does not match the FrameMaker 
version number

Error
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MsgATTRIBfailure2

8 Manually delete these files, for example with the file 
explorer at %APPDATA%\Adobe\FrameMaker\vv\toolbars.

Access to user area fails The Windows User Access control is (at least to me) a mys-
tery. I do not understand most circumstances leading to an 
error or even failing installation.

Especially in companies where only an IT admin may install 
programs, the access to the user area may fail even by start-
ing Install-FMvv-etb.exe wit admin rights and with the entry 
of a password. In this case only a manual copy will help.

Symptoms for this situation:  Menu Help > Enhanced Toolbar exists3).

 In menu View > Toolbars all ETB-xxx tool bars are missing

Precondition for manual copy Do not uninstall ETB with the installation program now!

Assure the existence of following files in the installation 
directory (%appdata%\D+DD\FMvv-toolbars-en):

FM 9 … 11 ...\ETB\customui.cfg

FM 11 ...\WorkSpaces\UnStructured\WYSIWYGView\menus\etb-menus.cfg

Copy manually The various FM versions have different file structures.

Deleting files of the Enhanced Toolbar failed.

It is not possible to delete 8 files in the directory
C:\Users\Klaus\AppData\Roam-
ing\Adobe\FrameMaker\9\toolbars\ zu .
The Read-Only attribute can not be removed.
Deinstallation continues for the other files.

The left files do not harm Your system, but You may wish
to remove them manually with the File Explorer at

(De)Installation Enhanced Toolbar for FM-9 en

3 If this is not the case, you need to contact the author for help. You will 
receive a detailed list, where to place which file. Your FM-version is need-
ed for this.

From %appdata%\D+DD\FMvv-toolbars-en To %appdata%\adobe\framemaker\vv\ 

\ETB There was no problem to copy stuff to 
$HOME\fminit and subdirectories.

\Icons\*.* \
\Toolbars\*.* FM-9: \toolbars

FM-10: \toolbars
FM-11 handled via work spaces

\WorkSpaces\*.* FM-9: \WorkSpaces
FM-10 \WorkSpaces
FM-11 \WorkSpaces
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Windows annoyances

Program is not installed 
correctly

After installing in Windows 7 you may get the following mes-
sage or the two programs:

8 Just ignore it with Cancel. You may set the compatibility 
flag for the program to avoid the message in the future.

User Access Control None of the D+DD programs is certified by Microsoft. Hence a 
standard Windows installation issues messages concerning 
danger by executing one of these programs.4)

4 Dov Isaaks of Adobe recommends to set UAC to a lower level or switch it 
off at all (lists.frameusers.com).

http://lists.frameusers.com/pipermail/framers/2011-January/022087.html
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ETB menus
For many menu items short cut labels have been added. Also 
new menu items have been introduced. 

The modifications to the menus are highlighted in yellow.

Standard menus

File menu Document, book

Edit menu Document, book
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Format menu No changes

View menu Document, book

Special menu

Graphic menu No changes
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Table menu

Help menu
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Context menus

Document context menu

Book context menu
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Text context menu

Anchored Frame context 
menu
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Table context menu

Graphics context menu
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Tool bars

Standard tool bars

ETB chnges the colours in the existing toolbars to be coloured 
in normal mode and grey when hovered over; for example:.

ETB tool bars

Quick Access WS etb_quick_ws.xml

Buttons for Open, Save, Cut, Copy and Paste have been left 
out, because ‘real users’ have the appropriate short cuts in 
their fingers. 

Note: Repeat repeats the last action in the command history. This 
may be any re-doable action.

Quick Access LT etb_quick_lt.xml

Only a minimum of standard functions has been kept.

Paragraph bar etb_para.xml
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Character bar etb_char.xml

Display functions etb_display.xml

Extra functions etb_extra.xml 

Tables etb_tables.xml

The standard table toolbar is extended with buttons in the 
shaded area.

Enlarged Equation palette

The Equation palette is enlarged by 125% and uses fonts for 
crisper button labels:
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Vertical tool bar

The vertical toolbar is very handy when placed in the margin 
area of facing pages - reducing mouse miles:

The vertical tool bar can be accessed by View > Show vertical 
Toolbar or by the icon ..

Note: Since this is a genuine FrameMaker palette, tool tips are not 
available. You may look up the horizontal tool bars.

Import file

Editing View

Pint View

Goback

Copy ¶ format

Repeat ¶ action

Text normal

Bold

Italic

Unterline

Increase font size

Decrease font size

Lower case

Initial caps

Upper case

Search/Replace

Spell checking

Anchored frame

Footnote

Table

Import formats

Show body pages

Show master pages

Show reference pages

Copy character format

Repeat character action

Switch 

Select table row

Select table column

Select body cells in column

Select table

Select first cell in table

Delete rows/columns

Add rows below

Add columns at right

Align top

Align middle

Align bottom

Straddle/unstraddle cells

Shrinkwrap column width

Custom ruling/shading

Switch

Ungroup

Bring to front

Distribute

Smooth

Flip up/down

Scale

Snap

Move up 1 pt *

Move left 1 pt *

Align top

Align hor. centre

Align bottom

Rotate clockwise

Make line solid

Group

Send to back

Reshape

Unsmooth

Flip right/left

Object properties

Gravity snap

Move down 1 pt *

Move right 1 pt *

Align left

Align vertical centre

Align right

Rotate counterclockwise

Make line dashed

* at zoom 100% the movement is 1 pt
at zoom 253% the movement is 0.1 mm
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Predefined work spaces
I have set up two new work spaces:

 ETB_WS for work stations with at least 1820 pixels screen 
width

 ETB_LT for laptops with at least 1400 pixels screen width

ETB-WS

 The pods to the right show icons and names. Graphics 
tools are arranged below the pods.

 First row of toolbars contains

- etb_quick_ws.xml
- etb_para.xml
- etb_char.xml
- etb_extra.xml
- etb-display.xml

 Second row of toolbars contain 

- trackchanges.xml
- align_object.xml
- object_properties.xml. 

- etb_tables.xml
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ETB-LT

Picture displayed with the same resolution as for ETB_WS.

 The pods to the right are minimized to the icons. Graphic 
tools are aligned to the left of the pods.

 First row of toolbars contains

- etb_quick_lt.xml
- etb_para.xml
- etb_char.xml
- etb_extra.xml

- etb_display.xml

 Second row of toolbars contains

- align_object.xml
- object_properties.xml
- etb_tables.xml
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Optional UI modifications
The following UI modifications are only installed, if you check 
the appropriate box in the installation dialogue.

Enhanced dialogues

Since years many dialogues have not been adapted to the 
requirements. ETB currently provides only a modification for 
the most annoying one. On my website you can see what 
could be done (if many of you request it).

In the pictures hereafter you see the original dialogue to the 
left, the modified to the right.

Insert Table

Coloured cursors and tab indicators

The FrameMaker internal cursors can be colourised to 
enhance their instant recognition. Also the small TAB indica-
tors (visible only if View > Borders is ON) can benefit from 
colour.

http://www.daube.ch/docu/fmaker54.html
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Additional utilities

TextHelper

This utility manifests itself by an icon in the system tray. 
Right clicking on it displays a context menu:

This utility establishes the following keyboard short cuts:

Windows+v Paste the clipboard contents without formatting information, 
that is, just plain text (including line breaks. This functions is 
handy to copy from other applications, including web pages, 
but also with FrameMaker.

Windows+space Remove sequences of spaces to one before pasting the text 
(without formatting information).

Windows+u Change \ to / before pasting the text (without formatting 
information).

Note: The following two functions work only correct if there exist 
only two document windows (most likely side by side). For 
example no book window must be open. Before invoking the 
function focus must be in one of the document windows.

Windows+y The currently active and then the other document window is 
scrolled down by one document-page5).

Windows+x The currently active and then the other document window is 
scrolled up by one document-page.

Note: If you have other useful functions in mind, please contact the 
author (ddd@daube.ch).

5 In the ETB the keys Page down and Page up advance the display a doc-
ument page, not a screen height.
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Shortcut overview
Shortcuts with function keys

Short cuts with Insert key    

Shortcuts with Control key

a

a. Light blue area: command works only on un-tabbed documents: Light yellow area: only for undocked panels. Light red areas: commands opens a dialogue/
panel. Not available in FM-9

F1 F2 F3 F4 F5 F6 F7 F8 F9 F10 F11 F12

Just the key Help Default 
paragraph 
format

Repeat last 
find

Repeat 
paragraph 
command

Repeat 
character 
command

Repeat last 
action from 
undo history

Select 
condition tag

Select 
character tag

Select 
paragraph tag

Repeat 
element 
command

Previous 
screen

Next 
screen

Shift + … File 
information

Go to previous 
view

Go to next 
view

Cascade 
windows

Tile windows Object 
properties

Conditional 
text

Change 
dialogue to As 
Is

Change 
dialogue to 
selection

Show context 
menu

Place 
paragraph at 
top of col.

Place 
paragraph 
anywhere

Ctrl + … Zoom 100% Zoom in Zoom out Close 
document

Show/hide 
conditional 
text

Switch 
between 
documents

Select area 
with same 
condition

Select area 
with same char 
format

Transpose 
characters

Select entire 
paragraph

Select 
sentence

Select line

ALT + … Change text to 
lower case

Change text to 
initial caps

Change text to 
upper case

Close dialogue 
box, Quit FM

Anchored 
frame

Update 
references

Copy 
conditional 
text settings

Copy character 
format

Copy 
paragraph 
format

Copy table 
column width

Insert cross 
reference

PDF set up

Insert, … Fit page in 
window

Make text 
unconditional

Move insertion 
point to next 
paragraph

Update 
paragraph tag

Show/hide 
graphics

Show/hide 
condition 
indicators

Deselect 
condition tag

Show a single 
condition

New paragraph 
tag

Spelling 
checker

Unwrap frame, 
put below pgf

Shrink frame, 
make in-line

Home End < 8 : > ! ?

Top cell in 
table

Bottom cell in 
table

Previous table 
cell

Next table cell Cell above Cell below ¡ inverted ! ¿ inverted ?

a b c d e f g h i j k l m

ª ord. fem. • bullet © copyright † dagger … ellipsis ƒ florin ß German ss æ ae ligature Æ AE ligature ‡ d. dagger œ oe ligature Œ OE ligature — m-dash

n o p q r s t u v w x y z

– n-dash º ord. masc. ¶ paragraph š s hacec ® registered § section ™ trademark μ my ¢ cent £ sterling × multiplay ¥ Yen ¤ currency

1 2 3 4 5 6 7 8 9 0 _ - . (period)

¼ quarter ½ half ¾ 3 quarters  ø oere Ø Oere ° degree ¯ macron - non break - · centred dot

% | / [ ] < > ~ " ' + :

‰ per 1000 ¦ broken vert. ⁄ fraction « » ‹ › ˜ tilde acc. " straight “ ' straight ‘ ± plus minus ÷ division

0 1 2 3 4 5 6 7 8 9

Select variable Insert elemen Wrap element Change 
element

Select In 
condition tag

Select Not In 
condition tag

Select Un-
conditional

Edit attribute Select 
character tag

Select 
paragraph tag
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Shortcuts and escape 
sequences

A complete list ordered by function area is available in ETB 
via Help > Enhanced Toolbar (ETB) > Online Manuals > 
FrameMaker Commands.

Little known short cuts CTRL+TAB switches between open documents, but also from 
a pod (e.g. Find) to the active document. Hence To replace 
manually:

1. CTRL+f
2. Write text to be found
3. ENTER
4. CTRL+TAB
5. Write text to replace the found one (highlighted).

Restrictions of the new interface
Some functions and features of Enhanced Tool Bars from FM-
8 and before could not be transferred to FM-9 and later.

The consequences of these restrictions are commented in 
customui.cfg. Affected commands are ‘out-commented’ by 
means of { } in place of < >.

Problem with special 
commands

Since FM-9 (the new user interface) there are issues with mul-
tiple code commands and hypertext commands.

 Multiple code commands (e.g. EditingDisplay) may not 
have a menu assigned, or the buttons and/or short cuts 
will not work. Only 2 of the 3 elements can be defined.

 For hypertext commands (e.g. the invocation of the vertical 
tool bar) there must not be a short cut defined (or the 
menu will not work).

Toggle commands Toggle commands are menu items which are switched by 
pressing Shift while selecting a menu item.

These commands do not allow menu modifications, such as 
re-ordering.

Application key The application key on Windows keyboards can be pressed to 
get the context menu. I have never used te tool bar short cuts 
wih his key – hence do not know whether they really worked 
at all.

Although a key sequence using the /Apps key6) is valid in 
customui.cfg nothing happens when such a sequence is keyed 
in. Hence these short cuts use the /Ins key.

6 Shlomo Perets’ Toolbar Customisations used this key and I wanted to be 
compatible.
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