
Enhanced Toolbar
for FM 7.2 and FM 8

Overview

The Enhanced Toolbar is based on the FrameMaker 
Express Customization from www.microtype.com. 
This package is precondition for the installation of 
the Enhanced Toolbar.

Note: This document describes both the FM 7.2 and FM 8 
version. Reference to FM 8 lets you assume the same 
for FM 7.2.

Enhanced Toolbar
provides

Modified QuickAccess Bar.

Extended Formatting Bar.

Extended menus and context menus.

Many useful keyboard short cuts.

Direct access to FrameMaker templates and clip 
art as well as online manuals and reference 
tables.

Access to FM configuration files.

Enhanced vertical tool bar.
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Installation
See also www.daube.ch.

The installation of the Enhanced Toolbar requires that the 
ToolbarPlus Express from MicroType (USD 25.-) has been pur-
chased. This is checked during installation.

Note: If multiple users (working with FrameMaker) are defined on 
your system you must start the installation with that user 
account, which was used to install FrameMaker. I call this the 
main user. Other users (accounts) working with FrameMaker 
must be added afterwards with Add user – or they loose the 
access to the tool bars.

1 Purchase the Toolbar Plus Express at Kagi Store . 

2 Download the Express Customization, but do not follow fur-
ther installation advice from the e-mail you got from Kagi/
MicroType!

3 Expand the downloded ZIP to any location (to be memo-
rised). This will only store one file FMTBPlusExp.zip. 

4 Close FrameMaker, if necessary. 

5 Download Inst‐FM8‐toolbars‐en.zip (resp. Inst‐FM72…) 
from www.daube.ch

6 Expand the downloaded ZIP to any location. This will only 
store one file Install‐FM8‐toolbars‐en.exe (resp. Install‐
FM72…)

7 Execute this self extracting archive, which expands its files 
to C:\SystemMods\FM8‐toolbars‐en\ (resp. 
C:\SystemMods\FM72…) and then starts the installation pro-
gram:

8 Fill in the location of the MicroType ZIP file from step 4 (or 
browse for its location).

9 The password for the Force option is only communicated 
to known people for special cases, because I do not want to 
sacrifice the work of Shlomo Perets for the Express Cus-
tomization.

10Install the files with Install first. A message box indicates 
successfull installation.

11Switch Windows to another account, which also uses 
FrameMaker. 

12Start the installation program again (with the short cut in 
the Start Menu) and establish the ETB with Add user. 

http://www.daube.ch/docu/fmaker57.html
http://www.daube.ch/docu/fmaker57.html#installation
http://store.kagi.com/cgi-bin/store.cgi?storeID=6FBWE_LIVE
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13Repeat steps 12+13 for all remaining user accounts work-
ing with FrameMaker. 

Note: If the Formatting Bar and the QuickAccess Bar can not be acti-
vated in a user account, then for this account the Enhanced 
Tool Bar has not yet been installed. See steps 12+13.

What’s installed?

Note: $HOME is the installation directory of FrameMaker.

Main user The main user is that user account which was used for the 
intallation of FrameMaker.

A short cut is placed in the Start Menu: (De)Insallation 
FM8‐Toolbars en (resp. (De)Insallation FM72…). This short cut 
can be moved to any convenient place.

The MicroType ZIP file is moved into the installation direc-
tory to save it.

The following files are distributed to appropriate places:

- Configuration files and documents to 
$HOME\fminit\configui

- Additional clip art to $HOME\clipart

- The modified vertical tool bar to $HOME\fminit

maker.ini gets information about the installation of the 
Enahnced Toolbar in section RegInfo: EnhToolBarVersion 
and EnhToolBarUsers.

Additional users The maker.ini file in the user area gets a new definition for 
the ToolBarIniFile. parameter.

In $HOME\maker.ini the new user is added to 
EnhToolBarUsers in section RegInfo.

Deinstallation

To get back to the original FrameMaker installation you must 
start the de-installation with the additional users. The main 
user must be the last one!

Note: You can not remove the Enhanced Toolbar for some users 
only.

Every user Start the installation program with the short cut in the 
Start Menu and then click on Reset FM-GUI to original.
Only the maker.ini files are modified.

Main user All files of the Enhanced Toolbar are removed from the FM 
installation (configuration files, clip art and additional doc-
umentation, enhanced vertical toolbar).

Complete removal of
Enhanced Toolbar

Since this is not a standard Windows de-installation you may 
wish to remove the installation directory and the short cut in 
the Start Menu to get rid of all things.

However, leaving short cut and installation directory intact 
allows you install the Enhanced Toolbar again.
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Additions/changes

Vis a vis the original FrameMaker installation

The switchable area of the QuickAcces Bar has been 
changed from 4 to 2 levels for text/table and graphic work.

Menu items Update All and New Format have been 
removed from the Paragraph Format drop-down menu, 
because they are now included in the menu opened by the 
new Paragraph Actions button .

The Symbols button  has been removed, because it pro-
vides only a limited set of symbols. The context-sensitive 
menus Insert Special Character offer a rich set.

Button Help  has been removed, it is redundant with F1 
and the Help menu.

The Enhanced Toolbar provides a number of additional 
menu items and context menus. See Additions to Frame-
Maker menus on page 10.

The Vertical Tool Bar now uses 2 rather than 4 levels 
which corresponds to the new QuickAccess Bar.

Unfortunately no Tool Tips are possible in this palette. 
Hence a description of the buttons is provided here (see 
Vertical tool bar on page 7).

Vis a vis the MicroType implementation

Spell-Scan & Print has been removed because spell check-
ing most time is a more complex task than assumed for 
this function.

Menu Insert Special Character got additional symbols: left 
single quote (‘ 6), right single quote (’ 9), left double quote 
(“ 66) and right double quote (” 99).

In the FM-8 version also some documents from FM 7.x are 
available in the menu Enhanced Toolbar > FM Online 
Manuals. These documents are still useful.

In Printing View no rulers are displayed. These remain not 
displayed when switching to Edit View.

Rather than use an additional menu for the documentation 
and other items these things are available at Help > 
Enhanced Toolbar. Of course the text in About Enhanced 
Toolbar has been modified.

The maker.ini files both from the user area and from $HOME 
can be displayed with the standard text editor.

The vertical toolbar was not available.
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Tool bars

QuickAccess Bar

The switchable area of the QuickAcces Bar has been changed 
from 4 to 2 levels for text/table and graphic work.

Formatting Bar

Compared to the standard Formatting Bar the MicroType 
extensions provide additional functions. The following table 
also contain some standard items indicated with a *.

Common part

Left part (text, table)

Right part (graphic editing, alignments)

Switch for the following

Icon Short cut Menu / Function Command a

Switch to the vertical tool bar ToolBarVertical

ALT+F6 Edit > Update References
(is also active in book window)

Update

Shift+BSP Edit > Clear
Alternative clipboard on page 8

Clear

CTRL+y YankKillBuffer

a. The command is used in fmtoolbr.ini. Also the tool tips are defined there.

Left part
Right part

Icon Short cut Menu / Function Command a

Formatting

Text alignment* !RulerAlignMenu

Line Spacing* !RulerSpaceMenu

Tabs on page 8 !RulerTabsMenu

Paragraph actions on page 8 !RulerPgfActionsMenu

Paragraph formats* !RulerPgfMenu

Character formats !RulerCharMenu

Current font* !RulerFontMenu
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Current font size* SizeMenu

 ALT+F9 Copy paragraph format
(paste with CTRL+v)

CopyPgfFormat

 ALT+F8 Copy character format
(paste with CTRL+v)

CopyCharFormat

 Alt+F7 Copy condition format
(paste with CTRL+v)

CopyCondTextSettings

 ALT+F10 Copy table column width
(paste with CTRL+v)

 CopyTableColumnWidth                        

 none Copy element attributes
(paste with CTRL+v))

CopyElemAttrs

 none File > Import > File ImportFile

Repeats

F4 Repeat last paragraph command RepeatLastParaCommand

F5 Repeat last character command CharacterRepeatLast

F3 Repeat last Find command
Edit > Find Next

FindNext

 F10 Repeat last element command RepeatElemCommand

Display

 ESC, q, q, e View > Edit View EditingView

 ESC, q, q, p View > Print View PrintingView

 Apps,F6 View > Hide Conditional Text Indicators ToggleCondUseFormat-
Override

Shift+F3 View > Zoom > Out ZoomOut

Shift+F2 View > Zoom > In ZoomIn

 Shift+F2 Jump back (after hyperjump) GotoPreviousView

 Shift+F3 Jump next
(in vew-only documents)

GotoNextView

 ESC,F,l,k Toggle view only / editable
(lock/unlock document)

Lock

ALT+Pg up First page GotoFirstPage

Pg up Previous page GotoPreviousPage

F11 Previous screen GotoPreviousScreen

F12 Next screen GotoNextScreen

Pg down Next page GotoNextPage

ALT+Pg down Last page GotoLastPage

a. The command is used in fmtoolbr.ini. Also the tool tips are defined there.

Icon Short cut Menu / Function Command a
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Vertical tool bar

The vertical tool bar is entered by the leftmost symbol in 
the QuickAccess Bar. The same symbol in the vertical 
toolbar (top right) switches back to the QuickAccess Bar.

Help

New

Save

Cut

Paste

Undo

Text normal

Bold

Italic

Unterline

Increase font size

Decrease font size

Lower case

Initial caps

Upper case

Search/Replace

Spell checking

Anchored frame

Footnote

Table

Leave vertical tool bar

Open

Print

Copy

Delete

Redo

Switch 

Select table row

Select table column

Slect body cells in column

Select table

Select first cell in table

Delete rows/columns

Add rows below

Add columns at right

Align top

Align middle

Align bottom

Straddle/unstraddle cells

Shrinkwrap column width

Custom ruling/shading

Switch

Ungroup

Bring to front

Distribute

Smooth

Flip up/down

Scale

Snap

Move up 1 pt *

Move left 1 pt *

Align top

Align hor. centre

Align bottom

Rotate clockwise

Make line solid

Group

Send to back

Reshape

Unsmooth

Flip right/left

Object properties

Gravity snap

Move down 1 pt *

Move right 1 pt *

Align left

Align vertical centre

Align right

Rotate counterclockwise

Make line dashed

* at zoom 100% the movement is 1 pt
at zoom 253% the movement is 0.1 mm
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Details for the tool bars

The following elements have been added to the Formatting 
Bar:

Paragraph actions

Tabs Tab buttons have been condensed into a single button that 
opens a list: 

Alternative clipboard Erase Text and Place in Buffer. The erase buffer 
functions as a second clipboard, enabling you to 
cut/paste additional text without affecting the Win-
dows clipboard.

Paste Text from Erase Buffer.
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Menus

Help menu Rather than use an additional menu for the documentation 
and other items these things are available at Help > 
Enhanced Toolbar.:

Note: However, with this method the menu Enhanced Toolbar is 
active only when the cursor is within a text frame.

Insert Special Character Opens a context menu with special characters. The list also 
provides the dialog box code, in case you want to insert a spe-
cial character in a FrameMaker dialog box. (see Context menu 
Text on page 10).

Function Key Chart
(PDF)

Opens MicroType’s chart of Function and Application/Insert 
key combinations. The first page can be seen also here: Func-
tion & App./Insert Key Combinations on page 13.

Special Characters
Chart (PDF

Opens MicroType’s chart of special characters. This interac-
tive chart shows characters in standard fonts, Symbol, Ding-
bats, Wingdings and Webdings and provides:

Character name

Standard FrameMaker shortcut

ANSI code

Hex value (this is very useful in dialogue boxes)

Microtype Shortcuts
(PDF)

Enables easy access to these MicroType shortcut charts:

FM/Windows Standard Shortcuts

FM Escape Shortcuts

Structured FM Escape Shortcuts

Templates, Samples &
Clip Art

Links to templates, samples & clip art files, provided with 
FrameMaker. Clip art for scales and diagrams has been added 
by D+DD.

Online Manuals (PDF) Enables direct access to standard FrameMaker online manuals 
and others which are only available with the Enhanced Tool-
bars. In the FM-8 version also some manuals from FM 7.x are 
present, because these are still useful.

Configuration Files Both maker.ini from the user area and from the $HOME direc-
tory are opened with the standard text editor.

Console Log File Opens FrameMaker’s console log file as a text file (even if the 
console read-only window was closed)

More Resources at
MicroType.com

Opens microtype.com with the default browser.
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Enhanced Toolbar
User Guide (PDF)

Presents this document.

About Enhanced
Toolbar

This identifys the Enhanced Toolbar version.

Additions to FrameMaker menus

Enhanced Toolbar adds various items to the menues and con-
text menus. These are indicated in the screen shots with .

Context menu Text

Context menu 
Anchored Frame

Context menus can be acces-
sed by:

Right mouse button

Shift+F10

Pressing the Application 
or Insert key twice.



11

Menus
E
:\

_D
D

D
p

ro
je

ct
s\

FM
-t

o
o

lb
a
r8

0
-e

n
\D

o
cu

m
e
n

ta
ti

o
n

\f
m

8
-e

tb
-e

n
.f

m
 

2
0

1
0

-0
1

-2
0

Context menu Table

Context menu Graphic

Context menu Document

Context menu Book

The document context 
meanu can be displayed by 
right-click in the margin 
area.
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Menu Edit

Menu View

Menu Table

Validate Hypertext is also 
added to the book’s Edit and 
Context menus, applicable to 
selected files in book.
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Function & App./Insert Key Combinations
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Function & App./Insert Key Combinations
Many useful commands and common special characters (in 
standard fonts) are easily accessible through Function or 
Applications/Insert key combinations, as described on this 
page.

The Applications key 
is available on modern 
keyboards to the richt 
of the space bar.
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