
Miscellaneous

Overview

Plain text can be imported an formatted according to some 
rules. In particular, it is possible to convert a TAB delimited 
text to a table.

Importing objects from other applications uses a filter mecha-
nism, which is still not fully reliable for Word documents and 
Excel tables. The reason might be the ever changing format of 
MS office data.

A section provides general information about FrameMaker 
and some internal mechanisms.
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Importing methods
FrameMaker offers various methods of importing text and graphics. The 
most reasonable method depend on various factors:

Method Applicable to

Import filter Graphics and plain text in distinct files

Copy / paste Text and graphics from Office applications; 

OLE Avoid this method

Import filters

With File > Import > File… FrameMaker activates import filters 
which are third party developments. Some file formats are well defined 
and stable (eps, tiff, txt), but most are proprietary and not well defined. 
Word for example is not compatible with itself … On the other hand func-
tions in one application can not easily mapped to functions in another 
application because of the different object model (e.g. frames in Word vs. 
frames in FrameMaker).

Another obstacle are naming conventions or user definitions. FrameMaker 
users are adept to the catalog concept and hence use (in most cases) con-
sistent naming for paragraph and character formats. The great majority of 
MS Word users are not aware of the capabilities of the product and hence 
use Word as a heavily overpowered typewriter.

Note: Importing from Word may34) leave CR characters (\x0D) and other illegal 
characters (e.g. \x01) in the file. These restrict an FM search to the para-
graph ending with CR. You can find them only by searching backwards 
from the end of the flow. Clean the file by saving as MIF, opening the MIF, 
saving as FM, 

Copy and paste

The paste buffer can contain various forms of a copied object depending 
on the nature of the object and the creating application. Using just copy 
fills the paste buffer with forms which are specific to the creating applica-
tion and the setup of which. When using paste the target application will 
take a default format or you specify which format to take by using paste 
special.

Using copy special (if available) fills the paste buffer with a specific 
form (for example an image in tiff format or text in rtf = Rich Text For-
mat). In this case a paste will place only this specific form.

34 This actually depends on the filter type and FM version.



C – 3

Object Linking and Embedding
D

O
:\

[E
]\

FM
-c

o
u

rs
e
\h

a
n

d
o

u
t\

m
is

ce
ll

e
n

a
o

u
s.

fm
 

2
0

0
9

-0
3

-0
2

FrameMaker default for 
paste

The FrameMaker default format for pasting is defined (on Windows) in 
the maker.ini file. For more easy working the changes according to Paste 
prefers text on page A-41 are recommended.

Paste special in 
FrameMaker

When pasting a graphic this might provide the formats bmp (Bit Map), dib 
(Device Independent Bitmap) or EMF (Enhanced Metafile). 

When pasting a textual object, this might provide emf, rtf (Rich Text For-
mat) or text (plain text).

Object Linking and Embedding

Object Linking and Embedding provides a link to the source application. 
What you see on the screen and will be printed in FrameMaker is an image 
of the application window.

Note: On the Macintosh (or UNIX) no such thing exists.

Depending on the source of the object (same computer, other machine) the 
image may be just a bitmap. When transferring objects between Windows 
machines, the object seems to bear a WMF (mixed vector and bitmap) 
image.

Warning When planning to use the document on various computers, for example, 
send to a print shop, avoid OLE at all. The receiver of the document both 
must have access to the file and the same applications installed - which is 
often not the case.

Insert an object Select the object in the source application (e.g. Excel) and copy it to 
the clipboard.

In FrameMaker paste it into an anchored frame (if you just paste it to 
the current cursor location, a default frame is created).

When double clicking on the object, the original object window 
appears on the FrameMaker screen and the menus and buttons are from 
the source application (Excel). The data can be edited now.

To close the application window click somewhere outside the object 
window. Do not use File > Save or File > Close, as this will close 
the FrameMaker document also.
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Importing methods in detail

Text in Source applications

Although the various filters which FrameMaker provide are of high stand-
ard, they can not be accurate. Hence it is best practice, to

1 Provide the author(s) a template using the same paragraph and charac-
ter styles as the final FrameMaker document.

2 Since most MS Office users are not familiar to templates even with 
education they will fall into old habits and use individual markup. 
Hence You will need to clean the document in the source application. A 
set of macros may help you especially for multiple input.

3 Remove special formatting such as Word frames and remove all graph-
ics. Break down large documents into manageable chunks.

4 Use this / these cleaned documents for import to FrameMaker.

Note: You will need to judge points 1) and 2) and decide to work completely on 
plain text which you format in FrameMaker.

Graphics in source applications

Graphics in source applications (e.g. MS Word) may be OLE objects, 
imported or copied external files or application specific graphics. Depend-
ing on the nature handle them differently:

OLE objects See Object Linking and Embedding on page 3.

Copied into the document A copied file has lost its relation to the source. You do not have a clue 
about the original size or resolution in case of a bitmap. 

1 In the source application copy the image

2 In FM use Edit > Paste Special and select the most appropriate for-
mat. If a a vector format is available (eps, wmf, emf), use this (with 
preference to eps)

Linked to the document To see whether a file is copied or linked, switch the Field view ON in the 
source application. A linked file is displayed as something like this:
{INCLUDEPICTURE "G:\\Graphics&images\\!temp\\test.wmf" 
\* MERGEFORMAT \d}

Copy the referenced file (G:\Graphics&images\!temp\test.wmf) to an 
appropriate directory in your FrameMaker project and include the file by 
reference into FrameMaker.

Application specific 
graphics

To handle graphics created directly in the source application, try to export 
the graphic to a file in a common format (at best: eps).

If this is not possible (as with Word graphics), use the copy and paste 
method (See Copied into the document on page 4).

Last resort None of the above may work in certain circumstances. In this case use 
PDF as an intermediate format. If the image is a vector image, then the 
result will be a vector image. Otherwise you get a bit-map.
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1 Create a PDF. If PDFWriter or PDFMaker seems to get stuck use Print 
to PS (using the Distiller Printer) and then distil to PDF.

2 Open the file in Acrobat (the full product, not just the Reader).

3 Crop the page to the size of the image.

4 Save the page as eps with preview.

5 Import the eps in FrameMaker by reference.
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Application of importing methods

Importing Word files (text)

These rules are based on the work of FredRidder@Dialogic.com.

1 In the first step remove all graphics, even if they are imported by refer-
ence. Handle images completely separate from text.

2 Good adherence to the Word style sheet. Local format overrides are 
nothing but trouble. If necessary, write Word macros to enforce as 
much style conformance as possible before attempting to import.

3 Remove as much «special» formatting as possible by redefining the 
Word styles in a special «export» template. In particular, redefine any 
styles that have auto numbering or bullets in Word so that you don't 
wind up with duplicate tabs or bullet characters in your Frame files. 

4 Ensure exact 1-to-1 correspondence between Word style names and 
Frame style names. This allows you to import content only from Word 
files, leaving all the formatting stuff behind and redefining all the 
styles in Frame. This sounds like the harder way of doing things, but it 
works better in the long run because there are a number of format 
issues that are simply handled too differently in the two tools allow 
direct translation. (One good example is space before and space after 
paragraphs, which is additive in Word but not in Frame.) 

5 Remove any Word frames, that is, resolve them to ordinary text before 
importing.

6 Always import by using File > New to start a new Frame document 
and then File > Import > File to convert and copy the Word content 
into Frame. 

7 Always select the «Reformat Using Current Document's Formats» 
option in the «Import Text Flow by Copy» dialogue to apply your clean 
Frame styles and leave all the Word formatting behind.

8 Break large Word files into chapter-size or section-size chunks before 
importing to Frame. One of the biggest reasons for migrating from 
Word to Frame is Frame's ability to reliably build large books from 
smaller files, and the best time to do the chunking is before importing 
into Frame rather than after. In file importing, smaller is always better. 
(Yes, I'm afraid that size does matter...).

Importing a Word graphic

Word graphics may be of all the kinds described in Graphics in source 
applications on page 4. Use the methods proposed there.

Importing an Excel table

MS Excel (or FrameMaker) produced errors when importing sparse arrays 
(not completely filled table areas). This error is no more present with 
FrameMaker 6 and Excel 2000.

To import an Excel table (or part of):

1 In Excel select the table area to be copied

2 Copy to the clipboard
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3 In FrameMaker use Edit > Paste Special… and select text.

4 Convert the tabbed paragraphs to a table with Table > Convert to 
Table… 

5 Select an appropriate Table format and format the rows according to 
the needs.

Importing an Excel graphic

To import a graphic from Excel into FrameMaker:

1 In Excel select the graphic (chart)

2 SHIFT-Edit > Copy picture…

3 Select as shown when printed to get best results

4 In FrameMaker use Edit > Paste Special… and select wmf. 

Importing a Powerpoint graphic

1 In PowerPoint select the graphic or graphic elements.

2 Copy to the clipboard

3 In FrameMaker Paste (a wmf will be pasted)

Note: If you select text elements (e.g. large headings) these will not be copied. 
Also backgrounds will not be copied (they can normally not be selected)
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FrameMaker specifics
See also www.daube.ch.

Over the time FrameMaker was available on the following platforms and 
operating systems):

Windows Macintosh UNIX LINUX

Windows 3.1 
(up to FM 4)

System 7.x 
(up to FM 5.1)

IBM AIX Only ‘unofficial’ LINIX port ex-
isted for FM 5.5.6

Windows 95 (up to FM 5.6) System 8.x (until FM x.x) HP_UX

Windows NT 4.0 System 9.x (until FM 7.0) SUN Solaris

Windows 2000
Windows XP

Platform abandoned after FM 
7.0 March 2004

Only Sun Solaris continued 
with FM 7.1, others abandoned 
March 2004

Windows Vista (FM 8)

Platform differences

Property Windows 3.x, 9x, NT4, W2K, XP UNIX

User interface Windows, child windows, buttons, drop down 
lists, tabs in dialogues. Multi document inter-
face (MDI)

Windows, child windows, buttons, drop down 
lists. Most dialogues behave like palettes.

Keyboard short-cuts Adapted to Windows Some keyboard short-cuts

Escape sequences are platform independent, but adapted to UI-language

File format (line-ending) CR - LF CR

Character coding ANSI + extensions (OEM) ISO Latin-1

Help system
- version < 6
- version 6
- version 7

Frame hyper document
Winhelp
HTML

Frame hyper document
X-windows help
HTML

Starting with version 5.5 the FM-files (binary) were platform-compatible, 
hence MIF no more needed for platform-transfer.

Maker Interchange Format - MIF

Main features of this file format are:

preserve the document structure
is independent of character coding (uses only 7-bit ASCII)
is extensible (upward compatible)

Any FrameMaker version can import MIF. When opening an FM 6.x MIF 
in a 5.x Frame version, unknown items are skipped – MIF is even down-
wards compatible!

Saving a file as MIF cleans out some ambiguities which still accumulate 
with many changes in a document.

FrameMaker vs. word processing and DTP

Looking at the developments in document processing applications reveals 
various approaches (looking at the 1980’s):

http://www.daube.ch/docu/fmhist00.html
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Quark Xpress emulated35) dedicated and complex typography equip-
ment that required trained operators in print houses.

Aldus (now Adobe) PageMaker emulated a layout (paste-up) artist's 
workspace accessibly.

MacWrite emulated a typewriter (magnetic-card operator was still a 
profession).

Microsoft Word emulated MacWrite with bells, whims, and bugs.

FrameMaker emulated dedicated technical or scientific word-process-
ing systems that served publishing professionals printing book-length 
documents.

Any comparison between these applications must keep the (originally 
intended) purpose and users in mind36).

Word for Windows (6 … 8) FrameMaker > 5.12

Platforms Windows, Mac (not same functions) Unix, Mac, Windows

User interface Flexible and mostly intuitive, adaptable Sometimes clumsy due to platform independ-
ence

Template New document is copy; template can be 
updated from document styles and mac-
ros. Name *.dot. Document can not be 
updated from template

New document is copy; updates docu-
ment at any time (various aspects of doc-
ument). Any FM document is a template.

Extensibility Powerful macro language (many syntax 
changes in early versions)

API client FrameScript and many other 
specific API clients

Book functions Master document (very unreliable); mas-
ter document = Σ all documents

Well thought out; little automatism miss-
ing

Outline view Full featured API client Enhance

Layout of pages First, even, odd; header and footer area, 
columns for body

Any number of master pages, even mixed 
orientation; any # of frames

Styles Paragraph, character Paragraph, character, table, lines

Side headings Anchored frames (very unreliable) Standard definitions

Tables Heading not repeated; sorting and calcu-
lations

Heading repeated on pages; sort (FM 
5.5); calculations by API clients and 
scripts

Variables Fields, global variables in master docu-
ment

System and user variables, may be for-
matted

Graphics (direct) Located in hidden layer, positioning unrelia-
ble

Features sufficient for technical docu-
ments

Anchored frames A very unreliable feature The name of the game

Import graphics and text Default: copy; paragraph and character 
formatting; update of references kills for-
matting

Default: reference; paragraph formatting; 
update keeps formatting (ref.)

Language Associated with paragraph or character for-
mat

Associated with paragraph or character for-
mat

Index At any location (field) Generated document, very flexible

Table Of Contents etc. At any location (field), arbitrary lists pos-
sible with some effort

Generated document, very flexible, arbi-
trary lists with same functionality

35 You may substitute the word emulated by «was inspired by».
36 Many of these remarks are still valid for Word 2000 and even 2003
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Product history

You find a more or less complete history about the development of Frame-
Maker on the author’s web site on www.daube.ch. 

FrameMaker time line

1985 20051995 20001990

Frame Technology founded by
Steve Kirsch, David Murray, Charles 
Corfield and Vickie Blakeslee

Frame Technology 
acquired by Adobe Inc.

1.
3

2.
0

3.
0

5.
0

5.
12

5.
5

6.
0

4.
0

5 475

employees (~ 1/3 on R/D)

2200

employees (~ 40 on FM R/D)

7.
0

FrameMaker and 
+SGML merged into 
one product

7.
1

2010

330

Unix versions

Mac OS (until 9.x)

Windows versions

SUN Solaris only

only

1.
0

0.
6

7.
2

Adobe India becomes responsible for FrameMaker

8.
0

9.
0

FrameMaker icons Application icons on Windows (original size 32×32 pixels)

4.0 5.0 5.5 6.0 7.0 8.0 9.0

The icons for version 4 and 5 are scanned from documents, since no icon 
file could be found.

http://www.daube.ch/docu/fmhist00.html
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File names
document.fm standard document name

document.fm.lck File of length 0 to lock additional open.

document.auto.fm autosave copy 8 File > Preferences

document.backup.fmbackup copy (before new edit starts)

document.emg.fm emergency copy (some crashes)

documentxxx.fm generated file (for suffixes xxx see below)

document.book generated book started with «document»

document.mif Maker interchange format.

Name suffixes The following suffixes are default

Type of document English German French

Table of contents TOC IVZ TDM

Index IX SIX IX

List of Figures, Tables LOF, LOT AVZ, TVZ LDF, LDT

List of paragraphs, (alphabetical) LOP (APL) EAL (AEAL) LDP (LAP)

List of Markers, (alphabetical) LOM (AML) ML (AML) LDM (LAM)

List of References (text insets, images, 
fonts, unresolved x-refs etc.)

LOR LR REF

Standard Index, Index of Authors, Sub-
jects, Markers, References

IX, AIX, 
SIX, IOM, IOR

SIX, AIX, TIX, 
MIX, RIX

IX, IXA, 
IXT, IDM, 
IREF

list of formats/ index of formats LFT, IFT FL, FIX FOR, IFOR

Note: The defaults for the suffices (TOC, IX etc.) depend on the UI language. 
These can be changed when generating the files. However, names of build-
ing blocks (for example, for system variables) also depend on the UI lan-
guage and can not be changed.

Temporary files On start of FrameMaker some files are created in the temporary directory 
(in Windows defined by the environment variable TMP), for example 
FRM9A.tmp. These are removed at close of FM.

Crash files If FrameMaker crashes with an error message, such as 

a dump file is created in the $FMHOME directory:
h:\adobe\framemaker\en\FrameLog_99.11.05_09.44.39.txt

In other crash cases additionally the temp files are copied to the 
$FMHOME directory, e.g. formulas.fm.2EB. You may need these to 
send them to Adobe for error tracking.
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Document properties in MIF

View only documents

Any document can be locked for view only (no editing possible) with the 
command ESC, F, l, k. This lock is permanent and can not be unlocked, if 
the View Only statement is present in the MIF file of this document (see 
Lock document permanently on page 12).

Note: To be able to edit this document further, always keep the MIF version (text 
file) of the document to be able to remove the View Only statement.

Unlock document To unlock a view-only document, enter the sequence ESC, F, l, k

Unlocking of a permanently locked document is not possible.

Save as View Only With File > Save As … and selecting View Only x.x (*.fm) the file 
can be saved as viewable only without applying the ESC sequence.

Lock document permanently

The View Only MIF statements described in this section must appear in a 
Document statement. These statements have no effect in an unlocked 
(editable) document.

To disallow unlocking, open the MIF file and change the statement found 
in the <Document section:
<DViewOnly No> to
<DViewOnly Yes> and add statement
<DViewOnlyNoOp 0xF00>

The file is locked when opened in FrameMaker. However, the document 
read from the disk by FrameMaker is still in text format and can therefore 
be unlocked by someone with write permissions to the MIF file by revers-
ing the change.

Locked for everybody 1 Change the statement mentioned above to  
<DViewOnly No ><DViewOnlyNoOp \0xF00 >

2 open the edited MIF file in FrameMaker, and 

3 save the file in View Only format.

4 The following message appears:  
This file cannot be opened for editing after you save it in View-Only format. 
Save a backup file in Normal (editable) format? Yes No Cancel

5 If you select Yes, the file is immediately locked and cannot be 
unlocked. The file is saved in binary format to disk, and cannot be 
restored to an editable state.

Warning: There is no procedure for unlocking such a document (even Adobe can not 
help in this case)! If the copy command is still available for a document 
the contents of the document can be pasted into another document.
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Document control statements

You can use MIF statements to change the appearance and behaviour of 
the document window in the following ways:

Statement overview

Statement Value a

a. Default for normal document is highlighted

DViewOnly No document can be edited

Yes document is view only

DViewOnlyXRef GotoBehavior X-refs behave like gotolink

NotActive Disable hypertext in X-refs

OpenBehavior X-ref links behave like 
openlink

DViewOnlySelect Yes

UserOnly Disable highlighting 
destination link

No Disable selecting text

DViewOnlyWinBorders Yes Display scroll bars

No Suppress scroll bars

DViewOnlyWinMenubar Yes Display menu bar in Unix

No Suppress menu-bar display 
under Unix

DViewOnlyWinPopup Yes Allow popup hypertex cmd

No Disable popup hypertext cmd

DViewOnlyWinPalette No file behaves as document

Yes file behaves as palette

DViewOnlyNoOp 0x313 Disable cutting or clearing

DViewOnlyNoOp 0x322 Disable copying

DViewOnlyNoOp 0xF00 Disable unlocking the 
document

Sources Dan Emory: FrameMaker Palettes [pdf on the net, 1999] 
http://www.faqs.org/faqs/frame/faq/part2/ 
MIF reference Setting View Only document options

Disable user actions You can disable specific commands in a View Only document. For exam-
ple, a hypertext author might disable copy and print commands for sensi-
tive documents.

To disable a command, you must supply the hex code, called an fcode, that 
internally represents that command in a FrameMaker product. For exam-
ple, you can disable printing, copying, and unlocking the document by 
supplying the following statements:
<DViewOnlyNoOp 0x313> # Disable printing
<DViewOnlyNoOp 0x322> # Disable copying
<DViewOnlyNoOp 0xF00> # Disable unlocking the document

Warning: There is no procedure for unlocking such a document! If the copy com-
mand is still available for a document the contents of the document can be 
pasted into another document.

Explanation
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Document window menu 
bar

Suppress (No), Enable (Yes)
<DViewOnlyWinMenubar No>

This statement has no effect in the Windows version of a FrameMaker 
product because those versions have an application menu bar rather than a 
document window menu bar.

Display of scroll bars and 
border buttons

Suppress (No), Enable (Yes)
<DViewOnlyWinBorders No>

Selection in the document 
window

Suppress (No), Enable (Yes)
<DViewOnlySelect No>

You can normally select text and objects in a locked document by Control-
dragging in UNIX and Windows versions. Specifying 
<DViewOnlySelect No> prevents all selection in a locked document.

Context menus Suppress (No), Enable (Yes)
<DViewOnlyWinPopup No>

This statement has no effect in Windows versions.

A document region pop-up menu is a menu activated by the right mouse 
button. For example, in UNIX versions of a FrameMaker product, the 
Maker menu and Viewer menus can be accessed by pressing the right 
mouse button. If the DViewOnlyWinPopup statement has a value of No, 
the background menu does not appear when the right mouse button is 
pressed. 

Make window behave as 
palette

<DViewOnlyWinPalette Yes>

A palette window is a command window, such as the Equations palette, 
that exhibits special platform-dependent behaviour. In UNIX versions of 
FrameMaker products, a palette window can only be dismissed; it cannot 
be closed to an icon. 

In Windows versions, a palette floats outside the main application window 
and cannot be unlocked. To edit the palette, you need to reset the DVie-
wOnlyWinPalette statement to No in the MIF file before opening it in a 
FrameMaker product.

Using active cross-
references

A locked document automatically has active cross-references. An active 
cross-reference behaves like a hypertext gotolink command; when the 
user clicks on a cross-reference, a FrameMaker product displays the link’s 
destination page. By default, the destination page is shown in the same 
document window as the link’s source.

Behaviour gotolink You can use MIF statements to turn off active cross-references and to 
change the type of hypertext link that the cross-reference emulates. (By 
default, cross-references emulate the gotolink behaviour.)

Behaviour openlink To make cross-references emulate the openlink command, which displays 
the destination page in a new document window, use the following state-
ment:
<DViewOnlyXRef OpenBehavior>

Use this setting to allow users to see both the source page and the destina-
tion page.
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Disable active cross-
references

To turn off active cross-references, use the following statement:
<DViewOnlyXRef NotActive>

Control with 
DViewOnlySelect

Use this setting to emulate the behaviour of FrameMaker versions < 6. 
You can use the DViewOnlySelect statement to control whether active 
cross-references highlight the marker associated with destination text.

Value Effect when clicking on a cross-reference

Yes Highlight the marker associated with the destination text.

UserOnly Default: No highlighting of the marker. However, the user can se-
lect text in the locked document.

No No highlighting of the marker. The user cannot select text in the 
locked document.
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Background information for some commands

Hyperlinks: goto vs. open

Question: When I follow a link to another file in the FM book, it usually 
does not close the current file. Other times it does close the current file. Is 
this a bug or a feature, and how do I disable closing the current file?

Answer: FrameMaker hyperlinks have two variations: goto  and open.

The goto variation displays the target document in the current win-
dow(closing the currently-displayed file); the open variation displays 
thetarget document in a new window, leaving the current document open.

The goto/open behavior of hypertext markers generated automatically (eg 
in TOC/IX) is controlled through the corresponding flow in the reference 
page, eg: openObjectId <$relfilename>:<$ObjectType> 
<$ObjectId>

With respect to cross-references, the goto/open behavior is controlledin-
ternally by the DViewOnlyXRef property (see Behaviour openlink on 
page C-14 and Disable active cross-references on page C-15). This can be 
set only in MIF or by a plug-in.

If you press the Shift key when activating a link/cross-ref with Ctrl+Alt/
cross-ref (that is, Ctrl+Alt+Shift+click), the goto... is interpreted as an 
open... action (and vice versa).

Notice that the goto/open variation only applies to links activated inFram-
eMaker, and is not carried over to PDF interactivity (where all links/cross-
refs become "goto". More info at www.microtype.com, item 10.

[Shlomo Perets, 2008-12-29]

http://www.microtype.com/ImprovePDF.html
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FrameMaker principles and philosophy
FrameMaker development started in the UNIX environment, from which 
the following principles originate:

1 Keep it small and simple, but allow for easy aggregation.

In UNIX general purpose utilities can be “concatenated” via the stand-
ard input/output mechanism. 

2 Names are case sensitive. The roots of this is the C language. Hence 
not only items in the file system, but also most object-names handled 
by a program are case sensitive.

Impact on FrameMaker

1 Object names (names of paragraph formats etc.) are case sensitive. A 
style name Body is not the same as body.

2 Various tasks are not handled in the core of FrameMaker but in sepa-
rate processes:

- Tables
- Sorting of tables
- Formulas (Equations)
- SGML structure

As a result of this the integration in some cases is not as smooth as 
wanted by the user (e.g. table footnotes are handled independently of 
text footnotes).

3 Input to FrameMaker can be generated from other processes, hence the 
formatting process does not need user interaction or user judgement.

This requires that text features (e.g. TABs) can be handled without 
looking onto the screen. TABs are hence absolute, not relative as in 
text processing software.

4 No macro language is built into FrameMaker. But since the beginnings 
of FM automating was performed by processing the MIF form of files. 
For example, Data Base Publishing solutions generate MIF which is 
then formatted in FM.

In addition, since the beginnings the Frame Developer Kit was availa-
ble to build plug-ins on the various platforms. Since about 1997 the 
script language FrameScript is available, which allows scripts to do 
nearly the same as FDK programming allows.

5 Since FrameMaker was ported to various platforms (UNIX 8 Mac 8 
Windows) there was need for a common ground in the user interface. 
Also hardware (cpu, RAM, screen) was expensive in the beginning. 
Hence FM does not waste resources and on the other side has not a 
tweaked GUI.

6 FM has no “hidden intelligence” as some largely used programs pre-
tend. It does not work automatically in the background. You need to 
start such processes as updating the page numbering or define TAB 
positions explicitly.
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