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Synopsis:
This document provides an overview of the conversion 
process, using FrameMaker’s Word import filter, and de-
scribes the procedures I used to convert PairGain®’s sam-
ple Word 6.0 legacy documents. These procedures, I 
believe, are generally applicable to converting Word 6.0 
documents in which all paragraphs are properly and (rea-
sonably) consistently tagged, and format overrides are 
not used to substantially alter the intended purpose of the 
original tag.

The procedure is based on the use of the new 
FrameMaker template, whose paragraph catalog tag 
names match (in most cases) those in the legacy Word 
documents.

Note : There may be cases where PairGain® did not use a 
capability that was available in Word 6.0, or cases where 
a Word 6.0 capability was used, but was not successfully 
translated by the FrameMaker import filter. In those cas-
es, I am actually describing the state of the PairGain®’ 
documents as they exist after being initially imported into 
FrameMaker, before the FrameMaker template is applied, 
and before any clean-up work is performed.

Note : This document was originated in FrameMaker, us-
ing the same FrameMaker template that was developed 
for PairGain®’s use in converting Word 6.0 documents.
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Problems in Converting Word Documents

• Special Characters: Some special characters (e.g., trademark and degree symbol) in Word don’t tran
properly on import to FrameMaker. I recommend creating a sample Word document that just contain
stances of the special characters used in your documents. Import the document into FrameMaker, a
pare the original with the imported version to determine which special characters are mis-translated.

• Tables: There are a number of problems regarding tables. These include:

– In FrameMaker, the table title is part of the table object. In Word it is not. Consequently, FrameM
doesn’t know whether or not a table needs a table title within the table. FrameMaker resolves this
ma by creating an empty title line within every table it imports from Word. 

In the case of untitled tables, the title line must be deleted.

In the case of titled tables, FrameMaker includes the table title within the table object. This allow
table title to be repeated when the table overflows to a second column or page. Consequently, th
within the Table Caption paragraph above the table object must be copied and pasted into the title
within the table. Then, the Table Caption paragraph above the table object must be deleted.

FrameMaker tables also specify the gap between the top row of the table and the title line. A defaul
is applied to imported tables, and this value may have to be adjusted.

– The ruling of tables in Word does not usually translate properly, and must almost always be mod
after the document is imported.

– In Word, the top/bottom/left/right table cell margins are determined by the paragraph style. In 
FrameMaker, the default margin settings are established by the pre-defined table format. When 
FrameMaker imports a Word Table, it inserts a set of default table margin values into the table. T
default margin values may have to be changed, and/or the Table Cells panel of the FrameMaker
graph Designer may have to be used to specify ± overrides to the default margins. These overrides m
have to be specified for each paragraph style that is used in tables.

– Tables in FrameMaker can be centered in the text frame, or can be aligned to the left or right edge
text frame. In the imported document, the proper alignment may have to be applied to each table

– Tables in FrameMaker specify the left/right indentations of the table edges within the text frame, an
specify the amount of white space above and below the table. This information is not available in
Word table, consequently FrameMaker sets the left/right indents and space above/below to defa
ues. These values may have to be changed.

– FrameMaker tables have heading and footing rows, the contents of which are repeated when the
overflows to a second column or page. When FrameMaker imports a Word table, it does not creat
heading and footing rows, and instead places the contents of heading and footing rows in ordinar
rows. Consequently, heading and footing rows (as applicable) must be added to the imported tab
then the contents of the corresponding body rows must be cut and pasted into the newly created 
and footing rows.

– Word has no automated footnote feature for tables. FrameMaker does. The imported Word docu
use asterisks, daggers, etc. to indicate footnotes, and the footnote text is placed in the footing row
footnotes should be converted to FrameMaker table footnotes.

• Spaces: Modern publishing standards usually forbid multiple consecutive standard spaces in docume
a wider space is required, an en-space or em-space should be used. FrameMaker’s “smart spaces” o
vents occurrences of multiple spaces when documents that are originated in FrameMaker. However,
spaces” cannot eliminate multiple spaces in imported Word documents, which are usually replete with
Page 2 Dan Emory & Associates  Conversion of Word Documents



Problems in Converting Word Documents 6/2/98 Overview

 
 the 
o spec-
elow to 

ere the 
 preced-
bove 

 it uses 

, if not 
ly that 

s 
ning 
e of a 
efault 

o each 
selected 

ess 
rsion, 

ts, 
 text. For 

pdating 
 after 
g the 
ted.

 is 
graph 
lude 
ce or 
ears in 

 begins 
roach. 

, all 
rd must 
Word 
d in 
ulleted 
w 
ents, 

ocu-
rd. An 
ic icon 
and they should be replaced by either a single standard space or by an en-space or em-space.

• Space Above/Below Paragraphs: Word documents are inconsistent in the way space above/below
paragraphs are specified. In FrameMaker, the meaning of space above/below differs somewhat from
meaning in Word. In FrameMaker documents, the most reliable way to control space above/below is t
ify a standard space above (typically 6 points) appropriate for most paragraphs, and to set the space b
zero unless the space below exceeds the standard value. When FrameMaker encounters a case wh
space above specified in the current paragraph is greater than that specified in the space below of the
ing paragraph, it uses the Space Above specified in the current paragraph. Conversely, if the space a
specified in the current paragraph is less than the space below specified in the preceding paragraph,
the space below specified in the preceding paragraph.

• Markers: Although cross-reference and hypertext markers in the Word document are translated, most
all, of them are worthless. Some index markers appear to be translated properly, although it is unlike
multi-level index markers will work.

• Page Layout: FrameMaker creates a default 6 x 9 text frame for the 81/2 x 11 page size in the master page
of the imported Word document, regardless of the original text frame and page size in Word. Also run
header/footers don’t translate properly, and FrameMaker creates a First master page for the first pag
document. This is master page is an unnecessary Word artifact, since it is (usually) identical to the d
Right master page. The First master page should be deleted.

Unless otherwise specified, FrameMaker automatically applies the default Left or Right master page t
page of the document. In special cases (e.g., front and back covers), the user may override the auto-
Left/Right page layout, and replace it with a custom layout that is associated only with that page.

• Graphics: All graphics are imported into FrameMaker in the Windows Metafile (WMF) format, regardl
of the graphic format used in the Word document. In most cases, you will want to delete the WMF ve
and re-import the graphic in its original (e.g., EPSI) format.

• Autonumbering: Imported Word documents do not employ autonumbering for bullets, en-dash bulle
step numbers, figure captions, and table captions. That is, these elements appear as manually-entered
purposes of properly using FrameMaker’s cross-referencing, generated list, and automatic number u
capabilities, it is crucially important that these items use FrameMaker autonumbering. Consequently,
the document is imported into FrameMaker and the correct autonumber format is applied by importin
FrameMaker template, the manually entered text that is replaced by the autonumbering must be dele

• Bolded Titles for Heading 4 and Bulleted Items: In the Word documents, the Heading 4 paragraph
a Standard Paragraph with bolding applied to the title. Similarly, for titled bullets, the Hang Indent para
is used, with bolding applied to the title. In order to properly cross-reference these items and/or to inc
them in generated lists so that only the title, and not the text that follows, appears in the cross-referen
generated list, these titles must be converted to FrameMaker’s Run-In head format, where the title app
the Run-In head, and the text that follows is in a separate paragraph (with the proper indentation) that
on the same line, immediately following the Run-In head. This bulleted item is an example of that app
It uses the Hang Indent (Labeled) paragraph format for the Run-In head containing the title, and the Indent 
paragraph format for the text that follows it. Similarly, the Heading 4 paragraph style in FrameMaker is a 
Run-In head, and the text that follows is in a Standard Paragraph.

• Paragraph Tag Names: In order to optimize the new FrameMaker template for document conversion
of the paragraph tag names in the FrameMaker template that correspond to a paragraph style in Wo
exactly match the tag names in the Word documents. However, the naming conventions used in the 
documents are somewhat inconsistent, and, in many cases are not descriptive of how that tag is use
FrameMaker. For example, the Hang Indent tag in Word actually corresponds to an autonumbered b
paragraph in FrameMaker. These compromises in paragraph tag naming must be accepted if the ne
FrameMaker template is to be used both for effectively importing and reformatting legacy Word docum
and for originating new documents in FrameMaker.

The new FrameMaker template also includes a number of paragraph tags not included in the Word d
ments. These tags are used primarily to exploit FrameMaker capabilities that were not available in Wo
example is the way Note and Caution icons are produced. In the imported Word documents, the graph
 Conversion of Word Documents Dan Emory & Associates  Page 3
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must be imported into each location where it is used, creating a large file overhead. In FrameMaker, 
icons are imported only once into a reference page, and special paragraph tags (Icon (Note) and Ico
tion)) are used instead of the Note Icon tag. When either of the new tags replaces the Note Icon tag, a
replica of the graphic icon on the reference page appears at the Icon (Note) or Icon (Caution) insertio
in the document. Not only does this approach reduce file overhead, it also automatically updates all o
rences of the icon if a modified graphic icon is imported into the reference page.

• Character Formats: Character format tags do not exist in the Word documents. Consequently, whe
Word document is imported into FrameMaker, formatted strings (e.g., bold, emphasis, underlined) wi
paragraphs are untagged. FrameMaker, on the other hand, uses character tags to define the formattin
text strings. Standard practice requires that all document objects, including formatted text strings withi
graphs, be properly tagged. This is particularly true for:

– Documents having a long life-cycle that are subject to frequent revision

– Documents that may be re-purposed to meet other delivery requirements requiring different form
from that of the original document

– Documents containing information chunks that may be re-used in other publications

In these cases, standard practice dictates that ALL format overrides applied to text strings within para
should use character tags. This practice assures that all document objects can be globally re-formatt
conform to this standard practice, formatted text strings (other than those created by autonumbering 
cations in paragraph formats, which are already tagged) in imported Word documents should be tagg
the appropriate FrameMaker character format tag.

• Use of Variables: Word documents do not use variables. FrameMaker uses two types:

– System Variables. These are pre-defined by FrameMaker, and cannot be deleted. Their format an
tent can, to a limited extent, be modified from the default formatting. They are used to specify the
name of the current document, current date, document creation date, last modification date, page n
page count, table continuation and table sheet number for tables that overflow to a second colum
page, and running header/footer variables that specify, for instance, the contents of the current h
or the contents of a special marker within a running header or footer.

– User-Defined Variables. Variables of this type fall into two categories: (1) commonly used special c
acters, and (2) information that changes from document-to-document (e.g., part number, model n
release date, revision number, document number, product type, product name, and product nick
Proper use of variables can greatly improve both document consistency and document managem

• Cross-References: Word 6.0 documents do not use automated, updatable, hypertexted cross-refere
FrameMaker does. All existing cross-references to tables, figures, steps, and headings in the importe
documents must be converted to FrameMaker cross-references. This step also permits the rapid loca
repair of unresolved cross-references resulting from deleting or copying text that contains a cross-ref
source marker.

• Reference Pages: Word does not support the concept of reference pages. FrameMaker does. Refer
pages in FrameMaker are used for the following purposes:

– To provide repetitively used graphic elements (e.g., lines, icons) that can be inserted anywhere in
ument by special paragraph tags that specify a reference frame graphic in a frame above or belo
paragraph. Use of this approach greatly reduces the file overhead, because the graphic hit only o
once. Not only does this approach reduce file overhead, it also automatically updates all occurren
the graphic if the graphic is changed on the reference page.

– To provide other repetitively used graphics that cannot be inserted by the method described abo
which can be copied and pasted anywhere in a document. Keycap labels are an example.

– To define the complete formatting specifications for generated lists (e.g., table of contents, list of fi
list of tables) and indexes. When a generated list or index is produced, the reference pages from
source document(s) are replicated in the generated list/index, and the applicable format specifica
Page 4 Dan Emory & Associates  Conversion of Word Documents
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contained therein are used to format the list or index. Since the new template specifies that genera
and indexes are to be automatically hypertexted, their utility is greatly enhanced.

The proper use of these reference page features may require modification to the imported Word docu

How the New FrameMaker Template Assists in the Conversion Process

If the foregoing discussion of the problems in converting Word documents leads you to the conclusion th
FrameMaker template cannot possibly automate the entire process, you are correct. All that can be done
clude in the template everything that will be needed to automate the things that can be automated, and to
you in doing those things that can’t be automated.

What the FrameMaker Template Can  Automate

• Reformatting of Paragraphs: If the paragraph tag name in the Word document exactly matches a t
name in the FrameMaker template, it will be reformatted to conform to the template. But if the paragra
in Word was used (by means of format overrides) improperly for something it was not intended for, 
FrameMaker will remove those format overrides, and convert it to its intended purpose. That is likely to 
problems in deciding which paragraph tag in the template must be applied to restore it to its intended
Also, if a Word paragraph tag is used in the wrong place (e.g. a paragraph tag intended exclusively fo
tables) is used outside a table, it almost always will be formatted improperly for that deviant use.

• Adding the Template’s Master Page Layouts, and Applying Them: These master pages (includ-
ing the correct running header/footer formats) are added to the imported document, and the default Le
master pages are applied. However page layouts (e.g., the First master page) that are Word artifacts
main. If these artifact master pages were applied to any document page, the correct new master page
applied to it, and then the artifact master page must be deleted. However, the new running header/fo
mats use variables for document-specific information (e.g., release date, section number, model numb
existing variable definitions in the Variables catalog imported from the template must be edited to conta
definitions applicable to the imported document.

• Adding the Template’s Reference Pages: Any paragraph tags that were present in the imported Wo
document which, in the re-formatted version, use reference page graphics will have the applicable re
page graphic added above or below the paragraph.

• Adding Other Catalogs: Includes variable, character format, cross-reference, and table catalogs. 

What the FrameMaker Template Can’t  Automate, But Can  Simplify

• Table Reformatting: This is an onerous burden. The table catalog imported from the template conta
number of pre-defined table formats that match up well with commonly used table types in your Word
uments. You can look at the imported table and decide which pre-defined format comes closest to the
you want, and apply it to the table. Then, using the FrameMaker Custom Ruling and Shading dialog bo
specify that all ruling should revert to the default ruling specified in the pre-defined table format. This 
inates the (typically) botched-up table ruling in the imported table. Finally, you can then use the Table
signer and Custom Ruling and Shading dialog boxes to modify the ruling and any other settings in th

• Identifying Incompatible Paragraphs: An incompatible paragraph is one whose tag name was inher
from Word, and that tag name has no counterpart in the new template. Another incompatible type is 
whose intended purpose is misused (e.g., a paragraph type intended exclusively for use in tables that
used outside a table). Such tags must be converted to the appropriate tag in the template. Because o
plate design, any such tag that appears outside of tables will typically have the following appearance

Note that the text has been split into two columns, and (if border viewing is enabled) that the two ver
dashed lines appearing in the center of the text frame indicate the gap between the two text columns

Text in offending tag xxxxxxxxxxxxxxxxxxxxxxxx
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
 Conversion of Word Documents Dan Emory & Associates  Page 5
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• Fixing Mis-Translated Special Characters: The problem is to find them. But when you do find one,
you can replace it with the correct one from the Variable catalog imported from the template.

• Adding Cross-References: Again, the problem is to find them, since none of them are automated, a
there is no format differentiation that identifies them as cross-references. But when you do find one, y
replace it with an automated, hypertexted FrameMaker cross-reference by using the Cross-Referenc
box. The cross-reference format catalog imported from the template has a number of pre-defined for

• Applying Character Formats to Formatted Strings: The character catalog imported from the tem-
plate contains pre-defined formats for almost any type of formatted string. Simply highlight the forma
string within a paragraph, and apply the appropriate character tag to it. This action overrides the artif
matting inherited from Word. You can apply two or more (non-mutually-exclusive) character tags to the
string to get the combination of all of them.

• Visual Recognition of Special Types of Document Objects: The template design utilizes the fol-
lowing visual recognition methods to help you identify special types of document objects:

– Inserted cross-references are underlined blue (Double-clicking on a cross-reference with the left mous
button opens the Cross-Reference dialog box. To go to the cross-reference source, put the curso
cross-reference text, type + , and click the left mouse button). You can also use the F
Change dialog box to find all cross-references.

– Inserted variables are dark blue (double-clicking on a variable opens the Variable dialog box). You c
also use the Find/Change dialog box to find all variables.

– Anchor paragraphs for figures, equations, and tables are red (since these paragraphs are small and ar
normally empty, you can only see them if View > Text Symbols is turned on).

– Comment conditional text is red underlined (you can only see comments if they are not hidden). You c
also use the Find/Change dialog box to find conditional text.

– Question conditional text is red overlined (you can only see questions if they are not hidden). You ca
also use the Find/Change dialog box to find conditional text.

How FrameMaker Features Can Assist the Conversion Process

Find and Replace

In addition to finding strings, you can find paragraph tags, markers, cross-references, unresolved cross-ref
and more. For example when there are known culprits in the incompatible paragraph tag category, you ca
on the paragraph tag name, and track down each occurrence of it. Most importantly, the Find and Replace
lets you clean out all of the artifact manually entered heading, figure, table, and step numbers, as well as
and en-dashes, which are replaced by autonumbering specifications in the template’s paragraph catalog.
also use Find and Replace to eliminate multiple consecutive standard spaces.

Converting Multi-Column Text Arrays to FrameMaker Tables

Multi-column arrays are often created in Word by using paragraph tags that have tab stops to separate the c
In the Word documents, this method is used in technical specifications under each Tecspec Head. These
be converted to tables, using FrameMaker’s Convert to Table feature. Simply select all paragraphs in a m
umn array, and choose Table > Convert To Table. The Convert to Table dialog box opens. In this dialog box
the pre-defined table format you want to use, and click the Convert button. The array is converted to a tab
may have to do some manual clean-up after the conversion takes place.

Ctrl Alt
Page 6 Dan Emory & Associates  Conversion of Word Documents
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Preparation (Prior to Importing Each Word Document)

1 Open FrameMaker. Choose File > Preferences. In the Preferences dialog box:

a Turn on Automatic Save every 5 minutes.

b Turn on Show File Translation Errors.

c Turn off Save FrameImage With Imported Graphics.

2 On the View menu, turn on Formatting Bar, Borders, and Text Symbols.

3 If the Frame Console Log is open, close it.

4 Close all open FrameMaker documents.

Import The Word Document

1 Choose File > Open, and select the Word document to be imported from the Import File dialog box.

2 The Unknown File Type dialog box may open. If it does, choose Microsoft Word, and click the Conver
ton.

3 After the Convert operation is completed, the converted Word document should be displayed.

4 Check to see if the Frame Console Log is open, indicating that file translation errors were detected. Hop
the log won’t open. If the log opens, examine it to see if the translation errors were extensive. The log 
are quite cryptic, but they may give you some clue about what happened.

5 Choose File > Save As, and save the imported file under an appropriate name that differs from the n
the Word document (usually, the extension should be.fm).

6 Open the Paragraph Catalog, and click the Delete bar at the bottom to open the Delete Formats From
dialog box. Delete all paragraphs from the catalog, and click Done.

7 Choose Special > Cross-Reference to open the Cross-Reference dialog box. Click the Edit Format b
open the Edit Cross-Reference Format dialog box, and delete all formats from the left-hand Formats l
Then click Done to close the Edit Cross-Reference Format dialog box, and click Cancel to close the C
Reference dialog box.

8 Choose File > Save to save the document.

9 If you want to delete the imported WMF graphics so that you can later import them in their original for
do it now. Page through the document to locate the graphics. When you find a graphic, click in the ce
the graphic object to select it, and clear it ( , e, b). After deleting each graphic object, re-save the
ment (sometimes, FrameMaker crashes when you delete a graphic).

Steps 6 and 7 below are required to purge the imported Word document of all paragraph and 
cross-reference formats. This must be done to assure that all artifact Word formats, as well 
as default FrameMaker formats, are deleted prior to importing the new FrameMaker template 
into the imported Word document.

!
If you perform step 9 below, DO NOT delete the anchored frames that contain the graphics. 
Delete only the graphic object within the anchored frame. Also, DO NOT delete the graphics 
or anchored frames for Notes, Cautions, and Warnings, because they will be handled later.

Esc
 Conversion of Word Documents Dan Emory & Associates  Page 7
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10 Choose File > Close, and save the document.

Apply the FrameMaker Template to the Imported Document

1 Choose File > Open, and open the FrameMaker template.

2 Choose File > Open, and open the imported Word document saved in Step 10 under “ Import The Word Doc-
ument” .

3 With input focus in the imported Word document, Choose File > Import > Formats to open the Import fo
dialog box. In this dialog box:

a Select the template file from the Import From Document menu.

b Turn on all check boxes under Import and Update.

c Under While Updating Remove, turn off Manual Page Breaks, and turn on Other Format Overrid

d Click the Import button. The import formats action is performed. All catalogs will become filled with
formats from the template, and all paragraphs whose tag names match tag names in the template
updated to their template-prescribed formats. Also, the master page layouts and reference pages
template will replace those in the imported Word document.

4 Move input focus to the template file opened in step 1. Choose File > Close to close (without saving) th
plate file.

5 Choose File > Save to save the imported document.

6 Choose Format > Page Layout > Master Page Usage, and make the following settings in the Master P
age dialog box:

a Turn on Right/Left under Use Master Page.

b Under Apply To, turn on the Pages, Even, and Odd check boxes, and turn off the That Currently 
Master Page check box.

c Click the Apply button.

7 Choose File > Save to save the imported document.

8 If the imported document contains the front matter (i.e., cover, Table of Contents, etc.), go to the first (
page of the document, insert the cursor anywhere in the first page, and again choose Format > Page
> Master Page Usage. In the Master Page Usage dialog box:

a Select the Front master page from the Custom menu under User Master Page.

b Under apply to, turn on Current Page.

c Click the Apply button.

9 Choose View > Master Pages. There should be only six master pages, named Left, Right, Blank, Fron
and Blank Before Back. If there are more than six, find the ones that are artifacts from Word (e.g., Firs
delete them by displaying the master page to be deleted and choosing Special > Delete Master Page

10 Choose File > Save to save the imported document.

11 For some inexplicable reason, FrameMaker does not import the document-wide format settings from t
plate. You must now make those settings. Proceed as follows:

a Choose Format > Document > Text Options, make the following settings in the Text Options dialog
and then click the Apply button:
Page 8 Dan Emory & Associates  Conversion of Word Documents
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b Chose Format > Document > Footnote Properties. In the Footnote Properties dialog box, set the n
ing of text footnotes to Sequentially from 1, and then click the Set button.

c If the imported document contains the front matter (i.e., cover, Table of Contents, etc.), choose
Format > Document > Numbering. In the Numbering Properties dialog box, choose “roman (iv)” f
the Page # Style menu, and then click the Set button.

12 Choose File > Save to save the imported document.

13 Definitions for the following document-dependent variables must be edited so they are document-spe

• Revision*

• Section*

• Release Date*

• List No*

• Product Type*

• Part Number*

• Model Number*

• CLEI Code*

• Product Name*

• Product Nickname

• Copyright Year*

* denotes a variable that is used in the running header/footers and/or (may be) used in the front matt

All of these document-dependent variables can be found in the lower-left corner of the first reference
Select View > Reference Pages, and locate the list of variables to be changed on the first reference p
ceed as follows to change each variable definition:

a On the reference page, double-click on the variable whose definition is to the edited. The Variable
box opens. Click the Edit Definition button to open the Edit User Variable dialog box.

b The selected variable’s current definition appears in the Definition slot of the Edit User Variable d
box. Type in the new definition between <Variable> and <Default ¶ Font> in the Definition slot.

c Click the Change button, then click the Done button. This returns you to the Variable dialog box. 
the Done button to close the dialog box.

Repeat substeps a thru c for each variable on the reference page.

14 Choose File > Save to save the imported document.

Table 1. Text Options Settings 

Parameter On/Off Superscript Subscript Small Caps

Smart Quotes On N/A N/A N/A

Smart Spaces On N/A N/A N/A

Size N/A 65% 65% 80%

Offset N/A 35% 25% N/A

!
Observe the following precautions while editing variable definitions:

• DO NOT attempt to change any variables other than those listed above.

• DO NOT click the Add or Delete button in the Edit User Variable dialog box.

• DO NOT click the Create Variable, Convert to Text, Update, or Insert buttons in the Vari-
able dialog box.
 Conversion of Word Documents Dan Emory & Associates  Page 9
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Delete Unwanted Artifacts from the Imported Document

This procedure uses the FrameMaker Find and Replace capability to delete artifact strings from the docu

1 Choose Edit > Find/Change to open the Find/Change dialog box. The table below lists the search str
which find and replace operations are to be performed.

The Find and Replace operations in the table below should be performed exactly in the se-
quence in which they are listed.

Unless otherwise specified, DO NOT use the Change All In option in the Find/Change dialog 
box. Instead, initiate the search with the Find button, and each time an instance of the string 
is found click the Change & Find button if you want to change it, or click the Find button if 
you don’t want to change it.

After completing a find and replace operation for a particular string, re-save the document. 
This assures that, if you make a mistake during the execution of the next find and replace op-
eration, you can revert to the last saved version of the document.

Table 2. Find and Replace Operations (Sheet 1 of 2)

Find Type
Search Stringa

(see footnote at bot-
tom of table)

Consid-
er Case

Use
Wildcards Change

Re-
place-
ment 
Stringb

Purpose

Text \b\t No Yes To Text Empty Remove manually entered bullets that 
have been replaced by autonumbered 
bullets

Text \b No Yes To Text Empty Remove manually entered bullets not fol-
lowed by a tab stop that have been re-
placed by autonumbered bullets

Text \=\t No Yes To Text Empty Remove manually entered en-dashes that 
have been replaced by autonumbered en-
dashes

Text \= No Yes To Text Empty Remove manually entered en-dashes, not 
followed by a tab stop, that have been re-
placed by autonumbered en-dashes

Text [1-9]\t No Yes To Text Empty Remove manually entered step numbers 
between 1 and 9 that have been replaced 
by autonumbered step numbers

Text 1[0-9]\t No Yes To Text Empty Remove manually entered step numbers 
between 10 and 19 that have been re-
placed by autonumbered step numbers

Text [a-z]\t Yes Yes To Text Empty Remove manually entered substep num-
bers between a and z that have been re-
placed by autonumbered substep 
numbers

Text Figure [1-9]PSS Yes Yes To Text Empty Remove manually entered figure num-
bers between 1 and 9 in Figure Captions 
that have been replaced by autonum-
bered figure titles

Text Figure 1[0-9]PSS Yes Yes To Text Empty Remove manually entered figure num-
bers between 10 and 19 in Figure Cap-
tions that have been replaced by 
autonumbered figure titles
Page 10 Dan Emory & Associates  Conversion of Word Documents
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2 Execute the Find/Replace operation on each string, in the order listed in the table above.

Clean Up The Tables

See “ Tables”  on page 2 for a discussion of the many types of problems produced when tables in Word docum
are imported into FrameMaker. The new FrameMaker template contains a number of pre-defined table fo
that were designed to match commonly used table types in the Word documents. All of these table types
sented and described in the document named stylguid.fm.

This procedure provides an efficient (but tedious) way to clean up table problems by a process that includ
plying the most appropriate pre-defined table type to each table.

1 Go to the first page of the document, and put the cursor at the top of that page.

2 Choose Edit > Find/Change to open the Find/Change dialog box, and choose Any Table from the Find

3 Choose Table > Table Designer to open the Table Designer dialog box. Keep this dialog box open thro
the fix-up process.

4 Choose Table > Custom Ruling & Shading to open the Custom Ruling & Shading dialog box. Keep th
log box open throughout the fix-up process. Make the following settings in the Custom Ruling & Shad
dialog box:

a Turn on the Custom Cell Ruling checkbox, and turn off the Custom Cell Shading checkbox.

a. P and S are used in the Search String and Replacement String columns to represent Periods (.) and standard 
Spaces respectively. Substitute the period and space characters for P and S.

b. The word “Empty” in the Replacement String column means that the replacement string is blank.
c. You can select the “Change All In” option in the Find/Change dialog box to replace all multiple consecutive 

spaces with a single space without having to examine each occurrence.

Text Figure 2[0-9]PSS Yes Yes To Text Empty Remove manually entered figure num-
bers between 20 and 29 in Figure Cap-
tions that have been replaced by 
autonumbered figure titles

Text Table [1-9]PSS Yes Yes To Text Empty Remove manually entered table numbers 
between 1 and 9 in Table Captions that 
have been replaced by autonumbered ta-
ble titles

Text Table 1[0-9]PSS Yes Yes To Text Empty Remove manually entered table numbers 
between 10 and 19 in Table Captions that 
have been replaced by autonumbered ta-
ble titles

Text Table 2[0-9]PSS Yes Yes To Text Empty Remove manually entered table numbers 
between 20 and 29 in Table Captions that 
have been replaced by autonumbered ta-
ble titles

Text SS No No To Text S Replace multiple consecutive standard 
spaces with a single spacec

Para-
graph Tag

Space After Table 
Grid

Yes No To Text Empty Delete these empty artifact paragraphs 
when they appear below a table, because 
the space below the table is specified in 
the table format, making these spacing 
paragraphs unnecessary.

Table 2. Find and Replace Operations (Sheet 2 of 2)

Find Type
Search Stringa

(see footnote at bot-
tom of table)

Consid-
er Case

Use
Wildcards Change

Re-
place-
ment 
Stringb

Purpose
 Conversion of Word Documents Dan Emory & Associates  Page 11
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b In the Apply Ruling Style listbox, select From Table.

c In the To Selection section turn on the Top, Bottom, Left, Right, Row, and Column checkboxes.

5 Click the Find button to find each table.

6 When a table is found, the entire table, including the anchoring paragraph above it, is highlighted. Noti
the Table Tag slot in the Table Designer indicates “Table”, which indicates that the table does not us
pre-defined format. Choose from the Table Tag menu in the Table Designer dialog box the most appr
pre-defined table format, and click the Apply button. The pre-defined format is applied to the table. Not
if a pre-defined table format that does not include a table title is applied, the empty table title line in the
object is removed.

7 With the table still highlighted, click the Apply button in the Custom Ruling & Shading dialog box. The ru
specified in the pre-defined table format is applied to the table.

8 If the table has a Table Caption paragraph above it, the table is anchored to the end of that paragrap
table does not have a Table Caption, it is anchored to the end of the preceding paragraph. In either c
ceed as follows:

a Put your cursor in the anchoring paragraph, press the End key, and then press the left-arrow key t
the cursor to the left of the anchor symbol.

b Press the Enter key to create a new empty paragraph that contains the anchor symbol.

c Finally, apply the Table Anchor paragraph format to the new paragraph by selecting Table Ancho
the paragraph catalog. Notice that the empty paragraph containing the anchor symbol is now sma
tered, and colored red. If the anchor symbol is larger than the ¶ symbol, select the entire Table A
paragraph, and apply to it the Default ¶ Font tag from the Character catalog.

9 If the table format applied in step 6 removes the table title line in the table object, but the table has a 
Caption paragraph above the Table Anchor paragraph created in step 8, you must add a table title line
this, select “Above Table” from the Title Position menu in the Table Designer, and click the Apply but

10 If the table has a Table Caption paragraph above the Table Anchor paragraph, select the text (not th
paragraph) in the Table Caption paragraph, cut it to the clipboard, put the cursor at the very beginning
title line in the table, and paste it into the table title line. Then apply the Table Caption paragraph form
the title line in the table. Finally, delete the (now empty) Table Caption paragraph above the Table An
paragraph.

11 If the top row of the table is a heading row, it must be converted to a FrameMaker heading row. Choose
> Add Rows or Columns to open the Add Rows or Columns dialog box, and proceed as follows:

a Select to Heading from the Add Rows menu.

b Click the Apply button. A blank heading row is created in the top row of the table.

c Select the entire “old” heading row below the new heading row so that “handles” appear in the row
type +  to cut it to the clipboard. The Cut Table Cells dialog box appears. Select Remove
from Table, and click the Cut button. The “old” heading row is removed.

d Put the cursor in the new empty heading row at the top of the table, and type + . The Paste
dialog box appears. Select Replace Current Rows, and click the Paste button. The heading cells 
pear in the new heading row.

12 If the bottom row of the table is a footing row, it must be converted to a FrameMaker footing row. Cho
Table > Add Rows or Columns to open the Add Rows or Columns dialog box, and proceed as follow

a Select to Footing from the Add Rows menu.

b Click the Apply button. A blank footing row is created in the bottom row of the table.

c Select the entire “old” footing row above the new footing row so that “handles” appear in the row,
type +  to cut it to the clipboard. The Cut Table Cells dialog box appears. Select Remove

Ctrl X

Ctrl V

Ctrl X
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from Table, and click the Cut button. The “old” footing row is removed.

d Put the cursor in the new empty footing row at the bottom of the table, and type + . The 
Rows dialog box appears. Select Replace Current Rows, and click the Paste button. The footing ce
appear in the new footing row.

13 Choose File > Save and save the document.

14 Repeat step 5 thru 13 for each table in the imported document.

Converting Note, Caution and Warning Icons

In the imported document, anchored frames contain the graphic icon. The anchored frame and the graph
tained therein must be deleted and replaced by applying either the Icon (Note) or Icon (Caution) paragrap
These two paragraph styles specify the applicable icon in a Frame Above. Proceed as follows:

1 Open the Find/Change dialog box, and make the following settings to search for occurrences of the No
paragraphs:

2 Click the Find button. When an occurrence of a Note Icon paragraph is found, proceed as follows:

a Examine the highlighted icon to determine whether it is a Note, Caution, or Warning.

b Click the Change button in the Find/Change dialog box to delete the anchored frame containing th

c If (as determined in substep a) the graphic icon was for a note, apply the Icon (Note) paragraph ta
table cell that is to contain the icon; otherwise, apply the Icon (Caution) paragraph tag. The correct
ic icon will appear in the table cell.

3 Repeat step 3 until no further occurrences of the Note Icon paragraph are found.

4 Choose File > Save to save the document.

Converting Text Arrays to Tables

See “ Converting Multi-Column Text Arrays to FrameMaker Tables”  on page 6 for a description of the procedure

Fixing Incompatible Paragraph Formats

See “ Identifying Incompatible Paragraphs”  on page 5 for a description of how to identify these paragraph type
When an incompatible format is found, examine the content, and determine which paragraph format in th
plate paragraph catalog should be applied to it.

Table 3. Find/Change Settings for Finding Icons

Find Type
Search String
(see footnote at bot-
tom of table)

Consid-
er Case

Use
Wildcards Change

Re-
place-
ment 
String

Purpose

Para-
graph Tag

Note Icon Yes No To Text Empty Find occurrences of Note, Caution, and 
Warning Icons.

Ctrl V
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Creating Run-In Heads for Heading 4 and Titled Bullet Paragraphs

See “ Bolded Titles for Heading 4 and Bulleted Items”  on page 3 for a description of this problem.

In the imported Word document, a Standard Paragraph with a bolded lead-in title followed by a period, fol
by the rest of the text must be converted to a Heading 4 Paragraph. Proceed as follows:

1 Delete the period at the end of the bolded title, and the space(s) after the period. Then, hit ENTER to
the Standard Paragraph as this point.

2 Put the cursor in the bolded title line, and apply the Heading 4 paragraph tag (Run-In Head format) to i
that the unbolded Standard Paragraph now appears on the same line as the bolded title.

In the imported Word document, a Hang Indent paragraph with a bolded lead-in title followed by a colon, fol
by the rest of the text must be converted to a Hang Indent (Labeled) paragraph. Proceed as follows:

1 Delete the colon at the end of the bolded title, and the space(s) after the colon. Then hit ENTER to br
Hang Indent paragraph at this point.

2 Put the cursor in the unbolded text line below the bolded title line, and apply the Indent paragraph tag

3 Put the cursor in the bolded title line, and apply the Hang Indent (Labeled) paragraph tag (Run-In He
mat) to it. Note that the unbolded Indent Paragraph now appears on the same line as the bolded title

Miscellaneous Clean-Up

Go through the document looking for any of the following:

1 Special characters that should be replaced by variables in the Variable Catalog. Proceed as follows:

a Select the text string to be replaced by a variable.

b (Choose Special > Variable to open the Variable dialog box.

c Select the appropriate variable, and click the Replace button.

2 References to headings, steps, labeled bullets, tables, and figures should be replaced by FrameMak
references. Proceed as follows:

a Locate references by using Find/Change to search on keywords such as “see”, “figure”, “table”, “
and “section”.

b When a reference is found, select it, and choose Special > Cross-Reference to open the Cross-R
dialog box,

c In the Cross-Reference dialog box, select from the Paragraph Tags listbox the paragraph tag nam
Heading 1, Step Text, Figure Caption, Table Caption) in which the source is located, and select fr
Paragraphs listbox the instance of that paragraph tag that is the source. Then select from the Form
the cross-reference format you want to use, and click the Insert button to insert the cross-referen

3 Footnotes defined by symbols (*, †, ‡) in the footnote source, where the footnote text (with the same symb
appears in a footing row at the bottom of the table. These should be converted into FrameMaker tabl
notes. Proceed as follows:

a Select the symbol (*, †, ‡) in the footnote source (NOT the matching symbol in the footnote text in 
footing row), and choose Special > Footnote to replace the symbol with the FrameMaker footnote
cator. This action also creates a blank letter-numbered TableFootnote paragraph below the last ro
table.

b Cut the corresponding footnote text (NOT the entire paragraph) in the table footing row to the clipb
and paste it into the TableFootnote paragraph created below the table, and then remove the symb†, 
‡) from the footnote text. Finally, select the TableFootnote paragraph, and apply the Default ¶ Fon
acter format to it.
Page 14 Dan Emory & Associates  Conversion of Word Documents
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