FrameMaker 7.2
Crash Course

Overview

This handout for a crash course covers each topic
on one page only. Comprehensive information
about FrameMaker (> 350 pages) can be found at
www.daube.ch/docu/fm-kurs/handout.pdf
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Properties of FrameMaker

Designed for long and long living structured documents
Any FM document is also a template

Internal names are case sensitive

TOC/Index etc. are stand-alone documents

Import default is “by reference”

Formats are independent (no “based on”)

Not all can be undone! No drag’n drop,

No macros = plug-ins, FrameScript

Modern user interface only starting with version 9

‘Layers’ in a document

Heading

) Wr7t19g mfo
7itle
Page

on the next

Heading Heading B o d y p a g es:
2AFE /T Zegyl set of ’
”275;;;2/ ”;”f’”/’”ﬂf In these you are working.
orver . .
pages jom masterpages Heading and footing areas

the Right’ can not be edited - they

are ‘background’.

Footing Footing Footing
*manua\\y assigned automatically assigned * *manual\y assigned M a Ste r pag es
Hea oG T These define the layout.
L/R master pages are
assigned automatically.
Others must be assigned
J F manually.
£ Y
& «.75'
Footing Footing
Title Left Right Rotated REfe rence pages
Footnot <Sparatext>  <Spa- . -
e R f;;;,)’ " - These contain various ele-
<Sparatext> <Spa- .
Longtine ) Sz . ments, which can be refer-
_____ v [oenm o enced or define templates
Graphic-] (I e for generation of special
Valld -7 Type> <SObjectla>
/!// pages (TOC, Index etc.)
/ /
L o e e o
Reference 70C

Applying formats

Character Designer m » f Catalog E
Character Tag | Family: ILucida Sane;l r IUnderIine ;I HDE-f-@-EJ-l-t---ﬂ-Egn-t--- ]
I;._...- — I ——————— = = ol
i 1-highlight
Paragraph Designer m tline Fg -I Return L = o
. y 1y ;
B asic | Default Font I Pagination I Numberingl Advancedl Table CeIII trmmely thcllﬁpc gtht
Paragraph Tag: compuer
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Properties: Ergerint il H H fh-fig-Head
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To Selection g el darkness and chaos. hyperigst
! icon
Update pocm : - Edit.. | Zheading keywold =]
Line 5pacing: ZheadingTOC n Elephants
Formats Tagged: m Zheading-notoc Delete...
bodytexst Ali t: Spt x| | T Mest Paf Tag: Sheading :
I% BT SreadraTOr = Lions F8, 1, Return
hal = hl eading
Commands: B Sheading = 7ebras
bodytext
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Basic text handling

To select Type, do Task Type

Word double click Apply paragraph format F9, name, Enter
Paragraph triple click Apply character format F8, name, Enter
Sentence ESC, h, s Repeat last para formatting ESC, j, j

Line ESC, h, | Repeat last character formatting ESC, ¢,

All text in a cell ESC, t, h, a Enter straight single quote (" ') ESC, " / ESC, CTRL+'

Note: Avoid local formatting (font, size, bold, centre etc.) as much as
possible to ease maintenance of the document.

FM 8 handles Unicode The internal character set provides many special charac-
ters.For entry methods see FrameRoman character table on
page 25.
Internal character map & CharacizikEy f=1 IS Y
Eont: [0 Sembol =2 Help
+
CTRLq,S !V#EV&;()*+,—./01234ﬂ
® ™ . . slel|7[z]a] | [<|=|>]7|=]a|lx|a|Ele|r|B
ﬂ R © With 10p diameter... RN NEREEENGE B GEE
S G T Resistance: 178 W 4\3-'“5*;5?;’;;“’“””
1T 2 3 1 1 <l i il G g -
H Ya V2 Resistance: 178 Q \\ Tl welvia
1L w < |
5 6 7 8 9 : TS sl a]o]<]=[=]=]. [T <]x
> = (After copy/paste
FR| gD N D|(2|(z(c|c|e |8 |L| V| BB
Y v « » ... p ?ppéy c}i)arlalgtert)format TV R TR < eI T <
E F G H J Or ym O On Characters to copy : Select I Copy
Spell checking FM-7 supports 24 languages including variants such as Swiss

German and Swiss German (new). 4 dictionary levels:

Spelling Checker x| Hierarchy of dictionaries:

| 1 Language dictionary.

Comection: Iausser-nrdent-licher-weise Sh Hyphenatinnl 2 Site dictionary.
Check: i i
{+ Book

" Document
£ Cument Page

—» 3 Personal (Project) dictionary.

Optians. .. | p 4 Document dictionary.

Dictisnaiis...| Dictionaries 2 ... 4 mix languages.

Start Eheckingl Eu:u[rectl Learn | Allon ik Du:u:umentl inearnl

Hyphenation

Text Options x| t| Pagination' Numbering  Advanced |Tab|e CeII| Influences
V' Smart Quates V¥ Smart Spaces Automatic Hyphenation:

» Paragraph properties

Allowe Line Breaks &fter: . ) -
|f’-"| I e, # Adjacent; |2 Shortest Prefix |3 » Text OptiOl'lS

Shorte st Word: |5 Shortest Suffix: |3 D s .
Superscript Subscript Smal Caps: = Dictionaries

Size: [70.0% [Fo.0z [B0.0% W Hyphenate

» Options in spell checking

Stetch: [100.0% | [100.0% | [1000%
(g Lires I‘an° |7=n°

Word Spacing (% of Standard Space):
[

Task Enter in text in dialogues
Avoid hyphenation ESC, n, s \-

Optional hyphen CTRL+minus \-

Nonbreaking hyphen ESC, minus, h \+

Nonbreaking blank CTRL+blank \. (\, blank)



Paragraph and character formatting

Create a derived
paragraph format

Faragraph Designer

Paragraph T ag:

Ilwa-wide-list - I

Properties:

IBasiu: - I

T o Selection

Note:

Follow your template standards for naming formats! For exam-

ple, use x-name for chapter local items and z-name for layout
specific items.

1 Put the cursor into a paragraph with best fitting format
(e.g. Iwa-wide list).
wide list) wide list wide list wide list wide list wide list and
so on and so forth.
2 Define the new name (both in catalogue and selection).
Indents: Space: [V Tab Stops:
Easic | Diefault Fu:untl F'aginatiu:unl Numl:ueringl .ﬁ.dvancedl T able EEIII First: Above Pt
[0.0cm [Bope =] | [*0om L
|ndents: Space: ¥ Tab Stops: Left: Below Faf: @
First: dbove Pk |4'EI Em IE-EI pt ;I
[0.0cm [Bopt ]| |[F0em L
Left: Below Pgf:
[20cm [Eopt =] New Format x|
Right: Create a new paragraph format uzsing

Update All |

Faormats Tagged:
[g-rside-list

Commands: IEI y

ew Format...

Global Update Options. ..

Delete Farmat...
SetwWindow to bs |z
Reszet Window from Selection

the properties in the Paragraph Designer.
Tag: [hafE-wide-list
¥ Storein Catalog W Apply to Selection

Cancel |

TABs are absolute

v

abc) cd)

more text here)))

vV

ef)gh
target

3

Create Character style

Import a specific style

Modify the desired attributes (at best in the designer) and
check with Apply.

wide list b) wide list wide list wide list wide list

wide list and so on and so forth.

For titles specifiy “keep with next” in tab Pagination.
Click Update All to get the final definition into catalogue.

Select text to see the effect of your formatting.
Character Designer > Commands > Set Windows to As Is

Define the name of the format and set the appropriate
attributes (do not forget language), check with Apply.

In Commands > New Format activate both Catalog and
Selection.

In the source document select the paragraph (or string)
with the desired format and copy it to the clipboard.

In the target document paste the selection.

In the 9/fDesigner select Commands, activate both
Catalog and Selection and then click Create..
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Hierarchical numbering

Example

1 format
Ochapter
Theading
2heading
3heading
tt-table-title

ft-figure-title

The term hierarchical numbering refers to heading numbers
with hierarchical dependencies. For example a level 3 heading
depends on the numbering of the level 2 numbering, which in
turn depends on the numbering in level 1.

In tab Numbering of the paragraph designer you see only the
numbering of the current format, not the relationship to the
other formats in the hierarchy. To see the dependencies it is
good practice to set up a scheme.

We assume 4 levels of headings. The highest level is the chap-
ter heading. The others are section headings. In addition,
tables and figures shall restart their numbering in the main
sections: Tab. k.n.m: and Abb. k.n,m: (c: chapter-#, n:
number from the main section, m: number of table or figure).

The following table describes this scheme ( . denotes a
required blank):

Label, intro  chapter level 1 level 2 level 3 tables figures TAB
H: <$chapnum> <,=0> <,=0> <,=0> <,=0> <,=0> \t
H: <$chapnum>. <n+> <,=0> <,=0> <> <> \t
H: <$chapnum>. <n>. <n+> <,=0> <> <> \t
H: <$chapnum>. <n>. <n>. <n+> <> <> \t
H:Tab.. <$chapnum>. <n>. <> <> <n+> <> \t
H:Fig.. <$chapnum>. <n>. <> <> <> <n+>: \t

Syntactical elements

Fig-.

Building block
<n>
<a>
<A>
<r>

<R>

Interpretation

H: Label of the numbering range. This may be any upper- or
lower case letter or nothing for local lists.

<$chapnum> Chapter number (normally set via the book functions)
<3=0> Set counter to 0, but do not display (hence the leading blank).
<n+> Increment counter and display value (hence no blank).
<n> Display current counter value.
<.> Place holder in this column to get the matrix straight.

Tab.., . : \t Everything after the label and outside the <...> constructs is
displayed. \t creates a TAB character.

Numbering type and range Building block Meaning

arabic 1,2 ...17 ... 65535 <$chapnum> Chapter number

lower case a, b ... q ... aa, ab ... crxo (65535) <$volnum> Volume number

upper case A, B ... Q ... AA, AB ... CRXO (65535)

lower case roman i, ii ... xvii ... mmmmmmmmmcmxcix (9999)

upper case roman I, Il ... XVIl ... MMMMMMMMMCMXCIX (9999)

In tab Numbering of the § format ft-figure-title gets:
H:Tab..<$chapnum>.<n>.<.>.<.><.><n+>:\t

The 5t figure in the 2nd main section of chapter 7 gets the
following representation:

Fig. 7.2.5: Effect of the fragrance of lily of the valley to
the behaviour of cockchafers



Table handling

“Space above” The table anchor is here: L

(Table designer). Table 1: Table title (] format tn-tab-title-numbered)

Outside ruling o
Footing cells (repeated on next page) Foot Foot
Space defined by box

on Reference page. ®>a. This is a table footnote (] format ztf-table-footnote)
Space below———»

(Table designer) This is the next paragraph after the table, the ordinary text

I
“Gap” (Title Position)
(Table designer). Heading cells (repeated on next page) Head Head
.
. > - -
Column ruling Body cells (f format tm-table-middle) strads
Body Row ruling . dled
Y cells
I— a
Separators \ A footnote reference
Cell margin (Table designer) Rt
This cell is very large to show the
Cell margin from { designer, — > margins and surrounding areas straddled cells
“Table Cell” properties.

Individual ruling and
shading

Custom Ruling and Shading m

¥ Custorn Cell Ruling:

Apply Buling Style: To Selection:

Outside Edge:

IV Top ¥ Bottom
¥ Left ¥ Right

Inside Borders:

S I o o Select row CTR+double click at he far left/right of a
— cell.

¥ Custom Cell Shading

‘ FiII:I‘IDD°/° VI Color: |

\ Select clumnsCTR+double click into the middle of a cell.

Apply I Show Cument Settings.. |
Apply Ruling Style: To Selection:
[ ] Dutside Edge:
[ Top [T Bottom
05 _pt et T Right
1 ptwhite
1_pt LI Inzide Borders:
EditRuingSte.. | | ¥ Row W Column
Ausgewadhlte spalten konnen mit der maus skaliert werden.
Import table from Excel 1 In Excel select the table area and copy to the clipboard.

2 In FrameMaker paste with Edit > Paste Special...

Paste Special: text Paste Special RTF
You get a number of tabbed para- You get an anchored table, to which
graphs, which you convert to a table.  you apply the appropriate table format.

3 Select an appropriate Table format and format the
rows/the table according to the needs.
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Anchored frames

Anchored Frame m

Ancharing Position: IBB|DW Current Line ;I

Alignment: I Left ;I

[ Cropped [ Floating

Size:

‘ wiidth; |1 1.8cm Height; |5.5 cm ‘
Care |

Frame with caption

Anchor paragraph =

Title paragraph =

Importing graphics
Attention with png graphics:

When creating png graphics
do not optimise the palette
(less than 8bit colours)

png with less than 8-bit col-
ours create an entry into the
colour catalogue for each
colour in the png!

Inline graphics (icons)

Anchored frames are the universal container floating with the
text. Some forms are bound to a location on the page of the
anchor. Insert a frame with Special > Anchored Frame...

€ This (colour filled) frame is Outside Text Column. It con-
tains an imported graphic. The most used frame type for
graphics is Below Current Line:

This text is within a text frame
which is located in the anchored
frame. Use this form for longer ex-
planations in a graphic or side by
side to a graphic. Both | formats
and character formats can be ap-
plied. Tables can be anchored.

» The frame can either be filled with colour or have a border.

» There is no property frame title as it exists for tables.

1 Use a distinct paragraph for the anchor (e.g. za-anchor),
and define the following to become the next paragraph:

2 For the figure title define, for example, ftn-fig-title-
numbered. Specify Keep with previous (the anchor para-
graph). This Y may be automatically numbered.

Der froschkdnig war es nun end-
gultig leid, noch langer auf die
prinzessin zu warten.

Figure 1: The title (caption) for the graphic or the frame.

1 Select the frame into which you want to import the graphic.
If no frame is selected, FM places a default anchored frame
at the cursor location.

2 File > Import > File ... opens the dialogue to select the
graphic file.

3 Choose Import by Reference (use Copy into Document
only in rare cases, for example on reference pages).

4 In the next dialog specify a resolution (for bit maps). You
may later modify this with Graphics > Object Properties
or Graphics > Scale. Vector graphics are imported directly.

5 The imported graphic can be resized with the mouse also.

For this form &8\ yge the frame type At Insertion Point.
To move the frame up/down, use ALT+arrow on the selected
frame. You may wish to switch off the paragraph property
Line Spacing Fixed.



Graphics with FM tools

Graphic objects

Tool bars for graphic
work

Callouts

group ungroup

nudge (1pt at 100%) = ALT+arrow

The graphics palette defines graphic objects as well as prop-
erties for graphic objects. You may set the properties before
you create an object or apply the properties to selected

objects.

Ease graphic work with View > Options > Grid Spacing and
Graphics > Snap ON and/or Graphic > Gravity on.

Intelligenter cursor (objektabhdngig)

Cursor fur grafische objekte

Linie = ™. T Bogen (kreis, ellipse)
Rechteck ||| Rechteck mit gerundeten ecken
Offenes polygon [*7 ||| Kreis, ellipse
Geschlossenes polygon [-7|4. || Freihandlinie, spline

Textrahmen
Graphikrahmen
Fullmuster festlegen
Linienmuster festlegen
Linienstarke festlegen
Linienende festlegen
Linientyp festlegen
Farbe festlegen
Farbtonwert festlegen

Uberdrucken festlegen

to front/back  ditribute

reshape

Text zeile

Fillmuster zuweisen
Linienmuster zuweisen
Linienstarke zuweisen
Linienende zuweisen
Linientyp zuweisen
Farbe zuweisen
Farbtonwert zuweisen

Uberdrucken zuweisen

flip scale obj.prop.

0 x:-'J .'\I_l E_I

snap gravity

align multiple objects (on last selected)

turn (15° incr.) solid dashed

;gii;lﬁ:i Umlﬂﬂﬁlﬂﬂu!%li%lél ﬁFlﬂH! o i-f.i

A graphic object is either filled or has a border, not both.

Do not place numbers and text into the graphic itself. Overlay
these in the FrameMaker document to maintain constant font
size for the legends (and ease translation).

O

44 - overlay centered
and group

- copy/paste and edit figur@ @

S€ a text frame for longer explanations.

Both | formats and character formats are

possible. Borders cling to the contents.

A text line can only use character formats (here: ft-fig-text).
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Canned text

Variables
Typical variables

Edit User Variable

MName: ||:-r-:-:|u-:t_narne

Diefinition: |Framet sker course TR

User Variables: Character Farmats:

arrow <Default 1 Fonts
fr+en-version < 0-nio-language
rianual nuriber <1-highlight>

< 2-highlight

< F-highlight>
<bodypfonty

< computers

< cyrillic

revizion_lewvel
verdor

sdd | Change | Delet

Cross reference to text
on reference page

Cross-Reference x|
Source
Document: lm Goto Source |

Source Type: B Source Text: Page Reference

Format: Iheadlngﬂt\e ~ | Edit Format... |
<Sparatexd >
Text inset

Layout items
Usage

Set up

Plug in AutoText

Canned text reduces redundancy and eases maintenance of
standard text (e.g. warning texts).

Product-name, revision-no, revision-date, author, copyright
date, manual-no, vendor.

Use for book-wide definitions. Use special names (e.g. x-name)
for chapter-wide definitions (must not be distributed via
book).

Open dialog via Special > Variable... or by double clicking on
a variable in the text.

Variables can contain text and highlights, but no other varia-
bles.

The maximum length in FM-8 is 1022 chars for UTF-8 text.
This includes the notation of character format, e.g.
<l-highlight>. Use </> to switch character format off (in
place of <Default Y Font>).

Open dialogue via Special > Cross-reference... and search in
the current document for the relevant paragraph format,
select the paragraph:

This text is located on the reference page Reference in a text
frame with the flow name caveat. For finding this text easily it
has the paragraph format x-bodytext and not just bodytext.
However, you can also include this text into the body pages as an
inset. In case of an inset the name of the flow is relevant.

(The coloured background is on the current page).

Only single paragraphs can be referenced. However, mainte-
nance of these texts is easy: double click on the text to get the
dialogue Cross Reference where you click on Go to Source.

The purpose of the text should be recognisable within the
first few words because display in the dialogue is limited.

A text inset can be of arbitrary length (e.g. multiple para-
graphs). See Text insets on page 14.

Special pages, such as the last page of a chapter, containing
company address etc. Another usage is the famous This page
intentionally left blank in loose leaf publications.

A master page with name Last contains the text frame with all
the text. The text frame must be of type background, other-
wise the text will not appear on the body pages.

All FM constructs such as complicated tables, lists or figures
in frames can be handled. See AutoText on page 19.



Cross references

A document template provides a number of cross reference
formats. The text “See” or “See on page” shall not be part of
the cross reference format, because they may be needed in
several forms.

Cross reference to 1 Open dialogue Special > Cross-reference...

I"\’\I"’\"I"’\“lﬁ

x| 2 Select Source Type Paragraphs. The list of paragraphs for-
Source: mats are displayed under Paragraph Tags.
Dot Curer =] Goto soue | 3 Select the tag name for the target of the reference (e.g.

Source Type: E Source Text: Pages 24
Paragraph Tags: Paragraphs:

2heading).

4 Under Paragraphs you see the texts of these paragraphs to
choose from. Select the appropriate one.

= arzp
eading-notoc Cregte Character style

readngnaoc | PEECISIFEREEYE r 5 Under Format select the appropriate format for the refer-

ence: heading & page. Below the drop down list you see the
pattern of this format:

Format: Iheading 4 page | Edi anﬂai...l _hi -
s <ot < o e oo <l-highlight><$paratext></> on page\ <$pagenum>
[ met | CometioTer.| Concel | The main building blocks of this cross reference format are

$paratext providing the text of the target paragraph and
$pagenum, the page number of the target paragraph.

6 With Insert the cross reference to the target is inserted at
the current cursor location: Create Character style on page 4

Modify cross reference If a special format is needed, modify an existing one with Edit

format Format:

Xl 1 In the Cross Reference dialogue select the most appropri-
Name:  [readngttie ate format and click Edit Format.

Definiton: 2 Provide a new name, e.g. heading title mod and click on

Add to get the new name into the list.

Formats: Building Blocks:
ZZﬂ;ﬂSiEZZ?ewaﬂ P 2| 3 In the Definition build the generation pattern with fixed
Pk text and building blocks from the list. The list starts with
. J <Sparenumonly> system variables and continues with character formats.
“PageMumDocToc = | |<Sfilename: d

Set up the new format, for example
<2-highlight><$paratext></>

[ | e | </>is shorthand for the building block <Default { Font>

4 Click Change to store the new definition and Done to leave
the dialogue.

Add | Change | Delete |

5 In the Cross Reference dialogue click Insert to apply the
new format for the selected target reference:
Create Character style

Cross reference to other
files

v

The target file must be open.

» In the drop down list Document select the appropriate tar-
get document and find the relevant paragraph or cross ref-
erence marker.

10
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Books

Set up book from init
chapter

A E:\FM-course\

=10 x|
% EM\FM-course“handout®handout book -
—Q title-pages fm

e8] handout TOC fm

8] handout!¥fm

B
—Q texthandling fm

—'E styles fm

—Q tables fm

—'E layout fm

—Q graphics fm

—'E references fm

—Q boal fm

—'@ generated_docsfm

—Q acrobat fm

—'@ formulas fm

Y htmlfm

—'@ specials.fm

—Q tips fm

—'@ rulesofthumb fm

—Q miscellenaous fm
- |
4 L2

Pages: 1- 22 =X 0TH

ial

Setting the numbering
properties of a book file

Numbering Properties m
Vulumel Chapter ?PGQE I F‘alaglaphl Footnotel Table Footnotel
IPage ;I
' First Page H: IT Format: INumenc (14] ;I
" Continue Humbering from Previous Page in Book
£~ Read from File

=

[Mo Unda)

Distribute formats

A FrameMaker book is a list of files (with properties) stored in
a book file. The book contains layout definitions from the file
from which it was initiated. These are used for generated files
such as TOC or index.

A book is set up to provide homogeneous numbering over
chapters and to be able to generate lists (such as TOC) and
indexes from the collection of files.

1 In the chapter file which shall become part of a book, use
File > New > Book.

2 You are asked whether the current file shall become part of
the book. Answer Yes.

3 The book dialogue opens with the (absolute) file name
entered.

4 Save the book with an appropriate name. The file name of
the chapter file w ill become relative to the book.

5 Add more files to the book. You may drag file names from
the Windows File Explorer into the book window.

6 Rearrange the file names by drag and drop.
Set up the numbering of the book files (see hereafter).

Set up a numbering scheme for the whole book to overview
the numbering process, for example:

File Vol. Chapter Page number Paragraph Footnotes
title 1 0 1 roman restart 1
booknameTOC ~ same same continue roman continue continue
introduction same next 1 arabic restart continue
planning same next 1 arabic continue continue
working same next 1 arabic continue continue

1 Select the file in the book and open Format > Document >
Numbering.

2 Choose the required tab and define the numbering accord-
ing to the desired scheme.

3 Continue to set all numbering properties of the current file
and then advance to the next file in the book.

4 Apply the settings with Edit > Update Book (or icon & ).
This will renumber the items (paragraphs, pages, etc.)

1 In the book window select the target files for the formats.

2 In File > Import > Formats select the source file and define
the format categories to be imported and distributed.

Category Document Properties covers a great set of properties
and hence need to be handled carefully!

11



Table of contents

Generate TOC from a file

Set Up Table of Contents m
Suffie: |TOC
&ddFile: [Before handoutTOE im =l
Include Paragraphs Tagged: LDon't Include;
[0chapter-title: Ochapter-titleTOC ﬂ
[1heading TheadingTOC
heading =] headingTOC
—y Zheading-natoc
Bheading
SheadingTOC |

¥ Cieate Hypetest Links

Table of contents 1]

Fererate TOC froma file 1

Format the penerated TOC 2

Btandard formathng for the TOC entres A
_]Tab]e of contents within a text document 3]
T0OC imported to the current flow 3]

{TOC Imported to nested text frame 4§

Chapter TOC

Generate TOC for a book

Set Up Table of Contents m
Suffi. |TOC
&ddFile: [Before handoutTOE m =
Include Paragraphs Tagged: Don't Include;
[Ochapter-title [Ochapter-titleTOC ﬂ
[1heading TheadingTOC
oheading E=| headingTOC
—y Zheading-notoc:
Sheading
SheadingTOC |

¥ Cieate Hypestest Links

Table of contents 1]

Generate TOC from a file 1

Format the penerated TOC 2

Ftandard formatting for the TOC entries 2]
[Table of contents within a text document 3
H’DE imported to the current flow 3]

_]TUE Imported to nested text frame 45

1 Enter the document from which you want to generate the
TOC and select Special > Table of Contents...

2 You are prompted whether to set up a TOC as part of a new
book or as an independent file. Click Yes.

3 In the dialogue Set Up Table of Contents move the para-
graph styles, which should appear in the TOC, to the left.
(You can move all items from one side to the other by holding
SHIFT while clicking on the arrow button).

4 Normally you want to generate hypertext links: click the
selection box.

5 Click Set. A new file named documentnameTOC.¥m is created
with default presentation of the TOC.

When working with a template, the document file contains
definitions for xxxTOC paragraphs which will be used and
the generated TOC looks final.

6 Save the file. Do not change the name of this file!

7 After changes in the original document file you must
update this TOC file: in the document file follow steps 1 - 6
from above. Since you already have a TOC file from step 6,
this will be used for the re-generation.

A TOC generated from a document file can be used as a text
inset in the document itself. To get correct page numbers you
must update after the insert both the TOC file and Inset in the
container file!

1 In the book file select the file before/after you want to
place the TOC and select File > Add > Table Of Contents.
In the book a file booknameTOC.¥m will appear, then opens
the dialogue.

2 Define where you want to add the generated file into the
book (before/after the selected file).

3 In the dialogue Set Up Table of Contents move the para-
graph styles, which should appear in the TOC, to the left.

4 Normally you want to generate hypertext links: click the
selection box.

5 Click Set. A new file named booknameTOC.¥m is created with
default presentation of the TOC.

When working with a template, the book file contains defi-
nitions for xxxTOC paragraphs which will be used and the
generated TOC looks final.

6 Save the file. Do not change the name of this file!

7 After changes in document files of the book you must
update this TOC file with Edit > Update Book...: Assure
that the TOC file is listed under “Generate”.
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Index

Insert an index entry

ke

tarker Type: IlndeH
tarker Text:

-

[

index: define an entry:markerindes entry

MHew Marker |

=
[

Edit an index entry

Blanks in index entries

Multi level entries

Multiple entries in one

marker

Special characters in

index entries

Generate index for a

Set Up Standard Index m
Suffi |12
Add File: [ I
Include Markers of Type: Don't Include:
Index uthor -
P [Comnment
Conditional Text
- CrossFief
lE quation
Glossany =l

F Lrsats Hyperteit Links

Set

Cancel

Index entries are markers of the type index.

1 Place the cursor at the desired point. Prefer the end of a
paragraph for the location! Translators will love You!

2 Special > Marker opens the dialogue Marker. The marker
type Index might be selected already. If not, select this
type from the drop down list.

3 If you have selected text, or do so while the Marker dia-
logue is open (it stays open), the selected text appears in
the box as Marker Text. The marker will be placed in front
of the selection.

4 Change the marker text to your desire and insert the
marker with New Marker.

» Open the dialogue with Special > Marker.
» Find (or directly select) the relevant Index Marker.

» The dialogue will get the marker text to be modified. The
button to be clicked now reads Edit Marker.

Blanks may be arranged around the colon and the semicolon
which have syntactic meaning in the entries. These blanks do
not appear in the index display. Required blanks (e.g. to keep
words together) must be inserted as \. (backslash, blank).

Multi level entries are separated by a colon (:). The following
example will create a main entry abrasion and a sub entry gla-
cial: abrasion: glacial

Multiple entries within one marker are separated by a semico-
lon. This is for example useful to place all permutations of
multi level entries in one marker:

character: delete; delete: character

Colon, semicolon, < and > are syntactic characters in Index
Marker entries and must be ‘escaped’ for literal use:

Income \> 100 millions; fruit\: vitamins for all
vegetables: cucumbers\; beans\; cauliflower

1 In the book file select the file before/after you want to
place the index and select Add > Standard Index.

2 In the dialogue Set Up Standard Index the appropriate
marker type is already selected.

3 Normally you want to generate hypertext links: click the
selection box.

4 Click Set. A new file named name booknamelX.fm is created
with default presentation of the Index.

5 For updates the same procedure as for TOC applies.
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Text in

sets

Dieser text rahmen steht auf der referenz
seite Reference des aktuellen dokuments.

Note:

Insert an inset

Source: E:NFM-coursehCra..

Flow to Impart:

Aerash-course. fm

" Body Page Flow:

{*' Reference Page Flow:

INone Avallable hd I

ToC vI

Formatting of [mported Flow:

ToC
[P

% Feformat Using Curren

DocTOC

while Imparting, RemofsEyfHmes
[~ Manual Page Breaks
[ Other Format Ovenides

" Feformat a3 Plain Text

" Fetain Source’s Formatting

b azterPa

Updating of Imported Flow:

0 Automatic
" Manual

» Avoid duplicate information by referencing predefined

text.

» Any text flow in any document can be used as an inset.

Hence the inset may come from a reference page of the
container document:

flow caution-esd

B B e P

8 A CAUTIONS :

P i i |Device may be damaged by Electrostatic Discharge :

N “ MEDIACLAVE electronic boards must not be touched without taking H

;1 |ESD protection steps such as use of an ESD wristhand or electrostatic :
conductive shoes §

B oo B .

» For easy insertion use the same styles in the inset as for

the container document.

Variables are resolved only one level deep.

At the desired location start an empty paragraph with a no-
breaking space (CTRL+space) and locate the cursor before
this blank.

With File > Import navigate to the file with the inset flow.
This may be the current file to insert from the reference

pages.

Choose the type of flow to be imported (master page or ref-
erence page) and select from the drop down list.

Normally you choose Reformat using Current Document’s
Formats.

Click on Import to insert the flow at the cursor location.

/\ CAUTION

shoes.

Device may be damaged by Electrostatic Discharge.

<product name> electronic boards must not be touched without taking ESD
protection steps such as use of an ESD wristband or electrostatic conductive

Organise insets

Cross references

The no-breaking space assures correct formatting of the
anchoring paragraph caused by the first paragraph in the
inset.

Name the flows with their purpose/contents. For example,
name the flow warn-hot, caution-esd, info-customs.

You may set up a project specific document with insets
(various body pages with various flows).

Do not place cross references (inset = container) in an
inset, because the container changes!

For references from the container to the inset define a cross
reference marker (give it useful content) in the inset to which
you refer from the various container documents.
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Conditional text

Note:
Define a condition

Tag |Elperator|
Condition Indicators:

‘ Style: INumeric Unde;l Color: IMagenta ;I ‘

Lelete | Cancel |
Apply a condition to text
Conditional Text m
Current Selection |x:
" Unconditional
' Conditional
In: Mt In: As s
Comrment
0 perator
e |
dpply | EditCondiion Tag.. |  Show/Hide.. |

Display the conditional
text

Note:

Show/Hide Conditional Text | x|

= Show Al
% Show Hide:
Do <|
- |
W Show Candition |ndicatars
Cancel |
Note:

Table columns (or individual cells in a table) cannot be made
conditional. Only whole table rows can be conditional.

1 In Special > Conditional Text > Mange condition... click
on Add or Edit.

2 (For Add) provide the new name in the edit box and select
an appropriate style and colour for the display (this style is
not used for printing!); click Set.

3 The condition is now listed in Manage Conditions dia-
logue.

1 Select the text which will receive the condition (for example
“comment”)

2 Special > Conditional Text > Apply Conditional Text... If
you do not see the desired condition tag in the “Not in:”
column, you must first set up this tag.

3 Set the current selection to Conditional (radio button) and
move the desired condition to the left column (“In:”) and
click Apply.

The text with the condition gets a special appearance accord-
ing to the settings of the condition tag:

Hidden conditional text is represented by a maker symbol (T).

If you delete a Conditional Text Marker you actually delete the
conditional text!

To display (and print) text with and/or without any condition:

1 Select Special > Conditional Text > Show/Hide Condi-
tional Text.

2 To display (and print) everything, activate the radio button
Show All.

3 To display (and print) only certain condition texts,

- move the conditions into the appropriate column (Show
or Hide).

- Activate radio button Show as per Condition
4 Click Set
You may move all tags at once with SHIFT+click on an arrow.

The condition indicators (underlining, colour) are only visible
if Show Condition Indicators is checked.
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Create PDF
Save as PDF

PDF Setup (x|
Settings | Bookmarks | Tags | Links |
FOF Job ptions: [ High Quaity Frint [~
Open PDF Document on Page |1 5t Zoom IDefauIl -
™ iew Generated PDF in Acrobat
Pegistration Marks: [More =1
Page Size: ‘ Wwidth: [21.0cm Height: |29.7 cm |

Page Fange: ‘(: Al Start Page: [1 End Page: [14 |

IF you select a page range other than “All", generated
PDF will exclude Bookmarks, Tags, and Hyperest links

Set Cancel
PDF Setup x|
Settings 5E‘Eo‘i{‘m§i‘k§“l Tags | Links |
Bookmarks - I

Include Paragraphs: Don't Includs:

[¥ Generate PDF Bookmarks Baookmarks Expanded through Level: IW -
|

. Ochapter-title lOchapter-titleTOC
Theading [1headingTOC
. .. 2heading [2headingTOC
dtr-doctitle-right L I [2heading-notoc
[Fheading
e I [FheadingTOC
[4heading
Sheading =
< Eookmark Level > Get Defaults
™ Include Paragraph Tags in Bookmark Text
™| Auticles: | Thread by Test Frame -
Set Cancel
Note:

FHOL T ays mangs.

@ Al Stat Page: |1? End Page: |1? |

= Odd-Mumbered Pages I Even-Murmbered Pages
V¥ Collate ™ Last Sheet First

I" Skip Blank Pages [~ Spot Calar &z BlackAwhite
™ LowResolution Images

Registration Marks: INone ;I

™ Thumbnails - Frews: |2 Cols: |2
Copies: |1 Scale: |1DDX
W Print to File: Browse. .. |

|E AF-coursehCrash-courseshfm-8-entim-8-en.ps

‘ = [ Bttt Separations Separations Setup... | ‘
[V Generate Acrobat Data FDF Setup... | ‘

‘ Printer:  Adobe PDF { ‘

Frint | Cancel |

With File > Save As... a standard Windows dialogue opens.

In the bottom list Save as Typ select PDF and define a file
name documentname.pdf in the name field.

After clicking Save the PDF Setup dialogue appears which
has 4 tabs for various settings.

In the Settings pane you define

- The set of Distiller parameters (Job-options)
- How the PDF document should open initially.

- Registration marks are only necessary if you want to
print on smaller paper and see crop marks to trim the
paper.

- Further parameters normally need no change from the
already set values.

In the Bookmarks pane you specify which items you want
to have in the bookmarks pane of Acrobat/Adobe Reader.

- Define bookmarks from the heading levels with the <---
and ---> arrows. You can move all items from the left
pane to the right one (or vice versa), by holding SHIFT
and clicking the ---> (<---) button.

- Set the appropriate level of the bookmark with the <<
and >> buttons.

- To have the bookmarks closed to the first level, enter 1
into the drop-down list Bookmarks expanded through
Level.

Normally you uncheck the first check box both in the panes
Tags and Links.

Click on Set to initiate the generation of the PDF. Distiller
will appear automatically. It disappears after some time as
long as FM is open.

Automatically generated hyperlinks in TOC and Index as well
as cross references are live in the generated PDF.

Printing with Adobe PDF printer

1

For the document (or the book file) use menu Format >
document > PDF Setup to define the Distiller Job Options,
Bookmarks etc. See Save as PDF.

Open File > Print and activate

- Print to File and specify a file name (where you have
suffient space for a large file).

- Generate Acrobat Data (to get bookmarks etc.)
With Setup... select the printer Adobe PDF (formerly called

Distiller printer) and in Print Setup click on Properties...
There deactivate Relay on System Fonts only ..

Leave Printer Setup and in Print Document or Print Book
click on Print. & The resulting PS (PostScript) file must be
processed by the Distiller afterwards.
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Equation editor

rertical and horizontal list elements times
=
Relations Matrices Pasitioning
5 Calculus Runctions /

=Y A A

= 5 .

41 i ?'_' ) ?.1. "_'? .1?
Vo] A? ﬁ' 2/ lo..10% ot
[]=? DE? f J_ 710 L

32 | -2 |/t | o | o |2
superscripts, subscripts potence, power

Distinguish opertors !

Strings in formulas

The equation editor (formula editor) is controlled from a spe-
cial palette, which opens from Special > Equations ... or with
button at the right border of the document window E‘

The equation (or formula) is a special object created in an
anchored frame. It is not just a graphic.

An in-line formula is inserted in an ordinary paragraph,
rather than in a paragraph of its own.

Most time you will need to specify “no fixed line spacing” to
the anchoring paragraph give room to the formula. The frame
can be treated like any other anchored frame (border, back-
ground):

_ JB5-1
2

Such simple formulas can be entered directly from the key-
board:

- b Proportions of Golden Rectangle.

Typing Result Explanation
ESC m 1 Insert large equation (frame). The highlighted
? ? is the ‘entry point’ of the formula.
a= The new ‘entry point’ is the ? after the equal
a=7? sign.

\sqgrt Function names like sqrt, pwr, log etc. are
ENTER a= ﬁ preceded by a backslash and terminated by
ENTER:

5 space The ? is replaced by 5, the two spaces select

space a= the 5, then the square root as a whole.

-1 The “minus one” is attached to the selection,
a=.5-1 not just to the last entry.

space JE _1 The blanks select the 1, then -1, then the right

Space a=——>5— term. The slash creates a fraction bar below

space / ) this selection.

2 space 5_1 Selecting the right term provides the entry
space b a = Tb point (?) to the right. A variable is displayed in
italics.

ESC m p J5-1 Shrink wrap the formula. Then apply “variable
a = Tb line height” to the anchoring paragraph.

More complicated formulas require selection of math objects
from the Equation palette and enter items at the highlighted ?

Strings are required, for example to enter physical dimen-
sions or for ‘wordy formulas’. You start the string with " and
terminate it with RETURN:

SuCCess = expenditure
effort
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Special layout

Assign master page

Master pages for rotated
tables

1

Create master page in por-
trait mode (e.g. copy from
Right) and name it appro-
priately (e.g. Rotated-
right)

Rotate page with Format >
Customize Layout >
Rotate page clock-
wise/counter clockwise.

Rotate central text frame
back. The heading/foot-
ing area will remain
rotated.

Multiple columns

A FrameMaker document may contain a (nearly) arbitrary
number of master pages, for example, title, last,
landscape-left, landscape-right).

For ordinary pages the master pages Right and Left are
assigned automatically. Other master pages are assigned with
Format > Page Layout > Master Page Usage...

Rotated tables are not rotated themselves but located in a
rotated text frame:

Text is oriented this way and tables are
placed normallyL

here you can edit the table similar to the text

pa1el04 S| eaJte bul0o4
paje10. S| eaJe bulpesy

Hecate est Iovis et Latonae filia, soror
Apollinis. Est tricopor et triceps,
magicarum artium magistra ac
fascinationum praeses, cinctra
latrantium canum turma; noctu stans in
triviis vel prope sepulcra et ubi taminata.

If for some reason you keep the master page in portrait mode
and just rotate the inner text frame, you can not directly edit
a table anchored in this text frame.

You can not change the number of columns within a flow. To
insert pages with other column layout than the standard
pages you need disconnected pages. The text within these do
not flow/reflow if text amount is changed.
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Useful addenda

Enhanced tool bar

These are plug-ins install as dl1”s (except the first one) and
hence do not need the FrameScript interpreter (which is a
plug-in by itself).

= Two button groups only, not four.
* Additional useful commands, e.g. F4 to repeat Y-actions.

R s e e T e R e 3 ) e Eaa P 2 b B e B e B e R N S B E P PN e e

| X|E[@e| @[ <[~|[P B|[U|alah| ablabas| .|| =2 S0 e (R 2| E5(EE = L

dy = [oetaurnFont =] [4dal = o EBEE = BElGwEE S ] QA o] Blm]a |
The Enhanced Toolbar at www.daube.ch is based on the works
of Microtype.

AutoText Inserts FM constructs (pictures, tables, text) via menu or
B shortcut. Installs menu item AutoText. The names in the sub-
 int menu (Hint, Warning etc.) are defined in an FM document an

Wit hence can be of any language.

E-mail Address
Street Address

Recording Icons Elay
Sto

Callout
Pause

Sample Table East Forward

Archive (for books)

Cleaning tools
Tools

Characters »

List Character Usage
Delete Unused Character Tags

Readability *»

Create Character Tag List
Remaove Non-list Character Tags

Create Conversion Document
Convert Characters

Remove Overrides
Find Next Override

v Skip Master Pages

Generate Character Tag Report

About Character Tools...

Poerful script collection

= An FM document contains the constructs.

* One set of items per FM-installation, but menu can contain
submenus for subsets of items, for example, icon collec-
tions.

Source: Silicon Prairie Software, USD 10.-

This plug-in collects all referenced graphics and text insets
into two subdirectories. Usage: File > Utilities > Archive doc-
ument.

*= Useful to clean out the graphics directory.

» Useful to store a project on a CD or the like.

* Unicode in file names is not supported.

Source: Bruce Foster, USD 25.-

These tools support the migration from old to new style defi-
nitions. Installs menu item Tools.

» Report used and unused styles to judge the need for clean-
ing the document.

Eliminate unused tags for paragraphs, characters and
tables.

* Rename tags for paragraphs, characters and tables by
means of a conversion table.

= Local overrides can be searched and eliminated.

Source: Silicon Prairie Software. Character Tools, Paragraph
Tools, Table Tools: USD 10.- each.

Another (more expensive) source for equivalent tools is
Squidds.de.

www.i-frame.itl.info provides a layered set of scripts for vari-
ous purposes (many for free). Precondition is the plug-in
FrameScript.
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Migration

Prepare the current
document

Import new styles

Check the import

Alternative method

To apply a new template to a current document some steps
are necessary:

1

Remove all unused styles (paragraph, characters, tables)
from the current document. Also remove unused colours
and unused cross reference formats. Without tools this is
quite laborious.

Remove unused master pages and unused reference pages.

Rename used styles which have different names than the
new template. Table driven tools are of great help here.

Import styles from the new template. Also import the mas-
ter and reference pages. In File > Import > Formats check
the boxes: remove Manual Page Breaks and Other
Format/Layout Overrides.

Styles with similar names in both the current document
and the new template get the new definitions.

Carefully check the updated document and apply new over-
rides (for example, page breaks) as required.

If old style names still exist, rename them to x-oldname to
indicate that they exist only in this document:

In paragraph designer select the style, change the name
and then Update All. You will get a prompt to allow the
new name.

Apply similar changes to character or table styles which
have old names.

For large differences in style the following method may be
useful.

1
2

Create a new document from the template.

In the old document select all text (CTRL+a) and copy it to
the clipboard.

In the new document Paste Special (Text only). Tables will
be inserted as paragraphs with TABS. You do not get
anchored frames yet.

Apply the appropriate styles (paragraph and character).

5 Reconstruct the tables with new format:

- Select the paragraphs to become the table.

- Select Table > Convert to Table...

- Select the appropriate table format and click Convert.
- It may be necessary to re-arrange and/or straddle cells.

Reconstruct the anchored frames:

- Copy the anchored frame from the old document.
- Paste it to the desired location in the new document.

- You may need to apply new styles to Text Lines (created
with A-tool) and text in text frames, adjust line thick-
nesses etc.

Archive the old document. It may be necessary to get some-
thing out of it later.
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Import from Word

Precondition

Although it may look tedious work the following method is
the safest - and in most cases fastest - method to import text
from other applications, in particular, MS Word.

This method avoids the pollution of formats which are gener-
ated by the import filters which try to keep as much as possi-
ble of the source appearance.

A clean FrameMaker template with all necessary formats for
paragraphs, character, tables, cross references etc. is key. If
necessary the catalogues will be extended.

Prepare the Word file

Export graphics to
distinct files

Resolve anchored frames

Clean up the text

Save the Word file

Create a copy of the document and prepare this copy for the
import to FrameMaker:

= Export all graphics to distinct files (if you can not find the
original location of the graphic files).

» Convert Word graphics to distinct graphic files.

= Resolve anchored frames

* (Clean out text

Users of Word most time copy graphics into Word. Approved
practice in FrameMaker is to import graphics by reference.
Hence you may first create these graphic files (or find the
orginal location). A Utility such as Office Image Exporter may
be of great help.

Word graphics are available only in Word. They must be
extracted also. See Convert Word graphics on page 23.

After exporting all graphics delete them in the Word file.

Anchored frames in Word can be converted by FM-8 to FM-
anchored frames - but the process is not reliable. Hence select
all contents and place it outside the frame. Then delete the
frame.

Remove hard page breaks.
Remove hard line breaks if they serve only layout purpose.
Remove hard hyphenations and optional hyphenation.

v Vv Vv Wwv

Remove field functions (such as TOC). In FM there are dif-
ferent mechanisms for most of them.

Save the cleaned document as RTF. The version of RTF saved
depends on the Word version and can not be determined from
the file.

Import the RTF to FrameMaker

1 In FrameMaker import this file to a location where the 9
format is Body or bodytext (if this is appropriate for most
of the text).

2 In case the document has been saved as .doc (Word file),
select Microsoft Word in the dialogue Unknown File Type.
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Format text in FM

Note:

Note:

When applying formats with a designer (Paragraph Designer,
Character Designer), do not use Update All, but Apply (to
selection only). User Update All only if really the catalogue
should be be updated!

The FM document looks nearly as the Word document,
because the filters try to keep the appearance. The document
does not yet contain any FM styles from the template. These
are now applied.

Some discipline is required to avoid to many left out * for-
mats.

1 Start with applying headings. First apply main section
headings, then sections, then subsections. With a tool such
as the Enhanced tool bar on page 19 it is easy to repeat for-
mat applications.

2 Standard running text gets the format Body (or bodytext).

3 When applying list formats the bullets and numbering fig-
ures are placed before the Word elements, which must be
removed (see Clean up the import on page 23).

4 Tables got the Format A during import. Hence the neces-
sary table format must be applied. Both horizontally and
vertically straddled cells are handled correctly by FM-8.

5 Word does not know about table title and heading rows.
Hence these must be reconstructed:

- Select and cut the body rows to be converted to heading
rows.

- Place the cursor into the now topmost row and with
Table > Add Rows or Columns add the desired number
of rows To Heading.

- Select the empty heading rows and paste the rows from
the clipboard with Replace Current Rows.

- If a table title is defined in the new template, set it up.

6 Format all cells (header, body, footer) with the appropriate
paragraph formats.

7 Vertically straddled cells are not handled properly in FM-7.
These must be reconstructed.

8 Apply the necessary character formats.
9 Insert the graphics (see Place the graphics on page 23).

10Search through the whole document for formats with local
overrides (* prefix in the information area). Walk through
the lines with the ¥ key (in tables with TAB key through all
cells). As soon as you notice a * in the information area the
format has local overrides (or not yet an FM format).

With tools (see Useful addenda on page 19) the cleaning of doc-
uments can be accelerated significantly.
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Clean up the import

Note:

Remove numbering

Remove bullet symbol

Place the graphics

Bullets or other list introducers as well as numbering must be
removed from the imported list entries, because in FM they
belong to the property Numbering.

In the following do not use Change All even in so called obvious
cases. Always use Find or Change & Find.

Set up Find/Change with Wildcards ON and this find pattern:
[1-9] -\t for single figures and [1-9][0-9] .\t for two figure
numbers. Of course, the period may also be a parenthesis in

certain cases. The Change field is empty to delete the item.

If the bullet symbol is from the standard font, then it appears
as - However, if it comes from Wingdings or Dingbats etc,
then you see the base character in front of the list lines, these
may be é, U or everything else. Start your search pattern with
the first symbol coming along (Wi ldcards must be ON):

[=1\t and extend as soon as you discover more of these:
[=é*8c]\t

At the desired locations import the graphics and let them use
the default FrameMaker anchored frame. When you (like me)
prefer to use specific anchored frames:

» Define an anchored fram Below current Line using the
width of the full text column, right adjusted and 2 cm high.

» Import the first graphic into this frame and align it (e.g.
with a margin of 2 mm on top). At this stage the height
might not be sufficient for the graphic, but leave it.

» Select the frame with the graphic in it and copy this con-
struct to all other places where graphics shall be placed.

» Replace the graphics in the frames 2 ... n with the correct
ones. They will be adjusted already. Adjust the height of all
frame and check the graphics.

Convert Word graphics

Method 1

Method 2

Word graphics can be copied and directly pasted into FM
(they are WMF objects). However it will very difficult to
extract them from FM for further use. Hence it is better to
paste them into a graphic application and save them to a file.

» Generate a PDF from the Word document. It may be useful
to delete all pages without graphics first.

» In Adobe Illustrator (or another program capable to edit
PDF) import a page from this file.

» With appropriate operations (such as ungroup, remove
crop mask etc.) get access to all relevant objects.

» Select all relevant graphic objects and copy them to a new
canvas.

» Save this graphic as PDF or eps with preview. You may crop
the PDF in Acrobat to the desired size, if you did not spec-
ify a proper canvas size.

» If the graphic application correctly handles WMF it is possi-
ble to directyl paste the graphic into it.
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Recommended

Zoom factors

[Preferences]

Line widths

[Preferences]

Snap and grid

Template path
from

to (for example)

Smart quotes

setup of FM

Much behaviour of FrameMaker is defined by settings in
maker.ini. In Windows 2K and above there is a local copy in
the user area (%APPDATA%, for example

C:\Documents and Settings\Klaus Daube\Application
Data\Adobe\FrameMaker\8.0) which has precedence.

Set the zoom factors to values which are most useful for your

paper size and monitor sizes. For example, for an 20" display:

Zoom=28, 36, 50, 74, 90, 125, 200, 353, 500, 1000

When zoomed to 353% a nudge (moving an object by
ALT+arrow key moves by 0.1 mm steps

The default line widths are rather coarse; better may be:
PenWidths=0.1mm, 0.25mm, 0.35mm, O.5mm
In dialogues the values will be displayed converted to pts.

These can be set to be in the state most users wish for new
documents. The actual state is saved in the document.

If you want to get document templates from a special loca-
tion, change in section [Directories]

TemplateDir=templates
Templates=templates

TemplateDir=D:\_doc-std\Frame
Templates=D:\_doc-std\Frame\FM-templates

For better handling set section [Spelling]Jup with symbols:

SmartQuotes=\xd4\xd5\xd2\xd3 ;English € 7« u2018, u2019, u201C, u201D

; SmartQuotes=\xe2\xd4\xe3\xd2 ;German > © . U201A, u2018, u201E, u201C
; SmartQuotes=\xdc\xdd\xc7\xc8 ;French “ 7 « » u2039, u203A, uO0OAB, u0OO0BB
; SmartQuotes=\xdc\xdd\xc7\xc8 ;Swiss < > « » Uu2039, u203A, uO0OAB, u0OO0BB
; SmartQuotes=\xd5\xd5\xd3\xd3 ;Swed/Finn 7 7 7 ” 12019, u2019, u201D, u201D

Paste prefers text

from
to

Note:

The default for Paste (from none FM files with CTRL+v) may
create OLE connections (Object Linking and Embedding). To
paste the contents rather than the object property, change in
section [Preferences]:

ClipboardFormatsPriorities=FILE, OLE 2, EMF, META, DIB,
BMP, MIF, RTF, TEXT

ClipboardFormatsPriorities=TEXT, RTF, FILE, OLE 2, EMF,
META, DIB, BMP, MIF

ClipboardFormatsPriorities only affects the Windows clip-
board. It does not affect operations within FrameMaker

To paste without formats within FrameMaker use Paste Spe-
cial (CTRL+SHIFT+v) > Text. There are also utilities available
to strip formatting from the clipbaord.

Display character positions correctly

[Fonts]

DisplayUsingPrinterMetrics=0n (default since FM-8)

Match colours in FrameMaker and PDF

[Preferences]

GetLibraryColorRGBFromCMYK=None
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