
FrameMaker 8
Crash Course

Overview

This handout for a crash course covers each topic 
on one page only. Comprehensive information 
about FrameMaker (> 350 pages) can be found at
www.daube.ch/docu/fm-kurs/handout.pdf
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Properties of FrameMaker
Designed for long and long living structured documents

Any FM document is also a template

Internal names are case sensitive

TOC/Index etc. are stand-alone documents

Import default is “by reference”

Formats are independent (no “based on”)

Not all can be undone! No drag’n drop,

No macros  plug-ins, FrameScript

Modern user interface only starting with version 9

‘Layers’ in a document

Applying formats

body pages

Dokument seiten

master pages

Vorgabe seiten

reference pages

Referenz seiten

manually assigned

Footnote

Long line

Graphic-1

<$paratext>  <$pa-
genum>

<$paratext>  <$pa-
genum>

<$paratext>  <$pa-
genum>

openObjectId <$relf-
ilename>:<$Object-

Type> <$ObjectId>

Reference TOC

Footing

Heading

Title Left

Footing

Heading

Right

F
o
o
tin

g

H
e
a
d
in

g

Rotated

Title 
Page

Footing

Heading

Footing

Heading

Writing into 
connected 

text frames 
automaticall

y continues 
on the next 

page and 
requests 

new empty 
pages from 

the Right/

Footing

Heading

Left set of 
masterpages

Other 
masterpages 

such as Title 
must be 

automatically assigned manually assigned

Body pages:

In these you are working. 
Heading and footing areas 
can not be edited - they 
are ‘background’.

Master pages

These define the layout. 
L/R master pages are 
assigned automatically. 
Others must be assigned 
manually.

Reference pages

These contain various ele-
ments, which can be refer-
enced or define templates 
for generation of special 
pages (TOC, Index etc.)

In the beginning

There was nothing than
darkness and chaos.

Elephants

Lions

Zebras

Noah was not able to navi-
gate the arch out of the sea

F9, 1, Enter

F8, 1, Enter

Table designer
Cross reference setup, etc.
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Basic text handling

Note: Avoid local formatting (font, size, bold, centre etc.) as much as 
possible to ease maintenance of the document.

FM 8 handles Unicode Even the ‘old’ character set contains many special symbols 
(see FrameRoman character table on page 25).

Spell checking FM-8 supports 34 languages including variants such as Swiss 
German and Swiss German (new). 4 dictionary levels:

Hyphenation 

To select Type, do Task Type

Word double click Apply paragraph format F9, name, Enter

Paragraph triple click Apply character format F8, name, Enter

Sentence ESC, h, s Repeat last para formatting ESC, j, j

Line ESC, h, l Repeat last character formatting ESC, c, c

All text in a cell ESC, t, h, a Enter straight single quote (" ') ESC, " / ESC, CTRL+'

“internal” character map

With 10µ diameter...

Resistance: 178 Ω

CTRL+Q, 5

copy/paste

Hierarchy of dictionaries:

1 Language dictionary.

2 Site dictionary.

3 Personal (Project) dictionary.

4 Document dictionary.

Dictionaries 2 … 4 mix languages.

Task Enter in text in dialogues

Avoid hyphenation ESC, n, s \_

Optional hyphen CTRL+minus \-

Nonbreaking hyphen ESC, minus, h \+

Nonbreaking blank CTRL+blank \  (\, blank)

Influences

Paragraph properties

Text options

Dictionaries

Options in spell checking
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Paragraph and character formatting
Note: Follow your template standards for naming formats! For exam-

ple, use x-name for chapter local items and z-name for layout 
specific items.

Create a derived 
paragraph format

1 Put the cursor into a paragraph with best fitting format 
(e.g. lwa-wide list).

2 Define the new name (both in catalogue and selection).

3 Modify the desired attributes (at best in the designer) and 
check with Apply.

4 For titles specifiy “keep with next” in tab Pagination.

5 Click Update All to get the final definition into catalogue.

Create Character style 1 Select text to see the effect of your formatting.

2 Character Designer > Commands > Set Windows to As Is

3 Define the name of the format and set the appropriate 
attributes (do not forget language), check with Apply.

4 In Commands > New Format activate both Catalog and 
Selection.

Import a specific style 1 In the source document select the paragraph (or string) 
with the desired format and copy it to the clipboard.

2 In the target document paste the selection.

3 In the ¶/f Designer select Commands, activate both 
Catalog and Selection and then click Create..

wide list wide list wide list wide list wide list 
wide list and so on and so forth.

3

TABs are absolute

abc cd ef gh

more text here target

wide list b wide list wide list wide list wide list 
wide list and so on and so forth.
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Hierarchical numbering
The term hierarchical numbering refers to heading numbers 
with hierarchical dependencies. For example a level 3 heading 
depends on the numbering of the level 2 numbering, which in 
turn depends on the numbering in level 1.

In tab Numbering of the paragraph designer you see only the 
numbering of the current format, not the relationship to the 
other formats in the hierarchy. To see the dependencies it is 
good practice to set up a scheme.

Example We assume 4 levels of headings. The highest level is the chap-
ter heading. The others are section headings. In addition, 
tables and figures shall restart their numbering in the main 
sections: Tab. k.n.m: and Abb. k.n,m: (c: chapter-#, n: 
number from the main section, m: number of table or figure).

The following table describes this scheme (  denotes a 
required blank):

Syntactical elements

H: Label of the numbering range. This may be any upper- or 
lower case letter or nothing for local lists.

<$chapnum> Chapter number (normally set via the book functions)

<3=0> Set counter to 0, but do not display (hence the leading blank).

<n+> Increment counter and display value (hence no blank).

<n> Display current counter value.

< > Place holder in this column to get the matrix straight.

Fig.  Tab.  . : \t Everything after the label and outside the <…> constructs is 
displayed. \t creates a TAB character.

Interpretation In tab Numbering of the ¶ format ft-figure-title gets:

H:Tab. <$chapnum>.<n>.< >.< >< ><n+>:\t

The 5th figure in the 2nd main section of chapter 7 gets the 
following representation:

Fig. 7.2.5: Effect of the fragrance of lily of the valley to 
the behaviour of cockchafers

¶ format Label, intro chapter level 1 level 2 level 3 tables figures TAB

0chapter H: <$chapnum> < =0> < =0> < =0> < =0> < =0> \t

1heading H: <$chapnum>. <n+> < =0> < =0> < > < > \t

2heading H: <$chapnum>. <n>. <n+> < =0> < > < > \t

3heading H: <$chapnum>. <n>. <n>. <n+> < > < > \t

tt-table-title H:Tab. <$chapnum>. <n>. < > < > <n+> < >: \t

ft-figure-title H:Fig. <$chapnum>. <n>. < > < > < > <n+>: \t

Building block Numbering type and range Building block Meaning

<n> arabic 1, 2 … 17 … 65535 <$chapnum> Chapter number

<a> lower case a, b … q … aa, ab … crxo (65535) <$volnum> Volume number

<A> upper case A, B … Q … AA, AB … CRXO (65535)

<r> lower case roman i, ii … xvii … mmmmmmmmmcmxcix (9999)

<R> upper case roman I, II … XVII … MMMMMMMMMCMXCIX (9999)
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Table handling

Individual ruling and 
shading

Select row CTR+double click at he far left/right of a 
cell.

Select clumns CTR+double click into the middle of a cell.

Import table from Excel 1 In Excel select the table area and copy to the clipboard.

2 In FrameMaker paste with Edit > Paste Special… 

3 Select an appropriate Table format and format the 
rows/the table according to the needs.

The table anchor is here:

This is the next paragraph after the table, the ordinary text 

Table 1: Table title (¶ format tn-tab-title-numbered)

Heading cells (repeated on next page) Head Head

Body cells (¶ format tm-table-middle)
strad-
dled 
cells

A footnote reference a

a. This is a table footnote (¶ format ztf-table-footnote)

This cell is very large to show the
margins and surrounding areas straddled cells

Footing cells (repeated on next page) Foot Foot

“Space above”
(Table designer).

“Gap” (Title Position)
(Table designer).

Column ruling

Body Row ruling

Separators

Cell margin (Table designer)

Cell margin from ¶ designer,
“Table Cell” properties.

Outside ruling

Space defined by box
on Reference page.

Space below”
(Table designer)

Paste Special: text Paste Special RTF

You get a number of tabbed para-
graphs, which you convert to a table.

You get an anchored table, to which 
you apply the appropriate table format.
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Anchored frames
Anchored frames are the universal container floating with the 
text. Some forms are bound to a location on the page of the 
anchor. Insert a frame with Special > Anchored Frame…

 This (colour filled) frame is Outside Text Column. It con-
tains an imported graphic. The most used frame type for 
graphics is Below Current Line:

The frame can either be filled with colour or have a border.

There is no property frame title as it exists for tables.

Frame with caption 1 Use a distinct paragraph for the anchor (e.g. za-anchor), 
and define the following to become the next paragraph:

2 For the figure title define, for example, ftn-fig-title-
numbered. Specify Keep with previous (the anchor para-
graph). This ¶ may be automatically numbered.

Anchor paragraph 

Title paragraph Figure 1: The title (caption) for the graphic or the frame.

Importing graphics 1 Select the frame into which you want to import the graphic. 
If no frame is selected, FM places a default anchored frame 
at the cursor location.

2 File > Import > File … opens the dialogue to select the 
graphic file.

3 Choose Import by Reference (use Copy into Document 
only in rare cases, for example on reference pages).

4 In the next dialog specify a resolution (for bit maps). You 
may later modify this with Graphics > Object Properties 
or Graphics > Scale. Vector graphics are imported directly.

5 The imported graphic can be resized with the mouse also.

Inline graphics (icons)  For this form  use the frame type At Insertion Point.
To move the frame up/down, use ALT+arrow on the selected 
frame. You may wish to switch off the paragraph property 
Line Spacing Fixed.

This text is within a text frame
which is located in the anchored
frame. Use this form for longer ex-
planations in a graphic or side by
side to a graphic. Both ¶ formats
and character formats can be ap-
plied. Tables can be anchored.

Der froschkönig war es nun end-
gültig leid, noch länger auf die
prinzessin zu warten.

Attention with png graphics:

When creating png graphics 
do not optimise the palette 
(less than 8bit colours)

png with less than 8-bit col-
ours create an entry into the 
colour catalogue for each 
colour in the png!
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Graphics with FM tools

Graphic objects The graphics palette defines graphic objects as well as prop-
erties for graphic objects. You may set the properties before 
you create an object or apply the properties to selected 
objects. 

Ease graphic work with View > Options > Grid Spacing and 
Graphics > Snap ON and/or Graphic > Gravity on.

Tool bars for graphic 
work

A graphic object is either filled or has a border, not both.

Callouts Do not place numbers and text into the graphic itself. Overlay 
these in the FrameMaker document to maintain constant font 
size for the legends (and ease translation).

Intelligent cursor (depending on object)

Line

Open polygon

Rectangle

Circle, ellipse

Text frame

Graphic frame

Define area fill pattern

Define line fill patten

Define line width

Define line-end type

Define line type

Define colour

Define tint

Define overprint type

Cursor for graphic objects

Arc (circle, ellipse)

Freehand-line, spline 

Rectangle with rounded corners

Closed polygon 

Text line

Apply area fill pattern

Apply line fill pattern

Apply line width

Apply line-end type

Apply line type

Apply colour

Apply tint

Apply overprint type

group ungroup to front/back ditribute reshape flip scale obj.prop. snap gravity

nudge (1pt at 100%) = ALT+arrow align multiple objects (on last selected) turn (15° incr.) solid dashed

44  overlay centered 44
and group

 copy/paste and edit figure: 3 A

Use a text frame for longer explanations. 
Both ¶ formats and character formats are 
possible. Borders cling to the contents.

A text line can only use character formats (here: ft-fig-text).
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Canned text
Canned text reduces redundancy and eases maintenance of 
standard text (e.g. warning texts).

Variables

Typical variables Product-name, revision-no, revision-date, author, copyright 
date, manual-no, vendor.

Use for book-wide definitions. Use special names (e.g. x-name) 
for chapter-wide definitions (must not be distributed via 
book).

Open dialog via Special > Variable… or by double clicking on 
a variable in the text.

Variables can contain text and highlights, but no other varia-
bles. 

The maximum length in FM-8 is 1022 chars for UTF-8 text. 
This includes the notation of character format, e.g. 
<1-highlight>. Use </> to switch character format off (in 
place of <Default ¶ Font>).

Cross reference to text 
on reference page

Open dialogue via Special > Cross-reference… and search in 
the current document for the relevant paragraph format, 
select the paragraph:

This text is located on the reference page Reference in a text 
frame with the flow name caveat. For finding this text easily it 
has the paragraph format x-bodytext and not just bodytext. 
However, you can also include this text into the body pages as an 
inset. In case of an inset the name of the flow is relevant.

(The coloured background is on the current page).

Only single paragraphs can be referenced. However, mainte-
nance of these texts is easy: double click on the text to get the 
dialogue Cross Reference where you click on Go to Source.

The purpose of the text should be recognisable within the 
first few words because display in the dialogue is limited.

Text inset A text inset can be of arbitrary length (e.g. multiple para-
graphs). See Text insets on page 14.

Layout items

Usage Special pages, such as the last page of a chapter, containing 
company address etc. Another usage is the famous This page 
intentionally left blank in loose leaf publications.

Set up A master page with name Last contains the text frame with all 
the text. The text frame must be of type background, other-
wise the text will not appear on the body pages.

Plug in AutoText All FM constructs such as complicated tables, lists or figures 
in frames can be handled. See AutoText on page 19.
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Cross references
A document template provides a number of cross reference 
formats. The text “See” or “See on page” shall not be part of 
the cross reference format, because they may be needed in 
several forms.

Cross reference to 
paragraph

1 Open dialogue Special > Cross-reference… 

2 Select Source Type Paragraphs. The list of paragraphs for-
mats are displayed under Paragraph Tags.

3 Select the tag name for the target of the reference (e.g. 
2heading).

4 Under Paragraphs you see the texts of these paragraphs to 
choose from. Select the appropriate one.

5 Under Format select the appropriate format for the refer-
ence: heading & page. Below the drop down list you see the 
pattern of this format:
<1-highlight><$paratext></> on page\ <$pagenum>

The main building blocks of this cross reference format are 
$paratext providing the text of the target paragraph and 
$pagenum, the page number of the target paragraph.

6 With Insert the cross reference to the target is inserted at 
the current cursor location: Create Character style on page 4

Modify cross reference 
format

If a special format is needed, modify an existing one with Edit 
Format:

1 In the Cross Reference dialogue select the most appropri-
ate format and click Edit Format.

2 Provide a new name, e.g. heading title mod and click on 
Add to get the new name into the list.

3 In the Definition build the generation pattern with fixed 
text and building blocks from the list. The list starts with 
system variables and continues with character formats.

Set up the new format, for example 
<2-highlight><$paratext></>

</> is shorthand for the building block <Default ¶ Font>

4 Click Change to store the new definition and Done to leave 
the dialogue.

5 In the Cross Reference dialogue click Insert to apply the 
new format for the selected target reference:
Create Character style

Cross reference to other 
files

The target file must be open.

In the drop down list Document select the appropriate tar-
get document and find the relevant paragraph or cross ref-
erence marker.
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Books
A FrameMaker book is a list of files (with properties) stored in 
a book file. The book contains layout definitions from the file 
from which it was initiated. These are used for generated files 
such as TOC or index.

Set up book from initial 
chapter

A book is set up to provide homogeneous numbering over 
chapters and to be able to generate lists (such as TOC) and 
indexes from the collection of files.

1 In the chapter file which shall become part of a book, use 
File > New > Book.

2 You are asked whether the current file shall become part of 
the book. Answer Yes.

3 The book dialogue opens with the (absolute) file name 
entered.

4 Save the book with an appropriate name. The file name of 
the chapter file w ill become relative to the book.

5 Add more files to the book. You may drag file names from 
the Windows File Explorer into the book window.

6 Rearrange the file names by drag and drop.

7 Set up the numbering of the book files (see hereafter).

Setting the numbering 
properties of a book file

Set up a numbering scheme for the whole book to overview 
the numbering process, for example:

1 Select the file in the book and open Format > Document > 
Numbering.

2 Choose the required tab and define the numbering accord-
ing to the desired scheme.

3 Continue to set all numbering properties of the current file 
and then advance to the next file in the book.

4 Apply the settings with Edit > Update Book (or icon ). 
This will renumber the items (paragraphs, pages, etc.)

Distribute formats 1 In the book window select the target files for the formats.

2 In File > Import > Formats select the source file and define 
the format categories to be imported and distributed.

Note: Category Document Properties covers a great set of properties 
and hence need to be handled carefully!

File Vol. Chapter Page number Paragraph Footnotes

title 1 0 1 roman restart 1

booknameTOC same same continue roman continue continue

introduction same next 1 arabic restart continue

planning same next 1 arabic continue continue

working same next 1 arabic continue continue
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Table of contents

Generate TOC from a file 1 Enter the document from which you want to generate the 
TOC and select Special > Table of Contents…

2 You are prompted whether to set up a TOC as part of a new 
book or as an independent file. Click Yes.

3 In the dialogue Set Up Table of Contents move the para-
graph styles, which should appear in the TOC, to the left. 
(You can move all items from one side to the other by holding 
SHIFT while clicking on the arrow button).

4 Normally you want to generate hypertext links: click the 
selection box.

5 Click Set. A new file named documentnameTOC.fm is created 
with default presentation of the TOC.

When working with a template, the document file contains 
definitions for xxxTOC paragraphs which will be used and 
the generated TOC looks final.

6 Save the file. Do not change the name of this file!

7 After changes in the original document file you must 
update this TOC file: in the document file follow steps 1 - 6 
from above. Since you already have a TOC file from step 6, 
this will be used for the re-generation.

Chapter TOC A TOC generated from a document file can be used as a text 
inset in the document itself. To get correct page numbers you 
must update after the insert both the TOC file and Inset in the 
container file!

Generate TOC for a book 1 In the book file select the file before/after you want to 
place the TOC and select File > Add > Table Of Contents. 
In the book a file booknameTOC.fm will appear, then opens 
the dialogue.

2 Define where you want to add the generated file into the 
book (before/after the selected file).

3 In the dialogue Set Up Table of Contents move the para-
graph styles, which should appear in the TOC, to the left.

4 Normally you want to generate hypertext links: click the 
selection box.

5 Click Set. A new file named booknameTOC.fm is created with 
default presentation of the TOC.

When working with a template, the book file contains defi-
nitions for xxxTOC paragraphs which will be used and the 
generated TOC looks final.

6 Save the file. Do not change the name of this file!

7 After changes in document files of the book you must 
update this TOC file with Edit > Update Book…: Assure 
that the TOC file is listed under “Generate”.
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Index
Index entries are markers of the type index. 

Insert an index entry 1 Place the cursor at the desired point. Prefer the end of a 
paragraph for the location! Translators will love You!

2 Special > Marker opens the dialogue Marker. The marker 
type Index might be selected already. If not, select this 
type from the drop down list.

3 If you have selected text, or do so while the Marker dia-
logue is open (it stays open), the selected text appears in 
the box as Marker Text. The marker will be placed in front 
of the selection.

4 Change the marker text to your desire and insert the 
marker with New Marker.

Edit an index entry Open the dialogue with Special > Marker.

Find (or directly select) the relevant Index Marker.

The dialogue will get the marker text to be modified. The 
button to be clicked now reads Edit Marker.

Blanks in index entries Blanks may be arranged around the colon and the semicolon 
which have syntactic meaning in the entries. These blanks do 
not appear in the index display. Required blanks (e.g. to keep 
words together) must be inserted as \  (backslash, blank).

Multi level entries Multi level entries are separated by a colon (:). The following 
example will create a main entry abrasion and a sub entry gla-
cial: abrasion: glacial

Multiple entries in one 
marker

Multiple entries within one marker are separated by a semico-
lon. This is for example useful to place all permutations of 
multi level entries in one marker: 
character: delete; delete: character

Special characters in 
index entries

Colon, semicolon, < and > are syntactic characters in Index 
Marker entries and must be ‘escaped’ for literal use:

Income \> 100 millions; fruit\: vitamins for all
vegetables: cucumbers\; beans\; cauliflower

Generate index for a 
book

1 In the book file select the file before/after you want to 
place the index and select Add > Standard Index.

2 In the dialogue Set Up Standard Index the appropriate 
marker type is already selected.

3 Normally you want to generate hypertext links: click the 
selection box.

4 Click Set. A new file named name booknameIX.fm is created 
with default presentation of the Index.

5 For updates the same procedure as for TOC applies.
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Text insets
Avoid duplicate information by referencing predefined 
text.

Any text flow in any document can be used as an inset. 
Hence the inset may come from a reference page of the 
container document:

For easy insertion use the same styles in the inset as for 
the container document.

Note: Variables are resolved only one level deep.

Insert an inset 1 At the desired location start an empty paragraph with a no-
breaking space (CTRL+space) and locate the cursor before 
this blank.

2 With File > Import navigate to the file with the inset flow. 
This may be the current file to insert from the reference 
pages.

3 Choose the type of flow to be imported (master page or ref-
erence page) and select from the drop down list.

4 Normally you choose Reformat using Current Document’s 
Formats.

5 Click on Import to insert the flow at the cursor location.

The no-breaking space assures correct formatting of the 
anchoring paragraph caused by the first paragraph in the 
inset.

Organise insets Name the flows with their purpose/contents. For example, 
name the flow warn-hot, caution-esd, info-customs.

You may set up a project specific document with insets 
(various body pages with various flows).

Cross references Do not place cross references (inset  container) in an 
inset, because the container changes!

For references from the container to the inset define a 
cross reference marker (give it useful content) in the inset 
to which you refer from the various container documents.

This text frame is locaed in the refer-
ence pae Reference of the current 
document

  CAUTION

Device may be damaged by Electrostatic Discharge.

<product name> electronic boards must not be touched without taking ESD 
protection steps such as use of an ESD wristband or electrostatic conductive 
shoes.
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Conditional text
Note: Table columns (or individual cells in a table) cannot be made 

conditional. Only whole table rows can be conditional.

Define a condition 1 In Special > Conditional Text > Mange condition… click 
on Add or Edit.

2 (For Add) provide the new name in the edit box and select 
an appropriate style and colour for the display (this style is 
not used for printing!); click Set. 

3 The condition is now listed in Manage Conditions dia-
logue.

Apply a condition to text 1 Select the text which will receive the condition (for example 
“comment”)

2 Special > Conditional Text > Apply Conditional Text... If 
you do not see the desired condition tag in the “Not in:” 
column, you must first set up this tag.

3 Set the current selection to Conditional (radio button) and 
move the desired condition to the left column (“In:”) and 
click Apply.

The text with the condition gets a special appearance accord-
ing to the settings of the condition tag:

Display the conditional 
text

Hidden conditional text is represented by a maker symbol ( ). 

Note: If you delete a Conditional Text Marker you actually delete the 
conditional text!

To display (and print) text with and/or without any condition:

1 Select Special > Conditional Text > Show/Hide Condi-
tional Text.

2 To display (and print) everything, activate the radio button 
Show All.

3 To display (and print) only certain condition texts,

- move the conditions into the appropriate column (Show 
or Hide).

- Activate radio button Show as per Condition

4 Click Set

Note: You may move all tags at once with SHIFT+click on an arrow.

The condition indicators (underlining, colour) are only visible 
if Show Condition Indicators is checked.
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Create PDF

Save as PDF
1 With File > Save As PDF … you get a standard File saving 

dialogue with the file name documentname.pdf which you 
may change.

2 After clicking Save the PDF Setup dialogue appears which 
has 4 tabs for various settings.

3 In the Settings pane you define

- The set of Distiller parameters (Job-options)

- How the PDF document should open initially.

- Registration marks are only necessary if you want to 
print on smaller paper and see crop marks to trim the 
paper.

- Further parameters normally need no change from the 
already set values.

4 In the Bookmarks pane you specify which items you want 
to have in the bookmarks pane of Acrobat/Adobe Reader.

- Define bookmarks from the heading levels with the <--- 
and ---> arrows. You can move all items from the left 
pane to the right one (or vice versa), by holding SHIFT 
and clicking the ---> (<---) button.

- Set the appropriate level of the bookmark with the << 
and >> buttons.

- To have the bookmarks closed to the first level, enter 1 
into the drop-down list Bookmarks expanded through 
Level.

5 Normally you uncheck the first check box both in the panes 
Tags and Links.

6 Click on Set to initiate the generation of the PDF. Distiller 
will appear automatically. It disappears after some time as 
long as FM is open.

Note: Automatically generated hyperlinks in TOC and Index as well 
as cross references are live in the generated PDF.

Printing with Adobe PDF printer
1 For the document (or the book file) use menu Format > 

document > PDF Setup to define the Distiller Job Options, 
Bookmarks etc. See Save as PDF.

2 Open File > Print and activate 

- Print to File and specify a file name (where you have 
suffient space for a large file).

- Generate Acrobat Data (to get bookmarks etc.)

3 With Setup… select the printer Adobe PDF (formerly called 
Distiller printer) and in Print Setup click on Properties… 
There deactivate Relay on System Fonts only …

4 Leave Printer Setup and in Print Document or Print Book 
click on Print.

5 The resulting PS (PostScript) file must be processed by the 
Distiller afterwards.
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Equation editor
The equation editor (formula editor) is controlled from a spe-
cial palette, which opens from Special > Equations … or with 
button at the right border of the document window .

The equation (or formula) is a special object created in an 
anchored frame. It is not just a graphic. 

An in-line formula is inserted in an ordinary paragraph, 
rather than in a paragraph of its own. 

Most time you will need to specify “no fixed line spacing” to 
the anchoring paragraph give room to the formula. The frame 
can be treated like any other anchored frame (border, back-
ground):

 Proportions of Golden Rectangle.

Such simple formulas can be entered directly from the key-
board:

More complicated formulas require selection of math objects 
from the Equation palette and enter items at the highlighted ?

Strings in formulas Strings are required, for example to enter physical dimen-
sions or for ‘wordy formulas’. You start the string with " and 
terminate it with RETURN:

Typing Result Explanation

ESC m l Insert large equation (frame). The highlighted 
? is the ‘entry point’ of the formula.

a = The new ‘entry point’ is the ? after the equal 
sign.

\sqrt 
ENTER

Function names like sqrt, pwr, log etc. are 
preceded by a backslash and terminated by 
ENTER:

5 space 
space

The ? is replaced by 5, the two spaces select 
the 5, then the square root as a whole.

- 1 The “minus one” is attached to the selection, 
not just to the last entry.

space 
space 
space /

The blanks select the 1, then -1, then the right 
term. The slash creates a fraction bar below 
this selection.

2 space 
space b

Selecting the right term provides the entry 
point (?) to the right. A variable is displayed in 
italics.

ESC m p
 

Shrink wrap the formula. Then apply “variable 
line height” to the anchoring paragraph.

potence, powersuperscripts, subscripts

timesvertical and horizontal list elements

Distinguish opertors !

a 5 1–
2

---------------- b⋅=

?

a = ?

a = ?

a 5=

a 5 1–=

a 5 1–----------------=
?

a 5 1–
2

----------------b=

a 5 1–
2

----------------b=

success expenditure
effort

----------------------------=
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Special layout

Assign master page A FrameMaker document may contain a (nearly) arbitrary 
number of master pages, for example, title, last, 
landscape-left, landscape-right).

For ordinary pages the master pages Right and Left are 
assigned automatically. Other master pages are assigned with 
Format > Page Layout > Master Page Usage... 

Master pages for rotated 
tables

Rotated tables are not rotated themselves but located in a 
rotated text frame:

If for some reason you keep the master page in portrait mode 
and just rotate the inner text frame, you can not directly edit 
a table anchored in this text frame.

Multiple columns You can not change the number of columns within a flow. To 
insert pages with other column layout than the standard 
pages you need disconnected pages. The text within these do 
not flow/reflow if text amount is changed.

Text is oriented this way and tables are 
placed normally

Hecate est Iovis et Latonae filia, soror 
Apollinis. Est tricopor et triceps, 
magicarum artium magistra ac 
fascinationum praeses, cinctra 
latrantium canum turma; noctu stans in 
triviis vel prope sepulcra et ubi taminata.

here you can edit the table similar to the text

1 Create master page in por-
trait mode (e.g. copy from 
Right) and name it appro-
priately (e.g. Rotated-
right)

2 Rotate page with Format > 
Customize Layout > 
Rotate page clock-
wise/counter clockwise.

3 Rotate central text frame 
back. The heading/foot-
ing area will remain 
rotated.

Footing area is rotated

H
eading area is rotated
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Useful addenda
These are plug-ins install as dll’s (except the first one) and 
hence do not need the FrameScript interpreter (which is a 
plug-in by itself).

Enhanced tool bar Two button groups only, not four.

Additional useful commands, e.g. F4 to repeat ¶-actions.

The Enhanced Toolbar at www.daube.ch is based on the works 
of Microtype.

AutoText Inserts FM constructs (pictures, tables, text) via menu or 
shortcut. Installs menu item AutoText. The names in the sub-
menu (Hint, Warning etc.) are defined in an FM document an 
hence can be of any language. 

An FM document contains the constructs.

One set of items per FM-installation, but menu can contain 
submenus for subsets of items, for example, icon collec-
tions.

Source: Silicon Prairie Software, USD 10.-

Archive (for books) This plug-in collects all referenced graphics and text insets 
into two subdirectories. Usage: File > Utilities > Archive doc-
ument.

Useful to clean out the graphics directory.

Useful to store a project on a CD or the like.

Unicode in file names is not supported.

Source: Bruce Foster, USD 25.-

Cleaning tools These tools support the migration from old to new style defi-
nitions. Installs menu item Tools.

Report used and unused styles to judge the need for clean-
ing the document.

Eliminate unused tags for paragraphs, characters and 
tables.

Rename tags for paragraphs, characters and tables by 
means of a conversion table.

Local overrides can be searched and eliminated.

Source: Silicon Prairie Software. Character Tools, Paragraph 
Tools, Table Tools: USD 10.- each.

Another (more expensive) source for equivalent tools is 
Squidds.de.

Poerful script collection www.i-frame.itl.info provides a layered set of scripts for vari-
ous purposes (many for free). Precondition is the plug-in 
FrameScript.

http://www.microtype.com/ToolbarPlus.html
http://www.siliconprairiesoftware.com/
http://home.comcast.net/~bruce.foster/Archive.htm
http://www.siliconprairiesoftware.com/
http://www.squidds.de/en/products/squidds-produkte/toolbox-for-framemaker.html
http://www.daube.ch/docu/fmaker57.html
http://www.i-frame.itl.info/index.php?id=framescriptde&L=1
http://www.framescript.com/
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Migration
To apply a new template to a current document some steps 
are necessary:

Prepare the current
document

1 Remove all unused styles (paragraph, characters, tables) 
from the current document. Also remove unused colours 
and unused cross reference formats. Without tools this is 
quite laborious.

2 Remove unused master pages and unused reference pages.

3 Rename used styles which have different names than the 
new template. Table driven tools are of great help here.

Import new styles 4 Import styles from the new template. Also import the mas-
ter and reference pages. In File > Import > Formats check 
the boxes: remove Manual Page Breaks and Other 
Format/Layout Overrides.

Styles with similar names in both the current document 
and the new template get the new definitions.

Check the import 5 Carefully check the updated document and apply new over-
rides (for example, page breaks) as required.

6 If old style names still exist, rename them to x-oldname to 
indicate that they exist only in this document:
In paragraph designer select the style, change the name 
and then Update All. You will get a prompt to allow the 
new name.

Apply similar changes to character or table styles which 
have old names.

Alternative method For large differences in style the following method may be 
useful.

1 Create a new document from the template.

2 In the old document select all text (CTRL+a) and copy it to 
the clipboard.

3 In the new document Paste Special (Text only). Tables will 
be inserted as paragraphs with TABS. You do not get 
anchored frames yet.

4 Apply the appropriate styles (paragraph and character).

5 Reconstruct the tables with new format:

- Select the paragraphs to become the table.

- Select Table > Convert to Table…

- Select the appropriate table format and click Convert.

- It may be necessary to re-arrange and/or straddle cells.

6 Reconstruct the anchored frames:

- Copy the anchored frame from the old document.

- Paste it to the desired location in the new document.

- You may need to apply new styles to Text Lines (created 
with A-tool) and text in text frames, adjust line thick-
nesses etc.

7 Archive the old document. It may be necessary to get some-
thing out of it later.
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Import from Word
Although it may look tedious work the following method is 
the safest – and in most cases fastest – method to import text 
from other applications, in particular, MS Word.

This method avoids the pollution of formats which are gener-
ated by the import filters which try to keep as much as possi-
ble of the source appearance.

Precondition A clean FrameMaker template with all necessary formats for 
paragraphs, character, tables, cross references etc. is key. If 
necessary the catalogues will be extended.

Prepare the Word file
Create a copy of the document and prepare this copy for the 
import to FrameMaker:

Export all graphics to distinct files (if you can not find the 
original location of the graphic files).

Convert Word graphics to distinct graphic files.

Resolve anchored frames

Clean out text

Export graphics to 
distinct files

Users of Word most time copy graphics into Word. Approved 
practice in FrameMaker is to import graphics by reference. 
Hence you may first create these graphic files (or find the 
orginal location). A Utility such as Office Image Exporter may 
be of great help.

Word graphics are available only in Word. They must be 
extracted also. See Convert Word graphics on page 23.

After exporting all graphics delete them in the Word file.

Resolve anchored frames Anchored frames in Word can be converted by FM-8 to FM-
anchored frames - but the process is not reliable. Hence select 
all contents and place it outside the frame. Then delete the 
frame.

Clean up the text Remove hard page breaks.

Remove hard line breaks if they serve only layout purpose.

Remove hard hyphenations and optional hyphenation.

Remove field functions (such as TOC). In FM there are dif-
ferent mechanisms for most of them.

Save the Word file Save the cleaned document as RTF. The version of RTF saved 
depends on the Word version and can not be determined from 
the file.

Import the RTF to FrameMaker
1 In FrameMaker import this file to a location where the ¶ 

format is Body or bodytext (if this is appropriate for most 
of the text).

2 In case the document has been saved as .doc (Word file), 
select Microsoft Word in the dialogue Unknown File Type.

http://www.rinasoft.com/
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Format text in FM
Note: When applying formats with a designer (Paragraph Designer, 

Character Designer), do not use Update All, but Apply (to 
selection only). User Update All only if really the catalogue 
should be be updated!

The FM document looks nearly as the Word document, 
because the filters try to keep the appearance. The document 
does not yet contain any FM styles from the template. These 
are now applied.

Some discipline is required to avoid to many left out * for-
mats.

1 Start with applying headings. First apply main section 
headings, then sections, then subsections. With a tool such 
as the Enhanced tool bar on page 19 it is easy to repeat for-
mat applications.

2 Standard running text gets the format Body (or bodytext).

3 When applying list formats the bullets and numbering fig-
ures are placed before the Word elements, which must be 
removed (see Clean up the import on page 22).

4 Tables got the Format A during import. Hence the neces-
sary table format must be applied. Both horizontally and 
vertically straddled cells are handled correctly by FM-8.

5 Word does not know about table title and heading rows. 
Hence these must be reconstructed:

- Select and cut the body rows to be converted to heading 
rows.

- Place the cursor into the now topmost row and with 
Table > Add Rows or Columns add the desired number 
of rows To Heading.

- Select the empty heading rows and paste the rows from 
the clipboard with Replace Current Rows.

- If a table title is defined in the new template, set it up.

6 Format all cells (header, body, footer) with the appropriate 
paragraph formats.

7 Apply the necessary character formats.

8 Insert the graphics (see Place the graphics on page 23).

9 Search through the whole document for formats with local 
overrides (* prefix in the information area). Walk through 
the lines with the  key (in tables with TAB key through all 
cells). As soon as you notice a * in the information area the 
format has local overrides (or not yet an FM format).

Note: With tools (see Useful addenda on page 19) the cleaning of doc-
uments can be accelerated significantly.

Clean up the import Bullets or other list introducers as well as numbering must be 
removed from the imported list entries, because in FM they 
belong to the property Numbering.

Note: In the following do not use Change All even in so called obvious 
cases. Always use Find or Change & Find.

Remove numbering Set up Find/Change with Wildcards ON and this find pattern: 
[1-9].\t for single figures and [1-9][0-9].\t for two figure 
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numbers. Of course, the period may also be a parenthesis in 
certain cases. The Change field is empty to delete the item.

Remove bullet symbol If the bullet symbol is from the standard font, then it appears 
as • However, if it comes from Wingdings or Dingbats etc, 
then you see the base character in front of the list lines, these 
may be é, U or everything else. Start your search pattern with 
the first symbol coming along (Wildcards must be ON):

[•]\t and extend as soon as you discover more of these:
[•é*8ç]\t

Place the graphics At the desired locations import the graphics and let them use 
the default FrameMaker anchored frame. When you (like me) 
prefer to use specific anchored frames:

Define an anchored fram Below current Line using the 
width of the full text column, right adjusted and 2 cm high.

Import the first graphic into this frame and align it (e.g. 
with a margin of 2 mm on top). At this stage the height 
might not be sufficient for the graphic, but leave it.

Select the frame with the graphic in it and copy this con-
struct to all other places where graphics shall be placed.

Replace the graphics in the frames 2 … n with the correct 
ones. They will be adjusted already. Adjust the height of all 
frame and check the graphics.

Convert Word graphics
Word graphics can be copied and directly pasted into FM 
(they are WMF objects). However it will very difficult to 
extract them from FM for further use. Hence it is better to 
paste them into a graphic application and save them to a file.

Method 1 Generate a PDF from the Word document. It may be useful 
to delete all pages without graphics first.

In Adobe Illustrator (or another program capable to edit 
PDF) import a page from this file.

With appropriate operations (such as ungroup, remove 
crop mask etc.) get access to all relevant objects.

Select all relevant graphic objects and copy them to a new 
canvas.

Save this graphic as PDF or eps with preview. You may crop 
the PDF in Acrobat to the desired size, if you did not spec-
ify a proper canvas size.

Method 2 If the graphic application correctly handles WMF it is possi-
ble to directyl paste the graphic into it.
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Recommended setup of FM
Much behaviour of FrameMaker is defined by settings in 
maker.ini. In Windows 2K and above there is a local copy in 
the user area (%APPDATA%, for example 
C:\Documents and Settings\Klaus Daube\Application 

Data\Adobe\FrameMaker\8.0) which has precedence.

Zoom factors Set the zoom factors to values which are most useful for your 
paper size and monitor sizes. For example, for an 20" display:

[Preferences] Zoom=28, 36, 50, 74, 90, 125, 200, 353, 500, 1000

When zoomed to 353% a nudge (moving an object by 
ALT+arrow key moves by 0.1 mm steps

Line widths The default line widths are rather coarse; better may be:

[Preferences] PenWidths=0.1mm, 0.25mm, 0.35mm, 0.5mm

In dialogues the values will be displayed converted to pts.

Snap and grid These can be set to be in the state most users wish for new 
documents. The actual state is saved in the document.

Template path If you want to get document templates from a special loca-
tion, change in section [Directories] 

from TemplateDir=templates
Templates=templates

to (for example) TemplateDir=D:\_doc-std\Frame
Templates=D:\_doc-std\Frame\FM-templates

Smart quotes For better handling set section [Spelling]up with symbols:

SmartQuotes=\xd4\xd5\xd2\xd3   ;English   ‘ ’ “ ”  u2018, u2019, u201C, u201D
; SmartQuotes=\xe2\xd4\xe3\xd2   ;German    ‚ ‘ „ “  u201A, u2018, u201E, u201C
; SmartQuotes=\xdc\xdd\xc7\xc8   ;French    “ ” « »  u2039, u203A, u00AB, u00BB
; SmartQuotes=\xdc\xdd\xc7\xc8   ;Swiss     ‹ › « »  u2039, u203A, u00AB, u00BB
; SmartQuotes=\xd5\xd5\xd3\xd3   ;Swed/Finn ’ ’ ” ”  u2019, u2019, u201D, u201D

Paste prefers text The default for Paste (from none FM files with CTRL+v) may 
create OLE connections (Object Linking and Embedding). To 
paste the contents rather than the object property, change in 
section [Preferences]:

from ClipboardFormatsPriorities=FILE, OLE 2, EMF, META, DIB, 
BMP, MIF, RTF, TEXT

to ClipboardFormatsPriorities=TEXT, RTF, FILE, OLE 2, EMF, 
META, DIB, BMP, MIF

Note: ClipboardFormatsPriorities only affects the Windows clip-
board. It does not affect operations within FrameMaker
To paste without formats within FrameMaker use Paste Spe-
cial (CTRL+SHIFT+v) > Text. There are also utilities available 
to strip formatting from the clipbaord.

Display character positions correctly

[Fonts] DisplayUsingPrinterMetrics=On (default since FM-8)

Match colours in FrameMaker and PDF

[Preferences] GetLibraryColorRGBFromCMYK=None
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FrameRoman character table

00 01 02 03 04 05 06 07 08 09 0a 0b 0c 0d 0e 0f

20 blank ! " # $ % & ’ ( ) * + , - . /
30 0 1 2 3 4 5 6 7 8 9 : ; < = > ?
40 @ A B C D E F G H I J K L M N O
50 P Q R S T U V W X Y Z [ \ ] ^ _
60 ‘ a b c d e f g h i j k l m n o
70 p q r s t u v w x y z { | } ~ DEL

80

Ä Å Ç É Ñ Ö Ü á à â ä ã å ç é è
: A * A , C ’ E ~ N : O : U ’ a ‘ a ^ a : a ~ a * a , c ’ e ‘ e

\u00c4 \u00c5 \u00c7 \u00c9 \u00d1 \u00d6 \u00dc \u00e1 \u00e0 \u00e2 \u00e4 \u00e3 \u00e5 \u00e7 \u00e9 \u00e8

90

ê ë í ì î ï ñ ó ò ô ö õ ú ù û ü
^ e : e ’ i ‘ i ^ i : i ~ n ’ o ‘ o ^ o : o ~ o ’ u ‘ u ^ u : u

\u00ea \u00eb \u00ed \u00ec \u00ee \u00ef \u00f1 \u00f3 \u00f2 \u00f4 \u00f6 \u00f5 \u00fa \u00f9 \u00f9 \u00fc

a0

† ° ¢ £ § • ¶ ß ® © ™ ´ ¨ ¦ Æ Ø
blank ! " # $ % & ’ ( ) * + , - . /

\u2020 \u00B0 \u00A2 \u00A3 \u00A7 \u2022 \u00B6 \u00DF \u00AE \u00A9 \u2122 \u00B4 \u00A8 \u00A6 \u00C6 \u00D8

b0

× ± ð Š ¥ μ ¹ ² ³ ¼ ½ ª º ¾ æ ø
0 1 2 3 4 5 6 7 8 9 : ; < = > ?

\u00d7 \u00b1 \u00f0 \u0160 \u00a5 \u00b5 \u00b9 \u00b2 \u00b3 \u00bc \u00bd \u00aa \u00ba \u00be \u00e6 \u00f8

c0

¿ ¡ ¬ Ð ƒ Ý ý « » … þ À Ã Õ Œ œ
@ A B C D E F G H I J K L M N O

\u00bf \u00a1 \u00ac \u00d0 \u0192 \u00dd \u00fd \u00ab \u00bb \u2026 \u00de \u00c0 \u00c3 \u00d5 \u0152 \u0153

d0

– — “ ” ‘ ’ ÷ Þ ÿ Ÿ ⁄ ¤ ‹ › fi fl
P Q R S T U V W X Y Z [ \ ] ^ _

\u2013 \u2014 \u201c \u201d \u2018 \u2019 \u00f7 \u00fe \u00ff \u0178 \u2044 \u00a4 \u2039 \u203a \ufb01 \ufb02

e0

‡ · ‚ „ ‰ Â Ê Á Ë È Í Î Ï Ì Ó Ô
‘ a b c d e f g h i j k l m n o

\u2021 \u00b7 \u201a \u201e \u2030 \u00c2 \u00ca \u00c1 \u00cb \u00c8 \u00cd \u00ce \u00cf \u00ec \u00d3 \u00d4

f0

š Ò Ú Û Ù € circum
flex

tilde macron breve Ž ring cedilla double 
acute

ž undef

p q r s t u v w x y z { | } ~

\u0161 \u00d2 \u00d2 \u00db \u00d9 \u20ac \u02c6 \u02dc \u02c9 \u02d8 \u017d \u02da \u00b8 \u02dd \u017e

Codes Input method in FM Codes Input method in FM Area Unicode sub range

80 to 9f esc sequence:

Å  ESC, *, A 

a0 to fe CTRL-q sequence:

¼  CTRL+q, 9

Basic Latin; Letterlike Symbols

Latin Extended-A; Latin Extended-B

Latin-1 Supplement; Alphabetic pres. Forms

Mathematical operators; General Punctuation

Spacing modifiers; Currency Symbols

ˆ ˜ ¯ ˘ ° ˞ ˝
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