FrameMaker 9
Crash Course

Overview

This handout for a crash course covers each topic
on one page only. Comprehensive information
about FrameMaker (> 350 pages) can be found at
www.daube.ch/docu/fm-kurs/handout.pdf
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Properties of FrameMaker

*» Designed for long and long living structured documents
= Any FM document is also a template

* Internal names are case sensitive

» TOC/Index etc. are stand-alone documents

» Import default is “by reference”

» Formats are independent (no “based on”)

= Not all can be undone! No drag’'n drop,

* No macros = plug-ins, FrameScript

*» Modern user interface only starting with version 9

‘Layers’ in a document
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Footing Footing Footing
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fd = manually.
o y-2
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. i r &)
Footing Footing
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Reference 70C
Applying formats
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First: Ahove Pk v Tab Stops:
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Table designer
Cross reference setup, etc.
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Basic text handling

To select
Word
Paragraph
Sentence
Line

All text in a cell

Note:

FM 8 handles Unicode

Type, do Task Type

double click Apply paragraph format F9, name, Enter
triple click Apply character format F8, name, Enter
ESC, h, s Repeat last para formatting ESC, ¢, ¢

ESC, h, | Repeat last character formatting ESC, j, j

ESC, t, h, a Enter straight single quote (" ') ESC, " / ESC, CTRL+'

Avoid local formatting (font, size, bold, centre etc.) as much as
possible to ease maintenance of the document.

Even the ‘old’ character set contains many special symbols
(see FrameRoman character table on page 25).,

. =15]x|
“internal” character map : ms p— S
Font - cida Sans Unicode = Help
CTRL+Q, 5
Q’ H|#%|CIC|U|%|%|E|3|F|g|H| 6| H|h | h|g|T|L|£
1‘| [S ® © ™ o] n|ne| @ o | Bla| w2 & ] R &[> ™ [¥|z|3{0
Wlthloudlameter sIh|K|A[B|C|e|e|E|Fld|m o|x|a|3]T
R S B I Group B x|
Unicode Subrange
I_,I ] 2 3 y4 Vz Ea‘”" | Punch g( ﬂ
s | 6 7 8 9 Resistance: 178 gﬁrﬁtﬂéﬁmg
Y y << )) P p :Lrlg'\m!;erForms
Mathematical Operators
E F G H J co py/paste Misca\lanauusTZ:hm:a\ ;I
Characters to copy

Spell checking

FM-8 supports 34 languages including variants such as Swiss
German and Swiss German (new). 4 dictionary levels:

Hierarchy of dictionaries:

1 Language dictionary.

Carmechian;

lan-guag-es . ..

Check: I 2 Site dictionary.

£ Bk [ Automatic Conection P 3 Personal (Project) dictionary.
1 fifap Optiohz... I .

& Document = p 4 Document dictionary.

™ Current Page ‘ Dictionaries. . | Dictionaries 2 ... 4 mix languages.
Start Checking | Comect | Learn | Al in Document | Unlearn |

Hyphenation

Text Options m

V' Smart Quates V¥ Smart Spaces

Influences

Allows Line Breaks After:
(==

Paragraph Tag: Ilbt-bulleted-tight ;I

Automatic Hyphenation;

= Paragraph properties
= Text options

Shetch [1000% | [1000% | [100.0% am s:::::wm:]:s— shotstsu} = Options in spell checking
Task Enter in text in dialogues
Avoid hyphenation ESC, n, s \_
Optional hyphen CTRL+minus \-
Nonbreaking hyphen ESC, minus, h \+

Nonbreaking blank CTRL+blank \. (\, blank)




Paragraph and character formatting

Note: Follow your template standards for naming formats! For exam-
ple, use x-name for chapter local items and z-name for layout
specific items.

Create a derived 1 Put the cursor into a paragraph with best fitting format
paragraph format (e.g. lwa-wide list).

wide list) wide list wide list wide list wide list wide list and
so on and so forth.

2 Define the new name (both in catalogue and selection).

Paragraph Tan: IIwI:n-mde-Ilst
- = = —
m ﬂ ﬁ Q ﬂ ﬂ HS Indentz and Spacing

Faragraph Tag: IIwa-wide-Iisﬂ ;I First: Above Pok: v Tab s
Indentz and Spacing ID'D il IE'D Rt ;I 40 cm L
i : Left: Belaw Paf: :
First: &bove Paf: ¥ Tab Stops: |4 5 IE Do _I
O ) -
[tocm [6opt =] .
= — NewFormat |
New Format
|20cm [Bopt =] — El
; ; Create a new paragraph format uzing
Right: Ling Space: N t the properties in the Paragraph Designer.
0.0 cm 125p0 = | =oAL _ ——
I I _I [Global Update Options. .. Tag: Im-l'ﬁ'llde-lISt

Alignment: [T MestPgf Delete Format... ¥ StoreinCatalog W Apply to Selection
ILeft - I I ;I SetWindow to bz |z

Fezet Window from Selection MI
P
Commands: E Update &l | Feset | £pply I

3 Modify the desired attributes (at best in the designer) and
check with Apply.

wide list b) wide list wide list wide list wide list
abc) cd) ef)gh wide list and so on and so forth.

more text here))) target

TABs are absolute

v vV

4 Click Update All to get the final definition into catalogue.

—

Create Character style Select text to see the effect of your formatting.
2 Character Designer > Commands > Set Windows to As Is

3 Define the name of the format and set the appropriate
attributes (do not forget language), check with Apply.

4 In Commands > New Format activate both Catalog and
Selection.

—

Import a specific style In the source document select the paragraph (or string)

with the desired format and copy it to the clipboard.
2 In the target document paste the selection.

3 In the Y/fDesigner select Commands, activate both
Catalog and Selection and then click Create..
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Hierarchical numbering

Example

1 format Label, intro
Ochapter :
lheading H:
2heading :
3heading :
tt-table-title H:Tab..
ft-figure-title H:Fig..

Syntactical elements

The term hierarchical numbering refers to heading numbers
with hierarchical dependencies. For example a level 3 heading
depends on the numbering of the level 2 numbering, which in
turn depends on the numbering in level 1.

In tab Numbering of the paragraph designer you see only the
numbering of the current format, not the relationship to the
other formats in the hierarchy. To see the dependencies it is
good practice to set up a scheme.

We assume 4 levels of headings. The highest level is the chap-
ter heading. The others are section headings. In addition,
tables and figures shall restart their numbering in the main
sections: Tab. k.n.m: and Abb. k.n,m: (c: chapter-#, n:
number from the main section, m: number of table or figure).

The following table describes this scheme ( . denotes a
required blank):

chapter level 1 level 2 level 3 tables figures TAB
<$chapnum> <,=0> <,=0> <,=0> <,=0> <,=0> \t
<$chapnum>. <n+> <,=0> <,=0> <> <> \t
<$chapnum>. <n>. <n+> <,=0> <> <> \t
<$chapnum>. <n>. <n>. <n+> <> <> \t
<$chapnum>. <n>. <> <> <n+> <> \t
<$chapnum>. <n>. <> <> <> <n+>: \t

H: Label of the numbering range. This may be any upper- or
lower case letter or nothing for local lists.
<$chapnum> Chapter number (normally set via the book functions)
<3=0> Set counter to 0, but do not display (hence the leading blank).
<n+> Increment counter and display value (hence no blank).
<n> Display current counter value.
<3> Place holder in this column to get the matrix straight.
Fig.3 Tab.3 . : \t Everything after the label and outside the <...> constructs is
displayed. \t creates a TAB character.
Building block Numbering type and range Hierarchical building block
<n> arabic 1,2 ...17 ... 65535 <$volnum>
<a> lower case a, b ... q ... aa, ab ... crxo (65535) <$chapnum>
<A> upper case A, B ... Q ... AA, AB ... CRXO (65535) <$sectionnum>
<r> lower case roman i, ii ... xvii ... mmmmmmmmmcmxcix (9999) <$subsectionnum>
<R> upper case roman I, Il ... XVIl ... MMMMMMMMMCMXCIX (9999)

Interpretation

In tab Numbering of the 9 format ft-figure-title gets:
H:Tab..<$chapnum>.<n>.<.>.<.><.><n+>:\t

The 5t figure in the 2nd main section of chapter 7 gets the
following representation:

Fig. 7.2.5: Effect of the fragrance of lily of the valley to
the behaviour of cockchafers



Table handling

“Space above” The table anchor is here: L

(Table designer). Table 1: Table title (] format tn-tab-title-numbered)

I
“Gap” (Title Position)
(Table designer). Heading cells (repeated on next page) Head Head
.
. > - -
Column ruling Body cells (f format tm-table-middle) strads
Body Row ruling . dled
Y cells
I— a
Separators \ A footnote reference
Cell margin (Table designer) Rt
This cell is very large to show the
Cell margin from { designer, — > margins and surrounding areas straddled cells
“Table Cell” properties.

Outside ruling o
Footing cells (repeated on next page) Foot Foot
Space defined by box

on Reference page. ®>a. This is a table footnote (] format ztf-table-footnote)
Space below———»

(Table designer) This is the next paragraph after the table, the ordinary text

2010-02-11

Individual ruling and
shading
custom ruLinG ano sHapinG [N

¥ Custorn Cell Ruling:

Apply Buling Style: To Selection;

Dutside Edge:

¥ Iop [V Bottom
IV Left [V Right

Inzide Borders:

EditFuing St | |7 Pow 7 Cobmn Select row CTR+double click at he far left/right of a
[V Custorn Cell 5 hading: Cell.
Fill: | 100% ~ | Caolor: [{iE=e - . .
‘ i =] oot R ‘ Select clumns CTR+double click into the middle of a cell.
Apply I Show Current Settings.. |
Appl Fuling Stle: To Selection
From Table DOutzide Edge:
T Top [ Bottom
™ Left " Right
Inzide Barders:
EditRuina Stye.. | || Row W Column
Import table from Excel 1 In Excel select the table area and copy to the clipboard.

2 In FrameMaker paste with Edit > Paste Special...

Paste Special: text Paste Special RTF
You get a number of tabbed para- You get an anchored table, to which
graphs, which you convert to a table.  you apply the appropriate table format.

3 Select an appropriate Table format and format the
rows/the table according to the needs.
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Anchored frames

Ancharing Position: I Below Current Line ;I

Alignment: I Left ;I

[ Cropped [ Floating

Size:

‘ Wwidth: |1 1.8 cm Height: |4.0 cm ‘

Frame with caption

Anchor paragraph =

Title paragraph =

Importing graphics
Attention with png graphics:

When creating png graphics
do not optimise the plaette
(less than 8bit colours)

png with less than 8-bit col-
ours create an entry into the
colour catalogue for each
colour in the png!

Inline graphics (icons)

Anchored frames are the universal container floating with the
text. Some forms are bound to a location on the page of the
anchor. Insert a frame with Special > Anchored Frame...

€ This (colour filled) frame is Outside Text Column. It con-
tains an imported graphic. The most used frame type for
graphics is Below Current Line:

This text is within a text frame
which is located in the anchored
frame. Use this form for longer ex-
planations in a graphic or side by
side to a graphic. Both { formats
and character formats can be ap-
plied. Tables can be anchored.

» The frame can either be filled with colour or have a border.
» There is no property “frame title” as it exists for tables.

1 Use a distinct paragraph for the anchor (e.g. za-anchor),
and define the following to become the next paragraph:

2 For the figure title define, for example, ftn-fig-title-
numbered. Specify Keep with previous (the anchor para-
graph). This §J may be automatically numbered.

Der froschkdnig war es nun end-
gultig leid, noch langer auf die
prinzessin zu warten.

Figure 1: The title (caption) for the graphic or the frame.

1 Select the frame into which you want to import the graphic.

2 File > Import > File ... opens the dialogue to select the
graphic file.

3 Choose Import by Reference (use Copy into Document
only in rare cases, for example on reference pages).

4 In the next dialog specify a resolution (for bit maps). You
may later modify this with Graphics > Object Properties
or Graphics > Scale.

5 The imported graphic can be resized with the mouse also.

For this form 4\ yse the frame type At Insertion Point:.
To move the frame up/down, use ALT+arrow on the selected
frame. You may wish to reset the paragraph property Line
Spacing Fixed.



Graphics with FM tools

Graphic objects The graphics palette defines graphic objects as well as prop-
erties for graphic objects. You may set the properties before
you create an object or apply the properties to selected
objects.

Ease graphic work with View > Options > Grid Spacing and
Graphics > Snap ON and/or Graphic > Gravity on.

| Arc (circle, ellipse)

Intelligent cursor (depending on object) R | cursor for graphic objects
Line
o

Open polygon “L | Freehand-line, spline

Rectangle O o Rectangle with rounded corners
Circle, ellipse  =J €2 | Closed polygon
Text frame A | Text line

Graphic frame
Define area fill pattern %%
Define line fill patten ;&
—

Apply area fill pattern

Apply line fill pattern

Define line width Apply line width

Define line-end type Apply line-end type

Apply line type
Apply colour

Define line type | ===

Define colour

Apply tint

Define overprint type Apply overprint type

HE NNE BN

il
wiill
Define tint O
el |

Tool bars for graphic

work

group ungroup  to front/back  ditribute reshape flip scale obj.prop. snap gravity
i “III -' l'f-"r"

nudge (1pt at 100%) = ALT+arrow align multiple objects (on last selected) turn (15°incr.) solid  dashed

4 W Qo

[ O Y =S

o Bl
A graphic object is either filled or has a border, not both.

Callouts Do not place numbers and text into the graphic itself. Overlay
these in the FrameMaker document to maintain constant font
size for the legends (and ease translation).

O 44 = overlay centered = copy/paste and edit figur@ @

and group
S€ a text frame for Tonger explanations.
Both | formats and character formats are
possible. Borders cling to the contents.

A text line can only use character formats (here: ft-fig-text).

2010-02-11
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Canned text

Variables
Typical variables

Mame: |product_name

Definitior:. DD FrameMaker support material

Character Fomats:

Cross reference to text
on reference page

Source:

Document: IEunent

] GotoSouce

Saurce Type: IF’aragraphs =1

Paragraph Tags:

Faragiaphs: Fage Reference

PSII T his text is located on the reference page Referen:
2-chapter-number
2-doc-classification
2-doc-info

z-fonter =
footer
el &l
Reference:
Fomat. | headingtilz = Edit Fomat. .
<1-highlights < fparatext> </>
Convert ta Test... | Replace I
Text inset

Layout items
Usage

Set up

AutoText plug in

[Default 1 Fori> il

< 0-novlanguages

<1-highlight>

< 2-highlight>

<3 highlight> | s

FileNamne: — fm-S-er.fm

Locatiot

Page - [ Headingl [ Heading2

4 | &
glofs| |

Canned text reduces redundancy and eases maintenance of
standard text (e.g. warning texts).

Product-name, revision-no, revision-date, author, copyright
date, manual-no, vendor.

Use for book-wide definitions. Use special names (e.g. x-name)
for chapter-wide definitions (must not be distributed via
book).

CTRL+0 (zero) opens the selection list at the bottom of the
window. Type the first characters of the name and press
Enter to insert the variable into the text.

Double click on the variable or Special > Variables... opens
the bottom Pod: Create new User variable with o5l Edit with

, Insert with 5.

Variables can contain text and highlights, but no other varia-
bles.

The maximum length in FM-8/9 is 1022 chars for UTF-8 text.
This includes the notation of character format, e.g.
<l-highlight>. Use </> to switch character format off.

Open dialogue via Special > Cross-reference... and search in
the current document for the relevant paragraph format,
select the paragraph:

This text is located on the reference page Reference in a text
frame with the flow name caveat. For finding this text easily it
has the paragraph format x-bodytext and not just bodytext.
However, you can also include this text into the body pages as an
inset. In case of an inset the name of the flow is relevant.

(the coloured background is on the current page).

Only single paragraphs can be referenced. However, mainte-
nance of these texts is easy: double click on the text to get the
dialogue Cross Reference where you click on Go to Source.

The purpose of the text should be recognisable within the
first few words because display in the dialogue is limited.

A text inset can be of arbitrary length (e.g. multiple para-
graphs). See Text insets on page 14.

Special pages, such as the last page of a chapter, containing
company address etc. Another usage is the famous This page
intentionally left blank in loose leaf publications.

A master page with name Last contains the text frame with all
the text. The text frame must be of type background, other-
wise the text will not appear on the body pages.

All FM constructs such as complicated tables, lists or figures
in frames can be handled. See AutoText on page 19.



Cross references

A document template provides a number of cross reference
formats. The text “See” or “See on page” shall not be part of
the cross reference format, because they may be needed in

several forms.

Cross reference to 1 Open dialogue Special > Cross-reference...
paragraph 2 Select Source Type Paragraphs. The list of paragraphs for-
o mats are displayed under Paragraph Tags.
Lecurent: [Curen =] SGowSarce] 3 Select the tag name for the target of the reference (e.g.
Source Type: IFavagraphs ;l 2heading)_
| S
ol e pan 4 Under Paragraphs you see the texts of these paragraphs to
Comactcssents choose from. Select the appropriate one.
Interpretation
IS | Noitetirideai ol 5 Under Format select the appropriate format for the refer-
Refeeree ence: heading & page. Below the drop down list you see the
<T+hi hIE::Tj: Ihteai?fpage \ <3y > ~ . pattern Of thlS format:
P I <l-highlight><$paratext></> on page\ <$pagenum>
The main building blocks of this cross reference format are
$paratext providing the text of the target paragraph and
$pagenum, the page number of the target paragraph.
6 With Insert the cross reference to the target is inserted at

Modify cross reference

the current cursor location: Create Character style on page 4

If a special format is needed, modify an existing one with Edit

format Format:
1 In the Cross Reference dialogue select the most appropri-
_ ate format and click Edit Format.
Marne: Iheadlng&page
e 2 Provide a new name, e.g. heading title mod and click on
Add to get the new name into the list.
Formats: Building Blocks:
ipsgenum ﬁl 3 In the Definition build the generation pattern with fixed
parden text and building blocks from the list. The list starts with
j Sparanumont> system variables and continues with character formats.
— Sl - Set up the new format, for example
a4 | _Chrse | Do | <2-highlight><$paratext></>
Done | Concdl | </> is shorthand for the building block <Default § Font>
4 Click Change to store the new definition and Done to leave
the dialogue.
5 In the Cross Reference dialogue click Insert to apply the
new format for the selected target reference:
Create Character style
C_ross reference to other » The target file must be open.
files » In the drop down list Document select the appropriate tar-

Note:

get document and find the relevant paragraph or cross ref-
erence marker.

The bottom Pod lists all markers under the tab Makers. They
can be handled there with the various action-buttons.

10
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Books

Set up book from initial
chapter

handout.booke |
EmERalte s es|= o
= & EFM-course®handout'handout book
..... titlepages fm

..... [l handoutTOC fm

..... [feal handout!X fm

..... working fm

..... texthandling fm

..... styles fm

| Gruppe 1

Crdnerl

..... a ayout fm

..... [F araphiics fm

..... a references fm

..... a book fm

..... a generated_docsfm

..... a acrobat fm

..... a formulas fm

..... [we] it fm

..... a specials fm

..... a tips fm

..... a rulesofthumb fm

..... a miscellenaous fm

Setting the numbering
properties of a book file

Numbering Properties m

anumel Ehapterl Sechnnl Sub-section  Page |F‘aragraph| Foo 4 I L4
-

Eormat: INumeric [14) ;I

" Continue Mumbering from Previous Page in Book

¥ First Page #: |1

" Read from Fils

Mo Unda)

Cancel

FM9 proviedes the new numering levels
Subsection and Section, which
can be used in the paragraph numbering
schemes.

Distribute formats

Note:

A FrameMaker book is a list of files (with properties) stored in
a book file. The book contains layout definitions from the file
from which it was initiated. These are used for generated files
such as TOC or index.

A book is set up to provide homogeneous numbering over
chapters and to be able to generate lists (such as TOC) and
indexes from the collection of files.

1 In the chapter file which shall become part of a book, use
File > New > Book.

2 You are asked whether the current file shall become part of
the book. Answer Yes.

3 The book dialogue opens with the (absolute) file name
entered.

4 Save the book with an appropriate name. The file name of
the chapter file w ill become relative to the book.

5 Add more files to the book. You may drag file names from
the Windows File Explorer into the book window.

6 Rearrange the file names by drag and drop.

Set up the numbering of the book files and perform an Edit
> Update Book to renumber the elements in the book.

Set up a numbering scheme for the whole book to overview
the numbering process, for example:

File Vol. Chapter Page number Paragraph Footnotes
title 1 0 1 roman restart 1
booknameTOC  same same continue roman continue continue
introduction same next 1 arabic restart continue
planning same next 1 arabic continue continue
working same next 1 arabic continue continue

1 Select the file in the book and open Format > Document >
Numbering.

2 Choose the required tab and define the numbering accord-
ing to the desired scheme.

3 Continue to set all numbering properties of the current file
and then advance to the next file in the book.

4 Apply the settings with Edit > Update Book (or icon ﬁ).
This will renumber the items (paragraphs, pages, etc.)

1 In the book window select the target files for the formats.

2 In File > Import > Formats select the source file and define
the format categories to be imported and distributed.

Document Properties cover a great set of properties and hence
need to be handled carefully!

11



Table of contents

Generate TOC from a file

Set Up Table of Contents m
Suffis: |TOC

dd File: [Eeioe I-]
Include Paragraphs Tagged: Don't Include;

Oichapter-titleTOC e
[Theading TheadingTOC
heading = headingrotos

—y ZheadingTOC
Bheading
SheadingTOC |

¥ Cieate Hypertest Links
Sct Cancel |

{Table of contents 1]

Generate TOC from a fila 1

Format the penerated TOC 2

Btandard formatting for the TOC entries 2]
[Table of contents within a text document ¥
TOC imported to the current flow 3]

TOC Imported to nested text frame 4§

Chapter TOC

Generate TOC for a book

Set Up Table of Contents m
Suffi. |TOC
&dd File: [Before handoutTOE: m =
Include Paragraphs Tagged: Don't Include;
[Dchapter-title [OchaptertitleTOC ﬂ
|1 heading P TheadingTOC
[2heading —I Zheading-notoc —
| [2headngTOC
3heading
3headingTOC LI
¥ Cieate Hypestest Links
Set 1 Cancel |

{Table of contents 1]

Generate TOC from a fila 1

Format the penerated TOC 2

Btandard formatting for the TOC entries 2]
[Table of contents within a text document ¥
TOC imported to the current flow 3]

TOC Imported to nested text frame 4§

1 Enter the document from which you want to generate the
TOC and select Special > Table of Contents...

2 You are prompted whether to set up a TOC as part of a new
book or as an independent file. Click Yes.

3 In the dialogue Set Up Table of Contents move the para-
graph styles, which should appear in the TOC, to the left.
(You can move all items from one side to the other by holding
SHIFT while clicking on the arrow button).

4 Normally you want to generate hypertext links: click the
selection box.

5 Click Set. A new file named documentnameTOC.fm is cre-
ated with default presentation of the TOC.

When working with a template, the document file contains
definitions for xxxTOC paragraphs which will be used and
the generated TOC looks final.

Save the file. Do not change the name of this file!

7 After changes in the original document file you must
update this TOC file: in the document file follow steps 1 - 6
from above. Since you already have a TOC file from step 6,
this will be used for the re-generation.

A TOC generated from a document file can be used as a text
inset in the document itself. To get correct page numbers you
must update after the insert both the TOC file and Inset in the
container file!

1 In the book file select the file before/after you want to
place the TOC and select File > Add > Table Of Contents.
In the book a file booknameTOC.¥m will appear, then opens
the dialogue.

2 Define where you want to add the generated file into the
book (only the selected file is in the drop down list).

3 In the dialogue Set Up Table of Contents move the para-
graph styles, which should appear in the TOC, to the left.

4 Normally you want to generate hypertext links: click the
selection box.

5 Click Set. A new file named booknameTOC.fm is created
with default presentation of the TOC.

When working with a template, the book file contains defi-
nitions for xxxTOC paragraphs which will be used and the
generated TOC looks final.

6 Save the file. Do not change the name of this file!

7 After changes in document files of the book you must
update this TOC file with Edit > Update Book...: Assure
that the TOC file is listed under “Generate”.
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Index

Insert an index entry
marxer [

Marker Type: I Imdex

Marker Text:

=l
index: define an entry; marker: index entr ;l
=

Edit an index entry

Blanks in index entries

Multi level entries

Multiple entries in one
marker

Special characters in
index entries

Generate index (for a
book)

Set Up Standard Index m
Suffie: |I%
&l File: [After handoutlX fm =l
Include Markers of Type: Don't Include:
Index uthar S
| |cemment
[Conditional Text
Y ICross-Ref
E quation
Glnssary =l

¥ Create Hypertest Links

g Cancel |

Index entries are markers of the type index.

1 Place the cursor at the desired point. Prefer the end of a
paragraph for the location! Translators will love You!

2 Special > Marker opens the dialogue Marker. The marker
type Index might be selected already. If not, select this
type from the drop down list.

3 If you have selected text, or do so while the Marker dia-
logue is open (it stays open), the selected text appears in
the box as Marker Text. The marker will be placed in front
of the selection.

4 Change the marker text to your desire and insert the
marker with New Marker.

» Open the dialogue with Special > Marker.
» Find (or directly select) the relevant Index Marker.

» The dialogue will get the marker text to be modified. The
button to be clicked now reads Edit Marker.

Blanks may be arranged around the colon and the semicolon
which have syntactic meaning in the entries. These blanks do
not appear in the index display. Required blanks (e.g. to keep
words together) must be inserted as \. (backslash, blank).

Multi level entries are separated by a colon (:). The following
example will create a main entry abrasion and a sub entry gla-
cial: abrasion: glacial

Multiple entries within one marker are separated by a semico-
lon. This is for example useful to place all permutations of
multi level entries in one marker:

character: delete; delete: character

Colon, semicolon, < and > are syntactic characters in Index
Marker entries and must be ‘escaped’ for literal use:

Income \> 100 millions; fruit\: vitamins for all
vegetables: cucumbers\; beans\; cauliflower

1 Select Special > Standard Index (or in book Add > Stand-
ard Index). A file named docnamel X .tm (or booknamel X .¥m)
is created (an appears in the book window). Then the set up
dialogue appears.

2 In the dialogue Set Up Standard Index the appropriate
marker type index is already selected.

3 Normally you want to generate hypertext links: click the
selection box.

4 Click Set. A new file named name booknamelX.fm is created
with default presentation of the Index.

5 For updates the same procedure as for TOC applies.
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Text insets

This text frame is located in
the reference page Reference
of the current document

Insert an inset

Import Text Flow by Reference m

Source: E:NFM-coursehCra...-3-enhfm-3-en.fm

Flow to Import:

" Body Page Flow: Mone Available - I
¥ Reference Page Flow: | caution-esd - I

Tac
Farmatting of Imparted Flaw: | 5

DocTaC
. _ M asterPagetd aps
Y'hile: Importing. B emofEeeee]

[ Manual Page Breal wam-electical-shock
cavest

[ Other Format Oven
¢~ Retain Source’s Formatting

' Feformat Using Curen

" Reformat as Plain Test

Updating of Imported Flow;

& Automatic
" Manual

Avoid duplicate information by referencing predefined
text.

Any text flow in any document can be used as an inset.
Hence the inset may come from a reference page of the
container document:

flow caution-esd

% ........................................................................ B e P
) ki CAUTIONS
Device may be damaged by Blectrostatic Discharge :
MEDIACLAVE electronic bhoards must not be touched without taking H
ESD protection steps such as use of an ESD wristhand or electrostatic :
conductive shoes §

For easy insertion use the same styles in the inset as for
the container document.

At the desired location start an empty paragraph with a no-
breaking space (CTRL+space) and locate the cursor before
this blank.

With File > Import navigate to the file with the inset flow.
This may be the current file to insert from the reference

pages.

Choose the type of flow to be imported (master page or ref-
erence page) and select from the drop down list.

Normally you choose Reformat using Current Document’s
Formats.

Click on Import to insert the flow at the cursor location.

/\ CAUTION

shoes.

Device may be damaged by Electrostatic Discharge.

<product name> electronic boards must not be touched without taking ESD
protection steps such as use of an ESD wristband or electrostatic conductive

Organise insets

Cross references

The no-breaking space hinders reformatting of the anchoring
paragraph according to the first paragraph in the inset.

Name the flows with their purpose/contents. For example,
name the flow warn-hot, caution-esd, info-customs.

You may set up a project specific document with insets
(various reference pages with various flows each).

Do not place cross references (inset = container) in an
inset, because the container changes!

For references from the container to the inset define a
cross reference marker (give it useful content) in the inset
to which you refer from the various container documents.
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Conditional text

Note:

Define a condition
ADD/EDIT CONDITION TAG _

Tag Mame: IUperator

Condition Indicators:

Styler [ Numeric Undsiine =l
LColor: [Magenta w | Mew Color
add | Ede

FileName:  fm-3-en.fm

Location:

Conditional ..~ | Page [ Headingl [ Heading2

Apply a condition to text

Display the conditional
text

Note:

SHOW/HIDE CONDITIONAL TEXT _

" Show All
" Show az per Condition

Show: Hide:

Comment _I
o

I~ Show if all Conditions Applied

= Show az per Expression

Expression I"Comment"DF!”Dperator" ;I

EBuild E xpression
Apply

¥ Show Condition |ndicators

Note:

Table columns (or individual cells in a table) cannot be made
conditional. Only whole table rows can be conditional.

1 Special > Conditional Text opens the bottom Pod with tab
Conditional Text. Click on Create new Tag .

2 Provide the new name in the edit box and select an appro-
priate style and colour for the display (this style is not
used for printing!); click Set.

3 The condition is now listed in the Pod.

1 Select the text which will receive the condition (for example
“Opeator”)

2 Special > Conditional Text opens the Pod. If you do not
see the desired condition tag in the “Not in:” column, you
must first set up this tag.

:LES 58| CONDITIONAL TEXT [

t: ICurrent : ;I g IE ﬂ ﬂ

" Conditional & Unconditional [ I Motln © Asls

Condition Tag = | Style | Color
Comment Underline Red
Operator Mumeric nderline M agenta

3 Select the desired condition for the text in the list and
select Conditional (radio button) and click Apply |==.

bl

4 The text with the condition gets a special appearanhce
according to the settings of the condition tag:

Hidden conditional text is represented by a maker symbol (T).

If you delete a Conditional Text Marker you actually delete the
conditional text!

To display (and print) text with and/or without any condition:

1 Select Special > Conditional Text > Show/Hide Condi-
tional Text.

2 To display (and print) everything, activate the radio button
Show All.

3 To display (and print) only certain condition texts,

- move the conditions into the appropriate column (Show
or Hide).

- Activate radio button Show as per Condition
4 Click Set
You may move all tags at once with SHIFT+click on an arrow.

The condition indicators (underlining, colour) are only visible
if Show Condition Indicators is checked.
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Create PDF
Save as PDF

PDF Setup X

Settings | Bookmarksl Tags | Links |

Settings i

FDF Job Options: | High Qualiy Prnt =]
Open POF Document on Page |1 atZoom |Fit Page -

I~ View Generated POF in Aciobat
I Generate POF for review only

Begistiation Marks: [Nore =1

|Mdm: 21.0cm Height: [23.7 cm ‘
| ® Al € Stat Page: [1 End Page: [25 ‘

If pou select a page range other than "4l generated
PDF will exclude Bookmarks, Tags, and Hypertext links

Page Size:

Page Range:

I Convert CMYK Colors to RGB

*

FM9p250:This setting - intended to
make FM behave as FM8 - creates a lot
of errors, hence do not use it until fixed.

Cancel

1

CEET x4

Setings | Bookmatks ] Tags | Links |
Bookmarks hd

¥ Generate PDF Bookmarks

Include Paragraphs:
Ochaptertitle

Don't Inchude:

MchaptertiieTOC
| . Theading TheadingTOC
i 2heading-notoc:

2heading
ltr-doctitle-ight <= | [2headingTC
Fheading
hia 3headingTOC
dheading
Sheading LI

Get Defauls

Bookmarks Expanded thiough Level: |1 - I
B

<< Bookmark Level k23
™ Include Paragraph Tags in Bookmark Text

I Articles IThread by Text Frame -

Set Cancel|

Note:

Frint PFage Range:

@ Al Start Page: |18 End Page: |1B |

= Odd-Mumbered Pages I Even-Mumbered Pages
V¥ Collate ™ Last Sheet First

I" Skip Blank Pages [~ Spot Calar &z BlackAwhite
[~ LowResolution Images

INone ;I
™ Thumbnails - Fews: |2 Cols: |2
Copies: |1 [100

IV Fint to File: Icourses\fm-ﬁ-en\fm-g-en.ps Browse... |

Registration Marks:

Scale:

‘ = it Separations

Separations Setup... | ‘
[V Generate Acrobat Data FDF Setup... | ‘

Setup... ”
Cancel |

‘ Printer:  Adobe PDF

With File > Save As PDF ... you get a standard File saving
dialogue with the file name documentname.pdf which you
may change.

After clicking Save the PDF Setup dialogue appears which
has 4 tabs for various settings.

In the Settings pane you define

- The set of Distiller parameters (Job-options)
- How the PDF document should open initially.

- Registration marks are only necessary if you want to
print on smaller paper and see crop marks to trim the
paper.

Further parameters normally need no change from the
already set values.

In the Bookmarks pane you specify which items you want
to have in the bookmarks pane of Acrobat/Adobe Reader.

- Define bookmarks from the heading levels with the <---
and ---> arrows. You can move all items from the left
pane to the right one (or vice versa), by holding SHIFT
and clicking the ---> (<---) button.

- Set the appropriate level of the bookmark with the <<
and >> buttons.

- To have the bookmarks closed to the first level, enter 1
into the drop-down list Bookmarks expanded through
Level.

Normally you uncheck the first check box both in the panes
Tags and Links.

Click on Set to initiate the generation of the PDF. Distiller
will appear automatically. It disappears after some time as
long as FM is open.

Automatically generated hyperlinks in TOC and Index as well
as cross references are live in the generated PDF.

Printing with Adobe PDF printer

1

For the document (or the book file) use menu Format >
document > PDF Setup to define the Distiller Job Options,
Bookmarks etc. See Save as PDF.

Open File > Print and activate

- Print to File and specify a file name (where you have
suffient space for a large file).

- Generate Acrobat Data (to get bookmarks etc.)

With Setup... select the printer Adobe PDF (formerly called

Distiller printer) and in Print Setup click on Properties...
There deactivate Relay on System Fonts only ..

Leave Printer Setup and in Print Document or Print Book
click on Print.

The resulting PS (PostScript) file must be processed by the
Distiller afterwards.
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Equation editor

vertical and horizontal list elements times
=
Relations Matrices Pasitioning
5 Calculus Runctions
2 =20l 2 e 22 | g
I? ilP ?'!/ ?.1. "_'? .1?
Vo] A? ﬁ' 2/ lo..10% ot
[]=? DE? f J_ 710 L
32 | -2 |/t | o | o |2

superscripts, subscripts

Distinguish opertors !

potence, power

Strings in formulas

The equation editor (formula editor) is controlled from a spe-
cial palette, which opens from Special > Equations ... or with
button E‘

The equation (or formula) is a special object created in an
anchored frame. It is not just a graphic.

An in-line formula is inserted in an ordinary paragraph,
rather than in a paragraph of its own.

Most time you will need to specify “no fixed line spacing” to
the anchoring paragraph give room to the formula. The frame
can be treated like any other anchored frame (border, back-
ground):

_ JB5-1
2

Such simple formulas can be entered directly from the key-
board:

- b Proportions of Golden Rectangle.

Typing Result Explanation
ESC m 1 Insert large equation (frame). The highlighted
? ? is the ‘entry point’ of the formula.
a= The new ‘entry point’ is the ? after the equal
a=7? sign.

\sqgrt Function names like sqrt, pwr, log etc. are
ENTER a= ﬁ preceded by a backslash and terminated by
ENTER:

5 space The ? is replaced by 5, the two spaces select

space a= the 5, then the square root as a whole.

-1 The “minus one” is attached to the selection,
a=.5-1 not just to the last entry.

space JE _1 The blanks select the 1, then -1, then the right

Space a=——>5— term. The slash creates a fraction bar below

space / ) this selection.

2 space 5_1 Selecting the right term provides the entry
space b a = T b point (?) to the right. A variable is displayed in
italics.

ESC m p E_1 Shrink wrap the formula. Then apply “variable
a = Tb line height” to the anchoring paragraph.

More complicated formulas require selection of math objects
from the Equation palette and enter items at the highlighted ?

Strings are required, for example to enter physical dimen-
sions or for ‘wordy formulas’. You start the string with " and
terminate it with RETURN:

success = Sxpenditure
effort
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Special layout

Assign master page

Master pages for rotated
tables

1

Create master page in por-
trait mode (e.g. copy from
Right) and name it appro-
priately (e.g. Rotated-
right)

Rotate page with Format >
Customize Layout >
Rotate page clock-
wise/counter clockwise.

Rotate central text frame
back. The heading/foot-
ing area will remain
rotated.

Multiple columns

A FrameMaker document may contain a (nearly) arbitrary
number of master pages, for example, title, last,
landscape-left, landscape-right).

For ordinary pages the master pages Right and Left are
assigned automatically. Other master pages are assigned with
Format > Page Layout > Master Page Usage...

Rotated tables are not rotated themselves but located in a
rotated text frame:

Text is oriented this way and tables are
placed normallyL

here you can edit the table similar to the text

pa1el04 S| eaJte bul0o4
paje10. S| eaJe bulpesy

Hecate est Iovis et Latonae filia, soror
Apollinis. Est tricopor et triceps,
magicarum artium magistra ac
fascinationum praeses, cinctra
latrantium canum turma; noctu stans in
triviis vel prope sepulcra et ubi taminata.

If for some reason you keep the master page in portrait mode
and just rotate the inner text frame, you can not directly edit
a table anchored in this text frame.

You can not change the number of columns within a flow. To
insert pages with other column layout than the standard
pages you need disconnected pages. The text within these do
not flow/reflow if text amount is changed.
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Useful addenda

Enhanced tool bar

.g-ﬂ ﬁr;l] I % nx-numbered-next -

These are plug-ins install as dl1”s (except the first one) and
hence do not need the FrameScript interpreter (which is a
plug-in by itself).

= Two button groups only, not four.
* Additional useful commands, e.g. F4 to repeat Y-actions.

A &£ a AbAB|mmputer - 0 ET

=L & =

FEELEE0 ¢ e

AutoText
AutoText

Hint
Warning

E-mail Address
Street Address

Recording Icons ~  [EESEY
Sto

o EEE
Pause

Sample Table Fast Forward

Archive (for books)

Cleaning tools
Tools

Characters List Character Usage
Readability * Delete Unused Character Tags

Create Character Tag List
Remove Non-list Character Tags

Create Conversion Document
Convert Characters

Remove Overrides
Find Next Override

v Skip Master Pages

Generate Character Tag Report

About Character Tools...

Poerful script collection

T G%EYWYWYIADE

The Enhanced Toolbar at www.daube.ch is based on the works
of Microtype.

i § Tm
ilpd =

Inserts FM constructs (pictures, tables, text) via menu or
shortcut. Installs menu item AutoText. The names in the sub-
menu (Hint, Warning etc.) are defined in an FM document an
hence can be of any language.

= An FM document contains the constructs.

* One set of items per FM-installation, but menu can contain
submenus for subsets of items, for example, icon collec-
tions.

Source: Silicon Prairie Software, USD 10.-

Collects all referenced graphics and text insets into two sub-
directories. Usage: File > Utilities > Archive document

» Useful to store a project on a CD or the like (collects all
files, even from the network).

» Useful to clean out the graphics directory.

» Unicode in file names is not supported.

Source: Bruce Foster, USD 25.-

These tools support the migration from old to new style defi-
nitions. Installs menu item Tools.

* Report used and unused styles to judge the need for clean-
ing the document.

Eliminate unused tags for paragraphs, characters and
tables.

= Rename tags for paragraphs, characters and tables by
means of a conversion table.

= Local overrides can be searched and eliminated.

Source: Silicon Prairie Software. Character Tools, Paragraph
Tools, Table Tools: USD 10.- each.

Another (more expensive) source for equivalent tools is
Squidds.de.

www.i-frame.itl.info provides a layered set of scripts for vari-
ous purposes (many for free). Precondition is the plug-in
FrameScript.
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Migration

Prepare the current
document

Import new styles

Check the import

Alternative method

To apply a new template to a current document some steps
are necessary:

1

Remove all unused styles (paragraph, characters, tables)
from the current document. Also remove unused colours
and unused cross reference formats. Without tools this is
quite laborious.

Remove unused master pages and unused reference pages.

Rename used styles which have different names than the
new template. Table driven tools are of great help here.

Import styles from the new template. Also import the mas-
ter and reference pages. In File > Import > Formats check
the boxes: remove Manual Page Breaks and Other
Format/Layout Overrides.

Styles with similar names in both the current document
and the new template get the new definitions.

Carefully check the updated document and apply new over-
rides (for example, page breaks) as required.

If old style names still exist, rename them to x-oldname to
indicate that they exist only in this document:

In paragraph designer select the style, change the name
and then Update All. You will get a prompt to allow the
new name.

Apply similar changes to character or table styles which
have old names.

For large differences in style the following method may be
useful.

1
2

Create a new document from the template.

In the old document select all text (CTRL+a) and copy it to
the clipboard.

In the new document Paste Special (Text only). Tables will
be inserted as paragraphs with TABS. You do not get
anchored frames yet.

Apply the appropriate styles (paragraph and character).

5 Reconstruct the tables with new format:

- Select the paragraphs to become the table.

- Select Table > Convert to Table...

- Select the appropriate table format and click Convert.
- It may be necessary to re-arrange and/or straddle cells.

Reconstruct the anchored frames:

- Copy the anchored frame from the old document.
- Paste it to the desired location in the new document.

- You may need to apply new styles to Text Lines (created
with A-tool) and text in text frames, adjust line thick-
nesses etc.

Archive the old document. It may be necessary to get some-
thing out of it later.
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Import from Word

Precondition

Although it may look tedious work the following method is
the safest - and in most cases fastest - method to import text
from other applications.

This method avoids the pollution of formats which are gener-
ated by the import filters which try to keep as much as possi-
ble of the source appearance.

A clean FrameMaker template with all necessary formats for
paragraphs, character, tables, cross references etc. is key. If
necessary the catalogues will be extended.

Prepare the Word file

Export graphics to
distinct files

Resolve anchored frames

Clean up the text

Save the Word file

Create a copy of the document and prepare this copy for the
import to FrameMaker:

= Export all graphics to distinct files (if you can not find the
original location of the graphic files).

» Convert Word graphics to distinct graphic files.

= Resolve anchored frames

* (Clean out text

Users of Word most time copy graphics into Word. Approved
practice in FrameMaker is to import graphics by reference.
Hence you may first create these graphic files (or find the
orginal location). A Utility such as Office Image Exporter may
be of great help.

Word graphics are available only in Word. They must be
extracted also. See Convert Word graphics on page 23.

After exporting all graphics delete them in the Word file.

Anchored frames in Word can be converted by FM-8 to FM-
anchored frames - but the process is not reliable. Hence select
all contents and place it outside the frame. Then delete the
frame.

Remove hard page breaks.
Remove hard line breaks if they serve only layout purpose.

Remove hard hyphenations and optional hyphenation.

v v v Vv

Remove field functions (such as TOC). In FM there are dif-
ferent mechanisms for most of them.

Save the cleaned document as RTF. The version of RTF saved
depends on the Word version and can not be determined from
the file.

Import the RTF to FrameMaker

1 In FrameMaker import this file to a location where the 9
format is Body or bodytext (if this is appropriate for most
of the text).

2 In case the document has been saved as .doc (Word file),
select Microsoft Word in the dialogue Unknown File Type.
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Format text in FM

Note:

Note:

Clean up the import

Note:

Remove numbering

When applying formats with a designer (Paragraph Designer,
Character Designer), do not use Update All, but Apply (to
selection only). User Update All only if really the catalogue
should be be updated!

The FM document looks nearly as the Word document,
because the filters try to keep the appearance. The document
does not yet contain any FM styles from the template. These
are now applied.

Some discipline is required to avoid to many left out * for-
mats.

1 Start with applying headings. First apply main section
headings, then sections, then subsections. With a tool such
as the Enhanced tool bar on page 19 it is easy to repeat for-
mat applications.

2 Standard running text gets the format Body (or bodytext).

3 When applying list formats the bullets and numbering fig-
ures are placed before the Word elements, which must be
removed (see Clean up the import on page 22).

4 Tables got the Format A during import. Hence the neces-
sary table format must be applied. Both horizontally and
vertically straddled cells are handled correctly by FM-8.

5 Word does not know about table title and heading rows.
Hence these must be reconstructed:

- Select and cut the body rows to be converted to heading
rows.

- Place the cursor into the now topmost row and with
Table > Add Rows or Columns add the desired number
of rows To Heading.

- Select the empty heading rows and paste the rows from
the clipboard with Replace Current Rows.

- If a table title is defined in the new template, set it up.

6 Format all cells (header, body, footer) with the appropriate
paragraph formats.

7 Apply the necessary character formats.
8 Insert the graphics (see Place the graphics on page 23).

9 Search through the whole document for formats with local
overrides (* prefix in the information area). Walk through
the lines with the ¥ key (in tables with TAB key through all
cells). As soon as you notice a * in the information area the
format has local overrides (or not yet an FM format).

With tools (see Useful addenda on page 19) the cleaning of doc-
uments can be accelerated significantly.

Bullets or other list introducers as well as numbering must be
removed from the imported list entries, because in FM they
belong to the property Numbering.

In the following do not use Change All even in so called obvious
cases. Always use Find or Change & Find.

Set up Find/Change with Wildcards ON and this find pattern:
[1-9].\t for single figures and [1-9][0-9] .\t for two figure
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Remove bullet symbol

Place the graphics

numbers. To find a), b) etc. use the pattern [a-z])\t . The
Change field is empty to delete the item.

If the bullet symbol is from the standard font, then it appears
as - However, if it comes from Wingdings or Dingbats etc,
then you see the base character in front of the list lines, these
may be &, U or everything else. Start your search pattern with
the first symbol coming along (Wi ldcards must be ON):

[=1\t and extend as soon as you discover more of these:
[=€*8c]\t

At the desired locations either import the graphics and let
them use the default FrameMaker anchored frame. When you
(like me) prefer to use specific anchored frames:

» Define an anchored fram Below current Line using the
width of the full text column, right adjusted and 2 cm high.

» Import the first graphic into this frame and align it (e.g.
with a margin of 2 mm on top). At this stage the height
might not be sufficient for the graphic, but leave it.

» Select the frame with the graphic in it and copy this con-
struct to all other places where graphics shall be placed.

» Replace the graphics in the frames 2 ... n (they are alrady
adjusted), modify the frame to the desired height.

Convert Word graphics

Method 1

Method 2

Word graphics can be copied and directly pasted into FM
(they are WMF objects). However it will very difficult to
extract them from FM for further use. Hence it is better to
paste them into a graphic application and save them to a file.

» Generate a PDF from the Word document. It may be useful
to delete all pages without graphics first.

» In Adobe Illustrator (or another program capable to edit
PDF) import a page from this file.

» With appropriate operations (such as ungroup, remove
crop mask etc.) get access to all relevant objects.

» Select all relevant graphic objects and copy them to a new
canvas.

» Save this graphic as PDF or eps with preview. You may crop
the PDF in Acrobat to the desired size, if you did not spec-
ify a proper canvas size.

» If the graphic application correctly handles WMF it is possi-
ble to directyl paste the graphic into it.
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Recommended

Zoom factors

[Preferences]

Line widths

[Preferences]

Snap and grid

Template path
from

to (for example)

Smart quotes

setup of FM

Much behaviour of FrameMaker is defined by settings in
maker.ini. Be aware, that in XP and Vista there is a local copy
in the user area (%APPDATA%, for example

C:\Documents and Settings\Klaus Daube\Application
Data\Adobe\FrameMaker\8.0) which has precedence.

Set the zoom factors to values which are most useful for your

paper size and monitor sizes. For example, for an 20" display:

Zoom=28, 36, 50, 74, 90, 125, 200, 353, 500, 1000

When zoomed to 353% a nudge (moving an object by
ALT+arrow key) moves by 0.1 mm steps

The default line widths are rather coarse; better may be:
PenWidths=0.1mm, 0.25mm, 0.35mm, O.5mm
In dialogues the values will be displayed converted to pts.

These can be set to be in the state most users wish for new
documents. The actual state is saved in the document.

If you want to get document templates from a special loca-
tion, change in section [Directories]

TemplateDir=templates
Templates=templates

TemplateDir=D:\_doc-std\Frame
Templates=D:\_doc-std\Frame\FM-templates

For better handling set section [Spelling]Jup with symbols:

SmartQuotes=\xd4\xd5\xd2\xd3 ;English € 7« uy2018, u2019, u201C, u201D

; SmartQuotes=\xe2\xd4\xe3\xd2 ;German > . U201A, u2018, u201E, u201C
; SmartQuotes=\xdc\xdd\xc7\xc8 ;French “ ” « » u2039, u203A, uO0OAB, u0OO0BB
; SmartQuotes=\xdc\xdd\xc7\xc8 ;Swiss < > « » Uu2039, u203A, uOOAB, u0OO0BB
; SmartQuotes=\xd5\xd5\xd3\xd3 ;Swed/Finn ” 7 ” ” 12019, u2019, u201D, u201D

Paste prefers text

from
to

Note:

The default for Paste (from none FM files with CTRL+v) may
create OLE connections (Object Linking and Embedding). To
paste the contents rather than the object property, change in
section [Preferences]:

ClipboardFormatsPriorities=FILE, OLE 2, EMF, META, DIB,
BMP, MIF, RTF, TEXT

ClipboardFormatsPriorities=TEXT, RTF, FILE, OLE 2, EMF,
META, DIB, BMP, MIF

ClipboardFormatsPriorities only affects the Windows clip-
board. It does not affect operations within FrameMaker

To paste without formats within FrameMaker use Paste Spe-
cial (CTRL+SHIFT+v) > Text. There are also utilities available
to strip formatting from the clipbaord.

Display character positions correctly

[Fonts]

DisplayUsingPrinterMetrics=0n (default since FM-8)

Match colours in FrameMaker and PDF

[Preferences]

GetLibraryColorRGBFromCMYK=None
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FrameRoman character table

20  blank

30 O
0 @
P

50

70p

21~ O — O D &
C< < 11O &

80

o O m C m wui X

1
A
Q
60 a
g
A
5 A

CA , C E ~N

\u00c4 \u00c5 \u00c7 \u00c9 \u00d1 \u00d6 \uOOdc \uOOel \u00eO

€ 6 I I 1.1 n 6 o
90 y .. . . ) ‘
Ae e i i A U ~n (o] 0
\uOOea \uOOeb \uOOed \uOOec \uOOee \uOOef \uOOfl \uOOf3 \u0O0f2
¢ £ § T R ©
a0
! " # $ & ’ (
\u2020 \uOO0BO \uOOA2 \uOOA3 \uOOA7 \u2022 \uOOB6 \uOODF \uOOAE
4
X £+ 0 S ¥ p ' 2 3
b0
0 1 2 3 4 5 6 7 8
\u00d7 \uOOb1 \uOOf0 \uO160 \uOOa5 \uOO0b5 \uOOb9 \uOOb2 \uOOb3
v
Ve
i i " Db f Yy « »
c0
@ A B C D E F G H
\uOObf \u00Oal \uOOac \u0O0dO \u0192 \u00dd \u0Ofd \uOOab \uOObb
do
\ w X
\u2013 \u2014 \u201c \u201d \u2018 \u2019 \u00f7 \uOOfe \uOOff
A EAE
e0
a e f g h
\u2021 \u00b7 \u20la \u20le \u2030 \u00c2 \uOOca \u0Ocl \uOOch
v Y rd n A Y A ~ —
S O U U U € circum tilde macron
flex
fo

p q r S t u v w

\u0161 \u00d2 \u00d2 \uOOdb \u00d9 \u20ac \u02c6 \uO2dc \u02c9 \u02d8

X T X I o~

a

a

X

”n

d

Aa

\u00e2

N

)

Ao
\u00f4

©

)

\uO0A9

\u2026

Y

Y

\u0178

AN

E

\u00c8

A4

breve

y

Codes Input method in FM Codes Input method in FM Area

80 ... 9f esc sequence: a0 ... fe CTRL-q sequence

1
€ ESC, %, A Y4 « cTrRL+q, 9
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Oa 0b 0Oc 0d Oe of

N
"

+ , - ./

< = > 7
J] K L M NO
Z [ \N ] ~ _
j k I mn o
V4 { } ~ DEL
a a a ¢ é e

\u00Oe4 \u0Oe3 \uOOe5 \u00Oe7 \u00e9 \u00e8

6 6 U uu

\u00f6 \u00f5 \uOOfa \u00f9 \u0O0f9 \uOOfc
™ L E g
|

3 + , - . /

\u2122 \uO0B4 \uOOA8 \uOOA6 \u0OOC6 \uO0DS8

N a 0 3 *x o

: < = > ?
\u0Obd \uOOaa \uOOba \uOObe \u0OOe6 \uOOf8
J K L M N (0]

\u00de \u00cO \u0Oc3 \u00d5 \uO152 \u0153

[ A

\u2044 \u00a4 \u2039 \u203a \ufb0l1 \ufb02
i II\ -I- i 7 ”n
j k | m n )
\u00cd \uOOce \uOOcf \uOOec \u00d3 \u00d4
= ° V74 ~
Z ring cedilla  double Z undef
1 acute
z { I } =~

\u017d \u0O2da \uOOb8 \u02dd \uO17e

Unicode sub range
Basic Latin; Letterlike Symbols
Latin Extended-A; Latin Extended-B

Latin-1 Supplement; Alphabetic pres. Forms

- Mathematical operators; General Punctuation

Spacing modifiers; Currency Symbols
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