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FMbiblio – Bibliography
with Citavi or EndNote
Overview of version 2.1
Citavi and EndNote are widely used tools for creating
bibliographies. These products do however, not support FrameMaker. The ExtendScript FMbiblio bridges this gap.
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Introduction

• Any operation performed by a script can not be undone1) )!
Best practice is to save the document before performing
script actions on it.
• In case of an error or change of Your mind you can simply
Revert to Saved for the pertinent document.
• Only scripts which do not modify document contents (e.g.
creating a new document) are safe in this respect.

Important

Function of this script

• You get the temporary citations the usual way with
ALT+CTRL+c (Citavi) or CTRL+c (EndNote) and paste it into
your document with CTRL+v.
• FMbiblio replaces temporary citations by formatted citations in FM documents and FM books.
• FMbiblio may expand temporary citations to bibliographic
references. This is recommended in footnotes only.
FMbiblio controls the collaboration of the following programs:
• FrameMaker (versions 10 upwards [5], de/en/fr).
• EndNote (version 8 upwards).
• Citavi (version 4 and 5)

2)

.

Glossary
bibliographic application

Generic term for either EndNote© or Citavi©.

bibliographic reference

The bibliographic item itself. It refers to another work. The format of this depends both on the publication and of the referenced item (book, journal article, patent etc.).

citation

The reference to a bibliographic item. The format depends on
the publication. e.g. for IEEE journals this is a number in brackets: [17].

temporary citation

Also called place holder for the formatted citation.

resolve temp. citations

Process of exchanging the temporary citations (place holders)
by the final form of the citation., for example
{Bartels, 1981 #14}  [17].

expand temp. citations

Process of exchanging the temporary citations (place holders)
by the fully formatted reference., for example
{Bartels, 1981 #14}  Bartels, K. (1981). Veni vidi vici, Artemis
Verlag, Zürich.

1
2

This must not necessarily be the case for plug-ins represented as dll’s.
See Legal issue in the US on page 20.
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Bibliographic applications
In Europe Citavi© spread very fast as an alternative to EndNote. In the US EndNote© is the most used application to maintain bibliographic data bases and generate bibliographies in
scientific works.
These products are widely used for dissertations, theses and
scientific publications of all kinds and are available for Windows and Mac OS. They are integrated with MS Word but not
with FrameMaker.

Forms of bibliographic
citations

I came across the following forms of bibliographic citations
which are all supported by FMbiblio.
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• In-line citation with a reference at end of the document in
full form. For the citation various formats are in use. IEEE
for example uses just numbers in brackets [4]. In a de-luxe
document the citations are cross-references to the references (like in this document).
• Footnotes provide the complete bibliographic reference. The
footnote reference is the citation. This form should be used
only for short bibliographies.
• Citations being the references themselves, most time
enclosed in parentheses. So the reader can easily skip it.
This format seems to be used only in non-scholarly works.

From citation to reference

1 After collecting references in the database of the bibliographic application, the user can insert a temporary citation
(also called place holder) into his document.
At this stage the final form of both the citation and references must not be known.
2 If the work is ‘finished’, the place holders are replaced by
their final form and the bibliographic references are listed
alphabetically or the numeric order or the citations.
For MS Word these steps are supported by macros. The first
step can be performed also in FrameMaker:
• In the bibliographic application select the relevant entry.



• In the FM document the place holder is inserted by paste.
For MS-Word the bibliographic application then scans the document to collect the place holders (and replace by final form).
Then it places the list of references (the bibliography) at the
end of the document.
These steps are the task of FMbiblio in FrameMaker.

3
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Cooperation with FrameMaker
Advantages using a
bibliographic application

Although bibliographies can easily be created in FrameMaker
by means of cross references, a bibliographic application provides the following advantages:
• Maintenance of a bibliographic database for several works.
• The database can be filled with data from various sources
including the Internet.
• Generated references and citations can adhere to a large
number of output formats (most publications require special
formatting).
• At the time of inserting temporary citations the final form of
both citations and references need be known3) .

Using RTF scan facility of
the bibliographic
application

It may appear reasonable to export the FrameMaker document
as RTF, then scan and modify it by the bibliographic application
and finally import the RTF again into FrameMaker. However,
some problems are:
• Anchored frames get new attributes (at insertion) with all
previous content as one image.
• Layout and formats must be re-applied.
• Cross references become useless, must be rebuilt.

Solution with FMbiblio

The script FMbiblio controls the collaboration between
FrameMaker and the bibliographic application. An intermediate RTF file contains only the data concerning the bibliography
and not the complete FM document.
• The script handles either an individual FM document or all
documents of an FM book.
• To handle independent FM documents, start FMbiblio in the
first of these documents, then in the next, etc.
• To handle documents from an FM book, close the book file
before processing the documents independently.
• You can, however insert temporary citations into an arbitrary number of FM documents concurrently.
Of course, nothing is perfect – FMbiblio may not satisfy your
demand.

Forms of citations
handled

Any form of temporary citation (copied from the bibliographic
application) can be handled by the current version of FMbiblio,
for example, the following:

3

Characteristic

Example

Simple form

{Müller, 1925 #13}

With page range

{Neuman, 2003 #653, p. 53-54}

Combined citations

{Shone, 1998 #222; Rogers, 2003
#551; UNWTO, 2006 #608}

Special symbols in author
names

{Wisconsin Dept. of Health & Family
Services, 2004 #614}
{Barnes-Ellerbe, 2004 #290}

Keep in mind that the required form may vary between publishers and institutes of a university.
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Script installation

Script installation

1 Close FrameMaker if necessary.
2 Download the Inst-FMbiblio.zip from my web-page
3 UnZip the file to the desk top.
4 Execute the file PrepareInstallation.exe as Admin.

Note:
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Windows Defender may react to this program with a virus warning. This is a false positive. You may check this with an upload to
Virustotal. See Avoid Windows Defender intervention on page 6.
5 The last six FM-versions present in your %appdata%/Adobe/
FrameMaker/ are listed in the dialogue (on your system
there may be only one).

The language of the installation dialogues adapts to the UI
language of your current FM installation (de, en, fr).
6 Select the appropriate FM installation and use Continue .
This opens the installation program:



7 Select the appropriate option(s):
-

Use the first option to start the script automatically at FMstart.
- Use the second option if you wish to start the script on
demand from a trusted source. You can define the script
in File > Scripts … > Catalog (Script Library) as Favourite:
use the Add button and navigate to
My Documents\Adobe Scripts\FMbiblio\FMbiblio.jsx.
8 With Install the script and associated files will be transferred into the relevant locations.
9 A message indicates the end of the installation. The desktop
icons will be removed.

5
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10 Edit the file maker.ini according to Setting up maker.ini on
page 6 hereafter.
FMbiblio-testfiles

These are located on the website . See Using the test files on
page 26.

Setting up maker.ini

There are a few values in the
%appdata%\Adobe\FrameMaker\vv\maker.ini file which have
to be modified by the user before the script can work correctly.
FrameMaker must be closed while you edit this file.
Define the name (only Citavi or EndNote, no version!) and full
program path of the bibliographic application:
FMbib_BibAppName = Citavi
FMbib_BibAppLoc
= H:\Science\Citavi\bin\Citavi.exe
Other entries concerning debugging are explained in Enable statistical output on page 27.

Note:
Bibliographic application

Note:

Avoid Windows Defender intervention
1 In Windows settings navigate to Windows Security > Virus &
Threat protection settings > Manage Settings
2 Go to Exclusions
3 Add the folder you need to exclude:
C:\Users\username\AppData\Roaming\D+DD

Details of the D+DD script installation
• Unpacking creates a program (Prepinstallation.exe)
and a directory (InstallThis).
• Prepinstallation.exe should be executed with admin
rights (right-click and select), otherwise a message will
appear indicating this.
• Prepinstallation adds user specific information into the
InstallThis\config.ini file.
• Then InstallThis\Inst-FMbiblio.exe is executed,
which creates a directory D+DD\FMbiblio in the Windows
Start directory and copies everything from InstallThis
there. In addition, a short cut is created to this directory.
• This directory contains Inst-FMbiblio.exe, which is now
executed and the unpacked files on the desktop) are deleted.
• Inst-FMbiblio.exe asks where the script should be copied
to (Startup folder or MyDocuments\Adobe
Scripts\FMbiblio). The selected option must also be
selected during a de-installation in order to de-install at the
correct location.
• The script consists of the main module FMmarkers.jsx and
the modules in the FMbiblio directory.
• Write the follwong to maker.ini in the user area in the section [D+DD]:
FMbib_BibAppName= Citavi
FMbib_BibAppLoc= H:\Science\Citavi\bin\Citavi.exe
FMbib_CollectFile=FMbiblio-collected.rtf
FMbib_DoingBook = no
FMbib_Logging=0
FMbib_Template=FMbiblio-tpl.fm
See also Setting up maker.ini on page 6
6

Script installation

Operating the script
Menu entries

The menu Bibliography with Citavi/Endnote is added to the
end of the Format menu.
The individual steps reflected in the menu provide more control than a complete run at once.
Format

See

2022-09-28

Bibliography with Citavi/Endnote… Documentation
1 Collect temp. citations

page 28

2 Call biblio application

page 29

either 3a Resolve temp. citations
or 3b Expand temp. citations in footnotes
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Documentation
Interrupting work

page 29
page 30

Display the PDF with this information.
If you plan to interrupt your work with FMbiblio between process steps (close FM), be careful to rebuild the situation (open
documents or open book) you had for the first step.
Depending whether you have worked on a book or an individual document you may need to change a value in FMbiblio.ini:
04_DoingBook = no
See Enable statistical output on
page 27.

Process citations

The three steps of the process are run in sequence. The third
step has two alternatives depending on your bibliography
desires. Follow the instructions provided by popup-messages.
See more details at Creating the bibliography on page 12.
The time needed by the script (steps 1 one and 3) depends on
the length of the documents and the number of temporary citations.
To avoid to much screen flicker, screen refresh is switched off
during most time of the script. When processing a book, you
will notice the change between the documents.
I have not found a safe method to stop the script. Pressing ESC
(even multiple times) doesn’t do anything. Let it run.
If the script runs havoc, you will need to kill FrameMaker.
The script does not save the changed documents. Hence You
may withdraw the changes (replacing temporary citations). by
simply closing without saving. After step 3 you may start again
with File > Revert to Saved.

Time consumption

Stop the script



Withdraw script work
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Checking the document files
FMbiblio will not work correctly if illegal characters – namely
the infamous x\0d aka Carriage Return appears in the file. 4)
The problem with this character appears with Find in forward
direction (and hence is not only a problem for FMbiblio). The
find stops there. While the script can find all temporary citations, the later process (replace the temporary with the formatted citations) stops there.

Source of error

Check and correct files

You can not find these characters with Find in forward direction. Hence You must start at the end (of the document or the
end of the last document of a book) and search backwards.

At least since FM-12 you can change to nothing with Change &
Find. Change All does not work for this!
Another method to get rid of these disturbing characters is
‘MIF washing’:
1 Save the file(s) as MIF.
Do not save the current FM-version!
2 Open the MIF file(s)

MIF washing

3 Save the file(s) as ordinary FM documents thus overwriting
the misbehaving files.

4

Common source of this are old Word imports.
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Process overview

Process overview

The script FMbiblio controls the data flow between the two
involved programs:
FMbiblio

Temporary citation

Biblographic reference

2022-09-28

Formatted citation

FM with temporary citations

Müller et al
{Müller, 1925
#13} developed
an open issue on
this and hence
…

RTF file

1
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Bibliography

FM Bibliography resolved

RTF file

[[Müller, 1925 #13]]{Müller, 1925
#13}
[[Müller, 1925 #13]]{Müller, 1925
#13}
[[LaBonté, 1989 #11]]{LaBonté, 1989
#11}
[[Garneau, 1990 #12]]{Garneau, 1990
#12}
[[Bartels, 1981 #14]]{Bartels, 1981
#14}

2

[[Müller, 1925 #13]][1]
[[Müller, 1925 #13]][1]
[[LaBonté, 1989 #11]][4]
[[Garneau, 1990 #12]][6]
[[Bartels, 1981 #14]][2]
1.
Müller, P.D.H., De viris
illustribus. (9. ed.) 1925,
Hannover: Carl Meyer (Gustav
Prior). 155.
2.
Bartels, K., Veni vidi
vici. 5 ed. Lebendige Antike.
1981, Zürich: Artemis Verlag.
88.

3

Müller et al [1]
developed an
open issue on
this and hence
…

Bibliography
[1] Müller, …
[2] Bartels, …

Copy from biblio
Paste with CTRL+v

Bibliographic
database

bibliographic
application

Output
formats

Prepare the document

During the text development temporary citations (place holders) are copied from the bibliographic application into the user
document.

Step 1

The temporary citations are collected in FrameMaker and written into a new FM document. Two forms are written to avoid
problems during resolving the references in the bibliographic
application.
This new document is saved as RTF to allow the bibliographic
application to handle it.

Step 2

The bibliographic application scans this RTF file based on the
current bibliographic database and the selected output format.
The result is a new rtf file containing both the formatted citations and the generated bibliography.

Step 3

The new rtf file is opened by FrameMaker and the temporary
citations in the user document are searched and …
… replaced by the formatted form of citations, In this case the
user must copy the bibliography to an appropriate place in the
FrameMaker document or book and format it.
… replaced by fully formed references (e.g. in footnotes).
The author recommends to save the processed FM documents in
a different directory. This allows you to continue your textural
work with files containing the temporary citations. This is also a
safeguard against problems with the script.

either

or
Note:
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Specialities and restrictions
Note:

FMbiblio version 2.1 supports citations and/or references in
Right-to-Left languages (Arabic, Hebrew). FrameMaker 13 and
higher do so and newer versions of Citavi or EndNote do so. See
Testfiles on page 26.

Empty citations

FMbiblio can not work with output formats which replace the
temporary citations with nothing. Some formats of this type
are: Footnotes (EN 8), Amer Literature and GPA Verlag. Check
your particular format — it must not be empty.

Output formats

Citavi

EndNote

Citation > Citation Style > Edit
Citation style (SHIFT+F11)

Citations > Templates

If the output format is empty, define:

[Sequence Number]

Author-Date formats

[Bibliography Number]

These formats do not provide a relationship between the formatted citation (1) and the bibliographic reference(2) in the
resolved RTF file5) :
{Bartels, 1981 #14]](Bartels 1981)
{Müller, 1925 #13]](Müller 1925)

1

Bartels, K. (1981). Veni vidi vici. Zürich, Artemis
2
Verlag.
Müller, P. D. H. (1925). De viris illustribus.

Hence these formats can not be expanded automatically.
In addition the Author-Date formats do not distinguish
between the works of an author from the same year.
These are only handled for references. A citation currently can
not receive special formatting such as superscripting. See 3
Resolve / expand temporary citations on page 14.

Output formats with in-line
formatting

Collecting and resolving
temporary citations

Temporary citations are collected and resolved in these places:
• Standard text flow.
• Footnotes.
• Table title, heading cells, body cells, table footnotes.
• Text frames within anchored frames.
• Cross references (to citations). The citation is not expanded
by FMbiblio, but by the update of the reference by
FrameMaker.
Temporary citations are not found in the following places:
• Text lines (graphic object).

Expanding temporary
citations

It is not very meaningful to expand temporary citations to bibliographic references anywhere in the text. This function is
intended for footnotes and table footnotes.
The expanding process does not check where the temporary citations have been place!

Note:

5

10

How to find the reference corresponding to the citation? It can not be guaranteed that the 3rd reference corresponds to the 3rd citation.

Process overview

Author names with quotes

Be aware of the FM setting Smart Quotes in Format >
Document > Text options. Do not type over inserted temporary or formatted inserted citations with apostrophes!
Although not typographically correct various forms of quotation marks may appear in the database (only the Right Single
Quotation Mark ’ =x92) is correct): D’Alembert (correct) – D'
Alembert (not correct).
Hawaian names may contain another character: Kaho‘olawe
(x91).
A single accent grave (x60) is copied twice to the clipboard in
EndNote (D`Alembert is copied as D``Alembert) and hence
inserted incorrectly into the temporary citation.
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Accents in names
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Creating the bibliography
Check file(s) …

Independently of using FMbiblio it is advisable to get rid of illegal characters . see Checking the document files on page 8.
Save your document before starting FMbiblio. You can not
UnDo6) the replacement of the temporary citations performed in
step 3. But since FMbiblio does not save the processed file you
may «revert to saved» for undoing all actions of FMbiblio.

Note:

Inserting temporary
citations

1 In the bibliographic application select the Citation in the
Database view and copy it to the clipboard:
Citavi

EndNote

ALT+CTRL+c

CTRL+c

Citation > Quote > Copy to
clipboard

Edit > Copy

2 Switch to FrameMaker and place the cursor in the document
where you want to place the citation.
3 Paste the temporary citation from the clipboard (CTRL+v).
The inserted temporary citation has the format 7)
{LaBonté, 1989 #11}.
You may select multiple entries by CTRL+click to combine
citations. FMbiblio can handle these also. However, the
result of pasting into FM depends:

Selecting multiple entries in
the data base

Citavi

EndNote

Series of temp citations

Combined temp citation

{Ball, 2001 #642}{Neuman,
2003 #653, p. 22-23}

{Ball, 2001 #642; Neuman,
2003 #653, p. 22-23}

Both cases lead to a combined formatted citation [27; 45]

Note:

Combined citations can not be handled in the process of expanding (menu “3b Expand temp. citations in footnotes”). Of these
only the first item is handled:
Temp citation

What will be used in expansion

{Ball, 2001 #642}{Neuman,
2003 #653, p. 22-23}

{Ball, 2001 #642}

{Ball, 2001 #642; Neuman,
2003 #653, p. 22-23}

{Ball, 2001 #642}

Start the script8) FMbiblio. You will get an additional menu
item at the bottom of the Format menu.

1 Collect temporary
citations

• To collect citations from a single document and process
them later, activate your document.

6
7
8

12

Well, you have more than 1 Undo step, but some 100 Undo’s might not be
reasonable.
This assumes that the default template for temporary citations is used.
Of course you may have started the script already, because initially it only
sets up the menus.

Creating the bibliography
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• To collect citations from all documents of an FM-book and
process them later, activate the book. For ‘safety reasons’
you should not have another book open.
The temporary citations are collected into memory and then
written to a new FM document, which is saved in RTF format
and then it is closed.
Two forms are written to avoid problems during resolving the
references in the bibliographic application:
1 A bracketed form which is derived from the braced form ,
for example [[Müller, 1925 #13]].
2 The form with braces as used in the user document for the
bibliographic application to resolve the reference, for example {Müller, 1925 #13}.
[[Müller, 1925 #13]]
#13}¶



{Müller, 1925
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This new document is saved as rtf to allow the bibliographic
application to handle it.
A message is issued at the end of the step.

2 Call bibliographic
application

Now the bibliographic application comes into play. This dialogue reminds you about the tasks. It is kept open until you
close it by clicking the X button in the top right corner:

Note:



Be aware that for the function of menu “3b Expand temp. citations in footnotes” you need the special output-format _FMbiblio-expanding!
Citavi

EndNote

- Select the appropriate output style
- (Edit > Output Styles)
- Perform Citation > Format
publications… > Choose
documents (Shift+F7)

- Perform Tools > Rtf Document
Scan.

- Select the RTF file to be handled (paste the file-name provided by FMbiblio from
the clipboard)
- Save with name provided by the bibliographic application (the base name is appended by the format name).
- Dismiss this dialogue with the X button.
- Then invoke the next process step in FM-biblio.
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Follow the instructions in
• Setting up and using Citavi on page 20 or
• Setting up and using EndNote on page 22.
The bibliographic application works on the generated rtf file
and creates a new one which is saved with a name containing
the output format, for example:
fm-biblio.rtf  fm-biblio-Numbered.rtf
After the save the bibliographic application can be closed.

3 Resolve / expand
temporary citations

The modified rtf file is opened by FrameMaker and the temporary citations are either replaced by the formatted citations
(see 3a Resolve temp. citations on page 14) or to formatted references (see 3b Expand temp. citations in footnotes on page 15).
If you had collected in a book and the book is not active now,
you get a message to correct the situation.
Dismiss the message and activate the book before you initiate
Step 3 again.
The first part of the rtf file from step 2 contains formatted
citations to the right according to the output format selected in
the bibliographic application:
To the left the lines contain the bracketed form, to the right the
formatted citations are present. The example shows the IEEE format:

Details of the rtf processing

[[Müller, 1925 #13]]
[[Bartels, 1981 #14]]

[1]
[2]

The second part of the new RTF file contains the generated bibliography:
1. Müller, P.D.H., De viris illustribus. 9 ed. 1925…
2. Bartels, K., Veni vidi vici. 5 ed. Lebendige…

For expanding the temporary citations to references (case 3b) a
special form of formatted citations is needed (see Expanding
temporary citations on page 16).

3a Resolve temp. citations

This method replaces the temporary citation by the formatted
ones. The in-line-formatting of the citations is lost. Hence an
output format [10] will become [10] in the FM document9).
Copy the generated bibliography from the rtf file to the appropriate place in your document. Use Paste Special with RTF to
keep the formatting from the bibliographic application.
The bibliographic application applies local formatting to the
text (not Character formats) and puts the numbering in the
text. For different formatting (e.g. automatic numbering by
FrameMaker) you need to edit the text in FrameMaker.

Handle the bibliography

9

14

1.

Bartels, K., Veni vidi vici. 5 ed. Lebendige Antike.
1981, Zürich: Artemis Verlag.

2.

Daube, K. Text and Code - A Dragons Pond. in
G.U.I.D.E. Conference. 1989. Basel, Switzerland:
GUIDE.

Preserving the format may be subject of a later version [my health permitting].

3b Expand temp. citations
in footnotes

With this method formatted citations will not be used, because
the temporary citations in footnotes (or elsewhere!) will
directly be expanded to bibliographic references.
As a consequence of this presentation a document section bibliography is not set up.
For details see Expanding temporary citations on page 16.

Completion message

The completion of FMbiblio is displayed by a dialogue summarising the work done.

Adding bibliography incrementally
When extending the document after inserting the bibliography
you might need to sort in the added bibliography paragraphs
manually and also adapt any numbering.
Therefore you are recommended to keep the file(s) with temporary citations and use the file(s) with the formatted references
only to create an intermediate (or final) “state of the work”.

Bibliography of a FrameMaker book
FMbiblio may be started in a FrameMaker book with no open
files. One book file after the other will be opened and processed. Only *.fm files are opened though.
Common Open Errors, such as missing fonts, unresolved cross
references or old FM version are handled (accepted by the
script). You may still get prompts for rare situations which I
could not foresee.
If there are missing graphics, you will get the message Some
graphics could not be displayed, ... grey boxes ... as soon as you
come to such a page. But this is not during the open of the files.



E:\_DDDprojects\FM-Biblio\Docu\FMbiblio.fm

2022-09-28

Creating the bibliography
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Expanding temporary citations
A special form of bibliography places the bibliographic references in footnotes 10). In this case, the citation in the text is just
the footnote reference as here 11). For example:
Hecate est Iovis et Latonae filia, soror Apollinis 1). Est tricopor
et triceps, magicarum artium magistra ac fascinationum
praeses, cinctra latrantium canum turma 2) ; noctu stans in
triviis vel prope sepulcra et ubi loca sunt.

Before processing

1
2

{LaBonté, 1989 #11}
{Garneau, 1990 #12]}

Hecate est Iovis et Latonae filia, soror Apollinis 1). Est tricopor
et triceps, magicarum artium magistra ac fascinationum
praeses, cinctra latrantium canum turma 2) ; noctu stans in
triviis vel prope sepulcra et ubi loca sunt.

After processing

1
2

To achieve this, the following
steps are required:

LaBonté, A. A New Data Type for National Language? in SEAS Anniversary
Meeting. 1989. Amsterdam, The Netherlands: SHARE European Association.
Garneau, D., ed. National Language Support Reference Manual. January
10, 1990 ed. National language Information Design Guide, ed. IBM. Vol. 2.
1990, IBM National Language Technical Centre: Toronto, CDN.

1 For each reference you create a footnote and insert the temporary citation in the footnote.
2 In the bibliographic application use the output format _FMbiblio-expanding. See hereafter for the procedure to define
this.
3 In FMbiblio use menu 3b Expand temp. citations in
footnotes.

Note:

Combined citations can not be handled in the process of expanding:

Note:

Temp citation

What will be used in expansion

{Ball, 2001 #642}{Neuman,
2003 #653, p. 22-23}

{Ball, 2001 #642}

Depending of the existence of individual temp. citations some of
these may be expanded. This depends on the order the bibliographic application finds them in the data base.

Reference output format

To convert citations into references, FMbiblio expects the bibliographic application output format _FM-biblio-expanding (the
underscore at the beginning of the name helps you to find it in
the huge list). This must be created as follows:
1 Create a copy of your favourite output format and save it
with the name _FM-biblio-expanding. See “What Should I
Do if My Style Is Not Included?” in the bibliographic application Help

10 They may, however, also appear in the text or as side notes.
11 See also Expanded citations, second method on page 25-18
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2 Edit the format _FM-biblio-expanding to get the desired
properties:

E:\_DDDprojects\FM-Biblio\Docu\FMbiblio.fm
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Citavi

EndNote

• Open Citation > Citation Style > Edit
• Open dialogue Edit > Output Style > Edit
Citatidialogueon Style
_FM-biblio-expanding
• Select _FM-biblio-expanding.
• In the left pane select:
- About this Style
• Now You are in the Style Editor
check the field Based on
• In the right half of the main pane select the
- Citations > Templates:
last entry Unknown and in the main pane
edit the Rule set In-text citation:
Bibliography Number
(no brackets etc around it)
- Scroll the left pane down to find Index in
bibliography (with no brackets around it).
- Bibliography > Layout:
Bibliography Number
- Drag this item to the Rule set In-text cita( is the TAB-field)
tion and drop the item. You get it in addition to the bracketed form.
- Click on the bracketed form to select it
and delete it.
• Open menu File > Citation Style Properties
(takes some time).
• In the left pane select …
- Help text:
precede the heading with Based on ;
click OK.
- Bibliography: > Reference numbers:
clear the fields Text before … and Text
after…, thus removing the brackets;
click OK.
3 Save the modified output format _FM-biblio-expanding.
For Citavi you find _FM-biblio-expanding.css in the folder
FM-biblo-testfiles\DB-for-Citavi5. You can copy it to
C:\Users\username\Documents\Citavi 5\Custom Citation Styles\
to become available in Citation > Citation Styles.

Note:

Successive similar
references

You may have the same reference on one page in succession.
Before You start FMbiblio you should replace the second to last
same reference by the word ibid12):

48. {Müller, 1925 #13}
49. {Müller, 1925 #13}
50. {LaBonté, 1989 #11}

48. {Müller, 1925 #13}
49. ibid.
50. {LaBonté, 1989 #11}



Then this reference will not be resolved by the process - as it is
just ordinary text:

[1]48.Müller, P. D. H. 1925. De viris illustribus (9 ed.).
Hannover: Carl Meyer (Gustav Prior).
[2]49.ibid.
[3]50.LaBonté, a. A New Data Type for national Language?
in SEAS Anniversary Meeting. 1989 Amsterdam, The
Netherlands: SHARE European Association.

12 The word ibid stands for ibidem (aforementioned).
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Final work

Since Footnotes in FrameMaker may end up on the following
page of their reference, the ibid may be placed wrongly. Hence
you need to check this and probably replace some ibid by the
original citations, which you will find in the footnote before
the one with the ibid.

Additional use of expanded citations
You may set up your bibliography with cross references to temporary citations in a special chapter and then expand those to
full references. With this method you get the most elegant bibliography: uncluttered text and live cross references to the bibliography.

Reference to temp
citation

Here we just demonstrate the setting of a cross-reference to a
temporary citation [1] and another one [2]. In this example it is
just hereafter - but in real life it will exist in a chapter or at the
end of some document.
The cross reference format used in this example is bib-refnumber with the content <hypertext><$paranum></> . The
character format hypertext sets the text to blue.

Temporary citation

This is assumed to be in chapter Bibliography. Use a special ¶format for these entries (e.g. bibliography) for easy creating
the cross references. Key is the autonumbering here: Z:[<n+>]
For the first paragraph you set it manually (Apply) to
Z:[<n=1>] .

[1]

{Barnes-Ellerbe, 2004 #48}

[2] {Bartels, 1981 #14}
You may have set up these temporary citations in advance and
then insert the cross reference in the text.
The cross reference markers will be placed at the end of the
autonumber.
If you need to re-arrange these paragraphs later, apply the
standard numbering n+ to the first ¶ before you move it somewhere else. Then again set the numbering for the first P to n=1.
Of course you must update your cross references afterwards.

Expanding the temporary
citations

If you have set up the temporary citations in a separate document you need only process this with FMbiblio (steps 1, 2, 3b).
The cross reference markers stay intact. The

[1]

Barnes-Ellerbe, S., Knudsen, K. E., and Puga, A.
(2004). "2,3,7,8-Tetrachlorodibenzo-p-dioxin blocks
androgen-dependent cell proliferation of LNCaP cells
through modulation of pRB phosphorylation." Mol
Pharmacol, 66(3), 502-11.

[2]

Bartels, K. (1981). Veni vidi vici, Artemis Verlag,
Zürich.

Expanded citations, second method
If you know right from the beginning that this is the format of
choice, you may use a simple copy and paste from the bibliographic application. The format of the references must be set
in the output format of the bibliographic application.
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Since the footnotes themselves are numbered you should use
an output format not containing numbering, such as (in the
examples here) Academic Management Review.
For best appearance you may need to set up an own output format which fits to your FM document appearance (see Reference
output format on page 16)
1 Place a footnote reference in your text like this: 13).
2 In the bibliographic application find the desired bibliographic reference.

2022-09-28

To insert the bibliographic
reference:

3 Copy the formatted reference to the clipboard. Citavi:
CTRL+SHIFT+C; EndNote: CTRL+k.
4 In the footnote (see bottom of page here) paste the text from
the clipboard.
Note:



E:\_DDDprojects\FM-Biblio\Docu\FMbiblio.fm

Depending on your settings in maker.ini for
ClipboardFormatsPriorities you will either use ordinary paste
(CTRL+v) or paste special (with RTF) by SHIFT+CTRL+v get the
formatted text (see footnote 13) or the unformatted text as with
this footnote14).
If you are tired of using SHIFT+CTRL+v, selecting RTF and then
Enter you may wish to set in maker.ini [Preferences]:
ClipboardFormatsPriorities=RTF, UNICODE TEXT, TEXT,
FILE, OLE 2, EMF, META, DIB, BMP, MIFW, MIF

13 Müller, P. D. H. 1925. De viris illustribus (9 ed.). Hannover: Carl Meyer (Gustav Prior).
14 Müller, P. D. H. 1925. De viris illustribus (9 ed.). Hannover: Carl Meyer
(Gustav Prior).
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Setting up and using Citavi
Legal issue in the US

Reading the generated RTF file and resolving the temporary
citations is the fundamental function of the bibliographic
application for FMbiblio.
In Citavi 3 it was possible to insert references into a document
using place holders. These place holders were then converted
to formatted citations in a second step. At the same time, a bibliography was created. This option worked with all programs
that support rich text format (rtf), including OpenOffice
Writer, LibreOffice Writer and Scrivener.
Recently this place holder conversion process was protected by
a patent. As long as this patent is valid, we are unable to offer
the option to convert place holders in the United States.
What does this mean for you?
• When you download and install Citavi 4 in the United States,
this feature is not available.
• If you download and install Citavi outside the United States,
this feature is available. However, it will be deactivated if
you are using Citavi in the United States based on your IP
address.
What implications does this have in Citavi 4?
• If you use Citavi with the Add-In for Microsoft Word or with
a LaTeX-Editor or if you do not use Citavi to create publications, this restriction will not affect you.
• If you want to use Citavi with other word processors, you
cannot do so in the United States.

Statement in the Citavi
manual [1]

Consequences for
FMbiblio

You can not use FMbiblio with Citavi in the US due to patent
«System and method for citation processing, presentation and
transport and for validating references, US020120072422A1»

Citavi version > 5

As a consequence of this patent-quarrel and the increased use
of cloud based solutions Citavi 6 and above does no more support place holders as they are used in FMbiblio.

Set-up for temporary
citations

The default format of the temporary citations - called quote - is
defined as {author year db-record}, for example:
{Daube 2013 #1119}
{Sonderegger 2015 #1117}
This can be modified with Citation > Quote > copy or Insert
with Options. This influences however only the final format.

Define the reference data
base

You may specify the reference data base with File > Open
Project before you start FMbiblio or on demand of the script.

Specifying the
output format

In Citation > Citation Style > Browse Citation Styles you
select an already defined style. Styles can be modified and
stored with an adequate name (e.g. IEEE-D+DD, my personal
variant).
To handle menu option 3b (Expand temp. citations in footnotes)
you need to set up a special output format. See Reference output
format on page 16

Note:

Formatting the collected
temporary citations

In the second step of the FMbiblio process you are requested to
open the RTF file with the collected temporary citations and
apply the output formatting to it.
20

Setting up and using Citavi

2022-09-28

The path or the RTF file is already in the clipboard to be able to
paste it directly to the open dialogue of Citavi:
Citation > Format publications… > Choose documents
(Shift+F7) …
Opens the last used directory - it may already be the correct
one.
Paste the path of the RTF file into the input field.
After clicking on Open you get the dialogue which shows
whether the references have been resolved or not (a):
Reference cold be resolved

Red icon

Reference could not be resolved.

The output style (b) is that you have selected in Citation >
Citation style.
After clicking on Format ... a new file is generated and you are
requested to Save it. The proposed name is the original name,
appended by the name of the output format (e.g. BibFMcollected.rtf  BibFM-collected-IEEE-D+DD.rtf).
You get notice that you may open the generated file in Word.
Inspect the file, but do not change/save it!
The dialogue shown at left is then dismissed. You may now
leave Citavi.
Everything is now ready for step 3a or 3b in FMbiblio.

a

b
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Green icon

21

FMbiblio – Bibliography with Citavi or EndNote

Setting up and using EndNote

The relevant dialogues for the work with FMbiblio have not
changed muchover the development of EndNote.

Set-up for temporary
citations

The FMbiblio process assumes a certain setup of EndNote:
In EndNote ((Edit >) Preferences > Temporary Citations)
assure curly braces for Citation Markers to handle the short
citations.

EndNote 9

EndNote X7

Define the reference data
base

You may specify the reference data base with File > Open
before you start FMbiblio or on demand of the script.
For your work you might have a specific data base where you
collect all references from various sources.

Endnote 9

Endnote X7

22

Setting up and using EndNote

Specifying the
output format
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You may specify the output format (e.g. Numbered or IEEE)
before you start FMbiblio or on demand of the script.

When producing numbered output, the initial number is set to
the value from the Program setup of FMbiblio.
If you want to replace the temporary citations in the text by the
fully formatted references (most like in footnotes), you will
need a special output format. See Expanding temporary citations on page 16 for details.
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Output format for references
in footnotes

Formatting the collected
temporary citations

In the second step of the FMbiblio process you are requested to
open the RTF file with the collected temporary citations and
apply the output formatting to it.
The path or the RTF file is already in the clipboard butter to be
able to paste it directly to the open dialogue of EndNote:
Tools > RTF document > Scan … Opens the last used directory it may already be the correct one.
Paste the path of the RTF file into the input field.
After clicking on Open you get the dialogue which shows
whether the references have been resolved or not:
Since the temporary citations have been reduced to ‘unique’
occurrences, there is only 1 match reported (a). A zero indicates that this reference could not be resolved.
The output style (b) is the same as that in the main dialogue
(see Specifying the output format on page 23.
You may select another output style here. It will not be
reflected in the main dialogue.
Depending on your working method you may wish to set the
starting value for numbered references (c).
After clicking on Format ... you may get notice that “unmatched citations have been found”. Click OK to format anyway.
In the Save As dialogue the new file name is already inserted.
It is the file name of the input file, appended by the name of the
output style. For example BibFM-collected.rtf  BibFMcollected-IEEE.rtf.
Do not change the directory for saving the file! The directory is
the same as where your FM-files are located.
After the save you are back in the dialogue shown here. You
could select another output format to find a form which best
fits your demand. Inspect the generated RTF files with Word,
but do not change/save them!

a

c

b
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Messages
Error messages use the X icon, while information messages use
the i icon.

Message “Work done”

This message provides some statistics about the work done by
the script:

The figures except the last one are derived from the RTF file
delivered by the bibliographic application and processed in
step 3a or 3b. You may use an RTF file from step 1 which was
collected in a book also for replacing/expanding in a single file
of that book.
Independently of that the bibliographic application may find
the same entry in its data base for multiple “unique” citations:
{DuçanÌsídõrâ,#24}, {DuçanÌsídõrâ,#24} and
{DuçanÌsídõrâ,2006#24} are all leading to the same DB
record 24 (the  denotes a blank).
These differences may have their root in manual insertion or
copying of temp. citations.

Why discrepancies?

Messages of FMbiblio
#

Message

Reason/Remedy

10 Please open or activate a document or
book

Do so.

11

This message is currently not used.

12 Current document probably "Untitled";
You have a new document active, which
The active doc needs to have been saved. has not yet been saved.
Accidentally wrong document active.
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#

Message

Reason/Remedy

13 No temporary citations could be found in Information.
this document or book.
Collect function invoked to early.
Further steps with FMbiblio are not rea- Wrong document active.
sonable.

2022-09-28

14 The bibliographic application Citavi will be
started. …
Information what the user shall do in
15 The bibliographic application EndNote will the bibliographic application..
be started. …
16 The bibliographic application xxx could
not be found at yyy

Wrong path to bibliographic application in FMbiblio.ini ?
See Setting up maker.ini on page 6.

17 You collected citations from a book, but
no book is active now
Please reactivate the book

Do so.
See also Interrupting work on page 7.

18 After processing by bibliographic application there are nnn unresolved citations

Information. User must probably correct some temp. citations or amend the
bibliographic database.

E:\_DDDprojects\FM-Biblio\Docu\FMbiblio.fm

19 Select the RTF file with the formatted cita- Do so
tions:
20 Selection of an input-file has been cancelled
The current step will be terminated

Information.

21 Work done …

Some statistics.

22 Book xxx ready for processing

Information.

23 Document xxx ready for processing

Information.

24 Temporary citations replaced by yyy formatted citations

Information.



25 Collection of temp. citations completed.
RTF file is saved.
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Using the test files

The script comes with a set of test files. They are useful to
explore the script even before you install Citavi or EndNote.
The ZIP file contains the following subdirectories:

ZIP

Testfiles

FMbiblio

See Script installation on page 5.

Testfiles

These are located on the website.

These files are intended for experiments. Keep in mind that the
script does not save your changed documents and you hence
can safely resort to the initial state – if you close them without
save after processing with FMbiblio.
All FM-files are from version 10, which can be opened by any
successor. Do not save processed files!
DB-forCitavi5

Directory containing database and specification of output-format _FM-biblioexpanding for the tests. Certain items in the
DB refer to Citavi Attachments.

DB-for-EndNote

Directory containing databases for EN-9 and
EN-X7.

The following directories contain FM-10 files and Derived RTF
files (see hereafter).

Derived RTF files

Short+special

Document with all cases of temp. citations
(in ordinary text flow, tables, text frame in
anchored frame).
FM-13 file Short-bidi-chapter with
Hebrew and Arabic citations. Use the Citavi
DB for this.

Book

FM book with 3 files. Use this to test function 3a Resolve temp. citations on page 14.

BookFootnotes

FM book with 4 files using footnotes. Use
this to test function Expanding temporary
citations on page 16.

FMbiblio-collected.rtf

Result from step 1 (collection).

The following can be directly used in steps 3a or 3b respectively.
FMbiblio-collected-IEEE.rtf

Result from step 2 with output format IEEE.

FMbiblio-collected-_BibFM-expanding.rtf

Result from step 2 with output format
_BibFM-expanding.

• If you test with a book, FMbib_DoingBook in maker.ini section [D+DD] must be yes.
• If you test with a document, FMbib_DoingBook in maker.ini
section [D+DD] must be no.

Results from test files

The test files contain (by purpose) some badly formed temporary citations, which are not resolved in step 2. Hence the
application of steps 3a or 3b yield unresolved citations.
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Help – it does not work!

Help – it does not work!

To ease problem handling the process steps are run individually with the menu items 1, 2 and 3 (3a or 3b).
Running the same process step repeatedly requires that you reestablish the mandatory initial state of the FM documents:
FMbiblio does not change anything in your document or book
documents. The book documents are just opened. Hence you
may run this step as often as required – e.g. to get a list of the
temporary citations found (the generated RTF file).
The FM document or book must be open. For a book FMbiblio
opens the document files one by one and processes them.
FMbiblio does not save your document and book files. If something went wrong, you may close them without saving or Revert
to Saved.
It would be good practice to save the processed FM documents
(including the book file) in a new directory. See Adding bibliography incrementally on page 15.

For step 3 (replace temp.
citations in FM)

Changing bibliographic
application

EndNote expects a comma after the author’s name in the temporary citation. This is not produced if you insert with Citavi!
Hence you may start with EndNote and continue with Citavi,
but not vice versa. Be aware that you need to import your EndNote data base into Citavi before continuing your work with
this bibliographic application.

Enable statistical output

A switch in maker.ini section [D+DD] allows to produce statistical output about the handled citation (collected), unique and
formatted citations; additional messages)::
FMbib_Logging
= 0.
You may use the following words for true: true, on, yes,
ein, ja, oui, 1. For false : false, off, no, aus, nein, non, 0



E:\_DDDprojects\FM-Biblio\Docu\FMbiblio.fm

2022-09-28

For step 1 (collecting citations)
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Some program internals
Knowledge and information sources
[1]

Citavi 4: Manual. Available: http://www.citavi.com/
sub/manual4/en/index.html (2015-04-0202).

[2]

Community: FrameMaker Scripting | Adobe Community. Available: https://forums.adobe.com/community/framemaker/extendscript (2015-04-02).

[3]

Adobe Systems Inc, “JavaScript Tools Guide,”:
Adobe Scripts folder: On first launch, the Toolkit creates a folder named Adobe Scripts in the user's Documents folder. The Default favorite in the Scripts panel
displays the contents of this folder. When doubleclicking a JSX file, the Toolkit normally acts as an
invisible security filter. Before actually launching the
file, a security dialog asks if it is OK to execute the
script. The Toolkit treats the user's Documents/Adobe
Scripts folder, however, as a trusted location; when
you double-click a JSX file in that folder, the Toolkit
does not display the security alert. {Adobe Systems
Inc. #73D}

[4]

http://www.ieee.org/documents/ieeecitationref.pdf
(2016-02-10).

[5]FrameMaker ≥8 supports Unicode and hence supports
nearly any language with left-to-right script. The correct glyphs are only visible if an appropriate font is
used for the text15) .

Programming quirks
The script is provided in source form - hence You can look at it
and even may (of course on Your own risk) modify it. If you are
a programmer You might have some questions about my programming style though.

Localisation

The script issues menu and messages in English, German or
French depending on the UI language of FrameMaker.
Localisation does not use the ExtendScript method, because I
want to have all language dependent strings in an external file.
Since version 2.0 these are xml files.

Collect temp. citations (1)
Hierarchy of function calls
(reduced)

The reference numbers (n) are used in the text.
FMbiblioCollect
..CollectInBook
....CollectInDoc
......CollectInTables
......CollectInFootnotes

(1)
(2)

15 If your bibliographic references only use ‘western’ languages, nearly any
TrueType or OpenType font is OK.
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........GetTempCitations
..CreateBibDoc
....SortUnique
....OpenTemplate
..Message "RTF file is saved"

(3)
(4)
(5)

1 In ordinary paragraphs and in table paragraphs.
2 Both in ordinary footnotes and in table footnotes.
2022-09-28

3 Function performing the analysis of the various paragraph
types: look for the temporary citations by means of a regular
expression.
4 Since put in an array the temp. citations can easily be sorted
and duplicates be eliminated. So the generated RTF can
serve as an overview for the author.

E:\_DDDprojects\FM-Biblio\Docu\FMbiblio.fm

5 A FrameMaker document is used to create the RTF for the
handling by the bibliographic application.
Since storage is no more an issue in computers, the temporary
citations are collected into arrays. The same is done for the formatted citations and the bibliography created by the bibliographic application.
However I could not yet test, how many citations/references
can be handled by this approach. My system has 8GB RAM. On
the other side bibliographic references may become quite long
an numerous. In scholarly publications I have seen such items
spanning 4 lines.

Why an RTF intermediate?

Over the time the various EndNote releases have changed their
behaviour, in particular with relation to FrameMaker.
Only EndNote versions 1 … 5 provided the function Scan
Document in mif16). Version 6 did not support any scan at all
and starting with version 7 scanning RTF is back. Hence RTF is
the only format acting as a bridge between EndNote and
FrameMaker.
Citavi allowed to scan RTF right from the beginning, because it
not only supports MS Word. There is, however a problem with
US patents. See Legal issue in the US on page 20.

Call Bibliographic Application (2)



This step consists merrily only of a message to guide the user
and the invocation of the program.

Resolve process (3a)
Hierarchy of function calls
(reduced)

FMbiblioResolve
..ReadFileRTF
....Message "# unresolveds found"
..IsBookRequiredQ
..ExpandInBook
....ReplaceInDoc
......FindAndReplaceString
......Message "temp cits replaced by formatted cits"
Message "Work done"

(1)
(2)

(3)

16 mif (Maker Interchange Format) is a format widely used by utilities for
special FrameMaker functions.
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1 Read and interpret the RTF file issued by the bibliographic
application according to the chosen output-format.
2 Unresolved citations still contain the {..}.
3 For each line in RTF starting with [[, but not containing { =
resolved citations.
Note:

[2018-09-26] Function FindAndReplaceString randomly did not
handle the first item from ReplaceInDoc. The brute force method
to solve this was to append the first item to the list of items.

Expanding process (3b)
Hierarchy of function calls
(reduced)

The reference numbers (n) are used in the text.
FMbiblioExpand
..GetBiblioFromRTF
....GetTabRange
....Message (analysing the read RTF)
..IsBookRequiredQ
..ExpandInBook
....ExpandInDoc
......GetOpenParams
......FindAndReplacePara
........GetFindParams
........ReApplyFontAndSize
Message "Work done"

Contents of RTF

(1)

(2)

(1) The RTF as delivered by the bibliographic application contains 3 areas which are read into arrays for use in other functions:
[[Friðriksson, 2005 #31]]4
A
B
[[Friðriksson, 2005 #31; Daube, 1989 #6]]2; 4
[[Kaho‘olawe x91]]{Kaho‘olawe x91}
...
2
Daube, K. Text and Code - A Dragons Pond. G.U.I.D.E.
Conference, Basel, Switzerland.
Cin FrameMaker
3
Daube, K. (2005). Special characters
4
Friðriksson, F. ó. (2005). Þar sem djöflaeyjan rís
('Where the Devils' Island Rises'), a film based on a book by
Kárason.
A The temporary citation as collected in step 1. Read into
array gasFmtCitsRaw.
B The resolved citations as provided by the bibliographic
application. Due to the special output format _FMbiblioexpanding these are simply numbered for easy handling.
These are read into array gasFmtCitsFmt.
C The corresponding bibliographic references read into array
gaoBibliography.

Combined citations

From the arrows in the picture you can see that the formatted
citations may become a list of numbers corresponding to the
paragraphs in the bibliography.
In FM it is not possible to collect items in the clipboard. Hence it
is not possible to get paragraphs 2 and 4 together into the
buffer for later use in the replacement process.
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 Only the first item in such a list will be processed.

Re-apply ¶-format

(2) The ¶-format of the bibliography in the RTF normally does
not match the format in the user document. Hence the replacement process creates an unwanted formatting:
a)

LaBonté, A. "A New Data Type for National Language?" SEAS Anniversary Meeting, Amsterdam, The Netherlands, 1519-1523.
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b) Table footnote in its original appearance

It is however not correct to just re-apply the original ¶-format
of the document - this would remove the special formatting of
the bibliographic reference (e.g. italic). Hence only the fontfamily and the font-size is re-applied:
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a) LaBonté, A. "A New Data Type for National Language?" SEAS Anniversary Meeting, Amsterdam, The Netherlands, 1519-1523.
b) Table footnote in its original appearance
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