Wide tables
in FrameMaker

Overview

A table is a text container which can easily display
relations. Much information can be displayed with-
out loosing overview.

However, the space where a table can be placed -
the paper with the text frame on it - is not unlim-
ited. Hence for a growing number of columns some
ideas must be developed how to cope with this:

= Reduce font size and/or character width
= Use the full paper width
= Place table on a landscape oriented page

= Split table horizontally and align it on facing
pages

= Place the table on an oversized paper.

This document demonstrates all of these methods
and provides detailed information how to do it.
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Reduce font size and/or character width

Reduce font size and/or character width

The original table uses 12 point Lucida Sans in the table body.

Column 1 column 2 Column 3 Column 4 Column 5 Column 6
at vero eros iusto odio qui blandit zzril delenit dolore te I
et accumsan [0 . ¢ praesent . ) nulla facilisi.

dignissim augue duis  feugait
et luptatum
At vver eos est er eligent optio impedit
et accusam  Et harumd : Nam libe 9 P pedit

.o .. expedit . estcongue doming id
dignissum dereud facilis 3. soluta nobis %, . .

distinct. nihil Lorem ipsum

qui blandit.

Irure dolorin ut labore et Ut enim ad quis nostrud nisi utaliquip | Duis aute

. exercitation ex ea irure dolor in

reprehend dolore magna minim .

Lo : . ullamco commodo reprehenderi
incididunt aliqua. veniam, : i

laboris consequat. tin voluptate

When it becomes necessary to add two more columns, we may
decrease the font size to 10pt and use a narrow version of the
font (10 pt Lucida Sans Narrow) and decrease the widths of
the columns accordingly:

Column 1 column 2 Column 3 Column 4 Column 5 Column 6 Column 7 Column 8

qui blandit

at vero eros et iusto odio zzril delenit dolore te

o praesent . . nulla facilisi.
accumsan et dignissim augue duis feugait
luptatum
At vver eos et . . eligent optio  impedit
Et harumd est er expedit Nam libe g P P o .
accusam - - . est congue doming id dolor sit amet,
S . dereud facilis  distinct. soluta nobis - )
dignissum qui nihil Lorem ipsum
Tia non ob ea
. uis nostrud  nisi ut aliqui Duis aute . soluad
Irure dolorin  ut labore et . g . quip . . velit esse .
Ut enim ad exercitation ex ea irure dolor in . incommod
reprehend dolore magna . ) .. molestaie .
L . minim veniam, ullamco commodo reprehenderit quae egen ium
incididunt aliqua. . . Cillum. )
laboris consequat. in voluptate improb

fugiend.

However, soon we reach the lower limit of the font size which
can be read with ease and of course only for few fonts narrow
variants are available.

Hence we need other means to place more columns into the
table.



Use full paper width

As you can see from the following example, the table width
may exceed the width of the text frame in which the anchor-
ing paragraph is located.

This table is centred (this attribute always is relative to the
anchoring position)

vero eros . . qui blandit . . Last row in
iusto odio zzril delenit  dolore te A A
accumsan . . - praesent : . nulla facilisi. this wide
dignissim augue duis  feugait
luptatum table
t vver eos Et harumd ester Nam libe eligent optio |mpgd|t _ dolor sit
accusam .. expedit . estcongue domingid
. dereud facilis 7. .. soluta nobis . 4 amet,
ghissum distinct. nihil Lorem ipsum

To see the width of the text frame it is filled with a light col-
our.

Align the same table Left:

at vero eros . . qui blandit . . Last row
iusto odio zzril delenit  dolore te I o

et accumsan .0 . praesent . . nulla facilisi. this wide
dignissim augue duis  feugait

et luptatum table

At vver eos Et harumd ester Nam libe eligent optio |mpe_d|t _ dolor sit

et accusam .. expedit . estcongue domingid

o dereud facilis .. soluta nobis e ? amet,
dignissum distinct. nihil Lorem ipsum

Align the same table Right:

0S . . qui blandit . . Last row in
iusto odio zzril delenit dolore te I o
san .. . - praesent . ) nulla facilisi. this wide
dignissim augue duis  feugait
luptatum table
95 Et harumd ester Nam libe eligent optio |mpe_d|t . dolor sit
m .. expedit . estcongue doming id
dereud facilis 7. .. soluta nobis . ? amet,
n distinct. nihil Lorem ipsum



2007-01-23

E:\FM-specials\Samples\table-wide\table-wide1.fm

Rotate table

Rotate table

Your table may be wider than the space on a portrait page,
but fit nicely on a rotated page. To get a rotated table you
must rotate the text frame which contains the table. Just
rotating the table will only rotate the cells in it.

Create a rotated master page

Applying masterpages

This method creates a landscape text area in which the table
can be edited as usual, because the table is not rotated.

1 In View > Master Pages use Special > Add Master Page:
use a master page which provides the desired heading and
footing, for example ‘left’

2 Name the masterpage accordingly, for example, R-rotated.

3 Rotate page with Format > Customize Layout > Rotate
page clockwise/counter clockwise.

4 Rotate central text frame back. The heading/footing area
will remain rotated.

paiel04 S| eaJe bunoo4
pa1e104 S| B3R BUIpEIH

5 Create the masterpage L-rotated with the same method. It
is best to have the same orientation for both rotated pages.
Otherwise the user would need to turn the ‘book’ for the
second rotated page.

Apply a rotated master page to any desired table page with
Format > Page Layout > Master Page Usage.

You may wish to automate this assignment, if you have more
than one of these rotated pages and the text length outside
the tables is not yet fixed.



Assigh master pages automatically

Note:

Master page mapping
table

FrameMaker 7 allows to assign master pages depending on
one or more paragraph formats on a page.

The triggering paragraph tags can not be within a table.
Hence the only reasonable for rotating tables is the tag of an
anchor paragraph.

If this table does not exist, it will be created by Format >
Page Layout > Apply Master Pages ... The mapping table will
appear on reference page MasterpPageMaps and has this
appearance:

UnstructMasterPageMaps
Book Update (Yes or No): Yes

Paragraph Tag  Right-Handed Master Left-Handed Master Range Indicator (Sin- Comments
Name Page (or Single-Sided Page gle, Span pages, Until

Master Page)

zrt-rotated-table R-rotated

Range indicators

changed)

L-rotated Span pages For multi page tables

1 Set up the MasterPageMap accordingly
2 Choose View > Body Pages.

3 Make the appropriate document window or book window
active. If a book window is active, select the documents you
want to affect.

4 Choose Format > Page Layout > Apply Master Pages, and
then click Yes to override manually applied master pages.

FrameMaker searches each body page for the first occurrence
of any paragraph tag specified in the Master Page Maps table.
When it finds text containing the specified paragraph tag, it
applies the specified master page.

Single to apply the master page only to the body
page on which each paragraph tag appears

Span pages Master pages are applied to the entire span
of pages to which the paragraph tag is
applied.

Until changed Master pages are applied to all pages, until
the next body page with a different para-
graph tag listed in the mapping table is
encountered.

Blank Equivalent to Single.

Example of rotated table

Note:

The table is anchored at the triggering paragraph zrt-
rotated-tabTle. This is set up with a small height and start
on Top of Page. Hence it is the nearly invisible paragraph at
the top of the next page.

Remember, the trigger can not be in the table itself!



Rotate table
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Arrange wide table on facing pages

Arrange wide table on facing pages

If you have a table which will even not fit properly on a
rotated (landscape) page, you may wish to split it horizon-
tally. The result shall look like the following picture:

Wide tables
Table 1:  Conditions and results of wood gasification experiments.
Vivood "“-w]_d T Pend <ty T DOCia TCrs?

run no. wt%  Me 'C MPa min. min. mg/L %o
HB300RO1 10.5 2.0 303 12.2 41 0 18’480 142.9
HB400RO1 10.0 1.9 409 341 5 24 300 14.9
HB400R03 9.9 1.8 402 30.8 8 22 720 20.3
HB400R04 9.7 1.9 405 31.6 57 25 770 7.6
HB400R05 9.7 1.8 400 29.3 57 9 4’470 22.4
HB400R06 9.7 1.9 404 31.5 56 42 1’020 19.6
HB400RO7 9.6 1.9 404 31.0 6 92 670 13.8
HB400R08 29.9 2.1 403 32.0 55 43 1’620 0.1
HB400ONC1 9.6 N/A 409 293 6 92 14’390 871.4

Room between the two
table parts

a. DOC,q = dissolved organic content remaining in the aqueous phase.
b. TC,es. = total carbon content by DC-190 (boat module) in mg/g esidue %o).

This is the room between the two table parts. It may be nesc-
essary to move some text from behing the table into this area.

Select this text carefully to avoid confusion of the reader. It is

recommended to introduce the two table parts with an appro-

priate note or to place this note here between the two parts.

Second part of table

table appears.

Hereafter the anchor paragraph for the second part of the

2007-01-19
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Table 1 (continued)

Arrange wide table on facing pages

Xpoc ~ GE? Ygas CHy CO, Hy co YcHa
run no. % %  L/9wood VOI% vol% vol% vol% dcha/Iwood

HB300RO1 87.1 29 0.30 23 59 18 <0.1 0.05
HB400RO1 99.1 46 0.45 37 56 6 <0.1 0.12
HB400R03 99.0 77 0.84 30 45 24 <0.1  0.19
HB400R04 99.2 96 0.85 47 46 7 <0.1  0.30
HB400R05 95.1 80 0.75 40 47 13 <0.1 0.22
HB400R06 98.4 96 0.86 47 46 7 <0.1  0.30
HB400R07 99.4 103 0.92 49 43 8 <0.1 033
HB400R08 99.5 89 0.79 48 49 3 <0.1 0.28
HB40ONC1 85.7 21 0.19 14 61 16 9.0 0.02

a. GE = carbon gasification efficiency.

Long table to be split

Example overview

Split a table horizontally

If your table not only is wide, but also longer than a page, you
need to split it both horizontally and vertically into pieces. If
you envision such a situation plan the various parts of the
table in a matrix and set up individual tables to which you
refer from an overview table:

Unemployment in Swiss cantons from 1910 to 2005

Cantons A to F, first part
(see page 8-12)

Cantons G to Z, first part
(see page 8-13)

Cantons A to F, second part Cantons G to Z, second part
(see page 8-14) (see page 8-15)

The easiest method is this:

1 Make the table to start on Top of Page

2 Create a copy of the table

3 In the first part remove all rows beyond the first page
4 In the second part remove all rows in the first page.

You may need to create further copies if the table is longer
than two pages.

5-5

Split wide table horizontally

A

If you know from the beginning that the table rows will not fit
on the available width of the page, start with the left are, then
create a new table for the right area and proceed as if you

would have split an existing table.

B C

D

To split the table between the columns D and E. Assuming
that the first column (here without heading) contains the row
heading which shall be present in both parts:

1 Duplicate the table

2 Delete columns E to H from the first part

3 Delete columns A to D from the second part




Setting up the split table

= Normally the right table part does not repeat the left most
column of the original table. However, this may be useful,
if the table has many narrow columns.

* In a layout without side heads you do not need a special
anchoring paragraph, but this may be useful for independ-
ent placement of the table.

* In a layout with side headings you need the anchoring para-
graph (.e.g. zta-table-anchor of small height). It must have
the pagination property Across all Columns and
Sideheads. Due to this it shall be empty.

= The table parts both start on Top of page. For more auto-
matic adaptation to changes in the text you may want to
set the left part to Start on Left Page and for the right
part start on Right Page. If you need to arrange the tables
somewhere in the middle of the pages, use a special
anchoring paragraph and adjust the vertical position (with
Space above) only at this paragraph. There is no “absolute
positioning” of paragraphs in FrameMaker.

Short table to be split

Footnotes in the split
table

Adjust heights of rows

Space before the first
part of the table

Since the two parts of the original table are now two com-
pletely independent tables, footnote numbers start again for
the second part.

In the left part there is a formula in the heading which takes
much vertical space. Hence the other heading cells use an
additional empty paragraph to adjust for this.

In the right part of the table you need to create the same
heights of the table header. Since the height of a table row is
automatically adjusted to the contents, you may need to fix
the row height to identical values in the left and right part.

You do so by defining the row heights explicitly in both table
parts with Table > Row Format. You will need to fiddle
around with values until the defined height is just a little bit
more than the original (flexible) height of the row.

Adjusting the row heights may also be necessary for particu-
lar rows (or even all). This depends on the actual contents of
the left and right part of the table.

This space may be empty. But then please indicate the reason
for this gap. This is especially necessary if no other con-
structs create such holes in the text.

It may also be advisable to inform the reader about the real
location of the table in text with a cross reference such as (see
Conditions and results of wood gasification experiments. on

page 5-12).

5-10
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Arrange wide table on facing pages

Long table to be split

If your table not only is wide, but also longer than a page, you
need to split it both horizontally and vertically into pieces. If
you envision such a situation plan the various parts of the
table in a matrix and set up individual tables to which you
refer from an overview table:

Example overview Unemployment in Swiss cantons from 1910 to 2005

Cantons A to F, first part Cantons G to Z, first part
(see page 8-12) (see page 8-13)

Cantons Ato F, second part Cantons G to Z, second part
(see page 8-14) (see page 8-15)

Example of split and arranged table

First part of table Hereafter the table anchor paragraph follows:

5-11



Table 2: Conditions and results of wood gasification experiments.

Waood  © Tmax. Pend Tt DOCy? TCp
Mwood (T<To) (T>Tp)

run no. wt % Meat. °C MPa min. min. mg/L %o
HB300RO1 10.5 2.0 303 12.2 41 0 18480 142.9
HB400RO1 10.0 1.9 409 34.1 5 24 300 14.9
HB400RO03 9.9 1.8 402 30.8 8 22 720 20.3
HB400R04 9.7 1.9 405 31.6 57 25 770 7.6
HB400RO5 9.7 1.8 400 29.3 57 9 4’470 22.4
HB400R06 9.7 1.9 404 31.5 56 42 1’020 19.6
HB400R07 9.6 1.9 404 31.0 6 92 670 13.8
HB400R08 29.9 2.1 403 32.0 55 43 1’620 0.1
HB400ONCT 9.6 N/A 409 29.3 6 92 14’390 871.4

a. DOC,q, = dissolved organic content remaining in the aqueous phase.
b. TC,es. = total carbon content by DC-190 (boat module) in mg/g esidue (%0).

Room between the two This is the room between the two table parts. It may be neces-
table parts sary to move some text from behind the table into this area.

Select this text carefully to avoid confusion of the reader. It is
recommended to introduce the two table parts with an appro-
priate note or to place this note here between the two parts.

Second part of table Hereafter the anchor paragraph for the second part of the
table appears.

5-12
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Table 2 (continued)

Arrange wide table on facing pages

Xpoc  GE? Ygas CH; CO, H> Cco YcH4
run no. % % L/9wood VOl % vol% vol% vol%  9cHa/9wood

HB30ORO1 87.1 29 0.30 23 59 18 <0.1 0.05
HB400RO1 99.1 46 0.45 37 56 6 <0.1 0.12
HB400RO03 99.0 77 0.84 30 45 24 <0.1 0.19
HB400R04 99.2 96 0.85 47 46 7 <0.1 0.30
HB400RO05 95.1 80 0.75 40 47 13 <0.1 0.22
HB400R06 98.4 96 0.86 47 46 7 <0.1 0.30
HB400R07 99.4 103  0.92 49 43 8 <0.1 0.33
HB400R08 99.5 89 0.79 48 49 3 <0.1 0.28
HB40ONCT 85.7 21 0.19 14 61 16 9.0 0.02

a. GE = carbon gasification efficiency.

Split a table horizontally

The easiest method is this:

1 Make the table to start on Top of Page

2 Create a copy of the table

3 In the first part remove all rows beyond the first page

4 In the second part remove all rows in the first page.

You may need to create further copies if the table is longer
than two pages.

5-13



Further thoughts to consider

Column 1
Lorem
euismod
ad
aliquip
hendrerit
nulla
blandit
Et
met,
one
mmodo
nulla
luptatum
expedit
doming
consecte
magna
in
minim
commodo

€sse

column 2
ipsum
tincidunt
minim
ex
in
facilisis
praesent
tam
consectur
wonder
consequt.
pariatur.
delenit
distinct.
id
adipising
aliquam.
reprehend
veniam,
conseuat.

molestaie

Wide tables may become difficult to navigate or not to loose
overview. Hence consider these points for the design of the
table:

Column 3
dolor
ut
veniam,
ea
vulputate
at
luptatum
neque
adipiing
who
Duis
At
aigue
Nam
Lorem
elit,
Ut
incidunt
quis
Duis

cillum.

Provide horizontal guidance with shaded rows (zebra

effect)

Use rules especially if the table is filled only sparsely

Do not overuse ruling if it does not help the reader. For
example, vertical ruling may be unnecessary because of left
adjustment of the cell text.

Column 4

sit
laoreet
quis
commodo
velit

Vero

zzril
pecun
elit,
would
aute

vver
excepteur
libe
ipsum

set

enim

ut
nostrud
aute

Tia

5-14

Column 5

amet,
dolore
nostrud
consequat
esse
eros
delenit
modut
sed

ever

in

eos

sint
soluta
dolor
eiusmod
ad
labore
exerciion
irure

non

Column 6

contuer
magna
exerci
Duis
molestie
et

augue
est

ut

read
voluptate
et
occae.
nobis

sit
tempor
minim
et
ullamco
dolor

ob

Column 7

adicing
aliqguam
tation
autem
cosequat,
accumsan
duis
neque
labore
this

velit
accusam
Et

eligent
amet,
incidunt
veniam,
dolore
laboris

in

€a

Column 8
elit,
erat
ullamcoer
vel
vel
et
dolore
nonor
et
stuff?
esse
dignissum
harumd
optio
velit
et
quis
magna
nisi
reprehen

soluad
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Wide table on special paper size

Wide table on special paper size

This is of course an obvious method. You can combine
any paper sizes in one FrameMaker book - and also in
the generated PDF.

However, you can not Save as PDF the whole book with
various page sizes. Only the page size from the first file
in the book is considered.

Ordinary text on these wide pages

As you can see from this text, arranging the text in col-
umns on the wide paper may lead to undesired results.

Creating the PDF

Book has only one special chapter
1 Create a book PDF by saving the whole book as PDF

2 Save the document with oversize paper separately as

PDF

3 In Acrobat replace the wrongly created pages in the
book by the large pages from the separated PDF.

Ordinata Column A Column B
Lorem ipsum dolor
euismod tincidunt ut
ad minim veniam,
aliquip ex ea
hendrerit in vulputate
nulla facilisis at
blandit praesent luptatum
Et tam neque
met, consectur adipiing
one wonder who
mmodo consequt. Duis
nulla pariatur. At
luptatum delenit aigue

5-15

Column C

sit
laoreet
quis
commodo
velit
vero
zzril
pecun
elit,
would
aute
vver

excepteur

Column D

amet,
dolore
nostrud
consequat
esse
eros
delenit
modut
sed
ever

in

eos

sint

Multiple columns are always ‘balanced’ at the occur-
rence of a header which is not ‘In column’, but for
example ‘In the side Head area’ or ‘Across all columns’.

In any case you will need the full Acrobat product to
combine various PDF files into one - or a similar prod-
uct for the purpose.

This effect is very cumbersome for lists. Hence the
headings before the bulleted lists herearfter use a mod-
ified § format to appear ‘In column’. Horizontally

arranged lists are very difficult to comprehend.

Multiple chapters with larg pages

If your large paper is used in several chapters it is bet-
ter to use this method:

1 Savel all document in the book individually as PDF
2 Put the book together in Acrobat
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