Release Notes

FrameMaker 3.0 for MS Windows
This FrameMaker Hypertext document contains last-minute FrameMaker information and
tips. For additional information, open the fmreadme.txt file located on Disk 1.
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Navigating in the Release Notes
To:

Do this:

View a topic

Click a blue underlined topic name on page 1.

Go forward one page

Click

along the bottom of this window.

Go backward one page

Click

along the bottom of this window.

Return to page 1

Click

Print the Release Notes

1. Choose Print from the File menu.

along the bottom of this window.

The Print Document dialog box appears.
2. To print two Release Note pages per 8½" by 11"
page, select the Thumbnails option and specify 2
rows by 1 column.
3. Click Print.
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General printing information: You can resolve most printing problems by upgrading to
Windows 3.1, which includes better printer drivers than Windows 3.0. Also, installing a font
manager like ATM 2.0 (included with FrameMaker) can correct printing problems.
Unusually complex files may not print properly to printers with less than 2MB of memory.
Printing thumbnails of very complex documents may also fail.
Supported Printers: FrameMaker supports any printer that is supported by Windows and
ATM. Frame tested these printers:
Apple LaserWriter family

IBM 4019 (PostScript)

NEC ColorMate PS40

Canon Bubble Jet

IBM 4029

NEC SilentWriter 2 90

HP DeskJet 500, 500c

IBM Laser 10L

Okidata OL830 (PostScript)

HP LaserJet IIp Plus

Kodak Color 4

QMS PS 810, 100 30i, 1700

HP LaserJet III family

Kodak Diconix 180 si

Tektronix Phaser II PXi, III PXi

HP PaintJet

Linotronic
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PostScript printing with Windows 3.0: The printer driver included with Windows 3.0 may
print a border along the right edge of imported graphics and space characters incorrectly.
The ATM disk included with FrameMaker contains a newer driver that fixes these problems.
Windows 3.1 users: Although installing this printer driver will disable your TrueType fonts,
you may want to install it anyway if small fonts are not kerning properly.
To install and configure the driver:
1. Open the Control Panel from the Main Group window in the Program Manager, and
double-click the Printers icon from the Control Panel window.
The Printers dialog box appears.
2. Remove the current PostScript printer by clicking its name in the Installed Printers list
and clicking Remove.
3. Click Add Printer.
The Printers dialog box expands to display a list of available printers.
(continued on next page)
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4. Choose Unlisted Printer from the list of printers. Then click Install.
The Add Unlisted Printer dialog appears.
5. Insert the ATM disk in a disk drive, and select the drive letter in the Directories list box.
Select the pscript.drv file in the list box and click OK.
If a PostScript driver is already installed on your computer, a dialog box will appear,
asking you to confirm that you want to replace your current driver with this new one.
6. Click New to replace the current driver.
The new driver name appears in the Installed Printers list box.
7. Click Configure (Windows 3.0) or Connect (Windows 3.1).
8. In the dialog box that appears, select the port you print to from the Ports list box. Then
click OK.
9. Click Active in the Status area of the Printers dialog box.
10.Double-click the name of the active printer in the Installed Printers list box to make it the
default printer. Then close the Printers dialog box.
Now the new driver is installed.
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Microsoft PostScript printer driver version 3.5: This driver does not scale fill patterns;
they look different when printed at different resolutions. Gray fills are not affected.
Hewlett-Packard LaserJet printer driver versions 3.4 and 3.42: If you are using
Windows 3.0 or 3.0a with either of these drivers, band printing may distort large graphics,
particularly 24-bit images. To solve this problem, turn off Band Printing in the Print dialog
box, or upgrade to Windows 3.1, which includes an improved LaserJet printer driver.
Hewlett-Packard PaintJet printer: For best results, Frame currently recommends that
Windows 3.0 users use version 1.0 of the HP PaintJet printer driver. However, color text will
print as black. Also, when printing a document containing text placed on top of a
background, the text erases the background behind the text object, even though the
background may show through the text object on screen.
Also, imported graphics containing fill patterns may not print properly at 72 or 75 dots per
inch. Try printing at a higher resolution.
Windows 3.1 users should use the PaintJet driver included with Windows, which corrects
these problems.
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HP printers: When you print to an HP DeskJet, LaserJet II, or LaserJet IIIp printer, any
gray scale shading may not exactly match what you see on screen.
UltraScript printer driver: Use version 3.0, not version 2.3.
PostScript printer drivers: Some drivers may cause the bold and italic styles to be
unavailable in menus and dialog boxes. Replacing the driver with one from Microsoft or
Adobe will correct this problem.
LaserMaster: FrameMaker may not print reliably to a LaserMaster WinPrinter 800 if you
use the LaserMaster “Direct” printer driver. For better results, use a PostScript printer driver
included with the WinPrinter 800.
Printing books containing unavailable fonts: FrameMaker will not print a book file if one
or more documents in the book use fonts that are not available on the computer.
Save notification after printing: If you open a document, print it, and close the document
without making any changes, FrameMaker may inadvertently ask you to save the document
when it really isn’t necessary to do so.
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“Windows PS Header has not been downloaded. Please download the header.”
A PostScript printer may print this error message when you print a document from any
application, not just FrameMaker. To print documents successfully:
1. Choose Printer Setup from the File menu.
2. Click Options in the Printer Setup dialog box.
3. Select the Download Each Job option (Windows 3.0) or the Send Header with Each Job
option (Windows 3.1). Then try printing again.
Transmission Retry: The Printers Control Panel contains a Transmission Retry setting,
which controls how often to resend output to a printer when a transmission fails. The default
value of 45 or 90 is usually too low. To check or reset your Transmission Retry setting:
1. Open the Printers Control Panel.
2. Select an installed printer and click Connect (Windows 3.1) or Configure (Windows 3.0).
3. Check the Transmission Retry setting, enter a new one if necessary, and click OK.
For most PostScript printers, enter 240. For high resolution and color PostScript printers,
enter 700.
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Print option conflicts: The FrameMaker Print Document dialog box contains some options
that also appear in the Windows Printer Setup dialog box, like the number of copies and the
scale percentage. When you print a FrameMaker document, the settings in the Print
Document dialog box override those in the Printer Setup dialog box.
Since the Rotate Page command allows you to mix portrait and landscape pages in a single
document, FrameMaker also overrides the Orientation setting in the Windows Printer Setup
dialog.
Calling technical support with printing problems: If you have problems printing, please
have the following information available when contacting Frame Technical Support:
• the printer name and model number, and the amount of memory in the printer (if
applicable)
• the version number of Windows. Choose About Program Manager from the Help
menu in the Program Manager.
• the version number of your printer driver and the name of the company that created
it. In FrameMaker, choose Printer Setup from the File menu. Then click About in the
dialog box that appears.
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Adobe Type Manager 2.0 (ATM): FrameMaker requires a font management program like
ATM. If you need technical support for the ATM software that is included with FrameMaker,
contact Frame Technical Support.
Earlier versions of ATM do not support as many characters as ATM 2.0. To access every
character listed in Chapter 4 of the FrameMaker Quick Reference Guide, install ATM 2.0.
Since some Bitstream Facelift fonts do not support text rotation, Frame recommends using
Adobe fonts.
TrueType: Although FrameMaker is fully compatible with TrueType, you may want to
disable it if you print to a PostScript printer using Adobe fonts.
Smart Quotes: If FrameMaker displays a black box when you type a quotation mark, the
font you’re using does not contain “smart” quotation marks in its character set. To type
"straight" quotation marks:
• choose Document from the Format menu and turn Smart Quotes off, or
• press Control-', Esc ", or Control-`
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Symbol characters: To type a Symbol character using its ANSI code, make sure Symbol
is the current font before you type the ANSI code. If you type the ANSI code in a standard
text font and then change the character to Symbol, you will not get the correct character.
Unavailable fonts: When you open a FrameMaker file created on another computer, a
warning that some fonts are not available may appear. This can occur because:
• the same fonts are often named differently on different computer platforms
• the computer that created the document might have used fonts in the FrameMaker
document that are not installed on your system
To identify the unavailable fonts, close the document without saving it, and choose
Preferences from the File menu. Select the Show File Translation Errors option and click
Set. Then reopen the document. FrameMaker will create a list of the unavailable fonts and
display it in the FrameMaker Console window. Double-click the minimized FrameMaker
Console icon to see the list.
You can then edit your maker.ini file to convert comparable fonts with different names,
or substitute missing fonts with ones that are installed on your system. See Appendix D of
Using FrameMaker for more information.
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Changing printers: When you change printers using the Control Panel, FrameMaker may
automatically close any open dialog boxes. This maintains the integrity of font options listed
in FrameMaker dialog boxes.
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Applying character formats to whole paragraphs: If you select all of the characters in a
paragraph and change just the character format, FrameMaker assumes you want to
redefine the entire paragraph’s default font setting to your new character format.
Subsequently, if you apply another paragraph format to the same paragraph, you will lose
your character formatting.
To avoid this problem, put a space at the end of the paragraph. Don’t select the space
when you apply a character format. FrameMaker recognizes that you are not selecting all of
the characters in the paragraph and does not redefine the default font setting.
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Copy Para. Format command: If more than one paragraph is selected and you choose
Copy Para. Format from the Edit menu, FrameMaker copies the format of the first
paragraph.
Copy Char. Format command: If the selected text uses a mix of different character
formats and you choose Copy Char. Format from the Edit menu, FrameMaker copies the
format of the text at the start of the selection, not all of the character formats in the
selection.
Autonumber formats: To use a Symbol or Zapf Dingbat character in the autonumber
format of a paragraph format, you must type a different ANSI code number than the one
listed in the FrameMaker character set table. You can obtain a special ANSI code table for
typing Symbol and Zapf Dingbat characters into autonumber formats. Either download it
from the Frame BBS at (408) 433-4841, or ask a Frame Technical Support Representative
to mail you a copy.
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Hyphenation in table cells: If a cell contains only one word, and the word is too wide to fit
on one line, FrameMaker breaks the word across lines but doesn’t hyphenate it. To fix this
problem, either insert a hyphen manually or make the cell wide enough for the entire word.
Table footnotes: If a table ends at the bottom of a column, table footnotes appear at the
top of the next column. To force some rows to appear in the same text column as the
footnotes, put the insertion point in the first row you want to appear with the footnotes and
choose Row Format from the Table menu. In the Row Format dialog box, choose Top of
Column from the Start pop-up menu.
Selecting a table: When you format a table with the Table Format window, do not select
the entire table. If you select the entire table, FrameMaker may unexpectedly quit. Place
the insertion point in the table or select a single cell, and then make your changes in the
Table Format window.
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Importing tables: When you import text as a table by specifying a separator of 2 or more
spaces, the table might be imported incorrectly. Turn off Smart Spaces and reimport the
table.
Tables within tables: FrameMaker allows you to place a table within a table by drawing an
anchored frame and text column inside a table cell and then inserting the table in the
innermost text column. If you do this, and the outermost table breaks across two pages,
FrameMaker might unexpectedly quit.

Spell-checking
Spelling checker options: Spelling checker options let you select items for the spelling
checker to find or ignore, like repeated words and unusual capitalization. FrameMaker does
not save any changes to these settings; they are reset to the options listed in your
maker.ini file the next time you open FrameMaker. To preserve changes to spelling
checker options from one FrameMaker session to the next, modify the [Spelling]
section of the maker.ini file. For more information, see Appendix B of Using
FrameMaker.

Find/Change command
Finding and changing character formats/end of flow symbol: If you click Change All
when finding and changing a character format or an end-of-flow symbol (\f in the Find text
box), FrameMaker might keep finding and changing continuously. To cancel the search,
press Esc.
Typing special characters into dialog boxes: To enter some characters into
FrameMaker documents, you use Control or Escape key sequences. To enter these special
characters in the Find/Change window or a similar dialog box, you cannot use the Control
or Escape sequences. Instead, you must type a character code beginning with a backslash
(\). For a complete list of characters that require a backslash code, see Chapter 4 of the
FrameMaker Quick Reference Guide, or look up “Finding and changing special characters”
in the Index to FrameMaker Help.

‘

`

To enter an opening single quote mark ( ) in a dialog box, press the grave ( ) key.

Graphic objects
Distribute command: If the Distribute command in the Graphics menu moves objects
beyond the edge of a page (some objects disappear from the screen), immediately choose
Undo from the Edit menu to bring the objects back on the page. Then choose Distribute
again, but specify a smaller edge gap in the Distribute dialog box.
Arrowheads: Lines drawn with a projecting cap style might project through arrowheads. To
correct this problem, change the cap style of the line to Butt. For more information, see
“Adding a line ending” in Chapter 11 of Using FrameMaker.
Though at some magnifications, an arrowhead might not look centered on its line, the arrow
will print correctly.
Centering text lines: If you use the Object Properties dialog box to center a text line,
FrameMaker might unexpectedly quit if you later attempt to delete the text line. To center a
text line, press Esc j c or choose Align from the Graphics menu instead of using the Object
Properties dialog box.

Anchored frames
Selecting anchored frames: You can’t select an anchored frame in a rotated text column.
To select it, you must first rotate the column back to the original orientation.
Pen patterns: If you apply a pen pattern to an anchored frame or rounded rectangle, the
pattern might appear on the screen only on the top and left sides of the object. However,
the entire border will print correctly.

Imported graphics
Display quality: Since most monitors are capable of displaying only a certain number of
colors at one time, FrameMaker often must approximate the display of colors in imported
graphics. This affects the display quality only, and will not affect the print quality of the
graphic.
Device dependent graphics: EPS files, Windows Meta files, and some OLE objects might
not be device independent, meaning they may display poorly in FrameMaker. The
applications that created these files determine their quality; therefore, FrameMaker cannot
compensate for it.
Path names of referenced graphics: If you import a graphic file into an unnamed
document, FrameMaker references the graphic file using an absolute path name. To use a
relative path name, save the document and then reimport the file.
OLE objects: If you delete an OLE object from a FrameMaker document and try to restore
the object by choosing Undo, FrameMaker will close the connection to the OLE server (if it
was running).

Variables
System Variables: Use the Variable command on the Special menu to update system
variables on reference pages; they do not update automatically.
User variables: If you create a user variable that contains the <Default Para Font> building
block, the text following it may get truncated. To avoid this, always end the variable
definition with another building block.

Text columns
One-word text columns: If a text column contains only one word, and the word is too wide
to fit on one line, FrameMaker breaks the word across lines but doesn’t hyphenate it. To fix
this problem, either insert a hyphen manually or make the text column wide enough for the
entire word.
Connect Two Columns setting and Undo: You cannot undo the Connect Two Columns
setting in the Column Connections dialog box. FrameMaker might fail to alert you that this
command cannot be undone.

Generated files
Index and table of contents: When you generate index or table of contents files for a book
created in an earlier version of FrameMaker, be sure all the documents in the book are in
FrameMaker 3.0 file format. To do this, open all the documents in the book before you
generate the files.
List of fonts: A generated list of fonts in a document or a book won’t list the fonts used on
reference pages or in imported EPS (Encapsulated PostScript) files.
List of condition tags: A generated list of condition tags won’t list the condition tag
settings of conditional table rows.
Table of contents and index flows on a reference page: You can’t use the
<$paranumonly> building block in the special flow for a generated file.

Conditional text
Smart spaces: In a document with Smart Spaces turned on, FrameMaker won’t let you
type extra spaces in visible text. If the document contains hidden conditional text, however,
you can type a space next to a hidden space. When you show the hidden text, both spaces
appear. To avoid this problem, follow consistent standards for handling spaces preceding
and following conditional text. Either always make them conditional, or always make them
unconditional. You can also locate extra spaces by spell-checking the document with the
Extra Spaces spelling checker option turned on.
Showing and hiding conditional text: When you change the Show/Hide settings for
conditional text, the insertion point disappears from the document window. Click in a text
column in the document to replace the insertion point.
Copy Cond. Settings command: If selected text contains multiple condition settings and
you choose the Copy Condition Settings command from the Edit menu, FrameMaker
copies the settings at the start of the selection, not the settings that appear in the
Conditional Text window.

Help system and hypertext
You can open more than one FrameMaker Help window, which lets you display related topics
side by side. For example, as you read help on a procedure, you can open help on a dialog
box in a separate window. To open an additional FrameMaker Help Window:
• Hold down the Shift key while you click on any help system button.
Popup hypertext command: The popup command refers to a text column on a reference
page. This text column contains text to define the items in the pop-up menu, and hypertext
markers to control what happens when you select an item. If the marker text of a hypertext
marker uses a pathname to a document as a parameter, use two backslashes (\\) to
separate directory names instead of just one backslash.
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Clipped equations: Text near the edges of a shrink-wrapped equation might not display on
the screen. However, the equation will print correctly.
ATM 2.0: Install the copy of Adobe Type Manager that is included with FrameMaker.
Otherwise, the positioning of some characters in equations may be incorrect.
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Diacritical marks: This table lists several diacritical mark shortcuts that are missing or
incorrect in the FrameMaker Quick Reference Guide.
To type:

Press:

x'

` (back quote)

x''

``

x'''

```

x
x·

Ctrl-Alt-hyphen

··
x
···
x

period period

period

period period period

Limitations and error messages
Maximum document size: System configurations vary widely from one computer to the
next; therefore, it is difficult to predict the maximum document size possible. The maximum
document size depends on your available memory.
“Insufficient memory to start another application.” This error can appear under
Windows 3.0 when you exit FrameMaker and immediately try to restart it again. When you
exit an application, Windows 3.0 may take a few moments to free up the memory the
application occupied and make it available to other applications (even the application you
just quit). Try waiting a moment or two, and then start FrameMaker again.
“Nothing to paste.” This error can appear when you paste or import large graphics (bigger
than 500K). FrameMaker stores temporary copies of large graphics in the temp directory
set in your autoexec.bat file; if this directory is full, FrameMaker may fail to paste or
import a graphic. Similarly, if you print a large document or a book, an error may appear if
there isn’t enough room in the temp directory for the print spooler file.
If you’re printing large files or working with large graphics, be sure to keep plenty of space
available in your temp directory.
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Refresh command: Occasionally, a portion of a document window or a dialog box won’t
display correctly. To redisplay a document window, choose Refresh from the Window menu
or press Ctrl-l (lowercase L). The following screen display problems do not affect the
document or how it appears when printed. Choose Refresh to fix the display.
Change bars and graphics: If an automatic change bar obscures a graphic in the
margin of a page, white lines might appear in the change bar ruling area.
Tables: When a cell grows as you type text, the text in cells below might appear darker
on the screen at zoom settings other than 100%. Also, ruling lines that are the same
thickness might appear differently at zoom settings other than 100%. If choosing
Refresh doesn’t fix the screen display, the lines will still print correctly.
Indent and tab markers on the ruler: Scrolling a document horizontally may cause tab
and indent markers on the ruler to disappear.
Dialog boxes: When a text box in a dialog box contains a long value, it may display only
the end of the value. For instance, “16.682 pc” (picas) may look like “82 pc” when you first
open a dialog box. Click in the value and use the left arrow key to see the whole value.
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Video drivers: Some display drivers may crash while trying to display large bitmap
graphics or when zooming over 400%. If you experience driver problems, report them to the
manufacturer of your video card and display driver. They may have updated the driver to
correct the errors.
Windows 3.0 and 3.0a standard VGA driver: This driver may not display large images
properly. Windows 3.1 contains an improved VGA driver that corrects this problem.
Video Seven VRAM video driver: This driver may leave portions of dialog boxes and
menus on the screen, especially during scrolling operations. This driver may also cause the
text in a pop-up field to overwrite the pop-up button. Update the driver if a newer version
becomes available.
Diamond Stealth VRAM card and driver: When this driver is set to “TurboWindows”
1024x768 resolution with 256 colors, the Tools palette in FrameMaker does not display fill
and pen patterns properly. Setting the resolution to 1280x960, 16 colors displays the Tools
palette properly. An updated display driver may correct this problem.

Compatibility issues
Dell systems and the GPX-1024 Graphics Performance Accelerator card: Version
2.1.1 of the display driver included with the GPX-1024 card does not implement
MM_HIMETRIC screen mapping properly, which means Object Linking and Embedding
(OLE) may not work properly. Contact Dell to obtain an updated display driver.
Macro Recorder: Prior to playing back macros in FrameMaker, set the Macro Recorder
Preferences to play back macros at their recorded speed.
Object Packager: In certain instances, the Object Packager may corrupt memory and
cause FrameMaker to unexpectedly quit.
WordPerfect: If you close WordPerfect while FrameMaker is running, FrameMaker may
display a dialog box to inform you that the printer information for your system has changed.
Click OK to resume using FrameMaker. It may take a few moments for the system to close
the dialog box.
share.exe: Since this entry may cause problems during file operations, you should disable
share.exe by removing it from autoexec.bat, config.sys, and your path, or by
renaming the share.exe file. You must restart the computer for this change to take effect.
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Unknown file types: FrameMaker imports many graphics and word processing file
formats. (See Appendix E of Using FrameMaker for a complete list.) When you import a file,
FrameMaker may be unsure about the format and open the Unknown File Type dialog box.
The most likely format is highlighted in the list. If the highlighted format is incorrect, choose
the correct format from the list and click Convert.
Importing word processing documents: When importing a long document, FrameMaker
may include blank pages. You can remove them with the Delete Page command.
After importing a document, some text columns may be too small to see all the text inside,
especially text columns inside of frames. Resize the text columns to reveal all the text.
PICT files: Under Windows 3.0, you may not be able to import a PICT file that is larger
than 64K and uses 16 bits of color. Under Windows 3.1, images like this import correctly.
Ami Professional: When FrameMaker imports an Ami Pro file, it skips any graphics in Ami
Pro’s native graphics format. Copy and paste these graphics into FrameMaker after
importing the file. Also, the correct font, tab, and indent settings may not import properly.
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Autocad 11: FrameMaker does not support DXF files generated by this version of Autocad.
Micrografx Designer: Ovals drawn using thick pens (100 points or more) import at low
resolution or with incorrect dimensions.
Professional Write Plus: When you open or import a Professional Write Plus file, the
Unknown File Type dialog box recommends using the Ami Professional filter to translate
the file. Since Professional Write Plus files are 100% compatible with Ami Professional, use
the recommended filter to import the file. Use the Professional Write filter solely for
importing Professional Write 1.0, 2.0, and 2.2 files.
HPGL files: Use the HPGL I format if possible. Although FrameMaker supports the
HPGL II format, it does not support all record types.

Network issues
Using FrameMaker on a network: If you are sharing FrameMaker files on a network, be
sure to turn on Network File Locking in the Preferences dialog box to avoid having more
than one user modifying the same document at the same time. For more information on
Network File Locking, see Chapter 2 of Using FrameMaker.
Important: Network File Locking provides only a warning when other users try to open
documents that you are currently working with; it does not prevent other users from viewing
and modifying the document. To provide thorough protection, use the security features
available in your networking software to restrict access to important files and directories.
If two people attempt to save the same file simultaneously, a dialog box will appear that
provides an option to cancel the save or try again. You may have to click the Cancel button
several times before the dialog box disappears.

Calling Frame Technical Support (Page 1 of 2)
Call Frame Technical Support Monday through Friday from 7:00 AM to 5:00 PM Pacific
time at (408) 922-2744. Contact the Frame bulletin board service (BBS) any time at (408)
433-4841.
When contacting Frame Technical Support, please be prepared to provide as much
information in the following list as possible. This information will help your technical support
engineer solve your problem more quickly.
Hardware Information
Computer manufacturer/model

Total RAM

Processor (386, 486, AMD, etc.)

RAM available before starting Windows

MegaHertz (16, 25, 33, etc.)

Memory manager in use

BIOS

Disk space available on hard drive

Hard disk controller

Network manufacturer/version number

Math co-processor
(continued on next page)
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Software Information
FrameMaker version number

DOS version number

Windows version number and mode

Windows start-up files (TSR's)

Swap size (permanent or temporary)

Type (font) manager in use

Contents of config.sys file

Contents of autoexec.bat file

Network software (if any)

Location where FrameMaker is installed
(local hard disk or on a network)
Printer Information

Printer manufacturer/model

Amount of printer memory (if any)

PostScript or PCL

Windows printer driver version
Error Codes and Symptoms

Error message code number that appears
Precise symptoms of the problem

Keystrokes that caused the problem

