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Release Notes
(
This manual contains last-minute information and tips on version 5.5 of both Adobe®
FrameMaker® and Adobe FrameMaker+SGML~M It begins with a table of other release
notes and Readme files that may be installed on your system (see ~) and then
provides an alphabetical list of topics (see ~).
This manual uses the following terms:

(

• Platform refers to a supported operating system: Microsoft® Windows®, Macintosh®
(Mac™ OS), or UNIX®.
• FrameMaker product refers to both FrameMaker and FrameMaker+SGML.
• FrameMaker document refers to a document created in either FrameMaker or
FrameMaker+SGML.
• Version refers to a FrameMaker product that runs on a particular platform (for
example, the Windows version). Version also refers to a major revision of a
FrameMaker product. (Both FrameMaker 5.0 and 5.1 are considered part of version
5, but FrameMaker 5.5 is considered a separate version.)
Entries that apply only to a specific platform are identified accordingly. The remaining entries
apply to all platforms. For detailed information on multiplatform use, see the online manual
Working on Multiple Platforms.
Users upgrading to version 5.5 might want to especially note the following entries:
• "Backup autosave recover and lock files from previous versions" on page 3
• "Backward compatibility" on page 3
• "Formatting improvements" on page 7

(

Users working with multibyte (Asian) documents might want to note the following entries:
• "Combined fonts" on page 4
• "Find/Change wildcards in multibyte documents" on page 7
• "Keyboard shortcuts and multibyte documents" on page 9
• "Multibyte attribute values" on page 11
• "PDF export on Japanese UNIX systems" on page 12

Copyright © 1997 Adobe Systems Incorporated. All rights reserved. Adobe. the Adobe logo. Acroba~ Adobe Illustrator. Adobe Type
Manager. ATM, Distiller, Frame Developer's Kit. FraIneMaker, FrameMaker+SGML, FrameMath, FrameServer, FrameViewer,
PagcMaker, Photoshop, and PostScript are trademarks of Adobe Systems Incorporated. All other brand or product names are trademarks of
their respective companies or organiz.ations.
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Other release notes and Readme files
This manual covers a wide range of topics. You might also be interested in the following
(
files, which cover some more narrowly defined topics (some of these files may not be
present on your system). In the following table, language in a path name represents a userinterface language, such as usenglish or francais.
Online file

Platform

ContEmts

Location

Readme.txt

Windows

Late-breaking installation
information

The top level of the CD-ROM, or
installed in the main product folder

ReadMeFirst

Macintosh

Late-breaking installation
information

The top level of the CD-ROM, or
installed in the main product folder

README

UNIX

Late-breaking installation
information

The top level of the CD-ROM, or
installed in $FMHOME

README

All

Overview of the sample Maker
Interchange Format (MIF) files

The MIF folder in the Samples folder

README

All

Late-breaking information on
filters

The Filters folder.

FDK Release Notes

All

Late-breaking information on
the Frame Developer's Kit™
(FDK)

The relnotes folder within the
omanuals folder

README

UNIX

Information on setting up a
Demo account

$FMHOME/fminitlsamplehome

README.VUE

UNIX

Integration information for
HPVUE

$FMHOME/fminitlsamplehome

README.filemgr

UNIX

How to update the document
icon in the OpenWindows File
Manager

$FMHOME/fminitlsamplehome

README

UNIX

$FMHOME/fminitllanguagel
How to integrate the ToolTalk
protocol with X Window System APIArealtooltalk
applications

README.Command

UNIX

How to customize the keyboard $FMHOME/fminitllanguagel
interface
configui

README

UNIX

How to write a FrameServer
client

README

UNIX

How to write a UNIX graphic
inset editor

TM

(

(

$FMHOME/fdklsamples/unixsampl
frameserver/clclient
$FMHOME/fdklsamples/unixsampl
frameserver/fmbitmap

(
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General issues

(

This section is an alphabet,ical list of late-breaking topics and tips relating to version 5.5.
Topics that apply only to a particular platform are marked accordingly.

Anchored frames
• Dragging a frame anchored to the outside of a rotated text frame or column can be
difficult, because the anchored frame unrotates while you move it and snaps back to
its proper rotated position only when you've finished dragging it. If you find it hard to
reposition a frame this way, unrotate the text frame, position the anchored frame, and
then rerotate the text frame.

Backup, autosave, recover, and lock files from previous versions

(

• Version 5.5 of FrameMakl3r products use the same file-naming pattern on all platforms.
This means that backup files on the Macintosh and in UNIX now have different names.
The following table illustrates the differences.
Platform

Filename

Backup file in
version 5.1

Backup file in
version 5.5

Windows

Chapter.fm

Chapter.backup.fm

Chapter.backup.fm

Macintosh

Chapter.fm

Chapter.fmBackup

Chapter.backup.fm

UNIX

Chapter.fm

Chapter.fm.backup

Chapter.backup.fm

Similar patterns hold true for autosave files, recover files, and lock files.
Because of the changes in the naming patterns on the Macintosh and in UNIX,
backup, autosave, recover, and lock files from previous versions will not be overwritten
when you convert a file to version 5.5 on Macintosh and UNIX platforms.

Backward compatibililty
To open a 5.5 document in an earlier version of a FrameMaker product, save the
document as MIF, and then open the MIF file in the earlier product. When you do this,
the Console window will report that many "invalid" MIF statements are being skipped.
This is normal. Any feature or formatting in the document that is not available in the
older version will be ignored.

(

Version 5.5 lets you applll a Language property to words or characters by using the
Character Designer. Earlier versions allowed the Language property to be applied only
to whole paragraphs. If you use MIF to open a 5.5 document in an earlier version, any
text tagged in a character format that sets a special language will revert to the default
language.

(
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Color
• You can separate colors in imported Encapsulated PostScript (EPS) files as spot
colors. However, to print as spot colors, the colors must have been named in the
application that created the EPS files.

(

• In some cases, a FrameVector graphic is created when you import a vector-based
graphic. (For more information, see the online manual Working on Multiple Platforms.)
If the original graphic contains gradient fills, they are replaced by solid colors in the
FrameVector facet.
• You can create a custom color library for use in FrameMaker products. The custom
libraries use the same format as Adobe PageMaker@ color libraries. If a custom
PageMaker color library uses Japanese color names, the first character of the color
library family name must be a multibyte character.
• If a document has two or more colors with the same definition but with different names,
each color appears on its own sheet when you print color separations. For example,
a document that contains a color named Aqua and a color named BlueGreen will print
a separation for each of these colors-even if the definitions of Aqua and BlueGreen
are identical. The information presented on page 249 of the FrameMaker User Guide
is not accurate in this respect.

(

• (Windows and UNIX) Empty color separation pages may be printed for a page-even
if you've selected Skip Blank Separation Pages in the Separation Setup dialog boxif that page contains an imported EPS graphic.

Combined fonts
• Combined fonts use the Western font for all single-byte characters and use the Asian
font for all multibyte characters. For this reason, Japanese single-byte, half-width
katakana characters are not supported in combined fonts.
• (Windows and Macintosh) You can turn off the Allow Bolded and Obliqued Styles
setting in the Asian Text area of the Edit Combined Fonts dialog box. Creating a
combined font with this setting off means that bolding or italicizing the Western text
will not automatically bold and italicize the Asian text as well. If you're sharing
documents with users on UNIX systems, you may want to turn off this setting to avoid
cross-platform differences.

(

(
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Context menus

(

• When you right-click (Control-click on the Macintosh) in a document, a context
(shortcut) menu will appear where you clicked. The contents of this menu are
determined by the position of the pointer, not the insertion point. For example, if the
insertion point is in a table but the pointer is over a graphic, the context menu will
contain commands for working with graphics, not tables.
Here are some platform-specific tips for using context menus:
- (Windows) The Shift+F10 keyboard shortcut is equivalent to right-clicking.
- (Windows and UNIX) If you want to use the commands in context menus on selected
text, select the text by right-dragging and then choose a command from the context
menu that immediately appears. Moving the pointer and then right-clicking might
deselect the text.
- (Macintosh) In previous versions, Control-clicking was used to quick-copy text. The
keyboard shortcut for quick-copy is now Control-Command-c1ick.

(

- (UNIX) The many context menus replace the single Maker pop-up menu in earlier
versions.
- (UNIX) The F4 keyboard shortcut is equivalent to right-clicking.

Courier font (Windows and Macintosh)
• Do not use the Courier font when Adobe Type Manager® (ATM®) is turned off or not
installed. Doing so may prevent FrameMaker products from accurately displaying
Courier text.

Delete commands
• The following delete commands in FrameMaker products have been changed slightly
to conform more closely with UNIX Emacs commands.
Current shortcut a
Command
Delete backward to the start of the Esc k b, Meta+h,
previous word
Control+Meta+h, Meta+Delete

(

Meta+h,
Control+Meta+h,
Meta+Delete

Delete backward to the start of a
line

Unchanged

Delete forward to the end of the
next word

Release Notes

Esc k b

Delete backward to the end of the No shortcut available.
previous word
Contro/+u, Control+Backspace,
Shift+Backspace, Contro/+Delete

Delete backward to the end of the Esc k a
previous sentence

(

Previous
shortcut

Esc k f, Meta+d, Control+Delete

Unchanged
Esc k f

5
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Current shortcut a

Previous
shortcut

Delete forward to the start of the
next word

No shortcut available.

Meta+d

Delete forward to the end of a line Control+k, Control+Shift+Delete

.....
(

Unchanged

Delete forward to the end of a
sentence

Meta+k

Unchanged

Delete forward to the start of the
next sentence

Escks

Unchanged

Clear selected text (Edit> Clear)

Esc e b, Control+w b

Esc e b

a. All shortcuts apply to UNIX systems except for underlined shortcuts, which are Windows only. Bold
shortcuts apply to Windows as well as UNIX; italicized shortcuts apply to Macintosh as well as
UNIX; and bold-italicized shortcuts apply to all three platforms.
b. In previous Macintosh and UNIX versions, Control+w was a shortcut for Edit> Cut.

(

These commands now put the deleted text into a special buffer. Previously, all the
commands (except Clear) put the deleted text on the Clipboard.
You can restore the text in this buffer by pressing Control+y or Esc e Shift+y (on all
platforms). Previously, Control+y inserted the contents of the Clipboard. This means
you can use the delete commands in the previous list as a way of cutting and pasting
without changing the contEmts of the Clipboard.
In addition, sequential delete commands from this list add to this special buffer instead
of overwriting it. Delete-back commands add the text to the beginning of the buffer;
delete-forward commands add the text to the end of the buffer. For example, you could
place an entire paragraph into the buffer by placing the insertion point at the start of
the paragraph and then pressing Esc k s repeatedly until all the sentences have been
removed.

Delete commands that remove single characters (Delete, Del, Backspace, Control+h,
and Control+d) have not changed and do not place the deleted characters into the
special buffer.

(

Document comparison
• Document comparisons between long documents or documents with many tables may
cause FrameMaker products to run out of memory. Increase the memory available to
FrameMaker products, and try the document comparison again.

• (Windows) If you need to compare two book files that contain some identical document
files, be sure to turn off Network File Locking in the Preferences dialog box. With
Network File Locking selected, an alert that the files could not be opened appears
when you compare these book files.

(
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Find/Change wildcards in multibyte documents

(

• When Use Wildcards is selected in the Find/Change dialog box, certain characters
(*, ?, I, 1\, $, [, and]) have special meanings. In a multibyte document, the bracket
characters ([ and]) do not work as wildcards. The other wildcard characters work as
documented.

fontlist file (UNIX)

(

• The format of the fminit/fontdir/fontlist file has changed in version 5.5. You must update
any personal fontlist files in order to make full use of version 5.5's font capabilities. The
new fontlist format is incompatible with earlier versions of FrameMaker products. If you
need to continue to use an earlier version of a FrameMaker product along with version
5.5, save a nonupdated copy of the fontlist file and switch to it before starting the
earlier version. For more information on the fontlist file, see the online manual
Managing Fonts.

Formatting improvements
• If you're upgrading from version 5.0 or 5.1 of a FrameMaker product, you may notice
some formatting improvements when a document is opened in version 5.5. This will
be true especially for documents with many footnotes or for multicolumn documents
where tables or anchored frames straddle the columns.

Graphics
• Dashed lines and polylines might appear and print solid if the lines are especially thick
and either have round or projecting caps or contain acute angles. To correct the
problem, change the Line Ends Options setting to Butt, use a smaller line width, or
redraw the object using separate lines.

HTML export

(

• If you have several lines of code that you want to export as a single block of code in
HTML, don't map each line to PRE. Doing that inserts an extra blank line between
each line of code. Instead, adjust the mapping on the HTML reference page so that
the row for this format in the HTML Mapping table resembles this:
P:Code

PLAIN TEXT
Parent = PRE
Depth = 0

N

N

• Vector graphics and text frames convert to bitmaps when you export to HTML. If you're
converting them to GIF format and if the text is greeked in the GIF graphic, turn off
greeking in the File> Preferences dialog box.

(

• If there is a line break in the middle of a word in the converted HTML file, there may
be a marker in the middle of that word in the FrameMaker document. To fix this, move
the marker to the beginning or end of the word and save as HTML again.

Release Notes

7

General issues
Go To

".

I

• When you save as HTML, only the main text flow is converted. The main text flow is
the first autoconnected flow in the document. If a document has no autoconnected
flows, nothing will be converted to HTML. If there are unconnected flows in addition to
a main flow, only the main, autoconnected flow will be converted.

(

• GIF graphics imported by reference that have been scaled or cropped in a
FrameMaker document may lose these settings when you save as HTML. To avoid this
problem, choose File> Utilities> HTML Setup and click Options. Click Copy Files
Imported by Reference and click OK. Then save as HTML again.
• When you save as HTML, FrameMaker products use default filters to convert graphics
to GIF, JPEG, or PNG format. You can use a custom filter, instead of the default one,
if the custom filter was created and installed as described in the Frame Developer's
Kit documentation. You specify the filter to use for HTML export by changing the filter
name in the HTML Options table on the HTML reference page. The filter name
appears in the Value column of the Image Format row.

(

• (Windows) The HTML files produced by FrameMaker products do not display line
breaks when opened in Notepad. To view the HTML file correctly, use a FrameMaker
product, WordPad, or Netscape Navigator (choose View> Document Source in
Navigator).
• (UNIX) If you have the 5.1 prerelease HTML export plug-in (code-named HoTaMaLe)
installed, un install it before using the built-in HTML export feature in version 5.5. The
plug-in is loaded in $HOME/fminiUusenglish/APIArea/apiclients. For information on
uninstalling plug-ins, see the online manual Customizing FrameMaker Products.
• (UNIX) In some cases, there may be too many items than can be displayed in a popup menu in the HTML Setup dialog box, thereby not letting you make a mapping for
an item. If this happens, specify the mapping in the HTML reference pages instead.
• (UNIX) If you've set a resource in a FrameMaker product so that the background color
is not white, graphics exported when you save as HTML may pick up this color. If this
isn't what you want, reset the resource to white and save as HTML again.

Hypertext and HTML export

(

• The table on page 402 of the FrameMaker User Guide describes how hypertext
commands work when you convert a document to HTML. The row in that table
describing the Hypertext open commands is incorrect. The correct information follows:

Hypertext command

Result in HTML

Open Document & Fit to Page

Command works as described in the chapter but
doesn't fit to page or open a separate window.

Open
Open
Open
Open

Release Notes

Document
Document
Document
Document

as New
at First Page
at Last Page
at Page Number

These commands do not work.

(
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Hypertext

(

• Generating a list of hypertext markers produces a list of markers drawn only from body
pages. Because documents may have hypertext markers on master pages, a
generated list of hypertext markers may not be complete.
• When you insert an openlink command in the current document, be sure to specify
both the document filename and the linkname in the command syntax. The section,
''To create a link to a specified topic," in the hypertext chapter of the FrameMaker User
Guide erroneously states that you can omit the filename if the topic you want to display
is in the current document. Instead of using openlink and specifying a filename, you
can use the gotolink command to set up links within a document without specifying
the filename.

(

• (Macintosh) If you click hypertext buttons in a MIF file, they may not work as expected.
The hypertext gotolink command will not display the location in the current MIF
file containing a corresponding newlink command. To correct the problem, save the
MIF file in Document format. (The gotolink command will display the location in
a different MIF file containing a corresponding newlink command.)

Installing to a network (Windows)
• A network administrator can install a FrameMaker product to a network server so that
users can SUbsequently install from that network server. Users might expect a reduced
set of options when performing this sort of installation since the network administrator
preselects and predetermines most of the choices. However, the following options will
still appear when a user installs from the network, even though it makes no difference
what the user chooses:
- The language of the installation (US English or International English)
- The type of installation (Registered Owner Version or On a Network Server)
- The fileset (Typical, Compact, or Custom)

(

Keyboard shortcuts and multibyte documents
• Don't use the keyboard shortcut for transposing characters when the insertion point is
between two multibyte characters. Doing so may change the characters to symbols or
other characters.
• Because a front-end processor (FEP) interprets keyboard input before a FrameMaker
product can do so, some keyboard shortcuts may not work in some input modes. You
may have to switch to Western input mode or disable the FEP to access all keyboard
shortcuts.

(

• (Macintosh) Because the Esc key is used to input Korean characters, you can't use
Esc-key shortcuts when you're working on a Korean document on the Macintosh
unless you turn off standard input mode in the Apple Korean FEP. Other shortcuts,
such as those using the Command or Control keys, work as usual.

Release Notes
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• (UNIX) If you're using the csOO front-end processor (FEP), you won't be able to use
an Esc-key shortcut for a command that applies to Japanese text that has been
selected with the keyboard (with Shift+arrow, for example). The csOO FEP filters out
the Esc key, thereby nullifying the shortcut. However, you can use Esc-key shortcuts
if you select Japanese text by dragging, and you can use these shortcuts on any
Western text.

(

So too, HP-UX systems use the Meta key to toggle the FEp, thereby making it
unusable for keyboard shortcuts. You can use Control+space to toggle the FEP instead
of Meta by making the following changes:

FEP

Do this

XJIM

Add the following line to the file $HOME/.xjim_keybind:
XJim.ConversionStartKey: Ctrkkey>Space\n\<key>Henkan_Mode

ATOK8 or VJE

Use the customization window to change the binding of the FEP switch
to a key other than Meta

EGBridge

Edit the file /etc/optlegb/config/EGBMap and modify the line:
LKONOFF = XK_Henkan XK_Meta_L
(Replace XK_Meta_L with another key. See the output of the
command xmodmap -pk for a list of the possible keys.)

(

Log file in UNIX
A new environment variable, FMLOGFILE, has been added for FrameMaker products
running on UNIX systems. If FMLOGFILE is set prior to starting a FrameMaker"product, and
if the command-line option -console_log is given, the file named in FMLOGFILE will be
created or overwritten with the console log information for the session.
If FMLOGFILE is not set prior to starting a FrameMaker product, and if the command-line
option -console_log is given, the file $HOME/fmconsole.log will contain the console log
information, as it did in previous versions of FrameMaker products.

(

Meta, Alt, and AltGraphic keys (UNIX)
• There are several resources you can use to map the Meta key and the Alt key.
Resource

Explanation

Maker.meta:

Sets the modifier for the Meta key. If this resource is set, it
is used. Otherwise, the modifier assigned to Meta_L or
Meta_R is used. If there are no modifiers assigned to
Meta_L and Meta_R, the modifier assigned to AieL or
Alt_R is used.
Most X servers work with Maker. meta: 1
Solaris X servers work with Maker. meta: 4

(
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Resource

Explanation

Maker.alt:

Sets the modifier for the AltGraphic key, which makes
another key produce its alternate meaning (indicated by a
third character printed on the keycap). If this resource is set,
it is used. Otherwise, the modifier assigned to Mode_switch
is used. If Mode_switch isn't assigned a modifier, AICl or
AICR is used as long as it is assigned a different modifier
than Meta.
Solaris servers work with Maker. al t: 1
Most other X servers work with Maker. al t: 2
Older SGI X servers work with Maker. al t: 3
IRIX 4.0.5 machines work with Maker. al t: 13

!Maker.metaBeatsAIt: False On some HP systems, AICl, AICR, and Mode_switch
(AltGr) are assigned to the same modifier. In that case, this
resource determines the meaning of the modifier. The
default, True, means the modifier will specify Meta.
Uncomment the resource to have the modifier specify AltGr
instead. (Or use the xmodmap program to remap your
keyboard.)

(

!Maker.teIiMods: True

When uncommented, makes FrameMaker products print to
the console the values used for Meta and Alt.

Moving objects by using arrow keys (Windows)
When an object is selected, you can move it by pressing Alt with an arrow key. However,
the arrow key cannot be on the numeric keypad. Instead, you must use the keys in the
arrow-key cluster, to the left of the numeric keypad.

Multibyte attribute values
• Do not use multibyte characters when entering values for attributes in
FrameMaker+SGML. If you do, the value will not be correctly exported to SGML.

(
Opening text files (Macintosh)
• If your Macintosh uses Mac OS 7.5.3 with virtual memory turned on, and a
FrameMaker product locks up while opening a text file, turn off virtual memory or
upgrade your operating system to version 7.6.1 or later.

Pasting tab-delimited text
• The FrameMaker User Guide states (on page 376) that tab-delimited text is converted
to a table upon pasting. This is not true. Once tab-delimited text is pasted, you can
select it and convert it to a table by using the Table> Convert to Table command.

(
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Pathnames from UNIX servers on a Macintosh
• The Macintosh version of a FrameMaker product will not be able to find a file on a
UNIX server if a volume name on the server contains a slash character (for example,
if the UNIX server has a volume name such as /usr/structure). For more information
on naming files when working across platforms, see the online manual Working on
Multiple Platforms.

(

PDF export
The fourth bulleted item on page 448 of the FrameMaker User Guide contains an error.
It should note that "other hypertext commands convert to equivalent PDF links" when
you save as PDF.
(Windows) For best results when exporting to Portable Document Format (PDF), be
sure to install and use the AdobePS 4.2 PostScript driver. Also install the appropriate
PostScript Printer Description (PPD) file for your printer. The AdobePS driver is
included on the FrameMaker product CD-ROM.

(

(Windows) For best results when exporting color images to PDF, be sure to have a
color printer selected as the current driver. Some black-and-white printers may disable
color output to PDF.

PDF export on Japanese UNIX systems
• Currently, Adobe Acrobat® Distiller® is not available for Japanese UNIX systems. If you
work on a UNIX system and want to convert a Japanese-language document to PDF,
you could save the file as PostScript®, move the PostScript file to a Windows or
Macintosh Japanese system, and distill it there.

PDF export on SGI systems
Adobe Acrobat Distiller is not available for SGI UNIX systems. If you work on a an SGI
system and want to convert a document to PDF, save the file as PostScript, move the
PostScript file to a platform where Distiller is supported (for example, Solaris, SunOS,
Windows, or Macintosh), and distill it there.

(

Printer drivers (Windows)
• Because FrameMaker products for Windows print a page description to the Windows
Graphics Device Interface (GDI), FrameMaker products have no control over the
abilities or limitations of any printer driver. FrameMaker products can support only
printer drivers that have been approved for use in Windows 95 or Windows NT. Do not
use Windows 3.1 printer drivers.
The preceding also applies to printing to a typesetter at a service bureau. Be sure to
use the latest driver for the specific printer you wish to create output for.

(
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• If you have numerous PostScript fonts installed and discover that some of them are
not being automatically downloaded correctly (Courier is being sUbstituted), you may
need an updated PostScript driver. Adobe recommends you use the AdobePS
PostScript driver version 4.2 or later and not the PostScript driver shipped with
Windows 95.
The 4.2 driver is included on the FrameMaker product CD-ROM. Be sure to install this
driver and the appropriate PostScript Printer Description (PPD) for your printer.
• To obtain the latest printer drivers or PPD for Windows 95 or Windows NT, download
them from Microsoft's Web site (www.microsoft.com) or from the printer manufacturer's
site. For example, go to www.hp.com to find the latest drivers or PPDs for HewlettPackard printers.

(

Printing
If you want images created in other applications to overprint when printed from a
FrameMaker product, note the following special cases:
- CMYK TIFF files overprint over spot plates when printed as separations and their
Overprint attribute is set to True and their Fill property is set to None.
- (Windows and UNIX) Encapsulated PostScript (.eps) files do not overprint when
printed as separations.
- (Macintosh) Encapsulated PostScript files created in an Adobe product (including in a
FrameMaker product) overprint when printed as separations if the Overprint attribute
of individual objects was selected in the application that created the EPS file, and if
the Fill property of the EPS image is set to None in the FrameMaker product.
(Windows) The FrameMaker product Print Document dialog box contains some
options that may also appear in the Windows printer Properties dialog box, such as
the number of copies. When you print a document, the settings in the Print Document
dialog box override those in the Properties dialog box.
Because the Rotate Page command lets you mix portrait and landscape pages in a
single document, FrameMaker products also override the Orientation setting in the
Windows Properties dialog box. Always leave the Windows Orientation option set to
Portrait.

(

• (Windows) If you're familiar with PostScript, you might want to send the PostScript
error-handler file to your PostScript printer to help troubleshoot printing problems. This
file loads a small program into your printer so that it prints any PostScript error
encountered. You can send this error handler to your printer from the DOS prompt with
the following command.

copy "C:\Program Files\Adobe\FrameMakerS.S\Fminit\Ehandler.ps"

lptl:

If you've installed the FrameMaker product in a different location or if your printer is
connected to a different device (such as lpt2), make the appropriate changes in this
command.

(
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• (Windows) If you're printing to a color PostScript printer but your color documents are
output without color, verify that the current printer supports color and that color has
not been disabled for that printer. To make sure color is not disabled, right-click the
printer driver and choose Properties. Look for Color options and set them accordingly.

(

• (Macintosh) If you use a PS Printer B.x or LaserWriter B.x PPD that supports custom
paper sizes, you will see an option called Frame Custom Paper Size in the Paper popup menu in the Page Setup dialog box. Some printer drivers might add their own
options to the pop-up menu, in which case you'll see both Frame Custom Paper Size
and an option called Custom. For best results, choose Frame Custom Paper Size.

• (Macintosh) If you're printing text at non-integral point sizes (for example, at 8.5 rather
that 9.0 points), make sure the Unlimited Downloadable Fonts option in the Page
Setup options dialog box is turned off. Otherwise, text may be positioned improperly
on the page with some printer drivers. (Turning off this option will also greatly increase
printer performance.) With this option off, you may want to add more RAM to your
printer or consider turning off Larger Print Area in the Page Setup options dialog box,
limiting the number of fonts used in your document, or turning off printer-specific
features such as image enhancement.

(

• (UNIX) A rotated text frame containing PostScript code may cause a document to print
improperly, particularly if the text frame is on a master page. To correct the problem,
set the rotation angle of the text frame to zero degrees.

Printing to typesetters (Windows)
Here are some tips for printing to Linotronic typesetters in Windows.
Some Linotronic typesetters automatically put registration marks on the page. Check
with your service bureau to see if you need to use the Registration Marks setting when
you print from a FrameMaker product.
Because Windows registration marks must be outside the printed page, the page size
must be smaller than the page size of the Linotronic printer driver. For example, if the
page size is 8.5x11 inches, the Linotronic printer driver page size would be 9.5x12
inches. If the printer driver page size is smaller, Windows warns you that registration
marks will not fit on the printed page.
Not all Linotronic models support thumbnails. Test various thumbnail settings to find
the optimum setting. Some Linotronic models will print 1x2 thumbnails correctly, but
not 2x2 thumbnails.
- Some Linotronic drivers fail to let you enter a custom paper size even after you have
chosen User Defined Size in the Paper Size pop-up menu. To enter a custom paper
size, right-click the Linotronic driver and choose Properties. Click the Paper tab, and
then select the custom paper size icon from the horizontal scroll list of icons.
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Quick-copying between documents

(

• Quick-copying text (copying text without using the Clipboard) from one open document
to another is possible only on UNIX systems. Contrary to what the User Guide states
on page 54, in Windows and on the Macintosh you can quick-coPY only within a single
document.

Screen display
• If the document display seems incorrect or unusual, refresh the display by pressing
Control+1 (lowercase L).

Selection shortcuts (Windows)

(

• The following two keyboard shortcuts have changed slightly to better conform to
Windows conventions:
Shortcut

Previous behavior

Shift+End

Selected the current line, then the next line Selects from the insertion point
to the end of the line

Shift+Home Selected the current line, then the
previous line

New behavior

Selects from the insertion point
to the start of the line

Esc h I (lowercase L) still selects the current line, then the next line; and
Esc Shift+h Shift+1 (uppercase L) still selects the current line, then the previous line.

SGML export
• If you're saving a FrameMaker+SGML document as SGML and text in a graphic
becomes greeked, turn off greeking in the File> Preferences dialog box and save as
SGML again.

(

Spelling Checker
• You can't add words to a dictionary that are longer than 25 characters. This is true for
both words in your personal dictionary (added by clicking Learn in the Spelling
Checker dialog box) and for a document dictionary (added by clicking Allow in
Document). Also, words longer than 29 characters cannot be checked for spellingthey are always treated as spelled correctly by the Spelling Checker.
• The Spelling Checker may incorrectly select a word as misspelled when the word is
not separated by spaces from words with a different Language property. If this
happens, the Spelling Checker may require that you fix the spacing before you
continue spell-checking.

(

• In a multibyte document, some special characters may not be displayed in the Spelling
Checker dialog box as they are in a Western-language document. For example, a
backslash will be displayed as a yen symbol, and a nonbreaking hyphen will be
displayed as a blank.
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• In a multibyte document, turn off the Straight Quotes option in the Spelling Checker
Options dialog box if your document contains Roman text in a multibyte font.

(

Table sorting
• Sorting a table row or column will not work as expected when some table cells contain
Asian, multibyte characters and other cells contain Western, single-byte characters.
• Numbers preceded by special symbols will sort correctly as numbers. These special
symbols are 0+-,. and $. Combining several of these symbols in a cell will sometimes
make the cell sort incorrectly. For example, a table cell containing -2 will sort correctly
as a negative number falling between -3 and -1, but a cell containing -2+3 will sort
incorrectly (it will be interpreted as -23).

Table formats

(

• All the properties in a table format are applied when you insert a new table but only
some properties are applied to an existing table. In addition, there are table properties
that are not stored as part of a format and therefore would never be applied to table.
This information is covered in the FrameMaker User Guide on pages 117 and 129.
The following table summarizes the points made on those pages:

Stored in catalog

Applied to
existing table

Basic table properties

Applied to
new table
Yes

Default ruling

Yes

Yes

Default shading

Yes

Yes

Number of heading, body, and footing rows

Yes

No

Number of columns and their widths

Yes

No

Default paragraph formats for text in cells
(only the first paragraph format in column in
each type of row is stored)

Yes

No

Yes

(

Not stored in catalog
Cell contents (for example, text or graphics)
Rotated cells
Straddled cells
Custom ruling
Custom shading
Row formatting (the minimum or maximum row height, where it starts, and its Keep With
setting)

(
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Tabs in markers

(

• You can enter a tab character in marker text by either entering \t or the hexadecimal
code \x08. However, if you generate a list of markers, only tabs entered as hex codes
appear. If you generate an index of markers, only tabs entered as \t appear.

Troubleshooting in Windows
• If a FrameMaker product crashes with an invalid page fault or fatal error for no
apparent reason, go through the following checklist of Windows settings:
1. Make sure you have plenty of disk space available for the temp variable.

To do this, open a DOS shell, type set, and press Return. Both the paths for TMP and
TEMP should be set to a local drive directory other than root, \windows, or \dos.
You should have at least 5 MB free on the drive that temp is set to when starting a
FrameMaker product. If you need to change the path for tmp or temp, do one of the
following:

(

- (Windows 95) Choose Start> Run, enter sysedi t, and click OK. In autoexec.bat, find
the set temp and SEt tmp statements, and then edit the path statements to reflect
the new path.
- (Windows NT) Choose Start> Settings> Control Panel, double-click System, and then
click the Environment tab. Edit the User Variables for both tmp and temp.
2. Check the swap file settings.

Choose Start> Settings> Control Panel, double-click System, click the Performance tab,
and then click Virtual Memory. If necessary, click Let Windows Manage My Virtual
Memory Settings. Windows will create the swap file on the drive listed below this option.
The space available on this drive is also listed. If the available space is less than the
amount of RAM on your system, you should increase the available disk space or switch
the swap file to a drive with more available space.
(Windows NT) The minimum virtual memory should be double the amount of RAM in your
system.

(

3. Test the video driver.

Choose Start> Settings> Control Panel, double-click Display, click the Settings tab, and
then click Change Display Type. The adapter type, manufacturer, and version number will
be listed in this box. Check with your manufacturer to see if this is the latest driver
version. Also check with the manufacturer for known incompatibilities (there may be a
Readme file installed with the driver that covers this issue).
Test in VGA mode by doing one of the following:
- (Windows 95) From the previous dialog box, click Change and then click Show all
Devices. Choose "Standard display types" under Manufacturers and Standard Display
Adapter (VGA) under Models. Click OK and let Windows restart.
- (Windows NT) Restart your computer and choose Windows NT 4.0 (VGA mode) from
the Windows NT boot menu.

(
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If the problem goes away in VGA mode, you probably should obtain an updated driver.
4. Check system resources.

Windows 95 and NT 4.0 handle resources much more efficiently than Windows 3.x, but
it's still possible to run low. In Explorer, choose Help> About Windows. This dialog box
lists the available memory (RAM and swap) and system resources available. Normally,
the system resources are in the 70-90% range. If the resources run below 70%, you are
taxing your resources heavily; free up more resources by exiting other programs.
5. Run Scan Disk to fix disk errors on all local partitions.

Choose Start> Programs> Accessories> System Tools> Scan Disk.
6. Check the system date in the DatelTime control panel.

The month and year should be current.
7. Run Windows 95 in safe mode.

Restart your computer and press F8 when the DOS screen shows Starting Windows 95
in the upper left corner of your screen. Then choose Safe Mode.

(

Video drivers (Windows)
• FrameMaker products depend on Windows and your Windows video driver to produce
the screen display. The only drivers and video accelerators supported are those that
have been tested and approved by Microsoft or by their manufacturers for use with
Windows 95 or Windows NT.
If the document display seems incorrect (for example, if buttons in a dialog box are cut
off) and if the problem is not fixed by pressing Control+1 (lowercase L), the video driver
might not be fully compatible with or correctly configured for Windows.
If your video driver offers settings you can change, experiment with them. For example,
changing the screen resolution often corrects display problems. To change the
resolution, right-click the desktop and choose Properties. Then, under Desktop Area,
drag the slider. You can also troubleshoot display problems by starting Windows in safe
mode (restart Windows and press F8 before Windows loads; then choose Safe Mode
from the menu).

(

If the display problem goes away at a low resolution (such as 640 by 480) or in safe
mode, you probably should obtain an updated driver. You can contact the manufacturer
of your video card to get the latest driver, or you can look for it in one of the Microsoft
online download areas or in the Microsoft World Wide Web site (www.microsoft.com).

Word filters (Windows)
• Version 5.5 of FrameMaker products cannot open Microsoft Word files saved in
Office 97 (Microsoft Word 8) format. To avoid this problem, in Word, save the file as a
Word 6.0/95 file or as an RTF file instead. For additional late-breaking information on
filters see the README file in the Filters folder.
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