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An enhanced user interface and an updated user experience

The Adobe FrameMaker 12 user interface has been enhanced to make it easier 
than ever to work the way you want.

Customize the appearance of icons

The new icon options allow you to configure your icons the way you want them. 
Regular size or large, greyscale or color. The options are yours.

What are the benefits?

Crisp, consistent look and feel
Choose either regular sized or large icons (in greyscale or color) to suit 
your work style.

Quickly get to know your icons
Pods now use a standard set of icons. As soon as you know one icon and 
its function you know it across all pods. Learning how to work in pods is 
faster than ever.



Click the image to launch a video. Once playing, right–click for options.

Change the appearance of icons

Icons can be regular or large size and color or greyscale.

TASK

1. Select Edit > Preferences.

2. Under Global, select Interface.

3. Set the icon size1 and color options.

4. Restart FrameMaker.

Manage multiple files

The new Currently Opened Files pod allows you to view all of your currently 
opened files and their complete file path. Quickly identify and navigate between 
saved, unsaved, and active files. At exit there are also options to manage 
multiple open files.

What are the benefits?

Get a clear picture of all the files you are currently working with
Filter, sort, and search a detailed list of your currently opened files in one 
pod.

1. Icon sizes do not change in pods, only in toolbars.






Quickly access the right files, even when several with the same name are open
Simply double-click a file within the Open Files pod and access it. Locate 
and update your files with ease.

Save or close multiple files in one go
Be prompted with a list of unsaved files before you close and quickly 
choose which files you want to save.

Click the image to launch a video. Once playing, right–click for options.

Work with the Currently Opened Files pod

Use the Currently Opened Files pod to view, filter, search, and sort through 
your opened files.

TASK

1. Select File > Currently Opened Files.

2. Under View, select an option.

3. Search by typing in the Search text field.

4. Click Name or Path to sort files.

5. Double click a file to switch to for reading or editing.

Save or close multiple files

Quickly save or close one or multiple opened files.






TASK

1. In the Currently Opened Files pod select all the files to save or close.

2. Click Save Files, Save and Close, or Close Files.

Usability enhancements

FrameMaker UI improvements aren’t just pretty, they’re designed to help you 
increase productivity. Pick from multiple interfaces based on your workflow. 
Improved drag-and-drop functionality and enhanced pod management helps 
you reconfigure your workspace to your ideal work environment.

What are the benefits?

Pick the interface that works best for the job at hand
Use FrameMaker, Structured FrameMaker, or FrameMaker XML Author. 
Depending on the work you do there are three interfaces to pick from.

Open files using an improved drag and drop
Improved functionality lets you drag and drop files into many parts of 
FrameMaker to open them (for example, onto the grey space).

Manage pods more efficiently
Enhanced pod management lets you arrange your workspace to suit your 
personal working style. Pod setup is fast and easy to do with additional 
functions within pods to show or hide exactly what you need to see.

Click the image to launch a video. Once playing, right–click for options.






Drag and drop to open files

TASK

1. Select any file to open in FrameMaker.

2. Drag and drop it into the FrameMaker interface.
ADDITIONAL INFORMATION: You can now drag and drop into almost any location 
and the file opens: Any empty grey space, toolbar, or menu.

Search and filter using pods

TASK

1. In any pod that supports search, type content in the top right field.

2. Click on any pod label to sort the results.

As an example, click on the filename, or the path and sort in the Currently 
Opened Files pod.

Expand and collapse pods

TASK

1. Double click the title bar of any pod.

Close pods

Customize the interface by closing one or multiple pods.

TASK

1. In any pod click the menu icon in the top right corner.

2. Select Close or Close Tab Group.

Enriched authoring, with new capabilities

Embed QR Codes

Generate and edit Quick Response (QR) codes using FrameMaker.



What are the benefits?

Bridge the gap between print and online worlds
Add QR codes to documentation and quickly link readers to web-based 
information or even phone numbers or email addresses.

Edit embedded QR codes in real time
Generate and preview QR codes and change the properties, link targets, 
and sizes to suit your document needs.

Click the image to launch a video. Once playing, right–click for options.

Insert a QR code

Develop and insert a QR code into documentation.

TASK

1. Select the location to insert the QR code.

2. Select Special > Generate QR Code.

3. Develop the QR code as needed.

Edit a QR code

Modify a QR code by changing the destination it points to.

TASK

1. Select any existing QR code.






2. Select Special > Edit QR Code.

3. Modify the QR code as needed.

Regular Expression–based searching

Search using regular expressions lets you perform complex searches to locate 
and replace specific information within the document while using either 
WYSIWYG or Author view.

What are the benefits?

Locate hard-to-find information using regular expressions
Use complex search criteria to find specific information within your 
documents. PERL, GREP, and EGREP searches are supported using both 
WYSIWYG and Author view (example: search for Licen[sc]e to find 
instances of License and Licence).

Create consistency by using find and replace
Find and replace complex content that is incorrect, out of date, or 
inconsistent (example: change formatting on telephone numbers 416 123 
4567 and 905-123-7890 to match (416) 123-4567 and (905) 123-7890 for 
consistency).

Click the image to launch a video. Once playing, right–click for options.






Find/replace with regular expressions

Use regular expressions to find and replace text that matches a specific pattern 
or format.

PREREQUISITE

The Find/Change dialog must be open.

For more details related to syntax refer to the complete FrameMaker 12 
documentation.

TASK

1. Under Find select Text.

2. Enter the expression to find.

3. Select the Regular Expression radio button.

4. Under Change select To Text.

5. Enter the expression to replace.

6. Use the Find, Change, and other buttons as needed.

Single sourcing, now more effectively

Enhanced, intuitive conditional text pod

The conditional text pod has been enhanced with an intuitive new check box 
mechanism, making applying conditional tags for single-sourcing content 
easier than ever.

What are the benefits?

Working with one (or more) conditions is easy; easy to identify the 
condition, and easy to apply or remove it

Viewing the properties of content is easy when you see a check box that is 
selected, shaded, or cleared to show you that the selected content is 
conditional in one, some, or no combinations.



Click the image to launch a video. Once playing, right–click for options.

Apply or remove a condition

Check boxes allow conditions to be quickly set or cleared.

PREREQUISITE

The Conditional Tags pod must be open.

TASK

1. Select the content to modify.

2. Under State, set one or more check boxes to on, off, or as is.
ADDITIONAL INFORMATION: A solid check mark is on, no check mark is off, and a 
shaded check box is as is.

3. Click Apply.
ADDITIONAL INFORMATION: This icon is a check mark on the toolbar.

Build complex conditional expressions

The new and simplified expressions builder contains predefined buttons 
allowing you to work with Boolean operators simply and quickly and even use 
the new nested parentheses features to define complex expressions.

What are the benefits?

Build complex conditional text expressions easily
With parenthesis support and an easy-to-use user interface you can create 
more complex and powerful expressions faster and more accurately.






Create and save multiple expressions for future use
Create, save, and apply your expressions with a guided expression builder, 
helping you develop powerful and complex conditional expressions to 
publish content in whatever format you need.

Click the image to launch a video. Once playing, right–click for options.

Create conditional expressions

Build complex expressions using a set of predefined buttons.

PREREQUISITE

The Show/Hide Conditional Text pod must be open.

As you create expressions the Conditional Expression Builder will guide you to 
build valid expressions and will highlight errors, preventing you from saving the 
expression while there are still errors.

TASK

1. Click Build Expression.

2. Develop the expression.
ADDITIONAL INFORMATION: This can be done largely by double-clicking options in 
the dialog. Nested parentheses are supported.

Any highlighted content would need to be reviewed for errors in the 
expression. For details, refer to the Adobe FrameMaker 12 documentation.






Features that make you more productive

Smart Catalog: a powerful way to work with catalogs

Faster loading times, the ability to search through catalogs, and keyboard 
shortcuts make accessing the Smart Catalog and applying tags quicker than 
ever.

What are the benefits?

Quickly find and apply the correct tag
Conveniently view all paragraph, character, other catalog items, or 
elements in one location. The smart catalog dialog box shows available tag 
options for any chosen insertion point. It displays up to ten objects at a 
time, searching through the catalogs as you type, letting you find content 
quickly.

Familiar keyboard shortcuts
Accessing the Smart Catalog feature is as easy as ever. Use familiar 
keyboard shortcuts to search for and apply style and conditional text tags 
in unstructured FrameMaker or catalog elements in structured 
FrameMaker.

Click the image to launch a video. Once playing, right–click for options.

Update content with tags in FrameMaker

Use keyboard shortcuts to access the Smart Catalog dialog box and apply tags.






TASK

1. Select content to update using the Smart Catalog.

2. Use the appropriate keyboard shortcut to access the tag names.
• To apply conditional formats, press Ctrl+4.

• To remove conditional formats, press Ctrl+5.

• To apply character formats, press Ctrl+8.

• To apply paragraph formats, press Ctrl+9.

• To insert variables press Ctrl+0.

3. Type a tag name.

4. Press Enter.

Modify elements in structured content

Insert, wrap, or change elements in structured FrameMaker by using keyboard 
shortcuts to access the Smart Catalog.

TASK

1. Select the content to update using the Smart Catalog.
ADDITIONAL INFORMATION: This could include inserting an element, wrapping 
content, changing elements, or other modifications.

2. Use the appropriate keyboard shortcut to access the tag names.
• To insert an element press Ctrl+1.

• To wrap text in an element press Ctrl+2.

• To change an element press Ctrl+3.

3. Type a tag name.

4. Press Enter.

Restore your last work session

While working with many open files that are set to work just the way you want, 
it can be tough to exit FrameMaker since remembering all the files you are 
working with (and opening them one by one) can be extremely frustrating. 
Thankfully, you can now use the restore session feature and reset your last 
session to exactly how it was when you closed the program.



What are the benefits?

Close your work session and pick up right where you were
Work with multiple files, configure and position pods, shut down 
FrameMaker, and then restore your session to begin working right where 
you left off.

In case of a crash, recover your content immediately
In the case of a crash the restore session feature now returns your files, 
pods, display settings, and you can get right back to work.

Quickly open all of your recent files in one action
Be more productive when working with multiple files by using the Open 
All Recent Files feature.

Click the image to launch a video. Once playing, right–click for options.

Restore your last session

Restore your files, return to your previous page locations, zoom settings, pods, 
and other configuration options to how they were last time FrameMaker was 
exited.

PREREQUISITE

Files must have been previously opened.

When working with FrameMaker you can restore a session from the Starter 
Page, or via the menu and pick up working right where you left off.






TASK

1. Select File > Restore Last Session.

RESULT:

All files and configurations from the last time you exited FrameMaker are 
restored.

Open all your recently used files at once

Another option to restoring the session you can also choose to open all recently 
used files. The difference between this option and the restore is that this option 
does not remember page location, pod configurations, and other configuration 
settings. Moreover, open all recent files will open all the recent files that you 
have worked on in different sessions.

TASK

1. Select File > Recent Files > Open All Recent Files.

RESULT:

All files in your Recent Files menu option are opened at once using the current 
configurations of pods and toolbars.

Improved product performance

Enhancements to the authoring and stability make the software faster and more 
productive.

Faster to launch and file performance improvements

New features, new abilities, and improved performance! It’s now faster than 
version 11 to launch the software, XML files open faster than ever, even the ones 
with many references (graphics, or other referenced content) are faster to work 
with.

More stable than ever

We have improved the stability of the product by resolving multiple bugs from 
previous releases. We analyzed crashers from various sources such as feedback 
from our customers and partners, bug database, crash logs and have fixed 



several of the outstanding bugs in this release.

Launch preferences

Configure what happens at launch time to streamline startup speed.

TASK

1. Select Edit > Preferences.

2. Under Global, select Launch.

3. Configure options as needed.

Load Adobe Fonts 
On Startup

Deselect this if you do not require Adobe fonts in a session.

Delay Load Client When you select this option, clients such as MathFlow and 
PDF import comments clients are loaded in a delayed 
manner.

Delay Load 
Language Provider

When you select this option, only the English language is 
loaded on startup

Don't Load Startup 
Scripts

Specify the startup script names in this field that you do not 
want FrameMaker to load on startup. Use commas to delimit.



Collaborate with other content creators

• Use industry standard CMS tools

• PDF reviews become even more powerful

• SMEs can review content on a mobile device, and even in the cloud

Use industry standard CMS tools

More than ever it’s important to manage content using the best content 
management systems and FrameMaker works with leading CMS tools. 

FrameMaker has a native connector to EMC Documentum, Microsoft 
SharePoint, and now in this release, also with Adobe Experience Manager. 

What are the benefits?

See your files without leaving FrameMaker
Content in your repository is visible from inside FrameMaker making it 
fast and efficient to work with the repository.

Check files in and out and secure them when editing
Your files are your files. While you work with them no one else can check 
a file out or make edits, so there is no chance of accidentally overwriting 
the work that others do. Files can also be opened in Read Only mode to 
allow you to see a document, even while it is checked out by others.

Use version control to ensure that the right file is the current file
As you make changes to files and check them into the system you 
automatically get a backup copy. The backup file is generated every time 
so you can see your entire history. Review what you changed a day, a week, 
a month, or even a year ago and restore files from any previously saved 
version.

Manage dependencies between files
Dependents are simply other files that the current document links to. You 
can view the dependents, resolve content, and view all dependencies from 
one place to know exactly how your files work together.

http://www.adobe.com/ca/solutions/web-experience-management.html


Find exactly what you need, even across thousands of documents
By using either a basic or advanced search you can specify as much—or as 
little—information as you want to find just the right content across the 
entire repository.

Custom attribute support in Documentum and SharePoint
Configure additional metadata to define every detail you need for your 
content with custom attributes.

Create a CMS connection

TASK

1. Select CMS > Connection Manager.

2. Select a CMS from the Choose Connection dropdown.

3. Configure the Connection Details.

Work with content stored in the repository

TASK

1. Select CMS > Open Repository.
STEP RESULT: The Repository Manage dialog appears.

2. If required, select a Repository.

3. Select a book, file, or ditamap from the repository.

4. Right-click and choose from checking out the file, opening as 
read–only, etc.
ADDITIONAL INFORMATION: This will open the file in FrameMaker.

5. Make edits as needed.

6. Right-click on the file and choose checkin.
ADDITIONAL INFORMATION: You can specify versions, labels, or other metadata.

PDF reviews become even more powerful

FrameMaker allows you to generate PDF for review by SMEs and then later on 
import comments directly from the PDF. Further, the workflow has been 



enhanced in this release so that authors can continue to work with the source 
files (even XML!) while review comments are being made in the PDF.

Enhanced Adobe PDF Review

The enhanced Adobe PDF review workflow lets you perform authoring and 
reviewing tasks at the same time. You can now continue to make modifications 
to your FrameMaker files and then seamlessly import comments from 
reviewers. The comments they will appear exactly where they should, even if 
you have added or changed content in the source.

What are the benefits?

Get things done on time
Continue the authoring and editing process by adding content and 
reordering existing content within documents while waiting for 
comments to come back from reviewers and subject matter experts.

Import comments where they belong
Comment integration is seamless, and notes will be imported into the 
correct paragraph, even if the paragraph location has changed within the 
document. This works for documents created from binary FrameMaker 
or structured and XML content.

Click the image to launch a video. Once playing, right–click for options.

Review while editing source files

Import review comments into the FrameMaker source file as you make edits.






TASK

1. Create a PDF file and provide it to reviewers.
ADDITIONAL INFORMATION: If working with structured XML content, for the review 
comments to be imported correctly when the underlying XML source is 
changed, you have to generate the ids for the elements before generating the 
review PDF. For this we have provided an option under Structure Tools > 
Assign Unique ID to Elements to populate the id attribute for all elements. 
For more information, refer to the documentation.

2. Continue to edit your source files.
ADDITIONAL INFORMATION: For more information on edits, please refer to the 
documentation.

3. After comments have been added to the PDF, import them to 
FrameMaker.

SMEs can review content on a mobile device, and even in the 
cloud

Review content on mobile devices

While FrameMaker makes the review workflow more powerful for authors, it 
also makes it easier than ever for reviewers to make comments on the go.

Use devices such as smartphones or tablets and download the Adobe mobile 
PDF app from http://www.adobe.com/ca/products/reader-mobile.html

What are the benefits?

Faster reviews and updates
Subject matter experts don’t need to be tied to a desk in order to perform 
reviewing tasks—they can now review by adding comments to PDF files 
using sticky notes or by using the typewriter, highlight, underline, and 
strikethrough tools.

http://www.adobe.com/ca/products/reader-mobile.html


Click the image to launch a video. Once playing, right–click for options.

Review PDF on mobile devices

Add comments in PDF files on a mobile device.

TASK

1. Create a PDF file and provide it to reviewers.
ADDITIONAL INFORMATION: If working with structured XML content, for the review 
comments to be imported correctly when the underlying XML source is 
changed, you have to generate the ids for the elements before generating the 
review PDF. For this we have provided an option under Structure Tools > 
Assign Unique ID to Elements to populate the id attribute for all elements. 
For more information, refer to the documentation.

2. Have your SMEs open the PDF and make comments using the Adobe 
mobile PDF app.

3. After comments have been added to the PDF, import them to 
FrameMaker.

Manage content with FrameMaker and Dropbox

Manage content and collaborate on the go by uploading, downloading, or 
synchronizing files from any computer at any time using Dropbox, a 
cloud-based file-hosting service.






What are the benefits?

Collaborate with reviewers who may have limited access
Make it easy to deliver files to reviewers and team members who don’t 
have access to content management systems or specific internal networks.

Access files on the go
Dropbox is a cloud-based service and accessible from any location with an 
Internet connection. Work with content on any machine, at any time, 
from anywhere.

Keep content up-to-date
Dropbox automatically synchronizes and updates files, giving you access 
to content as soon as it becomes available.

Work offline when needed
Dropbox allows files to be downloaded to a local folder for times you need 
to work but aren’t connected to the cloud.

Click the image to launch a video. Once playing, right–click for options.

Download and install the Dropbox application

To work with Dropbox the Dropbox desktop application must be downloaded 
and installed. This provides access to Dropbox directly through a folder on your 
hard drive.

Files in the Dropbox folder automatically sync online and to any other 
computers or mobile devices linked to your account. The application runs in the 
background and automatically keeps your files in sync and backed up online.






You never need to manually upload or download files in your Dropbox 
folder.The desktop application even works when you go offline. The next time 
you're online, Dropbox will sync changes just where it left off.

TASK

1. Go to www.dropbox.com

2. Follow the online instructions to create an account and install the 
required components.

Configure FrameMaker and Dropbox

Ensure that files can be synchronized by setting up the way your tools work 
together.

PREREQUISITE

You must have an account with Dropbox before configuring it to work with 
FrameMaker.

TASK

1. Select Edit > Preference.

2. Under Global select Dropbox

3. Configure the options as required.

Save to repository

Files can be stored on Dropbox by saving files to a synchronized folder.

TASK

1. Select File > Dropbox > Save to Dropbox folder.
ADDITIONAL INFORMATION: Select Save to Dropbox folder with Dependencies 
if the file has links to other content (images and cross-references for example) 
or if saving a book to Dropbox to ensure all related files are also saved to the 
repository.

2. Select the location and complete saving as needed.



Share for review

Share your files for review by linking them via Dropbox.

PREREQUISITE

Files must be opened from a Dropbox location. Select File > Dropbox > Open.

Sharing a link provides access to a specific file. From within Dropbox you can 
also share entire folders.

TASK

1. Select File > Dropbox > Share.
STEP RESULT: The folder that contains the current file opens.

2. Right–click the file to share.
STEP RESULT: A list of options appears.

3. Select Share Dropbox link.
STEP RESULT: The path and file info from Dropbox is copied to the system 
clipboard.

AFTER COMPLETING THIS TASK:

Share the link with others via email or other communications tools.

Open files

Open and modify files hosted on Dropbox without losing any FrameMaker 
functionalities.

Files are stored locally and synchronized with the Dropbox website. This allows 
you to work locally with files and have them automatically synchronize with the 
web-based service.

TASK

1. Select File > Dropbox > Open.

2. Select the file to open.

3. Click Open and work with the file using all the normally available 
features in FrameMaker.

Save files locally and access content offline

Files can be stored on Dropbox by saving files to a synchronized folder.



If you will be offline or disconnected from Dropbox you can save a copy of 
required files to another location.

TASK

1. Select Dropbox > Save locally.
ADDITIONAL INFORMATION: Select Save locally with Dependencies if the file has 
links to other content (images and cross-references for example) or if saving a 
book from Dropbox to ensure all related files are also saved to the local 
location.

2. Select the location and complete saving as needed.



Publish

• Multi–device publishing

• Customize multi–device publishing outputs

• Share settings for multi–device publishing outputs

• DITA Output via the DITA OT

Multi–device publishing

FrameMaker now incorporates multi–device publishing features as part of the 
installation and no other software is needed. Publish content, including 
documents, books, XML files, and DITA maps, to multiple output formats at 
the same time. Gone are the days of buying additional tools to generate 
non-PDF output for FrameMaker content.

What are the benefits?

Powerful out-of-the-box publishing capabilities
Native functionality means you don’t have to purchase or install any 
additional tools just for multi–device publishing.

Generate output for almost any device in the most popular online formats
FrameMaker supports the most common of the online and digital output 
types—Responsive HTML5, ePub, Kindle, WebHelp, and Microsoft 
HTML Help—that make your published content available for use on 
almost any device.



Click the image to launch a video. Once playing, right–click for options.

Publish content to one output

Use the Publish feature to generate a single output.

TASK

1. Select File > Publish.
STEP RESULT: The Publish pod appears.

2. If required, click the Gear icon and change publish settings.

3. Select an output type.

4. Click  (Generate Selected Output).

Publish content to multiple outputs

Use the Publish feature to generate multiple outputs at once.

TASK

1. Select File > Publish.
STEP RESULT: The Publish pod appears.

2. If required, click the Gear icon and change publish settings.

3. Click  (Generate Multiple Outputs).






Customize multi–device publishing outputs

Let your output match the source. or use settings files to completely redefine the 
publishing to use a new look and feel. You can customize how your content 
looks in different outputs. Use settings files that contain style mappings for 
paragraphs, character, tables, figures, cross-references, and set up each output 
type with unique titles, cover pages, and other custom configurations.

What are the benefits?

Change text, images, and other source content to best suit online delivery
Develop specific settings using the easy-to-understand visual editor and 
customize paragraph, character, table, and image styles. Rework 
cross-references to drop page numbers, or resize images.

Configure each output format with a unique appearance
Ensure that each type of output is configured the way it needs to be by 
defining metadata such as title and file information. Configure search 
settings, keywords, and even entire layouts based on output type.

Click the image to launch a video. Once playing, right–click for options.

Edit current settings values

Configure default settings to customize the appearance of your outputs.

PREREQUISITE

The Publish pod must be open.






TASK

1. Click Change Settings.

2. Select Edit Settings.

3. Under Style Mapping modify settings for content.
ADDITIONAL INFORMATION: This includes updates to paragraph, character, table, 
cross-reference, image, and other settings.



4. Under Outputs modify settings for supported output formats.
ADDITIONAL INFORMATION: This includes any setup for the Responsive HTML5, 
WebHelp, ePub, Kindle, and Microsoft HTML outputs.

AFTER COMPLETING THIS TASK:

Once values are set either Save to override the current values in the selected 
settings file, or click Save As to create a new settings file.

Share settings for multi–device publishing outputs

After settings have been created, save and share them with other users to publish 
and ensure a consistent look and feel across multiple output types.

What are the benefits?

Ensure output consistency
Design and share settings files to ensure consistency in documentation 
formats used by multiple content creators within your organization.



No need for each author to reset formats
Let writers and reviewers focus on content. The development of the look 
and feel of output can be left to others and a shared settings file applied at 
the time of publishing.

Click the image to launch a video. Once playing, right–click for options.

Load shared settings

Load and apply a settings file to your FrameMaker documents.

PREREQUISITE

You must know where a settings file can be located.

The Publish pod must be open.

TASK

1. Click Change Settings.

2. Select Browse Settings.

3. Select a file to load.

4. Click Open.






DITA Output via the DITA OT

Publish DITA content to multiple output formats without having to install the 
DITA Open Toolkit—DITA-OT is now included and supported 
out-of-the-box.

For more information about DITA-OT visit the Organization for the 
Advancement of Structured Information Standards (OASIS) website at 
https://www.oasis-open.org/committees/tc_home.php?wg_abbrev=dita. 
OASIS maintains the DITA specification.

What are the benefits?

No need to manually install and configure the DITA-OT
The DITA-OT feature now allows you to publish your DITA content 
out-of-the-box—the DITA Open Toolkit is installed as part of your 
FrameMaker 12 environment.

Support for a a wide range of publishing outputs
Seamlessly publish content in various formats, including HTML, 
Microsoft HTML Help (.CHM), and Java™ Help from any DITA topic or 
map.

Take advantage of all that the DITA-OT has to offer
You can configure additional outputs beyond the defaults by setting up 
the DITA Open Toolkit.

Click the image to launch a video. Once playing, right–click for options.






Publish using the DITA-OT

It is easy to publish several different output types from DITA content.

PREREQUISITE

A DITA topic or map must be open.

TASK

1. Select DITA > Generate DITA-OT Output.

2. Choose an output type.

3. Specify any options.

4. Click Build.



XML/DITA Authoring and Review

• Explore the new Adobe FrameMaker XML Author

• MathML Support

• Easily Preview and update DITA Maps

• Author faster using the Quick Element Toolbar

• Enhanced whitespace handling

Explore the new Adobe FrameMaker XML Author

As part of this release, we are bringing you a brand-new XML authoring 
solution! FrameMaker XML Author is a fully standards-compliant XML editor. 
You can quickly create XML content based on a standard such as DITA or any 
custom structure with the easy-to-use and familiar FrameMaker interface. 
FrameMaker XML Author has the same support for standards like DITA that 
the regular FrameMaker product has, and it has been enhanced even more in 
this release.

From the complete FrameMaker feature set, FrameMaker XML Author takes a 
large set of features to enable XML authoring. In this regard, it excludes features 
that are not required by an XML author. For example, FrameMaker XML 
Author does not include the functionality to create and work with unstructured 
FrameMaker documents. However, it does include all the features that are 
needed by XML authors, including the ability to work seamlessly across all the 
3 views i.e. WYSIWYG, Author, and XML Code views.

With the new FrameMaker XML Author product, XML authors will get the 
right product, which is tailored to meet their specific needs. All of this comes at 
a much more affordable price than the FrameMaker product. Furthermore, the 
product is simplified with the reduced, but the right feature set. Also, it will 
work seamlessly with the FrameMaker product, since the content created with 
FrameMaker XML Author will be fully standards-compliant XML and can be 



consumed by FrameMaker for various tasks such as multi-device publishing.

Learn more at http://www.adobe.com/products/framemakerxmlauthor.html

Use the Adobe FrameMaker XML Author interface

There are two ways of using FM XML Author. You can purchase it as a separate 
product, install and use it, just like you use FrameMaker. Alternatively,  you can 
run it as a mode within the FrameMaker product.

The Adobe FrameMaker installation allows you to change the mode and work 
in the same environment that is provided with the new Adobe FrameMaker 
XML Author software. This allows you to mimic the work environment, test 
settings, and develop content in the same way that other users might work. You 
can ensure that all your instructions to users, templates, or other features work 
as you expect before making them available to contributors, reviewers, or even 
authors who use the new software.

TASK

1. Select Edit > Preferences.

2. Under Global > General, select FrameMaker XML Author.

MathML Support

FrameMaker now offers seamless integration with MathML using MathFlow® 
Editor from Design Science (http://www.dessci.com/en/products/mathflow/).

MathML facilitates the dynamic use and re-use of mathematical and scientific 
content within documentation, and a one month trial for both MathFlow Style 

http://www.adobe.com/products/framemakerxmlauthor.html


and MathFlow Structure are included with your purchase of Adobe 
FrameMaker. For more information about the MathML standard, visit 
http://www.w3.org/Math/

What are the benefits?

Seamless workflow between FrameMaker and MathFlow
Out-of-the-box integration means you can start using MathFlow 
immediately to build complex equations. Open the MathML editor in 
FrameMaker and use the convenient toolbar to start creating.

Develop and edit using the interface best suited to your workflow
Use the MathFlow editor that suits your needs. Free 30-day trials for Style 
MathFlow and Structure MathFlow are included with FrameMaker. With 
either product, choose to create and edit your equations in XML source 
view or WYSIWYG view.

Publish your equations to multiple outputs
FrameMaker imports your equations as images and saves the MathML 
source code in the document XML file. When you publish, convert your 
content, including your equations, to ePub, Kindle, WebHelp, Microsoft 
HTML Help, or Responsive HTML5 output.

FrameMaker and MathML

Click the image to launch a video. Once playing, right–click for options.






Structured FrameMaker and MathML

Click the image to launch a video. Once playing, right–click for options.

Create a MathML equation

Create MathML equations by typing, using toolbar icons, or a combination of 
both.

TASK

1. Select the location to insert a MathML equation.

2. Select Special > MathML Equation.
STEP RESULT: The MathFlow Structure Editor appears.

3. Create the equation using the Design View or the Source View.

Create a MathML equation with DITA

MathML content can also be created within the DITA environment.

TASK

1. Select File > New > XML.

2. Under Structured Applications select the DITA 1.2 MathML Sample.

3. Select the location to insert a MathML equation.

4. Select Special > MathML Equation.
STEP RESULT: The MathFlow Structure Editor appears.






5. Create the equation using the Design View or the Source View.
ADDITIONAL INFORMATION: A MathML supported DITA 1.2 template is provided as 
a starting point.

Set MathML preferences

Default editors and configuration can be specified.

TASK

1. Select Edit > Preferences.

2. Select MathML.

3. Configure the preferences.

Edit a MathML equation

Modify MathML equations within the Design View or the Source View.

TASK

1. Double-click the equation to edit.
STEP RESULT: The MathFlow Structure Editor appears.

2. Modify the equation using the Design View or the Source View.

Format a MathML equation

Format properties of MathML equations inside of unstructured FrameMaker as 
required.

TASK

1. Select the equation to format.

2. Select Graphics > Object Properties.

3. Modify the DPI, Compose DPI, and Font Size as needed.



Format a MathML equation in XML view

Format properties of MathML equations inside of a structured XML document 
as required.

PREREQUISITE

The equation must be in a structured XML document that supports MathML 
and the document must be open in Code View.

TASK

1. Find the mathml element.

It may appear similar to <mathml composedpi="300" 
fontsize="14">.

2. Modify the composedpi and fontsize attributes.

Easily Preview and update DITA Maps

Instantly expand DITA maps to preview all content inside topicref elements and 
make updates and modifications directly within the DITA map.

What are the benefits?

Use the preview to see what is in a topic without having to open it first
Quickly access and preview DITA maps inside of FrameMaker by 
resolving one or more topicref elements to show the content inside.

Easily modify and update DITA topics
Simply double-click to open topics for modification and edits within 
FrameMaker.



Click the image to launch a video. Once playing, right–click for options.

Expand or collapse DITA map topicref elements

Resolve topicref elements within a map, preview the content inside the topicref 
element, and easily hide the content when done.

PREREQUISITE

A DITA map must be open and displayed in Document View.

TASK

1. Select a topicref.
• To select a single topicref element click on the topicref.

• To select all the topicref elements either click anywhere except on a 
specific topicref or press Ctrl+a.

2. Select DITA > Resolve Topicref(s) > Show Content.
ADDITIONAL INFORMATION: Use Hide Content to collapse selected topicref 
elements. You can also right-click a topicref element to access these options.

Open and update a topicref

Modify and update DITA map topicref elements inside of Document View.

PREREQUISITE

A topicref must be expanded in a map, within the Document View.

TASK

1. Double click a topicref.






2. Modify content in the topic and save it.

3. In the DITA map select DITA > Update References.

Author faster using the Quick Element Toolbar

The DITA-configured Quick Element Toolbar lets you immediately start 
inserting elements, or wrapping content into valid XML elements without 
knowing tag names. Authors can also build their own toolbar to use with any 
customizable XML.

What are the benefits?

Structure content even when you don’t know all the syntax
Authors and subject matter experts unfamiliar with DITA can get started 
immediately—the toolbar makes it easy to insert content correctly the first 
time.

Get it right—every time
Easily insert elements, even if you don’t remember every detail. The 
toolbar only displays elements that work where you’ve chosen to place 
them, ensuring you create great documents every time.

Build your own toolbar
Create and customize your own toolbar to work specifically for your 
application.

Click the image to launch a video. Once playing, right–click for options.






Display the toolbar

View and use the Quick Element Toolbar to insert common elements.

TASK

1. Select View > Toolbars > Quick Element Toolbar.

Insert elements using the toolbar

TASK

1. Select the location to add an element.
ADDITIONAL INFORMATION: To wrap content in an element, first select the 
content.

2. Click the associated icon on the toolbar.

Enhanced whitespace handling

XML whitespace handling has been updated to be compliant with XML 
standards making for a completely standards-compliant XML editing 
environment that feels less cluttered and has faster performance.

The following enhancements have been made:

• The xml:space setting is honored when the user does pretty printing e.g. 
FM12 won’t pretty print <codeblock> element xml:space to be preserved, 
unlike FM11

• XML files, created with other XML editors and which use spaces for pretty 
printing, will not have whitespaces showing

• Improved handling of those elements, where spaces are to be preserved — 
for example, content within the <codeblock> element in DITA

• no extra line feeds at the start and end of the the <codeblock> element.

• if there is a linefeed at the beginning of the <codeblock> element it is 
preserved

• an inline element at end of line within the <codeblock> element now does 
not drop the linefeed

• open, edit, and save a DITA file with the <codeblock> element containing 
leading spaces and spaces are retained.



• pretty printing for a new XML or modified XML file is of by default.

Standard Code Treated as

Any sequence immediately before and after 
opening or closing tags is ignored.

<p> Content  </p> Content

Non-space characters (tabs and new-line) and 
multiple spaces are consolidated to a single 
space.

<p>2 tabs  5 spaces end</p> 2 tabs 5 spaces end

You can allow for whitespace to be preserved 
using the xml:space attribute and setting it to 
preserve.

<p xml:space="preserve">5 spaces word</p> 5 spaces word

White spaces occurring between two elements 
are ignored, if the element has only element 
content. If the element has mixed content, such 
white space is treated according to the first two 
rules.

<ol> <li> first item </li> </ol> 1) first item



ADDITIONAL LINKS

Additional links

More information on the full Adobe Technical Communication Suite and the 
tools it provides can be found online.

Reviewer’s Guides

• Adobe Technical Communication Suite 5 Reviewer’s Guide

• Adobe FrameMaker 12 Reviewer’s Guide

• Adobe FrameMaker XML Author 12 Reviewer’s Guide

• Adobe FrameMaker Publishing Server 12 Reviewer’s Guide

• Adobe RoboHelp 11 Reviewer’s Guide

Product home pages

• Adobe Technical Communications homepage

• Adobe FrameMaker homepage

• Adobe FrameMaker XML Author homepage

• Adobe FrameMaker Publishing Server homepage

• Adobe RoboHelp homepage

Social and other media

• Adobe TV

• YouTube

• Twitter

• Facebook

• TechComm Central (Blog)

• Upcoming LIVE eSeminars

http://wwwimages.adobe.com/www.adobe.com/content/dam/Adobe/en/products/technicalcommunicationsuite/techcomsuite-5/pdf/TCS5_GETTING_STARTED_GUIDE.PDF 
http://wwwimages.adobe.com/www.adobe.com/content/dam/Adobe/en/products/framemaker/pdf/FRAMEMAKER12_REVIEWERS_GUIDE.PDF 
http://wwwimages.adobe.com/www.adobe.com/content/dam/Adobe/en/products/framemakerxmlauthor/Pdf/FRAMEMAKERXMLAUTHOR12_GETTING_STARTED_GUIDE.PDF 
http://wwwimages.adobe.com/www.adobe.com/content/dam/Adobe/en/products/robohelp/robohelp-11/PDF/RoboHelp11_GETTING_STARTED_Guide.pdf 
http://wwwimages.adobe.com/www.adobe.com/content/dam/Adobe/en/products/framemakerpublishingserver/fmps12/PDFs/FMPS_12_Getting_Started_Guide.pdf 
http://www.adobe.com/ca/products/framemaker.html
http://www.adobe.com/ca/products/robohelp.html
http://www.adobe.com/ca/products/technicalcommunicationsuite.html
http://www.adobe.com/products/framemakerxmlauthor.html
www.adobe.com/products/framemakerpublishingserver.html
http://tv.adobe.com/channel/technical-communication
http://www.youtube.com/user/AdobeTCS
https://twitter.com/AdobeTCS
http://www.adobe.com/cfusion/event/index.cfm?event=list&loc=en_us&type=eseminar&product=Technical+Communication+Suite&interest=&audience=&monthyear= 
https://www.facebook.com/adobetcs
http://blogs.adobe.com/techcomm/
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