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Working environment

Overview

The FrameMaker working environment is not as 
modern as that of office applications, but provides 
all you need for your work.

Customisation is possible, but not to the extent of 
other Windows applications, because FM keeps con-
sistency between platforms.

There are numerous add-ons (Application Program-
ming Interface clients) from third party vendors, be-
cause FM concentrates ‘on the core business’ of the 
application.

FrameMaker 7 combines two products. Hence you 
need to decide at first start - or later - which inter-
face to use.

Contents

Working environment ..............................................  2

Help and documentation .........................................  6

Elements of the work space .....................................  8

Extensions by API clients .......................................  15

Structured documents ...........................................  16
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Working environment

Starting FrameMaker in standard mode

Beginning with FrameMaker 7 two interfaces are available:

Standard (unstructured) 

Structured (with SGML techniques)

To check the current interface, select File > Preferences > 
General and look at the bottom of the dialouge. If „Structured 
FrameMaker« is listed in the drop down list Product Inter-
face, 

1 Select FrameMaker in the drop down list.

2 Close FrameMaker and start again.

FrameMaker works pace

The FrameMaker window contains both fix areas and items 
the visibility of which can be toggled on and off (*):

Plug-ins may install additional items in the menu bar, such as 
‘FrameScript’ displayed here.

Toggle visibility of the button bar (2) and Quick Formatting 
Bar (3, 4) with menu View > Quick Access Bar and > Format-
ting Bar.

Indication of modified
formats

The status area (6) displays information from the current 
selection or cursor location: flow, paragraph format and char-
acter format. An asterisk (*) preceding a format name indi-
cates local overrides (change relative to the information in the 
catalogues).

Indication of changes The page information (4) displays the current page number 
and total number of pages. An asterisk appears after the sec-
ond number if changes to the saved version have been 
applied. After saving the * disappears and the diskette icon in 
the left area of (2) is greyed out.

Change zoom factor Change the zoom factor to the next lower value with the z 
button and to the next larger value with the Z button.

9

4
2

1

5

76
8

3

1 Menu bar

2 Button bar with 4 ‘pages’

3 Quick Formatting Bar

4 Drop down list paragraph 
catalogue

5 Buttons for floating pal-
ettes

6 Status area

7 Page number area

8 Zoom buttons

9 Open palette Paragraph 
catalogue
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Non printing items in 
display area

Toggle visibility of the following items with View > xxx.

Borders are associated with the cell borders of tables, text 
frames, graphic frames and anchored frames. 

Text Symbolsindicate end-of-paragraph and other situations. 
See Control characters in the text on page 1-13.

Rulers are not that helpful in FrameMaker, because they 
align with the paper edge, not the text edge.

Grid Lines  align to the top left corner of their container. With 
nested frames you may see different areas.

Some discipline required...

Only one UnDo level in FrameMaker until version 7.1!

Avoid direct formatting („MS Word style« rather than using 
styles) in ‘real’ documents — use only in memos, letters 
etc. with short lifetime. (deactivate View > Formatting 
bar).

Have a list of short-cuts for your most used commands 
ready (see Short-cuts on page A-2)

Preferences

In FrameMaker preferences are „levelled«: Some are global to 
the FrameMaker installation, others are valid throughout a 
session and many are set in a document.

Preferences for the 
current FrameMaker 
session

Set the program preferences with File > Preferences > Gen-
eral:

Set Automatic Backup on Save if you want to keep a copy 
of the original state of the documents (before you started 
editing them).

Automatic Save every (10) Minutes is a good insurance 
against system crashes. FrameMaker saves very fast! Frame-
Maker is very stable – this feature is rarely needed.

Since FM 7.2 the warnings about clearing the Undo History 
can be specified.

Show file translation errors will display found errors 
when opening files (e.g. from other platforms).

Greek Screen Text displays text smaller than the given 
size as gray box to save processing time.

Cross-Platform File Naming must select the ‘least com-
mon denominator’ among the platforms for which the files 
are uses (Windows 3.x  Unix  Mac  Windows 95).

Save FrameImage with Imported Graphic saves a special 
vector form of the graphic with the document. This speeds 
up the display of imported graphics, because the filter is 
only activated for modified source files.
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Network File Locking is a must for files residing on a LAN. 
Otherwise the file can be opened independently.

Remember Missing Font Names is a must for cross-plat-
form working if not all fonts are available on all platforms.

Preferences for the 
current document

With Format > Document... > Text options you set properties 
of the current document:

Smart quotes translates ordinary quotes ("a", ’a’) during 
keyboard input to typographic quotes («a», ‘a’). These 
forms depend on the UI language and can only be set in 
maker.ini. Hence they are actually pertinent to the Frame-
Maker installation. See Smart quotes on page A-36.

Smart Spaces reduce multiple spaces ( ) during key-
board input to at most one space to keep the text neat.

Allow Line Breaks After special symbols allow automatic 
hyphenation of words containing these special characters. 
Some characters require special notation (see Control char-
acters in the text on page 13).

You may wish to set special properties for Superscript, 
Subscript and Small Caps (German: Kapitälchen).

Note: For a more complete list of document properties see Document 
Properties on page 3-13.

Installation specific 
settings

Depending on the platform general preferences can be set. On 
Windows this is performed in maker.ini file located in the 
home-directory of FrameMaker. See Modifications to maker.ini 
on page A-37 for recommended changes.

File locations (e.g. dictionaries)

Font mapping

Pen widths, dash patterns

Smart quote characters

Program inherent 
defaults

There are a number of defaults, which (to my knowledge) can 
not be set explicitly:

Type and placement of anchored frame when inserting an 
image, including the margin to the image.

The number of default page sizes and their properties (e.g. 
margins).

Navigate the document

Go to specific page Click into the page number area. In the dialogue Go to 
Page enter the desired page number and Go!

You may want to jump back to the page where you have 
left the cursor in the text: select the appropriate option 
button.

To go back to where you jumped from enter ESC, v, P (Eng-
lish FM).
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Set view options The method of displaying pages (facing, horizontal scroll etc.) 
is a property of the document. Set this option with View > 
Options... according to your needs. 

Setting Variable provides a good automatism: for small 
enough zoom factors pages are arranged in blocks. If two 
pages fit into the display area, they are facing.

Set units of measure You may also wish to set the units of measure. These are 
defaults for entering values in various dialogues, for example 
the Paragraph Dishonour or the Table Designer.

Modify list of zoom 
factors

The list of zoom factors can be set for the current session: 
click on the drop down list and select Set...

In dialogue Zoom Menu Options set the values to your 
desire. Default settings are taken from the frame.ini file (in 
Windows). The value range is 25... 1600%.

You may modify the list of default values in the maker.ini 
file. See Zoom factors on page A-36.

Customising Framemaker

Due to its platform concept, FrameMaker does not exploit the 
GUIs to their limits. Hence customisation is not a task for the 
end-user, but for programming experts. Customisable are:

The menus and their contents, the tool bars (see Modified 
tool bars on page 1-15)

The size of the default page (which is the really empty one)

Minimum styles (paragraph, character, table) for new docu-
ments are located in a special template.

Sample templates

FrameMaker comes with a number of sample templates

Report, Book, Letter, Resumee and Conditional Text.

In the English version layout is based on the 8.5» x 11» 
paper (called Letter).

To use a sample template File > New > Document…

Use button Explore Standard Templates.

From the appearing list select a template

To create an empty document from the template, press 
Create

To display a sample layout, press Show Sample

Close the last FrameMaker instance (Standard Templates), 
which you do not need any more.
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Help and documentation

International versus US FrameMaker

At the installation of FrameMaker you are asked whether to 
install the US version or the International English version. The 
differences are:

For working with the Internation English version it is good 
practice to set the default language appropriately. See Default 
language in ¶ and f designer on page A-37.

FrameMaker Help

Version 6 of Framemaker introduced the platform dependent 
help system. Version 7 provides HTML help files which are 
opened in your default browser:

The help system includes all of the information in the 
Adobe FrameMaker 7.0 User Guide plus keyboard short-cuts, 
full-colour illustrations, and more detailed information 
about some procedures.

General search function via JavaScript (hence the browser 
must be enabled for JavaScript).

Font size depends on a style sheet - hence can be adapted.

To have help adjacent to your document, reduce the win-
dow size of FrameMaker and the browser.

Documentation

Adobe documentation Same manual for all platforms and for both user interfaces.

Quick Reference Card

Online-manuals for special themes. These are no more ref-
erenced in the Help menu. They are located in the $FMHOME/
OnlineManuals directory. 1)

Third party 
documentation

Jürgen Gulbins, Angelika Obermayr, Karl Obermayr: Desk-
top Publishing mit FrameMaker [4. EFL. Springer 2002], 
ISBN 3-540-44216-2. www.framebuch.de
Das buch wendet sich an anwender von Mac OS, Unix und Win-
dows. Es bietet eine grundlage für die arbeit mit FrameMaker 
und gibt tips und hinweise aus der praxis. Es vermittelt grundla-
gen zur typographie, zum einsatz und druck von farbe, zur 

US-version Internationl English

Languae of User interface US-english (color, not colour)

Paper size of templates Letter A4

Language in ¶ formats of 
predefined templates

US English UK English

1 $FMHOME is the symbolic name for the installation directory of Frame-
Maker. This may be, for example, H:\adobe\FrameMaker.7en
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online-zusammenarbeit mit WebDAV, sowie zur ausgabe mit 
PDF, HTML und XML.

Ute Mitschke und Bernhard Schulze: FrameMaker 6+7; In 
der Praxis anwenden und beherrschen; mit CD-ROM; bro-
schiert - 560 seiten [Addison-Wesley 2002] 
ISBN 3-8273-1736-3.
Das buch zielt gerade auch auf professionelle anwender und 
deckt neben satz/layout und der erstellung von dokumentvorla-
gen auch den bereich databased publishing/cross media sowie 
den plattformunabhängigen datenaustausch mit SGML/XML 
ab.

Sarah S. O‘Keefe and Sheila A. Losing: FrameMaker 7, The 
complete Reference; [Mc Graw Hill Osborne 2002, ISBN 0-
07-222361-8 (about 850 pages).
The authoritative resource on FrameMaker 7. Master the myr-
iad features and complex interface of FrameMaker 7, and 
implement complex multichannel publishing solutions. This 
book helps you understand and master FM’s many features to 
increase your productivity and improve your published docu-
ments. Learn to create and manipulate text, control page lay-
out, and construct books – plus advanced techniques including 
hypertext, modular text, and working with XML, SGML, DTDs, 
and element definition documents.

Klaus Krüger: Adobe FrameMaker 7, Standard Modus und 
Struktur-Modus; [2. aufl. www.buchstabenkabinett.de 
2002], broschiert, 268 seiten A4. ISBN 3-936485-01-1.
Auser mit tips für einsteiger befasst sich das buch mit 
FrameMaker im standard- und strukturmodus. Schwerpunkte 
sind u. a. kapitel und abschnitte numerieren, verzeichnisse 
generieren, querverweise aktualisieren, veriablen und 
merhseitiger tabellensatz. Die erklärungen für struktur-modus 
richten sich an anwender, die mit vorgegebenen struktur-regeln 
arbeiten. 20 mindmaps in farbe.

… and many more, see for example, www.books.ch or 
www.amazon.com with the keyword framemaker. However, 
from the abobe mentioned books Klaus Daube knows the 
authors personally.

Mailing lists

US-mailing list Send Framers mailing list submissions to

framers@lists.frameusers.com

To subscribe or unsubscribe via the World Wide Web, visit

http://lists.frameusers.com/mailman/listinfo/framers 

or, via email, send a message with subject or body 'help' to

framers-request@lists.frameusers.com

You can reach the person managing the list at

framers-owner@lists.frameusers.com

German mailing list Webform for enrolment:

http://tipps.frame-user.de/seiten/maillisten/frame-
talk-form.mgi

http://www.books.ch/
http://www.amazon.com/
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Elements of the work space

Palettes and catalogues

Tool palette The Tool palette is located to the top right of a document win-
dow.

If the ¶ and the f buttons are missing, but others are visible, 
FrameMaker is run in structured mode. To switch to standard 
mode, see Starting FrameMaker in standard mode on page 1-2.

Catalogues Display the paragraph catalogue with Format > Paragraphs > 
Catalog or clicking on the appropriate button in the tool pal-
ette.

Display the character catalogue with Format > Characters > 
Catalog or clicking on the appropriate button in the tool pal-
ette.

The table catalogue is displayed with Table > Table 
Designer… and then opening the tab Basic and pulling down 
the list Table Tag.

Other catalogues are visible only via special functions, e.g.:

Colour View > Color > Definitions and in the Tools Palette

Cross-refsSpecial > Cross-Reference… Format

Table-rulesTable > Custom Ruling Shading > Edit Ruling Style

Variables Special > Variable…

Display the Paragraph catalog (see Catalogues on page 1-8)

Display the Character catalog (see Catalogues on page 1-8)

Display the Graphics Tool palette (see Graphic objects on 
page 1-12)
Display Formula Palette (Palette overview on page 11-5)

Display the History Palette (present since FM 7.2). See Com-
mand History palette on page 14

Paragraph catalogue Character catalogue Table catalog

History Palette (since FM 7.2)
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Quick access bar (tool bar)

Common commands and 
Quick Formatting Bar

Since FM 7.2 the basic tool bar includes Redo, Import File, 
Object Properties, Toggle View Only, Insert Symbols and First 
Page, Last page as well as Find Next.

Edit text

Graphic commands

Edit graphics

Edit tables

On the Macintosh the Quick Formatting 
Bar belongs to the document window - not 
to the main FrameMaker window.
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Menus and palettes

Document menus

While in book

New since FM 7.2}
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Book menus
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Graphic objects

Graphic objects are defined and inserted with the tools pal-
ette. this palette opens from the Triangle button to the right 
of the FrameMaker main window

Appearance of check boxes

Various dialogues provide check boxes, which display 3 
states:

The «As Is» state occurs, if some of the selected items have 
set properties and some have not set (cleared) properties.

Intelligent cursor (depending on object)

Line

Rectangle

Open polygon

Closed polygon

Create text frame

Create graphic frame

Define area fill colour

Define line fill colour

Define line width

Define line-end type

Define line type

Define colour

Define tint

Define overprint type

Cursor for graphic objects

Arc (circle, ellipse)

Rectangle with rounded corners

Circle, ellipse

Freehand-line, spline

One-line text

Apply area fill colour

Apply line fill colour

Apply line width

Apply line-end type

Apply line type

Apply colour

Apply tint

Apply overprint type

checked
(active)

unchecked
(inactive)

As Is
(may be)

Windows

Mac

UNIX Solaris KDE
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Control characters in the text

Display of these symbols is controlled by View > Text Sym-
bols. These symbols do not appear on output or in files.

The special symbols have no width (exception: the non-break-
ing space) and you may need special techniques to handle 
them. See Non-width characters on page A-17).

For searching/replacing special characters see Special charac-
ters in dialogue boxes on page A-3. Structured FrameMaker 
uses additional symbols.

Note: In this document text symbols are displayed with a special font, 
if they are needed to understand the situation.

§ End of text flow / end of table 
cell

This symbol can not be deleted.

¶ End of paragraph (‚contains‘ 
the style definition)

Pressing Enter or Return terminates a 
paragraph and ‘opens’ a new one.

 Tabulation symbol See details at Tabulation on page 2-4

 New line (hard return) Press SHIFT+Return for hard return

 Non-breaking space Press CTRL+space for this symbol

 Optional hyphen Indicates a location at which a word can 
be hyphenated if necessary

 Suppress automatic hyphena-
tion

Place this symbol at the beginning of a 
word for better clarity

 Marker (index, cross refer-
ence,...)

Place markers preferably at the begin-
ning of a paragraph. Do not spread them 
in words.

 Anchor (table, frame) Place anchors preferably at the end of a 
paragraph

I Formula aligned manually See Align formulas on page 11-6

Table 1: Control characters in the text
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Multiple Undo and Redo

Version 7.2 brings this new feature. If there is no action avail-
able for Undo or Redo in the current document, the corre-
sponding menu items and tool bar buttons are greyed.

The command history is available through the Edit menu and 
context menus. The command history is kept separately for 
each document.

Saving a document (with Save, Save As, or autosave) clears 
both the undo and redo history for that document. Generally, 
commands that do not change the content, such as copying 
text, cannot be undone and do not affect the command his-
tory.

As in previous releases, cursor movement and object selec-
tion actions are not undoable, but when a previous state is 
restored, it includes the original cursor location and object 
selection state.

Commands that affect an external file (such as Spell Checker 
commands that update the user dictionary) are not undoable.

Command History palette This palette allows you to select a specific action to undo or 
redo. The command history is shown only for the active docu-
ment.

In the command History palette, the most recent command is 
highlighted. Commands listed above the most recent are 
undoable. Commands listed below the most recent are redoa-
ble, and are marked with an asterisk (*).

You can undo and redo actions only in the order in which 
they were originally performed. When you select a command 
to undo, all later commands (which have been affected by the 
selected action) are also undone. FrameMaker also moves the 
selected command and all succeeding commands to the Redo 
list. Similarly, redoing a command moves it and later com-
mands back to the Undo list.

For a complete list of commands that can and cannot be 
undone see file FM72_UserGuideSupplement.pdf.
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Extensions by API clients
API clients add to the functions of FrameMaker and integrate 
themselves into the menus. Some book function are now 
superseded by FM version 7.

The following lists a few of the plug-ins. For an updated list 
see www.frame-user.de/seiten/zubehoer/plugins.html.

Another list can be found at www.frame-user.de/
_frameloads/tools-infos-zubehoer/Top100-FMAPI.pdf.

Please be aware that it is difficult to maintain the web-refer-
ences and keep the links intact.

End-notes Collected footnotes at end of book):
The Endnotes client application creates functionality similar 
to footnotes except that these notes occur at the end of a doc-
ument or book instead of at the bottom of the page. In addi-
tion, there is functionality to provide notes at the end of a 
FrameMaker book, in a separate generated document ("loe" — 
List of Endnotes).
www.frametools.com/frametools_by_fml.htm.

Import/export filters According to many source the best import/export filters are 
from www.blueberry.com/mif.htm:
The latest version of Filtrix converts Word 97 files to MIF. For 
maximum speed and minimum file size, we work with native 
Word 97 format, not RTF. Filtrix exports/imports MIF to Word 
2, 6, and 7 native format.)

Index tools Silicon Prairie Software:www.kagi.com/spsoftware/

Outline display Outline display of document similar to the capabilities of 
FrameMaker + SGML: www.sandybrook.com

RTF and HTML from MIF Export of FM (MIF) to Word RTF, HTML and winhelp with 
mif2go by www.omsys.com

Style management,
special character

palette

Systec tool box: www.systec-gmbh.com/toolbox

Script (macro) language The full featured macro language FrameScript has access to 
all FM command: www.framescript.com

Extensive script
collection

Rick Quatro provides FrameScripts for many tasks. Very good 
scrips (also free ones) are from itl in Munic. Especially the 
InstallScriptsInFolder is an essential tool to manage scripts.

Modified tool bars www.microtype.com provides a tool bar with many functional 
additions (for displays of 1024 pixel width).

For example, the Quick Formatting Bar is extended by drop 
down lists for Character Catalogue and Font. The standard 
button bar is ‘folded’ into two long items, easing the access 
significantly. 

Database of plug-ins A nearly complete database about FrameMaker (and Word) 
extensions can be found at leximation.com

http://www.frame-user.de/seiten/zubehoer/plugins.html
http://www.frame-user.de/_frameloads/tools-infos-zubehoer/Top100-FMAPI.pdf
http://www.frame-user.de/_frameloads/tools-infos-zubehoer/Top100-FMAPI.pdf
http://www.frametools.com/frametools_by_fml.htm
http://www.blueberry.com/mif.htm
http://www.kagi.com/spsoftware/
http://www.sandybrook.com
http://www.omsys.com
http://www.systec-gmbh.com/toolbox/
http://www.framescript.com/
http://www.frameexpert.com/
http://www.microtype.com/
http://www.itl.eu/108.0.html?&L=0
http://www.leximation.com/toolsearch/
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Structured documents

Open structured document in standard FrameMaker

When opening a structured document in unstructured mode, 
you are warned with a Document is Structured message.

You may view the document with no further consequences.

If you choose to Open for Editing, any structure informa-
tion is lost in the document.

You may, however, Cancel the opening, switch FrameMaker 
into structured mode (seeStarting FrameMaker in standard 
mode on page 1-2) and edit the file correctly.

Undo is not supported for structured books (FM 7.2)



Text handling

Overview

FrameMaker provides good capabilities to handle 
text. Due to its intended use of formatting large 
documents, some functions go beyond what is 
known from text processing packages.

Hyphenation dictionaries can be set up for a docu-
ment or a complete project. In addition, each docu-
ment can contain a local dictionary.

Contents

Text handling .........................................................  2

Find and change .....................................................  6

Hyphenation and spell checking ..............................  8



Text handling

2 – 2

Text handling

Typing text

FrameMaker versions up to version 7.2 can handle text of the 
latin script with a rich set of accented charaacters. Due to the 
limitations of an 8-bit code the number of distinct characters 
is not sufficient even for the European languages. In particu-
lar support of the Eastern European languages (in US parlance 
Central Europe) is lacking. But even for the Northern Euro-
pean languages some characters are missing.

Entering text of characters which are supported but not avail-
able on your keyboard requires special methods. See Keyboard 
input on page 2 ff.

Supported languages

Dictionaries for hyphenation and spell checking are available 
for the following languages:

Using the technique of virtual fonts (for example, Arial CE) it 
is possible to handle Polish and other Eastern European lan-
guages. With some more effort even languages with the 
cyrillic alphabet can be processed. More details can be found 
at itl.eu (search for One World Publishing).

Text manipulation

Move text around There is no drag-and-drop funtion in FrameMaker. To move 
text use cut and paste instead. 

Selecting text The same methods as in other text processing software are 
used in FrameMaker.

Select a word Double click on the word or drag the mouse across the 
word.

Language Variants supported

English UK, US

Deutsch Deutschland, alte und neue Rechtschreibung;
Schweiz, alte und neue Rechtschreibung

Fran4ais France, Canada

Espaniol Spain, Catalá

Italiano Italia

Portugès Portugal, Brasil

Dansk Denmark

Nederlands Netherlands, nieuv

Norsk Norwegian, Nynorsk

Suomi Finland

Svenska Sweden

Chinese a

a. This requires a ‘Chinese’ operating system.

Korean, Japanese, Traditional Chinese, Simplified Chinese

http://www.itl.eu
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Note: There is no means to select a word including its trailing blank. 
You need to use the mouse or SHIFT+ARROW to extend the 
selection.

Select an arbitrary text
string

Place the cursor in front of the first character to be 
selected, and hold the SHIFT key while clicking behind the 
last character to be selected. 

or

Drag with the mouse across the area to be selected.

Selecting paragraphs Triple clicking in a paragraph selects it including its style 
definition (which is ‘located’ in the terminating paragraph 
mark (¶).

Select contents only If you only want to select the contents (text) of the para-
graph, 

- Select the complete paragraph.

- Hold down the SHIFT key while pressing the LEFT 
ARROW key once.

Line and page breaks Line breaks and page breaks can not be avoided in all cases by 
using an elaborate paragraph catalogue:

Line breaks are entered by CTRL+ENTER.

Page breaks are not entered into text. If a paragraph must 
appear on the next page, apply the attribute with Special > 
Page Break…

Copy and paste

Paste just text Sometimes you want to get rid of all formatting and other 
properties stored with the text in the clip-board (for example, 
when copying from Word). Then you need to use Edit > Paste 
Special... and select Text from the menu.

An ESC sequence is not available for this function, but you 
may use SHIFT+CTRL+v, t,  (where  is the Enter/Return key) 
as a fast access to the menu.

Note: When selecting a portion of text which includes one or more 
paragraph-ends (¶ symbols) the pasted text bears the source 
format. To get only the text contents, use the method described 
here.

Copy format of one 
paragraph to another

To copy just the format specifications of a paragraph,

1 Have your cursor in the source paragraph and use Edit > 
Copy Special > Paragraph Format

2 Place the cursor in the target paragraph and paste.
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Tabulation

FrameMaker uses absolute tabbing, whereas most text proces-
sors use relative tabbing. Hence you always need the same 
number of TABs to reach a certain position, whether they can 
actually perform or not (see lines 1 to 3 in the example 
below).

Ruler and tab positions FrameMaker does not provide a useful ruler for tab positions. 
The ruler starts at the paper edge, not at the text frame:

Example The lines in the picture contain tabs stops at 2, 4, 6 and 8 cm. 
The layout of the page defines a left margin of 2 cm, room for 
side headings is 5.6 and the gap is 0.6 cm. Hence the first tab-
mark appears on 2 + 6.2 +2 = 10.2 cm on the ruler. 

Tabs in continuation
lines

In the second and next lines of a paragraph TAB positions are 
only performed, if the TAB characters really exist in the text. 
(see lines 3 and 4 in the example above.

Superfluous TAB
characters

If there are no tab positions for a TAB character to perform, 
they are ignored. This contrasts to MS Word where a para-
graph always contains invisible default positions. 

Note: Rounding errors may require a slightly smaller (-0.05mm) 
position of a right adjusted TAB than the width of the text 
frame.

Local formatting with the ruler

The ruler at the top of the FrameMaker window is handy for 
quick and dirty formatting:

1 If the ruler is not visible, activate it with View > Rulers. If 
the formatting bar is not visible, activate it with View > 
Formatting Bar.

2 Place the cursor in the paragraph you want to format or 
select a number of paragraphs to be formatted.

3 With the upper indent handle adjust the left (and the right) 
indent of the first line of the paragraph.

4 With the lower indent handle you set the ‘hanging indent’ 
for lines 2 to n of a paragraph (for lists etc.).

5 To specify a tab position, select the appropriate tab type 
(left, right, ...) in the left area of the formatting bar and 
click into the ruler area below the numbers.

6 Double click on the TAB position to get a dialogue to 
change the properties (type of tabulation, exact position 
etc.)

these are 2 TABs

TAB position

Handle for indenting the first

line of the paragraph

Handle for indenting the other

lines in the paragraph

Left Center Right Decimal Tab
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Support typographic rules

Smart spaces ‘Smart spaces’ (Format > Document > Text Options) does 
not remove superfluous blanks when importing text files. It 
works only for keyboard input.

Smart quotes ‘Smart Quotes’ are also set in Format > Document > Text 
Options. If set, entering a single quote or double quote with 
the keyboard changes them to typographic quotes accord-
ing to the setting in the maker.ini file (Windows). See Smart 
quotes on page A-36. Unfortunately there is no connection to 
the Language property of a paragraph.

To enter straight quotes (e.g. the inch symbol) when Smart 
Quotes are active, you need special ESC sequences (see Key-
board input on page A-2.

Note: If you change the settings for Smart Quotes in the maker.ini 
file (for example, from the English to the French form) and 
then open a document which uses smart quotes, all quotes are 
changed to the new form! 

Object manipulation

Selecting tables and parts 
of

A table is an independent object (not part of the surrounding 
text). A table is anchored at a crtain place in surrounding text, 
although it may appear quite distant to the anchoring loca-
tion.

Select a table Hold the CTRL key and triple click into a cell or...

Select the table anchor (see Select a non-width character (or 
narrow characters) on page A-17 

Select a column Hold the CTRL key and double click into the middle part of 
a cell 

Select a row Hold the CTRL key and double click into the far left or far 
right of a cell 

Select an area of cells Drag with mouse across the desired cells.

Selecting a text frame A text frame is the container of the text and is a graphic 
object. Hence it can only be grabbed with holding the CTRL 
key down while clicking on its edge (the cursor becomes a 
hollow arrow tip)

Note: Be careful not to move the mouse during the CTRL+click. 
CTRL+Click+move creates a copy of the object (see Ghost 
objects on page A-26).
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Find and change
Since the backslash is used for special notations in dialogue 
boxes (see below), it must be doubled to search it literally. To 
search for D:\QM_Handbuch you must enter D:\\QM_Handbuch.

Find/Change with pattern matching

Especially for cleaning imported text it is convenient to 
search for a pattern, for example «figure, followed ba TAB at 
the beginning of a line» to remove all manually numbered 
lists. See Wildcard-characters for Find dialogue on page A-4

Examples

Remove manual
numbering of

paragraphs.

This works also on already numbered paragraphs (FM-auton-
umber-format (<n+>\t) ). This finds only 1-figure. To find two 
figures, the pattern [0-9] must be replaced by [0-9] [0-9] .

Find Text ^[0-9]

Use Wildcards ON

Change <empty>

Remove empty
paragraphs

Find Text \p\p

Use Wildcards ON

Change \p

Note: Always be very careful in using Change All. The ‘empty’ para-
graph may contain a Table anchor or a Frame anchor which 
will also be selected!

Replace text with copied text or a variable

In this context variables are just a special form of text.

Note: Do not click into the document window when the found text is 
highlighted. You will loose the selection and can not paste.

Find arbitrary objects

FrameMaker allows to find nearly any object (Cross Refer-
ence, Marker, …). Explore the Find scroll-down list!

To replace text by content of the clipboard To replace text by a variable:

Copy the text to be used in replacement to the clipboard. Copy the text you are replacing to the clipboard.
Set up the variable definition (see  User variables on page 7-2).

In Find/Replace specify the text to be searched for in the 
Find field and select By Pasting form the list Change.

In Find/Replace paste the copied text into the Find field 
and select By Pasting form the list Change.

Specify where to Look in: Book, etc. Specify where to Look in: Book, etc.
Go back to the document where the text is still selected. Re-
place it with the variable, then copy the variable into the paste 
buffer.

With Find/Replace find the first/next occurrence of the text 
and replace it by pasting the variable from the paste buffer 
(CTRL+V).

With Find/Replace find the first/next occurrence of the text 
and replace it by pasting the variable from the paste buffer 
(CTRL+V).
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Find and change character formats

If –for example – you have imported a Word document and 
should now replace the direct formatting bold of all affected 
items with charcter format 2highlight, do the following:

1 Select the first string which is bold.

2 Apply the default character format (F8, Enter) to remove 
the bold appearance.

3 Apply the character format 2highlight (F8, 2h.., Enter).

4 Select from the menu Edit > Copy Special … > Character 
Format (ALT+F8).

5 In the Find/Change dialogue set Find list to Character 
Tag… and set all check boxes to As Is (click them once or 
twice to display a grey tic mark); set all properties other 
than Weight to As Is. In Weight select bold.

6 In the Find/Change dialogue set Change list to By Pasting.

7 With Change & Find apply the character format to the cur-
rent item and look up the next. Repeat this step as often as 
necessary.

Note: Be aware of the fact that FM’s As Is mechanism takes the cur-
rently active values. Hence replacing the bold format in a 
heading (e.g. 14pt Arial) may put that text portion into 10pt 
Times (if you started in ordinary text with these attributes).

Find and change paragraph formats

If –for example – you have imported a Word document and 
should now change some of the Normal paragraphs to format 
special, do the following:

1 Select the first Normal paragraph which should be changed.

2 Open the paragraph designer (CTRL+m) to get the para-
graph tag of this paragraph and copy the name from the 
field Paragraph Tag to the clipboard2).

3 Apply the paragraph format special (F9, sp.., Enter).

4 Select from the menu Edit > Copy Special… > Paragraph 
Format (ALT+F9).

5 In the Find/Change dialogue set Find list to Paragraph 
Tag: and paste the name from the clipboard into the entry 
field.

6 In the Find/Change dialogue set the Change list to By Past-
ing.

7 With Change & Find apply the paragraph format to the 
current item and look up the next. Repeat this step as often 
as necessary.

Note: For globally changing a paragraph tag name, see Renaming a 
paragraph format on page 3-9.

2 While this seems to be overkill for pargraph format Normal it is less er-
ror prone for names like wxfFaxNum, because FM style names are case 
sensitive.
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Hyphenation and spell checking

Dictionaries

Types of dictionaries FrameMaker supports for types of dictionaries:

The general dictionaries provided by FrameMaker. The 
are language specific.

The site dictionary normally it is set to Read Only and is 
maintained by a service department. Hence you can not 
‘learn’ into this dictionary. To use this dictionary, specify 
the path with the method described in Set up and use a 
project dictionary on page 2-8.

The project or personal dictionary normally is maintained 
by the project owner and hence can be written to with the 
Learn button.

The document dictionary is located in the document and 
can be maintained only via the MIF format of the file. This 
dictionary is filled with the Allow in Document function.

Note: The setting of a project or personal dictionary lasts for the cur-
rent FrameMaker session only!

Format of dictionary The site dictionary as well as the project or personal diction-
aries (e.g. user.dct) are plain text files using special notations 
for the characters with codes > 127 (see Internal code table on 
page A-16). You may wish to remove unreasonable hyphena-
tion points. Be aware that all languages are collected in the 
same file. Words starting with - are not hyphenated.

The dictionary entries can not be longer than 31 characters 
including the hyphenation dashes. However, the special codes 
(e.g. \x80 for Ä) count only as one. Hence words such as Über-
wachungsbedürftigkeit are not kept completely (\x86ber-wa-
chungs-be-d\x9frf-tig-kei) and hence not found.

For a more friendly handling of the dictionary files with the 
special codes you may use the utility fm2win2fm by D+DD.

Set up and use a project 
dictionary

1 Edit > Spelling Checker

2 Select Dictionaries. The current dictionary is displayed at 
the bottom of the dialogue.

3 Activate Personal Dictionary and select Change Diction-
ary from the drop-down list, OK.

4 For a new (or existing) project dictionary, define the appro-
priate path and file name (extension dct) and Use! it.

5 Back in the Spelling Checker dialogue: Start Checking or 
leave the dialogue (X). The settings are active during the 
current FrameMaker session.

6 The current dictionary is indicated at the bottom of the 
dialogue Dictionary Functions.

7 With Learn you add entries to the current personal diction-
ary. With Allow in Document you add entries to the docu-
ment internal dictionary. Use this for very special words.

<Maker Dictionary 2.0>
-\x86ber-g\x8ange
\x80nderun-gen
\x86ber-pr\x9f-fung
Abtrag-arms
Pro-gram-mier-men\x9f

http://www.daube.ch/docu/fmaker42.html
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Collecting unknown 
words

It is useful to collect unknown words in a project dictionary 
in advance in these cases:

In German words can be combined to a nearly unlimited 
repertoire and hence these combined words may be 
hyphenated at unwanted places.

The special field covered by the text is not covered by the 
standard dictionary at all: chemistry, legal, medicine etc.

There are, however some limitation to the user dictionaries or 
site dictionaries (see Format of dictionary on page 2-8):

The dictionary entries can not be longer than 31 characters 
including the hyphenation dashes. Hence may need to con-
centrate on few hyphenation points.

Only about 2000 entries can be collected. Unfortunately 
there is no mechanism to combine flexed words into one 
entry (which is done in the standard dictionaries).

1 To collect the unknown words of a FramMaker book, start 
in the first relevant chapter (e.g. to leave out the TOC) and 
activate Check: Book.

2 Click on Options… to open the dialogue Dictionary Func-
tions.

3 Activate Write all Unknown Words to File…and click OK.

4 In the dialogue Store Spell Checking Results in File: navi-
gate to the desired directory and enter the desired file 
name with the file extension dct.

5 You get feedback about the written entries:

6 Inspect the file and correct it:

<MakerDictionary 2.0>
Ac-it-vate wrong word  delete line
-Dachgiebel incorrect hyphenation
Fram-Mak-er Wrong spelling  correct it
-Mehrfach\x15Drehb\x8anke incorrect hyphenation
Nix-on do not hyphenate
pour-quoi
-rien
sie-he Do not hyphenate

contents of file after
correction

<MakerDictionary 2.0>
Dach-giebel
Frame-Maker
Mehr-fach-Dreh-b\x8anke
-Nixon
pour-quoi
-rien
-siehe

7 To use this dictionary follow Set up and use a project diction-
ary on page 2-8

Note: To handle the umlauts and accented characters with ease in 
any text editor, see the utility fm2win2fm by D+DD.

http://www.daube.ch/docu/fmaker42.html
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Hyphenation

Note: FrameMaker behaves differently than MS Word - also concern-
ing hyphenation.

General remarks Automatic hyphenation is a paragraph property.

Hyphenation can be selectively disabled with a character 
format specifying language ‘None’.

Manual hyphenation (with discretionary/optional hyphen, 
suppress hyphenation) is active only in paragraphs with 
the attribute Hyphenate set.

For special terminology consider collecting the words in a 
file and creating a ‘project dictionary’ with appropriate 
hyphenation points.

Change hyphenation of a 
word 

1 Edit > Spelling Checker

2 Enter the word for which the hyphenation is to be changed.

3 Select Show Word’s Hyphenation

4 Clear all hyphenation points (-) which you do not want.

5 Avoid hyphenation of a word with a preceding minus sign.

6 Learn (store in the personal or project dictionary). 

Avoid hyphenation To avoid the hyphenation of a word, (e.g. a product name),

1 Place the cursor in front of the word

2 Enter ESC, n, s (English FM) or ESC, k, t (German FM).

Optional hyphenation 1 Place the cursor in the word, where you want to provide 
optional hyphenation

2 Enter CTRL+minus (Windows) or command+minus (Mac)

Note: Suppression of hyphenation takes precedence over optional 
hyphenation points.

Optional hyphen is not 
honoured?

If the optional hyphenation is not honoured, check the num-
ber of successively hyphenated lines in the paragraph 
designer: Advanced properties: max # adjacent. The standard 
value is 2 to avoid ‘ladders’.

Non breaking blank To keep words or characters together and protect them from 
hyphenation use the non breaking space (CTRL+space).

Non breaking hyphen To avoid hyphen in a compound word (such as end-user), use 
the non-breaking hyphen ESC, -, h (English FrameMaker) or 
ESC, -, w (German version).

Non breaking slash You can switch off the hyphenation after specific symbols in 
the dialogue Format > Document > Text Options by remov-
ing these symbols from the list Allow Line breaks after (the 
slash is normally the first symbol there).
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If you both need a breaking and a non breaking slash, provide 
a variable (e.g. named slash) with the definition «\/» (without 
the quotes. Use this variable as non-breaking slash.

Apply new hyphenation 
to existing document

1 Edit > Spelling Checker

2 Select Dictionaries

3 Select Re-hyphenate Document, OK!

To hyphenate or not to 
hyphenate

Be aware of the influence of non breaking symbols to the fol-
lowing word: it depends! 

Spell checking

Start spell checking at the beginning of the document with 
Edit > Spelling Checker > Start Checking!

Spell checking and hyphenation use the same dictionary.

FrameMaker starts the checking at the current cursor loca-
tion and wraps to the beginning of the file.

If there are ‘errors’, which are ignored, the wrapping may 
go on and on. Hence watch the vertical scrolling bar.

Spell check does not ‘dive into’ text insets – these are inde-
pendent files which must be checked separately.

Spell Check options The options for the spell checker are set with Edit > Spelling 
Checker > Options…

Note: The settings are saved in the frame.ini file and hence are 
available across FrameMaker sessions.

Type of symbols non breaking normal

non-breaking blank after the arrow
(justified paragraphs)

siehe auch
 Dachgiebel

siehe auch 
Dachgiebel

non-breaking hyphen between words Mehrfach-Dreh-
bänke

Mehrfach-Dreh-
bänke

Option Checks for example Comments

Find

Repeated words this and and that

Unusual hyphenation un-usual, re-initialise

Unusual capitalisation TheSis, wronG

Two in a row Richard Nixon ?? ??? will pass

Straight quotes "welcome back friends"

Extra spaces and so on e.g. from importing text

Spaces before/after ( rien ), pourquoi ? French typography requires 
these spaces 

Ignore

Single character words Just a bunch of if’s

All UPPERCASE words USB bus

Words containing … 123.9 ignore the period

Roman numerals see page vii

Words with digits Lotus123
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Styles

Overview

In this chapter properties of paragraph and charac-
ter styles are discussed. The hierarchical numbering 
of paragraphs is vital for technical and scientific 
publications.

Importing styles or elements of style from other 
documents eases the set up of consistent layout and 
design. This is a key feature of FrameMaker.

Contents

Names for styles .....................................................  2

Paragraph styles .....................................................  3

Character styles ....................................................  11

Import formats from another document .................  13

Special formatting ................................................  16
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Names for styles
Paragraph and character formats, table formats, cross refer-
ence forms and so on are named. Choose names carefully as 
they live longer than you imagine!

Name by function Style names based on the function can be learned easier and 
are better suited for structured documents. Naming by 
appearance is a reminiscence of layouters and typographers. 
We are talking about document processing here:

Name with abbreviation Paragraph formats can be applied to an object with keyboard 
short-cuts:

F8, characterformat, Enter

F9, paragraphformat, Enter

Names may be shortened to the relevant length.

For this reason it is important to use names which differenti-
ate in the first characters: 

Using lower case characters distinguishes the user defined 
styles from the FrameMaker supplied styles, which always 
start with an upper case character.

Special names Name items which are not used by the author of a text com-
pletely different, for example, precede the names by z. The 
will sort at the end of the list of styles. Items in this category 
are used on layout pages (master pages) or as ‘hidden fea-
tures’:

Dangerous characters in 
style names

Do not use blanks, umlauts, brackets [ ], angle brackets < > 
and the $-sign in style names (paragraph, character) – these 
may interfere with special constructs such as in cross-refer-
ences and damage HTML export.

Name based on appearance Name based on function

24pt-Garamond-bold 1heading

left-2cm-right-2cm-italic citation

hanging-indent-bullet lb-bulleted-list

10pt-Times body

5rows-left-adjusted invoice

Table with frame and fancy head full-statistics

First shot Efficient Keys

Heading 1 1heading F9, 1

Heading 2 2heading F9, 2

Wide list lw-list-wide F9, lw

Checklist lc-checklist F9, lc

Wide table with horizontal lines zlw-wide-line F9, zlw

Highlight bold 2highlight F8, 2

Name Usage

z-anchor automatically applied as follow on ¶

z-footer layout

z-header layout
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Paragraph styles
Using style names for paragraphs, character sequences and 
tables (rather than local formatting) gives you these advan-
tages:

The appearance of a document can be changed ‘in the last 
minute’.

The appearance of all documents in a book can be changed 
with ‘the snip of a finger’ (importing styles from any docu-
ment).

Note: Upper- and lower case is relevant in style names (Heading and 
heading are not the same).

Properties of paragraphs and text

To set up paragraph and character styles you need to under-
stand various properties of text elements. The terminology 
varies between text processing applications, but the concepts 
are comparable.

Properties of lines and 
paragraphs These are some lines before the paragraph 

demonstrating various paragraph 
Properties.

This is the paragraph of a 
list to demonstrate the in-
dentation properties for the 
sake of better understand-
ing.

This paragraph uses Indent First, which 
is common in prose texts.

In technical texts paragraphs are formatted 
as blocks, that is without indentation of 
the first line, but with Space Before.

Line spacing

Indent First

Indent Left

line height

Space above

Space below

text frame

Indent Right
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Properties of type In the font properties for a paragraph and in the definition of 
character formats a number of modifications to the original 
font appearance can be set:

Property Meaning Example 
value

Example presentation

Angle Character shapes are either slanted (‘mechani-
cally’ tilted: oblique, slanted, italicised) or de-
signed for a pleasing appearance (italic)

regular
italic
slanted

The upright form is called roman, 
the designed tilted form is italics 
(kursive), whereas slanted etc. has no 
specific shapes (e.g.) for f or g.

Weight Thickness of the strokes forming a character 
shape. Various names are in use. Only few fonts 
provide more than just bold.

regular,
bold
semibold

This is the regular form. and here 
comes bold.

Variation Some fonts provide narrow or wide forms or 
other variations. Condensed is a designed 
form, Narrow is a ‘mechanical’ deformation.

regular
condensed
narrow

This is Lucida Sans. Here comes Lucida 
Sans Narrow.

Spread Additional space between characters in% of em-
space (German: geviert)

0% This text is not spread at all (set tight)

3% This text is spread a little bit

20% T h i s  t e x t  i s  s p r e a d  h e a v i l y

Stretch The character shapes are stretched graphically 100% This text is not stretched at all

160% This is really stretched

Pair kern Individual character pairs are arranged closer 
than their bounding box defines. This creates 
better appearance for certain character pairs in 
large sizes

Without AV-Medium Yoga

With AV-Medium Yoga

Manual kerning is not recommended. It can 
work only on the characters of one line.

Manually AV-Medium Yoga  

Underline This text decoration should be used only to vis-
ualise conditional text (added text) – it is not a 
good emphasis

u
se

 t
he

se
 o

n
ly

fo
r 

in
d

ic
at

io
n

of
 c

ha
n

g
es

Underlining cuts through the 
descenders, numeric underlining 
does not; double may be awful.

Overline This may be useful for certain mathematical 
stuff

Here comes what you expect.

Strike through This text decoration is predestined to visualise 
the text condition ‘deleted’

Well, this was here, and that’s here 
now. 

Change bar If you apply this character format, it will be re-
moved by Format > Document > Change 
Bars > Clear all

On the side of the text frame you see 
a vertical bar indicating this charac-
ter format

Superscript These character formats are widely used for 
formula like text pieces

La
rg

er
 l

in
e-

sp
ac

in
g

 t
ha

n
n

o
rm

al
 m

ay
b
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n

ee
d

ed

A superscript2) has various uses, for 
example in cross-reference formats

Subscript Subscripts may be needed in chemi-
cal notations, such as H2SO4

Small caps In German this is called Kapitälchen. The Fram-
eMaker form is a mechanical modification. Real 
Small Caps are specially designed forms.

SMALL CAPS (KAPITÄLCHEN) ARE WIDELY 
USED FOR PRESENTATION OF PRODUCT 
NAMES, OPUS NAMES OR IN HEADINGS.

Uppercase Thesis text decoration s do not physically 
change the text (the buttons AB and ab do so). 
You can find the unmodified text with the Find/
Change dialogue an ‘Consider Case’ active.

HELLO, THIS SHALL BE ALL UPPER 
CASE – CAN YOU READ IT EASILY?

Lowercase this is all lower case although typed 
with caps lock on

Colour Shades of gray are useful in any printing pro-
cess. Colour is good for electronic distribution 
(PDF, Web) and costs a lot in real printing.

Use shades of gray for 

large font sizes, for exam-

ple in headings. This creates a more 
uniform gray value of the page.
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Define a paragraph style name

Basic properties Place the cursor in a paragraph the style of which you want 
to develop (and store in the catalogue).

Open the Paragraph Designer (Format > Paragraphs > 
Designer).

In the field Paragraph Tag enter the name of the para-
graph style to be created.

In the drop down list Commands select New Format.

In the Dialogue New Format activate both Store in Cata-
logue and Apply to Selection (this to gives you a visual 
hint about the developing format of the paragraph).

In the Basic properties either define Space above or Space 
below for paragraphs. Only in rare cases both definition 
are needed.

Set up paragraph properties

Font properties

Define the name of the paragraph style (if you want to 
define a new style).

Set the properties in a specific property area (Basic, Default 
Font, Pagination etc.)

For test purpose (visual check of appearance) you may wish 
to just apply the settings to the current paragraph with 
Apply.

Store the settings in the catalogue as well as apply them to 
the current paragraph with Update All.

Pagination

Start on Top of Page if you need to have a page break before 
the paragraph.

Always set «Keep with Next Paragraph» headings to avoid 
dangling headings.

When tweaking a layout it may be necessary to set Widow/
Orphan lines to 1 or a large number.
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Pagination The Pagination properties define the arrangement of para-
graphs. Running text always is «In Column». For headings you 
will need variations:

Numbering

You need the Numbering property category for numbered 
lists, bulleted lists and items such as the notes in this chapter. 
For example, bulleted and numbered lists use the following 
setup:

n1_numbered_1st <n=1>

nx-numbered_next<n+>

lb-bulleted \b\t

note Note:\t

The display of the counter depends on the character used in 
the construct: n (1, 2, 4), r (i, ii, iv), R (I, II, IV), a (a, b, d), A (A, 
B, D).

Hierarchical numbering for heading is more elaborate and is 
explained on page page 10.

To highlight the numbering (or the constant text as for the 
note), you must define a character format first. You can not 
select fonts.

Normally the numbering Position is at the «Start of Para-
graph», but for formulas etc. it is desirable to set this to «End 
of Paragraph».

Note: When hiding the counter by the leading blank you must leave 
out the counter format character: Not < n=0> but < =0>.

Numbered lists Numbered lists are normally not bound to the hierarchy of 
headings (see Numbering on page 6). If numbered lists are 
bound to the heading scheme, than the lists must be treated 

A) Hecate Latonae Filia, soror Apollinis.

Est tricopor et 
triceps, magicarum 
artium magistra ac 
fascinationum 

praeses, cinctra 
latrantium canum 
turma.

B) Noctu triviis nec hoverei

vel prope sepulcra 
et ubi loca sunt 
caedibus 

contaminata 
sinistra.

C) Hec est Iovi Latonae filia, soror 
Apollinis. Est trico 
por et triceps, mag 
icarum artium mo 
magistra actual.

D) Fasinosa del 
mortioriti

Praeses, cinctra 
latrantium 
num contaminata. 
Latonae filia, soror 

Apollinis. Est trico 
et triceps, 
magicarum 
artiumra.

E) Turma. noctu 
stans in triviis vel 
prope sepulcra et 
ubi loca sunt 
caedibus 
contaminata. 
Latonae filia, soror 
Apollinis. Est trico 

A Across all Columns and 
Side Heads

B Across all columns

C Side Head, alignment First 
Baseline

D In Column

E Run-In Head, Default 
punctuation «.«

Watch the interruption of the 
text area by a heading.

Numbering elements

< =0> Set counter,
no display

<=0> Set counter, display
< > Place holder in 

scheme
<n> Display counter arabic
<n+> Increment and display
\b Bullet symbol
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similar to the table or figure. In this case, more rows and col-
umns are added to the matrix.

Note: The footnote numbering is completely out of the game for 
numbered paragraphs (see Footnotes on page 7-10).

Bulleted lists A bulleted list is a special form a numbered list. The number 
degrades to a constant symbol. A standard bullet (centered 
dot) is available in every text font, hence it is provides as a 
building block (\b) in the dialogue. 

To get more fancy bullets, you need to define a character for-
mat for ‘switching the font’ (see Setting up a character style on 
page 11) and replace the \b building block with the corre-
sponding character. For example to get a list bulleted with , 
you need to ‘switch to’ Dingbats or Wingdings and enter v (see 
Symbols and dingbats on page A-5).

Advanced

On the Advanced property sheet you define typographic 
details as well as graphic Frames attached to the paragraph 
(above or below). These graphic frames are located on the ref-
erence pages (see Graphic elements on reference pages on 
page 15).

With the settings of Word Spacing you define, how much the 
word space can be compressed or expanded for justified text.

Do not check the box «Allow Automatic Letter Spacing» - this 
creates very bad typography.

Note: You can not attach a graphic element behind the paragraph 
(e.g. to create a shaded background). You may achieve the 
desired effect with a table of only one cell.

Table Cell

These properties become only relevant if the paragraph is 
used in a table (table heading, body or bottom cells). 

For each cell margin you can specify 

From Table Format, Plus a value (relative setting), or

Custom (absolute setting).

Use Custom to define the complete margin around the para-
graph ignoring the margin which is set in the Table Designer.

Align the paragraph within the table cell (top, bottom, middle) 
with this property sheet.

Cell Margins from 
the Table designer This is the paragraph in the table 

cell with the properties from the 
paragraph designer.

Cell Margins from 
the Paragraph de-
signer.
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Setting only one property in ¶ or ƒ catalogue

You may need to set one property for all entries in the cata-
logue. For example, the language or the default font (if it is 
really the same in all styles!)

To set the language in all 
paragraph catalogue 
entries

1 Open the paragraph designer (menu Format > Paragraphs 
> Designer or CTRL+M)

2 Open the appropriate tab (Default Font)

3 In the Commands drop down list select Set Window to As 
Is or press SHIFT+F8.

4 In the Language field set the desired language (e.g. 
Schweizerdeutsch)

5 In the Commands drop down list select Global Update 
Options… and set the radio buttons Default Font Properties 
only (the name of the current tab) and All Paragraphs and 
Catalogue Entries

6 Press the Update button.

Setting up a group of paragraph styles

To set up a group of paragraph styles the following method is 
recommended (but check out your personal preferences):

In a new document, delete all entries in the catalogue. 
Name this document according to its purpose, for example: 
parastyles.fm

For each style enter a paragraph on which you can see how 
the style develops. Start the paragraph text with the name 
of the style you want to develop on this paragraph. Provide 
at least two lines in a paragraph to see the indentations.

Apply the style names to the paragraphs according to the 
procedure described in Names for styles on page 2.

Set the Property sheets in the Paragraph Designer to the 
first category of properties (Basic).

- Set the properties according to the needs for this para-
graph style and Update All (both the selected paragraph 
and the catalogue).

- Work through all paragraphs with a distinct property 
sheet of the paragraph designer.

Then change to the next property sheet for all paragraphs.

Note: The Paragraph Designer displays the format name of the cur-
rent paragraph (where the cursor is in). Hence it is convenient 
to work with already named paragraphs.
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Renaming a paragraph format

Use this operation with care because all paragraphs of a partic-
ular style name (including the catalogue) are changed! Gener-
ally this is correct for cleaning up an imported Word 
document):

1 Select a paragraph with the style name to be changed (e.g. 
from «Eingerückt» to «lb-bulleted».

2 In Paragraph Designer (Format > Paragraphs > 
Designer...) change the displayed ¶-name to the desired. 
Clicking on Update all will prompt you to accept the 
change.

Merging paragraph formats

Assume, for example, you have the following paragraph 
styles: 2heading, 2Heading, 2HEADING (for example, due to 
input from other documents). The ‘only valid one’ is 
2heading.

You merge them together by renaming

2Heading to 2heading
2HEADING to 2heading

Paragraphs with the changed names will display an * in the 
information area on the screen (lower left corner). This indi-
cates local overrides, which should be removed:

1 Select one of the changed paragraphs.

2 In the Paragraph designer (Format > Paragraphs > 
Designer...), click Update all. You will be prompted to dis-
miss the overrides: click Remove Overrides.

Replace paragraph format in document or book

To replace a paragraph format (say: fromThis) by another one 
(say toThat) in a document or book:

1 Set the insertion point into a paragraph that uses the 
desired format (toThat)

2 Edit > Copy Special… > Paragraph Format. The desired 
format is now in the clipboard.

3 In the Find/Change dialogue set the Find list to Paragraph 
Tag: amd enter the name of the unwanted style (fromThis) 
into the field.

4 Set the Change list to By Pasting

5 You might want to do one or two replaces individually to 
make sure this gives you what you want, but you can then 
do a "change all" for the document or book.
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Hierarchical numbering

Dependencies in numbering (e.g. all headings) require the 
use of a sequence name (e.g. H:). Independent numbering 
such as the numbered lists, do not need a sequence name.

Blanks () are relevant! It denotes ‘no display’ for the num-
bering item.

The numbering items consist both of a counter and a for-
mat for display. Once the format is set (using n, R, a etc.) 
the setting of the counter (=x) must not use the n again 
(except for the real display of the initial value (see below 
the scheme for the numbered lists).

Example numbering 
scheme

In the following example scheme the table and the figure num-
bering should restart at the main heading (level 1). Heading 
levels ‘inherit’ the number from the higher level.

This scheme is used for preparing the entries into the dialog 
field of the paragraph designer, tab Numbering. For 3heading 
you enter there, for example (leaving out all the informal 
space in the above table, but observing the required space):

H:<n>.<n>.<n+>< >< >

Note: Be careful with the arrangement non-syntactical element (such 
as the TAB or the periods or the word Table). They may inter-
fere with the numbering when accessing the numbering infor-
mation in cross-references etc. See Building blocks $paranum 
and $paranumonly on page 7-5.

Linebreak in autonumber

There is no building block \n to force the paragraph contents 
to the next line. However, you can set up the autonumber 
string as follows (watch the ordinary space at the end of the 
string):

T:Test<n+>\t
In the basic properties of this paragraph style you define a 
tab position corresponding to the width of the text frame 
(minus «one» character):

It is essential to start the paragraph text with a nonbreaking 
space for this construct.

Seq. 
label

Prefix Numbering flow

Format-name  1head 2head 3head table figure

1heading H: <n+> <=0> <=0> <=0> <=0>\t
2heading H: <n>. <n+> <=0> <> <>\t
3heading H: <n>. <n>. <n+> <> <>\t
tt_table_title H: Table <n>. <> <> <n+> <>\t
ftn-fig-title-numbered H: Figure <n> <> <> <> <n+>\t

Frame-width = 11.8 cm; TAB position = 11.7 cm

Start paragraph text with a nonbreaking space
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Character styles
Upper- and lower case is relevant in style names (dingbats and 
Dingbats are not the same).

Character styles are used to:

highlight portions of a paragraph

format the autonumber part of a paragraph

format elements in a cross-reference or variable

format the graphic text created with the Text Line tool

Note: Only the last applied character format is stored. Previously 
applied character formats become ‘local formatting’  See fig-
ure at left.

Note: Local text formatting with Format > Font, Format > Size or 
Format > Style or with the buttons from the formatting bar 
(View > Formatting Bar) can not be used in paragraph num-
bering, variables and cross references. This ‘local’ formatting 
is not preserved when saving the file as HTML. ‘Local’ format-
ting is generally not recommended for long living documents.

Setting up a character style

The name of a character style should provide a hint about its 
purpose, not its appearance: 1-highlight, footnote-refer-
ence,…

Note: The properties which can be et for a character format are the 
same as on tab Font in the Paragraph Designer (see Properties 
of type on page 3-4).

Select a text portion (a word or phrase) which can display 
the definition of the style. 

Open the Character Designer (Format > Characters > 
Designer).

In the field Character Tag enter the name of the style to be 
created.

In the drop down list Commands select New Format.

In the Dialog New Format activate both Store in Catalogue 
and Apply to Selection (this to gives you a visual hint 
about the developing format).

If you want the character format to add properties to the 
selection rather set the full range of properties, set all 
properties to as is by selecting Set Window to As Is from 
the Commands drop down list or with SHIFT+F8.

Note: This ‘Set Window to As Is’ is needed, for example, for a format 
just changing the font, but not the size or anything else.

Set the desired properties of the character format.

Define the character format both in the catalogue as well 
as set the properties in the selection with Update All.

Hecata iovis et illis gurgenta
format-1

format-2

This part is
local formatting

(no f-format)
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Renaming a character format

Use this operation with care because all text sequences with a 
particular style (including the catalogue and hence also cross 
references etc.) are changed! Generally this is correct for 
cleaning up an imported Word document):

1 Select a character sequence with the style name to be 
changed (e.g. from «italic» to «1-highlight».

2 In Character Designer (Format > characters > Designer...) 
change the displayed f-name to the desired. Clicking on 
Update all will prompt you to accept the change.

Note: Be aware that only the name of the last applied character for-
mat is retained (see beginning of this section).

Replace character format in document or book

To replace a character format (say: fromThis) by another one 
(say toThat) in a document or book:

1 Select a piece of text that uses the character format toThat

2 Edit > Copy Special… > Character Format. The desired 
format is now in the clipboard.

3 In the Find/Change dialogue set the Find list to Character 
Tag: and enter the name of the unwanted style (FromThis) 
into the field.

4 Set the Change list to By Pasting

5 You might want to do one or two replaces individually to 
make sure this gives you what you want, but you can then 
do a "change all" for the document or book.

Character styles in building blocks

In the context of cross-references, the <$paratext> building 
block ignores all character formatting present in the 
extracted paragraph text (including case formatting), except 
superscript, subscript and font family properties.

This applies also to the Running Header/Footer system varia-
bles which contain this construct.

This differs from the use of <$paratext> in generated files, 
where FrameMaker retains all character formatting if it is the 
result of a character tag (untagged font properties are not 
retained).

[FrameMaker Building Blocks: Cross-Reference Formats, 
http://www.microtype.com/resources/BBxref.pdf]

Example To have the italics property visible in the cross-reference, you 
have to use a different font name which activates the italic – 
inspect your font list and see whether you have a suitable 
font which also has «Italic» or «Oblique» as part of the font 
name and use in the character format with this definition.

Note: For more details see http://www.microtype.com/resources/
FTPreserveFmtXref.pdf

http://www.microtype.com/resources/FTPreserveFmtXref.pdf
http://www.microtype.com/resources/FTPreserveFmtXref.pdf
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Import formats from another document

Warnings concerning format imports

See also Contents of format categories on page 3-14.

Document Properties Be aware that the category Document Properties contains 
properties of such diverse items as: 

Document numbering (Format > Document > Number-
ing…)

Change bars (Format > Document > Change Bars…)

Footnote settings (Format > Document > Footnote Proper-
ties…)

Text options (Format > Document > Text options…)

Acrobat setup (Format > Document > PDF Setup …)

Variable Definitions Both System Variables and User Variables are imported. This 
may override specific settings from a template.

Running Heading/
Footers

While their use is defined in the category Page Layouts, their 
definition is located in category Variables. Appearance may 
be affected by Character Formats.

Cross-reference formats 
and Variables

These are often affected by Character Formats, hence an 
import of changed Character Formats may be necessary.

Importing Format categories

Import formats from 
another document

Open the source document

Open the target document.

In the target document: File > Import > Format

Select the source document in the drop down list

Use the Deselect All button if you want to set only few cat-
egories.

Activate the elements of the document you want to import.
To import layout with changed definitions for Running 
Heading / Footing, you must select both Layout Pages and 
Variables.

Import!

Save the target document.

Importing Page Layouts When importing master pages the property Room for Side 
Heads is not imported, because this is a property of the text 
flow. Hence after importing the master pages it may be neces-
sary to set this attribute once on the body pages of each tar-
get document. 
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Contents of format categories

It is not obvious which document properties are located in 
which format category.

Note: If you need to import only part of a category, for example, just 
the user variables, you need a special plug-in (ImportFormat-
Special by rick Quatro, www.frameexpert.com.

Item to be imported
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Change bar (revision bar) properties X

Character catalogue X

Colour catalogue X

Colour views (for separation) X

Condition types, Condignly text formats X

Content definition for TOC, index etc. X

Cross-reference formats X

Custom marker definitions X

Custom math elements from Math reference 
page

X

Document view, grid and snap properties X

Footnote properties, numbering, layout X X

Layout X

Marker type names X

Math font definition and sizes X

Numbering of chapter, pages, paragraphs, foot-
notes, table-footnotes

X

Page size, pagination, master page usage X

Paragraph «Frame above/below» graphics X

Paragraph catalogue X

PDF setup, document information X

Print separations settings X

Rubi text properties X

Ruling styles in tables X

Running Header/Footer formats X

Spell check options X

System variable definitions X

Table catalogue X

Text options (smart …, super/subscript) X

User variable definitions X

View and lock (document/palette) X

http://www.frameexpert.com/plugins/importformatsspecial/index.htm
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Import formats into book 
files

When in a book file, all properties for the documents, such as 
paragraph styles, master pages, cross reference formats etc. 
can be imported and distributed to all files in the book.

1 Open the book file

2 Select the files to be updated.

3 In the Import Formats dialogue specify the file from which 
you want to import. This file need not be part of the book, 
but it must be open.
To import layout with changed definitions for Running Head-
ing / Footing, you must select both Layout Pages and Varia-
bles.

4 Specify (check the boxes) which properties you want to 
import and distribute.

5 If you want to remove local overrides, check the appropri-
ate boxes.

6 Import!

Note: The files of the book must be open, if your files use currently 
unavailable fonts and graphics (because this requires user 
intervention).

Import only part of a 
format category

To import just some of the needed formats (e.g. paragraph 
formats for headers only) you need an intermediate docu-
ment.

Set up an empty document.

Import the paragraph/character/table styles.

Delete all styles you don’t need (in the paragraph and/or 
character catalogue or Table designer).

Save the file with a distinct name (imports are not possible 
from unsaved files).

Open the target document and import the desired style ele-
ments from the intermediate document.

Removing style overrides

To remove all (that is also those applied intentionally!) style 
overrides, you must re-import the catalogue from a reference 
document, such as a template.

Be careful in selecting the items you want to import. To 
remove overrides from paragraph formats only, check only 
Paragraph Formats and leave all other option unchecked.

During import check the box Other Format/Layout Over-
rides. You may also wish to check Remove Manual Page 
Breaks.
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Special formatting

Paragraph with background

Paragraph in table cell A well known method is to use a one-cell table with or with-
out ruling and cell shading:

Another method is the overlap of two paragraphs. See 

Anchored frame at the 
paragraph

If you do not need a fill but only a frame for the paragraph, 
this might be a solution for You. Anchor a frame with the fol-
lowing properties at the end of the paragraph: outside text 
frame, right adjusted. Adapt height, width, distance above 
baseline to your needs. Distance to text frame normally is the 
negative width of the frame or column.

This is the paragraph under the frame
Note: The anchored frame is in foreground, hence you can not edit 

the contents with the mouse. On top of page both the para-
graph and the frame are aligned with the layout frame. Hence 
the relative position of frame and paragraph will change.

Editing the paragraph 1 Place the cursor in the previous or next paragraph.

2 Use the appropriate arrow key to move the cursor into the 
overlaid paragraph.

3 Edit the text (using SHIFT+arrow keys for selections)

Text fragments with background

A few methods are at hand for this task.

Equation with string Place an equation (most time the smallest size is adequate) 
and insert the desired text as string (enter " followed by the 
text and terminate text with ENTER. Then shrink wrap the for-
mula and apply the desired border or fill attributes to the 
frame.

Here comes the formula text: . This might 
require some tweaking of the vertical position to align the 
text to the baseline of the paragraph. Selecting text (for edit-
ing) in the formula string is possible with the mouse but not 
with the arrow keys ( No Insertion point).

As with all graphic objects, frame fill and border can only be 
of same colour. You can apply character formats to the text, 
however it will not be displayed in the status area.

Anchored frame with text 
line

Here is an anchored frame  (same as gen-
erated with formula). Character formats are recommended 
(and displayed in the status area). It is a little bit tedious to 
adjust the baseline, but editing the contents is easy.

This is the paragraph in the text cell, which is shaded and 
has outside ruling. You may want to set up a special table 
format for this, for example parashade.

just as small as possible

«at insertion point»



Tables

Overview

Tables are anchored objects which flow with the 
text. The many properties a FrameMaker table can 
bear make this construct very flexible.

Tables with special properties are used for ‘non-
table’ purpose, such as headings with shaded back-
ground or titled graphics.

Tables can be rotated as a whole to provide many 
columns. Standard FrameMaker allows only to sort 
the items in tables. With plug-ins other actions can 
be performed in tables.

Contents

Table properties .....................................................  2

Handling table items ...............................................  3

Set up table properties ............................................  4

Special table positions ............................................  9

Set up a table template .........................................  10

Importing tables ...................................................  11

Special operations ................................................  12

Nested tables .......................................................  18
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Table properties
In the diagram hereafter the table area is lightly shaded to 
display the complete object ‘table’. 

Table alignment is relative to the paragraph with the anchor 
(be aware of side heads...)

Properties in the table catalogue

When using an existing table to create a table template, the 
following properties are stored in the catalogue:

All properties which can be set in the table designer (posi-
tion, cell-margins, regular ruling and shading, title posi-
tion).

Properties from the sample table:

- number of rows for table heading, body and footing

- number of columns, width of each column

- paragraph format in the first row (of table heading, body 
and footing) for each column.

The following properties are not kept in the table catalogue:

Straddling of cells

Individual ruling and/or shading

Other paragraph formats than specified above

…

The table anchor is here:

This is the next paragraph after the table, the ordinary text 
outside the table which is a special object.

Table 1: Table title (¶ format tn-tab-title-numbered)

Heading cells Head Head

Body cells (¶ format tm-table-middle)

A footnote reference a

a. This is a table footnote (¶ format ztf-table-footnote)

straddled cells

This cell is very large to show the
margins and surrounding areas

Footing cells Foot Foot

«Space above»
(Table designer).

«Gap» (Title Position)
(Table designer).

Column ruling

Body Row ruling

Separators

Cell margin (Table designer)

Cell margin from ¶ designer,
«Table Cell» properties.

Outside ruling

Space defined by box
on Reference page.

Space below»
(Table designer)
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Handling table items

Inserting tables

Tables are anchored objects similar to anchored frames. You 
can select the whole table by selecting the anchor.

To insert a table 1 Place the cursor where you want to place the table anchor. 
To have a better overview use an empty paragraph (but this 
may create to much empty space).

2 Insert the table with Table > Insert Table …

3 Select the format from the drop down list Table Tags

4 Specify the number of rows and columns for the table. You 
may wish to start with few rows only.

5 Specify the number of heading and footing rows. Most time 
you will have zero footing rows. Insert!

Note: You can not transform ordinary table rows to heading- or foot-
ing rows after the table is inserted into the text. You can, how-
ever, add heading and footing to an existing table and then 
transfer content form body rows as required.

6 Adjust the width of the columns to your desire.

7 You may wish to remove the table title (if the template 
table comprises one). You need the Table Designer for this 
(see Basic table properties on page 4).

Selecting table items and other operations

On the Mac use ALT in place of the CTRL key for the following:

Select a table Hold the CTRL key and triple click into a cell or …

Select the table anchor (see Select a non-width character (or 
narrow characters) on page A-17 

Select a column Hold CTRL and double click into the middle part of a cell 

Select a row Hold CTRL and double click into the far left or far right of a 
cell 

Select an area of cells Drag with mouse across the desired cells.

Find the anchor of a table Place the cursor in the table, then press ESC, t, I (upper case 
i). This moves the cursor just behind the anchor point ().

Copy / cut and paste cells When pasting cells the number of cells to be pasted to need 
not be equal to the copied or cut cells. The copied cells are 
repeated to a larger amount of paste cells (a, b, c  a, b, c, a, 
b) or discarded or a smaller amount (a, b, c  a, b).

Insert a table row Insert a table row below the current one with CTRL+ENTER. 
Use Table > Add Rows or Columns … for more than one 
item.
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Set up table properties
Table properties are set up with the table designer (Table > 
Table Designer or CTRL+t)

Basic table properties

Indents Indents specify the amount of space to the left and right of 
the table within the text frame. Normally this is zero.

Space Space above defines the space between the line with the 
anchor point and the upper edge of the table (or when the 
table title is above) the table title.

Space below defines the space below the table (or any table 
footnotes) and the next text paragraph.

Alignment This defines the alignment of the table relative to the anchor-
ing point.

Start Start defines whether the table should start at specific loca-
tion (Top of column etc.) or just after the anchor line (Any-
where). With Float the table can move to the next page and 
text appearing logically after the table is moved between the 
anchor point and the table.

See also Special table positions on page 4-9

Numbering This defines the flow of numbering:

Title position This may be above or below the title. You can also set «no 
Title».

The Gap defines the space between the table title and the 
table body.

Orphan rows This value defines, how many rows at least must be placed. If 
these rows do not fit on the current page, the table is moved 
to the next page.

For cell margins see also Table
Cell on page 3-7.

Row First Column First
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Default cell margins For paragraphs without any additional setting of cell margins 
(see Table Cell on page 3-7) this defines the margins around 
the paragraph in the table cell: Table ruling.

Default cell margins may cut off accents in the first cell line, 
especially with thick ruling:

Table ruling With this dialogue only properties for regular patterns (n-th 
line, n-th row etc.) can be set.

This table is left indented by 0.5 cm and uses special ruling to 
group rows

Table shading With this property sheet only regular patterns can be set (n-th 
line, n-th row etc.).

The Fill values (White, 3%, 10% etc.) do not fill with shades, 
but with patterns (see Border and Fill patterns on page 6-12)

When using shades be aware of the multiplicative effect of fill 
and colour: 50% fill of a colour which is defined as 20% black 
results in a 10% shade of gray.

Colours are defined in View > Color > Definitions … (see Col-
ours on page 6-12).

Custom ruling and shading

Additional properties for individual rows, columns and cells 
are defined with Table > Custom Ruling and Shading.

Specify either ruling or shading or both with the appropriate 
check boxes.

When using shades be aware of the multiplicative effect of fill 
and colour: 50% fill of a colour which is defined as 20% black 
results in a 10% shade of gray.

Colours are defined in View > Color > Definitions…

Cell Margins from 
the Table designer This is the paragraph in the table 

cell with the properties from the 
paragraph designer.

Cell Margins from 
the Paragraph de-
signer.

top=0pt

top=6pt

Heading row(s)

The line above is the separator between body and heading Cell

Body ruling is set to «Every 2nd», Others: none

The non-shaded area is the body of the table

This is another row in this table

The line below is the separator between body and footing

Footing row(s)
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Note: Beware of the ‘reverse logic’ to remove settings! You need to 
check all elements which you want to clear and then use the 
selection None from the Apply Ruling Style list.

Reassign original table ruling and shading

Apply custom ruling Apply the custom ruling with Table > Custom Ruling and 
Shading. For example, remove the ruling from the inner cells 
with style None:

Reassign the original 
ruling

1 Select the same cells as for the custom ruling/shading or 
(if appropriate) the whole table.

2 In Table > Custom Ruling and Shading set To Selection 
(Top, … Right) and ‘Inside Borders’ (Row, Column).

3 From the drop down list Apply Ruling Style select From 
Table.

4 Check Custom Cell Ruling, uncheck Custom Cell Shading

5 Apply!

Re-assign the original 
shading

1 Perform steps 1 to 3 from before

4 Check Custom Cell Shading, uncheck Custom Cell Ruling

5 Apply!

Reset to catalogued table 
properties

1 Set all check boxes

2 In the drop-down lists select From Table

3 Apply!

Table ruling peculiarities

The size of a table or cell is the skeleton (···) on which the 
ruling is applied. A container text frame (- - -) with the table 
anchor does not crop the table, but the anchored frame (outer 
container) does. The table has 3mm ruling and its width is the 
same as the frame width (115mm).

Table anchor

skeleton (partially)
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Define line styles for tables

Line styles used in tables (fine, bold, double etc.) are set with 
Table > Custom Ruling & Shading, button Edit Ruling Style.

When changing the name of a style only rulings in the current 
document are affected. When importing table styles to 
another document, the changed name will become an addi-
tional name in the target document.

Provide meaningful names. It may be useful to add the line 
width to the name – but this creates problems if you need to 
change the properties of the line style.

It is not possible to create dashed lines or other broken 
forms. Use the Pen Pattern attribute to apply a fill percentage 
of a colour (for example, black) to the line.

Modify column widths

Copy column widths To copy a column width from table-1 to table-2:

1 Click in the column whose width you want to copy

2 Choose Edit > Copy Special > Table Column Width.

3 Click in the column in table-2 which will receive the new 
width. Paste!

4 For all columns in a table you will need to repeat steps 1 to 
3 for each column.

Adjust column width with 
mouse

Set a reasonable grid spacing (e.g. 0.1 cm) in View > 
Options

Set Graphics > Snap to activate the grid for your work

Select the column you want to adjust (e.g. CTRL+click into 
the middle of a cell); day a handle.

Note: To adjust to widths defined by the grid spacing you must start 
with the left most column and work to the right - or you get 
crude values.
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Functions in tables

Sort by columns and 
rows

Sorry, there is no undo for this function.

1 Place the cursor in the table

2 In Table > Sort … set the desired options; Sort!

Warning

A Table sort deletes all cross reference markers from the 
cells.

To overcome this problemedit all cross reference markers in 
the table to get a different type and re-edit them back after 
the sort.

1 Specify a user marker type wasxref

2 Edit the CrossRef markers in the table by changing the 
name Marker Type:

3 Sort the table.

4 Edit all wasxref markers back to CrossRef.

Calculations in tables FrameMaker does not provide calculations in tables. This can 
be performed by’plug-ins’:

FrameScript by Elmsoft (http://www.framescript.com/) is a 
full blown macro language which knows all FrameMaker 
commands. Scripts are located in a special directory.

Caxton Table tools (http://www.caxton-inc.com/
xtras.html) can, for example, calculate the sum in a table 
column. Unfortunately support for these tools is «discon-
tinued».

http://www.framescript.com/
http://www.caxton-inc.com/xtras.html
http://www.caxton-inc.com/xtras.html
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Special table positions

Table at top of page

To get a table at the top of a page,

1 Select the table (place cursor anywhere into the table)

2 Activate the table designer (Table > Table Designer)

3 Set Start to Top of Page

This will move the table to the next page and display it on 
top. The anchor of the table is left at the current paragraph.

Error in FrameMaker 6.0 If the table anchor is within a paragraph, and the table «Starts 
on top of page», then

The first part of the paragraph up to the line with the 
anchor is moved to the next page

The table is displayed on the next but one page, followed 
by the rest of the paragraph (which is correct).

Table at top of first page

Insert the table at the first paragraph of the first page

For the paragraph set Space Below to -font size (e.g. -14pt)

For the table set Space Above to -font size of the paragraph 
(e.g. -14pt)

Floating text around table

A table with attribute Float allows text from behind the table 
to flow between the anchor line and the table start:

Paragraph

This gray area is the text frame with the table located topmost.

Hecate est Iovis et Latonae filia, 
soror Apollinis. Est tricopor et 
triceses, cinctra latrantium canum 
turma; noctu stans in triviis vel 
prope sepulcra et ubi loca sunt 
caedibus contaminata.

Paragraph with table anchor

This text was typed behind the 
table, but flowed before it as soon 
as the table became the attribute 
Float. Text which does not fit in 

front of the table, will continue 
behind it, as this example clearly 
demonstates in this two column 
text flow.

First Next

first This table has the at-
tribute Float and the first 
row does not fit onto the 
first page.

second Hence

third viis vel prope sepulcra et 
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Set up a table template
Any table in a document can be used for a table template.

To define a table 
template from an 
existing table

Set up the table as desired for your purpose:

Widths of columns, paragraph format in the columns, heading 
and footing rows, regular ruling and shading etc. 

Keep in mind that certain properties (custom ruling and/or 
shading, straddling of cells – often used in headers – are not 
kept in the table catalogue.

1 Place the cursor in the table.

2 In the table designer (CTRL+T) set the table tag (the name 
of the table template), for example Invoice.

3 Select Commands: New Format.

4 Activate Store in Catalogue; Create!

Sophisticated table templates

For frequent use of sophisticated table layouts the mecha-
nism of the table catalogue is not sufficient (straddles cells, 
custom shading/ruling, various paragraph formats). 

It is handy, to collect such items for copy and paste in a spe-
cial document belonging to the project. 

Samples from the
Statistical Yearbooks of

the Canton of Lucerne

# Work type h CHF

The first item on this invoice

Next item on this invoice

Last item in this table

Table 2:

Invoice

In der Gemeinde wohnhafte Schüler/innen 2002/2003
Vorschule (Kindergarten) 16
Primarstufe 108
Sekundarstufe I (inkl. Gymn. U.-Stufe) 44

Ausbildungsniveau Wohnbevölkerung ab 15 Jahren (2000)
Obligatorische Schule 25,6 %
Berufsausbildung 41,1 %
Maturitätsschule, Lehrerausbildung 4,9 %
Höhere Berufsausbildung 10,0 %
Fachhochschule, Universität 3,6 %
Andere, keine, keine Angaben 14,8 %

Total Öffentlicher Auftraggeber (ohne Unterhaltsarbeiten)

Jahr Total Davon Davon

Bund Kanton Gmden Hochbau Tiefbau

1984 2,4 4,3 2,4 10.5 2,6 9,9 -2,7

1985 5,0 -1,6 -16,9 -9,2 13,7 -6,7 5,6

1986 7,2 7,4 -2,4 0,9 15,5 11.6 2,3

1987 -0,8 4,9 4,2 3,8 5,6 10,9 -3,1
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Importing tables

Import from prepared text

Each table row corresponds to a line in the text file.

Table cells are separated by TAB characters.

Beispiel einer zeile  nächste zelle  dritte zelle
Zweite zeile mit der  2. zelle 1 und der dritten zelle

1 File > Import > File... select Copy into Document.

2 In the dialogue Unknown File type select Text; Convert!

3 In the next dialogue (Import text by copy) select Convert to 
Table

4 Select the desired table format (e.g. Wide-h-rules) and acti-
vate Leave Heading Rows empty. Convert!

The table heading is empty, so you need to fill in appropri-
ate text.

You will need to adapt the column widths.

You may want to adapt the cell format with paragraph for-
mats.

Import from Excel

Import complete table 
(file)

1 Import the file by Copy with File > Import > File and select 
the appropriate Excel format (Excel is for versions > 5).

2 Set the appropriate formatting options for the import (e.g. 
Re-format using current Document Formats). 
You do not get a chance to define the table format!

3 Apply the desired formatting to the placed table.

Import part of table 1 In Excel select the table area and copy to the clipboard

2 In FrameMaker use Edit > Paste Special… and select text.

3 Convert the tabbed paragraphs to a table with Table > 
Convert to Table… 

4 Select an appropriate Table format and format the rows 
according to the needs.

Date / time Operation Reason Action

Wed 98-07-01 14:39:05 Starting

Wed 98-07-01 14:59:57 Testing Button colours Restart

Wed 98-07-01 15:00:48 Starting

Wed 98-07-01 15:10:30 Restart (inst) I don‘t like that colour scheme 
mentioned in FrameUsers 

Restart

Wed 98-07-01 15:11:44 Starting

Wed 98-07-01 16:13:44 Restart (inst) DDD icon in shell32.dll 
replacing Windows icon

Shut down
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Special operations

Merge tables

1 Save your work to have a backup for this operation.

2 Copy all the body rows from the second table (do not select 
the heading rows).

3 Click inside the first cell of the last row of the first table 
and Paste!

4 At this point Frame pops a Faster Rows dialogue asking 
where to paste the rows. and choose Insert Below Current 
Row.

5 Select the second table and delete it.

Split a table vertically

Method A To split a (source) table into two tables (see also Method B on 
page 4-13):

1 Save your work to have a backup for this operation.

2 Select the body rows to be used in the source table and 
copy them to the buffer. Paste this table fragment to the 
location of the second table part. A Table anchor with the 
table fragment appears.

3 Place the cursor into the first row of the new table and 
insert the desired number of heading rows (Table > Add 
Rows or Columns…). Specify the number of header rows 
to be added and choose To Heading from the drop down 
list. Add!

4 Copy the heading rows from the source table and paste 
them into the empty heading rows in the second table (set 
Replace Current Rows in the Paste Rows dialogue).

5 If the source table has Footing rows: Place the cursor into 
the last row of the new table and insert the desired number 
of footing rows (Table > Add Rows or Columns…). Copy 
the footing rows from the source table and paste them to 
the empty footing rows in the second table.

6 Select the copied body rows in the source table and delete 
them.

Heading row(s)

The non-shaded area is the body of the table cell

This is another row in this table - split above this row

The line below is the separator between body and footing

This is another row in this table - split above this row

The line below is the separator between body and footing

This is another row in this table - split above this row

The line below is the separator between body and footing
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Split wide table horizontally
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Method B FrameMaker does not have a command to split tables between 
rows or columns. 

If you need to insert some rows of different widths into a 
table, you need to ‘split’ the table manually, before you can 
insert table C in between (see Split a table vertically on 
page 4-12 for another method):

1 Make a copy of your table (A  B)

2 Remove the superfluous body rows at the end of A

3 Remove the superfluous body rows at the beginning of B

4 Anchor table A, then C, then B with the above mentioned 
spaces before or after.

Split wide table horizontally

Arrange the split table on facing pages. For tables longer than 
a page you will also need vertical splitting.

Page break within table row

FrameMaker does not split a row of a table across pages (text 
frames, actually). If you have cells where the content is larger 
than can fit on a page (in the text frame height) you will get 
strange effects:

The cell contents flows outside the text frame

If even larger, the cell extends to the end of the paper 
where it is cut off.

Solution Create a new row (or rows), manage the cell's content manu-
ally so you fit what you desire on a page, and let Frame man-
age the placement of rows on pages. You can apply custom 
ruling and/or shading properties as needed to affect the 
appearance of the cells.

A B C D E F G H

1

2

A B C D

1

2

E F G H

1

2
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Fix appearance of table title

The table title may expand over the right edge of a table (title 
area is filled with light gray to show it in print). 

To make the heading as wide as the table itself, use one of the 
following methods:

1 Add an anchored frame to the title to limit the space in the 
title area

2 Use additional header rows for the title area

Anchored frame in title 
area

At the end of the title add an anchored frame with property 
«Run into Paragraph» and an alignment fitting the purpose 
(filled with gray in this demonstration).

The alignment of the anchored frame may be «side farther 
from binding» rather than «right» to adapt automatically to 
the location of the table. You may need some experimenting 
for your particular situation.

Centred title constrains 
the title width

If the first paragraph in the title is centered, it will constrain 
the whole title to the width of the table. You could have a 
tiny, blank, centered paragraph in each title just above your 
normal, left-aligned title. [Rick Quatro, 2006-10].

Whether this is a bug or a feature is not known to the gurus.

Table 3: This is just a long table title to demonstrate
the effect on this centred table

Column 1 2 3

Some contents Some con-
tents

some con-
tents

Something Nothing Each

Table 4: This is just a long table ti-
tle to demonstrate the effect of 
the anchored frame

Column 1 2 3

Some contents Some con-
tents

some con-
tents

Something Nothing Each

Centered paragraph in title

Table title shaded for demon-
stration only to see the effect

The table is left aligned.

This paragraph is centered
Table 5: This is the real table title 
paragraph, it is left adjusted

Column 1 2 3

Some contents Some con-
tents

some con-
tents

Something Nothing Each
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Fix appearance of table title
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Title in header rows 1 Add a row on top of the heading rows.

2 Straddle all cells in this row

3 Insert the table title (using the correct ¶-format of table 
titles) into this row.

4 Space below is not active in cells with only one paragraph, 
hence you may wish to define and add a paragraph z6pt 
(line spacing 6pt fixed). A line break would show up in a 
«list of tables».

5 Remove any ruling on the top and sides of this row; also 
remove any shading to fit the appearance of standard 
tables.

6 Set table property «No Title». 

The table then looks like this:

Both table and title 
centred

If you want both the table centred in the text frame and also 
the table title be centred:

1 Define the table alignment to be centred

2 Define the table title ¶ format to be centred:

Table 6: This is just a long table 
title to demonstrate the effect

Column 1 2 3

Some contents Some con-
tents

some con-
tents

Something Nothing Everything

This is the body text with the table anchor at the end of this 
paragraph.

Table 7: This table title has attribute centred, so it will fill the entire 
width of the text frame.

This table is centered

Some contents Some con-
tents

some con-
tents

Something Nothing Each
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Rotate table cells

You can rotate only in increments of 90°. Rotate slected table 
cells with Graphics > Rotate or use the buttons .

You may select the whole table – this will not rotate the table, 
but all cells in the table.

Line breaking in rotated 
cells

Since the line length is in the direction of the row height, line 
breaking will take place only in ‘constricted’ rows. As long as 
no row height is defined, a default applies – and this is very 
large: 35.56 cm (14").

Rotated tables

To get a rotated table you must rotate the text frame which 
contains the table. Just rotating the table will only rotate the 
cells in it (see Rotate table cells on page 4-16).

Create a rotated master 
page

This method creates a landscape text area in which the table 
can be edited as usual, because the table is not rotated.

1 In View > Master Pages use Special > Add Master Page: 
use a master page which provides the desired heading and 
footing, for example ‘left’ and modify the page as needed. 
See Master pages for rotated tables on page 5-21

2 Apply this master page to any desired page with Format > 
Page Layout > Master Page Usage.

3 To automate the process see Assign master pages automati-
cally on page 5-22.

Develop large tables

Using an ancillary large document may be handy to find out 
the appropriate layout of large tables:

Set up a large document, for example in A3 portrait (42cm 
wide, 29.7cm high)
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Develop your table in this document using your standard 
paragraph formats (import them into this document).

After work the table may be to large to fit even into a 
rotated frame of an A4 portrait.

To check whether the table will fit into the target docu-
ment, place a vertical line at the desired location from the 
left. Then start with the tweaking:

- Reduce the font size of your paragraphs in the table. Do 
not use smaller sizes than 7pt for sans serif fonts (such as 
Arial or Helvetica) or 8pt for serif fonts (such as Times).

- Reduce the width of certain or all columns

- As a last resort consider splitting the table horizontally. 
In this case you will need to repeat at least the leftmost 
column in the second table. See Split wide table horizon-
tally on page 4-13

Tables with varying column widths

In a FrameMaker table all cells of a column have the same 
width. Straddled (combined) cells of fine granularity may 
allow to ‘display’ different widths (see Simulated nested table 
on page 4-18).

Another method combines two or even more tables :

The first table (A) has 5 columns, the second table (C) has 7 
and the third table (B) again has 5 columns. The Anchor 
position of all of these tables is at the end of the paragraph 
before the table (symbolized by  in that paragraph).

The first (A) and second (C) table have Space Below of 0.

The second (C) and third (B) table have Space Above of 0.

To select each anchor individually (for A, B or C) you need 
a special technique (see Select a non-width character (or nar-
row characters) on page A-17).
You may wish to select a distinct table by CTRL+triple-
click into one of its cells (see Handling table items on 
page 3).

A

A

C

C

B

B
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Nested tables
It is possible to nest tables, that is, to place another table 
within a cell of a table. But this requires two additional wrap-
pers:

Within the table cell an anchored frame must be placed

Within the anchored frame a text frame is opened

Within the text frame anything can be placed (text, table, 
anchored frame etc.)

Nested tables

Note: If the elements are highly nested (no space around the inner 
element of a nest) it will be very difficult to select and change 
them.

Simulated nested table With straddles in a fine grained table you can simulate a table 
in a table. This example started with an 8 x 8 table. This fine 
grain is only left in the centre area. Other areas are straddled:



Page layout

Overview

This chapter describes the ‘layers’ of a FrameMaker 
document: body pages, master pages and reference 
pages.

The building blocks of layout are text frames and 
graphic frames. The text frames on the master pag-
es are of two types: background frames (for headers 
and footers) and the foreground frames which re-
ceive the user input. Graphic frames are also used 
on the reference pages.

Any FrameMaker document can be a template to 
create new documents. The behaviour (un-named 
copy) of a standard template is just determined by 
the location of the file.

Contents

Layout terminology .................................................  2

Layout mechanisms ................................................  3

Columns, text flows and side headings ....................  6

Newsletter layouts ..................................................  7

Frame types ...........................................................  8

Running headers and footers .................................  13

Templates ............................................................  16

Sample template ...................................................  19

Handling master pages .........................................  22
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Layout terminology
Typography has a 500 year history and hence some terms 
may sound old-fashioned. Some have their roots in latin. 

See also Columns vs text flows on page 5-6

Structure of a FrameMaker document

A FrameMaker document contains three levels of information:

Body pages In these pages the running text is placed 
with tables and graphics anchored in the 
text.

Master pages These pages define the layout which is 
used in the body pages. There is always a 
masturbate Right. A Left page is present 
for documents defined to be double sided.

Reference pages These pages contain graphic elements for 
attachment to paragraphs as well as rules 
about construction a table of contents, an 
index or other generated documents.

Maximilian 
secondo

Rosa planta est. 
Maximilian canis est Iovis 
et Latonae filia, soror 
Apollinis. Est tricopor et 
triceps, magicarum artium 
magistra ac 
fascinationum. 

Homunculus
Lupus animalis est cinctra 
latrantium canum turma; 
noctu stans in triviis vel 
prope sepulcra et ubi loca 
sunt caedibus 

16 - 7

Hector Hector canis est Iovis et 
Latonae filia, soror 
Apollinis. Est tricopor et 
triceps, magicarum artium 
magistra ac 
fascinationum. Rosa 
planta est.

Lupus Lupus animalis est cinctra 
latrantium canum turma; 
noctu stans in triviis vel 
prope sepulcra et ubi loca 
sunt caedibus 
contaminata. vel illum 
dolore eu feugiat nulla 
facilisis at vero eros et 
accumsan nulla facilisis at 
vero eros et accumsan

Maximilian prima vista Homunculus

 E:\handout\design.fm16 - 6

Header (kopf)

Running head-
ing (lebender 
kolumnentitel)

Text frame (satz-
spiegel umfasst 
auch den kolum-
nentitel, nicht 
aber die paginie-
rung)

Heading across 
all columns and 
side headings

Heading 
(überschrift) in 
text column

Footer (fuss)

Pagination 
(paginierung, sei-
ten-numerierung)

Side heading (marginalie)

Top margin (kopfsteg)

Inner margin (bundsteg)

Outer margin (aussen-steg)

Bottom margin (fuss-steg)

Text frame: position on page 
and size define margins

Background frame (con-
tents defined in master 
page)
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Layout mechanisms

Page types

Body pages are the main working area for entering and 
editing text, graphics etc.

Heading/footing frames can not be changed on the body 
pages  use different master pages.

Reference pages serve various purposes: rules for building 
TOC or Index, graphic elements, rules for arbitrary lists 
etc.

Title 
Page

Footing

Heading

Footing

Heading

Footing

Heading

Writing into 
connected 
text frames 
automaticall
y continues 
on the next 

body pages

Dokument seiten

master pages

Vorgabe seiten

reference pages

Referenz seiten
Footnote

Long line

Graphic-1

disconnected connected

Title Left

Footing

Heading

Right

page and 
requests 
new empty 
pages from 
the Right/

Footing

Heading

Left set of 
masterpages

Other 
masterpages 
such as Title 
must be 

manually assigned automatically assigned

<$paratext> <$page-
num>
<$paratext> <$page-
num>
<$paratext> <$page-
num>
openObjectId <$relf-
ilename>:<$Object-
Type> <$ObjectId>

Reference TOC

F
o

o
tin

g

H
e
a
d

in
g

Rotated

connected
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Flows and frames

Text frames are connected together to form one text flow.

To connect text frames:
Format > Customize layout > Connect text frames

The paper (page)

Header frame 
bound to page

Text frame(s) 
connected) bound 
to page

Anchored ( ) 
frames float with 
the text

Graphic frame 
bound to page

Text frame within 
graphic frame

Text frame on 
page

Footer frame 
bound to page

TT

This a flow A

This text flow extends from 
this text frame to the one on 
the right – these text frames 
are connected.

vires humus fallo 25deu 
Anetn bisre freun carmi avire 
ingen umque miher muner 
veris adest duner veris adest 
iteru quevi escit billo isput 
tatqu aliqu diams bipos 
itopu 50sta Isant oscul bifid 
mquec cumen berra etmii 
pyren nsomn anoct reern 
oncit quqar anofe ventm 
hipec oramo uetfu orets 
nitus sacer tusag teliu ipsev 
75tvi Eonei elaur plica oscri 
eseli sipse enitu ammih 
mensl quidi aptat rinar uacae 
ierqu vagas ubesc rpore ibere 
perqu umbra perqu antra 
erorp netra 100at mihif 
napat ntint riora intui urque 
nimus otoqu cagat rolym 

oecfu iunto ulosa tarac 
ecame suidt mande onatd 
stent spiri usore idpar sep 
pretu tempu rev tenov sindu 
turqu brevt elliu repar tiuve 
tamia queso utage udulc 
vires humus 150eu uAnetn5 

bisre freun is adest nihi 
multi culti malenka dolce.

Anchored frame, 
flows with text
Graphic text - no para
styles, only character
styles.

This is flow B

ueso utage udulc vires humus fallo 25deu Anetn bisre freun 
carmi avire ingen umque miher muner veris adest duner veris 
adest iteru quevi escit billo isput tatqu tmii pyren nsomn 
anoct reern oncit quqar anofe ventm hipec oramo uetfu orets 
nitus sacer tusag teliu ipsev 75tvi oscri eseli sipse enitu 
ammih mensl quidi aptat rinar uacanetra 100at mihif napat 
ntint riora intui urque nimus otoqu cagat rolym oecfu iunto 
ulosa tarac ecame suidt man

Header frames are not visible on the body pages - can not be grabbed

Footer frames are not visible on the body pages - can not be grabbed

Text frame 
in a graphic 
frame with 
paragraph 

The paper (page)

Header frame 
bound to page

Text frame(s) 
connected) bound 
to page

Anchored ( ) 
frames float with 
the text

Graphic frame 
bound to page

Text frame within 
graphic frame

Text frame on 
page

Footer frame 
bound to page

TT
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Master page usage

Assignment of master 
pages

For ordinary pages the masturbates Right and Left are 
assigned automatically. Other master pages are assigned with 
Format > Page Layout > Master Page Usage... 

To assign a master page automatically plug-ins are available 
which perform this assignment based on a paragraph format.

Chapter 2:

Body pages

A

B

The title is vital

LeftTitle

Area for chapter title: either small to let only the chapter title 
go in (and text automatically flows to next page) or «space 
below» is larger than height of frame.
Key point: same flow tag (A) as the body text!

Text flow Paragraph for-
mat

Comments

A (connected) Heading1 etc. Main text flow

A (connected) Chapter-title Title area 

B (unconnected) Overview Can not be reached by cross-references

Table 1: Text flow properties in a chapter

Chapter 2:

Master pages References in same document

Was sind Pferdestärken?
Um die Leistung zu bestim-
men, die Dampfmaschine 
haben sollte, liess der 
schlaue Brauer sein stärkstes 
Pferd acht Stunden am Pump-
werk arbeiten. Das arme Tier 
wurde mit der Peitsche ange-
trieben und fast zu Tode 
gequält. Unter grösster Kraft-
anstrengung gelang es dem 
Pferd, in acht Stunden rund 
zwei Millionen Kilogramm 
Wasser in die Höhe zu pum-
pen. Aus der Höhe, um die 
Wassermenge gehoben 

wurde und der Anzahl Stun-
den ergab sich dann, dass 
das Pferd in jeder Sekunde 
etwa 70 Kilogramm Wasser 1 
Meter hoch gefördert hatte. 
Der Brauer stellte dement-
sprechend James Watt die 
Bedingung, die Dampfma-
schine müsse in jeder 
Sekunde finde-stets 70 Kilo-
gramm Wasser 1 Meter hoch 
pumpen. 

Right

A A

Background text frame 
for Running header/
footer

Text frame with named 
text flow (editable in 
body page)

Rotated background 
text frame

Background text frame 
for Running header/
footer

Was sind Pferdestärken?The title is vital

Chapter 2

Running H/F 2Running H/F 1

Running H/F 3
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Columns, text flows and side headings

Columns vs text flows

Side heads

Lorem ipsum dolor 
sit amet, 
consectetuer 
adipiscing elit, sed 
diam nonummy 
nibh euismod 
tincidunt ut laoreet 
dolore magna 
aliquam erat 
volutpat. Ut wisi 
enim ad minim 
veniam, quis 
nostrud exerci 
tation ullamcorper 
suscipit lobortis 
nisl ut aliquip ex ea 
commodo 
consequat. Duis 
autem vel eum 
iriure dolor in 
hendrerit in 
vulputate velit esse 
molestie consequat, 
vel illum dolore eu 

feugiat nulla 
facilisis at vero eros 
et accumsan et 
iusto odio 
dignissim qui 
blandit praesent 
luptatum zzril 
delenit augue duis 
dolore te feugait 
nulla facilisi. Et tam 
neque pecun modut 
est neque nonor et 
imper ned libidig 
met, consectetur 
adipiscing elit, sed 
ut labore et dolore 
magna aliquam 
makes one wonder 
who would ever 
read this stuff? Bis 
nostrud 
exercitation ullam 
mmodo consequet. 
Duis aute in 

column width

A
Hectic est Iovis et 
Latonae filia, 
soror Apollinis. 
Est tricopor et 
triceps, 
magicarum artium 
magistra ac 
fascinationum 
praeses, cinctra 
latrantium canum 
turma; noctu 
stans in triviis vel 
prope sepulcra et 
ubi loca sunt 
caedibus 
contaminata.

B

Hecate est Iovis et 
Latonae filia, 
soror Apollinis. 
Est tricopor et 
triceps, 
magicarum artium 
magistra ac 
fascinationum 
praeses, cinctra 
latrantium canum 
turma; noctu 
stans in triviis vel 
prope sepulcra et 
ubi loca sunt 
caedibus 
contaminata.

1 text flow 
with 2 col-

2 text flows
with 1 column

Hector Hector canis est Iovis et 
Latonae filia, soror 
Apollinis. Est tricopor et 
triceps, magicarum 
artium magistra ac 
fascinationum. Rosa 
planta est.

Lupus Lupus animalis est cinctra 
latrantium canum turma; 
noctu stans in triviis vel 
prope sepulcra et ubi loca 
sunt caedibus 
contaminata. vel illum 
dolore eu feugiat nulla 
facilisis at vero eros et 
accumsan nulla facilisis at 
vero eros et accumsan

Hector Hector canis 
est Iovis et 
Latonae filia, 
soror 
Apollinis. Est 
tricopor et 
triceps, 
magicarum 
artium magi-
stra ac 
fascinationu
m Duis 
autem vel 
eum iriure 

dolor in 
hendrerit 
in 
vulputate 
velit esse 
molestie 
consequa
t, vel 
illum 
dolore eu 
feugiat 
nulla 
facilisis at 
vero eros

Lupus Lupus 
animalis est 
latrantium 
canum 
turma; noctu 
stans in 
triviis vel 
prope 
sepulcra et 

ubi loca sunt 
contaminata
.

Side head area (D: marginalien-spalte)

gap

1 text flow with
2 columns and
side head area

1 text flow with 
1 column and 
side head area
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Newsletter layouts
For newsletters and the like you want to have various text 
areas to fill in. You may use for this purpose:

Distinct text frames with independent flow names. This is 
useful to start a story on page 1 and finish it on page 2 
while other stories are also on page 1. The two pieces must 
be connected together:

Various text frames with the same flow (A or none), con-
nected in an arbitrary order.

Connecting text frames 1 Select the first text frame

2 Select the second text frame (the first may become unse-
lected, but this does not harm)

3 Connect the frames with Format > Customize Layout > 
Connect Text frames. Text will overflow automatically 
from the first to the second frame.

4 Repeat this for all the frames to be connected. 1  2, 2  3, 
3  4 …

Text in frame 1 with 
flow name A (or no 
flow name at all)

Text in frame 2 with 
flow name A (or also 
no flow name) . The 
frames 1 and 2 are 
connected.

Start on 
page 1 in 
frame I 
which is 
con-
nected to 
frame II

This is 
frame II

This is 
frame III

This is 
frame IV

The first para 
must «start 
on top of col-
umn» or it 
will just flow 
…

Einen 
so heißen 
Sommer, wie 
nun vor 
hundert 
Jahren, hat 
es seitdem 
nicht wieder 
gegeben. 
Kein Grün 

dicke 
Wiesenbauer 
stand 
breitspurig 
in der 
Torfahrt 
seines 
stattlichen 

Hauses und 
rauchte im 
Schweiße 
seines 
Angesichts 
aus seinem 
großen 
Meerschaum
kopfe. Dabei 
schaute er 
schmunzeln
d einem 

fast war zu 
sehen; 
zahmes und 
wildes Getier 
lag 

verschmachtet auf 
den Feldern.

Es war an 
einem Vormittag. 
Die Dorfstraßen 
standen leer; wer 
nur konnte, war ins 
Innerste der Häuser 
geflüchtet; selbst 
die Dorfkläffer 
hatten sich 
verkrochen. Nur der 
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Frame types
Frames are ‘the name of the game’ – a main concept of Frame-
Maker. Frames enclose other objects. On the raw paper you 
can place graphic objects, such as text frames or graphic 
frames or rectangles. A text frame contains text which can 
contain anchor points for anchored objects, such as tables or 
anchored frames. Within an anchored frame any graphic 
object can be placed. Graphic objects have no anchor.

Text Frames

Normally you use text frames on master pages. Text frames 
can, however, also be used as graphic elements. In this case 
the text frame is located inside an anchored frame which 
floats with the surrounding text:

Insert a text frame Insert a text frame with the tool  from the Graphic Tool Pal-
ette by dragging the mouse. This tool is not the largest tool in 
the middle of Palette! You can set the number of columns and 
the gap between the columns after releasing the mouse.

After inserting, more attributes are set with Graphics > 
Object Properties… or button . The most important prop-
erties are about the text flow: tag name and auto connection.

Flow tag (flow name) The main flow on master pages normally is named A. The 
name can be any upper or lower case character. Cross refer-
ences operate only within, not across named flows. You can 
not reference an item in flow B from flow A.

A text frames within an anchored frame gets no flow name 
initially. Text frames placed in master pages are background 
frames with no flow name by default.

Auto connection

A text flow with a flow name (flow tag) automatically gets the 
property auto connect ON. This is the standard for text 
frames on the master pages where you want this automatism 
to happen. If this property is not set, you will not get addi-
tional pages automatically for more text.

Note: When switching from Master Page view to Body Page view, in 
rare occasions this attribute Auto connect may be lost and you 
need to re-apply it while on the Body Page.

Side heads

If you want to specify headings or other text to appear in a 
side head area, specify the needed properties in Graphics > 
Object Properties… or button . In the document you are 
reading the values are as displayed in the image.

See also Pagination on page 3-5 for the various heading styles 
possible in FrameMaker.

Note: The flag Room for Side Heads is a property of the text flow. 
Hence it is not imported with the master pages. It may be nec-
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essary to set this attribute again after switching to body page 
display.

Multiple columns

To specify multiple columns for a text frame (or change the 
initial setting) use Graphics > Object Properties… or button 

. 

If you also have specified Room For Side Heads the columns 
are established in the rest of the text frame. This may create 
too narrow columns (see).Columns vs text flows on page 5-6

Border and fill of text 
frame

Apply a border: Select the text frame

Apply a line with the graphic tool Apply Pen Style

Fill the frame with
colour:

Select the text frame

Fill the frame with the graphic tool Apply Fill Style

Example of text frames in 
anchored frame

The following anchored frame has a border

Note: The topmost line of text in a frame may extend beyond the 
boundary of the frame depending of the font metrics (enlarge 
the above image to see the effect). In particular, accents 
always extend to the outer area. See also Default cell margins 
on page 4-5.

Anchored frames

Anchoring position Depending on the anchoring position, additional parameters 
can be set.

Cropped If set the frame is cropped by the outer container. 
Most time this outer container is the text frame 
with the anchor.

Floating Set this option to allow text lines after the anchor 
to sneak before the frame, which is placed on the 
next page if its size requires.

In the following diagrams the bordered rectangle is the text 
frame with the text flow containing the anchored frame (the 
outer container).

This is text within a text 
frame

This text frame was cre-
ated with the graphic 
tool Text Frame

In this text frame all 
paragraph formats, 
character formats and 
table formats can be 
used as in the main text 
frame.

This is another text 
frame within the same 
anchored frame.

This has no border but 
is filled with 5% gray 
(border and fill can only 
have the same colour in 
FrameMaker)

This is text within a text 
frame

This text frame was cre-
ated with the graphic 
tool Text Frame.

In this text frame all 
paragraph formats, 
character formats and 
table formats can be 
used as in the main text 
frame.
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Below current line Alignment of the frame left, centre and right

At top of column Alignment of the frame left, centre and right

At bottom of column Alignment of the frame left, centre and right

At insertion point Distance above baseline varying

Outside column Distance above baseline varying, also distance to text frame

Hecate est Iovis et Latonae filia, 
soror Apollinis. Est tricopor et 
triceps, magicarum artium 
magistra ac fascinationum 
praeses, cinctra latrantium canum 
turma; noctu stans in tr iviis 

vel prope sepulcra et ubi loca sunt 
caedibus contaminata. Hecate est 
Iovis et Latonae filia, soror 
Apollinis. Est tricopor et triceps, 
magicarum artium magistra ac 
fascinationum praeses, cinctra 
latrantium canum turma; noctu 
stans in triviis vel prope sepulcra 

Hecate est Iovis et Latonae filia, 
soror Apollinis. Est tricopor et 
triceps, magicarum artium 
magistra ac fascinationum 
praeses, cinctra latrantium canum 
turma; noctu stans in tr iviis 

vel prope sepulcra et ubi loca sunt 
caedibus contaminata. Hecate est 
Iovis et Latonae filia, soror 
Apollinis. Est tricopor et triceps, 
magicarum artium magistra ac 
fascinationum praeses, cinctra 
latrantium canum turma; noctu 
stans in triviis vel prope sepulcra 

Hecate est Iovis et Latonae filia, 
soror Apollinis. Est tricopor et 
triceps, magicarum artium 
magistra ac fascinationum 
praeses, cinctra latrantium canum 
turma; noctu stans in tr iviis 

vel prope sepulcra et ubi loca sunt 
caedibus contaminata. Hecate est 
Iovis et Latonae filia, soror 
Apollinis. Est tricopor et triceps, 
magicarum artium magistra ac 
fascinationum praeses, cinctra 
latrantium canum turma; noctu 
stans in triviis vel prope sepulcra 

Hecate est Iovis et Latonae filia, 
soror Apollinis. Est tricopor et 
triceps, magicarum artium 
magistra ac fascinationum 
praeses, cinctra latrantium canum 
turma; noctu stans in tr iviis 
vel prope sepulcra et ubi loca sunt 
caedibus contaminata. Hecate est 
Iovis et Latonae filia, soror 
Apollinis. Est tricopor et triceps, 
magicarum artium magistra ac 
fascinationum praeses, cinctra 
latrantium canum turma; noctu 
stans in triviis vel prope sepulcra 

Hecate est Iovis et Latonae filia, 
soror Apollinis. Est tricopor et 
triceps, magicarum artium 
magistra ac fascinationum 
praeses, cinctra latrantium canum 
turma; noctu stans in tr iviis 
vel prope sepulcra et ubi loca sunt 
caedibus contaminata. Hecate est 
Iovis et Latonae filia, soror 
Apollinis. Est tricopor et triceps, 
magicarum artium magistra ac 
fascinationum praeses, cinctra 
latrantium canum turma; noctu 
stans in triviis vel prope sepulcra 

Hecate est Iovis et Latonae filia, 
soror Apollinis. Est tricopor et 
triceps, magicarum artium 
magistra ac fascinationum 
praeses, cinctra latrantium canum 
turma; noctu stans in tr iviis 
vel prope sepulcra et ubi loca sunt 
caedibus contaminata. Hecate est 
Iovis et Latonae filia, soror 
Apollinis. Est tricopor et triceps, 
magicarum artium magistra ac 
fascinationum praeses, cinctra 
latrantium canum turma; noctu 
stans in triviis vel prope sepulcra 

Hecate est Iovis et Latonae filia, 
soror Apollinis. Est tricopor et 
triceps, magicarum artium 
magistra ac fascinationum 
praeses, cinctra latrantium canum 
turma; noctu stans in tr iviis 
vel prope sepulcra et ubi loca sunt 
caedibus contaminata. Hecate est 
Iovis et Latonae filia, soror 
Apollinis. Est tricopor et triceps, 
magicarum artium magistra ac 
fascinationum praeses, cinctra 
latrantium canum turma; noctu 
stans in triviis vel prope sepulcra 
et ubi loca sunt caedibus 

Hecate est Iovis et Latonae filia, 
soror Apollinis. Est tricopor et 
triceps, magicarum artium 
magistra ac fascinationum 
praeses, cinctra latrantium canum 
turma; noctu stans in tr iviis 
vel prope sepulcra et ubi loca sunt 
caedibus contaminata. Hecate est 
Iovis et Latonae filia, soror 
Apollinis. Est tricopor et triceps, 
magicarum artium magistra ac 
fascinationum praeses, cinctra 
latrantium canum turma; noctu 
stans in triviis vel prope sepulcra 
et ubi loca sunt caedibus 

Hecate est Iovis et Latonae filia, 
soror Apollinis. Est tricopor et 
triceps, magicarum artium 
magistra ac fascinationum 
praeses, cinctra latrantium canum 
turma; noctu stans in tr iviis 
vel prope sepulcra et ubi loca sunt 
caedibus contaminata. Hecate est 
Iovis et Latonae filia, soror 
Apollinis. Est tricopor et triceps, 
magicarum artium magistra ac 
fascinationum praeses, cinctra 
latrantium canum turma; noctu 
stans in triviis vel prope sepulcra 
et ubi loca sunt caedibus 

Hecate est Iovis et Latonae filia, 
soror Apollinis. Est tricopor et 
triceps, magicarum artium 
magistra ac fascinationum 
praeses, cinctra latrantium canum 
turma; noctu stans in 

tr iviis vel prope 

sepulcra et ubi loca sunt caedibus 
contaminata. Hecate est Iovis et 
Latonae filia, soror Apollinis. Est 
tricopor et triceps, magicarum 
artium magistra ac fascinationum 
praeses, cinctra latrantium canum 
turma; noctu stans in triviis vel 

Hecate est Iovis et Latonae filia, 
soror Apollinis. Est tricopor et 
triceps, magicarum artium 
magistra ac fascinationum 
praeses, cinctra latrantium canum 
turma; noctu stans in 
tr iviis vel prope 
sepulcra et ubi loca sunt caedibus 
contaminata. Hecate est Iovis et 
Latonae filia, soror Apollinis. Est 
tricopor et triceps, magicarum 
artium magistra ac fascinationum 
praeses, cinctra latrantium canum 
turma; noctu stans in triviis vel 
prope sepulcra et ubi loca sunt 
caedibus contaminata.

Hecate est Iovis et Latonae filia, 
soror Apollinis. Est tricopor et 
triceps, magicarum artium 

0 cm

Distance above = 
-0.5 cm

Frame can be 
moved with mouse 
only vertically.
Left example: ¶ 
has flexible line 
height.

Hecate est Iovis et 
Latonae filia, soror

Apollinis Est tricopor et 
triceps, magicarum 
artium magistra ac 
fascinationum 
praeses, cinctra 
latrantium canum 
turma; noctu stans 
in tr iviis vel 
prope sepulcra et 
ubi loca sunt 
caedibus conta

minata. 
Heca

te est Iovis et 
Latonae filia, soror 
Apollinis. Est 
tricopor et triceps, 
magicarum artium 
magistra ac 

Hecate est Iovis et 
Latonae filia, soror

Apollinis Est tricopor et 
triceps, magicarum 
artium magistra ac 
fascinationum 
praeses, cinctra 
latrantium canum 
turma; noctu stans 
in tr iviis vel 
prope sepulcra et 
ubi loca sunt 
caedibus 
contaminata. Hecate 
est Iovis et Latonae 
filia, soror Apollinis. 
Est tricopor et 
triceps, magicarum 
artium magistra ac 

0 cm

Distance above = 
-0.5 cm; distance 
to text frame = 0.3 
cm

Frame can be 
moved with mouse 
in 2 directions.
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Outside text frame Distance above baseline varying, also distance to text frame

Run into paragraph Distance above baseline varying, also distance to text frame

Note: The anchors () are visible here by using a special font.

Manipulating frames

Selecting frame CTRL+click on the border of the frame or change cursor to a 
hollow triangle on the graphic tool bar (see Tool palette on 
page 1-8).

Note: Do not move the mouse when CTL-clicking. You will create a 
duplicate of the object! (see Ghost objects on page A-26).
Be aware, that you can not select text with the cursor for 
selecting objects! You need to change the cursor back for text 
editing work.

Resizing frame A selected frame displays 8 handles on which it can be 
resized in one or two dimensions. You can also resize 
anchored frames numerically with Special > Anchored Frame 
or any type of frame with Graphics > Object Properties.

Moving anchored frame If an anchored frame has numbered values for positioning 
attributes, such as Distance above Baseline, the frame can be 
moved with the mouse in the corresponding direction. In this 
case it can also be moved in small increments with an 
ALT+arrow key.

Graphic frames

Graphic frames are just containers for other graphic objects 
and allow to crop these at the frame border. These frames are 
placed directly on the page – not floating in the text. If the 
graphic frame is created inside a text frame, it lays above the 
text. If it is created starting outside a text frame (e.g. close to 
the page border) it lays behind the text.

I recommend to use graphic frames only on master pages, ref-
erence pages or within anchored frames.

Hecate est Iovis et 
Latonae filia, soror

Apollinis Est tricopor et 
triceps, magicarum 
artium magistra ac 
fascinationum 
praeses, cinctra 
latrantium canum 
turma; noctu stans 
in tr iviis vel 
prope sepulcra et 
ubi loca sunt 
caedibus conta

minata. Hecate est Iovis et 
Latonae filia, soror 
Apollinis. Est 
tricopor et triceps, 
magicarum artium 
magistra ac 

Hecate est Iovis et 
Latonae filia, soror

Apollinis Est tricopor et 
triceps, magicarum 
artium magistra ac 
fascinationum 
praeses, cinctra 
latrantium canum 
turma; noctu stans 
in tr iviis vel 
prope sepulcra et 
ubi loca sunt 
caedibus

contami nata. Hecate est 
Iovis et Latonae filia, 
soror Apollinis. Est 
tricopor et triceps, 
magicarum artium 
magistra ac 

0 cm

Distance above: 
-0.5 cm; distance 
to text frame = 0.3 
cm

Frame can be 
moved with mouse 
in 2 directions.

Hecate est Iovis et Latonae filia, 
soror Apollinis. Est tricopor et 
triceps, magicarum artium 
magistra ac fascinationum 
praeses, cinctra latrantium canum 
turma; noctu stans in triviis vel 
prope sepulcra et ubi loca sunt 
caedibus conta

Hecate est 
Iovis et Latonae 
filia, soror 
Apollinis. Est 
tricopor et triceps, 
magicarum artium 
magistra ac 
fascinationum praeses, cinctra 
latrantium canum turma; noctu 
stans in triviis vel prope sepulcra 
et ubi loca sunt caedibus 

Hecate est Iovis et Latonae filia, 
soror Apollinis. Est tricopor et 
triceps, magicarum artium 
magistra ac fascinationum 
praeses, cinctra latrantium canum 
turma; noct stans in trviis vel 
prope sepulcra et ubi loca sunt 
caedibus contami nata. 

 iHecate est 
Iovis et Latonae 
filia, soror 
Apollinis. Est 
tricopor et triceps, 
magicarum artium 
magistra ac 

fascinationum praeses, cinctra 
latrantium canum turma; noctu 
stans in triviis vel prope sepulcra 
et ubi loca sunt caedibus 

Gap (distance to text) = 4pt.

Alignment can be:

Side farther from binding

Side closer to binding

Left

Right
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Insert a graphic frame You insert a graphic frame with the (largest) tool from the 
middle of the Tool Palette  by dragging the mouse.

The coloured area underneath this and the following para-
graphs is a graphic frame, filled, moved to background, no 
run around (Graphics > Runaround properties).

Note: If you copy (or cut) the graphic frame and paste it to an other 
page with a cursor position, it becomes an anchored frame. 
You need to click outside the text frame before pasting to posi-
tion the frame on the paper.

Graphic frames in background can not be selected the normal 
way. You need to open a selecting rectangle from outside the 
main text frame (see Concealed objects on page A-26).

Graphic frames on 
Reference Page

The main purpose of graphics on reference frames are their 
use in the paragraph specification Frame Above/Below (see 
Advanced on page 3-7). 

See Special formatting on page 3-16 for background colour and 
or framing of paragraphs.

When inserting a graphic frame on a reference page, you must 
provide a name for the frame.

On the reference frame of this document (Reference) the fol-
lowing items are defined (truncated to the right). The graphic 
frames are shaded here for visibility only.:

Note: See the ztf-table-footnote frame here. It is empty, hence defines 
only space for the distance between table bottom and the table 
footnote.

zfn-footnote

Single Line

Double Line

ztf-table-footnote

ze-editors-note
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Running headers and footers
Running headers and footers pick up contents from the cur-
rent page or one of the previous pages.

The information to be placed is defined by system variables 
which are only available on master pages. For a complete list 
see Building blocks for system variables on page 7-4.

FrameMaker 7 provides 12 system variables for running head-
ers or footers for reference to paragraphs or to markers (until 
version 6 there were only 4 such variables). Other system var-
iables provide numbering properties and date and time infor-
mation.

Insert a system variable

To insert a system variable into the text frame on the master 
page:

Special > Variable…

Select the appropriate variable and modify its presentation 
according to your needs.

Numbering properties

You can insert the following numbering properties of the cur-
rent document:

The display of these numbers depend on the settings in For-
mat > Document > Numbering.

The correct values displayed in the body pages depend on the 
proper updating of the numbering. See Set up numbering of 
chapter files on page 8-6.

Purpose Format of variable Example of use (format)

Current page number (represented as #) <$curpagenum> Page <$curpagenum> of 
<$lastpagenum>Last page number in file <$lastpagenum>

Chapter number <$chapnum> Chapter <$chapnum>

Volume number <$volnum> Volume <$volnum>
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Reference to headings

The most common contents of headers are references to 
headings in the text. From a paragraph you can get the num-
bering information and/or the text.

There are cases where you need to set up a list of ¶-formats 
for reference. Assume the left page should always display 
information from a 1heading, 2heading or 3heading, which-
ever is closest to the reference: The proper format for this is:

<$paratext[1heading,2heading,3heading]>

If on the current page a 1heading is found, it is placed in the 
running header. If not, FM searches for a 2heading on the cur-
rent page and then for a 3heading. If none of these is found 
on the current page, the previous page is inspected etc.

Note: Character styles may not completely be transferred to the run-
ning heading. See Character styles in building blocks on 
page 3-12.

Purpose Format of variable Example of use

text of referenced paragraph type <$paratext[paratype]> <$paratext[2heading]>

numbering of referenced paragraph type <$paranum[paratype]> <$paranum[th-table-head]>

counter value of reference paragraph type <$paranumonly[paratype]> <$paranumonly[th-table-head]>

First evel 2 heading 1

E:
\F

M
-c

o
u

rs
e\

in
se

ts
\r

u
n

n
in

g
H

F-
1

.f
m

 
2

0
0

6
-0

8
-2

5

R

Level 1 heading on page 1
Hecate est Iovis et Latonae filia, soror Apollinis. Est tricopor 
et triceps, magicarum artium magistra ac fascinationum 
praeses, cinctra latrantium canum turma; noctu stans in triv-
iis vel prope sepulcra et ubi loca sunt caedibus contaminata.

First evel 2 heading 
Hecate est Iovis et Latonae filia, soror Apollinis. Est tricopor 
et triceps, magicarum artium magistra ac fascinationum 
praeses, cinctra latrantium canum turma; noctu stans in triv-
iis vel prope sepulcra et ubi loca sunt caedibus contaminata.

Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed 
diam nonummy nibh euismod tincidunt ut laoreet dolore 
magna aliquam erat volutpat. Ut wisi enim ad minim veniam, 
quis nostrud exerci tation ullamcorper suscipit lobortis nisl 
ut aliquip ex ea commodo consequat. Duis autem vel eum iri-
ure dolor in hendrerit in vulputate velit esse molestie conse-
quat, vel illum dolore eu feugiat nulla facilisis at vero eros et 
accumsan et iusto odio dignissim qui blandit praesent lup-
tatum zzril delenit augue duis dolore te feugait nulla facilisi.

2 Level 1 heading on page 1

L

Second level 2 heading
Et tam neque pecun modut est neque nonor et imper ned libi-
dig met, consectetur adipiscing elit, sed ut labore et dolore 
magna aliquam makes one wonder who would ever read this 
stuff? Bis nostrudesse cillum dolore eu fugiat nulla pariatur. 
At vver eos et accusam dignissum qui blandit est prae

Left page: Running H/F 1= 
<$paratext[1heading]>

Officia deserunt mollit anim id est laborum Et harumd dereud 
facilis est er expedit distinct. Nam liber te conscient to factor 
tum poen legum odioque civiuda et tam. Neque pecun modut 
est neque nonor et imper ned libidig met, consectetur adipisc-
ing elit, sed ut labore et dolore magna aliquam is nostrud 
exercitation ullam mmodo consequet. Duis aute in voluptate 
velit esse cillum dolore eu fugiat nulla pariatur. At vver eos et 
accusam dignissum qui blandit est praesent. Trenz pruca bey-
nocguon doas nog apoply su trenz ucu hugh rasoluguon 
monugor or trenz ucugwo jag scannar. Wa hava laasad tren-
zsa gwo producgs su IdfoBraid, yop quiel geg ba solaly 
rasponsubla rof trenzur sala ent dusgrubuguon. Offoctivo 

Third level 2 heading 3
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immoriatoly, hawrgasi pwicos asi sirucor.Thas sirutciun 
applios tyu thuso itoms ghusoconsequet. Duis aute in volup-
tate velit esse cillum dolore eu fugiat nulla pariatur. At vver 
eos et accusam dignissum qui blandit est praesent. Trenz 
pruca beynocguon doas nog apoply su trenz u

Third level 2 heading 

Right page: Running H/F 2 = 
<$paratext[2heading]>

pwicos gosi sirucor in mixent gosi sirucor ic mixent ples cak 
ontisi sowios uf Zerm hawr rwivos. Unte af phen neige phe-
ings atoot Prexs eis phat eit sakem eit vory gast te Plok peish 
ba useing phen roxas. Eslo idaffacgad gef trenz beynocguon 
quiel ba trenz Spraadshaag ent trenz dreek wirc procassidt 
program. Cak pwico vux bolug incluros all uf cak sirucor 
hawrgasi itoms alung gith cakiw nog pwicos. Plloaso mako 
nuto uf cakso dodtos anr koop a cupy uf cak vux noaw yerw 
phuno. Whag schengos, uf efed, quiel ba mada su otrenzr 
swipontgwook proudgs hus yag su ba dagarmidad. Plasa 

4 Level 1 heading on page 1

L

maku noga wipont trenzsa schengos ent kaap zux copy 
wipont trenz kipg naar mixent phona.

Cak pwico siructiun ruos nust apoply tyu cak UCU sisulutiun 
munityuw uw cak UCU-TGU jot scannow. Trens roxas eis ti 
Plokeing quert loppe eis yop prexs. Piy opher hawers, eit yag-
gles orn ti sumbloat alohe plok. Su havo loasor cakso tgu 
pwuructs tyu InfuBwain, ghu gill nug bo suloly sispunsiblo 
fuw cakiw salo anr ristwibutiun. Hei muk neme eis loppe. 
Treas em wankeing ont sime ploked peish rof phen sumbloat 
syug si phat phey gavet peish ta paPlokeing quert loppe eis 
yop prexs. Piy opher hawers, eit yaggles orn ti sumbloat alohe 
plok. Su havo loasor cakso tgu pwuructs tyu.

Fourth level 2 heading 
Lorem ipsum dolor sit amet, consectetaur adipisicing elit, sed 
do eiusmod tempor incididunt ut labore et dolore magna alig 
bo suloly sispunsiblo fuw cakiw salo anr ristwibutiun. Hei 
muk neme eis loppe. Treas em wankeing ont sime ploked 
peish r
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Level 1 heading on page 1
Hecate est Iovis et Latonae filia, soror Apollinis. Est tricopor 
et triceps, magicarum artium magistra ac fascinationum 
praeses, cinctra latrantium canum turma; noctu stans in triv-
iis vel prope sepulcra et ubi loca sunt caedibus contaminata.

First evel 2 heading 
Hecate est Iovis et Latonae filia, soror Apollinis. Est tricopor 
et triceps, magicarum artium magistra ac fascinationum 
praeses, cinctra latrantium canum turma; noctu stans in triv-
iis vel prope sepulcra et ubi loca sunt caedibus contaminata.

Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed 
diam nonummy nibh euismod tincidunt ut laoreet dolore 
magna aliquam erat volutpat. Ut wisi enim ad minim veniam, 
quis nostrud exerci tation ullamcorper suscipit lobortis nisl 
ut aliquip ex ea commodo consequat. Duis autem vel eum iri-
ure dolor in hendrerit in vulputate velit esse molestie conse-
quat, vel illum dolore eu feugiat nulla facilisis at vero eros et 
accumsan et iusto odio dignissim qui blandit praesent lup-
tatum zzril delenit augue duis dolore te feugait nulla facilisi.

2 Second level 2 heading

L

Second level 2 heading
Et tam neque pecun modut est neque nonor et imper ned libi-
dig met, consectetur adipiscing elit, sed ut labore et dolore 
magna aliquam makes one wonder who would ever read this 
stuff? Bis nostrudesse cillum dolore eu fugiat nulla pariatur. 
At vver eos et accusam dignissum qui blandit est prae

Left page: Running H/F 1= 
<$paratext[1heading,
2heading]>

Officia deserunt mollit anim id est laborum Et harumd dereud 
facilis est er expedit distinct. Nam liber te conscient to factor 
tum poen legum odioque civiuda et tam. Neque pecun modut 
est neque nonor et imper ned libercitation ullam mmodo con-
sequet. Duis aute in voluptateos et accusam dignissum qui 
blandit est praesent. Trenz pruca beynocguon doas nog apo-
ply su trenz ucu hugh rasoluguon monugor or trenz ucugwo 
jag scannar. Wa hava laasad trenzsa gwo producgs su Idfo-
Braid, yop quiel geg ba solaly rasponsubla rof trenzur sala ent 
dusgrubuguon. Offoctivo 

Third level 2 heading 3
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immoriatoly, hawrgasi pwicos asi sirucor.Thas sirutciun 
applios tyu thuso itoms ghusoconsequet. Duis aute in volup-
tate velit esse cillum dolore eu fugiat nulla pariatur. At vver 
eos et accusam dignissum qui blandit est praesent. Trenz 
pruca beynocguon doas nog apoply su trenz u

Third level 2 heading 

Right page: Running H/F 2 = 
<$paratext[2heading,
1heading]>

pwicos gosi sirucor in mixent gosi sirucor ic mixent ples cak 
ontisi sowios uf Zerm hawr rwivos. Unte af phen neige phe-
ings atoot Prexs eis phat eit sakem eit vory gast te Plok peish 
ba useing phen roxas. Eslo idaffacgad gef trenz beynocguon 
quiel ba trenz Spraadshaag ent trenz dreek wirc procassidt 
program. Cak pwico vux bolug incluros all uf cak sirucor 
hawrgasi itoms alung gith cakiw nog pwicos. Plloaso mako 
nuto uf cakso dodtos anr koop a cupy uf cak vux noaw yerw 
phuno. Whag schengos, uf efed, quiel ba mada su otrenzr 

4 Fourth level 2 heading

L

swipontgwook proudgs hus yag su ba dagarmidad. Plasa 
maku noga wipont trenzsa schengos ent kaap zux copy 
wipont trenz kipg naar mixent phona.

Cak pwico siructiun ruos nust apoply tyu cak UCU sisulutiun 
munityuw uw cak UCU-TGU jot scannow. Trens roxas eis ti 
Plokeing quert loppe eis yop prexs. Piy opher hawers, eit yag-
gles orn ti sumbloat alohe plok. Su havo loasor cakso tgu 
pwuructs tyu InfuBwain, ghu gill nug bo suloly sispunsiblo 
fuw cakiw salo anr ristwibutiun. Hei muk neme eis loppe. 
Treas em wankeing ont sime ploked peish rof phen sumbloat 
syug si phat phey gavet peish ta paPlokeing quert loppe eis 
yop prexs. Piy opher hawers, eit yaggles orn ti sumbloat alohe 
plok. Su havo loasor cakso tgu pwuructs tyu.

Fourth level 2 heading 
Lorem ipsum dolor sit amet, consectetaur adipisicing elit, sed 
do eiusmod tempor incididunt ut labore et dolore magna alig 
bo suloly sispunsiblo fuw cakiw salo anr ristwibutiun. Hei 
muk neme eis loppe. Treas em wankeing ont sime ploked 
peish r
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Running headers and footers


E
:\

FM
-c

o
u

rs
e
\h

a
n

d
o

u
t_

7
0

\l
a
yo

u
t.

fm
 

2
0

0
7

-0
6

-2
2

References to special markers

In some cases the needed information is not available in 
headers or other paragraphs. Then the required text is set up 
in markers on the pages to be referred to.

Date and time

FrameMaker provides a host of system variables for date and 
time information. For the complete list see Building blocks for 
system variables on page 7-4.

Note: Be aware that you can not set up user variables with building 
blocks from system variables (for example, have a user varia-
ble iso-date with the format yyyy-mm-dd). For such cases you 
need to modify the format of an existing system variable pro-
viding the needed information (e.g. current date).

Purpose Format of variable Example of use

marker text from marker of type «Header/
Footer $1»

<$marker1> Set up the marker text with a short version 
of a heading

marker text from marker of type «Header/
Footer $1»

<$marker2> Put additional information into the marker, 
which is not in the text
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Templates
Templates organise and define layout and appearance of doc-
ument types such as manuals, book chapters or theses. A 
template is an ordinary FrameMaker file and may contain 
explanatory text. Any FrameMaker document can act as a tem-
plate.

Interdependencies of template items

Many features of layout and style are related, they depend on 
each other. The following scheme is based on Sarah O’Keefe’s 
book FrameMaker 7: The Complete Reference.

Sample templates

FrameMaker comes with a number of pre-defined templates

The templates are grouped into the areas Book, Business, 
Outline, Reports and Special.

In the English version layout items are in inches.

Cond. text page Table tags

Graphic object Colour definitions Paragraph tags PDF settings

Cross reference
formats

Math definitions

Reference pages

Markers

Character tags

Variable definitions Master pages

Ruling styles
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To use a pre defined template File > New 

Open a folder with the desired type of template (e.g. Busi-
ness)

Select the desired template, New.

Organising templates

Templates are located in a special directory. The files from 
this directory are copied to an unnamed document which is 
then presented to the user.

The template directory is divided into sub directories, e.g. 
C:\Frame\Template\Reports\. Own templates can be copied 
or moved to this directory.

To use another directory for the templates with this special 
property (open a copy of the template), the new template path 
must be defined in maker.ini. See Template path on page A-36

Set up a new template

To set up a new template, for example for a report or script, 
many approaches are possible:

Set up from scratch (empty document)

Use existing document as a starter

Use a FrameMaker template as a starter

Use a FrameMaker 
template

Press Explore Standard Templates

Select the appropriate template, e.g. Report, Numeric. To 
get an impression of the template, press Show Example.

Select the desired template, Create.

Personalise the template according to Use an existing docu-
ment on page 17.

Save this file with an appropriate name (e.g. as …\doc-
standards\frame\report.fm).

Use an existing document Check the paragraph catalogue, the character catalogue 
and the table catalogue for un-needed entries and remove 
them.

Add any generally useful definitions to the paragraph cata-
logue, character catalogue or table catalogue. 

Check whether you need global changes to the paragraph cata-
logue or the character catalogue, such as changing the lan-
guage.

Make any desired changes to the master pages. You may 
wish to remove un-needed special pages or add such pages.

Check the reference pages for un-needed pages. You may 
for example find a page IVZ and a page TOC which both 
define stuff for the table of contents. IVZ is used in a Ger-
man environment, TOC for an English environment (Frame-
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Maker version). Check both for completeness and similar 
contents and remove the un-needed one.

The same may happen for the reference pages used for 
index: IDX in the German and IX in the English environ-
ment.

You may wish to remove the HTML reference pages altogether.

Check the standard reference page whether it contains all 
the graphics you reference in the ‘Frame above’ or ‘Frame 
below’ attributes of paragraphs.

Clean out any text on the body pages, or better: describe all 
formats with examples and specify its use. It may be 
cleared before use whenever you use this template docu-
ment.

Save the document at an appropriate place, e.g. at …\doc-
standards\frame\.

Save this file with an descriptive name at an appropriate 
place (e.g. as …\doc-standards\frame\report-general.fm).

Use an empty document Set up a sketch of the layout with all measures. Think 
about special pages (e.g. Title and Last for a chapter, Land-
scape for extra wide tables etc.).

Set up a table of all desired paragraph formats and charac-
ter formats, as well as the general purpose table formats 
with at least the general and main detail properties (font, 
size, weight, indents, type of pagination…).

Implement the design in master pages (layout) and cata-
logues starting with an ‘empty’ document (File > New, the 
select Portrait). You may need to clear the existing cata-
logues or use their contents as a starter.

Save this file with an descriptive name at an appropriate 
place (e.g. as …\doc-standards\frame\business-plan.fm).
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Sample template
The following is based on the layout of this handout.

Master page Left

Layout (master page)

Header frame: ¶-format z-header

Contents Running H/F 1; format=<$paratext[1heading]>

Contents of footer frame ¶-format z-footer

Contents D (f-format: DDD-symbols); TAB
System variable Chapter Number, « - «;
System variable Variable Current Page #; TAB; «(«;
System variable Filename long;
System variable Modification date short (in ISO for-
mat); «)»

Master page right

Layout Mirrored to Left

Header frame ¶-format z-header

Contents Running H/F 2; format=<$paratext[2heading]>

Footer frame Same as on page Left.

18 cm

5.6 cm
0.6 cm

11.8 cm

12

Header text frame:

Type background

Top=1cm, 
Height=0.4 cm, 
Left=2 cm, 
Width=18 cm

Main text frame:

Top: 2 cm, L=2 cm, 
W=18 cm, H=26 cm

Flow A, auto con-
nected

Side head: room 
5.6 cm, gap 0.6 cm

Footer text frame:

Type background

Top=28.6, H=0.4, 
L=2, W=18.

§
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Excerpt from a paragraph catalogue

Excerpt from a character catalogue

Basic properties Default Font Pagination Numbering.

Paragraph format 
name

sp
ac

e 
ab

o
ve

in
d

en
t 

le
ft

 [
cm

]

ta
b

 L
 [

cm
]

n
ex

t 
p

ar
ag

ra
p

h

fo
n

t

si
ze

 [
p

t]

w
ei

g
h

t

p
ag

in
at

io
n

k
ee

p
 w

it
h

 n
ex

t

N
u

m
b

er
in

g
 

(f
o

r 
h

ea
d

in
g

s
o

n
ly

 p
ro

vi
si

o
n

al
)

1heading page 1.5 1.5 bodytext

H
el

ve
ti

ca

24

b
ol

d

across all 
…

ye
s2heading 24pt 1.5 1.5 bodytext 18 in col.

3heading 11pt 1.5 1.5 bodytext 14 side head

body 5.5pt

Pa
la

ti
n

o

1
1

In
 c

o
lu

m
n

n
o

n1_numbered_1st 5.5pt 0.5 0.5 nx_numb... yes <n=1>\t

nx_numbered_next 5.5pt 0.5 0.5

n
o

<n+>\t

lb_bulleted_list 5.5pt 0.5 0.5 \b\t

tt_table_title 12pt 2.5

H
el

ve
ti

ca
-n

ar
ro

w

14

b
ol

dth_table_head 12

tc_table_cell 4pt

1
0

tl_table_list 4pt 0.5 0.5 \b\t

Footnote 4pt 0.5 9

Format name font size weight angle language

1highlight as is as is as is italic as is

2highlight as is as is bold as is as is

computer Letter Gothic as is as is as is none

name Helvetica Narrow 12pt bold normal none

bullets Zapf Dingbats as is as is as is none
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More items in a template

A complete template contains also:

Master pages for title, rotated pages, preliminaries etc.

Definitions of variables (depending on application)

Formats for cross-references, tables, TOC paragraphs etc.

Graphics on reference pages

Master pages for rotated tables

Rotated tables are not rotated themselves but located in a 
rotated text frame. For adequate handling (e.g. for Assign mas-
ter pages automatically on page 22) it is best to create both a 
right and a left rotated page:

If for some reason you keep the master page in portrait mode 
and just rotate the inner text frame, you can not directly edit 
a table anchored in this text frame:

Text is oriented this way and tables are 
placed normally

Hecate est Iovis et Latonae filia, soror 
Apollinis. Est tricopor et triceps, 
magicarum artium magistra ac 
fascinationum praeses, cinctra 
latrantium canum turma; noctu stans in 
triviis vel prope sepulcra et ubi taminata.

here you can edit the table similar to the text

1 Create master page in por-
trait mode (e.g. copy from 
Right) and name it appro-
priately (e.g. Rotated-
right)

2 Rotate page with Format > 
Customize Layout > 
Rotate page clockwise/
counter clockwise.

3 Rotate central text frame 
back. The heading/foot-
ing area will remain 
rotated.

Footing area is rotated

H
eading area is rotated

A
s 

so
o

n
 a

s 
y
o

u
 p

la
ce

 t
h

e 
cu

rs
o

r 
in

 
th

e 
ta

b
le

 i
t 

w
il

l 
b

e 
se

le
ct

ed
 –

 n
o

 
ed

it
in

g
 i

s 
p

o
ss

ib
le

 i
n

 a
 r

o
ta

te
d

 
ta

b
le

:

Heading area is oriented normally

Footing area is oriented normally
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Handling master pages

Assign master pages automatically

FrameMaker 7 allows to assign master pages depending on 
one or more paragraph formats on a page.

This is handy for automatic assignment of rotated pages for 
large tables. 

Note: The triggering paragraph can not be within a nested text 
frame (within an anchored frame) or a table. Hence the only 
reasonable trigger for rotating tables is the tag of an anchor 
paragraph.

Master page mapping table

If this table does not exist, it will be created by Format > 
Page Layout > Apply Master Pages … The mapping table will 
appear on reference page MasterPageMaps and has this 
appearance:

UnstructMasterPageMaps
Book Update (Yes or No): Yes

Having set up the table on the reference page,

1 When you are done, choose View > Body Pages.

2 Make the appropriate document window or book window 
active. If a book window is active, select the documents you 
want to affect.

3 Choose Format > Page Layout > Apply Master Pages, and 
then click Yes to override manually applied master pages.

FrameMaker searches each body page for the first occurrence 
of any paragraph tag specified in the Master Page Maps table. 
When it finds text containing the specified paragraph tag, it 
applies the specified master page.

Range indicators Single to apply the master page only to the body 
page on which each paragraph tag appears

Span pages Master pages are applied to the entire span 
of pages to which the paragraph tag is 
applied.

Until changed Master pages are applied to all pages, until 
the next body page with a different para-
graph tag listed in the mapping table is 
encountered. 

Blank Equivalent to Single.

Paragraph Tag 
Name

Right-Handed Master 
Page (or Single-Sided 
Master Page)

Left-Handed Master 
Page

Range Indicator (Sin-
gle, Span pages, Until 
changed)

Comments

dtr-doctitle-right Title Single The first chapter page

zi-imprint Last Single No header/footer

rt-rotate-table Rotated-right Rotated-left Span pages Wide multi page tables
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Reorder master pages

To reorder custom master pages [Help]:

1 Open a master page, and then choose Format > Page Lay-
out > Reorder Custom Master Pages.

2 Select a master page in the Custom Master Pages list, and 
move them with the Move Up or Move Down button.

3 Repeat step 2 as often as necessary to achieve the order 
you want.

4 Click Set. If you were previously viewing a custom master 
page, note that a different master page may now be visible.
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Graphics

Overview

FrameMaker provides a set of graphic tools which 
are sufficient for most purposes in technical texts. 
For sophisticated applications, such as marketing 
brochures, these tools are not sufficient and im-
ported graphics are used. FrameMaker support a 
great number of graphic formats.

The graphic tools of FrameMaker were not devel-
oped further at the point when specialised applica-
tions became available even on UNIX.

For diagrams D+DD provide clip-art of high preci-
sion (both scales and grids).

Contents

Importing graphics .................................................  2

Figures in FrameMaker ............................................  6

Graphics with FrameMaker tools ..............................  7

Graphic elements on reference pages .....................  15

Arbitrary guiding lines ..........................................  16
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Importing graphics
The kind of graphic formats FrameMaker can handle depends 
on the installation of the filters.

Supported graphic formats

Vector data formats The following filters for vector data are available in a com-
plete installation of FrameMaker:

Autocad drawings Both DWG and DXF files can be imported. Be aware that such 
drawings may be very large and hence scaled down to a black 
blob. It is also common that such files will have very thin 
lines after imported due to the scaling.

Normally it is necessary to prepare CAD drawings in the CAD 
application.

EPS (Encapsulated
PostScript)

Both black and white as well as full colour eps’ can be han-
dled.

If no preview image is included in the file, FrameMaker dis-
plays a gray box of appropriate size. To see the image, you 
need to print on a PostScript printer or create a PDF.

On a non-PostScript printer you will get only the preview 
image (if present) which in most cases is of very low resolu-
tion.

CGM Computer Graphics Metafile can be imported properly.

Corel Draw (CDR) FrameMaker 7 can import graphics Corel Draw up to version 
7.

Frame Vector FMV and Frame Image are FrameMaker internal formats which 
are created on request (File > Preferences > General) when 
documents containing copied (not referenced) images are 
saved.

Micrografx Drawing Native files from Micrografx Designer can be imported prop-
erly.

PDF From a multi page PDF you can import any selectable page.

SVG Scalable Vector Graphics is a recent file format, especially 
designed for the web. Unfortunately FM7 does not support 
this format correctly (converts to pixel).

WMF (Windows
MetaFile)

WMF (Windows Meta File) may contain both vector and raster 
data. This format is correctly imported. With EMF (Enhanced 
Metafile) you may get an incorrect or no picture.

Word Perfect Graphics This graphic format is also supported.

Raster data

BMP This Bit Map format is present on Windows only and uses 3 
bytes per pixel to contain the full range of colours. Hence the 
files are huge.

CCITT64 This is a FAX format and can be generated by a FAX driver or 
received via FAX software. It is only black and white (I level).

DIB The Device Independent Bitmap format exists only on Win-
dows. This format contains information about its original size 
and resolution. This format is widely used for screen shots.
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GIF This Graphic Interchange Format is a proprietary format3). 
GIF uses at most 256 indexed colours and may carry transpar-
ency. GIF is not an adequate format for photographs.

JPEG J-peg compression is lossy. You may set the compression to 
none. JPEG was developed for photographs. It is not a good 
choice for images with coloured areas (illustrations).

MacPaint This raster format supports full colour. As the name sug-
gests, it is native to the Macintosh environment.

PCX IBM PC Paintbrush files are very old and specific for DOS and 
Windows.

PNG Portable Network Graphics is a non proprietary format sup-
porting transparency. It was developed for the Web.

RAS SUN Raster may exist on UNIX environments.

TIF FrameMaker can handle both uncompressed and compressed 
(with LZW) Tagged Image Format. Most flavours of TIFF (black 
and white, greyscale, colour) are supported by FrameMaker.

XWD The X-Windows format is native to UNIX.

Recommended graphic format

Recommended formats are highlighted in bold. Use formats 
in the shaded area only for web-graphics.

Problems with imported graphics

To resolve problems with imported graphics, check this:

Do you have the proper filter (input interpreter) installed?

Does the file conform to the ‘de facto standard’ pertinent 
to the file format (there are various flavours of DXF, WMF, 
TIFF, etc. around)?

May the file be corrupted (for example, by a download)?

Can you get a different format from the source?

Note: png graphics with 8bit pixel depth (256 colours) fill the colour 
catalogue with numbers of colours named RGB xxx,xxx.xxx. 
Although you can eleminate these definitions by saving as MIF 
(they will not be present in the MIF) or Klaus Müllers script 
Delete Unused Colours, these definitions are back after open-
ing the MIF or saving the cleaned file …

3 Developed by CompuServe, another company (UNISYS) claimed patent 
rights during 2000 or so. At least since 2003 the patents are free.

Nature of image

Options Photograph Line drawing Drawing with 
coloured areas

No compression tif, jpg, epsa

a. This is an eps with no vector data

eps, wmf, dwg, 
svg

eps, wmf, dwg, 
svg

Lossless compression tif, jpg, gif, png  gif, png gif, png

Lossy compression jpg, png - -
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Importing graphics

To import a graphic: Place the cursor where you want the graphic to appear. 

File > Import > File

Look for the path and the desired graphic and choose 
Import by Reference.

Import!

If FrameMaker can not determine the graphics format and 
hence can not select an appropriate graphics import filter, 
the Unknown Filetype dialogue is displayed.
Select the appropriate file type and import the file with 
Convert.

Note: If you have not installed all filters, you might not find the 
appropriate file type in the list - in this case you need to con-
vert the file in a graphics application.

Importing raster graphics

If you have selected a bitmap graphic, set up the resolution 
for the desired size (dialogue Import Graphics Scaling).

To Fit in Selected Rectangle a rectangle must be selected, 
not a graphic frame or the anchored frame! The rectangle 
will be replaced by the graphic. 

For all other selections an anchored frame containing the 
graphic will be inserted with the following properties:

- Placement Below current Line, centered

- Centred

- Cropped (if the image is too large, it will be cropped)

- Margins of 1/12» = 6 pt (2.12 mm) around the image

Note: These defaults can be changed to something more useful 
only with a special plug-in.

Importing vector 
graphics

If you have selected a vector graphic, the graphic will be 
imported directly into an anchored frame (with the same 
properties as for a raster graphic).

When importing an SVG (Scalable Vector Graphic), the 
Unknown Filetype dialogue is presented, even though 
FrameMaker has recognised the correct format. Confirm 
with Convert. For SVG you get an additional dialogue:

In Import SVG 

- either set the desired DPI raster quality in the drop 
down list. The current DPI for the graphic is displayed as 
default.

- or set the specific dimensions from the drop down lists 
SVG width and SVG height. This may distort the image.

Import graphic into 
frame

When you import a raster graphic into a selected (anchored) 
frame, you may need to calculate a fitting resolution. In Cus-
tom dpi the last used value is provided, not a newly calcu-
lated value.
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Scaling graphics

Change the size and position of a selected graphic with the 
mouse (hold down the SHIFT key to constrain to propor-
tional scaling).

- You see the current width and heights in the status bar 
on the bottom left corner of the document window.

- If View > Rulers is set, current width and height are indi-
cated on the ruler, for example the top ruler

To scale numerically (by a percentage) or to a specific 
width and height, use Graphics > Scale.

You may also use Graphic > Object Properties for propor-
tional scaling in percent (Scaling > Percent, Set!)

To change the resolution (DPI) of a bit mapped graphic, use 
Graphic > Object Properties and use the Set DPI button. A 
higher resolution will reduce the image size, a lower reso-
lution will increase the image size.

This function is not available after scaling with the mouse.

Referenced vs. copied graphics

If you are importing images directly into the document (not 
by reference) or simply using the paste command to place the 
images into frames, the uncompressed version of the images 
are placed, not the highly compressed JPEG/TIFF images.

Printing coloured images

When printing coloured images on a standard laser printer or 
other black-and-white printer you get different results due to

different mapping of colours to gray scale

different printer resolutions

different types of printers

This is also true for PostScript printers.

Preserve colour in PDF If you do not have a colour PostScript printer and want to cre-
ate colourful PDFs, you must use the printer driver of Acrobat 
Distiller (FIle > Printer Setup and select Acrobat Distiller) 4).

Note: Adobe recommends to always use the Distiller Printer for PDF.

4 Printing a PostScript file and then distilling is the method until FM 6 and 
Acrobat 5. With later versions you can Save as PDF which automatically 
uses the Distiller Printer (since Acrobat 6 called Adobe PDF).
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Figures in FrameMaker
There is no real support for labelled figures in FrameMaker. 
To get a reasonable appearance with a figure title etc., you 
must

Place the image in an anchored frame

Place the anchored frame in a table, anchored at a para-
graph with run-in property (otherwise you get additional 
room at the top of the cell).

Define cell margins according to the needs.

Setting up a figure table

The table figure-table is set up with just one cell and the fol-
lowing properties:

Cell margins all 0

Alignment left

Start anywhere

Title position below table

Ruling none

Shading none

The paragraph format to display the area of the table (shaded 
in the sample below) in the cell is body. It is used only to 
place the anchor. The paragraph format for the table title is 
fn-fig-heading-numbered.

Using the figure table

After inserting the image (with File > Import > File) you need 
to adjust the properties of the anchored frame for... 

Anchoring type = Run into Paragraph; Alignment = Left

You may also wish to change the properties of the image to...

Top left position = 0 and adjust the size of the anchored 
frame manually...

You may wish to speed up your work by copying and pasting 
prepared tables and then replacing the images.

The format of this paragraph (body) should have 0 values 
for all items in the Tab «Table Cell». Otherwise you get addi-
tional space around the anchored frame (normally without 
border).

Based on this method you may wish to use a 3-column table:

Column1 = width of side head area; column 2: gap between 
side head and main text; column 3: as wide as the text area.

Figure 1: The eye of a model (created by an artist, no photo).
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Graphics with FrameMaker tools
Many technical drawings, schemes etc. can be done com-
pletely with FrameMaker tools:

Select graphic elements

Normally you just click with the cursor on a graphic element 
to select it. To select more than one element (e.g. for group-
ing) use SHIFT+click for the second to nth element.

In rare cases it may be necessary to CTRL+click on the first 
element. Be aware that moving the mouse during the click will 
create a copy of the element, not just select it!

For special operations the following ESC sequences may be 
useful: 

Tool bars for graphic work

Prepare the environment

Defaults for these
properties can be
defined in the file
maker.ini (see Set

reasonable default for
your work on page A-36)

Set a reasonable grid spacing (e.g. 0.1 cm) in View > 
Options

Set Graphics > Snap ( ) to activate the grid for your 
work.

With Graphics > Gravity ( ) set on, an object attracts 
the pointer (cursor) as you draw, resize or reshape a nearby 
object. Gravity has no effect to moved objects. The gravity 
is a property of the contour and the corners of an object. 
Its ‘range’ does not depend on the zoom level.

9-bit delimiter 8-bit check sequenceuseful frame data

end delimiter

Signal

Frame

Clock

Data

line active

line idle

1 1 11 1 1 1 10 0 0 0 0 01 1

Function Key-seq.

Select the first graphic element (on the page) ESC, o, F

Select the next drawn object (may be a group) ESC, o, n

Expand the object selection (add objects to selection) ESC, o, e
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Graphic objects

The graphics palette defines graphic objects as well as prop-
erties for graphic objects. You may set the properties before 
you create an object or apply the properties to selected 
objects.

Procedures

Set numeric values for 
properties

To set numeric values (e.g. for position, height, width), use 
Graphics > Object Properties or button . Which proper-
ties can be set depend on the object:

Intelligent cursor (depending on object)

Line

Rectangle

Open polygon

Closed polygon

Create text frame

Create graphic frame

Define area fill pattern

Define line fill patten

Define line width

Define line-end type

Define line type

Define colour

Define tint

Define overprint type

Cursor for graphic objects

Arc (circle, ellipse)

Rectangle with rounded corners

Circle, ellipse

Freehand-line, spline

One-line text

Apply area fill pattern

Apply line fill pattern

Apply line width

Apply line-end type

Apply line type

Apply colour

Apply tint

Apply overprint type

Object type O
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Imported graphic - x x x x x x x x x x x

Graphic object (el-
lipse, polygon etc.)

- x x x x x x x

Anchored frame x x x x x x x x

Graphic frame - x x x x x x x

Text frame - x x x x x x x x x

Graphic frame on 
reference page

- x x x x x x x x
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Set object attributes Object attributes are used in special export situations for 
anchored frames (Object Properties > Object Attributes):

Alternate text is exported only from structured documents 
to HTML, XML, SGML and tagged PDF. It is 
displayed in the same sense as ALT text in 
HTML.

Actual text is exported only to tagged PDF. The infor-
mation is intended for Screen Readers to 
describe the contents of the anchored 
frame.

Attributes The purpose of this item is not clear yet.

Pick up properties To pick up properties from an object and transfer it to the 
properties in the graphics palette, select the source object 
and enter ESC, g, O (letter O).5)

Group and ungroup items Use Graphics > Group to group various selected 
items.

Use Graphics > Ungroup to ungroup selected 
items. You can ungroup as long as the button is not 
greyed.

It is good practice to group all objects in a frame to avoid 
accidentally moving them. Do not just group the whole bunch 
of objects, but set up subgroups which belong together etc.

Align objects Select the objects to be aligned first and set the ‘master’ with 
the last selection. Then apply Graphics > Align to get a dia-
logue to specify the desired alignment or use the appropriate 
buttons .

Distribute objects With Graphics > Distribute or button you get a 
dialogue to specify the distribution (horizontal/
vertical, equidistant centred/edges, specific edge 
gap).

Define visibility Move selected items to the front or back of other 
objects with Graphics > Bring to Front / Send to 
Back.

Connect lines Gravity ON: Lines with reasonably close end points 
can be combined to one object with Graphics > 
Join. Drawing new elements close to existing ones 
snaps the new element to the existing one.

Modify shapes Depending on the selected graphic the function 
Graphics > Reshape does:

5 With Shalom Perets’ Express Customisation Kit installed you get this 
function on the context-menu (right click).
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Convert an arc from 1/4 circle or 1/4 ellipse to any angle. 
Use Graphics > Object Properties to set the value numeri-
cally.

Activate the handles of a polyline, polygon or spline to be 
able to:

- reshape the polyline or spline by dragging a handle 
(square).

- reshape the curvature by dragging a control point 
(round).

- add a handle point by control-clicking on the line.

- remove a handle by control-clicking on it.

Change the number of sides for regular polygons.

Regular polygons To create regular polygons (3 … n), start with a circle, ellipse, 
square or rectangle and reshape it to an arbitrary number of 
sides with Graphics > Set # Sides. You may also set the angle 
of the base line.

Freehand lines Use the polygon tool from the tools palette to set up the skel-
eton of a line (polyline).

With Graphic > Smooth convert it to a smooth line. 
For adjusting the shape it may be useful to get the 
polygon again with Graphic > Unsmooth.

Watch the different positions of the handle points in polygon 
mode and smooth mode (see figure above).

Move objects by small 
amounts

To move selected objects use ALT+arrow or the buttons 
depicting helicopters. The amount moved depends on the 
zoom factor. At 100% you move by 1 DTP-point6) (with 
ALT+SHIFT+arrow7) 6 DTP-points). Set the zoom factor to 
353 to move 0.1mm per nudge with ALT-arrow.

Rotate objects With the buttons you rotate the object by the 
amount defined in View > Options > Snap: Rotate 
(e.g. 15°). Using Graphics > Rotate allows you to 
define any angle. Cells in a table are rotated b y 90° 
increments.

With the mouse you can rotate an object also: use ALT while 
you move a handle (the cursor arrow gets an additional small 
double arrow to indicate the function). Watch the rotation 
angle in the status bar.

Flip upside-down and 
right-left

Use Graphics > Flip Up/Down or Flip Left/Right () 
for this action.

Mirror objects To mirror an object create a duplicate and flip this duplicate 
to your needs.

polyline

smoothed = spline

control point
handle point

6 1 DTP point = 1/72 inch = 0.3528 mm
7 Since the left ALT+SHIFT is the toggle between input locales in Windows 

you may end up with a different keyboard setting, for example typing z 
inserts a y. Check Control Panel > Regional Options > Input Locales. If 
there is more than one entry, you may encounter this problem …
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Measuring things Measure any object or any distance on the page by drawing a 
selection rectangle either around the object(s) or around the 
space you want to measure. 

Hold down CTRL+SHIFT at the beginning to assure nothing is 
selected.

You see the width and heights in the units of the document of 
the selection rectangle to bottom left of the status area:

Measuring objects To measure an object, simply select it and get the properties 
with Graphics > Object Properties. For example for object 2 
in the diagram above you get:

Alignment and snap 
details

The properties width and height of graphic object are meas-
ured in the middle of the contour line. Hence alignment and 
snap appear on this virtual line:

Special objects

Rectangles with rounded 
corners

To change the radius of the corner with Graphics > 
Object Properties or the button.

Special arrow tips To point to elements in photographs etc. you might want to 
have some blob at the end of a line - not an arrow pointing to 
the element.

object 1 object 2
selection
rectangle

Object handles
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To define a blob line tip Open the graphic tools palette

Click on the Arrow tool and select Set…

In the dialogue Line End Options

- Activate the Custom option

- Enter the values 135, 45 and 8pt into the value fields. 

- Set!

From now on your arrows will be rhomboid blobs as dis-
played here  for a line with double arrows.

Note: These special arrow settings disappear at the end of your 
FrameMaker session, they can not be saved.

Iconic images within text In line icons (e.g. )are placed in an anchored frame At 
Insertion Point with some negative «Distance above Base-
line». To get the frame just around the image (with no mar-
gin), use the function Shrink Wrap Equation (ESC, m, p).

You select the frame by clicking on the border and select the 
image by clicking in the middle of this ‘icon’.

Border and Fill patterns

The colour (or pen pattern) of the border and the colour (or 
fill pattern) of the interior area of an object can only be the 
same.

The fill patterns and pen patterns are a reminiscence from 
the early FrameMaker times, whereas colour and tint are 
newer concepts.

To apply real colour (and tint) you need to select the fill 
pattern black (left topmost pattern)

To leave the object transparent, select the fill pattern 
None.

Table > Shading > Fill uses these patterns: 100%is pattern 
0, 10% is pattern 5, White is pattern 7. For real shading 
(tint) use 100% fill in the table and a defined colour (e.g. 
40% black).

Colours

Initially FrameMaker provides only basic colours (black, 
white, cyan, yellow, magenta, red, green blue). More colours 
and special gray levels are defined with View > Colour > Def-
initions… A number of colour libraries (e.g. Pantone) are 
available.

For example, to define a colour needed for guiding lines, 
specify a strangely looking colour and name it GuidingLine.

Colour
Tint

pattern 7
pattern 0
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This colour will be listed in the Table Designer > Shading 
and in the Graphic Tools palette:

Shading Shading is the process of applying tint to a colour. Be aware 
of the fact, that a tint of 10% applied to a color which is 
defined as 40% black results in 4% black! In Tables only a lim-
ited set of tints is available, hence appropriate colours (such 
as 40% black) must be defined.

Clip art

FrameMaker comes with a set of clip art, which may be useful. 
These drawings are all done with FrameMaker tools. Hence 
you can modify them within FrameMaker.

Example clips

FrameMaker 6.0
and above

In FrameMaker > 6.0 there is no mention of the clip art files in 
Help or in the manual 8). The files, however, are still there:

The names of the clip art files in $FMHOME/clipart give a hint 
about their contents:

Own clip art It may be a good idea to collect arbitrary shapes for your 
projects also in the clip-art library. Just set up appropriate 
FrameMaker documents (carefully select the name of the file) 
and put it into the clip art directory.

8 With Microtype’s customisation kit you get access back in the Help 
menu.

arrows.fm
balloons.fm
clipart.book
dingbats.fm
electronic.fm

flowchart.fm
hardware.fm
icons.fm
maps.fm
officelayout.fm

people.fm
symbols.fm
transport.fm
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Importing from other applications

Origin The export function of Origin creates unreliable PostScript 
(eps). To fix the problem, 

Export eps from Origin (or less favourable emf)

Import this eps to Adobe Illustrator (or probably Macrome-
dia Freehand)

Export from Adobe Illustrator a conforming eps.

Excel To import a graphic from Excel into FrameMaker:

1 In Excel select the graphic (chart)

2 SHIFT-Edit > Copy picture…

3 In the Copy Picture (CTRL+Copy) dialogue select as shown 
when printed to get best results

4 In FrameMaker use Edit > Paste Special… and select wmf. 

Graphic objects When just copying and pasting a graphic from another appli-
cation, you get an embedded object (OLE). If you double-click 
on the graphic, the creating application is opened.

Do not use this method for documents you distribute.

For more details see Importing methods on page C-2.

0

0
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Graphic elements on reference pages
Graphic elements on the reference pages can be used for

Frame above or below a paragraph

Copy and paste to any location in the document on the 
body pages.

Note: Although the source of the graphic is a reference page, the 
placed graphics are real copies, not referenced graphics.

General elements The following elements are always present in a FrameMaker 
(original) template:

Footnote (defining the separator line and space)

Table Footnote (defining the separator line and space)

Single Line (for use in frame above/below)

Double Line (for use in frame above/below)

To create a graphic 
element for a paragraph

Switch to the Reference Pages (View > Reference Pages)

Create a graphic frame with the corresponding graphic 
tool.

You are requested to enter a name into the dialogue Frame 
Name. Provide a name describing the graphic you want to 
place into the frame.

Set the same name atop the frame with the graphic tool 
Draw a Text Line. For FrameMaker the text is irrelevant, 
but for the human reader it should be equal to the name of 
the frame.

Place the desired graphics into the frame:

Note: The size of the graphic frame defines the white space around 
the graphic when it is used above or below a paragraph. If you 
will use it for both purposes, centre the graphic vertically.

Defining defaults for the environment

In the file maker.ini a number of defaults can be defined. 
Unfortunately arrow tips can not be defined there. Hence any 
special definitions are lost at close of the FrameMaker ses-
sion.

Settings are located in various sections (windows parlance). 
See Set reasonable default for your work on page A-36.

meandered line
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Arbitrary guiding lines
For some work both the Snap (to virtual grid) and the Gravity 
(snap to adjacent object) is not sufficient. You need arbitrary 
guidelines to snap on or to find the desired position.

1 In View > Color > Define… specify a special colour for 
your guidelines, for example Graphic_construction. Use a 
colour such as magenta or pink which clearly separates 
from the real colours of your drawing.

2 In View > Color > Views… make the colour visible:

3 All your construction and guide lines shall use this colour:

4 For printing and saving as PDF hide the guide lines with 
View > Color > Views…
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Variables
Variables can be set up from building blocks.

Emphasis can only be introduced with character formats, 
not with direct formatting.

Note: Because the names of the building blocks of system variables 
are localised, you may get problems when changing the UI lan-
guage during the development of a document (the Running 
Heading / Footing definitions in layout are also variables).
This warning applies also to the building blocks of cross-refer-
ences 

User variables User variables can only contain ordinary text and refer-
ences to character formats. User variables do not have 
access to the building blocks of system variables.

Insert a variable It is, for example, not possible to define a user variable ISO-
date with the format <$year>-<$monthnum01>-
<$daynum01>. If you need such variable contents, you must 
sacrifice a system variable (for example, a short date).

Availability of system variables depends on context (body 
page, master page). For example, Current Page Number is 
available only on master pages.

Depending on the system variable itself the set of building 
blocks differ (you can not set up a file name with date).

To insert a variable:

Place the cursor at the desired location

Select Special > Variable...

Select the variable from the given list in the dialogue.

Press Insert! 

Convert a variable to 
ordinary text

If you need to abandon a variable in the text and convert it to 
ordinary, editable text

Double click on the variable in the text. This opens the dia-
logue Variable.

Convert to Text! You are prompted whether you really 
want to...

Import variable 
definitions from another 
document

Follow the instructions to Import formats from another docu-
ment on page 3-13. Check only the ‘Variables’ box in the 
import dialogue.

Specifying variable 
contents

Set up the contents of your variables to be used as flexible as 
possible:

Avoid plural or inflections.

Avoid punctuation (this may vary depending on usage)

Avoid prefixes or suffixes which may narrow the scope.
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Since you can not nest variables, you may need to set up vari-
able building blocks, which are combined with ordinary text 
in the document. For example, in the text «The Precision Dos-
ing Pump GP-98ML» there could be two variables:
Product-short Precision Dosing Pump
Product-type GP-98ML

Character formats and 
Building blocks

Character formats can be used in system- and user variables 
and cross-references. The special format <Default ¶ Font> 
can be replaced by </>.

Note: Character formats are active only until the end of the variable. 
Hence <Default ¶ font> is implicit at the end of the variable.

Line break in variable The sequence \r inserts a line break (hard return).

Real building blocks (see page 4) are only available in system 
variables.

Create / edit user 
variable

To create a new variable:

Select Special > Variable...

Create Variable! You will notice that you get the dialogue 
for user variables. You can not create additional system 
variables.

Define the name of the variable. This may contain blanks.

Set up the contents of the variable from text and emphasis 
notations. You do not have access to the building blocks of 
system variables.

Add! You may wish to define another variable.

Done! to go back to the Insert Variable dialogue.

Done! or Insert!

Note: If you need access to the building blocks of the system varia-
bles, you must edit an existing system variable to serve your 
needs.

Edit system variable You will need to edit system variables for

Variables which need access to the building blocks of sys-
tem variables (see ISO date above).

Running headers and footers

Adapt the format of system variables to company stand-
ards (for example, the file name in the page footers).

You edit system variables in the same manner as user varia-
bles. You just have more choices for the building blocks.
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Building blocks for system variables

The variables are grouped by purpose. You can not use any of 
the building blocks in any system-variable. 

Purpose English FrameMaker German FrameMaker

Current page number <$curpagenum> <$AktSeiteNum>

Page count <$lastpagenum> <$LetzteSeiteNum>

Volume Number <$volnum> <$BandNum>

Chapter Number <$chapnum> <$KapNum>

File name with full path <$fullfilename> <$DateinameLang>

File name <$filename> <$Dateiname>

Current table-page <$tbssheetnum> <$TabSeiteNr>

Number of table pages <$tblsheetcount> <$TabSeiteZählen>

<$marker1> <$Marke1>

<$marker2> <$Marke2>

<$paratext[paratype]> a <$AbsText[AbsTyp]

Number of the paragraph paratype <$paranum[paratype]> a <$AbsNum[AbsatzTyp]>

Counter value of paragraph paratype <$paranumonly[paratype]> <$AbsNumExkl[AbsatzTyp]>

Tagname of paragraph <$paratag[paratype]> b <$AbsTyp[AbsatzTyp]>

Name of condition type on page. <$condtag[hitag,..,lowtag,nomatch]> <$BedTyp[Typ1,...,Typn,Sonst]>

Seconds <$second> <$Sekunde>

Seconds with leading zeros <$second00> <$Sekunde00>

Minutes <$minute> <$Minute>

Minutes with leading zeros <$minute00> <$Minute00>

Hours from 1 to 12 <$hour> <$Stunde>

Hours 1 - 12 with leading zeros <$hour01 <$Stunde00>

Hours 1 -24 <$hour24 <$Stunde24>

am or pm <$ampm> <$ampm>

AM or PM <$AMPM> <$AMPM>

Day number <$daynum> <$TagNum>

Day number with leading zeros <$daynum01> <$TagNum01>

Day name (full length) <$dayname> <$TagName>

Day name abbreviated <$shortdayname> <$TagNameKurz>

Month number <$monthnum> <$MonatNum>

Month number with leading zeros <$monthnum01> <$MonatNum01>

Month name (full length) <$monthname> <$MonatName>

Month name abbreviated <$shortmonthname> <$MonatNameKurz>

Year with 4 figures <$year> <$Jahr>

Year with 2 figures <$shortyear> <$JahrKurz>

Character format of the paragraph <$Default Para Font> or </> <Absatz Standardschrift>

Character format name <name> <name>

a. To refer for the last (rather than first) occurrence of a tag name on a page, place +, in front of the tag name. 
For example <$paratext(+,lg-glossary)> . This lets you build dictionary-style headers or footers etc.

b. Nobody knows what this is good for.
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Scope of system variables

All system- and user variables are available on master pages. 
On body pages and reference pages all user variables are 
available, but not all system variables:

Building blocks $paranum and $paranumonly

$paranum This building block delivers the complete numbering, that is 
both constant text and counters.

$paranumonly This building block delivers the text from the first counter to 
the last counter, which may include constant text.

System variable Body/
Reference

Default definition (english FM)

Current Page # no <$curpagenum>

Page Count yes <$lastpagenum>

Current Date (Long) yes <$daynum> <$monthname> <$year>

Current Date (Short) yes <$daynum>/<$monthnum>/<$shortyear>

Creation Date (Long) yes <$daynum> <$monthname> <$year> <$hour>:<$minute00> <$ampm>

Creation Date (Short) yes <$daynum>/<$monthnum>/<$shortyear>

Filename (Long) yes <$daynum> <$monthname> <$year>

Filename (Short) yes <$daynum>/<$monthnum>/<$shortyear>

Table Continuation yes <$fullfilename>

Table Sheet yes <$filename>

Volume Number yes (Continued)

Chapter Number yes (Sheet <$tblsheetnum> of <$tblsheetcount>)

Running H/F 1 no <$paratext[Title]>

Running H/F 2 no <$paratext[Heading1]>

Running H/F 3 no <$marker1>

Running H/F 4 no <$marker2>

Running H/F 5 … 12 no <$paratext[paratag]>

User variable yes

Numbering scheme $paranum $paranumonly

H:<n>.<n>.<n+>< >: 11.9.3: 11.9.3

H:Table <n>.< >< ><n+>: Table 5.3: 5.3

C:(<n+>< =0>) (17) 17

C:(<n+>)< =0> (17) 17)
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Cross-references

Cross reference 
restriction

Cross references from one text flow to another are not possi-
ble. You can not have a text flow C on the title page with a 
nice chapter number and have it referenced from the layout 
pages or the text in flow A.

Target of a reference Any paragraph may be the target of a cross-reference.

In addition, special markers can be set to define a target.

Note: Cross references to another file contain the file path. Hence the 
refernce will be broken, if you move the file to another direc-
tory. If you need this move, save the file in the book dialogue to 
the new location.

Cross-reference to any paragraph

1 Place the cursor where you want to insert the cross-refer-
ence. and select Special > Cross-Reference …

2 For a cross-reference to another file select that file from 
the list of documents.

3 In Source type select Paragraphs

4 Select the desired paragraph type in the left hand list.

5 Select the desired paragraph in the right hand list.

6 Select the proper format for the cross-reference from the 
Format list. You might need to create a proper format with 
Edit Format!

7 Insert! will insert the cross-reference.

Cross-reference to marker

Insert a cross-reference 
marker

1 Place the cursor where you want to define the target 
(marker)

2 Insert the marker with Special > Marker...
Marker type= Cross-Reference

3 Define the name (text) of the marker. Be aware that in long 
document you will need some logic to find the correct 
markers later.

4 New Marker!

5 The Marker dialogue stays open, so you can go to the next 
location in the document...

Hint To use existing text to appear in the marker text: select the 
text while the marker dialogue is open or will be opened.

Note: The marker text can not be referenced. There is no such build-
ing block as <$markertext>! You can only refer to the page 
where the marker is located, or to the <$paratext> where the 
marker is (but this can be done without placing a marker first).
See Crossreference to marker text on page 7-7 for an alterna-
tive.
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Define a reference to a 
cross-reference marker

The source file (where to point to) must be open.

Place the cursor where you want to insert the cross-refer-
ence.

Special > Cross-Reference …

For a cross-reference to another file select that file from 
the list of documents.

Source type = Cross-reference Markers

Select the desired marker in the right hand list.

Select the proper format for the cross-reference from the 
Format list. You might need to create a proper format with 
Edit Format!

Insert! will insert the cross-reference.

Marker type Header/
Footer

The content of markers of type Header/footer $1 and 
Header/Footer $2 is available on master pages only. The sys-
tem variables <$marker1> and <$marker2> insert the marker 
contents.

Crossreference to marker 
text

A cross reference can not display the contents of a marker. 
However, a hyperlink can serve this purpose:

1 At the target location specify a named destination. The tar-
get may be highlightes by any means to recognise it.

2 At the ‘reference location’ insert a Jump to named destina-
tion. The reference can be formatted to look like a cross 
reference.

For details of these constructs see Types of hyperlinks on 
page 7-15.

Cross-reference to other file

The source of a reference may be outside the current file. In 
such cases you may wish to include the chapter number in the 
references format, for example «see Cross-references on 
page 7-6».

With FrameMaker 6.0 this became very simple thanks the sys-
tem variable Chapter Number. Of course you need files with 
the chapter number defined (Format > Document > Number-
ing > Chapter or via the book set up) or you get the default 
number (1).

Reference format <1-highlight><$paratext></> on page\ <$chapnum>-
<$pagenum>

Editing cross-references

To edit the appearance (format) of a cross-reference, dou-
ble click on it to enter the dialogue Cross-Reference. Click 
on Edit …

To change the target of the cross-reference, delete the 
cross-reference and insert a new one.
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Format of cross-references

Set up the format of cross-references to be used as flexible as 
possible:

Try to avoid plural or inflections.

Avoid punctuation

Avoid introductions which may vary

Try to avoid language dependent parts

Example formats: <1-highlight><$paratext></> on page\ <$chapnum>-
<$pagenum>

Producing, for example: Format of cross-references on page 7-8:

<1-highlight><$paranum><$paratext></> on page 
<$pagenum>

Producing, for example: Format of cross-references on page 8:

<1-highlight><$paranum><$paratext></> (<$pagenum>)

Producing, for example: Table 1: Building blocks for system vari-
ables on page 4

The last example includes a language dependent part, which 
is part of the automatic numbering of the table. To avoid this,

either abbreviate the word Table to Tab. in the autonumber 
(which fits at least English, French, German and Italian).

or abandon this prefix word completely. Then start the ref-
erence in the text with the appropriate language:
See Building blocks for system variables on page 4.

The format for the second solution is:

<1-highlight><$paranumonly> <$paratext></> on page\ 
<$pagenum>

Note: Character styles may not completely be transferred to the 
cross reference. See Character styles in building blocks on 
page 3-12.

Example of complex 
cross reference format

The following example shows a cross-reference format with 
various building blocks:

typed text typed text

<jumps>see <TitleProps><$paratext><jumps> on page\ <$paranumonly[H1]>\+<$pagenum>

building block

building block

character format building blocks

(e.g. setting weight, colour)

non-breaking

space

building blockbuilding block

non-breaking

hyphen

building block
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Update references
To update references in the current file, open Edit > Update 
References and activate the appropriate check boxes and 
then click Update.

You may automate certain function by selecting from Com-
mands:

Suppress automatic updating: Specify which references 
shall not be automatically updated when the file is opened 
or the book containing the current file is updated.

Update unresolved Cross-References: A dialogue appears, 
which allows to fix unresolved cross-references in all open 
files.

Update unresolved cross-references

All open files are scanned for unresolved cross-references and 
listed in the Numbering elements on page 3-6upper area. 

1 In the upper scroll list, select the file that used to contain 
the target of the unresolved cross-reference. The text below 
the list indicates the number of unresolved references.

2 In the lower scroll list, select the file that (now should) con-
tains the target, and click Open. If FrameMaker can't per-
form the update, select a different file and try again.

3 If FrameMaker fails in any of the files, correct manually:

- Edit > Find/Change, select Unresolved Cross-Refer-
ence

- If found, delete the reference and set up a correct one.

- Repeat Find/correct/file select, until all has been cor-
rected
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Footnotes
Footnotes consist of three elements:

1 The footnote reference which is placed in the running 
text: 9) 

2 The footnote text formatted according to a specific ¶ for-
mat (default: Footnote and TableFootnote).

3 A placeholder frame between the text area and the topmost 
footnote of that page (or under a table).

Footnotes in text Footnotes in text can be numbered in various ways. The num-
bering may start on each page anew or continue within a 
chapter or book. 

For text footnotes the place holder frame normally contains a 
line (see bottom of this page).

Footnotes in tables The same rules apply as for the footnotes in text. The default 
style name, however is TableFootnote, and hence there is 
another graphic frame on the reference pages with this name.

For table footnotes the place holder frame normally is empty, 
but may also contain a line for unruled tables.

End notes Endnotes are footnotes which are collected at the end of a 
chapter or document. FrameMaker can not handle these. How-
ever, ordinary footnotes may be converted to end notes by 
appropriate API’s or plug-ins as well as FrameScripts.

Insert a footnote

To place a footnote,

1 Place the cursor at the text location where the footnote ref-
erence shall appear.

2 Select Special > Footnote and write the footnote text into 
the new footnote paragraph.

Text footnotes are always placed at the bottom of the current 
page (if space allows). Table footnotes are collected after the 
table.

Note: You can not arrange the footnotes of a chapter at the end of a 
chapter (or file). For this you need to install an appropriate API 
(see Extensions by API clients on page 1-15).

Note: If a text footnote is referenced close to the end of a page (for 
example, in the last paragraph) then the footnote may be 
placed on the next page.

9 Sample footnote to demonstrate the elements comprising this construct 
and to display the appearance: ¶ format is zfn-footnote; numbering is ar-
abic, continuing in each chaper. The separator is the green line above.
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Appearance of footnotes

The following items must have the same name:

The style name in the Footnote Properties dialogue

The style name in the paragraph catalogue

The name of the graphic frame on the reference page.

Paragraph format for 
footnotes

Do not specify automatic numbering in these styles! It will 
interfere with the special numbering process of footnotes.

Specify TAB postions if you define TABs (\t) in the Prefix 
or Suffix elements prepended or appended to the footnote 
text. Also a hanging indent may be needed.

The separation line is not defined by the ‘Frame above’ 
property of the paragraph style (see Separation line or space 
on page 11).

Format of the footnote 
reference

The format name and the number format of the reference 
and the note is defined in Format > Document > Footnote 
Properties... 

You can only define constant text for the prefix and suffix 
in the footnote format (e.g. opening and closing brackets); 
you can not:

- Use system variables or user defined variables in the 
prefix or suffix field

- Use character formats in the prefix or suffix field.

You may wish to define the maximum height of space for 
text footnotes (per column). The default is 4" (10cm).

The style of the footnote numbering (arabic, …) and 
whether text footnotes shall start numbering on each page 
or continue numbering again is defined on Format > Docu-
ment > Numbering > Footnote and > Table Footnote.

The numbering may consist of a series of symbols (Format: 
Custom). The default symbols are * † ‡ . They must be in 
the text font. No character format or other font can be 
assigned for these symbols. You can not define groups of 
symbols such as *, **, ***. 

Separation line or space The separation line (or just space) is defined on the reference 
page named Reference by a graphic frame named Footnote 
respectively TableFootnote:

The text lines are just for the human reader. 
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Additional reference to a footnote

To refer to an already existing footnote you must place an 
ordinary cross-reference.

The reference should indicate the page number where the 
footnote can be found (see the next section).

Reference to footnotes in other chapters

To reference a footnote in another (than the current) chapter 
or file, you need a special cross-reference format providing 
both the page number (and/or the chapter number) and the 
footnote number.

To be able to format it similar as a footnote reference (super-
scripting) you need an appropriate character format (e.g. 
super). The complete cross-reference format may look like 
one of these:

<super><$paranumonly[Footnote]> on page\<$pagenum></>

<super><$paranumonly[Footnote]> on page\<$chapnum>-
<$pagenum></>

Footnotes in book files

Footnotes at the end of a 
book

There is no feature in FrameMaker to collect footnotes from 
various files and present them at the end of a FrameMaker 
book in a particular chapter (or at the end of the last chapter).

Solution Collect all notes in a file (use a paragraph format, such as x-
note), and refer to them with an ordinary cross-reference of 
an appropriate format (e.g. <super><$paranumonly[x-note]></>

Footnotes across books

To number the footnotes across the all (or certain) chapters 
of a book:

If you already have a book file, see Footnote number on 
page 8-7. Otherwise do the following:

1 In the first file of the sequence set the numbering proper-
ties in Format > Document > Footnote Properties > Num-
bering: The First Footnote # gets the initial number 
(normally 1). Set also the desired number format of the 
footnote (e.g. arabic).

2 Check whether the footnote format is correct in Format > 
Document > Footnote Properties…

3 In all other files of the sequence, set the numbering prop-
erties in Format > Document > Footnote Properties> 
Numbering set First Footnote Number to Continue Num-
bering from Previous Footnote in Book.
Check whether the footnote format is correct in Format > 
Document > Footnote Properties…

Note: The numbering will be correct only after you have set up a 
book from the files you have prepared.
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Footnotes and text columns

There is only one ¶ format for text footnotes available. Hence 
you must decide between the appearance.

In the first example the footnotes are «In column». The foot-
note from the title becomes the last one and its text extends 
across all columns as the title does.

In the second example the footnotes are «Across all col-
umns». The footnote from the title becomes the first one.

Editing footnotes

To move a footnote reference, select it, then cut it to the 
clipboard buffer and insert it (paste) it at the new location.

To change the reference appearance (e.g. from numbered to 
symbol), Format > Document > Footnote Properties and 
modify the number format (prefix and suffix) to your 
needs.

Note: Modifications of the format of footnotes applies to all footnotes 
in the document!

To change the appearance of the footnote, modify its para-
graph format.

This title is across all columns 1

This is just text in the column 
and uses a footnote reference 
in this left column 2.

This footnote reference is in 
the right column 3.

1. This footnote is refenced in the title

2. This footnote is referenced in 
the left column

3. Footnote referenced in the right 
column

This title is across all columns 1

This is just text in the column 
and uses a footnote reference 
in this left column 2.

This footnote reference is in 
the right column 3.

1. This footnote is refenced in the title
2. This footnote is referenced in the left column
3. Footnote referenced in the right column
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Hyperlinks
Milestones on the way to hypertext as we know it from the 
worldwide web are:

Vannevar Bush and his "Memex" (1945)

Douglas C. Engelbart with "Augment" (starting 1963)

Ted Nelson with project "Xanadu" (starting 1965)

Arno Schmid’s novel "Zettels Traum" (1970)

Find a good German summary here.

Hypertext in FrameMaker

Since version 3 FrameMaker supports hypertext in various 
forms:

Cross references provide live links during creation of docu-
ments. These are converted to hyperlinks in HTML and 
PDF.

Any generated file (such as the Table Of Contents, or 
Index) can automatically get cross references to their tar-
get information. See Hypertext links on page 9-2

Hyperlinks are active if the document is converted to HTML 
(see Generate HTML on page 12-1).

Hyperlinks are active if the document is converted to PDF 
(see Refining the PDF output on page 10-10)

Specific hypertext markers can refer to other documents or 
URLs on the web. 

Active area The active area (where you can click on) is defined by the text 
until the character format changes. You may also define sen-
sitive images or areas. See the manual for this technique.

Insert hyperlink

Select the hot spot text and highlight it with a character 
format 

In Special > Hypertext select the appropriate type of link. 
For a web-links this is «Go to URL».

The URL must be typed completely:

message URL http://www.daube.ch/docu/fmaker00.html

Note: Case of command and blank after command is relevant. If 
backslashes are used (e.g. in Windows paths), they must be 
doubled when preceding certain characters (f, i, n, o, s).

Format hyperlink It is good practice to highlight the hyperlink with a special 
character format such as hyperlink. Please avoid underscor-
ing in documents - its really looks bad:

This is a link to my FrameMaker stuff. Text outside hot spot.

http://www.daube.ch/docu/fmaker00.html
http://www.ibiblio.org/pioneers/bush.html
http://sloan.stanford.edu/mousesite/1968Demo.html
http://www.iath.virginia.edu/elab/hfl0155.html
http://www.xanadu.net/
http://www.ids-mannheim.de/grammis/ht/htxt304.htm
http://www.ids-mannheim.de/grammis/ht/htxt.htm
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Types of hyperlinks

FrameMaker supports a number hyperlink types. For example, 
the Equations palette is a FrameMaker document with lots of 
hyperlinks. The following table is just an excerpt:

Note: In file paths or URLs the backslash is not valid. The solidus 
(normal slash) must be used

Links to documents and applications

With links to documents the associated program (in Windows) 
will be started to view the document:

Open file in text editor message openfile D:/System_ddd/Documentation/data/FM6-
ini-mods.txt

Display directory with
explorer

message openfile C:/WINNT/Fonts/ATMFolder/

Play sound message openfile D:/System_ddd/sounds/5tones_up.wav

Path relative to current
document

sub-folder: message URL folder/file.ext

same folder message URL file.ext

parallel folder message URL ../folder/file.ext

1 level above message URL ../../folder/file.ext

Start a (Windows)
application

An application can be started directly (on Windows):

message system H:/Utilities/SearchReplace/SR32.EXE

Command (drop down list)a

a. For restrictions in conversion to PDF see Refining the PDF output on page 10-10

Syntax Exampleb

b. Not all examples may work in your environment...

PDF

Alert c

c. In PDF this will be a text note, the title will not be presented as such, but stay within the text.

alert text alert Time for lunch now! Y

Alert with title alerttitle title:text alerttitle Hello - I’m the 
title:This is in the 
first line
and this ...

Y

Open document
(same type as source- fm or pdf)

openlink path openlink D:/System_ddd/
Documentation/Syshw.fm

Y

Open document with associated applica-
tion

message openfile path openfile D:/System_ddd/
DDDcontrol.ini

Y

Go to URL message URL url message URL http://
www.daube.ch/docu/
fmaker00.html

Y

Specify named destination newlink name newlink here_we_go Y

Jump to named destination gotolink name gotolink ref_crossrefs Y

Popup menu
(works only in FrameMakerView mode)

popup 
textflow_on_refpage

popup popup1
N

Time for a break now, buddy

Hello - I’m the title:This is in the first lineAnd this (after a carriage return) is in the secondEven more lines are possible, but the maximumlength of the marker text is 255 characters.

http://www.daube.ch/docu/fmaker00.html
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Bibliographies
Bibliographies are an essential element in scientific publica-
tions. The format of the bibliographic data as well as the form 
of references varies. Each institution may have its own habits 
and publishers add to the variations. 

While everything can be set up in plain text, this section aims 
at formats which provide hypertext links from the reference 
to the bibliographic data. This goal may limit the formats.

Hypertext links are preserved in the document if transformed 
to PDF or HTML. In this section these links are highlighted 
with character format hypertext.

Numbered bibliography

A simple form of references use only the numbers of the bib-
liographic data, which basically are numbered lists.

References A reference uses the cross reference format <$paranum> to get 
the number including the brackets and <$paranumonly> to get 
just the numeric part for multiple entries.

The second form is more universal, but requires you to enter 
the brackets manually: single [3] or multiple [1, 2].

Bibliographic data [1] Daube, K., Aufbau des OBRZ Runtime Systems, in 
Technisch-wissenschaftliches Rechnen am MVS System. 
1989, OBRZ AG: Zürich. Handbuch 400.50.10.

[2] LaBonté, A. A New Data Type for National Language? 
in SEAS Anniversary Meeting. 1989. Amsterdam, The 
Netherlands: SHARE European Association.

[3] Garneau, D., ed. National Language Support Reference 
Manual. January 10, 1990 ed. National language 
Information Design Guide, ed. IBM. Vol. 2. 1990, IBM 
National Language Technical Centre: Toronto, CDN.

Essential properties of
paragraph format

The paragraph format for the bibliographic data in this exam-
ple is lit-ref-numbered with the main properties: Auto num-
bering sequence: «L:[<n+>]\t».

You may rearrange the paragraphs to get a sorted list and 
then update the references with Edit > Update References: 
all Cross References.
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Name and year in references

If you need independent access to the names and publication 
years to combine references, you need to set up paragraphs 
for each element. To stack the (logical) paragraphs in one 
physical paragraph you define the stacked ones as Run-in 
Headings. (format lit-short in this example).

This method provides a sequential list of data items (name, 
year, name, year, …) in the cross-reference dialogue. Strangely 
enough the first entry in the list is the second paragraph of 
the specified format…

References The cross reference format in the following examples is 
<hypertext><$paratext></> and refers to paragraphs of for-
mat lit-short.

The issue of character coding in electronic data processing 
was addressed quite aggressively by Daube in 1989 and again 
in 1990.

Bibliographic data Daube 1989 Daube, Klaus, 'Text and Code - A Dragons 
Pond.' Proceedings of the 30. G.U.I.D.E. 
conference in Basel. G.U.I.D.E. Headquarters, 
1989.

Comparing the human habits of gesture and miming 
with codes in data processing shows a severe gap in 
understanding coding mechanisms. This is the source 
of many problems related to national language 
support in data processing applications. This text 
also is available in French, kindly translated by 
Ministère des Communications du Québec, St. Foy, 
Canada,

Daube 1990 Daube, Klaus, National Language Support in 
SUSI, OBRZ AG, Handbuch 410 
(Dokumentverarbeitung mit SUSI), Kapitel 
410.20.35. Zürich 1990.

The text formatter SUSI supports code page switching 
(also within a file. A piece of text also may have the 
attribute language, to which hyphenation is bound. 
National keyboards can be used. The code page used 
internally is based on code page 037, the character 
set supports most Western and Eastern European 
languages.

Essential properties of
paragraph formats

lit-short Pagination: Run-in Head with default punc-
tuation « «. 

bibliography Pagination: anywhere; auto numbering 
sequence: «\t»; Left indent: 3cm; tab posi-
tion: 3cm.

Sorting the bibliographic data

To sort the bibliographic data in lists (paragraphs), either

move the paragraphs by cut and paste, or

use the plug-in Enhance from www.sandybrook.com which 
allows you to sort paragraphs (not table rows).

paragraphs «lit-short»

paragraph bibliography

generated TAB

X-ref. markers
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Reference and bibliographic entry

Thomas M. Reuter (tomreuter@compuserve.com) communi-
cated the following method: Use two paragraph formats for 
the bibliographic data (e.g. B1 for the part to be referenced 
and B2 for the full bibliographic data).

Paragraphs B1 (reference texts) must not print, hence they 
use a special colour which is defined ‘not to print’ (View > 
Color > Views…). In the example below this colour is named 
Bibliographie.

References Set up a cross reference to use it with the specially prepared 
coloured entries (paragraph format B1). Some examples are:

<$paratext>
<$aranum> <$paratext> (page <$pagenum>)

With these definitions you can create references in line, such 
as the mentioning of Marty et al without any fuss. You can 
also refer to the completely numbered item as in this exam-
ple: [2] Th. Reuter, FrameMaker (page 18).

You can extend this method to use more than one concealable 
short entry (variants of B1 paragraphs). Be aware of identifi-
cation problems in the cross reference dialogue.

Bibliographic data [1] Marty et al
[1] Marty Ch., R. Philipona and C. Frohlich, 1999: Probleme

mit Bibliographien in Framemaker, Journal of
FrameMaker, Nr. 43, 256-268.

[2] Th. Reuter, FrameMaker
[2] Reuter, Thomas M., 1999: Das Buch zu FrameMaker.

SmartBooks Kilchberg. ISBN 3-908488-28-1

Essential properties of
paragraph formats

B1 Next paragraph: B2; colour: Bibliographie; Keep 
with next; auto numbering sequence: «B:[<n+>]\t«.

B2 Next paragraph: B1; no keep; auto numbering 
sequence: «B:[<n>]\t».

Colour views The file with the bibliographic data needs special settings for 
the colour views (View > Color > Views…):

When working with the bibliography you need to see the 
text and use view 1.

For printing you must hide the coloured entries using 
view 2.

mailto:tomreuter@compuserve.com
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Table of bibliographic data

Since tables can be sorted, it would be nice to use them for 
bibliographies in place of the above mentioned lists.

However, sort destroys any markers in tables. This bug exists 
since we can sort tables (FM 5.5). Hence a special procedure is 
required:

Bug needs special
procedure

Set up the table with the bibliographic data. Use a distinct 
¶-format for the reference data (e.g. lit-short2).

Sort the table before you set up any cross references.

Insert the cross references at the desired places. To ease 
this, use a special notation in the running text to find the 
places where you want to insert the cross references (e.g. 
«[[engelbrecht 88").

If you need to update the table, insert new items at the 
alphabetic location and do not sort the table any more!

Example running text While [[Blum 2000 and [[Engelbrecht clearly describe the 
problem, [[Helm 1990 just tinkers around and does not pro-
vide any reasonable discussion of the problem.

After inserting the
references

While Blum et al, 2000 and Engelbrecht, E.G., 1998 clearly 
describe the problem, Helm, J. L.,1990 just tinkers around 
and does not provide any reasonable discussion of the Thin 
Tree Syndrome.

Blum et al, 
2000

Blum, L., Bajaj, P., Gass, J., Poulikakos, D., 2000, «Pollutant Formation 
of a 20 kW Domestic Gas Burner Operated at Partial Premixing Mode», 
Proceedings of Second European Conference on Small Burner 
Technology and Heating Equipment (ECSBT 2), Germany. 

Engelbrec
ht, E.G., 
1998

Engelbrecht, E.G., 1998, «Modelling of Premixed Combustion in a Gas 
Turbine», PhD Thesis, Cranfield University, England. 

Helm, J. 
L.,1990

Helm, J. L.,1990, Energy Production, Consumption and 
Consequences, National Academy Press, Washington, USA.

N. N., 
1998

N. N., 1998, ELCO Energiesysteme AG, Betriebsanleitung Gasbrenner 
Low-NOx, Vilters.

N. N., 
2000

N. N., 2000, Japanese Advanced Environmental Equipment, Global 
Environment Centre Foundation, Japan, http://nett21.unep.or.jp/
JSIM_DATA/JSIM13.html. 
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Bibliography with EndNote
EndNote (www.endnote.com) is one of the most used applica-
tions to maintain bibliographic data bases and generate bibli-
ographies in scientific works.

The product is widely used for dissertations, theses and sci-
entific publications of all kinds. EndNote is available for Win-
dows and Mac OS. It is well integrated with MS Word by means 
of macros and DDE (Dynamic Data Exchange).

Cooperation with FrameMaker

Advantages using 
EndNote

Although bibliographies can easily be created in FrameMaker 
by means of cross reference, EndNote provides the following 
advantages:

Maintenance of a bibliographic database for several works.

The database can be filled with data from various sources 
including the Internet.

Generated references and citations can adhere to a large 
number of output formats (most publications require spe-
cial formatting).

Drawbacks of EndNote Over the time the various EndNote releases have changed 
their behaviour significantly, in particular with relation to 
FrameMaker:

Only EndNote versions 1 … 5 provided the function Scan Doc-
ument in mif. Version 6 does not support any scan and start-
ing with version 7 scanning RTF is back which allows to work 
with most text processors and provides some possibilities for 
FrameMaker.

From version 8 on the Unicode support in EndNote hinders 
direct handling of the temporary references in FrameMaker, 
because FrameMaker is not Unicode compliant.

Using EndNote’s RTF scan 
facility

It may seem reasonable to export the FrameMaker document 
as RTF, then scan and modify it by EndNote and finally import 
the RTF again into FrameMaker. Some problems are:

Anchored frames get new attributes (at insertion) with all 
previous content as one image.

Layout and formats must be re-applied.

Cross references become useless, must be rebuilt.

EndNote 
Version

Cooperation

Handling non-Word files Word FM

5 (2001-09) Scans MIF and RTF, handles non-ASCI characters 
not correctly

+++ ++

6 (2002-06) No scan of RTF or MIF possible – purely a Word 
thing

+++ 0

7 (2003) Scan of RTF possible, but not MIF +++ +

8 (2004) New data base format to support UNICODE; only 
working with Word, No MIF support

++++ +

http://www.endnote.com/
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Solution with 
D+DD utility

D+DD has developed the utility FM+EN which controls the 
collaboration between FrameMaker, Word and EndNote. 
Manipulations in the paste buffer overcome the code differ-
ence between EndNote (Unicode) and FrameMaker (Mac 
Roman).

Process overview

The utility FM+EN controls the data flow between the three 
involved programs:

Process details Temporary citations are copied from EndNote and pasted into 
the FrameMaker document. However, not CTRL+v is used for 
pasting, but the new command CTRL+y provided by FM+EN. 
This command transforms the Unicode references to Frame-
Maker-digestible references.

Step 1 The temporary citations are collected in FrameMaker and 
written into an MS Word file. Two forms are written to avoid 
problems during resolving the references in EndNote:

The long form which is present in FrameMaker, for exam-
ple [[Müller, 1925 #13]]

The short form containing only the necessary information 
for EndNote to resolve the reference, for example {#13}.

[[Müller, 1925 #13]] {#13}¶ 

Step 2 EndNote scans this Word file (in rtf = Rich Text Format) 
based on the current bibliographic database and the selected 
output format. The result is a new rtf file containing both the 
formatted references and the generated bibliography:

Step 3 The first part of the rtf file from step 3 now contains format-
ted references to the right:

Müller et al 
[[Müller, 1925 
#13]] devel-
oped an open 
issue on this 
and hence …

Bibliography

[[Müller, 1925 #13]] {#13}
[[Müller, 1925 #13]] {#13}
[[Müller, 1925 #13]] {#13}
[[Bartels, 1981 #14]] {#14}
[[Müller, 1925 #13]] {#13}
[[Daube, 1989 #6]] {#6}
[[LaBontÃ©, 1989 #11]] {#11}
[[LaBontÃ©, 1989 #11]] {#11}
[[LaBontÃ©, 1990 #8]] {#8}
[[Garneau, 1990 #12]] {#12}
[[xxx xxx xxx]] {#}

EndNoteBibliographic

database

FM temporary citations

Müller et al [1] 
developed an 
open issue on 
this and hence 
…

Bibliography

[1] Müller, …

[2] Bartels, …

FM Bibliography resolvedWord

[[Müller, 1925 #13]] [1]
[[Müller, 1925 #13]] [1]
[[Müller, 1925 #13]] [1]
[[Bartels, 1981 #14]] [2]
[[Müller, 1925 #13]] [1]
[[Daube, 1989 #6]] [3]
[[LaBontÃ©, 1989 #11]] [4]
[[LaBontÃ©, 1989 #11]] [4]
[[LaBontÃ©, 1990 #8]] [5]
[[Garneau, 1990 #12]] [6]
[[xxx xxx xxx]] {#}

1. Müller, P.D.H., De 
viris illustribus. 9 ed. 
1925, Hannover: Carl Meyer 
(Gustav Prior). 155.

2. Bartels, K., Veni 
vidi vici. 5 ed. Lebendige 
Antike. 1981, Zürich: Artemis 
Verlag. 88.

Word

Output

formats

1 2 3

FM+EN
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[[Müller, 1925 #13]] [1]
[[Bartels, 1981 #14]] [2]
[[xxx xxx xxx]] {#}

With this data the temporary references in the FrameMaker 
file are searched and replaced by the formatted form.

The second part of the new file contains the generated bibli-
ography:

1. Müller, P.D.H., De viris illustribus. 9 ed. 1925…
2. Bartels, K., Veni vidi vici. 5 ed. Lebendige…

The user must copy this bibliography to an appropriate place 
in the FrameMaker document or book and format it.

Note: You must use Paste Special and select RTF to maintain the 
local character formatting from Word.

Utility FM+EN

Note: The following is an excerpt from the separate documentation 
about the utility FM+EN. See the D+DD website for details.

After start of the utility FM+EN you will get an icon in the sys-
tem tray. For the insertion of the temporary citations the util-
ity provides the «hot key» CTRL+y for the special paste 
operation.

Inserting a citation 1 In EndNote select the Citation in the Database view and 
copy it to the clipboard (CTRL+c). 

2 Switch to FrameMaker and place the cursor in the docu-
ment where you want to place the citation.

3 Paste the temporary citation from the clipboard (CTRL+y). 
The inserted temporary citation has the format 
[[LaBonté, 1989 #11]].

Note: For pasting the same temporary citation a second (or more) 
time use CTRL+SHIFT+y or CTRL +v.

You will run the process steps only after all (or most) of the 
temporary citations are inserted in the document or the docu-
ments of a book.

Operating the utility Right clicking on the utility icon in the system tray opens the 
following menu:

About Provides a panel with program information and a disclaimer.

Program Setup It is essential to define the UI languages of the involved pro-
grams before you execute the process steps. Other settings – 
such as working slowly or create footnotes from bibliographic 
references – are optional.

Change References and
build Bibliography

The three steps of the process are run in sequence. Follow the 
instructions provided by popup-messages.

Documentation Display the PDF with the full documentation.

Suspend Hotkeys If for any reason you need in an application the key CTRL+y 
you can suspend the key function from FM+EN and later re-
activate it.

http://www.daube.ch/docu/fmaker41.html
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Exit Close the utility. You may use the PAUSE key for this.

Final Work The completion of the process is displayed by a dialogue 
which reminds you to copy the generated bibliography into 
the FrameMaker document.

Note: EndNote uses local formatting in the text (not Character for-
mats) and puts the numbering in the text. For different format-
ting (e.g. automatic numbering by FrameMaker) you need to 
edit the text.

Bibliography in a FrameMaker book

If the utility is started in a FrameMaker book, it automatically 
collects and changes the citations in all files of the book.

1 Open all files of the book and handle messages concerning 
«missing fonts» or «missing graphics» accordingly.

2 Go to the book window and start FM+EN. The document 
windows will be maximised to get correct window titles.

3 Place the generated bibliography in a separate chapter or at 
a place of your desire.

Bibliography in footnotes

A special form of bibliography places the bibliographic refer-
ences in footnotes. The citation in the text is just the footnote 
reference. For example:

Hecate est Iovis et Latonae filia 10), soror Apollinis. Est 
tricopor et triceps, magicarum artium magistra ac 
fascinationum praeses, cinctra latrantium canum 11); 
noctu stans in triviis vel prope sepulcra et ubi loca sunt.

To achieve this, you create a footnote and insert the tempo-
rary citation in the footnotes. FM+EN will replace the tempo-
rary citation with the bibliographic reference. You need to 
specify this in the setup.

1. Müller, P.D.H., De viris illustribus. 9 ed. 1925, 
Hannover: Carl Meyer (Gustav Prior). 155.

2. Bartels, K., Veni vidi vici. 5 ed. Lebendige Anti-
ke. 1981, Zürich: Artemis Verlag. 88.

3. Daube, K. Text and Code - A Dragons Pond. in 
G.U.I.D.E. Conference. 1989. Basel, Switzer-
land: GUIDE.

10 LaBonté, A. A New Data Type for National Language? in SEAS Anniversary 
Meeting. 1989. Amsterdam, The Netherlands: SHARE European 
Association.

11 Garneau, D., ed. National Language Support Reference Manual. January 
10, 1990 ed. National language Information Design Guide, ed. IBM. Vol. 2. 
1990, IBM National Language Technical Centre: Toronto, CDN.
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FrameMaker books

Overview

A FrameMaker book merely is a logical concept to 
handle a set of files. The main purpose of books is 
to automate the generation of Table of Contents, In-
dex and the pagination process as well as the cross 
references. 

Chapters in a book can consist of more than one 
file.

All files in a book can receive formats (style ele-
ments) from any document at once. This is a great 
feature of FrameMaker.

Contents

Handling book items ...............................................  2

Numbering documents ............................................  5

Master books .........................................................  9

Combining Two Books ...........................................  10

Book error log ......................................................  11

Migration from FrameMaker 5.x .............................  14
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Handling book items
Either you start a new book without having any clue which 
files you want to put in.

Or you start from an already existing file.

The sequence of files in the book determines the chapter 
numbers (and other numbering).

Generated files get the name from the current book, for 
example, booknameTOC.fm.

Icons in book window

The files in the book window use different icons:

Book

Generated file

Standard file

Functions in the book window

Toggle the display of file name or heading text with the  
button. The displayed text is the content of the first para-
graph. Be aware that this may be a paragraph number only.

Add a file to the book with the  button. You get a full 
Open dialogue to select from any directory. The book window 
displays the relative path of the file to the book. As long as 
the book is not saved, the absolute paths of the files are dis-
played (see page 4).

Update all files in the book with the  button. This updates 
the numbering, cross references and (re-)generates TOC, 
Index, etc.

Open a file in the book, double click on its name or title dis-
play.

Activate an already open file by clicking on its name or title 
display.

Page numbers In the lower left corner of the book window the page range of 
the selected file(s) is indicated. An asterisk indicates changes 
in the file since last save.

Rename file

Note: Do not rename a file with the file manager, if this file is used in 
a book. You will need to set up the book again.

To rename a file, select it and change its name (similar to the 
Windows File Manager). For this operation it may be necessary 
to switch the display to Display File Names.

File names Document titles
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Before renaming a file FM saves the file with the old name and 
then updates all references of the renamed file.

Delete file To delete a file from the book, select it and press the  but-
ton or use the DEL key. Update the book to reflect changes in 
TOC etc.

Note: You do not get a chance to confirm the deletion, but you can 
undo the deletion. Not the file itself is deleted, just the notion in 
the book file.

Change location of file in 
book

Select the file and move it with the mouse (Drag and Drop) to 
the desired location. There is no possibility to move the files 
with the keyboard.

You may need to adjust the numbering and/or pagination 
properties of the book files after rearranging the file order.

Menu items related to the book window

File menu: For the book window some menu items change (see figure).

You get access to all files in the book (for open, close or save), 
if you hold the SHIFT key while selecting menu File.

When in a document file (x.fm) holding the SHIFT key while 
selecting the menu File lets you close or save all open files.

Edit menu If a book window exists in the current FrameMaker session, 
the following dialogues get an additional option button Book 
to allow processing in all files of the book. The 

Edit > Spelling checker.…gets the Book radio button enabled 
and selected.

Find/Change… gets the Look in Book radio button enabled 
and selected.

Additional items in Edit
menu

Rename File, Delete File from Book and Update Book… are 
only present for an active book window.

Context menu 
(right mouse button)

When you have selected a file in the book window, the context 
menu (press the right mouse button to get it) provides the fol-
lowing functions (ignoring obvious ones here):

Undo Drag/Drop You have changed the order of the files 
with drag and drop. This will be undone.

Redo Drag/Drop The previous drag and drop is redone.

Numbering… Provides the numbering properties for the 
file (see Set up numbering of chapter files on 
page 6).

Pagination… Provides the pagination properties for the 
file (similar to Format > Page Layout > 
Pagination)

Set up xxx xxx is the type of a generated file (Table of 
Contents, Index, etc.). Use this to define the 
properties of the currently selected file.
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Add files to the book

Start a book

File > New > Book starts a new book. If an FM-file is open, 
you are asked whether you want this file to be in the book. 
In this case the book gets the name from this file (e.g. 
maintenance.book)

You may now add files to the book (see later). They may be 
in any directory.

In the Save as... provide a reasonable name for the book, 
for example, microkeratome.book.

Add a chapter (file) to the 
book

1 In the book window use Add > File… to get a standard file 
list.

2 Select the desired file from the file list and Add! The file 
will be placed below the currently selected file in the book.

3 You may wish to move the file to another location in the 
book. Just move it with the mouse up or down (no key-
board function available).

Add a generated file to 
the book

FrameMaker can generate table of contents, indexes, lists of 
markers or paragraphs etc. This information is used in appen-
dices or prefaces of real books or long documents.

Use the Add menu to add generated files to the book. This 
menu is only visible if the book file is active. Select the 
desired type of file:

Table of Contents…In the next dialogue specify the properties 
of the Table of Contents (see Table of con-
tents on page 9-3).

List of The sub menu gives you a list of list types. 
These lists are based on marker types or 
paragraph styles (see Arbitrary lists on 
page 9-15.

Standard Index… In the next dialogue specify the properties 
of the Index (see Index creation on 
page 9-9).

Index of Gives you the choice of predefined indexes 
in a sub menu.

To add a generated file to the book,

1 Select the type of file from the Add menu (and probably 
using a sub menu)

2 If a detail dialogue pops up, either use the presented 
defaults (may be changed later) or set the properties now.

3 Back in the book window you may wish to change the loca-
tion of the file in the book.
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Numbering documents

Overview

The following example demonstrates the numbering capabili-
ties with FrameMaker. Normally the numbering properties of 
the various files are set from within the book window. 

The settings are transferred into the individual files.

Lorem ipsum dolor 
sit amet, 
consectetuer 
adipiscing elit, sed 
diam nonummy nibh 
euismod tincidunt ut 
laoreet

2 - 33

Lorem ipsum dolor 
sit amet, 
consectetuer 
adipiscing elit, sed 
diam nonummy nibh 
euismod

2 - 32

Lorem ipsum dolor 
sit amet, 
consectetuer 
adipiscing elit, sed 
diam nonummy nibh 
euismod

tincidunt ut laoreet
2 - 2

These properties are set in the book window for each file with Format > Document > Number-
ing 

booknameTOC introduction main stuff-1 main stuff-2 file name (example.)

0
continue numbering 

( 1)
continue numbering

( 2)
same as previous file 

( 2)
Chapter numbering

restart
format= roman

restart
format= numeric

continue continue
Page numbering

restart restart continue continue Paragraph numb.

TOC
Hecata....... 2-5
Lorem........ 2-7
Foxes........2-31

Foxes
Lorem dolor sit amet, 
adipiscing elit, sed 
diam euismod 
tincidunt ut laoreet 
maximu vesuvius 
tanebre solo.

2 - 31

Page numbering on Master 
page

a) System variable Chapter Number 
(<$chapnum>)

b) System variable Current Page #  
(<$curpagenum> )

c) Format of page number is set in 
Format > Document > Number-
ing (page # style) in the docu-
ment or from the book.

Lorem ipsum dolor

sit amet, consectetuer 
adipiscing elit, sed 
diam nonummy nibh 
euismod tincidunt ut
laoreet 

1 - 2

Chapter 1
Hecate est Iovis et 

Latonae filia, soror 

Apollinis. Est tricopor 

et triceps, nos a lo in 

particolo ms.

1 - 1

1 - #

Master page

b)

Chapter 2
Malenka munkis 

domodossola 

inkuration mea gurki 

doppo figuratione en 

stria fides bene no.

2 - 1

<$chapnum> - <$curpagenum>

c)

a)

i

2 - 2 2 - 32

2 - 33
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Set up numbering of chapter files

A FrameMaker document holds a set of numbering properties:

Paragraph numbering (see details in Hierarchical numbering 
on page 3-10).

Page number (used in layout)

Chapter number (new in FM 6)

Volume number (new in FM 6)

Numbering of the standard footnotes

Numbering of the table footnotes

These properties apply to text files as well as to generated 
files.

Set up a numbering 
scheme

If your book has more than just a few files it is useful to set 
up a table of the properties:

Apply the numbering properties

For the files in the book apply the properties book by file:

1 Select the file

2 Either use the context menu and select Numbering or use 
menu Format > Document > Numbering.

Volume number Set the volume number according to your file structure:

In 1st file of vol. 1 Set the Volume # to 1 and select an appro-
priate format (I, II, III or A, B, C etc.)

In next file of vol. Set Use Same Number as Previous File.

In 1st file of vol. x Set Continue Numbering from Previous 
File in Book.

Read from File This takes the number as specified in the 
document file with Format > Document > 
Numbering.

File Vol. Chapter Page number Paragraph Footnotes

p
re

lim
in

ar
y. title 1 0 1 roman restart 1

booknameTOC same same continue roman restart1 continue

introduction same same continue roman restart. continue

co
n

te
n

t

planning-1 same next 1 arabic restart. continue

planning-2 same same continue arabic continue continue

planning-3 same same continue arabic continue continue

working-1 same next. continue arabic continue continue

working-2 same same continue arabic continue continue

working-3 same same continue arabic continue continue

ap
p

en
d

ix diagrams next next 1 A restart. continue

drawings
same same continue next continue continue
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Chapter number Set the chapter number according to your book structure:

In 1st file of ch. 1 Set the Chapter # to 1 and select an appro-
priate format (1, 2, 3 or i, ii, iii etc.)

In 1st file of ch. x Set Continue Numbering from Previous 
File in Book.

In next file of ch. x Set Use Same Number as Previous File.

Read from File This takes the number as specified in the 
document file with Format > Document > 
Numbering.

Page number Set the page number according to your book structure:

In 1st file of ch. 1 Set First Page # to 1 and select an appro-
priate format (1, 2, 3 or i, ii, iii etc.)

In 1st file of ch. x For continuous page numbers set Continue 
Numbering from Previous File in Book 
For numbering scheme x-p set the number 
to 1.

In cont. files Set Continue Numbering from Previous 
File in Book.

Read from File This takes the number as specified in the 
document file with Format > Document > 
Numbering.

Paragraph number Set the paragraph numbering according to your book struc-
ture:

In 1st file of ch. 1 Set Restart Paragraph Numbering.

In 1st file of ch. x For continuous page numbers set Continue 
Numbering from Previous File in Book 
For numbering scheme x-p set the number 
to 1.

In cont. files Set Continue Numbering from Previous 
File in Book.

Read from File This takes the number as specified in the 
document file with Format > Document > 
Numbering.

Footnote number Set the footnote numbering according to your desire:

In 1st file of ch. 1 Set First Footnote # to 1 and select an 
appropriate format (1, 2, 3 or i, ii, iii etc.)

In other files For continuous footnote numbering across 
the book set Continue Numbering from 
Previous File in Book.

To start with 1 on each page, set Start Over on Each Page.

Read from File This takes the number as specified in the 
document file with Format > Document > 
Numbering.
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Table footnote Set the numbering properties for footnotes in tables accord-
ing to your desire:

Format Select an appropriate format (1, 2, 3 or i, ii, 
iii etc.)

Read from File This takes the number format as specified 
in the document file with Format > Docu-
ment > Footnote Properties…

Book wide functions

Selection of files To select all files in the book use CTRL+A. 

To select a contiguous group of files, select the first file 
and then SHIFT+click on the last file of the group.

To select arbitrary files, select the first file and then add 
more files by CTRL-clicking on the additional files.

Note: Just selecting the book (the first line in the list) does not select 
anything!

Search / Replace When issuing an Edit > Search/Replace from the book win-
dow, the search starts in the file which is selected in the book 
window. The search automatically continues to the next file in 
the book and wraps to the first file etc.

If you change anything in a file, the search/replace loops in 
this file until you did not change anything in the file.

Spell checking When issuing an Edit > Check spelling…from the book win-
dow, the check starts in the file which is selected in the book 
window. The check automatically continues to the next file in 
the book and wraps to the first file etc.

Update cross references and numbering

Neither the chapter numbers (or other paragraph numbering) 
nor cross-chapter references are current, until the chapter 
files are connected by a book.

To update the numbering 
and the references 

1 Open the book file

2 Select the files to be updated.

3 Press the update button ( ) or use Edit > Update Book…

4 In the dialogue Update Book move all files which you want 
to re-generate (TOC, index etc.) into the left pane. Move 
everything else to the right. You may have nothing in the 
left pane – Then only the numbering and cross references 
will be updated.

5 Press the Update button. All cross references, paragraph 
numbers and (if applicable) generated files are updated 
now.
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Master books
Since FrameMaker version 6 it is possible to create master 
books. Keep in mind that a FrameMaker book is just a logical 
collection of files, in the case of a master book the collection 
of FrameMaker book files.

In a master book, only the following actions are possible:

Add a book file to the master book

Remove a book file from the master book

Open a book file

Create a master book To create a master book, just create a book file with File > 
New > Book and save it with an appropriate name, e.g. 
master.book.

When adding files to the book with the icon  or with menu 
Add > Files you get a message about non-document files:

Activate Skip Non Document Format Messages to avoid this dia-
logue for future imports of book files.

The book files within the master book are represented with a 
book icon:

Access to document
files

Use this master book to open the individual book files and get 
access to the document files in these book files:

Source Dick Gaskill <dgaskill@bluepumpkin.com>
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Combining Two Books
By Bright Path Solutions [www.travelthepath.com]

Bright Path Solutions use this technique when making custom 
training books, as it allows them to easily pull topics from 
different classes without browsing for them.

1 Open your first book and – if desired – save it as a new 
name (such as, xyzcustomclass.book). 

2 Then, open the second book and «tile» or resize the open 
books so you can see them side-by-side. 

3 In the second book, highlight the range of files you wish to 
move into the first, custom book. (To highlight, click to 
select the first file desired and shift-click to select the last 
file desired.) 

4 Click down on the highlighted range and hold down the 
mouse button. Drag the files from the second book into the 
first book and drop them where desired by releasing the 
mouse button. (A small horizontal line appears to show 
you the drop location and moves as you move.) 

5 Close the second book without saving. 

6 Save the first, custom book. Adjust the file settings if 
desired and Update to adjust your table of contents and 
page numbering. 

You now have a custom book with topics/chapters combined 
from two book files.

Numbering chapters with text

Volumes and chapters in a book may be numbered not only 
arabic or roman, but also as text. This comes in handy to 
specify part titles and the like:

1 In the Numbering Properties dialogue in the book, set the 
Volume # Format for the file in question to Text and put 
the entire part title (number and text) in the Volume # field. 
So, for instance, the Volume # field in your Part 1 file 
would contain: 

Part 1: Part Title 

2 Then, define the autonumber of your part title paragraphs 
as <$volnum>. Your part title paragraphs can then be empty 
paragraphs, with the title text as part of the autonumber.

[richard.combs@polycom.com]

http://www.travelthepath.com/HTML/faqts.shtml
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Book error log
When updating a book, errors are collected in a file called 
Book Error log - bokname.book. This file…

can not be saved - it exists only during the current Frame-
Maker session. If you want to proceed tomorrow with the 
clean-up, select all items (CTRL+A) and copy them to a text 
editor window (or into a frame maker document).

contains hyperlinks as you know them from the Web (blue 
text with underline).

is cumulated during a FrameMaker session, if you do not 
delete (close) it between book functions.

It is good practice to work off all problems which are 
reported in this log, then delete (close) the log and update the 
book again.

Some of the errors reported would need your intervention or 
decision. Hence the book update will not be complete until 
you have handled these situations (e.g. missing fonts).

Sample report Book Error Report
E:\FM-course\handout_60\course00.book

October 21, 2000 6:46:36 pm 
E:\FM-course\handout_60\design.fm

Print setting for color Black is inconsistent.
Print setting for color Cyan is inconsistent.

E:\FM-course\handout_60\graphics.fm
Unresolved Cross-Reference to import_apps.fm
 

E:\FM-course\handout_60\references.fm
Unresolved Cross-Reference to book.fm

Update of file xxx is not possible

When updating the files in a book, FrameMaker can not react 
on the error messages such as

Font xxx missing and hence substituted by yyy for this ses-
sion. See Font issues on page A-33.

Language abc missing (dictionary not installed).

To handle this problem 1 Open all files in the book with SHIFT+File > Open All Files 
in Book.

2 Respond to the error messages.

3 Perform the desired book operation, such as import for-
mat.

4 Close all files in the book with SHIFT+File > Close all files 
in book.
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Inconsistent settings

Inconsistent colour 
settings

For handling inconsistent colours see Inconsistent colour on 
page A-32

Inconsistent conditional 
text settings

A particular condition tag is set to be shown in one file and to 
be not shown (hidden) in another. This is an informal mes-
sage and need not to be cleared – if the settings are what you 
want.

To get rid of this error at the update of a book, 

Select all files in the book

In View > Show/Hide Conditional Text set the settings 
you need
You may wish to eliminate any conditions by Show All.

Inconsistent numbering 
properties

This indicates that the numbering set within a file differs to 
the settings in the book file. To correct this:

Check the numbering for each file in the book

Import and distribute document properties

Import formats and 
distribute to all files of 
book

1 Open the book file

2 Select the files to be updated (see image).

3 Continue with the procedure described at Import formats 
into book files on page 3-15.

Import and distribute 
only part of a format 
category

To import just some of the needed formats (e.g. paragraph 
formats for headers only) you need an intermediate docu-
ment.

The procedure is described at Import only part of a format cate-
gory on page 3-15.
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Printing books

You may print all files (File > Print Book…) or only a selec-
tion from the book window (File > Print Selected Files…)

When printing a book to file (for example, a PostScript file for 
later distilling to a PDF), you have the choice to 

Create a single file for the whole book.

Create a separate file for each document file.

You need to select Single File for creation of a PDF of the 
whole book. Only in this mode correct bookmarks and hyper-
jumps can be created.

For other ingredients to create a PDF see Standard process with 
Distiller on page 10-4.



Migration from FrameMaker 5.x

8 – 14

Migration from FrameMaker 5.x
FrameMaker 6 introduces additional system variables $chap-
num and $volnum as well as additional Running H/F x varia-
bles for master pages. Until then crossreferences were needed 
to get the desired layouts.

Due to these changes FM > 5 

Open the old book in FrameMaker 6 or higher updates master 
pages (if it can). FrameMaker will convert the book and all 
files to the new level. FM saves the old files with a .backup 
extension and tries to convert file internals. You may end up 
with a large error log.

Of course you will need to adjust the layouts etc. yourself.

No more prefixes Use <$chapnum> in the generating pattern for the page number 
in TOC etc.

Old <$paratext> <$pagenum>

<$paratext> ............................................ <$pagenum>
<$paratext> ....................................... <$pagenum>

<$paratext> ................................... <$pagenum>

In addition specification of prefixes in the set up for 
generated files is necessary to carry over chapter numbers 
etc.

New <$paratext> <$chapnum>

<$paratext> ......................<$chapnum> - <$pagenum>
<$paratext> .................<$chapnum> - <$pagenum>

<$paratext> .............<$chapnum> - <$pagenum>



Generated documents

Overview

The Table of Contents (or TOC) is generated from a 
file or files of a book (or a set of).

An index can be generated from a file or files of a 
book (or a set of) by collecting the information from 
the index markers.

Lists of tables, graphics, formulas etc. can also be 
built from the paragraph properties. Such lists can 
help during the production process or be part of the 
final book.

Once the content of such documents is generated, 
the format can be adapted and the generation pat-
tern can be changed.

The mechanism of index generation can also be 
used to generate parts lists and the like.

Contents

Hypertext links .......................................................  2

Table of contents ....................................................  3

Index creation ........................................................  9

Arbitrary lists .......................................................  15

Building blocks on reference pages ........................  20

Adding text to generated document .......................  21
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Hypertext links
In all generated files (Table of Contents, Index, List of authors 
and the like) FrameMaker can automatically insert hypertext 
links to the source location. These hypertext links

ease the development of the document with the various 
revision cycles, homogenisation headings, correction of 
index entries etc.

are automatically transformed into hyperjumps in PDF and 
links in HTML

To get the hypertext
links

Check the box Generate Hypertext Links in the Setup for the 
TOC or index etc. 

Use the hypertext links
in FrameMaker

Holding CTRL+ALT while moving over the TOC or index lines 
(or other places with the links) changes the cursor into a 
pointing hand to indicate a hyperjump.

To jump just click now.

Note: Cross references act also as hypertext links.

Note: In generated files imported «by reference» into another docu-
ment the hyperjumps do not work, because there is no text 
which can be accessed directly. For working hyperjumps the 
generated document must be imported «by copy» - this 
requires a new copy after each update.
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Table of contents
The table of contents (TOC) must be started as a generated 
file (do not set up a file and then try to generate the TOC 
into it).

Document comprising a book may be closed to generate 
the TOC from them. The book file, however must be open.

You can generate a TOC from a single chapter file also.

The format of the generated file can be influenced by set-
ting up proper paragraph styles and master pages in the 
template for the chapter files.

Generate TOC from a file

1 Enter the document from which you want to generate the 
TOC and select Special > Table of Contents…

2 You are prompted whether to set up a TOC as part of a new 
book or as an independent file. Press the Yes button.

3 In the dialogue Set Up Table of Contents move the para-
graph styles, which should appear in the TOC, to the left.

Note: You can move all items from one side to the other by holding 
SHIFT while clicking on the arrow button.

4 You may wish to generate hypertext links: click the selec-
tion box.

5 Press the Set button. A new file named documentname-
TOC.fm is created with default presentation of the TOC.

If your document file contains definitions for xxxTOC para-
graphs, these will be used and the generated TOC may look 
already quite well. See Format of the generated TOC on 
page 6 for further refinement of the TOC.
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6 Save the file. Do not change the name of this file!

7 You must update this TOC file after changes in the original 
document file: in the document file follow steps 1 to 6 
from above. Since you already have a TOC file from step 6, 
this will be used for the re-generation.

Generation process

Hecate est Iovis

et Latonae filia, soror Apollinis. Est
tricopor et triceps, magicarum artium.

Latonae filia
soror Apollinis. Est tricopor et
triceps, magicarum artium magistra
ac fascinationum praeses,.

Apollinis
Est tricopor et triceps, magicarum
artium magistra ac fascinationum
praeses, cinctra latrantium canum.

docname.fm22

Hecate est lovis 22
Latonae filia 22
Apollinis 22

openObjectId 
<$relfilename>:<$ObjectType> 
<$ObjectId>

<$paratext> <$pagenum>
<$paratext> <$pagenum>

openObjectId 
<$relfilename>:<$ObjectType> 
<$ObjectId>

<$paratext><$pagenum>
<$paratext><$pagenum>

Hecate est lovis ...................................... 22

Latonae filia ........................................... 22

Apollinis ................................................ 22

docnameTOC.fm

Reference page

1heading
2heading

1headingTOC
2headingTOC

Raw generation of TOC

Format of TOC adapted

Text document

Reference page

docnameTOC.fm

1 For the TOC file [A] ¶-formats and layout 
pages are copied from the book or current 
document file. 

2 For each ¶-format defined in the TOC setup a 
¶-format named xxxTOC with default proper-
ties is created in the TOC file [B]. 

3 A TOC reference page [C] is created (or copied 
also) which contains the (default) definitions 
[D]. These also get the ¶-formats xxxTOC.

4 For each ¶-format defined in the TOC setup a 
line for the TOC is generated based on the 
pattern defined by [D].

5 To refine the layout of the TOC, you modify 
the ¶-formats xxxTOC in the TOC file [E] and/
or the generating pattern, for example, set a 
TAB between the text and the page number [F]

6 Changes in the generation patterns require an 
Update Book cycle to create the new contents.

A

¶ formats in text  formats in TOC

D

B

C

E

F

openObjectId 
<$relfilename>:<$ObjectType> 
<$ObjectId>

<$paratext><$pagenum>
<$paratext><$pagenum>



9 – 5

Generate TOC for a book


E
:\

FM
-c

o
u

rs
e
\h

a
n

d
o

u
t_

7
0

\g
e
n

e
ra

te
d

_d
o

cs
.f

m
 

2
0

0
7

-0
6

-2
2

Generate TOC for a book

1 Enter the book file for which you want to generate the TOC

2  File > Add > Table Of Contents.

3 Define where you want to add the generated file into the 
book (only currently open files are in the drop down list).

4 In the dialogue Set Up Table of Contents move the para-
graph styles, which should appear in the TOC, to the left.

Note: You can move all items from one side to the other by holding 
SHIFT while clicking on the arrow button.

5 You may wish to generate hypertext links: click the selec-
tion box.

6 Press the Set button. A new file named name documentnam-
eTOC.fm is created with default presentation of the TOC.

If your book file contains definitions for xxxTOC para-
graphs, these will be used and the generated TOC may look 
already quite well. The book gets these definitions at the 
time the book is set up from a document file.

For further refinement of the TOC see Format of the gener-
ated TOC on page 6.

7 Save the file. Do not change the name of this file!
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Format of the generated TOC

1 Open the TOC file

- The layout you see is the same as the document from 
which the TOC was generated.

- The names of the paragraph formats for the TOC entries 
are built from the original paragraph style names (e.g. 
1heading, 2heading) with the appendix TOC: 
1headingTOC, 2headingTOC.

- On the reference page named TOC you will find the fol-
lowing lines. These are the generating patterns for the 
TOC entries (the first line is needed for the hypertext 
links).

openObjectId <$relfilename>:<$ObjectType> <$ObjectId>
<$paratext> <$pagenum>
<$paratext> <$pagenum>

- Although second to last lines have the same content, 
these lines are formatted differently using the style 
names 1headingTOC and 2headingTOC (as an example).

2 Format these xxxTOC lines according to your needs (tabu-
lation, leaders for the tabs, font size etc. and update the 
paragraph catalogue with the settings.

Note: Whether an underline character in Custom Leader creates a 
solid line or not depends on the font.

Adapt the formatting of the TOC entries

We use the line with style 1headingTOC as an example here.

1 Insert a tab between the two elements:

<$paratext><$pagenum>

2 In the paragraph designer set a right aligned tab as far as 
possible and apply a dot leader. You may also wish to 
indent the paragraph depending on the level of entry.

3 If you wish to include the paragraph number in the TOC 
entry, add the element <$paranumonly> to the start of the 
line:

<$paranumonly><$paratext><$pagenum>

This paragraph number is available, even if in the text doc-
ument the paragraph number is invisible (colour white).

4 Save the changed document

The next time you generate the TOC, the new formatting will 
be used

Example of properly 
formatted entries on 
reference page TOC

<$paratext> <$chapnum>

<$paratext> ......................<$chapnum> - <$pagenum>
<$paratext> .................<$chapnum> - <$pagenum>

<$paratext> .............<$chapnum> - <$pagenum>
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Prepare for entries which 
are longer than a line in 
the TOC

The text of the TOC entry will extend beyond the right tab 
position, and the TAB will not be performed. Hence you need 
to restrict the width of the text frame to the same width as 
the TAB position. 

Note: Rounding errors may require a slightly smaller (-0.05mm) TAB 
position than the width of the text frame.

Tabbing in long lines Long TOC (or Index or …) entries may not create the correct 
tabbing in the second (or last) line of an entry. One TAB char-
acter is used to reach the TAB position in the first line. A sec-
ond TAB is needed to reach the TAB position in the second 
line. 

Include table of contents in document

The TOC file generated from a text document (also that of a 
complete book) can be referenced from any file including the 
one it was generated from.

Generate the TOC 1 Generate the TOC according to the method described ear-
lier.

2 You may move the generated file to a different location (to 
another directory, for example: E:\Frame-
Maker\Course\sample\foilsTOC.fm. Do this only as the 
last stage!

Note: FrameMaker always generates a file into the same directory as 
the source file, hence you will get a new file at the old place, 
which does not use your fancy formatting. Even importing the 
formatting from the ‘old’ file will not help, as the properties 
from the reference pages are needed during the generation.

3 At the desired place in the main document import the TOC 
document by reference with the settings Body Text flow, 
Retain Source’s formatting and Update automatically.

4 As demonstrated in TOC Imported to nested text frame on 
page 8, the TOC may be imported also into text flows 
inside an anchored frame to get special appearance.

Update the TOC 1 Double click on the TOC

2 Press the Update Now button

This text frame is wider than 
the position of the right tab:

Long entry in the table of 
contents ............... 17
Another entry ........ 23

This text frame is as wide as 
the position of the right tab:

Long entry in the table of 
contents..........................17
Another entry ..................23

Only one TAB char in the 
REF page:

<$paratext><$pagenum>
Long entry in the table of 
content 17
Another entry .................. 23

Two TAB chars in the REF 
page:

<$paratext><$pagenum>
Long entry in the table of 
content ...........................17
Another entry ..................23
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TOC imported to the 
current flow

Table of contents ..................................................... 1
Generate TOC from a file ...................................... 1

Format the generated TOC ........................................ 3
Standard formatting for the TOC entries ............... 3

Table of contents within a text document .................. 4
TOC imported to the current flow ......................... 4
TOC Imported to nested text frame....................... 5

TOC Imported to nested 
text frame

Be aware that tabulation needs room - A two column text 
frame within the anchored frame will be too narrow in the 
case here. 

TOC and current 
document have different 
layout

When importing form a file with different layout characteris-
tics of the imported text flow, either

use the formatting of the target flow. You may need to cre-
ate new paragraph formats in the target document.

or use the formatting of the source document. In this case 
you may need to adapt the paragraph formats in the source 
document.

Example The source document is a TOC using no side head area in the 
layout. The target document (such as this handout) uses a lay-
out with side head area. If you want the imported TOC to use 
the full the line length (as it is in the source document), you 
must define the paragraph formats xxxTOC (either in the 
source or the target document) with the pagination property: 
«across all columns and side heads».

Without this setting the source document will use only the 
column width (as this paragraph does) and the tabulation may 
not be honoured.

Table of contents ...................................................... 1
Generate TOC from a file ...................................... 1

Format the generated TOC ........................................ 3
Standard formatting for the TOC entries ................ 3

Table of contents within a text document ................... 4
TOC imported to the current flow.......................... 4
TOC Imported to nested text frame ....................... 5

xxx

Text frame

Anchored frame
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Index creation

For a good index you need …

Experience You need a lot of experience to create a good index for a gen-
eral document. FrameMaker can only provide the mechanics, 
not the intellectual capacity… 

Be prepared to accept ‘holes’ in your index: the fantasy of the 
reader only rarely matches that of the author.

Time A good index can only be created by many iterations.

Rules about generating the index must be adapted regu-
larly according to the nature of the document and the read-
ership.

FrameMaker APIs allow to speed the creation of an index, 
but also these can not provide intelligence.

Quick and dirty index

A quick and dirty index can be constructed from an alphabet-
ical list of paragraphs. Use heading paragraphs (including 
table headings, table titles, figure titles).

Create an alphabetic list From the current document File > Generate / Update...

In the dialogue Generate Book select the option List and 
select Alphabetical Paragraph List from the drop down 
list.

In the dialogue Set up Alphabetical Paragraph List move 
the desired paragraph types from the right pane to the left 
pane.

Generate! creates a new document named documentAPL.

You may not have two alphabetical lists with different par-
agraph types listed, because there is only one name-appen-
dix (APL).

For the intended purpose - just list the stuff - you will not 
need to format the list similar to what you will do with a 
TOC.

Rules for keywords

Choose keywords carefully. Include words which do not 
appear in the document, but describe the concepts behind 
existing words (so that readers can find ‘grouping words’. 
In most cases you will need two types of keywords: objects 
and actions which are applied to these objects.

Keywords are always singular, nominative.

Provide additional information to the keyword in parenthe-
ses, for example «contents (logically)» rather than logical 
content. This continues the hierarchy of terms.



Index creation

9 – 10

Use highlighting in keywords only for specific purposes. 
For example for subroutine names, program parameters.

Do not forget to specify synonyms and antonyms.

To define abbreviations you may use a form such as 
«KGB = …». The colon has a specific meaning in Frame-
Maker index entries.

Do not abbreviate the main keyword in subentries. Keep the 
audience in mind: technical documentation is often read by 
non-native speakers (Greeks read English …). The following 
is a bad example:

break
bicycle ~  (hydraulic)
truck ~ (pneumatic)

Both comprehension and translation fo this stuff is cum-
bersome.

Define index entries

Index entries are markers of the type index. 

To insert an index entry Place the cursor at the desired point. If your index entry 
can be formed from existing text, select that text.

Special > Marker opens the dialogue Marker. The marker 
type Index might be selected already. If not, select this type 
from the drop down list.

If you have selected text, or do so while the Marker dia-
logue is open (it stays open), the selected text appears in 
the box as Marker Text.

Change the marker text to your desire and place the 
marker with New Marker!

Types of index entries

Blanks in index entries Blanks may be arranged around the colon and the semicolon 
which have syntactic meaning in the entries. These blanks do 
not appear in the index display. Required blanks (e.g. to keep 
words together) must be inserted as \

Multi level entries Multi level entries are separated by a colon (:). The following 
example will create a main entry abrasion and a sub entry gla-
cial.

abrasion:glacial

It is good practice to define the possible words for the top 
level in advance.

Multiple entries in one 
marker

Multiple entries within one marker are separated by a semico-
lon. This is for example useful to place all permutations of 
multi level entries in one marker:

character:delete;delete:character
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Index entry spanning a 
range of pages

If an index entry should span a range of pages, the entry must 
be placed both on the start-page and on the end-page of the 
range:

<$startrange>text of index entry
<$endrange>text of index entry

Page ranges are created automatically, if the same marker text 
appears in index markers on successive pages.

Synonyms with no page 
reference

Synonyms should not display a page number in the index. To 
suppress the page number, add <$nopage> to the index entry:

<$nopage>Erosion. See Abrasion

If these entries are not placed at the end of the Index marker, 
you need the following instruction to regain page numbering:

<$singlepage>Abrasion

Highlighting of index 
entries

To apply highlighting, such as font changes, to an index 
entry, only character formats can be applied. It is not possible 
to use ‘local’ formatting with Format > Font etc.

<1highlight>special<Default Para Font> marker text

Note: The term <Default Para Font> can be abbreviated to </>.

Special characters in 
index entries

Since colon, semicolon etc. are syntactic characters in Index 
Marker entries, these characters must be ‘escaped’ for literal 
use:

<1highlight>Income</> \> 100 millions
fruit\: vitamins for all
cucumbers\; beans\; cauliflower

You may use standard escaped symbols (see Special characters 
in dialogue boxes on page A-3) and symbols from special fonts 
by means of character formats:

\F = character (format)
including <ddd_symbols>8</> importing<$nopage>

These definitions create the following index entries:

ƒ = character (format) .......................17-2
including  importing

Force sort order To force a word (e.g. with umlauts) or an entry with punctua-
tion so sort similar to another, use this syntax:

Ägerter[aegerter]
0900 233 455[nine hundred]
\F = character (format)[*]<$nopage>

These definitions create the following order of index entries:

ƒ = character (format)
Ägerter ............................................13-5
Affeltranger .....................................13-4
Cost History, screen ..........................12-5
0900 233 455 ..................................13-5
North pole .......................................17-2
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Generating an index

Generate index from 
current document

1 Special > Standard Index You are prompted whether to set 
up an index as part of a new book or as an independent 
file. Press the Yes button.

2 In the dialogue Set Up Standard Index the appropriate 
marker type is already selected.

3 Hypertext links are a great help and should be ON.

4 Press the Set button. A new file named name document-
nameIX.fm is created with default presentation of the 
Index.

If your document file contains definitions for xxxIX para-
graphs, these will be used and the generated index may 
look already quite well. See Format the generated index on 
page 13 for further refinement of the index.

5 Save the file. Do not change the name of this file!

6 You must update this index file after changes in the origi-
nal document file: in the document file follow steps 1 to 6 
from above. Since you already have a index file from step 6, 
this will be used for the re-generation.

Generate index from 
book

Use Add > Standard Index. You are not prompted and con-
tinue with step 2 as above.
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Format the generated index

1 The layout of the abcIX file is the same as the document 
from which the index was generated (in case you generated 
the index from a book, the formatting comes from the doc-
ument with which the book was created). 

You may wish to change the layout in the master pages (for 
example, set up two columns).

2 The names of the paragraph formats for the index entries 
are built from the levels of the entries: Level1IX, Level2IX. 
GroupTitlesIX defines the ‘character headings’.

3 On the reference page named IX you will find the following 
lines. The purpose of these lines can be determined from 
their format names (here indicated to the left):

4 The basic formatting concerns the index entries with the 
paragraph formats LevelxIX. Format them according to 
your needs (Paragraph Designer, Update All!)

5 You may also wish to change the appearance of the Group 
Titles, in particular the Font and the Size, Space above, 
Space below and probably apply a line before the para-
graph.

6 You can combine entries under one group title with these 
definitions in the GroupTitlesIX paragraph:

A-D[A];E-H[E];I-L[I];M-P[M];Q-T[Q];U-Z[X]

The symbols in brackets, such as [\] or [0] specify the sort 
order for symbols and numbers. The same method is used 
for the alphabetic character groups.

7 You may also wish to change the appearance of the page 
number (insert a tab character in front of <$pagenum>. The 
tab position, however, must be defined in the paragraph 
format of the LevelxIX lines.

Note: Changes in the formatting become visible immediately in the 
reference pages and in the body pages. Changes of the genera-
tion template (e.g. the insertion of the TAB character in front 
of the page number) become visible only after you have re-gen-
erated the index.

1, 2–3
Level1IX

Level2IX
Symbols[\];
Numerics[0];A;B;C;D;E;F;G;H;I;J;K;L;M;N;O;P;Q;R;S;T;U;V;W;X;Y;Z
<$symbols><$numerics><$alphabetics>
--–—
openObjectId <$relfilename>:<$ObjectType> <$ObjectId>
<$pagenum>

Add <$autorange> to automatically combine entries.

Enter any ‘prefixes’ to the page-number here (not in the Level#IX lines), if 
you need one. In particular, insert the leading TAB here. For example you 
may set up this line (format IndexIX) as:

<$chapnum>\+<$pagenum>

SeparatorsIX
Level1IX
Level2IX

GroupTitlesIX

SortOrderIX
IgnoreCharsIX

ActiveIX
IndexIX

Add any spacing between index text and page-numbering
Replace separating character with … for cc-pp numbers

Define the position of the TAB (for the page number) in the 
lines Level#IX. The TAB character to be generated must 
be placed on the line with ¶-format IndexIX
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Sort order Sort order is defined by the building blocks <$symbols> 
<$numerics> <$alphabetics>. They are defined as follows. Note 
the grouping by blanks!

<$numerics> 0 1 2 3 4 5 6 7 8 9

<$alphabetics> AÁÀÂÄÃÅaáàâäãåª Bb CÇcç Dd EÉÈÊËeéèêë 

Ffƒ Gg Hh IÍÌÎÏi íìîï Jj Kk Ll Mm NÑnñ 

OÓÒÔÖÕØoóòôöõøº Pp Qq Rr Ss Tt 

UÚÙÛÜuúùûü Vv Ww Xx YŸ yÿ Zz

<$symbols> All other characters in ASCII order

Change sort order You can exchange the order of the building block, e.g. to sort 
symbols before the alphabetic characters.

To change the order within a building blocks, you must com-
pletely redefine the block. 

When replacing <$alphabetics> with individual characters, 
separate the letter groups with a space.

Letter groups - for example, F f ƒ - are characters that are 
sorted as if they were the same character, unless they are 
the only characters that differ in the sorted text. In that 
case, the first character in the string appears first.

If you replace <$symbols> with individual characters, use a 
backslash before the angle bracket symbols (\< and \>).

To indicate that a letter pair should be sorted as a single 
character, specify the letter pair between angle brackets (< 
>) - for example, CÇcç<CH><Ch><ch>. In this example, all the 
characters or letter pairs are in the same letter group (the 
letter C). The letter pair CH is sorted after the letter C, and 
uppercase letter pairs are sorted before lowercase letter 
pairs.

Example definition for 
SortOrderIX

Although things are displayed in lines in this script, there 
must be only one paragraph of type SortOrderIX. No line 
breaks are allowed.

<$symbols><$numerics>AÁÀÂÄÃaáàâäãª Bb CÇcç Dd 
EÉÈÊËeéèêë Ffƒ Gg Hh IÍÌÎÏi íìîï Jj Kk Ll Mm NÑnñ 
OÓÒÔÖÕoóòôöõº Pp Qq Rr Ss Tt UÚÙÛÜuúùûü Vv Ww Xx YŸ yÿ 
Zz Åå Øø

Include index in document

Follow the rules defined for Include table of contents in docu-
ment on page 7.

Index entry does not show up in index

When working on the index and searching for markers with 
Find/Change you may come across non-index markers. These 
will change the marker type in the Marker dialogue.

Hence: before entering marker text for an index entry always 
check, whether you are really creating an index marker. You 
may change the marker type and then press Edit Marker at 
any time.
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Arbitrary lists
Especially in scientific publications various lists are required, 
for example, lists of:

Authors

Formulae

Figures

Tables

Diagrams

Bibliographic references (see Bibliography with EndNote 5 on 
page 20 in chapter 7).

Lists Some of these lists can be generated without further work, 
others need the insertion of markers into the text.

When FrameMaker generates these lists, it produces a file, 
which later can be formatted to the desired needs and also be 
imported to another document.

These files can either be produced from the current document 
or from a FrameMaker book.

Indices In an index you can specify the sorting order, the grouping of 
index characters etc. (in the appropriate reference page).

Note: Lists do not allow to group similar entries into one with a list of 
page numbers. If you want to avoid multiple entries of same 
kind (e.g. three times the same author name with different 
page numbers) you must use an index.

List of tables

Tables may bear a title, which is associated with paragraph 
style (in this document: ttn-table-title-numbered). Hence a 
list of all tables is a list of all paragraphs of the format(s) 
used for the table titles.

To generate the list of tables,

1 Open the book file (or the file from which you want to gen-
erate the list)

1 Special > Standard Index You are prompted whether to set 
up an index as part of a new book or as an independent 
file. Press the Yes button.
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2 In the dialogue Set Up List of Tables move the appropriate 
paragraph format(s) to the left. FrameMaker automatically 
recognises a format TableTitle.

3 You may wish to generate hypertext links: click the selec-
tion box.

4 Press the Set button. A new file named name document-
nameLOT.fm is created with default presentation of the 
List.

If your document file contains definitions for xxxLOT para-
graphs, these will be used and the generated index may 
look already quite well. See Format of the generated TOC on 
page 6 for further refinement of the index.

5 Save the file. Do not change the name of this file!

6 You must update this list file after changes in the original 
document file: in the document file follow steps 1 to 6 
from above. Since you already have a index file from step 6, 
this will be used for the re-generation.

7 You may wish to adapt both the formatting in the generat-
ing pattern (on a reference page named LOT). See Format of 
the generated TOC on page 6 or Format the generated index 
on page 13 for details.

You can import the generated file (referenced or copy) into 
the document:

Table 1: Control characters in the text ................................................................1 - 3
Table 2: Hierachical numbering...........................................................................4 - 6
Table 3: Snapshot from log of PC DDD-KLD ........................................................5 - 8
Table 4: ...........................................................................................................5 - 10
Table 5: The title can only be set in unrotated mode of the table ......................5 - 10
Table 6: Table with straddled cells ....................................................................5 - 13
Table 7: Building blocks for system variables ......................................................7 - 4
Table 1: Keyboard shortcuts (english and german FrameMaker) ..........................A - 2
Table 2: Special characters in dialogues ..............................................................A - 3
Table 3: Wildcard characters in Find dialogues ....................................................A - 3
Table 4: Insert special characters with CTRL+q....................................................A - 4
Table 7: Comparison between FrameMaker and Word for Windows .................... C - 3
Table 9: Imported from Excel and manually adapted.......................................... D - 8

Specials with these lists Paragraph numbering may restart at 1. In this document 
(book) the appendices start again with 1 (A) to allow for easy 
insertion of additional chapters.
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You may have empty paragraphs (see line with Table 4 above). 
To fix this, go to that table and either fill in the title or 
remove the title (it may have no significance).

List of figures

Since FrameMaker does not provide a native method to dis-
play figures with titles, tables are used for this purpose. 

Hence a list of figures is a list of tables of a specific para-
graph format (e.g. ftn-fig-title-numbered).

With Special > List of > Figures you specify the paragraph 
format(s) to be included. See Figures in FrameMaker on 
page 6-6 for details how to set up and use such tables.

Index of authors

An index of authors in an index of markers of type Author. To 
create this index:

1 Insert markers of type Author (Special > Marker) in the 
documents at an author name (selected text will be copied 
to the Marker dialogue).

2 In the document or the book file add the generated index 
with Special > Index of > Authors…

3 In dialogue Set up Author Index you move the type(s) of 
markers to be included from the right pane to the left pane 
(Author is already selected).

4 Press the Set button. A new file named name document-
nameAIX.fm is created with default presentation of the 
Index.

If your document file contains definitions for xxxAIX para-
graphs, these will be used and the generated index may 
look already quite well. See Format the generated index on 
page 13 for further refinement of the index.

5 Save the file. Do not change the name of this file!

6 You must update this index file after changes in the origi-
nal document file: in the document file follow steps 1 to 6 
from above. Since you already have a index file from step 6, 
this will be used for the re-generation.
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7 You may wish to adapt both the formatting in the generat-
ing pattern (on a reference page named AIX). See Format of 
the generated TOC on page 6 or Format the generated index 
on page 9-13 for details.

You can import the generated file (referenced or copy) into 
the document:

Gulbins...........................................................................4
Obermayr .......................................................................4
.ries GmbH .....................................................................5
Sandybrook Software ......................................................5
Thomas Glombik ............................................................5
Systec.............................................................................5

Document specific lists

Assume you are describing a large archeological site. You may 
wish to provide the reader special lists:

Strati (layers of findings, thus epochs)

Artefacts found (pottery, fibulae, weaponry etc.)

Locations (house, place, garden, cemetery etc.)

and so on.

To create these lists you need markers of appropriate type 
(stratus, artefact, location) and insert them at the proper 
place.

1 Define a new marker type with Special > Marker... and 
select Edit... from the list of Markers.

2 In the dialogue Edit Custom Marker Type specify the 
name of the new marker type (e.g. artefacts) and Add! it to 
the list of markers.

3 Now you can use this marker type similar to the marker 
types defined by FrameMaker.
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Parts list

For parts lists and similar applications the following method 
can be applied:

 

1 Place the numbers in text frames outside of the graphic or 
photograph.

2 Use a special paragraph format for the part-numbers in the 
graphics, for example part-number. This must be in the par-
agraph catalog.

3 Create an alphabetic list of these numbers with Special > 
List Of > Paragraphs

4 In the dialogue Set Up Alphabetical Paragraph List spec-
ify the paragraph format, which you want to be listed (in 
our example: part-number). Set!

5 A file with the name documentAPL is created:

0562.3321 80

0562.3775 80

In the first part of this list (in this example it is just the first 
line) all pages are listed on which the paragraph type could be 
found. You may wish to remove these lines after generation 
(if you remove the generating element - Level1APL - from the 
reference page, it will be recreated at the next generation).

To format this file to your needs apply the same techniques 
as described for formatting an index. The elements on the ref-
erence page APL indicate their meaning by their format 
names.

Support your work with lists

To support your document development you may use the fol-
lowing lists:

List of References: imported graphics to clean out all 
unused stuff from the directories before you distribute.

Alphabetic list of paragraphs (only headings) to get a start-
ing point for an index.

0562.3775

0562.3321

Text frame
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Building blocks on reference pages
[www.microtype.com]

When setting up the generating template for an automatically 
generated document, some restrictions apply to the building 
blocks which can be used. It is, for example, not possible to 
get the contents of a specific paragraph type with the build-
ing block <$paratext[paraname]> . Nothing will be generated.

Generally the building blocks which control index setup or 
hypertext are not listed in this table:

Special remarks <$paratext> This retains forced line breaks (\n) and all 
character formatting if these were applied 
with character tags. Other character prop-
erties are not kept.

<$markertext> The complete marker text is reproduced. 
This includes special characters and index-
specific building blocks.

references These include condition tags, external 
cross-references, unresolved cross-refer-
ences, imported graphics and text insets 
(also unresolved). From font properties 
only the first unique item on the page is 
taken.

</> short for <Default ¶ Font>

Generated file Default 
suffix

Source Order Supported building blocks

specific to file valid in all files

Lists

<$pagenum>
<$chapnum>
<$volnum>
<$relfilename>
<$fullfilename>
<characterformat>
</>

Table of contents TOC paragraphs collected

<$paratext>
<$paranum>
<$paranumonly>
<$paratag>

List of figures LOF paragraphs collected

List of tables LOT paragraphs collected

List of paragraphs LOP paragraphs collected

Alphabetical list of ¶ APL paragraphs sorted

List of markers LOM markers collected
<$markertext>

Alphabetic list of markers AML markers sorted

List of references LOR references collected <$referencename>
<$paratext>

Indexes
Standard index IX markers sorted

<$autorange>
<$nopage>

Author index AIX markers sorted

Subject index SIX markers sorted

Index of markers IOM markers sorted

Index of references IOR references sorted <$paratext>
<$autorange>

Document reports
Composite document CMP documents merged

not applicable
Summary (summary.fm) - changes collected

http://www.microtype.com/
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Adding text to generated document
Sometimes short introductory text is required in generated 
documents, such as:

Scope of table of contents

Explanation of syntactical constructs in an index

Note: You can not start with text and then ‘add’ a generated list to a 
document. You always must first generate the list into a new 
document and then add the introductory text.

The procedure is as
follows:

1 Generate the list or index

2 Locate the cursor at the very beginning

3 Enter text and format it accordingly

Note: Do not touch the first generated line, you may destroy the ‘crit-
ical flag’

Introduction to TOC You may wish to introduce the Table of Contents with some 
remarks:

Please note: Neither the course Introduction to FrameMaker nor 
the course FrameMaker for Scientific Publications covers all top-
ics from this handout. Some of the topics are presented only 
on special occasions.

This is the first
generated paragraph -

do not touch it

Conventions used in this manual ...................... 0 - 2
PDF version ..................................................... 0 - 2

Introduction to index You may wish to precede the generated text with some expla-
nations: 

=  used to explain abbreviations.
 at beginning of line: see also.
Else: points to synonym.
… repeats main keyword

This is the first
generated paragraph -

do not touch it

A

Headings in generated documents

Normally you can not use the standard heading formats in a 
generated list, because they will be used to generate the list …

To format a heading with the appearance of, for example, 
2heading, create a new paragraph format with the same prop-
erties, but name it 2heading-notoc and do not include this 
name into the generation of (for example) the Table of Con-
tents.

Note: Do not name it -noTOC. This will confuse FrameMaker and the 
heading will be removed each time you regenerate the file. 
This is because all generated ¶-formats in a Table of Contents 
end with the suffix TOC (with upper case characters). Instead 
use a format name something-notoc.
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Generate Acrobat (PDF)

Overview

This chapter aims at Acrobat 7. However most of 
the features described are also available in older 
versions.

FrameMaker is well integrated with Acrobat. Book-
marks are automatically generated from specified 
headings and you can set some document proper-
ties.

Contents

Introduction ...........................................................  2

Generate PDF from a FrameMaker document ............  4

Acrobat Reader .......................................................  9

Refining the PDF output ........................................  10

Modify the PDF file with Acrobat ............................  12

Some problems with PDF files ................................  13



Introduction

10 – 2

Introduction
PDF (Portable Document Format) is considered as the univer-
sal format for exchange of formatted documents. 

PDF preserves the exact layout, including the fonts and 
images.

PDF can be printed to any device for which the user has a 
printer driver.

PDF allows security against unwanted modifications or 
even printing.

With the full Acrobat product, a PDF can be modified (text 
lines, cropping pages, sticky notes, generation of thumb-
nail images of the pages, replacing pages, extracting pages, 
exchanging images etc.).

PDF versus Postscript

PostScript is a procedural programming language which is 
interpreted by a RIP (raster image processor) to generate the 
contents of pages (lines, images, etc.). A PostScript file may 
contain device specific commands, such as ‘select papertray’.

A PostScript file always must be handled (interpreted) 
sequentially. There is no means to just get page 17 out of 29 
pages, because the needed resources (e.g. a font) may be spec-
ified previously in the file.

PDF is an object oriented data format which provides direct 
access to the pages. Pages are completely independent. 
Resources are referenced and may be defined anywhere in the 
file.

PDF depends on a target

The above is the principle and told you by Adobe marketing. 
However, real life knows trouble and pitfalls:

A PDF file is targeted to specific output channels (display 
screen, web, office laser printer (B/W), high quality colour 
laser printer, plate making process for offset printer etc.)

Due to the immense number of possible combinations, well 
tested sets are named (e.g. Jaeggi Digiprint). Acrobat comes 
along with some names. But even these well tested sets are 
not universal at all.

Properties of printers (HW) and processes differ very much. 
Hence it is common practice to stick to one print shop, get 
his well proven PDF parameters and create the PDF with 
these. Also with this method test prints are recommended.

PDF is created using a number of parameters when setting 
up the job options in the Acrobat Distiller. There are many 
choices in each category (General, Compression, Fonts, Col-
our, Advanced) of options. For example:
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References

www.publisher.ch/ publisher is the Swiss journal for electronic publishing and 
the publication of the Swiss User Group of Adobe products.

www.microtype.com/ Shlomo Perets is a worldwide recognised expert in Frame-
Maker & PDF.

www.prepress.ch/ Mr. Jäggi is an EU wide recognised expert in PDF and provides 
a good set of JobOptions for the Acrobat Distiller on his web 
site.

Adobe Acrobat tips http://www.adobe.com/products/tips/acrobat.html

Jaeggi Distiller settings http://www.prepress.ch/d/pdf/web/settings.html

Create user friendly PDF

Read in www.microtype.com/Hmmms.html about common 
mistakes and omissions when generating PDF. Even files from 
reputed companies lack usability.

Enjoy the reader with a complete PDF – not just a garbage 
file.!

Option category Parameter Internet (Jäggi) Digital printing (Jäggi)

General: Compatibility Acrobat 4.0 (PDF 1.3) Acrobat 4.0 (PDF 1.3)

Format Optimise for fast Web view -

Resolution 2400 dpi (will only be used in print-
ing)

2400 dpi

Compression Colour images Bicubic downsampling to 72 dpi, au-
tomatic compression, low quality

Bicubic downsampling to 150 dpi, au-
tomatic compression, medium quality

Monochrome Bicubic downsampling to 150 dpi, 
CCITT group 4 compassion

Bicubic downsampling to 600 dpi, 
CCITT group 4 compassion

Fonts embed all fonts; subset embedded 
fonts below 35%

embed all fonts

Colour Conversion convert all to RGB leave colours unchanged

Advanced Options Convert gradients to smooth shades. 
Preserve overprint settings. Allow PS 
file to override job options; process 
DSC comments …

Convert gradients to smooth shades. 
Preserve overprint settings. Allow PS 
file to override job options. Save orig-
inal JPEG images in PDF if possible. 
process DSC comments …

http://www.publisher.ch/
http://www.microtype.com/
http://www.prepress.ch/
http://www.adobe.com/products/tips/acrobat.html
http://www.prepress.ch/d/pdf/web/settings.html
http://www.microtype.com/Hmmms.html
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Generate PDF from a FrameMaker document
In order to be able to create PDF from FrameMaker,

you need to have a PostScript printer driver installed – and 
be aware of the printer setup (2-up will yield only even 
pages...). 

have Adobe Acrobat (at least the distiller) installed. It is 
good practice to use the Distiller Printer driver to generate 
the PostScript file to be distilled. This driver is the most 
elaborate and safe one.

Save as PDF

With FrameMaker 7 a reliable procedure to save PDF directly 
is introduced. The standard process (generate PostScript file, 
distil) is performed in the background invisible to the user.

Note: Saving as PDF shall be Your standard method to create PDF 
output from FrameMaker. Use the other method only as fall 
back methods.

To create a PDF, 

1 use File > Save As... and specify PDF as file format.

2 in dialogue PDF Setup specify the Acrobat job options and 
all other necessary items according to Set up PDF properties 
in FrameMaker on page 10-5.

3 Start the process with Set!

Note: Do not Save as PDF to a diskette or small USB stick. The inter-
mediate tps file will not fit onto it - and this intermediate file 
can not be placed at another place as the final PDF file.

Standard process with Distiller

The overall process to generate a PDF consists of these steps:

1 Set up the PDF properties in the FrameMaker document or 
via the book for all files in the book.

2 Produce a PostScript file either from a single document or 
from the complete FrameMaker book.

3 Start the Acrobat Distiller and select the appropriate set of 
job options (or specify your own).

4 Open the PS file in Distiller. The distiller starts the process.
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Set up PDF properties in FrameMaker

In Format > Document > PDF Setup... you set parameters 
which are handed over to the distilling process in the Post-
Script file. Four categories of properties can be set by means 
of tabs (Windows).

If you want the same settings in all files of a book, open the 
book file and use File > Print Book… and there the button 
PDF Setup.

Settings In this pane you select the set of Distiller parameters (job-
options) which are located in the Distiller installation direc-
tory.

You also specify how the PDF document should open initially.

The setting of Registration marks is only necessary if you 
want to print on smaller paper and see crop marks to trim the 
paper. This is similar in the Print dialogue.

Further parameters normally need no change from the 
already set values.

Bookmarks In this pane you specify which items you want to have in the 
Table of Contents for the left pane of the Acrobat view (in Acro-
bat called bookmarks). Do not forget to specify a useful book-
mark level with the << and >> arrows.

You can move all items from the left pane to the right one (or 
vice versa), by holding SHIFT and clicking the >> (<<) button.

To have the bookmarks closed to the first level, enter 1 into 
the drop-down list Bookmarks expanded through Level. 
Entering 0 to close to the top level works only for a single 
document, not for a FrameMaker book.

Tags A tagged PDF file displays a logical document structure 
according to your settings. This allows to re-format the PDF 
file for alternate output devices such as screen readers. It 
also allows to export the PDF correctly to RTF.

If you have set attributes for anchored frames (see Set object 
attributes on page 6-9) this information is also carried over to 
tagged PDF.

Either leave the box Generate Logical PDF Structure 
unchecked, or set up the same structure as in category Book-
marks.

Links Normally check Create Named Destination For All Para-
graphs. (although unchecking this will create a smaller PDF 
file).

This box must be checked if you want to create links from 
other documents to this document in Acrobat.
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Document Information In the Acrobat Reader you display this information with File > 
File Info.

You may set file information for the book file or any docu-
ment file. This information can be accessed by an XMP con-
forming application.

This information is saved within the FrameMaker file, but in a 
standardised format. You can see it, for example, when open-
ing the FrameMaker file in a text editor.

To define this information, select File > File Information… in 
the book file (you need to select the top book file listed 
explicitly) or any other file in the book or you are already 
within a document file.

Author Author(s) of document, including company

Title Title of document

Subject You may wish to add data here

Keywords These become relevant if the PDF is com-
bined with others on a CD for example.

Copyright Place a copyright statement here.

Web Statement A notice pertaining to the use of the docu-
ment on the web, e.g. a disclaimer

Job Reference Author’s affiliation

Marked Select Yes for copyrighted document

Generate the PostScript file

In File > Print or File > Print Book you specify standard 
items, such as Page Range, and whether you want to print all 
or just the even (odd) pages. Pay attention to the following 
parameters:

Registration MarksSelect None.

Thumbnail Rows Do not check this (only useful on paper).

Copies Set to 1 (or you get a mangled PDF).

Scale Set to 100%.

Print to File Check! You may change the proposed file 
name and path.

Save Book As Select Single File for generation of Post-
Script for distilling with Acrobat. Only in 
this mode correct bookmarks and hyper-
jumps can be created.

Gen. Acrobat Data Check this. If not yet done, you may set 
the properties with PDF Setup!

Printer Select a PostScript printer, at best use the 
Acrobat Distiller Printer (Adobe PDF).

Note: PostScript files may become very large (the 300 pages of this 
handout produce about 50 MB due to many screen shots. 
Hence you may wish to print to your TEMP folder. The final 
PDF to be printable on a desktop laser printer (600 dpi) is only 
about 7.0 MB.
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Distil the PostScript file

Acrobat Distiller «converts» the PS input to the PDF. The vari-
ous parameters controlling the process are combined into 
sets, which are (in Windows) plain ASCII files residing in the 
Acrobat Distiller directory (e.g. in 
H:\adobe\Acrobat\Distillr\Settings).

Distiller setting Acrobat installs the following setting:

High Quality Print.joboptions 
High Quality Print.joboptions
Press Quality.joboptions
Standard.joboptions
PDFA DRAFT.joboptions
PDFX1a 2001.joboptions
PDFX1a 2003.joboptions
PDFX3 2002.joboptions
PDFX3 2003.joboptions
Press Quality.joboptions
Smallest File Size.joboptions

The Swiss PDF guru Jaeggi (see Jaeggi Distiller settings on 
page 3) has developed another set of options, which are 
highly recommended:

CD-ROM_D7P.joboptions
DigiPrint_D7P.joboptions
HighQuality_D7P.joboptions
Internet_D7P.joboptions
Offset_D7P.joboptions
OPI_D7P.joboptions
PDF16_D7P.joboptions
PDFX3-2002_Newspaper_D7P.joboptions
PDFX3-2002_Office_D7P.joboptions
PDFX3-2002_Offset_D7P.joboptions
Present_D7P.joboptions
Sep_D7P.joboptions

Distil the PostScript file Open Acrobat Distiller (you will have this on your system only 
if you have installed the Acrobat application, not just the 
Acrobat Reader - which is free).

1 Select the proper set of job options, e.g. Jaeggi-
Digitaldruck depending on your target (DigiPrint is also 
good for desktop printing).

2 You may check the settings in Settings > Joboptions, espe-
cially to set security options, which can not be saved in 
joboptions.

3 Select the PostScript file with File > Open and specify 
where to save the PDF file.

4 As soon as you press Open the distilling process starts. 
The PDF is generated into a temporary location and then 
moved to the save directory. A log file is displayed and also 
saved in the same directory:

Start Time: 2005-11-30 at 15:17:32
Source: acrobat.ps
Destination: G:\Filetype_examples\acrobat.pdf
Adobe PDF Settings: C:\Documents and Settings\All 
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Users\Documents\Adobe 
PDF\Settings\J_Internet_D7P.joboptions
%%[ ProductName: Distiller ]%%
%%[Page: 1]%%
%%[LastPage]%%
Distill Time: 3 seconds (00:00:03)
**** End of Job ****

Note: Be aware of the Distiller habit to keep its dialogue contents 
between sessions! Always check the save location!

Set security options Password Write it down and store the note in a safe 
place if you set a password!

Permissions … These check boxes can be set to prevent 
printing of the file, changing content or 
adding / changing notes using the Acrobat 
application.

The encryption level is low for compatibility with Acrobat 3.

Errors reported in the Acrobat log file

At the end of the log you may see error messages such as:

% [ Warning: The following Names in Name Tree Dests were 
not defined ] %

G14.1026542
G15.1006357
G16.1005762
M9.17866.chaptertitle.1

Event hough you have no undefined cross references in your 
document(s) you may get these errors. 

MIF helps in most cases Normally you can get rid of these problems by

1 Save the file creating the error as MIF, close file without 
saving.

2 Open the MIF file and save it as ordinary FrameMaker file.

Severe problems need
fixes in the MIF files

Severe problems not disappearing with the method men-
tioned before need removal of items in the MIF file (expert 
only!)

<ParaLine 
<TextRectID 32>
<Marker 
<MType 9>
<MTypeName `Cross-Ref'>
<MText `17866: chapter-title: 1'> <<<------
<MCurrPage `First'>
<Unique 1010926>

> # end of Marker
> # end of ParaLine

The highlighted part (a dubious marker) must be removed.



10 – 9

Acrobat Reader


E
:\

FM
-c

o
u

rs
e
\h

a
n

d
o

u
t_

7
0

\a
cr

o
b

a
t.

fm
 

2
0

0
7

-0
6

-2
2

Acrobat Reader
Acrobat reader (which is free at the Adobe Web site) displays 
PDF files. The reader can be set up to integrate as plug-in into 
a web-browser.

PDFs exist in levels 1.0 (Acrobat 1) to 1.6 (Acrobat 7). Your 
reader should be capable to read the highest level. 

Acrobat Reader window In the left pane Bookmarks (table of contents) or Thumb-
nails (small page images) can be displayed.

The right pane contains the document to be viewed.

Bookmarks If you have set up the PDF properties in FrameMaker, you get 
a complete structure of the headings similar to the tree in file 
explorer.

Cross references I you have cross-references in the document (X-ref markers in 
FrameMaker), these are active (PDF is a hypermedia-format).

FrameMaker generated files (Table of Contents, Index etc.) 
can contain live links, if you have specified so.

Web links Web links (see Web links on page 10) are active in PDF, if you 
set up the browser in File > Preference > Weblink… in Acro-
bat Reader.
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Refining the PDF output

Presentation formats

It may be desirable to set up a different layout for the on-line 
distribution (landscape orientation, A5)

Cross reference formats should not contain page numbers.

Hypertext commands in FrameMaker

Not all FrameMaker hypertext commands have an adequate 
Acrobat function:

Web links

To create a link to a web-page, use the FrameMaker hypertext 
command Go to URL:

1 Select the text which should become the hotspot in the PDF 
file. You may wish to specify a character format for this.

2 In Special > Hypertext select the command Open URL

3 At the cursor position (after a blank in the dialogue) type 
the complete URL (including the protocol), e.g. http://
www.daube.ch/docu/fmaker00.html

4 Press New Hypertext Marker.

Article threads

Do not check this option in Format > Document > Acrobat 
setup. Checking this option generates Acrobat articles in the 
same sequence as the text frames. A text flow creates an 
Acrobat article.

Frame Hypertext commands PDF equivalent Remarks (menus refer to the Acrobat Reader)

alert, alerttitle Note The note is closed initially

exit - Use menu File > Exit

gotolink, gotolink firstpage, gotolinkfit-
win, gotopage, nextpage, openlink, open-
linkfitwin, openpage, previouspage

Reference File name suffix FM will be changed to PDF

matrix (of buttons) - Replace with multiple references

message - Works only with Frame API clients

message system, message winexe - Replace with program launch

message URL Weblink May refer to any file type the browser can handle

newlink named destination OK since Acrobat 5

opennew - Acrobat can not create a new document

popup - Not possible in Acrobat 5

previouslink, previouslinkfitwin - Use menu View > Go Back

quit - Use menu File > Exit

quitall - Use menu Window > Close All
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Named destinations

For all cross references in FrameMaker (also those auto-
matically generated in TOC or index) named destinations 
are created in the Acrobat file.

Use the Frame hypertext command newlink for special des-
tinations (e.g. go to page 5)

Thumbnail pages

For the newer (> 5) PDF Readers it is not necessary to embed 
the thumbnail pages in the PDF. These readers can generate 
the thumbnails on the fly.

To generate thumbnail pages as a navigational aid:

1 In the Distiller Settings > Edit Adobe PDF Settings > Gen-
eral activate the option Embed Thumbnails.

2 You may wish to save the special settings with a name (e.g. 
Digiprint-thumbs.joboptions) in Save as...

Optimising for Internet distribution

In the Distiller Settings > Edit Adobe PDF Settings > General 
activate the option Optimise for fast Web view.

For distribution via the Internet, the server should be ‘byte 
serving enabled’ and the browsers should also be able to han-
dle served bytes (this is standard since IE 5.0).

Byte serving allows the server to send pages of the document 
out of order, according to the requests from the browser. The 
user can click into the Table Of Contents as soon as it is visi-
ble and jump to any page.

Predefined Job Options

Print shops may require you to use their job option if you 
want your PDF to be printed on their equipment.

It is also a good idea to use in other cases job options pre-
pared by experts, for example those at www.prepress.ch

X

X

http://www.prepress.ch/d/pdf/web/settings.html
http://www.prepress.ch/d/pdf/web/settings.html
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Modify the PDF file with Acrobat
For more sophisticated features, such as linking between vari-
ous PDF documents, link to HTML files etc. you need deep 
knowledge of the pdfmark statements which can be embedded 
into the PostScript file by FrameMaker.

Note: Functions described in this section require the Acrobat tool, not 
just the Acrobat Reader.

Crop pages

Sometimes it is necessary to produce the FrameMaker docu-
ment on A4 paper with large margins. This does not look nice 
in PDF.

To crop the pages to the desired presentation size, 

1 Open the PDF file in Acrobat (not Acrobat Reader)

2 Got to the desired page if you want to crop only one page.

3 Touch the crop tool  and open a rectangle on the page 
by dragging the mouse.

4 Click the crop tool again and adjust the values in the crop 
dialogue to your needs.
To crop all pages, select All in the Page Range.

5 Press OK to see the cropped page.

Export image as eps

Acrobat may be your last resort to cope with image problems. 
To extract an image from a PDF file,

1 Open the PDF in Acrobat and go to the desired page.

2 Crop the page to the image size (see Crop pages).

3 In File > Save As … select EPS as file format and save the 
file. Only the current page will become the eps. It may be 
necessary to set Options in Settings … (this button exists 
only for certain file formats, in particular for eps):

- General: include Preview

- General: No font inclusion

- PostScript Options: Send font at start only

Note: The eps you get is PostScript. But in many cases the image 
source was a TIFF or other bitmap and the eps can not provide 
vectors!
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Some problems with PDF files

Colours in FrameMaker and PDF don’t match

To make the online PDF files have the same colour shown in 
FrameMaker, follow the advice Match colours in FrameMaker 
and PDF on page A-37.

Long ovals etc. warped

Shapes with round corners etc. look like drawn with a wide-
nib pen and you’d changed the nib wangle halfway down the 
side.

Reason The problem is related to a new setting in Acrobat Distiller 7, 
intended to reduce the file size of PDFs created from CAD 
drawings.

Remedy In your Distiller 7.0 joboptions in the Advanced TAB turn OFF 
Convert smooth lines to curves

ON is default in «Standard» and «Smallest file size» - and in 
most job options from Stefan Jaeggi.

[Schlomo Perets, 2005-03-20]

Thin lines disappear in PDF

When creating a PDF for a high resolution printer thin lines 
disappear in the output.

Reason In PostScript it is possible to define hairlines. Hairline is sim-
ply the smallest line an output device is able to resolve. What 
may look fine on a 300 dpi laser printer will likely disappear 
at 2400 dpi. 

Remedy Make your thinnest lines at least 0.3 points (0.1mm) and your 
thinnest dotted rules at least 0.6 points (0.2mm).

In various graphic programs (Illustrator, CAD applications) 
there is no minimum default setting. Hence the graphic artist 
must obey this rule.

If you can not re-create the graphic with appropriate line 
widths, the program PStill may help: http://www.wizards.de/
~frank/pstill.html (2005: CHF 30).

Preparing files for printing

The following source gives useful advice:

http://millettheprinter.com/dtptips.htm
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Formulas (equations)

Overview

The FrameMaker formula (or equations) editor is a 
powerful instrument. It does not create just a 
graphic appearance of a formula but displays a 
mathematical structure. Hence the handling differs 
to most other formula editors .

Contents

Formulas (equations) ..............................................  2
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Common problems with formulas ..........................  10
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Formulas (equations)
A formula (or equation in FrameMaker terms) is a mathemati-
cal construct, not just a graphic (as for example, in MS Word). 
Hence you must follow the inner logic of a formula to develop 
it.

This script can not provide all the information from the man-
ual. For extensive work with formulas please read the manual!

Selecting formulas and their elements

A formula is automatically placed into an anchored frame 
(anchored at insertion point). The formula hereafter is placed 
in an anchored frame of different properties to display some 
features of a formula:
.

The framed rectangle is the anchored frame (anchored in 
the preceding paragraph, alignment left)

The light shaded area denotes the formula. Select the com-
plete formula with CTRL-click. Then the formula can be 
moved around within the anchored frame.

Select an element of the formula (e.g. the square root sym-
bol) with these methods:

- Double click on the element.

- Place the cursor in front of the element and press the 
space-bar once.

- Sweep the cursor over the element. The amount and 
direction of movement while sweeping expands the 
selection of the current formula construct.

Expand the selection to the higher level construct with the 
up-arrow or the space-bar.

Narrow the selection to an inner element with the down-
arrow.

To replace a construct, select it, press backspace to get the 
question mark (which is selected). No you enter the new 
term (or paste a selection).

In-line formulas

An in-line formula is inserted in an ordinary paragraph, 
rather than in a paragraph of its own. Most time you will need 
to specify «no fixed line spacing» to give room to the formula.

a
5 1–
2

-----------------⎝ ⎠
⎛ ⎞ b⋅=
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Stand alone formulas (display formulas)

Example formula:
proportion of the
golden rectangle

A rectangle with proportions that from classical Greek times 
has been thought optically pleasing. The relationship between 
the larger side a and the shorter side b of the rectangle is as 
follows:

 

Insert a formula 1 Place the cursor in an empty paragraph with the basic 
property «variable line spacing».

2 Open the Equation palette ( ).

3 With the button Equations select the appropriate size for 
the new equation (for example, New Medium Equation).

4 Select Operators in the Equations palette and start the for-
mula with operator ? = ? (the first ? will be highlighted, so 
that you can change it to «a».

5 Select the second ? and replace it by operator square-root; 
replace the ? under the root by «5».

6 Select the square root and apply operator «? - ?»; replace 
the new ? by «1».

7 etc. - by now you should know how to work with this editor …

8 Finally shrink wrap the equation (select from the drop 
down list Equations).

Keyboard input vs 
«mousing»

See Keyboard input for formula elements on page 12 for a com-
plete list of keyboard short-cuts. The keyboard input for the 
sample formula is ( denotes a blank, ! denotes a Return,  
is Right Arrow):

ESCmla=/\sqrt!5-12bESCmp

a
5 1–
2

-----------------⎝ ⎠
⎛ ⎞ b⋅=

In the keyboard short cuts 
the exclamation mark 
denotes the ESC character. 
To unwrap a formula you 
enter ESC, m, e. potence, powersuperscripts, subscripts

timesvertical and horizontal list elements
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Numbered formulas

Set up a numbered paragraph format with the number 
appearing at the end of the paragraph.

(1) 

Format name For example fon-formula-numbered.

Basic properties Line spacing must be variable (fixed not checked).

Space above and below becomes the space above and below 
the formula frame, not just around the paragraph text.

Numbering property F:Formula [<n+>]

Position «End of Paragraph».

Reference to a numbered formula

If you wish to reference a numbered formula, use a cross-ref-
erence style «paranum & page», which might look like this:

<1-highlight><$paranum><$paratext></> on page 
<$pagenum>

Example reference As you can see in (1)  on page 4, …

Create formula in anchored frame

Formulas can be placed directly into an anchored frame:

1 Select the frame

2 Select formula size from the Equations palette

3 Build the equation

4 CTRL-click on the formula to select it and move it around

5 Add any other elements to the anchored frame (for exam-
ple, graphics). These may also be in the frame at first.

6 Alignment of complete formulas with Graphics > Align... 
acts on the base line of the formula text (the base line of 
the word «sin» above), not the bounding box of the for-
mula.

a
5 1–
2

-----------------b=

xsin 5asech
x

-------------------------4= xsin

min

max

∑ 5xasech4=
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Palette overview

The Symbols and Operators palette are displayed on page 3.

Large Symbols

Calculus

Matrix

Relations

Delimiters
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Special formatting of formulas

Resize a formula

When setting up a formula you must choose a size (small, 
medium, large). To change this afterwards,

1 Select the formula. It may be shrink wrapped or expanded.

2 Select Graphics > Object properties

3 Change the size attribute to your desire; Set!

Align formulas

Align formulas 
graphically

Formulas can only be aligned if they are located in the same 
frame. Hence you may start with a frame and add the formu-
las to it.

To align the formulas at their boundaries (bounding box) 
treat the formulas as graphic elements:

1 Select the equation (s) which you want to align.

2 Select the equation which will be the master for the align-
ment.

3 Choose Graphics > Align and set the alignment to your 
desire. You may wish to use a guiding line (see image).

Align formulas along 
special symbol 

To align the formulas along a special point (e.g. the equal 
sign):

1 Click into the first formula to set the alignment point. You 
may move the alignment point with the left or right arrow.

2 Set the alignment point with the Equations palette Posi-
tioning > Left/Right > Set Manual or ESC, m, a, s. 

3 Repeat the above sequence for all formulas in the frame 
which you want to align.

4 To clear an alignment point, select the formula and enter 
ESC, m, a, d (or choose from the Equations palette Clear 
Manual).

5 Select the formula (CTRL+click) with the most proper 
alignment and choose Graphics > Object Properties.

6 Set the Alignment to Manual and set the left position to a 
memorable value (2.544  2.5) or copy the formula to the 
clipboard.

xsin basech
x

-------------------------4=

xsin

min

max

∑ 5xasech4=

xsin basech
x

-------------------------4=

xsin

min

max

∑ 5xasech4=
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7 Select the next formula to be aligned, with Object Proper-
ties set Alignment to Manual and the left position to the 
new/copied value.

8 Repeat the last operation for all formulas in the frame to 
be aligned.

Break long formula into lines

To break a long formula 
 into 

lines,

1 Place the cursor at the point where you want to break the 
formula. This can not be between a string (entered with "") 
and an operator!

2 Enter a manual break with Equations palette Positioning > 
Line Breaking > Set Manual or ESC, m, b, s.

3 To remove a manual line break, select the preceding and 
succeeding elements also (e.g. ) and apply ESC, m, 
b, c or choose from the Equations palette Clear Manual.

Copy and paste formula elements

Formulas with ‘self repeating’ contents can be set up very 
quickly with the keyboard:

ESCml
1/a+
enter 2 blanks to select the whole formula
copy
press ‘arrow right’ 3 times to select the ?
paste
press ‘arrow right’ 3+2 times to select the ?
paste
...
Select the last ? and replace it by \ldots (small L)

The formula may not be visible, since it is larger than the ini-
tially opened frame. Enlarge the frame to make the complete 
formula visible, before you shrink wrap it with ESC m p.

Physical dimensions and other strings

Physical dimensions are just strings for the FrameMaker 
Equation editor. They do not bear any mathematical property 
and hence are not considered in evaluations.

To enter a string into a formula, start the string with a " 
(straight quote) and terminate it with the Return key (). You 
see two double quotes ("") after entering the beginning 
straight quote. These disappear as soon as you type the first 
character of the string.

For example, for the first term of the following formula, enter 
v"[m/sec] . As soon as you close the string with the Return 
key (), the string is selected. To may just continue with the 
equal sign.

1 x+ )8 x8 8x7

8x6 56x5 70x4

6x3 28x2 8x 1

+ +
+ + +
+ + +

=

1 x+( )8 x8 8x7 28x6 56x5 70x4 56x3 28x2 8x+ + + + + + + +=

70x4 56x3+

1

a
1

a
1

a
1

a
1

a …+
----------------+

--------------------------+
------------------------------------+

----------------------------------------------+
---------------------------------------------------------
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Vehicle speed: (2) 

You may not be satisfied with the space between the variable 
and the physical dimension. You are tempted to increase this 
space with positioning or spacing:

Vehicle speed: (3) 

This method does not adjust the length of the fraction bar.

Enter space in formula 
string

The method of choice is to enter a space as the first character 
in the string:

Vehicle speed: (4) 

To enter a thin space, type ESC,,t. To enter an n-space, type 
ESC, n,t. The following formula uses n-spaces:

Vehicle speed:  (5) 

Note: It is very difficult to insert or even change this first blank after 
you have closed the string! The best method is to remove the 
string (select and delete) and create it again.

Adapt font for strings in 
formula

To specify a specific appearance of the formula strings, open 
Equation palette > Equations > Equation fonts… and enter a 
character format for Strings. You can not enter a font name. 
From the character format only the font property is used. The 
size is determined by the formula size (large, medium, small).

Decimal comma The equation editor does not honour the regional settings of 
the operating system! Only some localised versions (e.g. Ger-
man) can work with the decimal comma. However this works 
only correct, if at the same time the number grouping symbol 
is not a period.
If you need a decimal comma in the English version of FM you 
need to enter the decimal part as a string: 17",5 to get 17,5. 
If you enter just the comma as string, the number will be put 
in parenthesis and the comma behind it: 17(5), 

Diacritical marks

Two diacritical marks can be stacked one on top of the other. 
More can be stacked only if the base elements are ‘grouped’. 
The marks which can be elongated (based on a line) are 
always the lower ones. Tilde, hat, bow and dot are always on 
top of a line shape.

The following marks can be elongated to span more than one 
base element: overbar, underbar, arrow, half-arrow. These can 
be stacked according to the base elements.

The others are only placed centred above the spanned ele-
ments (see first formula in this topic). These forms are from a 
font, whereas the lines are drawn as line graphics.

v[m/sec]
s[m]
t[sec]
----------------=

v [m/sec]
s [m]
t [sec]
----------------=

v [m/sec]
s [m]
t [sec]
-----------------=

v [m/sec]
s [m]
t [sec]
-------------------=

ã v· xy=

) )

a bcde
˜

=
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Remove a diacritical mark To remove a diacritical mark, select the base element and 
expand the selection to include the diacritics. Applying the 
diacritical mark again will remove it (toggle the mark on/off).

Special diacritical marks The capabilities of FrameMaker for handling diacritical marks 
may not be sufficient for you, e.g. to place an elongated hat or 
tilde above three elements:

You need a little bit of work to create such constructs:

1 Create an anchored frame (here filled with gray to display 
it):  

2 With the Graphic-Line tool from the graphics tools palette 
( ) create the desired character (as an example, we use 
the tilde): . You will notice that this is a graphic object 
with handles.

3 You can now elongate it by pulling the right handle: 

4 Select the modified symbol (tilde) as a graphic object and 
copy it into the formula frame:

- Select the tilde

- Copy the tilde to the paste buffer

- Select the formula frame

- Paste the tilde into the frame

5 Move the selected symbol (tilde) to the desired place with 
the mouse or with CTRL+arrow.

Working tip In the anchored frame you may set up a collection of 
items: .

These symbols can only get character formats. If you need 
symbols from a special font (such as the last one from the 
Symbol font, you need to set up an appropriate character for-
mat.

Positioning, fine tuning presentation

You may not be satisfied with the space between math ele-
ments, the location of exponents and indices etc. Although 
FrameMaker does a good job, math typesetters and TEX 
experts may have their complaints. In these cases manual 
work with micro positioning may be necessary.

Use the keys ALT+ etc. for fine movements.

Editing formulas

1 Unwrap the formula (ESC, m, e)

2 Place the cursor behind the element you want to edit

3 Select the element with Space bar

4 Modify the element (delete, replace, …)

5 Shrink wrap formula (esc, m, p)

x∂
∂

uvw
x∂

∂
uvw+ 0=~^

~

~

~^∩
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Common problems with formulas

Formula overlaps surrounding paragraphs

The formula construct uses an anchored frame at insertion 
point, which can only expand the paragraph height, if the par-
agraph has variable Line spacing.

 This is the «formula paragraph».

For paragraphs used as ‘anchors’ for formulas, the check box 
for fixed Line Spacing must be unchecked.

Variables are not displayed in italic

If the variables in a formula are not displayed in italics, you 
have accidental removed the character format EquationVaria-
bles (English FM) or GlgVar (German FM).

Set up the format again with the properties: Angle = italic; 
everything else As Is. The format must be in the character cat-
alogue.

Fraction bar has not the desired length

Vehicle speed: 

The fraction bar can get a correct length only if FrameMaker 
knows about the length of the elements involved. If you use 
micro-positioning or spacing, this is just an optical correc-
tion. To get correct results, see Enter space in formula string on 
page 8.

Alternative fonts in formulas

The fonts used in the formulas are defined by character for-
mats. Within a formula use the context menu Equation Fonts 
... to display the dialogue for setting the font properties.

Possible font alternatives
for Math Symbols

«Lucida New Math», «Mathematical PI Std» or «Universal 
Standard Greek with Math PI».

Note: Re-defining the fonts may require re-shrinking of all equa-
tions! The definition in mathchar.cfg needs some tedious work!

a
5 1–
2

-----------------⎝ ⎠
⎛ ⎞ b⋅=

v [m/sec]
s [m]
t [sec]
----------------=

Category Default a

a. The notion «Default ¶ Font» actually refers to the «DefaultFamily» as 
specified in maker.ini ! At D+DD this is set to Lucida Sans rather 
than Times New Roman  see appearance of formulas here.

Modification needed …

Math Symbols Symbol tweaking maker.ini (and mathchar.cfg)

Functions Default ¶ Font any character format (font family used only)

Numbers Default ¶ Font any character format (font family used only)

Strings Default ¶ Font any character format (font family used only)

Variables EquationVariables any character format (style used only)
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Evaluation

Numeric results

To evaluate an equation 
(get numeric results):

To evaluate a formula, for example :

1 Select the equation inside its frame.

2 From the Equations palette choose Functions > Evaluation 
> Number crunch

3 You get the following result:

4 At this stage you may undo the operation to see the alge-
braic notation again.

Symbolic evaluation

With Functions > Evaluations some expansions are available. 
To apply an expansion, select the formula (or part of) and 
then choose the function:

Addition > Add
Fractions

 becomes  and then 

Division > Long Division Numerator and denominator must be polynomials for this 
function. Select any x in 

 and apply the func-

tion:  and then 

Multiplication >
Multiply out

 becomes 

Evaluation > Evaluate  becomes 

For even more mathematics see the manual.

a
5 1–
2

-----------------⎝ ⎠
⎛ ⎞ b⋅=

a 0.61803399 b⋅=

a
4
--- 2a

3
------- 7a

5b
-------+ + 11a

12
----------- 7a

5b
-------+ 55ab 84a+

60b
---------------------------------

x5 20x4 160x3 640x2 1280x 1024+ + + + +
x2 8x 16+ +

--------------------------------------------------------------------------------------------------------------------------

x3 640x2 1280x 12x4 144x3 1024+ + + +
x2 8x 16+ +

-------------------------------------------------------------------------------------------------------------+

3 12x2 1280x 48x3 448x2 1024+ + +
x2 8x 16+ +

-------------------------------------------------------------------------------------+ +

y x 4+( )5=
y x5 20x4 160x3 640x2 1280x 1024+ + + + +=

x 4+( )5 x 4+( ) x 4+( ) x 4+( ) x 4+( ) x 4+( )
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Keyboard input for formula elements
Many maths elements and most functions can be entered via 
the keyboard.

To enter a Backslash sequence, press Return to end the back-
slash sequence.

Most short-cuts are not localised, so they are valid both for 
the English and German FrameMaker. The only exception is 
the input of diacritical marks, which depends on the lan-
guage.

Note: On a Swiss keyboard some short cuts are not available (not 
working). This is because some characters such as tilde are 
only available as accents on ‘dead keys’.

Note: Some of the sequences listed in the Help for the German FM 
are wrong. The sequences given here are tested with Windows 
NT4 and 2000 with a Swiss keyboard. Sequences in shaded 
cells do not work at all. No correct key sequence could be found 
for these.

Equations pop-up menu

Strings

Strings are single line comments in a formula. To enter them, 
just start with a single or double apostrophe and enter the 
text. Terminate with a Return (there is no terminating apos-
trophe).

See example in Physical dimensions and other strings on page 7.

Command Short-cut

New Small Equation Esc m s

New Medium Equation Esc m m

New Large Equation Esc m l (lc L)

Shrink-Wrap Equation Esc m p

Unwrap Equation Esc m e

Equation Sizes Esc p e

Equation Fonts Esc m f

Insert Math Element Esc m i

Add Definition to Catalogue Esc m c

Update Definition Esc m U

Command Short-cut

Start String ' or "

End String Return
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Symbols

Greek characters

Element Short-cut Backslash sequence

α Control+Alt+a \alpha

β Control+Alt+b \beta

Γ Control+Alt+G \Gamma

γ Control+Alt+g \gamma

Δ Control+Alt+D \Delta

δ Control+Alt+d \delta

ε Control+Alt+e \epsilon

ζ Control+Alt+z \zeta

η Control+Alt+h \eta

Θ Control+Alt+Q \Theta

θ Control+Alt+q \theta

ϑ Control+Alt+J \vartheta

ι Control+Alt+i \iota

κ Control+Alt+k \kappa

Λ Control+Alt+L \Lambda

λ Control+Alt+l (lc L) \lambda

μ Control+Alt+m \mu

ν Control+Alt+n \nu

Ξ Control+Alt+X \Xi

ξ Control+Alt+x \xi

Π Control+Alt+P \Pi

π Control+Alt+p \pi

ρ Control+Alt+r \rho

Σ Control+Alt+S \Sigma

σ Control+Alt+s \sigma

ς Control+Alt+E \varsigma

τ Control+Alt+t \tau

ϒ Control+Alt+U \Upsilon

υ Control+Alt+u \upsilon

Φ Control+Alt+F \Phi

φ Control+Alt+f \phi

ϕ Control+Alt+j \varphi

χ Control+Alt+c \chi

Ψ Control+Alt+Y \Psi

ψ Control+Alt+y \psi

Ω Control+Alt+O \Omega

ω Control+Alt+o \omega

ϖ Control+Alt+I (uc i) \varpi

∂ Control+Alt+7 \cpartial
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Other special symbols

Diacritical marks

Please note the remarks on page 12 concerning the shaded 
areas!

Element Short-cut Backslash sequence

∞ Control+Alt+one \infty

⊥ Control+Alt+2 \bot

… Control+g period \ldots (lowercase L)

ℵ Control+Alt+3 \aleph

ℑ Control+Alt+4 \Im

ℜ Control+m $ \Re

℘ Control+Alt+5 \wp

∅ Control+Alt+zero \emptyset

∇ Control+Alt+6 \nabla

° Control+m ) \degree

′ Control+Alt+` \prime

″ Control+m " \pprime

Element Short-cut (FM-E) Short-cut (FM-D)

` (grave) ` (Grave)

~ (tilde) ~ (Tilde)

Control+g hyphen
Esc m _ (underline)

Control+g hyphen

Control+Alt+V Strg+Alt+V

Control+g ^ Strg+Alt+^

period Punkt

Control+g ~ (tilde) Strg+Alt+~ (tilde)

Control+g _ (underline) Strg+g _ (underline)

Control+g right arrow Strg+Alt+= a

a. Control+g right arrow works also in the German FM.

Control+g @ Strg+g @

x'

x̃

x

x

x̂

x·

x
˜
x

x

x

)
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Operators

Please note the remarks on page 12 concerning the shaded 
areas!

Toggle format switches between the representation of frac-
tions.

Element Short-cut Backslash sequence

? + ? plus \plus

? - ? minus (after an operand)

? x ? Control+m * (asterisk) \cross

? ⋅ ? Control+m . (period) \cdot

? • ? Control+8 \bullet

Toggle Format Control+T
Esc m T

? / ? Control+Alt+/ \fract

? ÷ ? Control+m / \div

/ \over

? = ? = \equal

= ? Control+g = \uequal

? ‡ ? Control+j \jotdot

? , ? comma \comma

? ⊗ ? Control+q D \otimes

? ⊕ ? Control+q E \oplus

? ∧ ? Control+q Y \wedge

? ∨ ? Control+q Z \vee

? ∩ ? Control+m i \cap

? ∪ ? Control+m u \cup

, ? Control+m , (comma) \ucomma

; ? ; (semicolon) \semicolon

¬ ? Control+m n \neg

- ? Control+hyphen \minus

Control+m one \mp

± ? Control+q one \pm

∇ ? Control+q Q \grad

∇ ? ? Control+q Q
(and add operand)

Δ ? Control+m Control+d \change

Control+m x \box

Control+m o \boxdot

Control+m 2 \box2

∀ ? Control+m a \forall

∃ ? Control+m e \exist

?
?
---

?+−

?
?•

?2
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Large symbols

Use these short-cuts to type each element with only one oper-
and. Then use Add Operand and Toggle Format as needed

∴ ? Control+m t \therefore

Control+a, Esc m v l (lc L) \atop

?   ? Control+m ; (semicolon),
Esc m h l (lc L)

\list

? ? * (asterisk) \times

| ? | Control+g | (bar) \abs

? ? (superscript) Esc m ^

? ? (subscript) Esc m Control+_ 

? ? (superscript in front) Control+m Control+^

? ? (subscript in front) Control+m _ (underline)

Control+r \sqrt

Control+r
(and add operand)

? ×10 ? Control+E \sn

? ? (exponent) ^ \power

? † Control+m d \dagger

? ! ! \fact

? * Control+m s \ast

∠ ? Control+q P \angle

Element Short-cut Backslash sequence

?
?

?

??

Element or command Short-cut Backslash sequence

Control+S \sum

Control+P \prod

Control+i \int

Control+I (uc i) \oint

Control+m I (uc i) \bigcap

Control+m U \bigcup

Add Operand Control+N
Esc m n

Toggle Format Control+T
Esc m T

?∑
?∏

?∫
?∫°

?∩
?∪
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Delimiters

Use Toggle Format to switch between the various types of 
parentheses.

Apply Remove Parentheses only to the selection from which 
you really want to remove the grouping. To remove only one 
delimiter (and its mate), place the cursor right to the delim-
iter and press Delete.

Element or command Short-cut Backslash sequence

(?) ( \id

[?] [ (left bracket)

{?} { (left brace)

| (bar) \substitution

Control+m < \dangle

|?| Control+g | (bar) \abs

(? Control+m ( \lparen

[? Control+m [ (left bracket)

{? Control+m { (left brace)

| (bar) (and add operand)

Control+m k \ket

||?|| Control+m | (bar) \norm

?) ) \rparen

?] ] (right bracket)

?} } (right brace)

| (bar)
(and add two operands)

Control+m b \bra

Control+q i \ceil

(?,?) Control+m N \inprod

[?,?] Control+m C \cmut

{?,?} Control+m A \acmut

_ (underline) \overline

Control+m B \bket

 Control+q k \floor

Control+m h \choice

Control+m D \downbrace

 Control+m P \upbrace

Toggle Format Control+T
Esc m T

Remove Parenthe-
ses

Esc m r p

?

?〈 〉

?
?

?| 〉

?
?
?

?〈 |

?

? ?〈 | 〉

?
?⎝ ⎠

⎛ ⎞

x

}

x

{
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Relation

Element Short-cut Backslash sequence

? < ? < \lessthan

? > ? > \greaterthan

? = ? = \equal

? ~ ? Control+m ~ (tilde) \sim

? ⊂ ? Control+q L \subset

? ⊃ ? Control+q I (uc i) \supset

? ← ? Control+q comma \leftarrow

? → ? Control+q period \rightarrow

? ↔ ? Control+q plus \lrarrow

? ⊥ ? Control+m r \perp

? ≤ ? Control+g < \leq

? ≥ ? Control+g > \geq

? ≡ ? Control+q : (colon) \equiv

? ≈ ? Control+q ; (semicolon) \approx

? ⊆ ? Control+q J \subseteq

? ⊇ ? Control+q M \supseteq

? ⇐ ? Control+q \ \Leftarrow

? ⇒ ? Control+q ^ \Rightarrow

? ⇔ ? Control+q [ \LRarrow

? || ? Control+m p \parallel

? << ? Control+q l (lc L) \ll

? >> ? Control+q g \gg

? ≠ ? Control+q = \notequal

? ≅ ? @ \cong

? ∈ ? Control+q N \in

? ∋ ? Control+' \ni

? ∉ ? Control+q O (uc o)

= ? Control+g = \uequal

? ⊄ ? Control+q K \notsubset

? ∝ ? Control+q 5 \propto

Table 2: Relational operators
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Calculus

Use the first two mentioned short-cuts to type large symbols 
with only one operand. Then use Add Operand and Toggle 
Format as needed.

Element or command Short-cut Backslash sequence

Control+i \int

Control+I (uc i) \oint

Add Operand Control+N
Esc m n

Toggle Format Control+T
Esc m T

Control+g t \optotal

Control+g T

Control+g p \oppartial

Control+g P

Control+g t
(and add operand)

Control+g T
(and add operand)

Control+g p
(and add operand)

Control+g P
(and add operand)

δ ? Control+Alt+d \var

∇ ? Control+q Q \grad

Control+d \diff

∇ x ? Control+m c \curl

∂ ? Control+D \partial

∇ • ? Control+m v \diver

Control+L \lim

∇ 2 ? Control+m l (lc L) \lap

?∫
?∫°

?d
d

?d
d ?

?∂
∂

?∂
∂ ?

?

?

d
d

?

?

d
d ?

?

?

∂
∂

?

?

∂
∂ ?

?d

?
?

lim
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Matrices

To insert a matrix of any size, first insert a 1 by 1 matrix. 
Then add rows and columns one at a time. With the Equations 
palette you have a selection of pre defined matrices available

Functions

For the functions (except for the general function and the 
limit) you must have selected an appropriate portion of a for-
mula.

Pre defined matrices in

Equations palette > Matric

Command Short-cut

Add/Remove Brackets Control+T

Matrix Commands pop-up menu

Create 1 x 1 Matrix Esc x m

Add Row Esc x r

Add Column Esc x c
Control+C

Matrix Transpose Esc x t

Matrix Algebra Esc x a

Matrix Row Height pop-up menu

Toggle fixed/proportional Esc m t r

Matrix Column Width pop-up menu

Toggle fixed/proportional Esc m t c

Element / command Short-cut Backslash 
sequence

? (?) Control+f \function

Control+L \lim

Addition pop-up menu

Add Fractions ESC m a a

Order Sum ESC m a o

Order Sum Reverse ESC m a O (uc o)

Multiplication pop-up menu 

Factor ESC m u f

Factor Some ESC m u F

Multiply Out ESC m u m

Multiply Out Once ESC m u M

Distribute ESC m u d

Distribute Over Equality ESC m u D

Division pop-up menu 

Long Division ESC m d l (lowercase L)

Remove Division ESC m d d

Remove Division 1 Level ESC m d D

Remove Negative Powers ESC m d n

Remove Negative Powers 1 Level ESC m d N

Evaluation pop-up menu

?
?

lim
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Positioning and line breaking

The number of points shown in the following table is based 
on a zoom setting of 100 percent.

Number Crunch ESC m v n

Show All Digits ESC m v . (period)

Evaluate ESC m v e

Evaluate Substitution ESC m v s

Evaluate Integrals ESC m v i

Evaluate Derivatives ESC m v d

Evaluate Derivatives 1 Level ESC m v D

Rules pop-up menu

Enter Rule ESC m r e

Apply Rule ESC m r a

Designate Dummy ESC m r d

Other Rewrites pop-up menu 

Simplify ESC m o s

Simplify Some ESC m o S

Isolate Term ESC m o i

Expand First Term ESC m o e

Expand All Terms ESC m o E

Element / command Short-cut Backslash 
sequence

Function Short-cut

Micro positioning

Move up 1 point Alt+up arrow

Move down 1 point Alt+down arrow

Move left 1 point Alt+left arrow

Move right 1 point Alt+right arrow

Move up 6 points Alt+Shift+up arrow

Move down 6 points Alt+Shift+down arrow

Move left 6 points Alt+Shift+left arrow

Move right 6 points Alt+Shift+right arrow

Remove micro positioning Alt+Home

Left/Right (Alignment) pop-up menu

Left Esc m a l (lc L)

Centre Esc m a c

Right Esc m a r

Left of = Esc m a plus

Command Shortcut

Right of = Esc m a =

Set Manual Esc m a s

Clear Manual Esc m a d

Reset Alignment Esc m a R

Up/Down (Alignment) pop-up menu

Top Esc m a t
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Navigating in a formula

Select next prompt tabs through the entry fields of pop-up 
dialogues.

Moving math elements

Baseline Esc m a B

Bottom Esc m a b

Line Breaking pop-up menu

Set Manual Esc m b s

Clear Manual Esc m b c

Function Short-cut

Function Short-cut

Moving the insertion point

Left left arrow

Right right arrow

From beside a fraction to the numerator down arrow

Changing the selection

Select next prompt Tab

Increase scope of selection space

Select next element to the left left arrow

Select next element to the right right arrow

Function Short-cut

Moving math elements while retaining algebraic equivalency

Left Shift+left arrow

Right Shift+right arrow

Up Shift+up arrow

Down Shift+down arrow

To far left Control+Alt+left arrow

To far right Control+Alt+right arrow

Left into expression Control+Shift+left arrow

Right into expression Control+Shift+right arrow

Moving math elements without retaining algebraic equivalency

Swap with element on left Control+m Control+left arrow

Swap with element on right Control+m Control+right arrow
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Display comparison
Since Donald Knuth developed TEX in the late 1970s for type 
setting mathematics the presentation of formulas with this 
tool is the gauge for

Relative size of objects (exponents, indices etc.)

Extension of symbols for root, sum, product etc.

Extension of parentheses, brackets and braces

Positioning of attributes (boundaries, limits, etc.)

Keep in mind that the beauty in the eye of the beholder [Scottish 
philosopher David Hume].

I do not have access to many systems, hence the following are 
mainly copies from books and screenshots.

TEX

FrameMaker

Mathtype

MS Word EQ Editor 3.0

MathCAD 11

MathML (Netscape 7.1)
with MIT fonts
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Generate HTML

Overview

HTML can be generated from a FrameMaker file or 
all files of a book.

The transformation is controlled by a large table on 
the reference pages, which is set up by default with 
some guessing by FrameMaker.

To get good transformation results this table must 
be adapted.

Contents

Save as HTML .........................................................  2

WebWorks Publisher Standard Edition ......................  5
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Save as HTML
With File > Save as … and selecting HTML a FrameMaker 
internal process is used to convert the document to HTML.

Since FrameMaker 6 an independent program is distributed. 
With WebWorks Publisher Standard Edition (see page 5) you 
get more pleasing results. For serious work, however, you 
need the full product WebWorks Publisher which allows full 
configuration of the conversion process.

Note: This process uses mapping tables on the reference tables 
named HTML. Hence a template may provide a complete set-
up.

To set up the mapping tables select File > Utility > HTML 
setup

If not all styles in the document are in the paragraph cata-
logue, you get prompts for all of those. You may decide not 
to include them in the catalogue. Nevertheless they are 
available for conversion to HTM.

Follow these rules for a reasonable setup:

After this set up you may need to change heading levels in 
the Heading table on the reference page Headings, because 
the automatism is not that good.

Paragraph type / Character type Mapping to HTML element

Heading, table heading, table title Heading (autolevel)

Ordinary paragraphs and the like, table 
cells (except lists in tables)

Paragraph

Citations Block Quote

Glossary term Data term

Glossary definition Data Definition

Code examples Pre formatted Text

Numbered and bulleted lists List Item

Continuation paragraphs to lists List Item (Continued)

Character formats for code, keyboard 
input etc.

Code

Character formats for variables Variable

Normal emphasis Emphasis

Stronger emphasis Strong Emphasis

anything you don’t like to appear in the 
HTML output.

Throw Away
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Set the options for graphics. The conversion of graphic for-
mats is only applied to graphics, which are copied to Fram-
eMaker (not referenced) or FrameMaker vector graphics.

Set the option Copy Files Imported by Reference if you 
want all referenced graphics to appear in the same direc-
tory as the HTML file. These files are not converted.

Select Save as... and choose HTML from the Save as type… 
pull down list.

Define an appropriate file name (with extension html) and 
wait some time.

You may need tweaking of the generated mapping table on 
the reference pages names HTML and Headings (see Head-
ing table on page 12-3).

The generation (with some tweaking according to the rules 
above and an adapted Headings table) gets useful results

Definitions on the Reference Pages

The tables are displayed here in there more or less original 
appearance. I have only removed the Comment columns in 
most cases.

Heading table In most cases, this table need some adaptation, because Fram-
eMaker defines arbitrary heading levels

HTML Mapping table As soon as you change a H* item to a distinct HTML heading 
(for example, H3), this heading will disappear at the next 
HTML generation from the Heading table displayed above.

HTML options table

System macros These macros can be used to define special headers at the 
entrance into an HTML page (see Code for a navigation bar on 
page 4).

Cross reference macros These are OK for most purposes and don’t need any changes.

General Macros Have not yet figured out what can be done with these.

Character macros This is a mapping of characters to HTML entities or ordinary 
characters. You may need to add some special characters 
here.

Control Value Comments

Image Format 0001IMAGGIF         GIF

Copy Files Imported by Refer-
ence

N

Export Encoding ISO-8859-1

CSS Export Encoding ISO-8859-1
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Code for a navigation bar

To insert a navigation bar of the kind …

[First Page] [Previous Page] [Next Page] [Table of Con-
tents] [Index]

… the following code should be used for macros StartOfDoc, 
StartOfSubDoc, StartOfFirstSubDoc and StartOfLastSubDoc.

<H5>
<A HREF=»$parentdoc»>[First Page] </A>
<A HREF=»$prevsubdoc»>[Previous Page] </A>
<A HREF=»$nextsubdoc»>[Next Page] </A>
<A HREF=»$FrameBookTOC.htm»>[Table of Contents]<A>
<A HREF=»$FrameBookIX]»>[Index]</A>

</H5>
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WebWorks Publisher Standard Edition
Since version 6 FrameMaker includes Quadralay WebWorks 
Publisher Standard Edition (WWPst), which provides robust 
features for creating HTML, Dynamic HTML, and XML output:

Map FrameMaker elements (such as paragraph tags, charac-
ter tags, and graphics) to online styles.

Convert text, graphics, and tables to HTML, Dynamic 
HTML—HTML with cascading style sheets (CSS)—and XML.

Determine how a FrameMaker document is divided into one 
or more HTML files.

Convert any images into online formats.

Specify how navigation bars appear at the top and bottom 
of a page.

Create an HTML FrameSet.

Note: On your system WWPst might not be installed or installed in a 
directory other than where FrameMaker is installed.

Templates

WWPst provides templates for the following output forms of 
web pages:

Dynamic HTML This template produces HTML that uses a cascading style 
sheet (CSS) file and is compliant with the HTML version 4.0 
standard. Dynamic HTML Standard Edition output requires a 
version 4 or later browser.

Portable HTML This template produces basic HTML that is compliant with the 
HTML version 3.2 standard. Portable HTML Standard Edition 
output works well in any web browser (such as Netscape ver-
sion 2 or higher and Internet Explorer version 3 or higher).

XML+CSS This template produces Extensible Markup Language (XML) 
that can be displayed by browsers that support XML and CSS.

XML+XSL This template produces XML that can be displayed in brows-
ers that support the Extensible Stylesheet Language (XSL). The 
default XSL rules included with the template transform the 
generated XML into an HTML result set for display in IE5, 
however, they can easily be customized for other purposes if 
desired.

Conversion process

WWPst provides a wizard to set up a WWP project. Use File > 
New to start the wizard and follow the dialogues:

After defining the name and location (folder) of the project 
you are requested to enter the FrameMaker source. This may 
be a book or a FrameMaker file. The following example takes 
the file html.fm from this handout (chapter 11, first part).
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WWPst now analyses the input file(s) and creates a mapping 
table for the paragraph and character styles found (in use).

Set the defaults to more reasonable mappings:
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WWPst is now ready to convert the input files into HTML:

A number of project files become visible in the sub directo-
ries of the project. 

The most prominent results are the HTML file and the CSS 
file. We did not specify to break up the long input file into 
distinct HTML files at a certain heading level. Hence there is 
only one HTML file for one FrameMaker file.

Modifications to the WWPst project set up are not supported 
with the wizard.

The resulting HTML page looks much nicer than that one gen-
erated with the FrameMaker internal conversion tool. Obvi-
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ously the WWPst is an advertisement for the full product - 
hence the banner on top and at the bottom of the page:

Refining the project

The mapping can be refined with Project > Options:

Start new HTML pages with paragraph mapping to 
NewHTMLPage

Map a table format to either Default or Alternate Shading

In the mapping of cross reference formats remove the page 
number building blocks

Note: In WWPst the Macros and the General properties can not be 
changed. This requires the full product.

After setting of NewHTMLPage for 1heading and 2heading we 
get these files in the project:
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Now the FM file is broken up into 4 HTML pages. In addition 
we modify the default file mapping

Also the first and last file shall use the Normal page style.

In addition we fix the mapping of the paragraph tag lc-
checklist to SmartList1 and in the style sheet we set the text-
indent of the body tag to 0.

After these modifications page html2.html looks like this in 
Opera 6:

With the TOC button we get access to first and with the Index 
button to the last page of the set.

Navigation buttons

Since we now have multiple pages, WWPst automatically adds 
navigation buttons to the pages, both on top and at the bot-
tom:

WWPst assumes that the first input file of a FrameMaker book 
is a TOC (table of contents) file and the last is an IX (index) 
file.
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Style sheet (CSS)

Further tweaking, for example change indentations, can be 
performed by modifying the style sheet. This is also better 
organised than the version of the FrameMaker standard tool.

/* Document Defaults */
body { font-family: Verdana, Arial, Helvetica, sans-serif; font-size: 10pt; font-
style: normal; font-weight: normal; color: #000000; background-color: #FFFFFF; 
letter-spacing: normal; text-align: left; text-indent: 15pt; word-spacing: normal}
a:active { color: #0000CC}
a:hover { color: #CC0033}
a:link { color: #3366CC}
a:visited { color: #9999CC}

/* Paragraph Styles */
.Body { margin-left: 30pt}
.BodyRelative { }
.CellBody { }
.CellHeading { text-align: center; font-weight: bold; color: #003366}
.GroupTitlesIX { font-size: 16pt; color: #003366}
.Heading1 { font-size: 18pt; color: #003366 ; font-weight: bold; margin-top: 20px}
.Heading2 { font-size: 15pt; font-weight: normal; color: #003366}
.Heading3 { font-size: 12pt; font-weight: bold; color: #003366}
.Heading4 { font-size: 10pt; font-weight: bold; font-style: italic; color: #003366}
.IndentedRelative { }
.NewHtmlPage { text-align: center; font-size: 18pt; color: #003366 ; font-weight: 
bold; margin-top: 20px}
.Preformatted { }
.PreformattedRelative { }
.TableTitle { text-align: center; font-style: italic; font-weight: bold}
.Title { text-align: center; font-size: 18pt; color: #003366; font-weight: bold; 
margin-top: 20px}
.TOC1 {  font-size: 13pt; font-weight: bold}
.TOC2 {  font-size: 11pt}
.TOC3 {  font-size: 10pt}
.TOC4 {  font-size: 9pt}
.TOC5 {  font-size: 8pt}

/* Character Styles */
.Code { }
.CodeEmphasis { font-style: italic}
.CodeStrong { font-weight: bold}
.Emphasis { font-style: italic}
.EmphasisUnderline { font-style: italic; text-decoration: underline}
.Strong { font-weight: bold}
.StrongUnderline { font-weight: bold; text-decoration: underline}
.SubScript { }
.SuperScript { }
.WebJump { }
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Overview

In this chapter special and maybe rarely used func-
tions of FrameMaker are presented.

Contents

Document structure ................................................  2
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Document structure
FrameMaker documents are structured with the following 
mechanisms:

A book refers to chapters or parts of

A chapter (or part of a chapter in a file) is broken down 
into sections by means of headings (1heading, 2headings)

There is no control of the structure. You are free to place a 
heading level 5 just after the chapter heading... Rigid control 
over structure is maintained with the SGML mechanism avail-
able with the Structured Interface (Structured documents on 
page 1-16).

Checking structure

A document should keep a logical structure which depends 
on the subject the document is about. For example, the struc-
ture of a user manual for a machine is regulated by standards. 
to judge the value of structure, look at a beautifully shaped 
tree with its branches, twigs and leaves.

The physical structure of a document is reflected in the book 
file. The logical structure can be seen in the Table of Contents 
and some aspects can also be seen in the index.

Check structure with TOC In the enhanced structure we have a more even distribution of 
lower levels, thanks the new category elements of the work 
space:

Check structure with 
index

For example, the index of this handout first displayed these 
entries:

editing
cross-reference ............................. 7-8
graphic shape ............................... 6-9

How about editing footnotes or formulas? Well, there was no 
such subject in there until the index making process revealed 
this defect.

Old structure New structure

Working environment
Some discipline required.
Preferences
Customising FrameMaker 
Control characters in the text 

...
Palettes and catalogues

Tool palette 
Catalogues.

Quick access bar (tool bar)
Menus and palettes 

Graphic tools

Working environment 
Starting FrameMaker in standard mode
FrameMaker work space
Some discipline required
Preferences 
Navigate the document 
Customising FrameMaker
Sample templates
Control characters in the text
Appearance of check boxes.

...
Elements of the work space

Palettes and catalogues
Quick access bar (tool bar) 
Menus and palettes
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Modifying structure

Re-arrange files within a 
book

The files comprising a book are rearranged with File > Rear-
range Files... while you are in a book file.

If you have broken chapters into several files, you may need 
to adjust the settings for the files (numbering starting at 1 or 
continue, prefixes for generated files etc.) with File > Setup 
File.

Re-arrange information 
within a file

The standard FrameMaker implementation does not provide 
an outline view of the document. The powerful API (plug-in) 
«Enhance» from Sandybrook Software (http://
www.sandybrook.com) provides this feature:

Define up to 10 structural levels (1heading, heading2, cap-
tion,...)

Move entire levels or parts of

Promote and demote levels or parts of

Sort paragraphs alphabetically
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Conditional text
Note: Table columns (or individual cells in a table) cannot be made 

conditional.

Application of conditional text

Organising and implementing conditional text may be diffi-
cult. However, in the following cases it may be worth the 
effort:

Product levels Standard, extended, professional may be the names for condi-
tions in this case.

Development Information which is not yet fixed can be hidden in the cur-
rent release.

Review comments Questions to the reviewer and the answers can be placed in 
conditional text which may be hidden to print a clean draft.

Platform dependencies In software descriptions it may be useful to tag with Win-
dows, Mac and Unix.

Tutorials For training manuals you may wish to have both the Student 
part and the Instruction part in the same document.

Delivery medium Maintaining single source documents may require to handle 
special portions for the CD release, the printed version and 
the version for the web.

Compare docuemnts File > Utilities > Compare Documents … creaates a new 
document with two conditions (inserted, deleted) relative to 
the current document.

Keep it simple

Avoid assigning multiple condition tags to the same infor-
mation. Although you can handle 6 variants with 3 condi-
tions (mathematically) this makes you document very 
difficult to maintain.

Limit the number of conditions to the minimum. There is 
only a limited set of styles to represent the condition, 
although you can have many colours …

Use distinct condition tag names which alphabetise well.

If possible, tag entire paragraphs and not portions of para-
graphs, such as sentences or even words.

Define conditions for spaces and punctuation consistently. 

Alternatives for conditional text

Variables Company names, brands, product names and other short 
pieces are better handled by variables.

Custom markers Use custom markers for different types of indexed informa-
tion.

Note: Be aware that hidden conditional text also hides all markers in 
that text (e.g. cross reference targets, index markers).
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Chapters Instead of applying conditions to whole chapters, create alter-
native books. To avoid conflicts between the generated docu-
ments (e.g. the TOC or index), define individual prefixes in 
the book variants (e.g. TOC1 in the first book, TOC2 in the 
second).

Files You may break down a particular chapter into files. Placing 
the text inset referring to the file into a condition allows you 
to maintain the file independently (see Text insets on 
page 13-7).

Setting up conditions

Before applying conditions set up a scheme about the condi-
tions you need. For example, a software manual may have 
parts only relevant to operators and system programmers. 

If you ave portions only for beginners, you may face a ‘sub-
tracting’ condition. The unconditional text is common to all 
types of readers and hence may not contain all parts for 
standard users. A possible scheme is this:

Handle conditions

Presentation of 
conditional text

The following text is in condition tag «Comment».

This text is of condition «Comment». This is very useful for 

editorial comments

this is both Comment and Detail - colours are mixed

This is the last line with both the condition Comment and 
Detail.

This paragraph is without any condition, the following para-
graph is «Detail»:

This text has condition «Detail». This is an example, how to 
use conditional texts for variants of documents. Details are, 
for example, only needed for a certain type of readers.

This paragraph is without any condition.

Define a new condition To define a new condition tag (for example, operator):

1 In Special > Conditional Text… press Edit Condition Tag... 

2 Provide the new name in the edit box and select an appro-
priate style and colour for the display (this style is not 
used for printing!); Set! The condition is now listed in the 
«Not In: column».

Conditional text to be included

Type of reader std_user operator system beginner

Beginners not in not in not in in

Standard user in not in not in not in

Operator in in not in not in

System programmer in not in in not in
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Display the current 
condition of a text

1 Place the cursor in the appropriate text

2 Special > Conditional Text... displays the dialogue Condi-
tional text. This dialogue can stay open during work.

3 The radio button in Current Selection Is says whether the 
text is unconditional or conditional. The lists display the 
applicable conditions:

In The current selection is in this condition

Not in The current selection is not in these conditions

As is The current selection contains both text which is in 
a condition and text which is not.

Apply a condition To apply conditions you will need to define the condition tags 
and the appearance of the conditioned text:

1 Select the text which will receive the condition (for example 
«comment»)

2 Special > Conditional Text… If you do not see the desired 
condition tag in the «Not in:» column, you must first set up 
this tag (see Define a new condition on page 5).

3 Set the current selection to Conditional (radio button) and 
move the desired condition to the left column («In:») and 
press Apply!

Delete conditions 1 Select the text you want to make unconditional

2 Select Special > Conditional Text

3 Activate the Unconditional radio button

4 Click Apply.

Copying conditions You can use Copy Special > Conditional Text Settings and 
apply the condition(s) to a target selection by Paste.

Display the conditional text

Hidden conditional text is represented by a maker symbol (). 
At the beginning of a line the left portion of the T-arm is 
invisible (truncated by the boundary of the text frame).

Note: If you delete a Conditional Text Marker you actually delete the 
conditional text!

To display (and print) text with and/or without any condition, 
the following steps are required:

1 In Special > Conditional Text... click button Show/Hide.

2 To display (and print) everything, activate the radio button 
Show All.

3 To display (and print) only certain condition texts,

- move the conditions into the appropriate column (Show 
or Hide).

- Activate radio button Show 

4 Set!

Note: You may move all tags at once with SHIFT+click on an arrow.
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Text insets
Text insets are pieces of text imported by reference. These can 
be

Sources of text insets A file processed by import filters (original ASCII text, MS-
Word doc etc.)

A text flow from a FrameMaker document, which may be 
the current document (see example below). In most cases 
the complete file (the complete flow A) is imported. 

A text flow from a FrameMaker document which is in MIF 
format.

Text insets can be arranged in a single file in different flows. 
The flows may be located in reference pages and can have mem-
orable names, for example warning_highvoltage, 
warning_hotwater. In file text_inset.fm a flow A provides an 
introduction and flow warn_1 is short flow with boiler plate 
text.

Import text flow from a Frame document

As an example, we import hereafter the text flow 
chapt_overview from current document’s reference pages:

1 File > Import > FIle…

2 Specify the proper file name (specials.fm) in the File selec-
tion dialogue, Import!

3 The imported file is a FrameMaker file, hence you get the 
dialogue displayed to the left. Select the proper text flow 
and specify «Retain Source’s Formatting»; Import!

The imported text is placed at the current cursor location (in 
this case, below the current paragraph). The paragraph for-
mat of the insert is derived from the first paragraph format in 
the inset (here: chapt_overview.

Avoid re-formatting

When importing a text inset at the end of a paragraph, that 
paragraph gets the format of the first paragraph in the inset.

Importing a text inset in front of a paragraph does not re-for-
mat that paragraph).

When using empty ‘anchoring paragraphs’, insert a required 
blank prior to importing the text inset in front of that blank. 
You may wish to use a special format for the anchoring para-
graph (small size, …):

before importing 
place the insertion
point (cursor) here

¶

If you need to arrange text insets one after the other (modular 
texts) you may wish to define the ‘anchoring paragraph’ as 
Run-in-head which does not cause a line break at the end of 
the paragraph. Do not fill the Default Punctuation field with 
the non breaking space! This space must be in front.
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Text inset with variables and references

Text insets imported by reference have some properties, 
which must be considered when using them:

Referenced texts can not be edited (obviously...)

Formats (paragraph styles, table catalogue, character cata-
logue, cross-reference formats) stay local to the embedded 
document and are not added to the embedding document.

Variables from the inset are copied to the embedding docu-
ment and hence can be updated there (or the surrounding 
book).

Updating text insets

Whenever a FrameMaker document is opened references to 
other files (text inset, graphics) are updated. If this is not pos-
sible (for example, the file was moved or renamed), an error 
message is issued. Use Edit > Find and find «Unresolved Text 
Inset».

Update particular text 
inset

To update a particular text inset,

1 Double click into the text (this is selected and a dialogue 
appears).

2 In Text Inset Properties click on Update Now.

3 If the inset can not be updated (moved, renamed) an error 
message gives you a chance to search it yourself).

Update all references in 
file

To update all text insets of the current file,

1 Edit > Update References...

2 Activate the appropriate check boxes. 

3 Update!

Update everything in a 
book

To update all references in a book, 

1 Open the book file

2 Update external references with File > Generate/Update…

The process may halt in a particular file with «unresolved 
xyz». this may be a cross-reference or an inset or a graphic 
file. In this case open that file and find the unresolved xyz.

If unresolved cross-references are in the master pages (for 
example, a reference to a paragraph-number) this can not be 
discovered easily. The book error log points only to the body 
pages. You need to display the master pages and search for 
the unresolved reference.

Note: As long as you have not cleared the problem, the generate/
update process will halt at the first error.
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Import examples

For the sake of demonstration the text insets are underlaid 
with a colour.

Note: Error in FrameMaker (in the following example): The variable 
Filename [Long] with the format <$fullfilename> which is 
used in the text inset is re-evaluated when the text is imported. 
Hence the path noted in the third line is the path of the current 
document - and not that of the inset!

Text inset from flow 
warn_1

This is a flow from file E:\FM-
course\handout_70\specials.fm. 

The text inset is inserted at the beginning of this line

Inset from text flow A This file (E:\FM-course\handout_70\specials.fm) is used as 
an example of import by reference in various situations. Para-
graph styles are the same as in the main document with the 
exception of z_text-inset, which uses a script font for easy 
recognition.

Variable in the imbedded text. Lets see whats going on with 
a cross reference to another chapter in this book: Teamwork 
on page B-9. Please note the special format which is local to 
this text inset.

Here comes arbitrary text 
using various styles - just 
to see what happens with 
it

Hecate est Iovis et Latonae filia, soror Apollinis. Est trico-
por et triceps, magicarum artium

vel prope sepulcra et ubi loca sunt caedibus contaminata.

Note: Hecate est Iovis et Latonae filia, soror Apollinis. Cinctra latran-
tium canum turma; noctu stans in triviis vel prope sepulcra et 
ubi loca sunt caedibus contaminata.

Hecate est Iovis et Latonae filia, soror Apollinis. Est tricopor et triceps, 
magicarum artium magistra ac fascinationum praeses, 

Hecate est Iovis et Latonae filia, soror Apollinis. Est tricopor 
et triceps, magicarum praeses.This is the last line of the text 
inset.

The text inset is inserted at the beginning of this line

Danger du 
mort

ACHTUNG! ALLES LOOKENSPEEPERS!

Das computermachine ist nicht fuer gefingerpoken und mit-
tengrabben. Ist easy snappen der springenwerk, blowenfusen 
und poppencorken mit spitzensparken. Ist nicht fuer gwerken 
bei das dumpkopfen. Das rubbernecken sictseeren keepen das 
cotten-pickenen hans in das pockets muss; relaxen und 
watchen das blinkenlichten.

Relaxen und vatchen blinkenlichten!!!
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Hints and tips

Overview

This chapter provides some hints to speed up your 
work. 

Section FAQ gives you tips which result from the 
daily work with FrameMaker. For experts they may 
seem obvious, but not so for beginners.

For a complete list of all FrameMaker 6 commands 
(both for the German and English FrameMaker) see 
www.daube.ch/docu/fmaker08.html
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Keyboard input

Short-cuts
Any FrameMaker function can be invoked from the keyboard. 
ESC sequences (for example, ESC, o, F) are independent of plat-
form, but depend on the User Interface (UI) language. Short-
cuts using special keys depend on platform and (often) UI.

Purpose English FrameMaker version (Win) Deutsche FrameMaker version (Win)

Format paragraph a)  F9, para_stylename, RET F9, para_stylename, RET

Format characters a.) F8, char_stylename, RET F8, char_stylename, RET

Select graphic object CTRL+click on object CTRL+click on object

Select 1st / next drawn object ESC, o, F ESC, o, F

Select next drawn object ESC, o, n ESC, o, n

Keep graphic tool SHIFT+click the tool SHIFT+click the tool

Properties of selected / current object ALT+g, p ALT+g, o

Open Paragraph designer CTRL+m CTRL+m

Open Character designer CTRL+d CTRL+d

Open Table designer CTRL+t CTRL+t

Repeat last character modification ESC, c, c ESC, z, w

Repeat last paragraph modification ESC, j, j ESC, A, W

Straight single quote ESC, CTRL+'

Straight double quote ESC, " (SHIFT+2)

•(bullet) appearance strongly depends! CTRL+q, % / ALT 0149 CTRL+q, % / ALT 0149

† (dagger) CTRL+q, SPACE CTRL+q, SPACE

‡ (double dagger) CTRL+q, ‘ (grave accent) CTRL+q, ‘ (grave accent)

™ (trade mark) CTRL+q,, * CTRL+q, *

© (copyright) CTRL+q, ) CTRL+q,)

® (registered) CTRL+q, ( CTRL+q, (

¶ (paragraph symbol) CTRL+q, & CTRL+q, &

§ (section symbol) CTRL+q, $ CTRL+q, $

… (ellipsis) CTRL+q, I (uppercase i) CTRL+q, I (uppercase i)

— m-dash CTRL+q, Q / ALT 0151 CTRL+q, Q / ALT 0151

– n-dash CTRL+q, P / ALT 0150 CTRL+q, P / ALT 0150

  m-space ESC, blank, m / SHIFT+CTRL+blank ESC, s, m / SHIFT+CTRL+leerstelle

  n-space (m/2) ESC, blank, n / ALT+CTRL+blank ESC, s, n / ALT+CTRL+leer

 thin space (m/12) ESC, blank, t ESC, s, t

numeric space ESC, ,1 ESC, , 1

  non breaking space (m/3.5) ESC, blank, h / CTRL+blank ESC, s, z / CTRL+leerstelle

nonbreakable hyphen ESC, -, h ESC, -, w 

optional hyphen ESC,-, D / CTRL+minus ESC, -, t / CTRL+minus

suppress hyphenation ESC,n,s (front of word) ESC, k, t (am wort-anfang)

TAB in table cell ESC, TAB ESC, TAB

Select entire table triple click in any cell triple click in any cell

Select table column Double click close to  R/L border of cell Double click close to  R/L border of cell

Select table row Double click in the middle of a cell Double click in the middle of a cell

Add row after current row in table CTRL+RET CTRL+RET

Go to anchor position (behind anchor) ESC, t, SHIFT+i (cursor to be in table) ESC, t, w (cursor in tabelle)
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Special characters in dialogue boxes

Some of the most used special characters can be entered into 
dialogue boxes with a meta notation \xxx (the \ ‘escapes’ 
from the literal meaning of the character). These meta-nota-
tions are independent of the UI language and platform.

Insert variable name a.) ESC, q, v, name, RET 
CTRL+0, name, RET

ESC, k, v, name, RET
CTRL+0, name, RET

Refresh display CTRL+l (lower case L) CTRL+l (lower case L)

Hyperjump from references ALT+CTRL+click on the reference ALT+CTRL+click on the reference

Previous view (goback) in same file ESC, v, P ESC, v, v

Pick up graphic properties ESC, g, O (upper case letter o) ESC, g, O (upper cas letter o)

Lock / unlock document (view / edit) ESC, F, l (lower case L), k ESC, d, Y

Heroic open b) ESC o, H ESC o, H

Open without updating references CTRL+click on the Open button in the Open dialogue

a. Name can be abbreviated to significant length

b. Another (empty) document must be open. This bypasses all sorts of checks to 'force' a file to open. Before 
any changes save the file and reopen it normally.

Purpose English FrameMaker version (Win) Deutsche FrameMaker version (Win)

Desired character Meta notation hex Desired character Meta notation hex

TAB \t \x08 per thousand (‰) \%

forced return \r \x09 guillemet single left (‹) \(

start of paragraph \P guillemet single right (›) \)

end of paragraph \p \0a quote base single (‚) \, (comma)

start of word \< quote base double („) \g

end of word \> quote double left 66 (“) \‘ (grave) \xd2

end of flow / end of table cell \f a) \x0b quote double right 99 (”) \’ (single q.) \xd3

non breaking hyphen \+ quote single (’) \" (double q.) \x27

optional hyphen \- \x04 accent circumflex (ˆ) \@

suppress hyphenation \_ (underscore)\x05 accent grave (`) \{

backslash \\ accent tilde (˜) \~

non breaking space \ (space) \x11 hungarian umlaut (� ) \&

numeric space \s# or \# \x10 registered (®) \xa8

thin space \st or \i \x12 copyright (©) \xa9

n-space \sn or \N \x13 trademark (™) \TM \xaa

m-space \sm or \M \x14 ligature fi \fi only on Mac

n-dash \= \xd0 ligature fl \fl only on Mac

m-dash \m \xd1 micro sign (μ) \u only on Mac

bullet (•) \b \xa5 ligature Œ \OE

dagger (†) \d \xa0 ligature œ \oe

double dagger (‡) \D \xe0 ß (sharp s) \xa7 or ALT+0223

ellipsis (…) \e \xc9 Y-trema (Ÿ) \Y:

florin (ƒ) \F z-caron (ž) \k

fraction, non breaking slash (⁄) \/ (slash)b) \xda Z-caron (Ž) \.

a. \f does not work in Windows, \x0b finds the end-of-flow mark correctly

b. This is taken from the Symbol font, hence does normally not match the body font
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Wildcard-characters for Find dialogue

Use Wildcard must be set ON 

To find a $ or ^ while searching with Wild cards use \$ or \^

Example To find manually numbered paragraphs (start the line with a 
figure, followed by a period and a TAB symbol), use this pat-
tern: ^*[0-9].\t

Note: There are no wildcard notations for the replacement text.

Characters with diacritical marks etc.

For platform independence FrameMaker uses a special inter-
nal code table (see page 16). This defines a rich set of 
accented characters from the latin script. However, some 
characters even for European languages are missing (such as 

 or ) due to the limitations of an 8-bit coding and FM inter-
nal use of some code points.

Text entry A rich keyboard (e.g. the Swiss one) gives you direct access to 
all accented characters (except those with ring). These can be 
entered both in text and dialogue boxes by two methods:

Escape sequences Characters in rows 80 and 90 of the internal code page are 
created with esc sequences. For example, to get an Å type 
ESC, *, A (3 key strokes). See 

CTRL-q sequence Characters in rows a0 … f0 of the internal code page are cre-
ated with CTRL+q, followed by a character from the ASCII code 
page at a corresponding location (locascii = locfm - 80hex). For 
example, to get a Þ type CTRL+q, W (2 keys).

Select from context
menu

With microtype’s enhanced tool bar installed, you can select a 
great number of special symbols from the context menu. No 
foreign characters (such as Å) are provides though.

Entry into dialogue fields For characters not supported by the keyboard neither the 
CTR-q sequence nor the ESC sequences work. You need the 
hexadecimal value of the code point within the FrameMaker 
code. For example, to get an å into the entry field, type \x8c.

Matching a) 

a. Error in FrameMaker: The characters Ð, ð, Þ, þ, Š, š, Ý and ý are not 
recognises as such, but as punctuation when searching with wildcard 
characters * or ?.

Wild-card char.

Any number of characters * (asterisk)

Any one character ?

White space or punctuation | (vertical bar)

Start of line ^

End of line $

any character from list xyz (or alphanu-
meric)

[abcd] or [a-zA-Z0-9]

any character except the listed [^abcd]

brackets \[ and \]

Special characters such as TAB or m-dash See table above

http://www.microtype.com/
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Non-latin scripts

Non-latin scripts, such as cyrillic or greek or even arabic or 
hebrew are not supported directly by Framemaker. However 
special methods have been developed (with virtual fonts) 
which work on the NT based Windows platform. For Asian 
scripts (Chinese, Japanese) the Asian version of FrameMaker 
supports certain double-byte codes.

Symbols and dingbats

Symbols not belonging to an alphabet are collected in symbol 
fonts (for example: Wingdings, Symbol, Zapf Dingbats, 
Monotype Sorts, Mathematical PI).

The handling of these fonts bypasses the internal code page. 
Hence the entry method from the operating system can also 
be applied (copy/paste, ALT+0nnn):

Place symbol into text For example, you want to enter the symbol  into text. This 
symbol is found in the font Webdings 3 at the location of the 
character Ê, which has the code CA. Do the following:

1 Use your keyboard to enter the base character (Ê).

2 If not available on the keyboard, 

- use the CTRL-q sequence (CTRL-q, f), or
- the ESC sequence (none available in this case), or 
- copy the symbol from the character map (gets Ê), or
- enter it with ALT+0202 (  has Windows code CA = 202), 

gets Ê.

3 Apply the font property by character format (e.g. webbies) 
or font (Webdings 3).

Note: If you first define the font and then enter a character, you get 
different results, which are not correct.

Place symbol into 
dialogue box

Using symbols from other fonts (than the font of the text) is 
only possible in such dialogues which allow to define a char-
acter format: numbering of ¶, marker text, cross reference.

For example, to enter an  (located at code CA in the 
Wingdings 3 font) into an index marker: 

1 Use your keyboard to enter the base character (Ë).

2 If not available on the keyboard, use the alternative meth-
ods presented before for the base character or specify the 
FM code (\xe6).

3 Define the special font by a character format, e.g. webbies.

4 The index marker may now have this content:
changing <webbies>Ê</> finding and changing or
changing <webbies>\xe6</> finding and changing 

Keep in mind here, that the code \xe6 is that of the character 
Ê in the FrameMaker internal code page (see the following 
table).
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Table of characters and symbols
Although every effort was taken to get a complete and accu-
rate table, the author can not be held responsible for any 
errors.

This table contains 217 lines, hence all codes in a Windows 
character set are covered. For an interactive PDF table see 
Microtype 

PostScript font Zapf Dingbats has not been included, because 
the role of PS fonts (T1 type) has dwindled since 2000. 

Standard chars

char Ctrl+q 
or esc

\x
(hex)

Symbol D+DD Wing
dings

Wing-
dings2

Web
dings

A 41 Α 

a 61 α 

À K cb ⊄ 

à esc ‘ 
a

88  

Á g e7 ⎜ 

á esc ´ 
a

87  

Â e e5 ∑ 

â esc ^ 
a

89  

Ã L cc ⊂ 

ã esc ~ 
a

8b  

Ä esc : 
A

80   ☼

ä esc : 
a

8a  

Å esc *
A

81  

å esc *
a

8c  

Æ . ae → 

æ > be ⎯ 

b 62 β 

B 42 Β 

Note

The code in the third column 
(hex) is the hex code of the 
base character (leftmost col-
umn) in the FrameMaker 
internal code page.

This code is not identical to 
the code you get when con-
sulting the Windows Charac-
ter Map!

http://www.microtype.com/resources/MT_Charset.zip
http://www.microtype.com/resources/MT_Charset.zip
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C 43 Χ 

c 63 χ 

Ç esc ,
C

82  

ç esc ,
c

8d  

D 44 Δ 

d 64 δ 

Ð C c3 ℘ 

ð 2 b2 ″ 

E 45 Ε 

e 65 ε 

È i e9 ⎡ 

è esc ‘ 
e

8f  

É esc ´
E

83  

é esc ´
e

8e  

Ê f e6 ⎛ 

ê esc ^
e

90  

Ë h e8 ⎝ 

ë esc :
e

91  

F 46 Φ 

f 66 φ 

G 47 Γ 

g 67 γ 

H 48 Η 

Standard chars

char Ctrl+q 
or esc

\x
(hex)

Symbol D+DD Wing
dings

Wing-
dings2

Web
dings
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h 68 η 

I 49 Ι 

i 69 ι  0

Ì m ed ⎨ 

ì esc ‘
i

93  

Í j ea ⎢ 

í esc ´
i

92  

Î k eb ⎣ 

î esc ^
i

94  

Ï l ec ⎧ 

ï esc :
i

95  

J 4a ϑ  ☺

j 6a ϕ  1

K 4b Κ 

k 6b κ  2

L 4c Λ 

l 6c λ  3

M 4d Μ 

m 6d μ  4

N 4e Ν 

n 6e ν  5

Ñ esc ~
N

84  

ñ esc ~
n

96  

Standard chars

char Ctrl+q 
or esc

\x
(hex)

Symbol D+DD Wing
dings

Wing-
dings2

Web
dings
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O 4f Ο 

o 6f ο  6

Ò q f1 〉 

ò esc ‘
o

98  

Ó n ee ⎩ 

ó esc ´
o

97  

Ô o ef ⎪ 

ô esc ^ 
o

99  

Õ M cd ⊆ 

õ esc ~ 
o

9b  

ö esc :
o

9a  

Ö esc :
O

85  

Œ N ce ∈ 

œ O cf ∉ 

Ø / af ↓ 

ø ? bf ↵ 

P 50 Π 

p 70 π  7

Q 51 Θ 

q 71 θ  8

R 52 Ρ 

r 72 ρ  9

S 53 Σ 

Standard chars

char Ctrl+q 
or esc

\x
(hex)

Symbol D+DD Wing
dings

Wing-
dings2

Web
dings

Note

On a Swiss (and many other 
European) keyboard the tilde 
is an accent, hence you must 
type a character (e.g. blank) 
after it.

ESC, ~, o creates the same 
as ~, o
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s 73 σ 

ß
’

single 
quote

a7 ♣ 

Š 3 b3 ≥ 

š p f0  

Þ W d7 ⋅ 

þ J ca ⊇ 

T 54 Τ 

t 74 τ 

U 55 Υ 

u 75 υ 

Ù t f4 ⎮ 

ù esc ‘
u

9d  

Ú r f2 ∫ 

ú esc ´
u

9c  

Û s f3 ⌠ 

û esc ^
u

9e  

Ü esc :
U

86  

ü esc :
u

9f  

V 56 ς 

v 76 ϖ 

W 57 Ω 

w 77 ω 

Standard chars

char Ctrl+q 
or esc

\x
(hex)

Symbol D+DD Wing
dings

Wing-
dings2

Web
dings

Straight single quote

To get the straight single 
quote either «Smart Quotes» 
must be switched off in For-
mat > Document > Text 
Options... or you type
ESC, CTRL+' 
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X 58 Ξ 

x 78 ξ  ⌧

Y 59 Ψ 

y 79 ψ 

Ý E c5 ⊕ 

ý F c6 ∅ 

Ÿ Y d9 ∧ 

ÿ X d8 ¬ 

Z 5a Ζ 

z 7a ζ 

Ž z fa ⎥ 

ž ~ fe ⎭ 

0 30 0 

1 31 1 

2 32 2 

3 33 3 

4 34 4 

5 35 5 

6 36 6 

7 37 7 

8 38 8 

9 39 9 

! 21 ! 

Standard chars

char Ctrl+q 
or esc

\x
(hex)

Symbol D+DD Wing
dings

Wing-
dings2

Web
dings
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" esc " 22 ∀ 

# 23 # 

$ 24 ∃ 

% 25 % 

& 26 & 

'
ctrl+

single 
quote

27
\q ∋  ℡

( 28 ( 

) 29 ) 

* 2a ∗ 

+ 2b + 

, 2c , 

- 2d − 

. 2e . 

/ 2f /  /

: 3a : 

; 3b ; 

< 3c < 

= 3d = 

> 3e > 

? 3f ? 

@ 40 ≅ 

[ 5b [  ☯

\ 5c
\\ ∴  \

Standard chars

char Ctrl+q 
or esc

\x
(hex)

Symbol D+DD Wing
dings

Wing-
dings2

Web
dings

Straight double quote

To get the straight double 
quote either «Smart Quotes» 
must be switched off in For-
mat > Document > Text 
Options... or you type ESC, "

Straight single quote

To get the straight single 
quote either «Smart Quotes» 
must be switched off in For-
mat > Document > Text 
Options... or you type
ESC, CTRL+' 
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] 5d ] 

^ 5e ⊥ 

_ 5f _ 

`
grave

60
\Q ⎯ 

{ 7b { 

| 7c |  |

} 7d } 

~ 7e ∼ 

· a e1 〈 

¡ A c1 ℑ 

¿ @ c0 ℵ 

£ # a3 ≤ 

¥ 4 b4 × 

ƒ D c4 ⊗ 

¢ " a2 ′ 

¤ [ db ⇔ 

® ( a8 ♦ 

© ) a9 ♥ 

™ * aa ♠ 

¼ 9 b9 ≠ 

½ : ba ≡ 

¾ = bd ⏐ 

ª ; bb ≈ 

Standard chars

char Ctrl+q 
or esc

\x
(hex)

Symbol D+DD Wing
dings

Wing-
dings2

Web
dings

Grave

On a Swiss keyboard (and 
other European) this is an 
accent. Nevertheless you can 
not create it like a tilde.

CTRL+Q, CTRL+'creates `

Vertical bar

On a Swiss keyboard the key ¦ 
(ALTGR+7) must be used!

Example

To get an Aleph symbol (ℵ) 
into the text, enter CTRL+q, @ 
(two key strokes) and apply 
to the appearing ¿ a charac-
ter format which provides 
the Symbol font.
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º < bc … 

± 1 b1 ± 

× 0 b0 ° 

÷ V d6 √  ⌦

⁄ Z da ∨ 

μ 5 b5 ∝ 

¶ & a6 ƒ 

§ $ a4 ⁄ 

† blank
a0
\d  

¬ B c2 ℜ 

‰ d e4 ™ 

¹ 6 b6 ∂ 

² 7 b7 • 

³ 8 b8 ÷ 

¦ - ad ↑ 

° ! a1 ϒ 

• % a5 ∞ 

– P d0 ∠ 

— Q d1 ∇ 

… I c9 ⊃ 

¯ x f8 ⎠ 

ˆ v f6 ⎞ 

˜ w f7 ⎟ 

Standard chars

char Ctrl+q 
or esc

\x
(hex)

Symbol D+DD Wing
dings

Wing-
dings2

Web
dings

Broken vertical bar

On a Swiss keyboard the key | 
(ALTGR+1) must be used!
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Example To enter the symbol in text, type the | character and apply 
a character format which defines the font Wingdings

To get a list ‘numbered’ with the symbol, enter the 
sequence \xfc into the numbering field and apply a character 
format which defines the font Wingdings.

´ + ab ↔ 

¨ , ac ← 

° { fb ⎦ 

t́ } fd
\& ⎬ 

“ R d2 ® 

” S d3 © 

‘ T d4 ™ 

’ U d5 ∏  ⌫

„ c e3 © 

‚ b e2 ® 

‡ acc. 
grave

e0
\D ◊ 

¸ | fc ⎫ 

‹ \ dc ⇐ 

› ] dd ⇑ 

« G c7 ∩ 

» H c8 ∪ 

Standard chars

char Ctrl+q 
or esc

\x
(hex)

Symbol D+DD Wing
dings

Wing-
dings2

Web
dings

Double dagger

On a Swiss keyboard the 
grave character can not be 
entered directly into FM. A 
CTRL-Q sequence is needed:

CTRL+Q, ` creates ‡ You 
type the ` as ALTGR+`

Vertical bar (solid)

On a Swiss keyboard the bro-
ken vertical must be used 
(ALTGR+7).
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Internal code table 

The small character (sequences) below a row indicate the reference 
characters needed in ESC sequence or the CTRL-q sequence (see note). 

Use one of these methods for characters not on the keyboard:

Escape sequences Characters in rows 80 and 90 are created with esc sequences, 
e.g. to get a Å type ESC, *, A (3 key strokes).

CTRL-q sequence Characters in rows a0 … f0 are created by CTRL+q, followed by 
a character from the ASCII code page at a resp. location 
(locascii = locfm - 80hex); e.g. to get a Þ type CTRL+q, W (2 keys).

Characters require FrameMaker 7.2p158 and Win CE font.

These characters are available only on the Mac.

00 01 02 03 04 05 06 07 08 09 0a 0b 0c 0d 0e 0f

00
descr. 
hyph

suppr 
hyph

TAB NL
para 
end

flow 
end

10
num 

space
nonbr 
space

thin 
space

en 
space

em 
space

nonbr 
hyph

20 blank ! " # $ % & ’ ( ) * + , - . /
30 0 1 2 3 4 5 6 7 8 9 : ; < = > ?
40 @ A B C D E F G H I J K L M N O
50 P Q R S T U V W X Y Z [ \ ] ^ _
60 ‘ a b c d e f g h i j k l m n o
70 p q r s t u v w x y z { | } ~ DEL

80
Ä Å Ç É Ñ Ö Ü á à â ä ã å ç é è
: A * A , C ’ E ~ N : O : U ’ a ‘ a ^ a : a ~ a * a , c ’ e ‘ e

90
ê ë í ì î ï ñ ó ò ô ö õ ú ù û ü
^ e : e ’ i ‘ i ^ i : i ~ n ’ o ‘ o ^ o : o ~ o ’ u ‘ u ^ u : u

a0
† ° ¢ £ § • ¶ ß ® © ™ ´ ¨ ¦ Æ Ø

blank ! " # $ % & ’ ( ) * + , - . /

b0
× ± ð Š ¥ μ ¹ ² ³ ¼ ½ ª º ¾ æ ø
0 1 2 3 4 5 6 7 8 9 : ; < = > ?

c0
¿ ¡ ¬ Ð ƒ Ý ý « » … þ À Ã Õ Œ œ
@ A B C D E F G H I J K L M N O

d0
– — “ ” ‘ ’ ÷ Þ ÿ Ÿ ⁄ ¤ ‹ › Ź ff
P Q R S T U V W X Y Z [ \ ] ^ _

e0
‡ · ‚ „ ‰ Â Ê Á Ë È Í Î Ï Ì Ó Ô

‘ a b c d e f g h i j k l m n o

f0
š Ò Ú Û Ù € circum

flex
tilde macron breve Ž ring cedilla t’ ž undef

p q r s t u v w x y z { | } ~
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Note: Characters CTRL-q v … } are accents. For example CTRL-q v (ˆ) 
and ^ are different characters. The code table is based on Mac-
Roman.

Non-width characters

With View > Text Symbols active FrameMaker displays spe-
cial symbols such as anchors, optional hyphens etc. This dis-
play must not disturb the layout – hence these characters 
have no width.

No width characters can be stacked at a place – for example, 
anchoring several tables at the same place. This makes it very 
difficult, to select a distinct element, which is either the spe-
cial character itself (e.g. optional hyphen) or the anchored 
item. Even with 500% zoom factor you can not grab an indi-
vidual anchor.

Select a non-width 
character (or narrow 
characters)

1 Place the cursor behind the last recognisable character or 
the end of the paragraph (as in this diagram)

2 With the arrow left key move through the characters (in 
this case, before the closing parenthesis)

3 Hold down shift key while moving with the arrow left key 
over the anchor. This «extends the selection» (GUI term).

4 The anchored object becomes selected also. So you know, 
whether you have selected the right stuff...

If you didn’t catch the right thing, release the shift key, move 
back one character (in our case with the arrow right key) and 
repeat step 3 for any anchor which may be present left to the 
already found one.

Of course you can apply this procedure also from left to right.

This is any text with an anchor 
for the following table just here 
( )

TT ...(
T

)§
123 T

)§...(
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FrameMaker set up

General preferences

With File > Preferences > General you set the most used 
preferences:

Saving a file in FrameMaker does not take much time. Even for 
large files (200 pages) it is possible to automatically save 
every 10 minutes without significant delay of the work.

Automatic backup creates a backup file whenever you open 
the file. This file is over written at the next open. If you want 
to preserve versions, you need to rename the backups.

Sharing files in a network requires the option Network File 
Locking to be set. FrameMaker will create a file document.lck 
which existence is checked at open to prevent an additional 
open by an other user.

After selecting a different Product Interface (standard Fram-
eMaker or Structured FrameMaker) you need to restart the 
program.

Since FM 7.2 the warnings about clearing the Undo History 
can be specified.

Be aware of unavailable 
fonts

In the preferences dialogue you can set Remember Missing 
Font Names. Always set this option when you receive docu-
ments from other platforms.

Set this option also, if you receive a document for revision 
and need to give it back again. The font situation differs on 
most systems - even with the same operating system!

If a document contains fonts which are not available on the 
Windows platform and this option is not set then all unknown 
fonts are replaced by Times Roman and the information con-
cerning the original fonts used is lost.

Units of measure

When entering just a numeric value into an entry field in a 
dialogue, FrameMaker uses the default unit (which depends 
on purpose). Hence for clarity always enter also the unit.

www.cl.cam.ac.uk states:

The length of an inch 
changed from 1/0.3937 cm 
to 2.54 cm in 1959; the size 
of a point did not. Conse-
quently, the imperial 'size' of 
a point changed from 1/72 
inch to 1/72.27 inch. [Knuth 
1984, The TEXbook, p. 58]

DTP point = PostScript point. 
1 ATA pt (American Typefounders 
Association) = 0.013837". 
1 TEX pt = 1/72.27"

Unit Enter into 
dialogue

metric
Equivalent

Imperial 
equivalent

Definition

cm cm 10 mm 03937. inch

mm mm 0.1 cm 0.03937 inch

inch in, " 2.54 cm 1 inch USA, UK

pica pc, pi, pica 4.2175176 mm 1/6 inch 12 points (ATA)

DTP point pt, point 0.35278 mm 1/72 = 0.0139 " 1/72 US inch

Didot point dd 0.376 mm 1.07 pt 1/72 French inch

Cicero cc, cicero 4.531 mm 12.84 pt 12 Didot point

http://www.cl.cam.ac.uk/~mgk25/metric-typo/
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Platform specifics

Macintosh system 9

Windows handling

Quick access bar The quick access bar (button bar) is part of the document 
interface and hence only available with an open document

Palettes and non-modal
windows

Palettes (¶-catalogue, graphic tools etc.) and non-modal win-
dows (Find/Replace etc.) are not automatically kept on top of 
the displayed windows. To avoid frequent re-calling them, 
either install an appropriate system extension or reduce the 
document window width to allow grabbing the ancillary win-
dows at the right of the document window.

Keyboard input All entries using ESC sequences and CTR+q sequences are 
also valid on the Macintosh. The keyboard short cut using the 
modifier keys are different to those on Windows:

Operations and
typographic characters

Style name can be abbreviated to significant length

Special characters Some of these you might have forgotten how to type:

Appearance of check 
boxes

The «As Is» state occurs, if some of the selected items have 
set properties and some have not set (cleared) properties.

Key Meaning Key Meaning

 Shift  Option, sometimes called Alt

 Control  Command

Purpose Short cut Purpose Short cut

Format paragraph +9 — m-dash ++minus

Format characters +8 – n-dash +minus

Open Paragraph designer ++m n n m-space ++9

Open Character designer ++d n n n-space (m/2) ++8

Open Table designer ++t nn thin space (m/12) ++7

Repeat last character 
modification

+C numeric space ++0

Repeat last paragraph 
modification

+A n n non breaking space 
(m/3.5)

+blank

Straight single quote +’ optional hyphen +minus

Straight double quote +» suppress hyphenation ++minus

Refresh display +l (lower 
case L)

char keys char keys char keys

[ +5 ] +6 \ ++7

{ +8 } +9 @ +g

' +' " ++' # +3

checked
(active)

unchecked
(inactive)

As Is
(may be)

Appearance in Mac 
OS 9
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Unix (Sun Solaris)

Window handling Quick access bar, palettes and all non-modal windows are dis-
tinct windows and are not ‘integrated’ into the document win-
dow. For easy access reduce the document window width to 
allow grabbing the ancillary windows at the right of the docu-
ment window.

Appearance of check 
boxes

The «As Is» state occurs, if some of the selected items have 
set properties and some have not set (cleared) properties.

Keyboard specials The following relates to a Swiss-German keyboard only. I do 
not have experience with other keyboards on Sun Solaris.

There is no forward delete (deleting character to the right 
of the cursor) only the Backspace function exists.

A common keyboard layout includes function keys to the 
left of the typewriter layout:

Sole accents These can not be entered by using the compose + accent key 
followed by a blank (as on Windows and Mac). This method 
allows only to construct accented characters from the ISO 
Latin 1 set (e.g. ã ñ). To create accent characters of their own, 
do the following:

Tilde press ALTGR + 5

Circumflex press ALTGR + 4

Grave press ALTGR + 0 12)

Aigu press ALTGR + ? (key right to the 0)

Closing bracket The character ] can not be entered from the keyboard. It 
needs to be created in a text editor and then pasted to FM.

Degree symbol The degree symbol is very unruly when entered with the top 
left key. In some fonts it does not show up; in others it 
appears an infinity symbol (∞). When entered into a dialogue 
field it results in \xb0. Using CTRL+Q, ! results in \xb1. You 
need to copy this symbol from a text editor or Word …

checked
(active)

unchecked
(inactive)

As Is
(may be)

UNIX Solaris KDE

12 On the systems I had available this created an aigu accent (´) in text, but 
a correct grave accent (‘) in dialogue fields.
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Unix (Sun Solaris)


E
:\

FM
-c

o
u

rs
e
\h

a
n

d
o

u
t_

7
0

\t
ip

s.
fm

 
2

0
0

7
-0

6
-2

2

Copy and paste To handle all situations (including copy/paste from other 
applications), different methods are necessary.

Within FrameMaker text The left key group contains Again, Undo, Copy, Paste and 
Cut. Within FrameMaker these keys must be used – if you do 
not like to use the ESC sequences (for example ESC, e, c for 
copy) or menu entries.

This method can not be used to transfer data from the docu-
ment into a dialogue field.

Into FrameMaker
dialogues and

across applications

To transfer data from the FM document text into a FM dia-
logue field the X-windows buffer must be used. The same is 
true for transferring data between FM and another applica-
tions.

The X-buffer is automatically filled if text is selected. It is 
pasted into a new location by the middle mouse button:

1 Select the text to be copied with the left mouse. Get a word 
including the trailing space by double click or a paragraph 
by triple click.

2 Paste the buffer contents at the new location by placing the 
cursor and middle click.

Hyperlinks Hypertext (e.g. a cross-reference) is activated by CTRL-right-
click. Under some circumstances (e.g. X-Window client is an 
emulation on Windows) an additional read-only document is 
created and jumped into this.

In case of URLs (web link, e-mail) nothing may happen, 
because no connection to a browser or e-mail client may be 
established.

Keyboard macros Unix allows to create keyboard macros via menu File > Utili-
ties > Macro. It is good practice to invoke macros with a spe-
cial key such as the meta key ( ), located on both sides of 
the space bar:

For example, to open the ¶ designer: press  + F5. Or to copy 
a paragraph format press  + 0.

Code of macro Copy
Paragraph Format

Copy para format (meta null):
   <Macro Macro10
       <Label Macro10>
       <Trigger ~0>
       <TriggerLabel ~0>
       <Definition \!bf>
       <Mode NonMath>>

Macros can not contain symbolic entries. It is quite difficult 
also to handle dialog input.

Macros can not … Wait for keyboard input in a dialogue and then continue 
the macro. You will need to set up two macros.

Record mouse actions

Record F10 (put focus on menu bar)

Record F4 (display context menu)

u...
kein seiten- spalten- Masterpage  

zuordnung
¶ f T default f  

format
e-mail URL

Umbruch Designer Hyperlinks

Set Zoom ä 95% ä 180% Camera highl. marker Copy ¶ fmt
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Macro with
dialogue input

1 Start recording. Use only keyboard input for the actions to 
be recorded.

2 When at the dialogue, press CTRL+TAB to get to the first 
entry. This start is essential.

3 Enter the first value in the first field and jump to the next 
field with TAB or SHIFT+TAB to jump back.

4 Fill all fields, also those which already contain the desired 
values. Use the UP/DOWN arrow keys to navigate in scroll 
lists.

5 Enter RETURN to close the dialogue and get the values

6 Stop the macro and save it with appropriate name and trig-
ger.

Stop macro at
dialogue 13)

To create a macro which stops at a dialogue to enter values 
manually, enter CTRL+] when the dialogue appears in the 
recording. Then save the macro.

In the running macro (which stops at the open dialogue) enter 
the values, then press CTRL+].

Macro with repeated
actions

1 Record the actions to be repeated in a macro A

2 Set up a second macro B, in which macro A is invoked as 
often as necessary.

Location of macros Macros are located in a text file in the current account, for 
example at /home/afs99/fmMacros. The name must be 
fmMacros.

13 Procedure not rally clear - need to verify at LuStat
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Solving real and assumed problems
See also hints and tips on the web: www.daube.ch/docu/
fmaker00.html

Method to find the cause 
of problems

The general method to encircle problems is to bisect the doc-
ument and check each halve.

By further narrowing down to one page and then to para-
graphs, tables, graphics etc. you can find the culprit.

General problems

Warning: only one Undo 
level until version 7.1

Until version 7.1 FrameMaker has only one undo level. Hence 
save the file before you start any experiments or are not cer-
tain about the usefulness of a specific manipulation! From my 
long lasting experience with FrameMaker I can tell You that 
there is no reason to bemoan this situation. After some time 
of familiarity with FrameMaker You don’t need much undo.

Since version 7.2 FrameMaker provides multiple undo. How-
ever there are still operations which can not be undone and 
which therefore clear the undo-history. See this Adobe document 
for details of the function.

Strange behaviour of 
document

There are situations where FrameMaker seems to have lost all 
its ‘sense’. What’s going on?

FrameMaker relies on the Windows system services for stor-
age management, and these are not very water tight. Hence 
you may get situations which are the result of lost pointers or 
other garbage in storage.

Most of these situations can be fixed with the following:

Save the file in MIF

Close the document (do not save it)

Open the MIF file

Save the file again as FrameMaker (you may wish to use a 
different name to the original one).

In most cases the file now behaves ‘normal’ again.

Can not copy/paste text Text selected from a text line (produced with graphic tool A) 
can be copied to the clipboard, however:

it can only be pasted into a text frame (like this one);

it can not be pasted into dialogue boxes;

it can not be pasted into another application.

Find does not find You may need to switch to the masterpages or the reference 
pages to find the requested item. You can not search within 
text inserts - they are independent files.

See also Can not find words on page A-27

http://www.daube.ch/docu/fmaker00.html
http://www.daube.ch/docu/fmaker00.html
http://www.adobe.com/support/techdocs/331774.html
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Display and layout issues

Display jumps back when 
scrolling

This is a known bug since version 4 at least. The problem is 
caused by graphics with property «run around» which 
touches or overlaps a text frame (which may be on a master 
page).

Solution according to
Adobe KNB document

322405

1 FrameMaker 6.0 should have cleared this problem.

2 Locate the graphic that triggers the jump and

Adjust the adjacent text frame to remove the overlap / 
touching; or remove the run-around property from the 
graphic (if applicable).

3 Terminate the behaviour for the current FM session:

- Click outside any text frame and scroll through the com-
plete document.

- After any close / re-open or File > Revert to Save, this 
procedure must be repeated.

General solution Install the free plug-in RunaroundNone 
(www.frameexpert.com)

EPS looks awful on 
screen

An eps may contain a preview image, which is displayed on 
the screen. The resolution of this preview image can be set in 
most graphic applications. If not, a default of 72 dpi (dots to 
the inch) is used. Compare the two screen images:

If you need to position graphic elements (arrows, pointers) 
precisely or to get an idea of small print on an imported eps, 
you need to create it with a good preview picture. Just zoom-
ing into the image in FrameMaker does not do the job.

EPS prints, but on screen 
is only gray area

The cause is trivial: the eps does not contain a preview image. 
If you need to overlay some information on such an image, 
you do not have a clue where to place things. Hence you need 
to recreate the eps with a preview image.

If the source image and/or application not available, these 
steps may help you:

1 Print the page with the image to a PostScript file

2 Make a PDF from the page using Acrobat Distiller

3 Crop the page in Acrobat to the size of the image and 
export as eps with preview.

4 Import the eps to FrameMaker

72 dpi preview

300 dpi preview

http://www.frameexpert.com/
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Destroyed file contents? After some work (e.g. delete rows in tables, heavy editing of 
text) your screen may look very strange:

line thicknesses are wrong

lines are lost

text lines are intermingled

graphics are incomplete

etc.

Don’t panic, force a screen refresh either with CTRL+l (lower 
case L) or PageUp, then PageDown or other scrolling and do 
not forget to enlarge the image (the line may simply ‘fall 
between the pixels’ as in the depicted case).

Text can not be selected

You can not select text, as long as the cursor has the shape of 
a hollow arrow. Wherever you click with this cursor, the 
object (text frame) is selected (you see the handles of the 
object) - not the contents (the text).

Check the tools palette for the cursor setting. It will look as 
displayed in the image. 

You must select the ‘intelligent’ type of cursor (left button 
with the two cursor shapes on it).

Paragraph can not be 
removed or changed

After deletion of text insets you may have a paragraph, e.g. at 
the end of a chapter, that can not be removed, its format 
changed or otherwise manipulated.

Save the file as MIF, open MIF in a good text editor.

Search for <PgfLocked Yes> and assure the correct para-
graph by checking the text around it.

Delete the MIF line and save the MIF, re-open in FM.

Line not
visible

Artefact of
re-formatting



Solving real and assumed problems

A – 26

Ghost objects

Real duplicates You can access any object (e.g. a text frame) with CTRL+click. 
But you create a duplicate with CTRL+drag...

The current (selected) object is the duplicate which you can 
delete. It is also possible to undo the duplication operation.

Additional table
headers

Another type of ghost object is an additional table header on 
subsequent table pages

Try to cure this
situation by

Switching to the master pages, to look whether there is 
something wrong.

Switching back to the body pages with Remove Overrides 
activated.

Concealed objects Sometimes you can just see the black handles during the 
build-up of the screen. They are invisible when the screen is 
complete

If you suspect invisible
objects,

Start a selection rectangle outside the text frame and sweep 
the suspected area.

This will select the hidden objects (if there are any).

Bring them to the foreground with Graphics > Bring to 
Front

The original heading row Original heading row

This is something you can not get rid of, but you can not select it!

The first table cell the second table cell

and the next table cell the fourth table cell

the last line in the table the last cell in the table

Cursor opening the selection area

text
frame
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Where is the text? You have just imported a large text into a text frame, but the 
frame does not contain all the text.

A thin solid line at the bottom of the text frame indicates that 
there is more text then the frame can hold.

Enlarge the text frame or arrange for a connected text frame 
with the same text flow name.

Can not see facing pages You have reduced the zoom factor to a value with which 
pages could be arrange face to face (for example, to check the 
layout), but they do not:

The view of a document is saved in the file, hence you can 
have a different view on each open document. 

In View > Options… select Variable for Page Scrolling to get 
the display of facing pages.

Can not find words Searching for a sequence of words may not yield any result, if 
the text is interspersed with markers. In this example, the 
search reports ‘not found’:

What you see

This is, what you want to 
see.

You may need a low zoom 
factor if rotated pages are 
in the document.
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To avoid such situations:

Place cross reference markers at the beginning of a para-
graph.

Insert index markers at the end of a paragraph and com-
bine multiple entries into one marker.

Optional (discretionary) 
hyphen not working

You may see ample space at the end of a line and try to split 
the first word in the next line – but the word is not hyphen-
ated…

You have just hit a WYSIWYG problem: with standard installa-
tion FrameMaker displays fonts with font metrics for opti-
mised presentation of shape – but what we need is optimised 
placement similar to the placement of text in the printed 
page. See Display character positions correctly on page 37 for a 
suggestion.

Right tab not working When setting up text frames the inside text may not behave as 
expected. For example, a right tab might not be executed:

Reason Watch out for a graphic close to the text frame. The graphic 
may have the (default) run-around property „Run around Con-
tour« with a gap value > 0.

As soon as this kind of graphic is closer to the text frame 
than the gap value (or the graphic overlaps the text frame), 
the graphic will push text away.

Correction Remove any overlap or influence of the graphic by

placing the graphic far away from the text frame (distance 
> gap value), or 

setting the run-around property of the graphic to „Don’t 
run around«, or

Allowing „Run around Contour«, but setting the gap value 
to zero.

DisplayUsingPrinterMetrics=Off DisplayUsingPrinterMetrics=On

logo or other graphic too close to text frame

right tab position not reached in text frame
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Table does not split at 
desired row

A table can not split automatically at a certain row, if

vertically straddled cells hold rows together. Look at all 
columns to find overlaps of vertically straddles cells.

the table attribute «start on next page» forces a table start.

the attribute «float» keeps the first page together

Rows are kept together with «keep with next» or «keep 
with previous».

Example for vertically
straddled cells

The bordered frame is the text frame simulating 2 pages con-
taining the table

Table width and columns 
widths are wrong

Some of the FrameMaker dialogues provide too short entry 
fields. Table > Resize Columns may not display all figures in 
an entry field. Only the right most figures are displayed!

To select a value, do not sweep with the mouse over the figures - 
you might not get all the figures! Instead, double click on the 
figures to select all of them - also the hidden ones.

The real value of the
selected figures may be

318.0 cm

For a solution of this
problem see http://

www.daube.ch/public_html/
docu/fmaker20.html and

fmaker36.html

Watch the vertically straddled 
cells which block table rows.

The heading of the table

Vertically 
straddled 
cells

Vertically 
straddled 
cells over-
lap those 
in column 
2

The heading of the table

page x page x+1

http://www.daube.ch/public_html/docu/fmaker20.html
http://www.daube.ch/public_html/docu/fmaker20.html
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Importing and graphics

Problems with imported 
graphics

Vendors of graphic software tend to modify ‘standard’ output 
formats, which are needed to exchange graphics between 
applications (DXF, EPS, TIFF, WMF, etc.).

If you encounter problems with a FrameMaker document after 
importing a graphic, at first blame the graphic or its creating 
application. To fix the problem:

Import the graphic to another application - does it create 
problems also there?

Try to get another version of the graphic.

Imported graphic is not 
visible

If you import a graphic and it is not visible in the container 
(page, anchored frame, graphic frame), you may just see a 
white portion of it:

1 Select the container frame and with CTRL+a select all its 
contents. You will not see the object handles inside the 
now unselected container.

2 If there is really no graphic in the container, all graphic 
menu items (or buttons) are greyed out. You will re-import 
the graphic.

3 Group the invisible selection just in case more than one 
object is in the container.

4 Scale this contents down very much and Align Tops and L/
R Centers it in the container.

5 Now you should see the complete graphic, at least very 
small. Grab a corner handle and enlarge the graphic to the 
size of the container:

6 Now you may see what (might have) happened:

In most cases a small object is included in the complete 
graphic – especially if an eps was created from a CAD drawing 
not all surrounding stuff might have been removed.

The small objects may even be far out of the paper on the 
pasteboard of the drawing application (e.g. Illustrator). To 
avoid this error, you should not select all before creating 
the eps, but select only the desired items and then create the 
eps.

Full path of inserted 
graphics

The object property dialogue does not display the full path of 
an imported object, if the path name is too long:

G:\VeryLongFilenames\Level02\...\TheImage.png
E:\VeryLongFilenames\L...03\Level04\TheImage.png
..\..\Samples\Glossary...s\Graphics\TheImage.png 

The graphic you are looking for

What is this ?

At import this area was visible
The size of the imported object
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Relative paths are used only up to a certain level of directo-
ries. I have not yet found out what this level is. In the above 
examples the path for the document containing the image is 
E:\FM-specials\Tips\GraphicsFiguresEps\Path-of-

graphics.fm 

Method one Find out the full path name by 're-importing' - just opening 
the import dialogue for the selected image. In the Import dia-
logue expand the Look in drop down list to see the full direc-
tory hierarchy. 

Method two If you have the extended Send to function implemented in 
Windows, you may get the full path with the Send To Clip-
board function on the selected file:

G:\VeryLongFilenames\Level02\Level03\Level04\Level05\Le
vel06\Level07\Level08\Level09\Level10\TheImage.png

If you don't find this useful tool anymore on the MS-site, here 
is a copy of W95powertoy.zip. Unzip and right-click on 
SENDTOX.INF and select Install. It works fine in Win NT4, W2K 
and XP (although MS negates this).

http://www.microsoft.com/windows95/downloads/contents/WUToys/W95PwrToysSet/Default.asp
http://www.daube.ch/share/files/W95powertoy.zip
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Colour issues

Inconsistent colour One of the most pertinent errors is the inconsistent definition 
of colour in files. You can not get rid of this without major 
work:

Import colour from
correct document

1 Open a document from which you know that the colours 
are OK

2 Open the document with incorrect colour definitions.

3 Import only the colour definitions (File > Import > For-
mats…) from the clean source document.

4 This import is cumulative, that is, special colours in the 
target document are not removed.

5 If the problem persists when updating the book with the 
file in question, an imported graphic may be the culprit. 

Start with an empty
document

1 Set up an empty file with File > New > Document > Por-
trait

2 Delete all entries in the catalogues (paragraph, character), 
the table designer, the cross-reference formats.

3 Import the desired formats from the file with the colour 
error - but do not import the colour specifications!

4 If you really have a special colour set up, do it again.

5 Select the text in the file with the error and paste it into the 
new file. You may use Select All (CTRL+A) to get every-
thing.

Note: In many cases, however, this method import the error with the 
selected text (and graphics included etc.)

Just live the annoyance Ignoring the problem is only possible if you do not intend to 
take this document to a commercial printer!

Imported graphics Imported graphics can be the source of invalid colour defini-
tions. To find the graphic which causes the problem,

Remove one by one of the graphics and check for the prob-
lem. As soon the problem disappears, you have found the 
graphic in error.

The colour definition in the erroneous graphic can only be 
handled in the application in which the graphic was cre-
ated.

If the problematic graphic is an eps (Encapsulated Post-
Script), a TIFF or JPEG the original application can not be 
determined by the graphic type. Only Your intelligence can 
help here …

Huge number of colours You may notice a huge number of colours in your colour cata-
logue after importing graphics of format png (portable net-
work graphic). These colours are named RGB nnn,nnn,nnn. 
You should not delete these, but also not apply to any 
objects, since these colours may get lost when the file is 
saved as MIF (see www.microtype.com).

Note: You get these colours only for 256-colour (8-bit) PNG files. 
Hence use also for screen dumps PNG with ’millions of colours’.

http://www.microtype.com/resources/bugs/Colors_Lost_in_MIF.html
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Font issues

Font xxx missing See also Be aware of unavailable fonts on page 18

When opening a file, the following error message may occur:

Document named abc uses unavailable fonts.
To reformat the document using available fonts, click OK

In the FrameMaker console window you see what has been 
found and substituted:

The "Gugus" Font is not available.
"Times-Roman" will be used in this session.

Note: If you can not get rid of the unavailable font by these meas-
ures, the font may be used in an imported graphic or an empty 
document. See hereafter for methods to find these occurrences.

Where is the unavailable 
font used?

Make a copy of your document before you start your research!

Use the Edit > Find/Change dialogue to search for a Char-
acter Format. In the character definitions dialogue set all 
but the font family name to as is.
Search the body pages, the master pages and the reference 
pages for the font and correct any use of it.

The font in question may be used in imported graphics 
(also in an eps). You need the original application to 
change the font. In an eps file you can at least search with 
an ordinary text editor - but do not modify the font name 
just in the editor! Recreate the eps file in case.

The font in question may be used in empty text lines of 
FrameMaker graphics. Text lines are created with the A-
tool. To find these, 
do for each anchored frame with a graphic:

- Select the anchored frame, then select all objects with 
CTRL+A.

- If you get grouped objects, ungroup them until ungroup 
is not possible anymore.

- Check for empty objects and deselect them by holding 
the shift-key while you click on such an object.

- Group everything which is left selected

Situation Action 

The unknown fonts are important and they must not be substituted per-
manently by the FrameMaker default Times.

Cancel

Activate File > Preferences > Remember missing Font 
names. Now open the file again (you get the same message).

OK

The unavailable font is not essential or just a variation of Times. OK

Whether the substitution is permanent or just in this session, depend on 
the setting of File > Preferences > Remember missing Font 
names

You want to get rid of the unavailable fonts in the document Cancel

Activate File > Preferences > Remember missing Font 
names. Now open the file again (you get the same message).

OK

Save the file; Deactivate File > Preferences > Remember 
missing Font names
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- Select all again, deselect the grouped object. Only the 
empty objects are selected now. Delete them.

Note: A FrameScript script is available from Carmen Publishing for 
deleting empty graphic lines. This requires FrameScript form 
Finite Matters to be installed in your FrameMaker. See Exten-
sions by API clients on page 1-15 for these resources.
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Printing and presentation issues

Misalignment between 
text and graphics

Sometimes graphic elements are needed as an overlay to the 
text on the page (The U shaped line in the example below).

To place the graphic correctly you will use a large zoom level. 
However, the printed version may still be different and not 
accurate.

To avoid this effect, change the maker.ini file according to 
Display character positions correctly on page 37.

Accents not displayed in 
running header

Reason The running header is overlapped by another graphic element 
– in this case with the top text frame of the first header line. 
In the figure below the text frames are visualised with a bor-
der. 

Correction Remove the overlap of the text frame, for example by replac-
ing the two text frames by one of proper height containing 
both header lines. The separating line must be moved to front.

EPS prints badly If an eps looks pixeled (check with slanted lines) in the 
printed output, the reason might be:

inadequate printer driver (or wrong PPD for PS-printer)

non-PostScript printer

Messsystem Promag 53 (Kompakt-Ausführung)

Promag 53***-***********x
G = Foundation Fielbus, EEx i
K = Foundation Fielbus

top of frame 1

bottom of frame 2

overlap

line
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Recommended modifications to FM

Set reasonable default for your work

Zoom factors To get reasonable zoom factors in your session, adapt the 
zoom factors to the screen size and resolution. The following 
is for an 20" display. In section [Preferences] 

set to Zoom=28, 36, 50, 74, 90, 125, 200, 353, 500, 1000

When zoomed to 353% a nudge (moving an object by 
ALT+arrow key or ) moves by 0.1mm steps 14).

Dash patterns The following setting provide finer patterns than the FM 
default settings. In section [DashPatterns] 

set 1=Dash, 8, 4
2=Hidden, 4
3=Longdash, 16, 8
4=Dot, 2, 4
5=Dash-Dot, 8, 4, 2, 4
6=Dash-Dot-Dot, 8, 4, 2, 4, 2, 4
7=Chain, 8, 4, 4, 4
8=Phantom, 20, 4, 4, 4, 4, 4

Line widths The default line widths for graphics are rather coarse. In the 
section [Preferences] 

set (for example) to PenWidths=0.28pt, 0.7pt, 1pt, 1.4pt

or (will display as values converted to pt)

PenWidths=0.1mm, 0.25mm, 0.35mm, 0.5mm

Snap and grid Be aware, that some of these settings from the section 
[Preferences] are overridden by document settings.

Snap=On
Gravity=Off
DefaultRulerCm=0.1cm
DefaultGridCm=1cm
DefaultSnapCm=0.1cm

Template path If you want to get document templates from a special loca-
tion, change in section [Directories] 

from TemplateDir=templates
Templatesr=templates

to (for example) TemplateDir=D:\_doc-std\Frame
Templates=D:\_DOC-STD\Frame\FM-templates

Smart quotes Depending on the main language of your document you 
should define the proper typographic quotes in section 
[Spelling]. Select the appropriate set from the comment 
block:

; Deutsche anführungszeichen
SmartQuotes=\xe2\xd4\xe3\xd2

14 A nudge is defined as 1pt at zoom factor 100. Hence a factor of 353 nudg-
es by 0.1mm (1 pt = 25.4mm/72 = 0.3527 mm)
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Note: After installation of FrameMaker15) the definition of French 
quotes (guillemets) is incorrect for the single guillemets. They 
must be \xdc\xdd .

A more user friendly definition includes the display of the 
used characters:

; Smart Quote Characters
;English       ‘   ’   “   ”
; SmartQuotes=\xd4\xd5\xd2\xd3
;German        ‚   ‘   „   “
; SmartQuotes=\xe2\xd4\xe3\xd2
;French        ‹   ›   «   »         v-- activated
  SmartQuotes=\xdc\xdd\xc7\xc8
;Swedish/Finn. ’   ’   ”   ”
; SmartQuotes=\xd5\xd5\xd3\xd3
;Italian       ‘   ’   “   ”
; SmartQuotes=\xd4\xd5\xd2\xd3

Modifications to maker.ini

Have FrameMaker closed when modifying maker.ini. It is also 
good practice to keep a copy of the original file 
(maker.ini.ori) and make remarks at the beginning of the file 
about the changes, for example:

; 2004-10-12 default zoom factors changed to
; Zoom=28, 36, 50, 74, 90, 125, 200, 353, 500, 1000
; 2006-02-08 Patch b144

Paste prefers text The default for Paste (from none FM files with CTRL+v) may 
create OLE connections (Object Linking and Embedding). To 
paste the contents rather than the object property, change in 
section [Preferences]:

from ClipboardFormatsPriorities=FILE, OLE 2, EMF, META, DIB, 
BMP, MIF, RTF, TEXT

to ClipboardFormatsPriorities=TEXT, RTF, FILE, OLE 2, EMF, 
META, DIB, BMP, MIF

Note: ClipboardFormatsPriorities only affects pasting from the Win-
dows clipboard.  It does not affect the paste operation for con-
tent that is coming from a FrameMaker file.
To paste without formats within FrameMaker use Paste Spe-
cial (CTRL+SHIFT+v) > Text.

Default language in ¶ and 
f designer

In the first section [Frame] set

Language=UKEnglish

Display character 
positions correctly

In section [Fonts] set 

DisplayUsingPrinterMetrics=On

Match colours in 
FrameMaker and PDF

In section [Preferences] set

GetLibraryColorRGBFromCMYK=None

15 This is an error since FM 5.5
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Rules of thumb

Overview

In this chapter rules of thumb – methods developed 
by experience – are collected.

Legibility of printed matter is based on century old 
typographic tradition. Only recently these findings 
could be justified by research. They lead to a num-
ber of typographic rules.

Whereas FrameMaker provides the mechanics for 
layout, the user must think about the purpose of his 
design. Working in a team imposes rules which need 
not be observed when working alone.

A section gives some ideas about various elements 
present in scientific publications.

Contents

Form follows function .............................................  2

Layout issues .........................................................  7

Teamwork ..............................................................  9

Types of scientific publications .............................  13

Elements of the publication ...................................  15
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Form follows function
Technical, scientific and legal matters are texts which we do 
not read for pleasure. They are ‘must’ readings. Hence the 
author and producer should do everything to enhance reada-
bility and comprehension.

Roots of some arcane habits

The main purpose of script is communication. The ideas of 
the writer should become interpretable or even comprehensi-
ble by the reader.

The development of type and writing during centuries lead to 
certain rules known as «good typography» and good «writing 
style». The first of these rules refers to legibility, the second 
to readability.

The invention of the type writer cut back the rich expressions 
of printed type as they were developed since Guthembergs 
times. This new device eased writing for many people, but 
was limited in expression to one size of characters of fixed 
width. The only possible emphasis was underlining - and, with 
some effort - s p a c i n g the characters or bolding them by 
overprinting. In addition, it provided only a limited character 
set.

Many habits of layout, typing and writing are rooted in this 
limited device. At the end of the 20th century there are still 
many people in Switzerland believing that German does not 
use upper case umlauts or upper case French accented char-
acters. Even in France some people believe this...

The typewriter might also have lead to the numbering of 
headings to display structure and to refer to items elsewhere 
in the document. With text processing software or even Desk 
Top Publishing tools such as FrameMaker there is no need to 
restrict oneself to the times of type writing: we can use all the 
well established ‘standards’ of proven typography: font, type 
size, italic and bold type for emphasis, living references, and 
so on.

Form follows function

The basic principle of any design must be that it follows the 
function of the subject:

Although gothic chairs with their high back are very nice to 
look at they are very uncomfortable for the same reason.

A technical manual using flourishing script and hand made 
paper conveys the wrong message. It will not be considered 
serious.

Although in the old days of scrolls (biblia) the writing was 
in the same direction as the extension of the parchment, 
the line length was limited and precious space was sacri-
ficed for ease of reading.
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Legibility

It has turned out that some measures need different values 
depending on the language: English has shorter words and 
generally shorter sentences than German. This leads to differ-
ent optimum settings in these languages.16)

Properties of legibility The remarks give you an idea of good values of the property.

Line length About 50 - 70 characters per line. With the rule of thumb to 
have a 1cm line length for 1pt type size this yields 11 cm for 
11pt type.

Size of type Long words (german text) call for larger type (11pt), In Eng-
lish 10pt is a good reading size. Large pages (A3) need larger 
type due to larger reading distance.

Use larger type for headings (14, 18, 24pt), smaller type for 
footnotes (8 - 9pt).

Leading (space between
lines)

1/5 or 1/4 of type height seems to be optimal (10pt on 12pt). 
In any case it must be larger than the space between words.

Space between
characters

3 - 5% spread in normal text. Standard font settings are to 
tight. The higher value is needed for sans serif type (e.g. Hel-
vetica: Illness vs Illness)

Space between words Constant space (left aligned) is better than variable space 
(justified). To avoid ‘rivers’ across the typed page careful 
hyphenation must be applied to justified text.

Proportions of type x-height about 2/3 of capital heights. Smaller values need 
larger type size. Larger values need more leading. Low con-
trast (lines more or less equally thick). Normal (not heavy or 
thin) serifs.

Alignment Left adjusted text does not create holes (excessive word 
space) as justified text might do.

Colour of type Large type should not be in full black. Create a ‘constant level 
of gray’ by colouring type larger than 14pt with 40% black. 
Use real colour for special highlights (defined purpose) or 
images.

White space White space around type create the impression of larger type. 
10pt on 12pt it better legible than 11pt on 12.5pt. More than 
3 indentation levels can not be memorised. Heavily nested 
indentations also lead to very narrow text columns the pur-
pose of which nobody can digest.

Typographic signals Bullets, indentation and space visualise the structure of a 
text. Avoid to many different signals: limit yourself to 3 types 
of bullets and keep purpose constant.

Paper The paper should be really opaque (standard copier paper of 
80 g/m2 lets type shine through), not glossy and not abso-
lutely white (which strains the eyes).

16 Our visual system focuses at an angle of about 6°. The spacial frequencies 
for characters, words and lines of traditional type setting fit well to the 
physiology of the human eye. See for example: Object spatial frequencies, ret-
inal spatial frequencies, noise and the efficiency of letter discrimination. David 
H. Parish and George Sperling, in Vision Res. volume 31, number 6/7, 1991.
The importance of phase in the spectra of digital type by Ghuozen Duan and 
Robert A. Morris, UMASS Boston in Electronic Publishing, vol. 2, page 47-59 
(April 1989).
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Readability

It is very difficult to catch readability or even comprehensibil-
ity in facts and figures. For legibility we have a long typo-
graphic tradition which only recently was verified by 
cognitive science.

It is far more difficult to judge the semantics of text and 
define ‘ease of reading’ in this area.

Properties for good 
readability

The remarks give you an idea of good values of the property. 
Much of this is based on recent findings of cognitive science.

Character of type Character matches the content (Sans serif for technical, serif 
for serious, flourishing and script for informal or enjoyable 
text).

Size of vocabulary The basic German vocabulary is about 3000 words. The more 
words of the text are beyond this, the less it is understanda-
ble. Some technical texts use ‘controlled language’ for this 
reason.

Abstraction level Examples and comparisons to daily life are far more under-
standable than metaphors and abstractions.

Idiomatic words Special slang, newly invented buzz words or special terms 
(overuse of scientific terms) make it difficult to understand 
the text.

Numbering More than 3 numbering levels can not be memorised and do 
not help in navigation. In most cases numbering of headings 
is not necessary for navigation purpose, because variation in 
type size give better clues on the structure.

References Footnotes do not interrupt the reading flow as do in-line com-
ments (in parentheses), because it is easy to skip them in first 
reading. 

Cross references to title text give a better clue than to title 
numbers. Based on the title text the reader can decide 
whether ‘to jump’ to another location or to continue reading.

Navigation aids Technical and scientific texts need various access methods to 
the content, because they are not read the same way as prose.

Table of contents present the overall structure, but should 
not go beyond 3 levels. Present a detailed view in a substruc-
ture (e.g. in a chapter).

An index must be as rich as possible because the fantasy of 
the reader always differs from the knowledge of the writer.

Think of different indices for certain elements: people, works, 
actions, time, area…

Placement of images Keep descriptive text to the right of images. Although mir-
rored layout looks very nice in the first place, this violates the 
relation of speech and image in our brain.

Grouping Use white space and alignment to group items (e.g. in tables. 
Avoid heavy ruling which is often default for US based DTP 
systems.



B – 5

Research on readability


E
:\

FM
-c

o
u

rs
e
\h

a
n

d
o

u
t_

7
0

\r
u

le
so

ft
h

u
m

b
.f

m
 

2
0

0
7

-0
6

-2
2

Research on readability

Research by Arend Mihm The following diagram is based on research summarised in 
Textverständlichkeit und gesellschaftliche Lesefähigkeit by Arend 
Mihm in Linguistic und Didaktik, 1973.

The term reading ease (RE) was defined 1948 by Flesch and 
derived from the measures wl (average word length in sylla-
bles) and sl (average sentence length in words) with the fol-
lowing formula17), which he verified on an extensive set of 
text samples read by a great number of people:

RE = 206.835 - 84.6 • wl - 1.015 • sl

Mihm needed to adapt the figures found by Flesch for German 
texts, because in this language both the average sentence 
length and the average word length are larger than in English 
(≈ +20%).

17 To high a precision demonstrates lack of knowledge on the subject is still a 
valid insight from my studies at the School of Technology. Although we 
have here an elaborate formula the input was presumably much less pre-
cise...
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http://en.wikipedia.org/wiki/Flesch-Kincaid
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Personal experience with 
readability

This diagram is based on the authors experience with various 
text sorts and tries to cope with the fact that reading ease is 
only one side of the coin. The abstraction level and the size of 
the vocabulary add another dimension to the subject.
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Technical manuals

Legal and
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Layout issues

Books

Books are normally smaller than A4 and larger than A5. A 
very common size is 17 x 24cm (close to B5).

For books the inner margin is smaller than the outer margin. 
This gives room to a browsing thumb.

A4 loose leaf publications

For A4 publications the binding normally is inside. The clas-
sic 1/9 rule for margins creates much white space, because 
this rule assumes no side headings.

Margins

The classic rule for margins reduces the text area to 2/3 of 
the paper size and adjust the margins to these values:

Running headings are inside the text area, but the pagination 
is outside.

These margins are good for text areas which are filled with 
text. The margins are to large for layouts using side headings, 
such as technical and scientific publications.

Layout with side heads

Layouts with side heads use about 1/3 of the text width for 
the side heads and 2/3 for the common text. This creates a 
proper line length for the ordinary text.

Both running headings and pagination are outside the text 
area.

Mirrored layout Although a mirrored layout (side heads always on the outer 
side) look more pleasing on first sight, this confuses the rela-

Margin Relation For A4 [cm] for 17 x 24 [cm]

Top 1/9 of paper height 3.3 2.7

Bottom 2/9 of paper height 6.6 5.4

Inner 1/9 of paper width 2.3 1.9

Outer 2/9 of paper width 4.6 3.8

Text area 2/3 of dimension 14 x 19.8 11.3 x 16

Margin For A4 [cm] for 17 x 24 [cm]

Top 2.0 1.5

Bottom 1.7 1.7

Inner 2.0 1.7

Outer 1.0 1.0

Room for side head 5.6; gap 0.6 4.0; gap 0.4

Line length 11.8 9.9
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tion between image and text for small images in the side head 
area.

Use a mirrored layout for nice books, but not for technical 
and scientific publications.

Running headers and footers

Running headier repeat the information from the headings on 
the page.

The running header on the left page always repeats a higher 
level heading (e.g. 1-heading) than the running header on the 
right page (e.g. 2-heading).

Running footers with information from the page contents are 
present, for example, in dictionary style layout.

Tables

Both technical and scientific publications use tables much 
more than standard texts. 

Layout rules for tables Both start and end of the table must be clearly visible and 
distinguishable from the running text. A good method is to 
have the heading row shaded (up to 10%) and the footing 
row (or end of table) be indicated with a line.

Group rows either with additional white space or ruling.

Avoid to much ruling. Most ruling can be omitted when 
proper alignment of the columns is used.

Ruling defaults of US based DTP programs are to heavy for 
European eyes. A thin rule uses 0.3pt (and not 1pt as in the 
US).

Both heading and footing rows must be repeated on each 
page of a table which spans several pages. FrameMaker 
does this automatically.

Harmonize column width for tables which are not sepa-
rated by much text. If each table uses different row propor-
tions the page image becomes very cluttered.

For very wide tables rotate the table (or the whole page) 
counter clockwise. Care must be taken to text which is 
rotated in the cells or the text area: it must stand normal in 
the rotated page (an not top down!). 

Arrange table titles always at the same side (above or 
below) or the tables. If you need a special table construct 
for titled images (FrameMaker does not provide titled 
anchored frames), arrange the title of tables above and the 
title of images below.

If no list of table titles is created, titles may be omitted, 
because the tables are normally anchored in the text where 
they belong to and the heading row gives enough informa-
tion for the contents of the table.
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Teamwork
Teamwork requires more working rules than working in soli-
tude. The rules must be set up and observed by all team mem-
bers. Of course it is best to have one person responsible to 
manage the rules – the team responsible.

Team responsible

Tasks of the team responsible are:

Collecting wishes concerning layout and styles

Maintain the template directory

Document the template (layout, catalogues)

Keep the templates up to date

Maintain a project dictionary

Distribute changes

Directory structure for a project

Do not use umlauts, blanks and other dangerous charac-
ters in file names (which may be valid on your current plat-
form) – think about case dependency of file names!

Do not use chapter numbers in the file names – the order 
may change during the development of the document.

Do not mix versions (and/or languages) in one directory.

Keep graphics language independent. Either place circled 
numbers in the graphic to be referenced in the text or over-
lay the graphic in FrameMaker with callouts etc.

Keep reference data (reports, sources, original text) in a 
separate directory.

As it is often What would be better

/project-directory
arbeiten_d.fm
arbeiten_dv7.fm
einführung_d.fm
firlefanz.gif
graphic1.xyz
graphicz.xyz
introduction_e.fm

/project-directory
/de

arbeiten.fm
einfuehrung.fm
handbuch.book
/graphics_d

firlefanz.gif
/de_v7

arbeiten_dv7.fm
/en

introduction.fm
working.fm

/graphics
graphic1.xyz
graphicz.xyz
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Locking files in a network

FrameMaker creates a file name.lck for each document it 
opens (name is the file name of the document). This lock doc-
ument is placed in the same directory as the source file.

Even if you are not a single person working on any project, 
keep this preference ON; is does not affect your work outside 
a team:
File > Preferences: Network File locking.

Source code maintenance system

Extensive file control with access rights (e.g. read only) can 
only be maintained with a source control system. The support 
provided by FrameMaker is to weak in these cases.

With FrameMaker 7 Adobe has introduced a special form of 
source code maintenance system: FrameServer. This supports 
central distribution of files with check out - check in proce-
dures. 

Fonts in a mixed environment

Always set File > Preferences... Remember missing font 
names

Minimise your trouble with commercial printing by embed-
ding fonts completely into your PDFs.

Note: If your prints hop refuses to accept TrueType fonts in your 
document, change the prints hop! This one lives in the last cen-
tury.

FrameMaker is one of the very few applications which sup-
ports font integrity between Macintosh, Windows and UNIX. 
This is done by means of two tables in the maker.ini file. This 
is tedious work even for experts, because fonts are handled 
very differently on these platforms.

Font mapping for Windows font names

Unknown to known font mapping

Template library

FrameMaker treats any document as template when this is 
located in a particular directory which is defined in the 
maker.ini preferences.

When opening a template with File > New... a copy of the tem-
plate file is created automatically.
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Style planning

For a team project, the planning of layout and style is even 
more important than for any documentation project:

Provide (at least during development of the document) the 
following information on each page:

- full file name

- date of modification

Which styles for paragraphs and highlights are needed?
Use names, which allow easy recognition of the purpose 
and not the appearance (1heading rather than Big Heading). 
See also Names for styles on page 2

Think early about your numbering scheme for headings, 
tables, figures, formulas, chapters etc.
Do you really need a numbering system in the time of live 
cross references and hypertext? At which level do numbers 
restart? Should tables and figures be numbered independ-
ently of headings?

What types of tables are needed?
Set up a collection of wide and narrow tables and specify 
their ruling and shading. Define tables by appearance only 
for general styles. Be aware of the limitations of the table 
catalogue (it does not keep all what you might wish).

What layout will be needed for the pages?
FrameMaker support an ‘unlimited’ number of master 
pages for a document. Do you need special graphical ele-
ments in the layout, such as lines above and below para-
graphs? They will be placed in the reference pages of the 
template.

What formats for cross references will be needed?
FrameMaker starts with a set of these which may not be 
what you need.

If you plan to use the built in graphics tools, think about 
line widths and arrow tips. User defined arrow tips can not 
be kept between sessions!

Can you place ‘canned text’ in variables?
Candidates are product names, company names, copyright 
notes etc.

Do we use project specific graphics only?
General graphics (e.g. clip art) may reside in locations 
which are not available at the final stage of the document 
(commercial printing...). You will need to copy them.

Maintaining consistent use of styles is one of the main issues 
in document team work. FrameMaker support this with the 
capability to import style and layout definitions from other 
documents.

When initiated from a book file, the styles and layout defini-
tions are imported to all files of the book.

It is therefore important to develop styles only in one files of 
a project and propagate them via the book mechanism to all 
files of the project.
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Local styles

Using local styles (such as bolding a word, giving a paragraph 
an individual appearance) must be avoided as much as possi-
ble. In any case do not use styles which are not in the cata-
logue - there is little chance to find and maintain these 
elements!

If special styles are needed in a limited area of a project, use 
named styles with the chapter-number in the style name. For 
example, z1-figure-top. This would be a special style in 
chapter 1. The z keeps the style separate to the others. This 
method keeps things apart even if styles are accidentally 
propagated to other chapters.

Maintain a style guide

Even for small projects it is good practice to have a list of all 
styles available in one document. This displays the name of 
the style and its appearance. Sophisticated style guides list all 
properties of the style and where they must / may be used.

Simple style list bodytext: Lorem ipsum dolor sit amet, consectetuer 
adipiscing elit, sed diam nonummy nibh euismod tincidunt ut 
laoreet dolore magna aliquam erat..

Q ln-narrow-list is used for definiiton lists with short 
terms.Lorem ipsum dolor sit amet, consectetuer adipiscing 
elit, sed diam nonummy nibh euismod tincidunt ut laoreet 
dolore magna aliquam erat

Island lw-wide-list is used for definition lists with longer 
terms.Lorem ipsum dolor sit amet, consectetuer 
adipiscing elit, sed diam nonummy nibh euismod 
tincidunt ut laoreet dolore magna aliquam erat

Popocatepetl lww-verywide-list is used for very long 
terms. Lorem ipsum dolor sit amet, 
consectetuer adipiscing elit, sed diam 
nonummy 

This is a 3heading Character formats are 1highlight, 2highlight, computer, ddd-
symbols: 

name and dingbats: abcdefghijklmn

Boiler plate elements

Collect well thought out elements in a special document for 
easy copy and paste. Such elements may be:

Tables with sophisticated layout (straddled cells, special 
ruling and/or shading)

Figure tables with diverse arrangements of graphics or 
photos.

Special characters from exotic fonts

See Figures with legends on page 17 for examples.
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Types of scientific publications

Scripts

IMHO scripts can be set up similar to the handouts presented 
here. Very often more than one person works on such a paper 
which will introduce style differences as well as different 
method to achieve the same affect. Hence guidelines about 
the formats, layout and methods are needed for this work.

Nevertheless from time to time a complete cleanup of such 
documents is necessary.

Thesis

At the time being I do not have much insight into this - need 
input from ETH people.

Dissertation

A dissertation (at least at the ETH) consists of these parts:

Cover The cover repeats the front page

Preface Page numbers in roman numerals

Front page repeating the text of the cover

Dedication and probably a motto 8citation)

Acknowledgments

Preliminaries Page numbers in roman numerals)

I Table of contents

II Abbreviations

III Summary

IV Zusammenfassung

The contents Arabic page numbers. The structure headings may vary, but 
this is typical:

1 Introduction

2 Literature review

3 Experimental

4 Results and discussion

5 Conclusions

6 References

Paper for publication

Most publishers have their own rules how to present the vari-
ous elements of the paper:

Literature references are strictly regulated
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Format of images and file types are defined

Drawings (line types, line widths etc.) provide only little 
variation.

Colours are welcome only for photographs, not in layout

etc.

Templates for scientific texts

FrameMaker comes along with templates for outlines only:

Harvard outline This outline provides 7 levels with ample indentation. In level 
5 you have only half the page width available for text, in level 
7 about 1/3!

The numbering is very mixed - it uses all styles from upper 
case roman to lower case characters with parentheses.

Outline, Numeric This outline supports six paragraph levels. The levels use ara-
bic numbers and indentation.

Outline, Small Use this template to create a simple outline that uses bullets 
and dashes to indicate a paragraph’s level. 6 levels of para-
graphs are supported.
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Elements of the publication

Design Before you start it is good to look at basic design and typo-
graphic principles, such as Form follows function on page 2.

Layout Layout very often is based on a book format or A5. This deter-
mines the amount of space available. In particular, side head-
ings are not used much (in contrast to technical publications).

Body text To cope with footnote references and small in line formulas it 
is usual to have a wide line spacing. Use only few character 
formats and explain their use at the beginning (e.g. after 
Abbreviations: Typographic conventions)

Heading levels Usually 3 heading levels are numbered and the fourth one is 
not numbered. In an A5 layout the numbers run into the text 
space. In A4 layout it is convenient to set the numbers out-
side the text space.

If tables, figures and formulas are not numbered independ-
ently from heading levels, you set up a matrix (see Hierarchi-
cal numbering on page 3-10) to get correct numbering.

Tables Tables are numbered and in most cases the table title is 
arranged above the table. Only few authors set the table with 
different font than the body, although this gets tight in an A5 
layout. Ruling is preferred over shading, because copies are 
done easier in this case.

In Switzerland heavy ruling is unusual, in particular if you 
print to a high resolution device. In most cases it is not neces-
sary to place vertical rules, because the text boundaries itself 
guide the eye.

Figures Figures are numbered. The legend may extend to multiple 
lines. Various forms have been found for this element.

For greater flexibility it is recommended to place callouts 
(numbers, arrows etc.) not directly into the image, but overlay 
the images with FrameMaker graphics.

Small figures may be combined to clusters (e.g. 4 cells in a 
table).

Drawings Drawings in figures are mostly done outside FrameMaker, 
because very often these are graphics based on data. 

Pay attention to line styles, fonts and font size. It is good 
practice to create graphics in the needed size to avoid any 
scaling (which damages the font size). Use the same fonts as 
used in the document. Stick to one font-type (TrueType).

Images Images are mostly photographs. TIFF is not a good choice for 
this form of images. JPG is more adequate. However, some 
print shop insist on TIFF images.

When creating and storing images, do this in the highest pos-
sible resolution. When working in FrameMaker you can switch 
off the display of images, which may cause large build-up 
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time for pages (View > Options: uncheck Graphics). Switch 
the display of images on again for placing callouts etc.

When producing a PDF from your paper you adjust the param-
eters according to the publication process (see chapter 10).

Footnotes These may or may not be used. Some people prefer to collect 
the notes at the end in a separate chapter and handle them as 
ordinary reference.

Bibliography Whether to use a special tool such as EndNote (see Bibliogra-
phy with EndNote 5 on page 7-20) depends on the nature of 
your references. If you can not relay on existing data bases 
there is no use of EndNote. A simple table (see Bibliographies 
on page 7-16) will do the job.

Lists of authors etc. Some publications require lists of

authors

tables

figures

etc.

FrameMaker gives you great support for these items (see Arbi-
trary lists on page 9-15).

But this is only possible if you follow a good scheme for para-
graph formats, cross reference formats and character for-
mats. Do not highlight locally or use ‘Word-style’ formatting 
for paragraphs - this can not be accessed to generate things.

Formulas FrameMaker has a very good formula editor, although it needs 
some skill to be handled well. Keep in mind that in Frame-
Maker a formula (or equation as Frame calls it) is mathemati-
cal construct, not just an image (as for example in MS Word).

If you need to place a comment directly in the formula, use 
the method described at Physical dimensions and other strings 
on page 11-7.

If you have a very large number of formulas in another sys-
tem (e.g. Maple) consider to import the formulas as images. In 
this case use a high resolution to generate the image, because 
in many cases you just get a bitmap.
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Figures with legends
It is good practice to have a document with ‘boilerplate’ text 
and other elements available. The following pages give you 
some of the needed elements which you can copy.

You may install the shareware plug-in AutoText by Silicon 
Prairie Software (www.kagi.com/spsoftware/) to have ready 
access to any FrameMaker object (table, text, graphic, etc.). Be 
aware that predefined keyboard short-cuts (such as CTRL+t) 
may conflict with FrameMaker short-cuts.

Note: To be able to create a «list of figures» you need to have reason-
able text in the figure heading. Hence it is not recommended to 
have an empty figure heading and start immediately with 
(probably numbered) legend items after the figure number.

Figure with title in side head room

Here you see the standard method in technical documenta-
tion for callouts: numbers, which are explained in the legend. 
Text in the figure is avoided to ease modification and transla-
tion.

To see the construction in FrameMaker, the table is outlined 
with borders and the anchored frames are filled with gray. 
Anchor symbols are displayed with a special font. 

Arrangement within text column

This type of figure table (2 table columns) uses only the area 
of the text column

Figure 1: 
C. F. Gauss on German bank 
notes
1 Formula of normal distribution
2 The «bell curve»



1

2

Figure 2: 
C. F. Gauss on German bank 
notes
1 Formula of normal distribution
2 The «bell curve»1

2

http://www.kagi.com/spsoftware/
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Figure cluster

To avoid separation of the image from the title row, set 
Orphan Rows (Table designer, category Basic) to 2.

For large clusters of images this may not be sufficient: Set 
Table > Row Format > Keep with next (or previous).

Images in distinct table 
cells

The default numbering sequence in a table is Row first (as 
seen above). You can change this in Table designer, Basic cat-
egory.

Images combined in cell

Paragraph formats used 
for the figures

ftn-fig-title-numberedFigure title, sets legend number to 0.

ft-fig-text Legend without numbering. Automatic fol-
lower of ftn-fig-title-numbered.

legx-legend-nx Legend with numbering.

 

Figure 3: With no figure legend at 
all - just the figure title

Figure 4: With figure legend
Figure legend for longer explanations of 

the figure contents. 

 

Figure 5: Using figure-legend
1 Start of the mischief
2 Climax of the mischief
3 Back to normal again

Figure 6: Legend text and list
This is the introductory text 

1 The famous bell curve with the formula
2 Background image is taken from an 

engraving of Nuremberg

1

2

3

1

2

Figure 7: Key developments by C.F. Gauss
1 The Gaussian normal distribution is one of the most common distribution functions, 

especially in error theory. The function has many names, including de Moivre distri-
bution.

2 Instrument for triangulation. A sophisticated form of a sextant.

1 2
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Graphic overlays


E
:\

FM
-c

o
u

rs
e
\h

a
n

d
o

u
t_

7
0

\r
u

le
so

ft
h

u
m

b
.f

m
 

2
0

0
7

-0
6

-2
2

Graphic overlays

Collect prepared items in your boiler plate file. Here you see 
also white arrows to be placed on dark images. 

You can select and change the number also in grouped state. 
You just need to be able to select it with the mouse (zoom in 
for easy working).

Fonts

If your prints hop refuses your document because you use 
TrueType fonts, change the prints hop immediately. It lives in 
the previous century. The TrueType font definitions were 
jointly specified by Apple and Microsoft18) and finally led to 
the OpenType font definition, which is a container format for 
PostScript fonts and TrueType fonts. 

Contact your favourite print shop as early as possible also to 
get the preferred PDF job-options for generation of your PDF. 
Always generate the PDF with complete fonts included (no 
subsetting).

Special symbols

It may be cumbersome to enter special symbols in Frame-
Maker (see Symbols and dingbats on page A-5). So it is a good 
idea to place also the rarely used in the boiler plate file, espe-
cially if they are located in an exotic font:

Symbol Ω Σ • ≤ ≥ 

D+DD Symbols 

Figure 8: Numbers and arrows 
for image overlay
1 Arrows in the top row can be 

ungrouped and rotated when 
grabbed at the tip

2 Combined arrows (black on white) 
can not be rotated any more, hence 
the proliferation of items.

3 For length adjustment of arrows: 
ungroup and stretch arrow

4 After positioning, select the arrow, 
the number and the circle and group 
them

2 41 3

1

2

3

4
5

6 17 8
9

10

14

13

12

20

+

25

24

23
22

21 19
18

17

16

15

14

18 1990 Apple was tired about spending 30% of its revenues for font licens-
es to Adobe and hence developed the alternative together with Microsoft. 
This bowed the neck of Adobe to reveal the Type 1 font definition.



Bibliography

B – 20

Bibliography

Visible reference items

To get access to the reference items [...] with the cross refer-
ence mechanism these items must be distinct paragraphs (see 
also Bibliographies on page 7-16).

References in a table

References in run-in-
paragraphs

[Daube 1989]: Daube, K., Aufbau des OBRZ Run time 
Systems, in Technisch-wissenschaftliches Rechnen am MVS 
System. 1989, OBRZ AG: Zürich. p. Chapter 400.50.10.

[Garneau 1990]: Garneau, D., ed. National Language Support 
Reference Manual. January 10, 1990 ed. National language 
Information Design Guide, ed. IBM. Vol. 2. 1990, IBM 
National Language Technical Centre: Toronto, CDN.

[LaBonté 1989]: LaBonté, A. A New Data Type for National 
Language? in SEAS Anniversary Meeting. 1989. 
Amsterdam, The Netherlands: SHARE European 
Association.

Invisible reference items

Some publications require that the bibliography does not con-
tain the repeated references. For example, the bibliographic 
list may contain:

Acree, T. E., Barnard, J. and Cunningham, D. G. 1984. A 
procedure for the sensory analysis of gas chromatographic 
effluents. Food Chemistry, 14: 273-286.

And the references should be [Acrre et al, 1984].

This can not be achieved by cross references to markers, 
because there is no building block <$markertext> available in 
body pages.

[Daube 1989] Daube, K., Aufbau des OBRZ Run time Systems, in 
Technisch-wissenschaftliches Rechnen am MVS System. 
1989, OBRZ AG: Zürich. p. Chapter 400.50.10.

[Garneau 1990] Garneau, D., ed. National Language Support Reference 
Manual. January 10, 1990 ed. National language 
Information Design Guide, ed. IBM. Vol. 2. 1990, IBM 
National Language Technical Centre: Toronto, CDN.

[LaBonté 1989] LaBonté, A. A New Data Type for National Language? in 
SEAS Anniversary Meeting. 1989. Amsterdam, The 
Netherlands: SHARE European Association.
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Solution The solution is to hide the reference item in the bibliography 
list. The item is coloured with «invisible».

Colour definition 1 In View > Color > Define… specify a special colour for 
your reference items, for example invisible. Use a colour 
such as magenta or pink which clearly separates from the 
real colours of your document.

2 In View > Color > Views… make the colour visible:

Paragraph format Use a distinct paragraph format for your reference items in 
the bibliography table, for example, bib-ref. This format 
uses the colour invisible.

References in the text The text uses cross references to the reference items:

Extract dilution techniques, such as CHARM [Acree et al, 1984] 
or AEDA [Grosch, 1993], provide means to even evaluate the 
relevance and impact of a single compound within the entire 
aroma profile.

PDF creation and
printing

For printing and saving as PDF hide the reference items with 
View > Color > Views…

This does not affect the cross references, because the text is 
not excluded from the document (as conditional text would 
do).

Acree et al, 1984 Acree, T. E., Barnard, J. and Cunningham, D. G. 1984. A 
procedure for the sensory analysis of gas 
chromatographic effluents. Food Chemistry, 14: 273-286.

Grosch, 1993 Grosch, W. 1993. Detection of potent odorants in foods by 
aroma extract dilution analysis. Trends in Food Science & 
Technology, 4 (3): 68-73.

Karathanos et al, 1996 Karathanos, V. T., Kanellopoulos, N. K. and Belessiotis, V. G. 
1996. Development of porous structure during air drying 
of agricultural plant products. Journal of Food 
Engineering, 29: 167-183.



Bibliography

B – 22



Miscellaneous

Overview

Plain text can be imported an formatted according 
to some rules. In particular, it is possible to convert 
a TAB delimited text to a table.

Importing objects from other applications uses a 
filter mechanism, which is still not fully reliable for 
Word documents and Excel tables. The reason might 
be the ever changing format of MS office data.

A section provides general information about Fram-
eMaker and some internal mechanisms.

Contents

Importing methods .................................................  2

Importing methods in detail ....................................  4

Application of importing methods ...........................  6

FrameMaker specifics ..............................................  8

File names ............................................................  11

Document properties in MIF ..................................  12

FrameMaker principles and philosophy ..................  16
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Importing methods
FrameMaker offers various methods of importing text and 
graphics. The most reasonable method depend on various fac-
tors:

Import filters

With File > Import > File… FrameMaker activates import fil-
ters which are third party developments. Some file formats 
are well defined and stable (eps, tiff, txt), but most are propri-
etary and not well defined. Word for example is not compati-
ble with itself … On the other hand functions in one 
application can not easily mapped to functions in another 
application because of the different object model (e.g. frames 
in Word vs. frames in FrameMaker).

Another obstacle are naming conventions or user definitions. 
FrameMaker users are adept to the catalog concept and hence 
use (in most cases) consistent naming for paragraph and 
character formats. The great majority of MS Word users are 
not aware of the capabilities of the product and hence use 
Word as a heavily overpowered typewriter.

Note: Importing from Word may19) leave CR characters (\x0D) and 
other illegal characters (e.g. \x01) in the file. These restrict an 
FM search to the paragraph ending with CR. You can find 
them only by searching backwards from the end of the flow. 
Clean the file by saving as MIF, opening the MIF, saving as FM, 

Copy and paste

The paste buffer can contain various forms of a copied object 
depending on the nature of the object and the creating appli-
cation. Using just copy fills the paste buffer with forms which 
are specific to the creating application and the setup of 
which. When using paste the target application will take a 
default format or you specify which format to take by using 
paste special.

Method Applicable to

Import filter Graphics and plain text in distinct files

Copy / paste Text and graphics from Office applications; 

OLE Avoid this method

19 This actually depends on the filter type and FM version.
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Using copy special (if available) fills the paste buffer with a 
specific form (for example an image in tiff format or text in 
rtf = Rich Text Format). In this case a paste will place only 
this specific form.

FrameMaker default for 
paste

The FrameMaker default format for pasting is defined (on 
Windows) in the maker.ini file. For more easy working the 
changes according to Paste prefers text on page A-37 are rec-
ommended.

Paste special in 
FrameMaker

When pasting a graphic this might provide the formats bmp 
(Bit Map), dib (Device Independent Bitmap) or EMF (Enhanced 
Metafile). 

When pasting a textual object, this might provide emf, rtf 
(Rich Text Format) or text (plain text).

Object Linking and Embedding

Object Linking and Embedding provides a link to the source 
application. What you see on the screen and will be printed in 
FrameMaker is an image of the application window.

Note: On the Macintosh (or UNIX) no such thing exists.

Depending on the source of the object (same computer, other 
machine) the image may be just a bitmap. When transferring 
objects between Windows machines, the object seems to bear 
a WMF (mixed vector and bitmap) image.

Warning When planning to use the document on various computers, 
for example, send to a print shop, avoid OLE at all. The 
receiver of the document both must have access to the file 
and the same applications installed - which is often not the 
case.

Insert an object Select the object in the source application (e.g. Excel) and 
copy it to the clipboard.

In FrameMaker paste it into an anchored frame (if you just 
paste it to the current cursor location, a default frame is 
created).

When double clicking on the object, the original object win-
dow appears on the FrameMaker screen and the menus and 
buttons are from the source application (Excel). The data 
can be edited now.

To close the application window click somewhere outside 
the object window. Do not use File > Save or File > Close, 
as this will close the FrameMaker document also.
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Importing methods in detail

Text in Source applications

Although the various filters which FrameMaker provide are of 
high standard, they can not be accurate. Hence it is best prac-
tice, to

1 Provide the author(s) a template using the same paragraph 
and character styles as the final FrameMaker document.

2 Since most MS Office users are not familiar to templates 
even with education they will fall into old habits and use 
individual markup. Hence You will need to clean the docu-
ment in the source application. A set of macros may help 
you especially for multiple input.

3 Remove special formatting such as Word frames and 
remove all graphics. Break down large documents into 
manageable chunks.

4 Use this / these cleaned documents for import to Frame-
Maker.

Note: You will need to judge points 1) and 2) and decide to work 
completely on plain text which you format in FrameMaker.

Graphics in source applications

Graphics in source applications (e.g. MS Word) may be OLE 
objects, imported or copied external files or application spe-
cific graphics. Depending on the nature handle them differ-
ently:

OLE objects See Object Linking and Embedding on page 3.

Copied into the document A copied file has lost its relation to the source. You do not 
have a clue about the original size or resolution in case of a 
bitmap. 

1 In the source application copy the image

2 In FM use Edit > Paste Special and select the most appro-
priate format. If a a vector format is available (eps, wmf, 
emf), use this (with preference to eps)

Linked to the document To see whether a file is copied or linked, switch the Field view 
ON in the source application. A linked file is displayed as 
something like this:

{INCLUDEPICTURE "G:\\Graphics&images\\!temp\\test.wmf" 
\* MERGEFORMAT \d}

Copy the referenced file (G:\Graphics&images\!temp\test.wmf) to 
an appropriate directory in your FrameMaker project and 
include the file by reference into FrameMaker.

Application specific 
graphics

To handle graphics created directly in the source application, 
try to export the graphic to a file in a common format (at 
best: eps).
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If this is not passible (as with Word graphics), use the copy 
and paste method (See Copied into the document on page 4).

Last resort None of the above may work in certain circumstances. In this 
case use PDF as an intermediate format. If the image is a vec-
tor image, then the result will be a vector image. Otherwise 
you get a bit-map.

1 Create a PDF. If PDFWriter or PDFMaker seems to get stuck 
use Print to PS (using the Distiller Printer) and then distil to 
PDF.

2 Open the file in Acrobat (the full product, not just the 
Reader).

3 Crop the page to the size of the image.

4 Save the page as eps with preview.

5 Import the eps in FrameMaker by reference.
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Application of importing methods

Importing Word files (text)

These rules are based on the work of 
FredRidder@Dialogic.com.

1 In the first step remove all graphics, even if they are 
imported by reference. Handle images completely separate 
from text.

2 Good adherence to the Word style sheet. Local format over-
rides are nothing but trouble. If necessary, write Word mac-
ros to enforce as much style conformance as possible 
before attempting to import.

3 Remove as much «special» formatting as possible by rede-
fining the Word styles in a special «export» template. In 
particular, redefine any styles that have auto numbering or 
bullets in Word so that you don't wind up with duplicate 
tabs or bullet characters in your Frame files. 

4 Ensure exact 1-to-1 correspondence between Word style 
names and Frame style names. This allows you to import 
content only from Word files, leaving all the formatting 
stuff behind and redefining all the styles in Frame. This 
sounds like the harder way of doing things, but it works 
better in the long run because there are a number of for-
mat issues that are simply handled too differently in the 
two tools allow direct translation. (One good example is 
space before and space after paragraphs, which is additive 
in Word but not in Frame.) 

5 Remove any Word frames, that is, resolve them to ordinary 
text before importing.

6 Always import by using File > New to start a new Frame 
document and then File > Import > File to convert and 
copy the Word content into Frame. 

7 Always select the «Reformat Using Current Document's 
Formats» option in the «Import Text Flow by Copy» dia-
logue to apply your clean Frame styles and leave all the 
Word formatting behind.

8 Break large Word files into chapter-size or section-size 
chunks before importing to Frame. One of the biggest rea-
sons for migrating from Word to Frame is Frame's ability to 
reliably build large books from smaller files, and the best 
time to do the chunking is before importing into Frame 
rather than after. In file importing, smaller is always better. 
(Yes, I'm afraid that size does matter...).

Importing a Word graphic

Word graphics may be of all the kinds described in Graphics in 
source applications on page 4. Use the methods proposed 
there.
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Importing an Excel table

MS Excel (or FrameMaker) produced errors when importing 
sparse arrays (not completely filled table areas). This error is 
no more present with FrameMaker 6 and Excel 2000.

To import an Excel table (or part of):

1 In Excel select the table area to be copied

2 Copy to the clipboard

3 In FrameMaker use Edit > Paste Special… and select text.

4 Convert the tabbed paragraphs to a table with Table > 
Convert to Table… 

5 Select an appropriate Table format and format the rows 
according to the needs.

Importing an Excel graphic

To import a graphic from Excel into FrameMaker:

1 In Excel select the graphic (chart)

2 SHIFT-Edit > Copy picture…

3 Select as shown when printed to get best results

4 In FrameMaker use Edit > Paste Special… and select wmf. 

Importing a Powerpoint graphic

1 In PowerPoint select the graphic or graphic elements.

2 Copy to the clipboard

3 In FrameMaker Paste (a wmf will be pasted)

Note: If you select text elements (e.g. large headings) these will not 
be copied. Also backgrounds will not be copied (they can nor-
mally not be selected)
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FrameMaker specifics
FrameMaker is available on the following platforms (operating 
systems)

Platform differences

Starting with version 5.5 the FM-files (binary) are platform-
compatible, hence MIF no more needed for platform-transfer.

Maker Interchange Format - MIF

Main features of this file format are:

preserve the document structure

is independent of character coding (uses only 7-bit ASCII)

is extensible (upward compatible)

Any FrameMaker version can import MIF. When opening an FM 
6.x MIF in a 5.x Frame version, unknown items are skipped – 
MIF is even downwards compatible!

Saving a file as MIF cleans out some ambiguities which still 
accumulate with many changes in a document.

FrameMaker vs. word processing and DTP

Looking at the developments in document processing applica-
tions reveals various approaches (looking at the 1980’s):

Windows Macintosh UNIX LINUX

Windows 3.1
(up to FM 4)

System 7.x
(up to FM 5.1)

IBM AIX Only ‘unofficial’ LINIX port ex-
isted for FM 5.5.6

Windows 95 (up to FM 5.6) System 8.x (until FM x.x) HP_UX

Windows NT 4.0 System 9.x (until FM 7.0) SUN Solaris

Windows 2000
Windows XP

Platform abandoned after FM 
7.0 March 2004

Only Sun Solaris continued 
with FM 7.1, others abandoned 
March 2004

Property Windows 3.x, 9x, NT4, 2K, 
XP

Macintosh UNIX

User interface Windows, child windows, but-
tons, drop down lists, tabs in 
dialogues. Multi document in-
terface (MDI)

Windows, child windows, but-
tons, drop down lists. Format-
ting bar is part of document 
window.

Windows, child windows, but-
tons, drop down lists. Most di-
alogues behave like palettes.

Keyboard short-cuts Adapted to Windows Adapted to MacOS Some keyboard short-cuts

Escape sequences are platform independent, but adapted to UI-language

File format (line-ending) CR - LF LF CR

Character coding ANSI + extensions (OEM) Mac specific (Mac Roman) ( 
FM internal coding)

ISO Latin-1

Help system
- version < 6
- version 6
- version 7

Frame hyper document
Winhelp
HTML

Frame hyper document
Mac Help
HTML

Frame hyper document
X-windows help
HTML
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Quark Xpress emulated20) dedicated and complex typogra-
phy equipment that required trained operators in print 
houses.

Aldus (now Adobe) PageMaker emulated a layout (paste-up) 
artist's workspace accessibly.

MacWrite emulated a typewriter (magnetic-card operator 
was still a profession).

Microsoft Word emulated MacWrite with bells, whims, and 
bugs.

FrameMaker emulated dedicated technical or scientific 
word-processing systems that served publishing profes-
sionals printing book-length documents.

Any comparison between these applications must keep the 
(originally intended) purpose and users in mind21).

20 You may substitute the word emulated by «was inspired by».
21 Many of these remarks are still valid for Word 2000 and even 2003

Word for Windows (6 … 8) FrameMaker > 5.12

Platforms Windows, Mac (not same functions) Unix, Mac, Windows

User interface Flexible and mostly intuitive, adaptable Sometimes clumsy due to platform independ-
ence

Template New document is copy; template can be 
updated from document styles and mac-
ros. Name *.dot. Document can not be 
updated from template

New document is copy; updates docu-
ment at any time (various aspects of doc-
ument). Any FM document is a template.

Extensibility Powerful macro language (many syntax 
changes in early versions)

API client FrameScript and many other 
specific API clients

Book functions Master document (very unreliable); mas-
ter document = Σ all documents

Well thought out; little automatism miss-
ing

Outline view Full featured API client Enhance

Layout of pages First, even, odd; header and footer area, 
columns for body

Any number of master pages, even mixed 
orientation; any # of frames

Styles Paragraph, character Paragraph, character, table, lines

Side headings Anchored frames (very unreliable) Standard definitions

Tables Heading not repeated; sorting and calcu-
lations

Heading repeated on pages; sort (FM 
5.5); calculations by API clients and 
scripts

Variables Fields, global variables in master docu-
ment

System and user variables, may be for-
matted

Graphics (direct) Located in hidden layer, positioning unrelia-
ble

Features sufficient for technical docu-
ments

Anchored frames A very unreliable feature The name of the game

Import graphics and text Default: copy; paragraph and character 
formatting; update of references kills for-
matting

Default: reference; paragraph formatting; 
update keeps formatting (ref.)

Language Associated with paragraph or character for-
mat

Associated with paragraph or character for-
mat

Index At any location (field) Generated document, very flexible

Table Of Contents etc. At any location (field), arbitrary lists pos-
sible with some effort

Generated document, very flexible, arbi-
trary lists with same functionality
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Product history

You find a more or less complete history about the develop-
ment of FrameMaker on the author’s web site on 
www.daube.ch. 

FrameMaker time line

1985 20051995 20001990

Frame Technology founded by
Steve Kirsch, David Murray, Charles 
Corfield and Vickie Blakeslee

Frame Technology 
acquired by Adobe Inc.

1.
3

2.
0

3.
0

5.
0

5.
12

5.
5

6.
0

4.
0

5 475

employees (~ 1/3 on R/D)

2200

employees (~ 40 on FM R/D)

7.
0

FrameMaker and 
+SGML merged into 
one product

7.
1

2010

330

Unix versions

Mac OS (until 9.x)

Windows versions

SUN Solaris

only

1.
0

0.
6

7.
2

Adobe India becomes responsible for FrameMaker

http://www.daube.ch/docu/fmhist00.html
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File names
document.fm standard document name

document.fm.lck File of length 0 to lock additional open.

document.auto.fm autosave copy  File > Preferences

document.backup.fmbackup copy (before new edit starts)

document.emg.fm emergency copy (some crashes)

documentxxx.fm generated file (for suffixes xxx see below)

document.book generated book started with «document»

document.mif Maker interchange format.

Name suffixes The following suffixes are default

Note: The defaults for the suffices (TOC, IX etc.) depend on the UI 
language. These can be changed when generating the files. 
However, names of building blocks (for example, for system 
variables) also depend on the UI language and can not be 
changed.

Temporary files On start of FrameMaker some files are created in the tempo-
rary directory (in Windows defined by the environment varia-
ble TMP), for example FRM9A.tmp. These are removed at close 
of FM.

Crash files If FrameMaker crashes with an error message, such as 

a dump file is created in the $FMHOME directory:

h:\adobe\framemaker\en\FrameLog_99.11.05_09.44.39.txt

In other crash cases additionally the temp files are copied to 
the $FMHOME directory, e.g. formulas.fm.2EB. You may need 
these to send them to Adobe for error tracking.

Type of document English German French

Table of contents TOC IVZ TDM

Index IX SIX IX

List of Figures, Tables LOF, LOT AVZ, TVZ LDF, LDT

List of paragraphs, (alphabetical) LOP (APL) EAL (AEAL) LDP (LAP)

List of Markers, (alphabetical) LOM (AML) ML (AML) LDM (LAM)

List of References (text insets, images, 
fonts, unresolved x-refs etc.)

LOR LR REF

Standard Index, Index of Authors, Sub-
jects, Markers, References

IX, AIX,
SIX, IOM, IOR

SIX, AIX, TIX, 
MIX, RIX

IX, IXA,
IXT, IDM,
IREF

list of formats/ index of formats LFT, IFT FL, FIX FOR, IFOR
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Document properties in MIF

View only documents

Any document can be locked for view only (no editing possi-
ble) with the command ESC, F, l, k. This lock is permanent 
and can not be unlocked, if the View Only statement is 
present in the MIF file of this document (see Lock document 
permanently on page 12).

Note: To be able to edit this document further, always keep the MIF 
version (text file) of the document to be able to remove the 
View Only statement.

Unlock document To unlock a view-only document, enter the sequence ESC, F, l, 
k

Unlocking of a permanently locked document is not possible.

Save as View Only With File > Save As … and selecting View Only x.x (*.fm) the 
file can be saved as viewable only without applying the ESC 
sequence.

Lock document permanently

The View Only MIF statements described in this section must 
appear in a Document statement. These statements have no 
effect in an unlocked (editable) document.

To disallow unlocking, open the MIF file and change the state-
ment found in the <Document section:

<DViewOnly No> to
<DViewOnly Yes> and add statement
<DViewOnlyNoOp 0xF00>

The file is locked when opened in FrameMaker. However, the 
document read from the disk by FrameMaker is still in text 
format and can therefore be unlocked by someone with write 
permissions to the MIF file by reversing the change.

Locked for everybody 1 Change the statement mentioned above to 
<DViewOnly No ><DViewOnlyNoOp \0xF00 >

2 open the edited MIF file in FrameMaker, and 

3 save the file in View Only format.

4 The following message appears: 
This file cannot be opened for editing after you save it in View-
Only format. Save a backup file in Normal (editable) format? 
Yes No Cancel

5 If you select Yes, the file is immediately locked and cannot 
be unlocked. The file is saved in binary format to disk, and 
cannot be restored to an editable state.

Warning: There is no procedure for unlocking such a document (even 
Adobe can not help in this case)! If the copy command is still 
available for a document the contents of the document can be 
pasted into another document.
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Document control statements

You can use MIF statements to change the appearance and 
behaviour of the document window in the following ways:

Statement overview

Sources Dan Emory: FrameMaker Palettes [pdf on the net, 1999]
http://www.faqs.org/faqs/frame/faq/part2/
MIF reference Setting View Only document options

Disable user actions You can disable specific commands in a View Only document. 
For example, a hypertext author might disable copy and print 
commands for sensitive documents.

To disable a command, you must supply the hex code, called 
an fcode, that internally represents that command in a Frame-
Maker product. For example, you can disable printing, copy-
ing, and unlocking the document by supplying the following 
statements:

<DViewOnlyNoOp 0x313> # Disable printing
<DViewOnlyNoOp 0x322> # Disable copying
<DViewOnlyNoOp 0xF00> # Disable unlocking the document

Warning: There is no procedure for unlocking such a document! If the 
copy command is still available for a document the contents of 
the document can be pasted into another document.

Statement Value a

a. Default for normal document is highlighted

Explanation

DViewOnly No document can be edited

Yes document is view only

DViewOnlyXRef GotoBehavior X-refs behave like gotolink

NotActive Disable hypertext in X-refs

OpenBehavior X-ref links behave like 
openlink

DViewOnlySelect Yes

UserOnly Disable highlighting 
destination link

No Disable selecting text

DViewOnlyWinBorders Yes Display scroll bars

No Suppress scroll bars

DViewOnlyWinMenubar Yes Display menu bar in Unix

No Suppress menu-bar display 
under Unix

DViewOnlyWinPopup Yes Allow popup hypertex cmd

No Disable popup hypertext cmd

DViewOnlyWinPalette No file behaves as document

Yes file behaves as palette

DViewOnlyNoOp 0x313 Disable cutting or clearing

DViewOnlyNoOp 0x322 Disable copying

DViewOnlyNoOp 0xF00 Disable unlocking the 
document
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Document window menu 
bar

Suppress (No), Enable (Yes)

<DViewOnlyWinMenubar No>

This statement has no effect in the Macintosh and Windows 
version of a FrameMaker product because those versions have 
an application menu bar rather than a document window 
menu bar.

Display of scroll bars and 
border buttons

Suppress (No), Enable (Yes)

<DViewOnlyWinBorders No>

Selection in the document 
window

Suppress (No), Enable (Yes)

<DViewOnlySelect No>

You can normally select text and objects in a locked docu-
ment by Control-dragging in UNIX and Windows versions or 
by Command-dragging in Macintosh versions. Specifying 
<DViewOnlySelect No> prevents all selection in a locked docu-
ment.

Context menus Suppress (No), Enable (Yes)

<DViewOnlyWinPopup No>

This statement has no effect in Macintosh and Windows ver-
sions.

A document region pop-up menu is a menu activated by the 
right mouse button. For example, in UNIX versions of a Fram-
eMaker product, the Maker menu and Viewer menus can be 
accessed by pressing the right mouse button. If the DViewOn-
lyWinPopup statement has a value of No, the background 
menu does not appear when the right mouse button is 
pressed. 

Make window behave as 
palette

<DViewOnlyWinPalette Yes>

A palette window is a command window, such as the Equa-
tions palette, that exhibits special platform-dependent behav-
iour. In UNIX versions of FrameMaker products, a palette 
window can only be dismissed; it cannot be closed to an icon. 
In Macintosh versions, a palette always remains in front of 
the active window.

In Windows versions, a palette floats outside the main appli-
cation window and cannot be unlocked. To edit the palette, 
you need to reset the DViewOnlyWinPalette statement to No 
in the MIF file before opening it in a FrameMaker product.

Using active cross-
references

A locked document automatically has active cross-references. 
An active cross-reference behaves like a hypertext gotolink 
command; when the user clicks on a cross-reference, a Frame-
Maker product displays the link’s destination page. By 
default, the destination page is shown in the same document 
window as the link’s source.

Behaviour gotolink You can use MIF statements to turn off active cross-refer-
ences and to change the type of hypertext link that the cross-
reference emulates. (By default, cross-references emulate the 
gotolink behaviour.)
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Behaviour openlink To make cross-references emulate the openlink command, 
which displays the destination page in a new document win-
dow, use the following statement:

<DViewOnlyXRef OpenBehavior>

Use this setting to allow users to see both the source page 
and the destination page.

Disable active cross-
references

To turn off active cross-references, use the following state-
ment:

<DViewOnlyXRef NotActive>

Control with 
DViewOnlySelect

Use this setting to emulate the behaviour of FrameMaker ver-
sions < 6. You can use the DViewOnlySelect statement to con-
trol whether active cross-references highlight the marker 
associated with destination text.

Value Effect when clicking on a cross-reference

Yes Highlight the marker associated with the destination text.

UserOnly Default: No highlighting of the marker. However, the user can se-
lect text in the locked document.

No No highlighting of the marker. The user cannot select text in the 
locked document.
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FrameMaker principles and philosophy
FrameMaker development started in the UNIX environment, 
from which the following principles stem:

1 Keep it small and simple, but allow for easy aggregation.

In UNIX general purpose utilites can be ‹concatinated› via 
the standard input/output mechanism. 

2 Names are case sensitive. The roots of this is the C langue. 
Hence not only items in the file system, but also most 
object-names handled by a program are case sensitive.

Impact on FrameMaker

1 Object names (names of paragraph formats etc.) are case 
sensitive. A style name Body is not the same as body.

2 Various tasks are not handled in the core of FrameMaker 
but in separate processes:

- Tables

- Sorting of tables

- Formulas (Equations)

- SGML structure

As a result of this the integration in some cases is not as 
smooth as wanted by the user (e.g. table footnotes are han-
dled inependently of text footnotes).

3 Input to FrameMaker can be generated from other proc-
esses, hence the formatting process does not need user 
interaction or user judgement.

This requires that text features (e.g. TABs) can be handled 
without looking onto the screen. TABs are hence absolute, 
not relative as in text processing software.

4 No macro language is built into FrameMaker. But since the 
beginnings of FM automating was performed by processing 
the MIF form of files. For example, Data Base Publishing 
solutions generate MIF which is then formatted in FM.

In addition, since the beginnings the Frame Developer Kit 
was available to build plug-ins on the various platforms. 
Since about 1997 the script language FrameScript is availa-
ble, which allows scripts to do nearly the same as FDK pro-
gramming allows.

5 Since FrameMaker was ported to various platforms (UNIX  
Mac  Windows) there was need for a common ground in 
the user interface. Also hardware (cpu, RAM, screen) was 
expensive in the beginning. Hence FM does not waste 
resources and on the other side has not a tweaked GUI.

6 FM has no ‹hidden itenlligence› as some laargely used pro-
grams. It does not work automatically in the background. 
You need to start such processes as updating the page 
numbering or define TAB positions explicitly.

7 Also FM has bugs although it belongs to the class of very 
stable programs.
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